sgMap Object: 메인 페이지

sgMap Object 2.6
응용 개발자를 위한 sgMap Object 한글 매뉴얼
  • 메인 페이지
  • 네임스페이스
  • 클래스

♣ 제품명

    sgObject

♣ 소개

    본 매뉴얼은 sgObject 엔진을 이용하여 다양한 GIS application을 개발하고자 하는 응용 개발자를 위해 제작되었습니다.
    매뉴얼은 크게
    GIS 이론 및 제품 전반에 대해 안내해주는 [기본 매뉴얼:GIS 이론 및 제품 소개편]과
    엔진의 기본 기능들을 쉽게 활용할 수 있도록 GUI 형태로 제공된 Mapper 툴에 대한 활용법 및 기능을 설명하는 [GUI 툴킷 매뉴얼:Mapper 구성 및 활용편],
    클라이언트 개발자를 위한 인터페이스 구성 및 활용 안내서인 [응용개발 매뉴얼:인터페이스 구성 및 활용편]
    Object(SDK)가 제공하는 개발자 인터페이스 리스트를 사전식으로 정리한 [API 레퍼런스 매뉴얼],
    DB 구축 및 서버 관리자를 위한 [운영 매뉴얼:서버 운영 및 관리편]
    으로 구성됩니다.

♣ 사용방법

    본 매뉴얼은 COM+ 응용 개발자를 위한 인터페이스와 클래스이며 다른 언어의 개발방법은 제공되는 샘플소스와 함께 아래와 같은 방식을 참고하시기 바랍니다.

    * C API(linux, iOS, MacOS 등) : 엔진과 함께 제공되는 include 디렉토리의 "sg_object.h" 파일을 include 합니다.
         함수명은 "OGR_ + 각 인터페이스 별 약자 + 메소드명" 입니다. (예: sgObject::IWidget::ReSize는 OGR_WG_ReSize으로 변경됨)
         중간이름은 각 인터페이스에 대한 설명을 참조하시기 바랍니다.
         속성의 [get, set]은 각 속성명 앞에 "Get", "Set"을 붙여 메소드와 동일하게 사용할 수 있습니다.

    * Java(SWT) : 엔진과 함께 제공되는 "sgObject.jar" 파일을 library 에 등록합니다.
    * Java(Android) : 엔진과 함께 제공되는 "sgObjectForAndroid.jar" 파일을 library 에 등록합니다.
         Package명은 각 인터페이스명의 첫글자 "I"를 제거한 후 "net.sgsrc.map.jni."을 붙여서 사용할 수 있습니다.
         SWT와 Android를 위해 제공되는 특별한 인터페이스는 각각 "net.sgsrc.map.swt.", "net.sgsrc.map.android."을 붙여서 사용합니다.
         속성의 [get, set]은 각 속성명 앞에 "Get", "Set"을 붙여 메소드와 동일하게 사용할 수 있습니다.

    * JavaScript(WebBrowser) : 엔진과 함께 제공되는 "sgObject.js" 파일과 "sgObjectConstants.js" 파일을 include 합니다.
         <script src='sgObject.js'></script>
         클래스명은 각 인터페이스명의 첫글자 "I"를 제거한 후 "sgobject." 을 붙여 사용할 수 있습니다.
         속성의 [get, set]은 각 속성명 앞에 "Get", "Set"을 붙여 메소드와 동일하게 사용할 수 있습니다.

♣ 컴포넌트 다이어그램

♣ 최초작성

    작성자 - doung.nosp@m.gidu.nosp@m.k@gma.nosp@m.il.c.nosp@m.om / 작성일자 - 2009/12/25

♣ 수정정보

    수정자 - doung.nosp@m.gidu.nosp@m.k@gma.nosp@m.il.c.nosp@m.om / 수정일자 - 2019/07/18

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 목록

  • 네임스페이스
  • 클래스
  • 네임스페이스 목록
  • 네임스페이스 멤버
네임스페이스 목록
다음은 모든 네임스페이스에 대한 목록입니다. (간략한 설명만을 보여줍니다) :
N sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject 모듈 참조

  • 네임스페이스 목록
  • 네임스페이스 멤버
클래스 | 타입정의 | 열거형 타입 | 함수
sgObject 모듈 참조

클래스

interface | _IApplicationControlEvents
어플리케이션 ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다. 더 자세히 ...
interface | _IFeatureCanvasEvents
FeatureCanvas에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다. 더 자세히 ...
interface | _IFeatureLayerEvents
FeatureLayer 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다. 더 자세히 ...
interface | _IGraphicCanvasEvents
GraphicCanvas 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다. 더 자세히 ...
interface | _ILocationSensorEvents
LocationSensor 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다. 더 자세히 ...
interface | _IMap2DControlEvents
Map2D ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다. 더 자세히 ...
interface | _IMap2DEvents
Map2D 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다. 더 자세히 ...
interface | _IMap3DControlEvents
Map3D ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다. 더 자세히 ...
interface | _IMap3DEvents
Map3D 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다. 더 자세히 ...
interface | _IMapARControlEvents
MapAR ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다. 더 자세히 ...
interface | _IMapAREvents
MapAR 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다. 더 자세히 ...
interface | _IMapEarthControlEvents
MapEarth ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다. 더 자세히 ...
interface | _IMapEarthEvents
MapEarth 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다. 더 자세히 ...
interface | _IMotionSensorEvents
MotionSensor 객체에 발생하는 이벤트 처리를 위한 인터페이스를 제공한다. 더 자세히 ...
interface | _IVideoSensorEvents
Camera 장치와 연결하여 Video 수신 기능을 행하는 VideoSensor 객체에 이벤트 처리를 위한 인터페이스를 제공한다. 더 자세히 ...
class | AggregateGraphic
class | Animator
Animator는 Graphic객체를 Animation하는 객체이다. 자세한 내용은 IAnimator 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | Annotation
Feature 객체의 주석 정보 (간단한 텍스트 정보)를 관리한다. 더 자세히 ...
class | AnnotationLabel
AnnotationLabel는 Feature 객체의 주석 텍스트를 관리하는 객체이다. 더 자세히 ...
class | Application
class | ApplicationControl
class | AttributeIndex
AttributeIndex 객체는 FeatureCollection 객체에 Spatial Indexing 기능을 제공하고, 이를 사용하여 빠른 공간 검색 (공간 연산을 통한 부분집합 검색) 기능을 FeatureCollection 객체에 제공한다. 더 자세히 ...
class | Chart
Chart 클래스. 자세한 내용은 IChart 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | CommonFactory
CommonFactory 클래스. 자세한 내용은 ICommonFactory 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | CoverageFactory
CoverageFactory 클래스. 자세한 내용은 ICoverageFactory 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | DefaultTransaction
DefaultTransaction 객체는 작업의 전체 세트가 동시에 롤백 또는 커밋 할 수있는 작업을 제공합니다. 더 자세히 ...
class | DisplayFactory
DisplayFactory 클래스. 자세한 내용은 IDisplayFactory 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | DockWidget
class | Feature
Feature 객체는 Object를 활용한 GIS 애플리케이션에서 실세계의 객체를 표현하는 기본 단위로 Feature 객체를 데이터베이스와 대응시키면 레코드 한 개와 대응된다. 더 자세히 ...
class | FeatureAttributeDescriptor
FeatureAttributeDescriptor 객체는 Feature 객체에 저장된 일반 (속성) 정보 필드 한 개의 구조를 설명하는 객체이다. (데이터 타입 등) 더 자세히 ...
class | FeatureAttributeTreeWidget
class | FeatureCanvas
FeatureCanvas는 화면에 표현할 수 있는 여러 개의 FeatureLayer가 저장된 객체로 Map2D 객체를 통해 FeatureCanvas에 있는 Feature들을 실제 모니터 화면에 표현한다. 더 자세히 ...
class | FeatureCollection
FeatureCollection은 같은 종류의 Feature 객체들의 집합을 관리하는 객체이다. 더 자세히 ...
class | FeatureLayer
GIS에서는 데이터를 화면에 표현하기 위해 관리할 때 보통 Layer의 개념을 도입해 객체 종류별 관리를 한다. 더 자세히 ...
class | FeatureQuery
FeatureQuery는 주어진 Query 조건에 맞는 Feature 객체를 선별하기 위한 기능을 FeatureCollection에 제공하는 객체이다. 더 자세히 ...
class | FeatureType
FeatureType은 Feature 객체가 어떤 타입인지를 나타내는 객체이다. 더 자세히 ...
class | FeatureTypeStyle
FeatureTypeStyle 클래스. 자세한 내용은 IFeatureTypeStyle 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | FeatureTypeStyleFactory
FeatureTypeStyleFactory는 FeatureStyle 객체 및 Symbolizer객체를 생성하는 객체이다. 더 자세히 ...
class | FeatureTypeStyleRule
FeatureTypeStyleRule 클래스. 자세한 내용은 IFeatureTypeStyleRule 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | Fill
자세한 설명은 IFill 설명을 참고한다. 더 자세히 ...
class | Font
자세한 설명은 IText 설명을 참고한다. 더 자세히 ...
class | Generator3D
Generator3D 인터페이스는 2D를 3D로 변환하기 위한 객체이다. 더 자세히 ...
class | GeographicTransform
GeographicTransform. 더 자세히 ...
class | GeometryCollection
GeometryCollection은 기하 객체 모델의 GeometryCollection을 나타내는 객체이다. 더 자세히 ...
class | GeometryFactory
GeometryFactory는 기하를 생성하는 기능을 제공하는 객체이다. 더 자세히 ...
class | GPDLayerSource
[업데이트 예정] 더 자세히 ...
class | Graph
Graph 클래스. 자세한 내용은 IGraph 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | GraphicArc
class | GraphicCanvas
class | GraphicIcon
class | GraphicLabel
class | GraphicLineString
class | GraphicPolygon
class | GraphicRectangle
class | GraphicScaledImage
class | GridColorRampStyle
GridColorRampStyle 클래스. 자세한 내용은 IGridColorRampStyle 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | GridCoverage
GridCoverage 클래스. 자세한 내용은 IGridCoverage 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | GridCoverageProcessor
GridCoverageProcessor 클래스. 자세한 내용은 IGridCoverageProcessor 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | GridGeneralizeOp
class | GridHydrologyOp
GridHydrologyOp 클래스. 자세한 내용은 IGridHydrologyOp 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | GridInterpolationOp
GridInterpolationOp 클래스. 자세한 내용은 IGridInterpolationOp 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | GridMathOp
GridMathOp 클래스. 자세한 내용은 IGridMathOp 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | GridMorphometryOp
GridMorphometryOp 클래스. 자세한 내용은 IGridMorphometryOp 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | GridPreprocessOp
GridPreprocessOp 클래스. 자세한 내용은 IGridPreprocessOp 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | GridSurfaceOp
GridSurfaceOp 클래스. 자세한 내용은 IGridSurfaceOp 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | GridVisibilityOp
GridVisibilityOp 클래스. 자세한 내용은 IGridVisibilityOp 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
interface | IAggregateGraphic
다수의 그래픽 객체의 집합 형태를 그래픽화 하여 표현하는 인터페이스를 제공한다. 더 자세히 ...
interface | IAnimator
그래픽 객체의 애니메이션 효과를 제공하는 인터페이스를 제공한다. 더 자세히 ...
interface | IAnnotation
Feature 객체의 주석 정보 (간단한 텍스트 정보)를 관리하는 주석 객체에 인터페이스를 제공한다. 더 자세히 ...
interface | IAnnotationLabel
Feature 객체의 주석 텍스트를 관리하는 라벨 객체에 인터페이스를 제공한다. 더 자세히 ...
interface | IApplication
어플리케이션 위젯(최상의 위젯)을 제어하는 인터페이스를 제공한다. 더 자세히 ...
interface | IApplicationControl
어플리케이션 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다. 더 자세히 ...
interface | IAttributeIndex
FeatureCollection 객체에 인덱싱 기능을 제공하는 AttributeIndex 객체의 인터페이스를 제공한다. 더 자세히 ...
interface | ICanvas
지도 객체의 최상위 인터페이스로 2D/3D/AR 등 하위 상속 객체가 존재하며 모든 지도 객체의 공통 인터페이스를 제공한다. 더 자세히 ...
interface | IChart
차트의 세부 속성을 설정하기 위한 인터페이스를 제공한다. 더 자세히 ...
interface | IColorModel
C API(linux, iOS, MacOS 등) : 중간이름 "GCM"를 덧붙여서 "OGR_GCM_"+메소드명으로 사용한다. 더 자세히 ...
interface | IColorRampList
시스템에 유일하게 존재하는 GridColorRampStyle 형태의 래스터 일괄 표현 규정 리스트를 정의한 인터페이스를 제공한다. 더 자세히 ...
interface | ICommonFactory
다양한 Factory객체 인터페이스를 생성할 수 있는 최상위 인터페이스를 제공한다. 더 자세히 ...
interface | ICoverage
커버리지에 접근할 수 있도록 해주는 인터페이스이다 더 자세히 ...
interface | ICoverageFactory
ICoverageFactory 인터페이스는 커버리지 관련된 객체를 생성하기 위하여 사용된다. 더 자세히 ...
interface | ICurve
기하 명세에 정의된 커브의 일반 속성과 그러한 속성에 접근하기 위한 인터페이스를 제공한다. 더 자세히 ...
interface | IDefaultTransaction
작업의 전체 세트가 동시에 롤백 또는 커밋 할 수있는 작업을 제공합니다. 더 자세히 ...
interface | IDisplayFactory
화면에 표현되는 지도와 관련된 객체를 생성하기 위한 인터페이스를 제공한다. 더 자세히 ...
interface | IDockWidget
도킹위젯을 제어하는 인터페이스를 제공한다. 더 자세히 ...
interface | IFeature
실세계의 객체를 표현하는 기본 단위인 Feature 객체의 인터페이스를 제공한다. 더 자세히 ...
interface | IFeatureAttributeDescriptor
Feature 객체의 필드(속성) 객체로 FeatureType 객체는 FeatureAttributeDescriptor 객체의 집합이다. 더 자세히 ...
interface | IFeatureAttributeTreeWidget
속성관리창을 제어하는 인터페이스를 제공한다. 더 자세히 ...
interface | IFeatureAttributeValidValue
C API(linux, iOS, MacOS 등) : 중간이름 "FAV"를 덧붙여서 "OGR_FAV_"+메소드명으로 사용한다. 더 자세히 ...
interface | IFeatureCanvas
화면에 표현할 수 있는 여러 개의 FeatureLayer가 저장된 객체로 Map2D 객체를 통해 FeatureCanvas에 있는 Feature들을 실제 모니터 화면에 표현한다. (Document/View 구조에서 FeatureCanvas는 Document, Canvas2D는 View에 해당한다) 더 자세히 ...
interface | IFeatureCollection
같은 종류의 Feature 객체들의 집합을 관리하는 FeatureCollection 객체의 인터페이스를 제공한다. 더 자세히 ...
interface | IFeatureLayer
FeatureLayer 객체의 인터페이스를 제공한다. 더 자세히 ...
interface | IFeatureQuery
주어진 쿼리 조건에 맞는 Feature 객체를 선별하기 위한 기능을 제공하는 인터페이스를 제공한다. 더 자세히 ...
interface | IFeatureStyleCollection
자주 사용하는 FeatureStyle 객체의 집합을 관리하기 위한 인터페이스를 제공한다. 더 자세히 ...
interface | IFeatureType
Feature 객체가 어떤 타입인지를 나타내는 FeatureType 객체의 인터페이스를 제공한다. 더 자세히 ...
interface | IFeatureTypeStyle
FeatureCollection내의 Feature에 대한 속성 및 공간 정보에 따른 표현 방법을 기술하기 위해 사용된다. 예) 주제도 더 자세히 ...
interface | IFeatureTypeStyleFactory
FeatureStyle의 생성 및 Symbolizer등 스타일 관련 객체를 생성하는 인터페이스를 제공한다. 더 자세히 ...
interface | IFeatureTypeStyleRule
FeatureTypeStyle의 규정을 정의하며 속성 및 스케일에 따른 표현 인터페이스를 제공한다. 더 자세히 ...
interface | IFill
Brush의 스타일을 표현하기 위한 인터페이스를 제공한다. 더 자세히 ...
interface | IFont
글꼴의 스타일을 표현하기 위한 인터페이스를 제공한다. 더 자세히 ...
interface | IGenerator3D
2D를 3D로 변환하기 위한 인터페이스를 제공한다. 더 자세히 ...
interface | IGeodeticSpatialReference
IGeodeticSpatialReference 인터페이스 더 자세히 ...
interface | IGeographicCoordinateSystem
IGeographicCoordinateSystem 인터페이스 더 자세히 ...
interface | IGeographicTransform
IGeographicTransform 인터페이스 더 자세히 ...
interface | IGeometry
기하 및 위치 정보(공간 좌표)를 갖는 기하의 기하 및 위치 정보 관리를 위한 인터페이스를 제공한다. 더 자세히 ...
interface | IGeometryCollection
기하 및 위치 정보(공간 좌표)를 갖는 기하가 기본 기하(Point, LineString, Polygon 등)로 표현할 수 없는 복잡한 기하 구조를 갖는 경우 이를 표현할 수 있도록 해주는 인터페이스를 제공한다. 더 자세히 ...
interface | IGeometryFactory
Well Known Binary 및 Well Known Text 데이터를 통해 IGeometry 인터페이스를 갖는 객체를 생성하기 위한 인터페이스를 제공한다. 더 자세히 ...
interface | IGPDLayerSource
[업데이트 예정] 더 자세히 ...
interface | IGraph
그래프의 세부 속성을 설정하기 위한 인터페이스를 제공한다. 더 자세히 ...
interface | IGraphic
그래픽 객체의 인터페이스를 제공한다. 더 자세히 ...
interface | IGraphicArc
호의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다. 더 자세히 ...
interface | IGraphicCanvas
실세계좌표를 기반으로 표현되는 지도객체와 달라 비축척 그래픽 객체에 기반한 객체로 단면도, 설계도와 같이 지리적 특성을 더 자세히 ...
interface | IGraphicIcon
아이콘의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다. 더 자세히 ...
interface | IGraphicLabel
텍스트의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다. 더 자세히 ...
interface | IGraphicLineString
라인의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다. 더 자세히 ...
interface | IGraphicPolygon
폴리곤 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다. 더 자세히 ...
interface | IGraphicRectangle
사각형의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다. 더 자세히 ...
interface | IGraphicScaledImage
입력된 스케일과 이미지로 그래픽 객체를 표현하는 인터페이스를 제공한다. 더 자세히 ...
interface | IGridAnalysis
interface | IGridColorRampItem
FeatureTypeStyleRule에서 상속된 객체로 GridTypeStyle의 Rule에 의해 정의되는 표현 색상에 대한 정보 및 더 자세히 ...
interface | IGridColorRampStyle
GridTypeStyle로 부터 상속된 래스터를 위한 래스터 표현 규정을 일괄 정의한 인터페이스를 제공한다. 더 자세히 ...
interface | IGridCoverage
IGridCoverage 인터페이스는 데이터 공급 업체와 그리드를 (래스터) 분석 및 처리 기능을 제공하는 소프트웨어 공급 업체에 의해 소프트웨어 구현 간의 상호 운용성을 허용 방법을 정의합니다. 더 자세히 ...
interface | IGridCoverageProcessor
IGridCoverageProcessor 인터페이스는 그리드 커버리지 값에 접근할 수 있도록 해준다. 더 자세히 ...
interface | IGridGeneralizeOp
IGridGeneralizeOp 인터페이스 더 자세히 ...
interface | IGridHydrologyOp
IGridHydrologyOp 인터페이스는 수문학(수로, 수문, 하천, 지하수 등) 등의 처리를 위한 그리드 커버리지 알고리즘 제어 인터페이스 더 자세히 ...
interface | IGridInterpolationOp
IGridInterpolationOp 인터페이스는 그리드 보간 처리를 위한 그리드 커버리지 알고리즘 제어 인터페이스 더 자세히 ...
interface | IGridMathOp
IGridMathOp 인터페이스는 산술연산 등의 처리를 위한 그리드 커버리지 알고리즘 제어 인터페이스 더 자세히 ...
interface | IGridMorphometryOp
IGridMorphometryOp 인터페이스는 영상의 형태를 활용한 분석 알고리즘 제어 인터페이스 더 자세히 ...
interface | IGridOperation
IGridOperation 인터페이스는 그리드 커버리지 처리 기능에 대한 정보를 제공한다. 더 자세히 ...
interface | IGridPreprocessOp
IGridPreprocessOp 인터페이스는 영상전처리를 위한 그리드 커버리지 알고리즘 제어 인터페이스 더 자세히 ...
interface | IGridSampleDimension
IGridSampleDimension 인터페이스는 각각의 커버리지 샘플 차원에 대한 정보를 담고 있다. 더 자세히 ...
interface | IGridSurfaceOp
IGridSurfaceOp 인터페이스 더 자세히 ...
interface | IGridTypeStyle
FeatureTypeStyle로 부터 상속된 래스터를 위한 래스터 표현 규정을 정의한 인터페이스를 제공한다. 더 자세히 ...
interface | IGridVisibilityOp
IGridVisibilityOp 인터페이스 더 자세히 ...
interface | IHalo
글꼴의 배경 스타일을 표현하기 위한 인터페이스를 제공한다. 더 자세히 ...
interface | IHistogram
IHistogram 인터페이스는 하나의 샘플차원의 그리드 값에 대한 히스토그램을 계산한다. 더 자세히 ...
interface | IImageSymbol
Feature 객체를 화면에 표시하기 위해 심볼이 필요할 수도 있는데 IImageSymbol 인터페이스는 이 중 이미지 타입의 심볼 정보를 관리하는 ImageSymbol 객체의 인터페이스를 제공한다. 더 자세히 ...
interface | IIndexMapWidget
인덱스지도창 위젯을 관리하는 인터페이스를 제공한다. 더 자세히 ...
interface | ILayer
레이어 객체 인테페이스를 제공한다. 더 자세히 ...
interface | ILayerSource
LayerSource 객체의 인터페이스를 제공한다. 더 자세히 ...
interface | ILayerSourceFactory
GIS 데이터를 갖고 있는 데이터소스로부터 데이터를 가져와 LayerSource를 생성하는 LayerSourceFactory 객체에 인터페이스를 제공한다. 더 자세히 ...
interface | ILayerTreeWidget
레이어제어 관리창을 제어하는 인터페이스를 제공한다. 더 자세히 ...
interface | ILinearRing
기하 명세에 정의된 LinearRing에 대한 일반적인 인터페이스를 제공한다. (현재는 프로퍼티 및 메소드가 없으나 LinearRing에 대한 프로퍼티 및 메소드 추가를 고려해 만들어 놓은 인터페이스이다) 더 자세히 ...
interface | ILineString
기하 명세에 정의된 LineString의 속성과 그 속성에 접근하는 인터페이스를 제공한다. 더 자세히 ...
interface | ILineSymbolizer
선 스타일의 표현하는 방법 및 속성을 기술한다. 더 자세히 ...
interface | ILocationSensor
위치 센서 장치와 연결하여 위치 정보 수신 및 기타 부수 자료의 집계하고 제공 인터페이스를 제공한다. 더 자세히 ...
interface | ILocationService
LBS의 주요 기능을 제공하는 인터페이스로 주소정보를 기반으로 해당위치의 Feature 객체를 검색하고,. 더 자세히 ...
class | ImageSymbol
ImageSymbol은 Raster Image 심볼을 관리하는 객체이다. 더 자세히 ...
interface | IMap2D
2D 지도를 관리하는 객체로 Canvas 객체로 부터 상속되었으며 사용자에게 지도를 표출하고 마우스 등 사용자 UI 인터페이스를 제공한다. 더 자세히 ...
interface | IMap2DControl
Map2D 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다. 더 자세히 ...
interface | IMap3D
Canvas객체로부터 상속된 Map3D 객체에 대한 인터페이스를 제공한다. 더 자세히 ...
interface | IMap3DCamera
3D 지도의 카메라를 제어하기 위한 인터페이스를 제공한다. 더 자세히 ...
interface | IMap3DControl
Map3D 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다. 더 자세히 ...
interface | IMap3DLight
3D 지도의 채광을 제어하기 위한 인터페이스를 제공한다. 더 자세히 ...
interface | IMapAR
Canvas객체로부터 상속받은 MapAR 객체에 대한 인터페이스를 제공한다. 더 자세히 ...
interface | IMapARControl
MapAR 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다. 더 자세히 ...
interface | IMapEarth
Canvas객체로부터 상속받은 MapEarth 객체에 대한 인터페이스를 제공한다. 더 자세히 ...
interface | IMapEarthControl
MapEarth 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다. 더 자세히 ...
interface | IMark
심볼의 스타일을 표현하기 위한 인터페이스를 제공한다. 더 자세히 ...
interface | IMessage
제품의 언어별 메시지 체계에 따라 입력된 메시지 정보 제공 인터페이스를 제공한다. 더 자세히 ...
interface | IMotionSensor
자이로스코프 장치와 연결하여 방향각, 기우러짐, 가속도 및 기타 부수 자료를 집계 제공하는 인터페이스를 제공한다. 더 자세히 ...
interface | IMultiCurve
기하명세의 MultiCurve에 대한 일반적인 인터페이스를 제공한다. (MultiCurve는 Curve가 여러 개 있는 것) 더 자세히 ...
interface | IMultiLineString
기하명세에 정의된 MultiLineString에 대한 일반적인 인터페이스를 제공한다. (MultiLineString은 LineString이 여러 개 있는 것) 더 자세히 ...
interface | IMultiPoint
기하 명세에 정의된 MultiPoint에 대한 일반적인 인터페이스를 제공한다. 더 자세히 ...
interface | IMultiPolygon
기하 명세에 정의된 MultiPolygon에 대한 일반적인 인터페이스를 제공한다. (MultiPolygon은 Polygon이 여러 개 있는 것) 더 자세히 ...
interface | IMultiSurface
Surface가 여러 개 있는 것으로, 기하명세의 MultiSurface에 대한 일반적인 인터페이스를 제공한다. 더 자세히 ...
class | IndexMapWidget
interface | INetworkCoverageAnalysis
INetworkCoverageAnalysis 인터페이스는 네트워크 연산을 위해 사용된다. 더 자세히 ...
interface | IParameter
IParameter 인터페이스 더 자세히 ...
interface | IParameterInfo
IParameterInfo 인터페이스 더 자세히 ...
interface | IParameters
IParameters 인터페이스 더 자세히 ...
interface | IPoint
기하 명세에 정의된 점에 대한 일반적인 인터페이스를 제공한다. 더 자세히 ...
interface | IPointSymbol
Feature 객체를 화면에 표시하기 위해 심볼이 필요할 수도 있는데 IPointSymbol 인터페이스는 이 중 벡터 타입의 심볼 정보를 관리하는 PointSymbol 객체의 인터페이스를 제공한다. 더 자세히 ...
interface | IPointSymbolizer
심볼의 스타일을 표현하는 방법 및 속성을 기술한다. 더 자세히 ...
interface | IPointZ
기하 명세에 정의된 Point를 3차원으로 확장하기 위한 인터페이스를 제공한다. 더 자세히 ...
interface | IPolygon
기하 명세에 정의된 Polygon에 대한 일반적인 인터페이스를 제공한다. 더 자세히 ...
interface | IPolygonSymbolizer
기하 내부 영역을 채우는 방법 및 속성을 기술한다. 더 자세히 ...
interface | IPrintLayoutItem
출력창의 아이템을 제어하는 인터페이스를 제공한다. 더 자세히 ...
interface | IPrintLayoutWidget
출력창을 제어하는 인터페이스를 제공한다. 더 자세히 ...
interface | IQueryCommand
전체 비지니스 작업에 포함된 하나의 작업(쿼리)을 의미한다. 더 자세히 ...
interface | IQueryCommands
전체 비지니스 작업에 포함된 하나의 작업(쿼리)들을 의미한다. 더 자세히 ...
interface | ISampleDimension
ISampleDimension 인터페이스는 각각의 커버리지 샘플 차원에 대한 정보를 담고 있다. 더 자세히 ...
interface | ISensor
모든 센서(위치, 방향, 속도 외)의 상위 인터페이스로 센서의 공통 인터페이스를 제공한다. 더 자세히 ...
interface | ISpatialOperator
기하에 다른 기하와의 공간연산 인터페이스를 제공한다. 더 자세히 ...
interface | ISpatialReference
ISpatialReference 인터페이스는 Geometry 객체가 참조하는 공간참조체계를 정의하는 인터페이스를 제공한다. 더 자세히 ...
interface | ISpatialReferenceFactory
ISpatialReferenceFactory 인터페이스 더 자세히 ...
interface | ISpatialReferenceInfo
ISpatialReferenceInfo 인터페이스 더 자세히 ...
interface | ISpatialRelation
기하에 적용되는 공간 관련성 연산자들을 정의한다. 더 자세히 ...
interface | ISpatialRelation2
기하가 다른 기하와 공간적으로 어떤 관계에 있는지 테스트할 수 있는 인터페이스를 제공한다. 더 자세히 ...
interface | IStroke
펜의 스타일을 표현하기 위한 인터페이스를 제공한다. 더 자세히 ...
interface | ISurface
기하 명세에 정의된 Surface에 대한 일반적인 인터페이스를 제공한다. 더 자세히 ...
interface | ISymbol
Feature 객체를 화면에 표시하기 위해 심볼이 필요할 수도 있는데 ISymbol 인터페이스는 심볼 정보를 관리하는 Symbol 객체의 인터페이스를 제공한다. 더 자세히 ...
interface | ISymbolizer
Feature 객체를 화면에 표시하기 위해 필요한 그래픽 속성 (선굵기, 색 등)을 관리하는 FeatureStyle 객체의 인터페이스를 제공한다. 더 자세히 ...
interface | ITabWidget
탭위젯 객체를 제어하는 인터페이스를 제공한다. 더 자세히 ...
interface | ITextSymbolizer
라벨의 텍스트 스타일을 표현하기 위해 사용한다. 더 자세히 ...
interface | IUserDefinedWidget
사용자 정의 UI 객체를 정의/표현하기 위한 공통 인터페이스를 제공한다. 더 자세히 ...
interface | IUtility
일반적이지 않은 다양한 부수적인 기능 인터페이스를 제공한다. 더 자세히 ...
interface | IVectorAnalysis
벡터 레이어에 있는 feature들을 이용해서 다양한 연산을 할 수 있도록 인터페이스를 제공합니다. 더 자세히 ...
interface | IVideo
비디오의 세부 속성을 설정하기 위한 인터페이스를 제공한다. 더 자세히 ...
interface | IVideoSensor
카메라 센서 및 동영상 서비스로 부터 영상 정보를 획득하고 표현하는 인터페이스를 제공한다. 더 자세히 ...
interface | IWidget
위젯 객체를 관리하기 위한 최상의 인터페이스를 제공한다. 더 자세히 ...
interface | IWks
기하에 Well Known Binary 표현과 Well Known Text 표현을 다루는 인터페이스를 제공한다. 더 자세히 ...
interface | IXMLDoc
XML파일을 관리, 분석 인터페이스를 제공한다. 더 자세히 ...
interface | IXMLElements
XMLDoc객체로부터 해석된 객체에 존재하는 다양한 정보 관리 인터페이스를 제공한다. 더 자세히 ...
class | Layer
GIS에서는 데이터를 화면에 표현하기위해 관리할 때 보통 Layer의 개념을 도입해 객체 종류별 관리를 한다. 더 자세히 ...
class | LayerSource
GIS에서는 데이터를 화면에 표현하기 위해 관리할 때 보통 Layer의 개념을 도입해 객체 종류별 관리를 한다. 더 자세히 ...
class | LayerSourceFactory
LayerSourceFactory는 GIS 데이터를 갖고 있는 데이터소스로부터 데이터를 가져와 LayerSource를 생성하는 객체이다. 더 자세히 ...
class | LayerTreeWidget
class | LinearRing
LinearRing은 기하 객체 모델의 LinearRing을 나타내는 객체이다. 더 자세히 ...
class | LineString
LineString은 기하 객체 모델의 LineString을 나타내는 객체이다. 더 자세히 ...
class | LocationSensor
LocationSensor은 GPS 장치와 연결하여 GPS 수신 기능을 행하는 객체이다. 자세한 내용은 ILocationSensor 에 대한 설명을 참고한다. 더 자세히 ...
class | LocationService
주소정보를 기반으로 해당위치의 Feature 객체를 검색하고, 관리하는 기능과 POI 기능을 제공하는 객체이다. 자세한 내용은 ILocationService 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | Map2D
Map2D 클래스는 FeatureCanvas 객체와 연동하여 Feature들의 Geometry 및 주석 정보를 화면에 그리고 화면으로부터 사용자 입력을 받는 등 실제 화면 제어를 담당하는 객체이다. 더 자세히 ...
class | Map2DControl
class | Map3D
Map3D 클래스는 FeatureCanvas 객체와 연동하여 Feature들의 Geometry 및 주석 정보를 화면에 그리고 화면으로부터 사용자 입력을 받는 등 실제 화면 제어를 담당하는 객체이다. 자세한 내용은 IMap3D 에 대한 설명을 참고한다. 더 자세히 ...
class | Map3DControl
class | MapAR
MapAR 클래스는 FeatureCanvas 객체와 연동하여 Feature들의 Geometry 및 주석 정보를 화면에 그리고 화면으로부터 사용자 입력을 받는 등 실제 화면 제어를 담당하는 객체이다. 자세한 내용은 IMapAR 에 대한 설명을 참고한다. 더 자세히 ...
class | MapARControl
class | MapEarth
MapEarth 클래스는 FeatureCanvas 객체와 연동하여 Feature들의 Geometry 및 주석 정보를 화면에 그리고 화면으로부터 사용자 입력을 받는 등 실제 화면 제어를 담당하는 객체이다. 자세한 내용은 IMapEarth 에 대한 설명을 참고한다. 더 자세히 ...
class | MapEarthControl
class | Mark
자세한 설명은 IMark 설명을 참고한다. 더 자세히 ...
class | Message
Message는 메시지파일에 따른 메시지를 출력하는 객체이다. 자세한 내용은 IMessage 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | MotionSensor
MotionSensor은 Gyroscope 장치와 연결하여 Motion 수신 기능을 행하는 객체이다. 자세한 내용은 IMotionSensor 에 대한 설명을 참고한다. 더 자세히 ...
class | MultiLineString
MultiLineString은 기하 객체 모델의 MultiLineString을 나타내는 객체이다. 더 자세히 ...
class | MultiPoint
MultiPoint는 기하 객체 모델의 MultiPoint를 나타내는 객체이다. 더 자세히 ...
class | MultiPolygon
MultiPolygon은 기하 객체 모델의 MultiPolygon을 나타내는 객체이다. 더 자세히 ...
class | NetworkCoverageAnalysis
NetworkCoverageAnalysis 클래스. 자세한 내용은 INetworkCoverageAnalysis 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | Parameter
Parameter. 더 자세히 ...
class | ParameterInfo
ParameterInfo. 더 자세히 ...
class | Parameters
Parameters. 더 자세히 ...
class | Point
Point는 기하 객체 모델의 Point를 나타내는 객체이다. 더 자세히 ...
class | PointSymbol
PointSymbol은 Vector로 그려진 심볼을 관리하는 객체이다. 더 자세히 ...
class | Polygon
Polygon은 기하 객체 모델의 Polygon을 나타내는 객체이다. 더 자세히 ...
class | QueryCommand
자세한 설명은 IQueryCommand 설명을 참고한다. 더 자세히 ...
class | QueryCommands
자세한 설명은 IQueryCommands 설명을 참고한다. 더 자세히 ...
class | SpatialReference
SpatialReference는 Geometry 객체가 참조하는 공간참조체계를 정의하는 객체이다. 더 자세히 ...
class | SpatialReferenceFactory
SpatialReferenceFactory. 더 자세히 ...
class | Stroke
자세한 설명은 IStroke 설명을 참고한다. 더 자세히 ...
class | Symbolizer
자세한 설명은 ISymbolizer 설명을 참고한다. 더 자세히 ...
class | TabWidget
class | UserDefinedWidget
UserDefinedWidget 클래스. 자세한 내용은 IUserDefinedWidget 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | Utility
Utility는 여러가지 부수적인 기능을 제공하는 객체이다. 자세한 내용은 IUtility 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | Video
Video 클래스. 자세한 내용은 IVideo 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | VideoSensor
VideoSensor은 Camera 장치와 연결하여 Video 수신 기능을 행하는 객체이다. 자세한 내용은 IVideoSensor 에 대한 설명을 참고한다. 더 자세히 ...
class | XMLDoc
XMLDoc 클래스. 자세한 내용은 IXMLDoc 인터페이스에 대한 설명을 참고한다. 더 자세히 ...
class | XMLElements
XMLElements 클래스. 자세한 내용은 IXMLElements 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

타입정의

typedef enum sgObject::DiagramTypeEnum | DiagramTypeEnum
다이어그램 종류 더 자세히 ...
typedef enum sgObject::GraphTypeEnum | GraphTypeEnum
그래프 종류 더 자세히 ...
typedef enum sgObject::VolumeTypeEnum | VolumeTypeEnum
체적 위치 종류 더 자세히 ...
typedef enum sgObject::GridColorTypeEnum | GridColorTypeEnum
래스터 색상 선정 알고리 종류 더 자세히 ...
typedef enum sgObject::FeatureTypeStyleEnum | FeatureTypeStyleEnum
채색 방법 더 자세히 ...
typedef enum sgObject::SymbolizerTypeEnum | SymbolizerTypeEnum
그래픽 표식 종류 더 자세히 ...
typedef enum sgObject::SystemResourceEnum | SystemResourceEnum
시스템 내부 리소스 종류 더 자세히 ...
typedef enum sgObject::SystemKeyEnum | SystemKeyEnum
시스템 키보드 키 종류 더 자세히 ...
typedef enum sgObject::SensorTypeEnum | SensorTypeEnum
센서 종류 더 자세히 ...
typedef enum sgObject::LocationSensorTypeEnum | LocationSensorTypeEnum
위치 센서 종류 더 자세히 ...
typedef enum sgObject::ParameterType | ParameterType
typedef enum sgObject::TransactionEnum | TransactionEnum
트랜잭션 종류 더 자세히 ...
typedef enum sgObject::WebServiceTypeEnum | WebServiceTypeEnum
웹서비스 지도 유형 더 자세히 ...
typedef enum sgObject::ScreenModeEnum | ScreenModeEnum
화면의 현재 동작 모드 더 자세히 ...
typedef enum sgObject::SnapModeEnum | SnapModeEnum
Map2D에서 마우스로 공간 객체를 그려서 생성하거나 이동, 변경시 좌표의 입력을 도와주는 기능으로 마우스의 위치를 기준으로 관련된 공간 객체의 주요 부분에 표시하고 해당 좌표 정보를 활용할 수 있도록 하는 기능(이하, 스냅) 더 자세히 ...
typedef enum sgObject::CursorEnum | CursorEnum
마우스 커서 종류 더 자세히 ...
typedef enum sgObject::GeometryTypeEnum | GeometryTypeEnum
공간 객체의 구체적인 종류 더 자세히 ...
typedef enum sgObject::HitObjectTypeEnum | HitObjectTypeEnum
검색(hitting) 객체의 종류 더 자세히 ...
typedef enum sgObject::LabelTypeEnum | LabelTypeEnum
주석 종류 더 자세히 ...
typedef enum sgObject::LabelPositionTypeEnum | LabelPositionTypeEnum
속성주석 위치 종류 더 자세히 ...
typedef enum sgObject::SpatialOperatorEnum | SpatialOperatorEnum
공간연산 종류 더 자세히 ...
typedef enum sgObject::MapRotateEnum | MapRotateEnum
위치센서로부터 위치가 이동하는 경우 이동 방향으로 Map2D 화면의 자동회전 여부 더 자세히 ...
typedef enum sgObject::MapMoveEnum | MapMoveEnum
위치센서로부터 위치가 이동되고 있는 경우 지도 화면의 자동 이동 여부 더 자세히 ...
typedef enum sgObject::LineCapEnum | LineCapEnum
다각선의 시작, 끝점의 모양 더 자세히 ...
typedef enum sgObject::LineJoinEnum | LineJoinEnum
선과 선이 만나는 지점의 모양 더 자세히 ...
typedef enum sgObject::FileFormatEnum | FileFormatEnum
자주 사용되는 공간 자료의 저장 종류(포맷) 더 자세히 ...
typedef enum sgObject::SymbolTypeEnum | SymbolTypeEnum
점 표현의 구체적인 종류 더 자세히 ...
typedef enum sgObject::EditedTypeEnum | EditedTypeEnum
편집 종류 더 자세히 ...
typedef enum sgObject::SpatialDataTypeEnum | SpatialDataTypeEnum
데이터베이스에 저장된 공간데이터 유형 더 자세히 ...
typedef enum sgObject::WebServerTypeEnum | WebServerTypeEnum
지도 OpenAPI 서버 종류 더 자세히 ...
typedef enum sgObject::TopoSyncMoveEnum | TopoSyncMoveEnum
공간객체의 노드/버텍스 편집에 따른 주변 연결된 공간객체의 동시 이동 조건 종류 더 자세히 ...
typedef enum sgObject::AlignPositionEnum | AlignPositionEnum
위치 정렬 종류(3행3열) 더 자세히 ...
typedef enum sgObject::ChartTypeEnum | ChartTypeEnum
차트 종류 더 자세히 ...
typedef enum sgObject::Draw3DTypeEnum | Draw3DTypeEnum
3D 공간 객체 종류 더 자세히 ...
typedef enum sgObject::MouseButtonTypeEnum | MouseButtonTypeEnum
마우스 버튼 종류 더 자세히 ...
typedef enum sgObject::TransitionModeEnum | TransitionModeEnum
애니매이션 알고리즘 종류 더 자세히 ...
typedef enum sgObject::TimingModeEnum | TimingModeEnum
애니메이션 시간 종류 더 자세히 ...
typedef enum sgObject::RepeatModeEnum | RepeatModeEnum
애니메이션 반복 종류 더 자세히 ...
typedef enum sgObject::PointLocationEnum | PointLocationEnum
공간객체 내 점의 종류 더 자세히 ...
typedef enum sgObject::SampleDimensionTypeEnum | SampleDimensionTypeEnum
다양한 커버리지 자료형. 그리드 커버리지의 경우 밴드 자료형 더 자세히 ...
typedef enum sgObject::ColorInterpretationEnum | ColorInterpretationEnum
밴드가 어떤 컬러 모델 성분에 해당되는지를 나타낸다. 더 자세히 ...
typedef enum sgObject::PaletteInterpretationEnum | PaletteInterpretationEnum
커버리지 컬러 팔레트로 정수값을 가지는 커버리지에 대해서만 컬러팔레트 정보가 유효함 더 자세히 ...
typedef enum sgObject::SightModeEnum | SightModeEnum
3차원 가시권 분석 종류 더 자세히 ...
typedef enum sgObject::VariantTypeEnum | VariantTypeEnum
파라메터 자료형 타입 종류 더 자세히 ...
typedef enum sgObject::FilterTypeEnum | FilterTypeEnum
래스터 효과처리 타입 종류 더 자세히 ...
typedef enum sgObject::AccessModeEnum | AccessModeEnum
드라이버 접근 모드 더 자세히 ...
typedef enum sgObject::SystemSymbolEnum | SystemSymbolEnum
시스템 심볼 더 자세히 ...
typedef int | OGRErr

열거형 타입

enum | Camera3DModeEnum { sgCM3_Focal = 0, sgCM3_Eye }
3D 카메라 시선 이동 종류 더 자세히 ...
enum | LayerType3DEnum { sgLT3_Default = 0, sgLT3_Terrain, sgLT3_Mask, sgLT3_Model, sgLT3_Image, sgLT3_Elevation }
3D 레이어의 종류 더 자세히 ...
enum | TapPositionEnum { sgTP_North = 0, sgTP_South, sgTP_West, sgTP_East }
탭 GUI 객체의 Tap 위치 종류 더 자세히 ...
enum | DockAreaEnum { sgDA_No = 0, sgDA_Left = 0x1, sgDA_Right = 0x2, sgDA_Top = 0x4, sgDA_Bottom = 0x8, sgDA_Central = 0x10, sgDA_All = 0xf }
도킹 GUI 객체의 도킹 위치 종류 더 자세히 ...
enum | DockFeatureEnum { sgDF_NoFeatures = 0x00, sgDF_Closable = 0x01, sgDF_Movable = 0x02, sgDF_Floatable = 0x04, sgDF_VerticalTitleBar = 0x08, sgDF_FeatureMask = 0x0f, sgDF_AllFeature = sgDF_Closable | sgDF_Movable | sgDF_Floatable, sgDF_Reserved = 0xff }
도킹 GUI 객체의 스타일 종류 더 자세히 ...
enum | CanvasTypeEnum { sgCT_NULL = 0, sgCT_2D, sgCT_GRAPHIC, sgCT_3D, sgCT_EARTH, sgCT_AR }
캔버스 객체 종류 더 자세히 ...
enum ToolBarTypeEnum {
sgTB_MapDiz = 0, sgTB_MapNav, sgTB_MapSelect, sgTB_MapMeasure, sgTB_Edit, sgTB_EditVertex, sgTB_View, sgTB_LayerAdd,
sgTB_VectorGeomProcess, sgTB_VectorProcess, sgTB_RasterProcess, sgTB_SnapProperties, sgTB_PrintFile, sgTB_PrintExport, sgTB_PrintView, sgTB_PrintLayout,
sgTB_PrintItem, sgTB_End
}
툴바 객체 종류 더 자세히 ...
enum | EditActionTypeEnum { sgAC_Point = 0, sgAC_Line, sgAC_Free, sgAC_Circle, sgAC_Rectangle, sgAC_Polygon, sgAC_End }
입력 툴바 객체 내 입력 객체 종류 더 자세히 ...
enum NetworkAlgorithmEnum {
sgNA_NULL = 0, sgNA_Bellman_ford, sgNA_Bfs, sgNA_Bid_dijkstra, sgNA_Dfs, sgNA_Dijkstra, sgNA_Fm_partition, sgNA_Maxflow_ff,
sgNA_Maxflow_pp, sgNA_Maxflow_sap, sgNA_Min_tree, sgNA_Planarity, sgNA_Ratio_cut_partition, sgNA_St_number
}
네트워크 분석 알고리즘 종류 더 자세히 ...
enum | DiagramTypeEnum { sgRT_Chart = 0x0001, sgRT_Graph = 0x0002, sgRT_UserDefine = 0x0004 }
다이어그램 종류 더 자세히 ...
enum | GraphTypeEnum { sgGT_dot = 0x0001, sgGT_dotty = 0x0002, sgGT_lefty = 0x0003, sgGT_neato = 0x0004 }
그래프 종류 더 자세히 ...
enum | VolumeTypeEnum { sgVT_Above, sgVT_Below }
체적 위치 종류 더 자세히 ...
enum | GridColorTypeEnum { sgGC_Interpolated, sgGC_Discrete, sgGC_Exact }
래스터 색상 선정 알고리 종류 더 자세히 ...
enum | FeatureTypeStyleEnum { sgFS_Default = 0x0001, sgFS_GridRamp = 0x0002, sgFS_GridPseudo = 0x0003, sgFS_GridFreakOut = 0x0004, sgFS_GridDefault = 0x0005 }
채색 방법 더 자세히 ...
enum | SymbolizerTypeEnum { sgSL_Default = 0, sgSL_Line = 1, sgSL_Polygon = 2, sgSL_Point = 3, sgSL_Label = 4 }
그래픽 표식 종류 더 자세히 ...
enum SystemResourceEnum {
sgRS_StartBuffer = 512, sgRS_Default = 0x0000, sgRS_Logo = 0x0001, sgRS_Location = 0x0002, sgRS_Compass = 0x0004, sgRS_ScaleBar = 0x0008, sgRS_Scale = 0x0080, sgRS_IndexMapWidget = 0x0010,
sgRS_MapCtrlWidget = 0x0020, sgRS_ZoomLevelWidget = 0x0040, sgRS_MotionBtn = 0x0100, sgRS_LocationBtn = 0x0200
}
시스템 내부 리소스 종류 더 자세히 ...
enum SystemKeyEnum {
sgSK_NONE, sgSK_LeftSoftKey, sgSK_RightSoftKey, sgSK_Home, sgSK_Back, sgSK_Send, sgSK_End, sgSK_0,
sgSK_1, sgSK_2, sgSK_3, sgSK_4, sgSK_5, sgSK_6, sgSK_7, sgSK_8,
sgSK_9, sgSK_Star, sgSK_Hash, sgSK_Escape, sgSK_Delete, sgSK_Shift, sgSK_Control, sgSK_Up,
sgSK_Down, sgSK_Left, sgSK_Right, sgSK_Enter, sgSK_VolUp, sgSK_VolDown, sgSK_Power, sgSK_Camera,
sgSK_KeyCount
}
시스템 키보드 키 종류 더 자세히 ...
enum | SensorTypeEnum { sgSR_Location = 0, sgSR_Motion, sgSR_Video }
센서 종류 더 자세히 ...
enum | LocationSensorTypeEnum { sgLSR_Unknown = 0, sgLSR_NMEA, sgLSR_RTK }
위치 센서 종류 더 자세히 ...
enum | ParameterType { sgPT_IntegerType =0, sgPT_FloatingPointType, sgPT_StringType, sgPT_GridCoverageType, sgPT_FeatureCollectionType }
enum | TransactionEnum { sgTN_AutoCommit = 0, sgTN_ManualCommit = 1, sgTN_UnBind = 2 }
트랜잭션 종류 더 자세히 ...
enum | WebServiceTypeEnum { sgWS_Default = 0, sgWS_OpenAPI = 1, sgWS_WMS = 4, sgWS_WFS = 5, sgWS_GWFS = 6, sgWS_LTM = 7 }
웹서비스 지도 유형 더 자세히 ...
enum ScreenModeEnum {
sgSM_StartBuffer = 1024, sgSM_NullMode = 0, sgSM_SelectMode = 1, sgSM_SelectPolylineMode = 3, sgSM_SelectPolygonMode = 4, sgSM_SelectGeometryMode = 5, sgSM_SelectCircleMode = 6, sgSM_SelectKeepCircleMode = 7,
sgSM_ZoomInMode = 11, sgSM_ZoomInAreaMode = 12, sgSM_ZoomOutMode = 13, sgSM_ZoomOutAreaMode = 14, sgSM_PanningMode = 15, sgSM_InsertSymbolMode = 21, sgSM_InsertTextMode = 23, sgSM_InsertPolylineMode = 24,
sgSM_InsertPolygonMode = 25, sgSM_InsertCircleMode = 26, sgSM_InsertFreelineMode = 27, sgSM_InsertRectangleMode = 28, sgSM_InsertRingMode = 29, sgSM_DistanceMode = 32, sgSM_AreaMode = 33, sgSM_SingPostMode = 34,
sgSM_EditVertexMoveMode = 41, sgSM_EditVertexDeleteMode = 42, sgSM_EditVertexAddMode = 43, sgSM_EditMoveMode = 44, sgSM_EditDeleteMode = 45, sgSM_EditCopyMode = 46, sgSM_EditRotateMode = 47, sgSM_EditExtendMode = 48,
sgSM_EditTrimMode = 49, sgSM_EditScaleMode = 51, sgSM_EditBreakMode = 52, sgSM_EditBreakGeometryMode = 53, sgSM_EditDeleteRingMode = 54, sgSM_VolumeMode = 55, sgSM_TerrainProfileMode = 56, sgSM_SightMode = 57,
sgSM_PointGridMode = 58, sgSM_End = 59, sgSM_AnnotationMove = 101, sgSM_AutoPanningMode = 102, sgSM_AnnotationRotate = 103, sgSM_AnnotationEndMove = 104
}
화면의 현재 동작 모드 더 자세히 ...
enum SnapModeEnum {
sgNM_NullPoint = 0x0000, sgNM_NodePoint = 0x0001, sgNM_VertPoint = 0x0002, sgNM_EndPoint = sgNM_NodePoint | sgNM_VertPoint, sgNM_MidPoint = 0x0004, sgNM_NearestPoint = 0x0008, sgNM_IntersectPoint = 0x0010, sgNM_PerpendicularPoint = 0x0020,
sgNM_OrthoPoint = 0x0040, sgNM_ExtensionPoint = 0x0080, sgNM_CenterPoint = 0x0100, sgNM_ScalePoint = 0x0200, sgNM_RotatePoint = 0x0400, sgNM_GPSPoint = 0x0800, sgNM_Geometry = sgNM_EndPoint | sgNM_MidPoint | sgNM_NearestPoint | sgNM_IntersectPoint | sgNM_PerpendicularPoint | sgNM_OrthoPoint | sgNM_ExtensionPoint, sgNM_END = 0x0800
}
Map2D에서 마우스로 공간 객체를 그려서 생성하거나 이동, 변경시 좌표의 입력을 도와주는 기능으로 마우스의 위치를 기준으로 관련된 공간 객체의 주요 부분에 표시하고 해당 좌표 정보를 활용할 수 있도록 하는 기능(이하, 스냅) 더 자세히 ...
enum CursorEnum {
sgCS_Null = 0, sgCS_VertexMove = 1, sgCS_VertexDelete = 2, sgCS_VertexAdd = 3, sgCS_AnnoRotate = 4, sgCS_AnnoEndMove = 5, sgCS_AnnoMove = 6, sgCS_MapZoomIn = 7,
sgCS_MapZoomOut = 8, sgCS_MapZoomPan = 9, sgCS_MapInsert = 10, sgCS_MapSelectObject = 11, sgCS_EditTrim = 12, sgCS_EditExtend = 13, sgCS_EditBreak = 14, sgCS_End = 15
}
마우스 커서 종류 더 자세히 ...
enum GeometryTypeEnum {
sgGT_Unknown = 0, sgGT_Point = 1, sgGT_LineString = 2, sgGT_Polygon = 3, sgGT_MultiPoint = 4, sgGT_MultiLineString = 5, sgGT_MultiPolygon = 6, sgGT_GeometryCollection = 7,
sgGT_None = 100, sgGT_LinearRing = 101, sgGT_Point25D = 0x80000001, sgGT_LineString25D = 0x80000002, sgGT_Polygon25D = 0x80000003, sgGT_MultiPoint25D = 0x80000004, sgGT_MultiLineString25D = 0x80000005, sgGT_MultiPolygon25D = 0x80000006,
sgGT_GeometryCollection25D = 0x80000007
}
공간 객체의 구체적인 종류 더 자세히 ...
enum | HitObjectTypeEnum { sgHT_Unknown = 0, sgHT_All = 15, sgHT_Geometry = 0x01, sgHT_AnnoLine = 0x02, sgHT_AnnoLabel = 0x04, sgHT_AttrLabel = 0x08 }
검색(hitting) 객체의 종류 더 자세히 ...
enum | LabelTypeEnum { sgLT_SymbolLabel = sgHT_Geometry, sgLT_TipLabel = 0x02, sgLT_AttrLabel = sgHT_AttrLabel, sgLT_AttrShortLabel = 0x10, sgLT_AnnoLabel = sgHT_AnnoLabel }
주석 종류 더 자세히 ...
enum | LabelPositionTypeEnum { sgLP_GeoMBRCenter, sgLP_GeoMapInterMBRCenter, sgLP_GeoFirstCenter, sgLP_GeoFirstPointOnSurface }
속성주석 위치 종류 더 자세히 ...
enum | SpatialOperatorEnum { sgSO_Intersects = 0, sgSO_Equals = 1, sgSO_Disjoint = 2, sgSO_Touches = 3, sgSO_Crosses = 4, sgSO_Within = 5, sgSO_Contains = 6, sgSO_Overlaps = 7 }
공간연산 종류 더 자세히 ...
enum | MapRotateEnum { sgME_FixRotate = 0, sgME_AutoRotate = 1 }
위치센서로부터 위치가 이동하는 경우 이동 방향으로 Map2D 화면의 자동회전 여부 더 자세히 ...
enum | MapMoveEnum { sgMM_ManuMove = 0, sgMM_AutoMove = 1, sgMM_OneOnlyMove = 2 }
위치센서로부터 위치가 이동되고 있는 경우 지도 화면의 자동 이동 여부 더 자세히 ...
enum LineCapEnum {
sgLC_Flat = 0, sgLC_Square = 1, sgLC_Round = 2, sgLC_Triangle = 3, sgLC_NoAnchor = 0x10, sgLC_SquareAnchor = 0x11, sgLC_RoundAnchor = 0x12, sgLC_DiamondAnchor = 0x13,
sgLC_ArrowAnchor = 0x14, sgLC_ArrowAnchor1 = 0x15, sgLC_ArrowAnchor2 = 0x16, sgLC_Custom = 0xff, sgLC_AnchorMask = 0xf0
}
다각선의 시작, 끝점의 모양 더 자세히 ...
enum | LineJoinEnum { sgLJ_Round = 1, sgLJ_Mitre = 2, sgLJ_Bevel = 3 }
선과 선이 만나는 지점의 모양 더 자세히 ...
enum FileFormatEnum {
sgFF_IMG_BMP = 1, sgFF_IMG_GIF = 2, sgFF_IMG_JPG = 3, sgFF_IMG_PNG = 4, sgFF_IMG_TIF = 5, sgFF_IMG_UNKNOWN = 10, sgFF_GIS_SHP = 11, sgFF_GIS_DXF = 12,
sgFF_GIS_DWG = 13, sgFF_GIS_DGN = 14, sgFF_GIS_KML = 15, sgFF_GIS_GML = 16, sgFF_GIS_TAB = 17, sgFF_GIS_GEOJSON = 18, sgFF_GIS_GPX = 19, sgFF_GIS_S57 = 21,
sgFF_GIS_CSV = 22, sgFF_DB_ORACLE = 31, sgFF_DB_DB2, sgFF_DB_INFORMIX, sgFF_DB_SQLSERVER, sgFF_DB_MYSQL, sgFF_DB_POSTGIS, sgFF_DB_Altibase,
sgFF_DB_Tibero, sgFF_DB_ZEUS, sgFF_DB_Kairos, sgFF_DB_CUBRID, sgFF_DB_RDBMS
}
자주 사용되는 공간 자료의 저장 종류(포맷) 더 자세히 ...
enum | SymbolTypeEnum { sgST_Unknown = 0, sgST_Vector = 51, sgST_Image = 52 }
점 표현의 구체적인 종류 더 자세히 ...
enum | EditedTypeEnum { sgET_Null = 0, sgET_Insert = 1, sgET_Delete = 2, sgET_Update = 3 }
편집 종류 더 자세히 ...
enum | SpatialDataTypeEnum { sgSD_SpatialDBBlob = 1, sgSD_WKB, sgSD_WKT, sgSD_ArcSDE, sgSD_Geomedia, sgSD_Smallworld }
데이터베이스에 저장된 공간데이터 유형 더 자세히 ...
enum WebServerTypeEnum {
sgOA_GOOGLEMAP = 1, sgOA_YAHOOMAP = 2, sgOA_BINGMAP = 3, sgOA_VWORLD_2D = 4, sgOA_VWORLD_3D = 5, sgOA_NAVERMAP = 6, sgOA_DAUMMAP = 7, sgOA_KTMAP = 8,
sgOA_AGS = 9, sgOA_TMS = 10
}
지도 OpenAPI 서버 종류 더 자세히 ...
enum TopoSyncMoveEnum {
sgTS_None = 0x000, sgTS_Symbol2Symbol = 0x001, sgTS_Symbol2Node = 0x002, sgTS_Symbol2Vertex = 0x004, sgTS_Node2Symbol = 0x008, sgTS_Node2Node = 0x010, sgTS_Node2Vertex = 0x020, sgTS_Vertex2Symbol = 0x040,
sgTS_Vertex2Node = 0x080, sgTS_Vertex2Vertex = 0x100, sgTS_ComplexSymbolVertexStand = 0x1b7
}
공간객체의 노드/버텍스 편집에 따른 주변 연결된 공간객체의 동시 이동 조건 종류 더 자세히 ...
enum AlignPositionEnum {
sgAP_None = 0, sgAP_TopLeft = 1, sgAP_TopCenter, sgAP_TopRight, sgAP_CenterLeft, sgAP_CenterCenter, sgAP_CenterRight, sgAP_BottomLeft,
sgAP_BottomCenter, sgAP_BottomRight
}
위치 정렬 종류(3행3열) 더 자세히 ...
enum ChartTypeEnum {
sgCT_LINE = 0, sgCT_AREA, sgCT_BAR, sgCT_FLOATINGBAR, sgCT_HILOCLOSE, sgCT_COMBO_LINE_BAR, sgCT_COMBO_HLC_BAR, sgCT_COMBO_LINE_AREA,
sgCT_COMBO_LINE_LINE, sgCT_COMBO_HLC_AREA, sgCT_3DHILOCLOSE, sgCT_3DCOMBO_LINE_BAR, sgCT_3DCOMBO_LINE_AREA, sgCT_3DCOMBO_LINE_LINE, sgCT_3DCOMBO_HLC_BAR, sgCT_3DCOMBO_HLC_AREA,
sgCT_3DBAR, sgCT_3DFLOATINGBAR, sgCT_3DAREA, sgCT_3DLINE, sgCT_3DPIE, sgCT_2DPIE
}
차트 종류 더 자세히 ...
enum | Draw3DTypeEnum { sg3DT_Auto = 0, sg3DT_Geometry = 1, sg3DT_Box = 2, sg3DT_Sphere = 3, sg3DT_Cylinder = 4, sg3DT_Capsule = 5, sg3DT_Cone = 6, sg3DT_Polygon = 7 }
3D 공간 객체 종류 더 자세히 ...
enum | MouseButtonTypeEnum { sgMB_NoButton = 0, sgMB_LeftButton = 1, sgMB_RightButton = 2, sgMB_MidButton = 4, sgMB_WheelButton = 8 }
마우스 버튼 종류 더 자세히 ...
enum TransitionModeEnum {
sgTR_LINEAR = 0, sgTR_SINE = 1, sgTR_QUINT = 2, sgTR_QUART = 3, sgTR_QUAD = 4, sgTR_EXPO = 5, sgTR_ELASTIC = 6, sgTR_CUBIC = 7,
sgTR_CIRC = 8, sgTR_BOUNCE = 9, sgTR_BACK = 10
}
애니매이션 알고리즘 종류 더 자세히 ...
enum | TimingModeEnum { sgTI_EASE_IN = 0, sgTI_EASE_OUT = 1, sgTI_EASE_IN_OUT = 2 }
애니메이션 시간 종류 더 자세히 ...
enum | RepeatModeEnum { sgRP_RESTART = 0, sgRP_REVERSE = 1 }
애니메이션 반복 종류 더 자세히 ...
enum | PointLocationEnum { sgPL_StartNode = 0x01, sgPL_EndNode = 0x02, sgPL_Node = 0x03, sgPL_Vertex = 0x04, sgPL_All = 0x07 }
공간객체 내 점의 종류 더 자세히 ...
enum SampleDimensionTypeEnum {
sgSDT_Unknown = 0, sgSDT_Byte, sgSDT_UInt16, sgSDT_Int16, sgSDT_UInt32, sgSDT_Int32, sgSDT_Float32, sgSDT_Float64,
sgSDT_CInt16, sgSDT_CInt32, sgSDT_CFloat32, sgSDT_CFloat64
}
다양한 커버리지 자료형. 그리드 커버리지의 경우 밴드 자료형 더 자세히 ...
enum ColorInterpretationEnum {
sgCI_Undefined = 0, sgCI_GrayIndex, sgCI_PaletteIndex, sgCI_RedBand, sgCI_GreenBand, sgCI_BlueBand, sgCI_AlphaBand, sgCI_HueBand,
sgCI_SaturationBand, sgCI_LightnessBand, sgCI_CyanBand, sgCI_MagentaBand, sgCI_YellowBand, sgCI_BlackBand, sgCI_YCbCr_YBand, sgCI_YCbCr_CbBand,
sgCI_YCbCr_CrBand
}
밴드가 어떤 컬러 모델 성분에 해당되는지를 나타낸다. 더 자세히 ...
enum | PaletteInterpretationEnum { sgPI_Gray, sgPI_RGB, sgPI_CMYK, sgPI_HLS, sgPI_YCbCr }
커버리지 컬러 팔레트로 정수값을 가지는 커버리지에 대해서만 컬러팔레트 정보가 유효함 더 자세히 ...
enum | SightModeEnum { sgIM_LinearLine = 0, sgIM_RadialLine, sgIM_PolyhedralLine }
3차원 가시권 분석 종류 더 자세히 ...
enum VariantTypeEnum {
sgVT_None = 0, sgVT_Bool, sgVT_Int, sgVT_Short, sgVT_Long, sgVT_Float, sgVT_Double, sgVT_String,
sgVT_Handle
}
파라메터 자료형 타입 종류 더 자세히 ...
enum FilterTypeEnum {
sgFT_Unknown = 0, sgFT_GRAYSCALE, sgFT_SEPIA, sgFT_SATURATE, sgFT_HUE_ROTATE, sgFT_INVERT, sgFT_BRIGHTNESS, sgFT_CONTRAST,
sgFT_OPACITY, sgFT_BLUR, sgFT_DROP_SHADOW, sgFT_FILTER_TYPE_LAST = sgFT_DROP_SHADOW
}
래스터 효과처리 타입 종류 더 자세히 ...
enum | AccessModeEnum { sgAM_Open = 0x01, sgAM_Create = 0x02, sgAM_CreateCopy = 0x04, sgAM_Delete = 0x08 }
드라이버 접근 모드 더 자세히 ...
enum SystemSymbolEnum {
sgSym_DistanceLine, sgSym_MeasureText, sgSym_MeasureBText, sgSym_AreaLine, sgSym_MeasureVertex, sgSym_ZoomLine, sgSym_SnapLine, sgSym_MovingGeom,
sgSym_TempGeom, sgSym_MagnifyBox, sgSym_TooltipText, sgSym_TooltipBox, sgSym_SnapGrid, sgSym_Count
}
시스템 심볼 더 자세히 ...
enum OGRwkbGeometryType {
wkbUnknown = 0, wkbPoint = 1, wkbLineString = 2, wkbPolygon = 3, wkbMultiPoint = 4, wkbMultiLineString = 5, wkbMultiPolygon = 6, wkbGeometryCollection = 7,
wkbCircularString = 8, wkbCompoundCurve = 9, wkbCurvePolygon = 10, wkbMultiCurve = 11, wkbMultiSurface = 12, wkbCurve = 13, wkbSurface = 14, wkbPolyhedralSurface = 15,
wkbTIN = 16, wkbTriangle = 17, wkbNone = 100, wkbLinearRing = 101, wkbCircularStringZ = 1008, wkbCompoundCurveZ = 1009, wkbCurvePolygonZ = 1010, wkbMultiCurveZ = 1011,
wkbMultiSurfaceZ = 1012, wkbCurveZ = 1013, wkbSurfaceZ = 1014, wkbPolyhedralSurfaceZ = 1015, wkbTINZ = 1016, wkbTriangleZ = 1017, wkbPointM = 2001, wkbLineStringM = 2002,
wkbPolygonM = 2003, wkbMultiPointM = 2004, wkbMultiLineStringM = 2005, wkbMultiPolygonM = 2006, wkbGeometryCollectionM = 2007, wkbCircularStringM = 2008, wkbCompoundCurveM = 2009, wkbCurvePolygonM = 2010,
wkbMultiCurveM = 2011, wkbMultiSurfaceM = 2012, wkbCurveM = 2013, wkbSurfaceM = 2014, wkbPolyhedralSurfaceM = 2015, wkbTINM = 2016, wkbTriangleM = 2017, wkbPointZM = 3001,
wkbLineStringZM = 3002, wkbPolygonZM = 3003, wkbMultiPointZM = 3004, wkbMultiLineStringZM = 3005, wkbMultiPolygonZM = 3006, wkbGeometryCollectionZM = 3007, wkbCircularStringZM = 3008, wkbCompoundCurveZM = 3009,
wkbCurvePolygonZM = 3010, wkbMultiCurveZM = 3011, wkbMultiSurfaceZM = 3012, wkbCurveZM = 3013, wkbSurfaceZM = 3014, wkbPolyhedralSurfaceZM = 3015, wkbTINZM = 3016, wkbTriangleZM = 3017,
wkbPoint25D = 0x80000001, wkbLineString25D = 0x80000002, wkbPolygon25D = 0x80000003, wkbMultiPoint25D = 0x80000004, wkbMultiLineString25D = 0x80000005, wkbMultiPolygon25D = 0x80000006, wkbGeometryCollection25D = 0x80000007
}
enum OGRFieldType {
OFTInteger = 0, OFTIntegerList = 1, OFTReal = 2, OFTRealList = 3, OFTString = 4, OFTStringList = 5, OFTWideString = 6, OFTWideStringList = 7,
OFTBinary = 8, OFTDate = 9, OFTTime = 10, OFTDateTime = 11, OFTInteger64 = 12, OFTInteger64List = 13, OFTMaxType = 13
}

함수

importlib ("stdole32.tlb")
importlib ("stdole2.tlb")

타입정의 문서화

typedef enum sgObject::AccessModeEnum sgObject::AccessModeEnum

드라이버 접근 모드

typedef enum sgObject::AlignPositionEnum sgObject::AlignPositionEnum

위치 정렬 종류(3행3열)

typedef enum sgObject::ChartTypeEnum sgObject::ChartTypeEnum

차트 종류

typedef enum sgObject::ColorInterpretationEnum sgObject::ColorInterpretationEnum

밴드가 어떤 컬러 모델 성분에 해당되는지를 나타낸다.

typedef enum sgObject::CursorEnum sgObject::CursorEnum

마우스 커서 종류

typedef enum sgObject::DiagramTypeEnum sgObject::DiagramTypeEnum

다이어그램 종류

typedef enum sgObject::Draw3DTypeEnum sgObject::Draw3DTypeEnum

3D 공간 객체 종류

typedef enum sgObject::EditedTypeEnum sgObject::EditedTypeEnum

편집 종류

typedef enum sgObject::FeatureTypeStyleEnum sgObject::FeatureTypeStyleEnum

채색 방법

typedef enum sgObject::FileFormatEnum sgObject::FileFormatEnum

자주 사용되는 공간 자료의 저장 종류(포맷)

typedef enum sgObject::FilterTypeEnum sgObject::FilterTypeEnum

래스터 효과처리 타입 종류

typedef enum sgObject::GeometryTypeEnum sgObject::GeometryTypeEnum

공간 객체의 구체적인 종류

2.5차원은 모든 좌표에 Z 값이 존재하지 않고 공간 객체에 하나의 Z좌표만을 가진 공간 정보를 의미함

typedef enum sgObject::GraphTypeEnum sgObject::GraphTypeEnum

그래프 종류

typedef enum sgObject::GridColorTypeEnum sgObject::GridColorTypeEnum

래스터 색상 선정 알고리 종류

typedef enum sgObject::HitObjectTypeEnum sgObject::HitObjectTypeEnum

검색(hitting) 객체의 종류

typedef enum sgObject::LabelPositionTypeEnum sgObject::LabelPositionTypeEnum

속성주석 위치 종류

typedef enum sgObject::LabelTypeEnum sgObject::LabelTypeEnum

주석 종류

typedef enum sgObject::LineCapEnum sgObject::LineCapEnum

다각선의 시작, 끝점의 모양

typedef enum sgObject::LineJoinEnum sgObject::LineJoinEnum

선과 선이 만나는 지점의 모양

typedef enum sgObject::LocationSensorTypeEnum sgObject::LocationSensorTypeEnum

위치 센서 종류

typedef enum sgObject::MapMoveEnum sgObject::MapMoveEnum

위치센서로부터 위치가 이동되고 있는 경우 지도 화면의 자동 이동 여부

typedef enum sgObject::MapRotateEnum sgObject::MapRotateEnum

위치센서로부터 위치가 이동하는 경우 이동 방향으로 Map2D 화면의 자동회전 여부

typedef enum sgObject::MouseButtonTypeEnum sgObject::MouseButtonTypeEnum

마우스 버튼 종류

typedef int sgObject::OGRErr
typedef enum sgObject::PaletteInterpretationEnum sgObject::PaletteInterpretationEnum

커버리지 컬러 팔레트로 정수값을 가지는 커버리지에 대해서만 컬러팔레트 정보가 유효함

typedef enum sgObject::ParameterType sgObject::ParameterType
typedef enum sgObject::PointLocationEnum sgObject::PointLocationEnum

공간객체 내 점의 종류

typedef enum sgObject::RepeatModeEnum sgObject::RepeatModeEnum

애니메이션 반복 종류

typedef enum sgObject::SampleDimensionTypeEnum sgObject::SampleDimensionTypeEnum

다양한 커버리지 자료형. 그리드 커버리지의 경우 밴드 자료형

typedef enum sgObject::ScreenModeEnum sgObject::ScreenModeEnum

화면의 현재 동작 모드

typedef enum sgObject::SensorTypeEnum sgObject::SensorTypeEnum

센서 종류

typedef enum sgObject::SightModeEnum sgObject::SightModeEnum

3차원 가시권 분석 종류

typedef enum sgObject::SnapModeEnum sgObject::SnapModeEnum

Map2D에서 마우스로 공간 객체를 그려서 생성하거나 이동, 변경시 좌표의 입력을 도와주는 기능으로 마우스의 위치를 기준으로 관련된 공간 객체의 주요 부분에 표시하고 해당 좌표 정보를 활용할 수 있도록 하는 기능(이하, 스냅)

공간 객체 검색 대상 스냅 모드

typedef enum sgObject::SpatialDataTypeEnum sgObject::SpatialDataTypeEnum

데이터베이스에 저장된 공간데이터 유형

typedef enum sgObject::SpatialOperatorEnum sgObject::SpatialOperatorEnum

공간연산 종류

typedef enum sgObject::SymbolizerTypeEnum sgObject::SymbolizerTypeEnum

그래픽 표식 종류

typedef enum sgObject::SymbolTypeEnum sgObject::SymbolTypeEnum

점 표현의 구체적인 종류

typedef enum sgObject::SystemKeyEnum sgObject::SystemKeyEnum

시스템 키보드 키 종류

typedef enum sgObject::SystemResourceEnum sgObject::SystemResourceEnum

시스템 내부 리소스 종류

typedef enum sgObject::SystemSymbolEnum sgObject::SystemSymbolEnum

시스템 심볼

typedef enum sgObject::TimingModeEnum sgObject::TimingModeEnum

애니메이션 시간 종류

typedef enum sgObject::TopoSyncMoveEnum sgObject::TopoSyncMoveEnum

공간객체의 노드/버텍스 편집에 따른 주변 연결된 공간객체의 동시 이동 조건 종류

typedef enum sgObject::TransactionEnum sgObject::TransactionEnum

트랜잭션 종류

typedef enum sgObject::TransitionModeEnum sgObject::TransitionModeEnum

애니매이션 알고리즘 종류

typedef enum sgObject::VariantTypeEnum sgObject::VariantTypeEnum

파라메터 자료형 타입 종류

typedef enum sgObject::VolumeTypeEnum sgObject::VolumeTypeEnum

체적 위치 종류

typedef enum sgObject::WebServerTypeEnum sgObject::WebServerTypeEnum

지도 OpenAPI 서버 종류

typedef enum sgObject::WebServiceTypeEnum sgObject::WebServiceTypeEnum

웹서비스 지도 유형

열거형 타입 문서화

enum sgObject::AccessModeEnum

드라이버 접근 모드

열거형 멤버
sgAM_Open | 열기
sgAM_Create | 생성
sgAM_CreateCopy | 복사생성
sgAM_Delete | 삭제
enum sgObject::AlignPositionEnum

위치 정렬 종류(3행3열)

열거형 멤버
sgAP_None | 왼쪽 하단(기본)
sgAP_TopLeft | 왼쪽 상단
sgAP_TopCenter | 가운데 상단
sgAP_TopRight | 오른쪽 상단
sgAP_CenterLeft | 왼쪽 중앙
sgAP_CenterCenter | 정중앙
sgAP_CenterRight | 오른쪽 중앙
sgAP_BottomLeft | 왼쪽 하단
sgAP_BottomCenter | 가운데 하단
sgAP_BottomRight | 오른쪽 하단
enum sgObject::Camera3DModeEnum

3D 카메라 시선 이동 종류

열거형 멤버
sgCM3_Focal | 목표점을 중심으로 카메라가 이동
sgCM3_Eye | 카메라 현재 위치를 중심으로 목표점이 이동
enum sgObject::CanvasTypeEnum

캔버스 객체 종류

열거형 멤버
sgCT_NULL | 없음
sgCT_2D | 2D 지도
sgCT_GRAPHIC | 그래픽 객체 지도
sgCT_3D | 3D 지도
sgCT_EARTH | 구형 3D 지도
sgCT_AR | 증강 3D 지도
enum sgObject::ChartTypeEnum

차트 종류

열거형 멤버
sgCT_LINE | 가로 축 기준으로 데이터를 값 축(세로 축)에 선으로 나타내는 꺽은 선 차트
sgCT_AREA |
sgCT_BAR | 바(bar)형태로 나타내는 간트 또는 막대형 차트
sgCT_FLOATINGBAR |
sgCT_HILOCLOSE |
sgCT_COMBO_LINE_BAR |
sgCT_COMBO_HLC_BAR |
sgCT_COMBO_LINE_AREA |
sgCT_COMBO_LINE_LINE |
sgCT_COMBO_HLC_AREA |
sgCT_3DHILOCLOSE |
sgCT_3DCOMBO_LINE_BAR |
sgCT_3DCOMBO_LINE_AREA |
sgCT_3DCOMBO_LINE_LINE |
sgCT_3DCOMBO_HLC_BAR |
sgCT_3DCOMBO_HLC_AREA |
sgCT_3DBAR |
sgCT_3DFLOATINGBAR |
sgCT_3DAREA |
sgCT_3DLINE |
sgCT_3DPIE |
sgCT_2DPIE |
enum sgObject::ColorInterpretationEnum

밴드가 어떤 컬러 모델 성분에 해당되는지를 나타낸다.

열거형 멤버
sgCI_Undefined | 밴드는 컬러 모델 성분과 관계 없음.
sgCI_GrayIndex | 데이터 색상은 Lookup테이블을 이용하여 표현된다.
sgCI_PaletteIndex | 데이터 색상은 컬러 테이블을 이용하여 표현된다.
sgCI_RedBand | 밴드들은 RGB 컬러 모델 컴포넌트에 해당하고, AlphaBand는 존재할 수도 존재하지 않을 수도 있다.
sgCI_GreenBand | 밴드들은 RGB 컬러 모델 컴포넌트에 해당하고, AlphaBand는 존재할 수도 존재하지 않을 수도 있다.
sgCI_BlueBand | 밴드들은 RGB 컬러 모델 컴포넌트에 해당하고, AlphaBand는 존재할 수도 존재하지 않을 수도 있다.
sgCI_AlphaBand |
sgCI_HueBand | 밴드들은 HSL 컬러 모델에 해당한다.
sgCI_SaturationBand | 밴드들은 HSL 컬러 모델에 해당한다.
sgCI_LightnessBand | 밴드들은 HSL 컬러 모델에 해당한다.
sgCI_CyanBand | 밴드들은 CMYK 컬러 모델에 해당한다.
sgCI_MagentaBand | 밴드들은 CMYK 컬러 모델에 해당한다.
sgCI_YellowBand | 밴드들은 CMYK 컬러 모델에 해당한다.
sgCI_BlackBand | 밴드들은 CMYK 컬러 모델에 해당한다.
sgCI_YCbCr_YBand |
sgCI_YCbCr_CbBand |
sgCI_YCbCr_CrBand |
enum sgObject::CursorEnum

마우스 커서 종류

열거형 멤버
sgCS_Null | 기본 화살표
sgCS_VertexMove | 버텍스(점) 이동
sgCS_VertexDelete | 버텍스(점) 삭제
sgCS_VertexAdd | 버텍스(점) 추가
sgCS_AnnoRotate | 주석 회전
sgCS_AnnoEndMove | 주석 끝점 이동
sgCS_AnnoMove | 주석 이동
sgCS_MapZoomIn | 지도 확대
sgCS_MapZoomOut | 지도 축소
sgCS_MapZoomPan | 지도 이동
sgCS_MapInsert | 객체 그리기(입력)
sgCS_MapSelectObject | 객체 선택
sgCS_EditTrim | 객체 분할
sgCS_EditExtend | 객체 끝점 늘리기(확장)
sgCS_EditBreak | 객체 잘라내기
sgCS_End | 시스템 내부 사용
enum sgObject::DiagramTypeEnum

다이어그램 종류

열거형 멤버
sgRT_Chart | 차트
sgRT_Graph | 그래프
sgRT_UserDefine | 사용자 정의 외부 객체
enum sgObject::DockAreaEnum

도킹 GUI 객체의 도킹 위치 종류

열거형 멤버
sgDA_No | 없음
sgDA_Left | 왼쪽
sgDA_Right | 오른쪽
sgDA_Top | 위쪽
sgDA_Bottom | 아래쪽
sgDA_Central | 중앙에 겹치기
sgDA_All | 위 모든 위치
enum sgObject::DockFeatureEnum

도킹 GUI 객체의 스타일 종류

열거형 멤버
sgDF_NoFeatures | 없음
sgDF_Closable | 닫기 기능
sgDF_Movable | 이동 기능
sgDF_Floatable | 평평한 스타일
sgDF_VerticalTitleBar | 수직 타이틀바 스타일
sgDF_FeatureMask | 마스크 스타일
sgDF_AllFeature | 일반 스타일
sgDF_Reserved |
enum sgObject::Draw3DTypeEnum

3D 공간 객체 종류

열거형 멤버
sg3DT_Auto | 2D 공간 객체별 3D 객체 자동설정
sg3DT_Geometry | 2D 공간 객체
sg3DT_Box | 박스 객체
sg3DT_Sphere | 구형 객체
sg3DT_Cylinder | 원통형 객체
sg3DT_Capsule | 캡슐 객체
sg3DT_Cone | 콘형 객체
sg3DT_Polygon | 다각형 객체
enum sgObject::EditActionTypeEnum

입력 툴바 객체 내 입력 객체 종류

열거형 멤버
sgAC_Point | 점/심볼
sgAC_Line | 선
sgAC_Free | 자유선
sgAC_Circle | 원/타원
sgAC_Rectangle | 사각형
sgAC_Polygon | 다각형
sgAC_End |
enum sgObject::EditedTypeEnum

편집 종류

열거형 멤버
sgET_Null | 편집 안됨
sgET_Insert | 추가
sgET_Delete | 삭제
sgET_Update | 변경
enum sgObject::FeatureTypeStyleEnum

채색 방법

열거형 멤버
sgFS_Default | 기본 색상
sgFS_GridRamp | 래스터 색상 리스트 기반
sgFS_GridPseudo | 래스터 Pseudo 알고리즘 기반
sgFS_GridFreakOut | 래스터 FreakOut 알고리즘 기반
sgFS_GridDefault | 래스터 기본 색상 기반
enum sgObject::FileFormatEnum

자주 사용되는 공간 자료의 저장 종류(포맷)

열거형 멤버
sgFF_IMG_BMP | BMP 파일
sgFF_IMG_GIF | GIF 파일
sgFF_IMG_JPG | JPEG 파일
sgFF_IMG_PNG | PNG 파일
sgFF_IMG_TIF | TIF 파일
sgFF_IMG_UNKNOWN | 알지 못하는 이미지 파일
sgFF_GIS_SHP | SHP 파일 (ESRI사의 GIS 파일 포맷)
sgFF_GIS_DXF | DXF 파일 (AutoDesk사의 CAD 파일 포맷)
sgFF_GIS_DWG | DWG 파일 (AutoDesk사의 CAD 파일 포맷)
sgFF_GIS_DGN | DGN 파일 (Bentley사의 CAD 파일 포맷)
sgFF_GIS_KML | KML 파일 (Google사의 GIS 파일 포맷)
sgFF_GIS_GML | GML 파일 (OGC 표준 GIS XML 포맷)
sgFF_GIS_TAB | TAB 파일 (MapInfo사의 GIS 파일 포맷)
sgFF_GIS_GEOJSON | JSON 파일 (웹 JSON GIS 파일 포맷)
sgFF_GIS_GPX | GPX 파일
sgFF_GIS_S57 | S57 파일 (해양 표준 GIS 파일 포맷)
sgFF_GIS_CSV | CSV 파일 (아스키파일 포맷)
sgFF_DB_ORACLE | Oracle 데이터베이스
sgFF_DB_DB2 | DB2 데이터베이스
sgFF_DB_INFORMIX | Informix 데이터베이스
sgFF_DB_SQLSERVER | SQLServer 데이터베이스
sgFF_DB_MYSQL | MySQL 데이터베이스
sgFF_DB_POSTGIS | PostGIS 데이터베이스
sgFF_DB_Altibase | 알티베이스 데이터베이스
sgFF_DB_Tibero | 티베로 데이터베이스
sgFF_DB_ZEUS | 제우스 데이터베이스
sgFF_DB_Kairos | 카이로스 데이터베이스
sgFF_DB_CUBRID | CUBRID 데이터베이스
sgFF_DB_RDBMS | 일반 RDBMS 데이터베이스
enum sgObject::FilterTypeEnum

래스터 효과처리 타입 종류

열거형 멤버
sgFT_Unknown | 설정되지 않은 효과
sgFT_GRAYSCALE | 그레이 스케일 효과
sgFT_SEPIA | 세피아 효과(낮은 채도의 갈색 그림자 효과)
sgFT_SATURATE | 채도 효과
sgFT_HUE_ROTATE | 각도 효과
sgFT_INVERT | 반전 효과
sgFT_BRIGHTNESS | 밝기 효과
sgFT_CONTRAST | 명암대비 효과
sgFT_OPACITY | 투명도 효과
sgFT_BLUR | 블러 효과
sgFT_DROP_SHADOW | 그림자 효과
sgFT_FILTER_TYPE_LAST | 내부 시스템 활용
enum sgObject::GeometryTypeEnum

공간 객체의 구체적인 종류

2.5차원은 모든 좌표에 Z 값이 존재하지 않고 공간 객체에 하나의 Z좌표만을 가진 공간 정보를 의미함

열거형 멤버
sgGT_Unknown | 알지 못하는 타입
sgGT_Point | 점
sgGT_LineString | 다각선
sgGT_Polygon | 다각형(내부에 여러개 다각형을 포함함)
sgGT_MultiPoint | 다중 점
sgGT_MultiLineString | 다중 다각선
sgGT_MultiPolygon | 다중 다각형
sgGT_GeometryCollection | 다중 공간 객체 집합
sgGT_None | 선언되지 않은 타입
sgGT_LinearRing | 처음과 마지막점이 동일한 다각선(폐합선) = 다각형
sgGT_Point25D | 2.5차원 점
sgGT_LineString25D | 2.5차원 다각선
sgGT_Polygon25D | 2.5차원 다각형
sgGT_MultiPoint25D | 2.5차원 다중 점
sgGT_MultiLineString25D | 2.5차원 다중 다각선
sgGT_MultiPolygon25D | 2.5차원 다중 다각형
sgGT_GeometryCollection25D | 2.5차원 다중 공간 객체 집합
enum sgObject::GraphTypeEnum

그래프 종류

열거형 멤버
sgGT_dot | 다트
sgGT_dotty |
sgGT_lefty |
sgGT_neato |
enum sgObject::GridColorTypeEnum

래스터 색상 선정 알고리 종류

열거형 멤버
sgGC_Interpolated | 보간된 색상
sgGC_Discrete | 이산 색상
sgGC_Exact | 동일한 색상
enum sgObject::HitObjectTypeEnum

검색(hitting) 객체의 종류

열거형 멤버
sgHT_Unknown | 알지 못하는 타입
sgHT_All | 모든 타입
sgHT_Geometry | 공간 객체 타입
sgHT_AnnoLine | 주석 인출선 타입
sgHT_AnnoLabel | 라벨 주석 타입
sgHT_AttrLabel | 속성 주석 타입
enum sgObject::LabelPositionTypeEnum

속성주석 위치 종류

열거형 멤버
sgLP_GeoMBRCenter | 공간객체의 MBR 의 중심점 기준(가장 빠름)
sgLP_GeoMapInterMBRCenter | 공간객체와 지도의 교차 MBR의 중심점 기준(주석의 위치가 이동됨)
sgLP_GeoFirstCenter | 다중 객체의 경우 첫번째 공간객체의 중심점 기준
sgLP_GeoFirstPointOnSurface | 다중 객체의 경우 첫번째 공간객체의 면의 중심점 기준
enum sgObject::LabelTypeEnum

주석 종류

열거형 멤버
sgLT_SymbolLabel | 텍스트 주석(점 객체에 주석 존재)
sgLT_TipLabel | 툴팁 주석
sgLT_AttrLabel | 속성 긴(장)주석
sgLT_AttrShortLabel | 속성 단(짧은)주석
sgLT_AnnoLabel | 라벨 주석
enum sgObject::LayerType3DEnum

3D 레이어의 종류

열거형 멤버
sgLT3_Default | 일반 레이어
sgLT3_Terrain | 등고 레이어
sgLT3_Mask | 마스크 레이어
sgLT3_Model | 모델(공간 객체) 레이어
sgLT3_Image | 이미지(등고 객체의 색상) 레이어
sgLT3_Elevation | 등고 레이어
enum sgObject::LineCapEnum

다각선의 시작, 끝점의 모양

열거형 멤버
sgLC_Flat | 일직선 형태의 끝 모양
sgLC_Square | 정사각형 형태의 선 끝 모양
sgLC_Round | 둥근 선 끝 모양
sgLC_Triangle | 삼각형 선 끝 모양
sgLC_NoAnchor | 모양 없음
sgLC_SquareAnchor | 정사각형 형태의 돌출선 끝 모양
sgLC_RoundAnchor | 둥근 원 형태의 돌출선 끝 모양
sgLC_DiamondAnchor | 마름모 형태의 돌출선 끝 모양
sgLC_ArrowAnchor | 화살표 형태의 돌출선 끝 모양
sgLC_ArrowAnchor1 | 화살표1 형태의 돌출선 끝 모양
sgLC_ArrowAnchor2 | 화살표2 형태의 돌출선 끝 모양 화살표2 모양의 앵커를 지정
sgLC_Custom | 사용자 지정 돌출선 끝 모양
sgLC_AnchorMask | 선 끝 모양이 돌출 모양인지 여부를 검사하는 데 사용되는 마스크를 지정
enum sgObject::LineJoinEnum

선과 선이 만나는 지점의 모양

열거형 멤버
sgLJ_Round | 부드러운 원형 호 모양
sgLJ_Mitre | 부드러운 날카로운 모퉁이나 클리핑된 모퉁이 모양
sgLJ_Bevel | 대각선 모퉁이 모양
enum sgObject::LocationSensorTypeEnum

위치 센서 종류

열거형 멤버
sgLSR_Unknown | 알지 못함
sgLSR_NMEA | NMEA 방식
sgLSR_RTK | RTK 방식
enum sgObject::MapMoveEnum

위치센서로부터 위치가 이동되고 있는 경우 지도 화면의 자동 이동 여부

열거형 멤버
sgMM_ManuMove | 수동 이동(자동 이동 없음)
sgMM_AutoMove | 센서 위치로 자동 이동
sgMM_OneOnlyMove | 센서 위치로 1회만 이동
enum sgObject::MapRotateEnum

위치센서로부터 위치가 이동하는 경우 이동 방향으로 Map2D 화면의 자동회전 여부

열거형 멤버
sgME_FixRotate | 화면 고정(위치 정보 회전)
sgME_AutoRotate | 화면 회전(위치 정보 고정)
enum sgObject::MouseButtonTypeEnum

마우스 버튼 종류

열거형 멤버
sgMB_NoButton | 없음
sgMB_LeftButton | 왼쪽 버튼
sgMB_RightButton | 오른쪽 버튼
sgMB_MidButton | 중간 버튼
sgMB_WheelButton | 휠 버튼
enum sgObject::NetworkAlgorithmEnum

네트워크 분석 알고리즘 종류

열거형 멤버
sgNA_NULL
sgNA_Bellman_ford
sgNA_Bfs
sgNA_Bid_dijkstra
sgNA_Dfs
sgNA_Dijkstra
sgNA_Fm_partition
sgNA_Maxflow_ff
sgNA_Maxflow_pp
sgNA_Maxflow_sap
sgNA_Min_tree
sgNA_Planarity
sgNA_Ratio_cut_partition
sgNA_St_number
enum sgObject::OGRFieldType

List of feature field types. This list is likely to be extended in the future ... avoid coding applications based on the assumption that all field types can be known.

열거형 멤버
OFTInteger | Simple 32bit integer
OFTIntegerList | List of 32bit integers
OFTReal | Double Precision floating point
OFTRealList | List of doubles
OFTString | String of ASCII chars
OFTStringList | Array of strings
OFTWideString | deprecated
OFTWideStringList | deprecated
OFTBinary | Raw Binary data
OFTDate | Date
OFTTime | Time
OFTDateTime | Date and Time
OFTInteger64 | Single 64bit integer
OFTInteger64List | List of 64bit integers
OFTMaxType |
enum sgObject::OGRwkbGeometryType
열거형 멤버
wkbUnknown | unknown type, non-standard
wkbPoint | 0-dimensional geometric object, standard WKB
wkbLineString | 1-dimensional geometric object with linear interpolation between Points, standard WKB
wkbPolygon | planar 2-dimensional geometric object defined by 1 exterior boundary and 0 or more interior boundaries, standard WKB
wkbMultiPoint | GeometryCollection of Points, standard WKB
wkbMultiLineString | GeometryCollection of LineStrings, standard WKB
wkbMultiPolygon | GeometryCollection of Polygons, standard WKB
wkbGeometryCollection | geometric object that is a collection of 1 or more geometric objects, standard WKB
wkbCircularString | one or more circular arc segments connected end to end, ISO SQL/MM Part 3. GDAL >= 2.0
wkbCompoundCurve | sequence of contiguous curves, ISO SQL/MM Part 3. GDAL >= 2.0
wkbCurvePolygon | planar surface, defined by 1 exterior boundary and zero or more interior boundaries, that are curves. ISO SQL/MM Part 3. GDAL >= 2.0
wkbMultiCurve | GeometryCollection of Curves, ISO SQL/MM Part 3. GDAL >= 2.0
wkbMultiSurface | GeometryCollection of Surfaces, ISO SQL/MM Part 3. GDAL >= 2.0
wkbCurve | Curve (abstract type). ISO SQL/MM Part 3. GDAL >= 2.1
wkbSurface | Surface (abstract type). ISO SQL/MM Part 3. GDAL >= 2.1
wkbPolyhedralSurface | a contiguous collection of polygons, which share common boundary segments, ISO SQL/MM Part 3. Reserved in GDAL >= 2.1 but not yet implemented
wkbTIN | a PolyhedralSurface consisting only of Triangle patches ISO SQL/MM Part 3. Reserved in GDAL >= 2.1 but not yet implemented
wkbTriangle | a Triangle. ISO SQL/MM Part 3. Reserved in GDAL >= 2.1 but not yet implemented
wkbNone | non-standard, for pure attribute records
wkbLinearRing | non-standard, just for createGeometry()
wkbCircularStringZ | wkbCircularString with Z component. ISO SQL/MM Part 3. GDAL >= 2.0
wkbCompoundCurveZ | wkbCompoundCurve with Z component. ISO SQL/MM Part 3. GDAL >= 2.0
wkbCurvePolygonZ | wkbCurvePolygon with Z component. ISO SQL/MM Part 3. GDAL >= 2.0
wkbMultiCurveZ | wkbMultiCurve with Z component. ISO SQL/MM Part 3. GDAL >= 2.0
wkbMultiSurfaceZ | wkbMultiSurface with Z component. ISO SQL/MM Part 3. GDAL >= 2.0
wkbCurveZ | wkbCurve with Z component. ISO SQL/MM Part 3. GDAL >= 2.1
wkbSurfaceZ | wkbSurface with Z component. ISO SQL/MM Part 3. GDAL >= 2.1
wkbPolyhedralSurfaceZ | ISO SQL/MM Part 3. Reserved in GDAL >= 2.1 but not yet implemented
wkbTINZ | ISO SQL/MM Part 3. Reserved in GDAL >= 2.1 but not yet implemented
wkbTriangleZ | ISO SQL/MM Part 3. Reserved in GDAL >= 2.1 but not yet implemented
wkbPointM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbLineStringM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbPolygonM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbMultiPointM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbMultiLineStringM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbMultiPolygonM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbGeometryCollectionM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbCircularStringM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbCompoundCurveM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbCurvePolygonM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbMultiCurveM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbMultiSurfaceM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbCurveM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbSurfaceM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbPolyhedralSurfaceM | ISO SQL/MM Part 3. Reserved in GDAL >= 2.1 but not yet implemented
wkbTINM | ISO SQL/MM Part 3. Reserved in GDAL >= 2.1 but not yet implemented
wkbTriangleM | ISO SQL/MM Part 3. Reserved in GDAL >= 2.1 but not yet implemented
wkbPointZM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbLineStringZM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbPolygonZM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbMultiPointZM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbMultiLineStringZM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbMultiPolygonZM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbGeometryCollectionZM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbCircularStringZM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbCompoundCurveZM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbCurvePolygonZM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbMultiCurveZM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbMultiSurfaceZM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbCurveZM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbSurfaceZM | ISO SQL/MM Part 3. GDAL >= 2.1
wkbPolyhedralSurfaceZM | ISO SQL/MM Part 3. Reserved in GDAL >= 2.1 but not yet implemented
wkbTINZM | ISO SQL/MM Part 3. Reserved in GDAL >= 2.1 but not yet implemented
wkbTriangleZM | ISO SQL/MM Part 3. Reserved in GDAL >= 2.1 but not yet implemented
wkbPoint25D | 2.5D extension as per 99-402
wkbLineString25D | 2.5D extension as per 99-402
wkbPolygon25D | 2.5D extension as per 99-402
wkbMultiPoint25D | 2.5D extension as per 99-402
wkbMultiLineString25D | 2.5D extension as per 99-402
wkbMultiPolygon25D | 2.5D extension as per 99-402
wkbGeometryCollection25D | 2.5D extension as per 99-402
enum sgObject::PaletteInterpretationEnum

커버리지 컬러 팔레트로 정수값을 가지는 커버리지에 대해서만 컬러팔레트 정보가 유효함

열거형 멤버
sgPI_Gray | 흑백의 값을 갖는다. 0이 검정색이고 255가 흰색이다
sgPI_RGB | 빨강, 녹색, 파랑 3가지의 값을 갖는다. 각 값의 범위는 0에서 255이며 이때, 0은 명암이 없고 255이면 최대 명암값을 갖는다.
sgPI_CMYK | Cyan, Magenta, Yellow, Black의 4가지 값을 갖는다. 각 값의 범위는 0에서 255이며, 0일때는 명암값이 없고, 255일때 최대 명암값을 갖는다.
sgPI_HLS | 색상(Hue), 채도(Saturation), 밝기(Lightness) 3개 값을 갖는다. 색상은 0에서 360까지의 값을 갖고, 채도는 0에서 100까지의 값을 갖는다. 이 때, 채도값이 0이면 명암이 0이고, 100이면 최대의 명암값을 갖는다. 밝기는 0에서 100까지의 값을 갖는다.
sgPI_YCbCr |
enum sgObject::ParameterType
열거형 멤버
sgPT_IntegerType
sgPT_FloatingPointType
sgPT_StringType
sgPT_GridCoverageType
sgPT_FeatureCollectionType
enum sgObject::PointLocationEnum

공간객체 내 점의 종류

열거형 멤버
sgPL_StartNode | 시작점
sgPL_EndNode | 끝점
sgPL_Node | 시작, 끝점
sgPL_Vertex | 중간점(시작, 끝점 제외)
sgPL_All | 모든점
enum sgObject::RepeatModeEnum

애니메이션 반복 종류

열거형 멤버
sgRP_RESTART
sgRP_REVERSE
enum sgObject::SampleDimensionTypeEnum

다양한 커버리지 자료형. 그리드 커버리지의 경우 밴드 자료형

열거형 멤버
sgSDT_Unknown | 알지 못하는 자료형
sgSDT_Byte | 1바이트형
sgSDT_UInt16 | unsigned 16(2바이트)형
sgSDT_Int16 | signed 16(2바이트)형
sgSDT_UInt32 | unsigned 32(4바이트)형
sgSDT_Int32 | signed 16(4바이트)형
sgSDT_Float32 | float (4바이트)형
sgSDT_Float64 | double (8바이트)형
sgSDT_CInt16 |
sgSDT_CInt32 |
sgSDT_CFloat32 |
sgSDT_CFloat64 |
enum sgObject::ScreenModeEnum

화면의 현재 동작 모드

열거형 멤버
sgSM_StartBuffer | 내부 화면 모드 참고
sgSM_NullMode | 초기 모드
sgSM_SelectMode | 점, 사각영역으로 선택
sgSM_SelectPolylineMode | 선에 접하는 객체 선택
sgSM_SelectPolygonMode | 다각형 내부 또는 접하는 객체 선택
sgSM_SelectGeometryMode | 선택된 공간 객체 내부로 선택
sgSM_SelectCircleMode | 원, 타원 내부로 선택
sgSM_SelectKeepCircleMode | 원, 타원 내부로 선택(객체 유지)
sgSM_ZoomInMode | 화면 확대 실행
sgSM_ZoomInAreaMode | 화면 영역 확대 모드
sgSM_ZoomOutMode | 화면 축소 실행
sgSM_ZoomOutAreaMode | 화면 영역 축소 모드
sgSM_PanningMode | 화면 이동 모드
sgSM_InsertSymbolMode | 점, 심볼 입력 모드
sgSM_InsertTextMode | 문자 입력 모드
sgSM_InsertPolylineMode | 다각선 입력 모드
sgSM_InsertPolygonMode | 다각형 입력 모드
sgSM_InsertCircleMode | 원, 타원 입력 모드
sgSM_InsertFreelineMode | 자유선 입력 모드
sgSM_InsertRectangleMode | 사각형 입력 모드
sgSM_InsertRingMode | 다각형 내 내부 다각형 입력 모드
sgSM_DistanceMode | 거리 측정 모드
sgSM_AreaMode | 면적 측정 모드
sgSM_SingPostMode | 임의 점 입력 모드(출발점/도착점 등)
sgSM_EditVertexMoveMode | 노드, 버텍스 이동 모드
sgSM_EditVertexDeleteMode | 버텍스 삭제 모드
sgSM_EditVertexAddMode | 버텍스 추가 모드
sgSM_EditMoveMode | 공간 객체 이동 모드
sgSM_EditDeleteMode | 공간 객체 삭제 모드
sgSM_EditCopyMode | 공간 객체 복사 모드
sgSM_EditRotateMode | 공간 객체 회전 모드
sgSM_EditExtendMode | 공간 객체의 처음 선택한 객체를 다음 선택한 객체까지 연장시키는 모드
sgSM_EditTrimMode | 공간 객체의 처음 선택한 객체의 일부를 다음 선택한 객체를 기준으로 잘라내는 모드
sgSM_EditScaleMode | 공간 객체 크기 변경 모드
sgSM_EditBreakMode | 잘라내기 위한 기준 라인을 그려 해당 기준 객체를 활용하여 걸치는 모든 공간 객체를 잘라내는 모드
sgSM_EditBreakGeometryMode | 선택된 공간객체를 기준으로 걸치는 모든 공간 객체를 잘라내는 모드
sgSM_EditDeleteRingMode | 다각형 내부 다각형 삭제 모드
sgSM_VolumeMode | 부피 측정 모드
sgSM_TerrainProfileMode | 단면도 측정 모드
sgSM_SightMode | 가시권 분석 모드
sgSM_PointGridMode | Z점 그리드 보기 모드
sgSM_End |
sgSM_AnnotationMove | 주석 위치 이동 모드(내부 사용)
sgSM_AutoPanningMode | 화면 자동(마우스 이동에 따라) 이동 모드(내부 사용)
sgSM_AnnotationRotate | 주석 회전 모드(내부 사용)
sgSM_AnnotationEndMove | 주석 끝점 이동 모드(내부 사용)
enum sgObject::SensorTypeEnum

센서 종류

열거형 멤버
sgSR_Location | 위치 센서
sgSR_Motion | 방향 센서
sgSR_Video | 카메라 센서
enum sgObject::SightModeEnum

3차원 가시권 분석 종류

열거형 멤버
sgIM_LinearLine
sgIM_RadialLine
sgIM_PolyhedralLine
enum sgObject::SnapModeEnum

Map2D에서 마우스로 공간 객체를 그려서 생성하거나 이동, 변경시 좌표의 입력을 도와주는 기능으로 마우스의 위치를 기준으로 관련된 공간 객체의 주요 부분에 표시하고 해당 좌표 정보를 활용할 수 있도록 하는 기능(이하, 스냅)

공간 객체 검색 대상 스냅 모드

열거형 멤버
sgNM_NullPoint | 스냅 기능을 취하지 않음
sgNM_NodePoint | 끝(노드)
sgNM_VertPoint | 중간점(버텍스)
sgNM_EndPoint | 끝, 중간점(노드/버텍스)
sgNM_MidPoint | 라인의 중간점
sgNM_NearestPoint | 라인에서 가장 가까운 점
sgNM_IntersectPoint | 객체간 교차점
sgNM_PerpendicularPoint | 직각 교차점
sgNM_OrthoPoint | 수직, 수평 교차점
sgNM_ExtensionPoint | 연장선상 가장 가까운 점
sgNM_CenterPoint | 폴리곤, 원의 중심점
sgNM_ScalePoint | 스케일 변경시 변경 중심점(내부에서만 사용)
sgNM_RotatePoint | 회전시 회전 중심점(내부에서만 사용)
sgNM_GPSPoint | GPS 장치에서 들어오는 GPS 현재 위치
sgNM_Geometry |
sgNM_END |
enum sgObject::SpatialDataTypeEnum

데이터베이스에 저장된 공간데이터 유형

열거형 멤버
sgSD_SpatialDBBlob | DBMS 자체 공간자료 유형
sgSD_WKB | WKB(Well Known Binary)
sgSD_WKT | WKT(Well Known Text)
sgSD_ArcSDE | ArcSDE 블럽형
sgSD_Geomedia | Geomedia 블럽형
sgSD_Smallworld | Smallworld 블럽형
enum sgObject::SpatialOperatorEnum

공간연산 종류

열거형 멤버
sgSO_Intersects | 교집합
sgSO_Equals | 동일
sgSO_Disjoint | 비접촉
sgSO_Touches | 접촉
sgSO_Crosses | 횡단
sgSO_Within | 포함되는지 여부
sgSO_Contains | 포함하는지 여부
sgSO_Overlaps | 겹침
enum sgObject::SymbolizerTypeEnum

그래픽 표식 종류

열거형 멤버
sgSL_Default | 일반
sgSL_Line | 선
sgSL_Polygon | 채우기
sgSL_Point | 점/심볼
sgSL_Label | 문자
enum sgObject::SymbolTypeEnum

점 표현의 구체적인 종류

열거형 멤버
sgST_Unknown | 알려지지 않음(1~50 : system defined symbol)
sgST_Vector | 공간 객체 기반 벡터
sgST_Image | 이미지 데이터
enum sgObject::SystemKeyEnum

시스템 키보드 키 종류

열거형 멤버
sgSK_NONE |
sgSK_LeftSoftKey |
sgSK_RightSoftKey |
sgSK_Home | the home key - added to match android
sgSK_Back | (CLR)
sgSK_Send | the green (talk) key
sgSK_End | the red key
sgSK_0 |
sgSK_1 |
sgSK_2 |
sgSK_3 |
sgSK_4 |
sgSK_5 |
sgSK_6 |
sgSK_7 |
sgSK_8 |
sgSK_9 |
sgSK_Star | the * key
sgSK_Hash | the # key
sgSK_Escape | insert by gskim
sgSK_Delete |
sgSK_Shift |
sgSK_Control |
sgSK_Up |
sgSK_Down |
sgSK_Left |
sgSK_Right |
sgSK_Enter | the center key
sgSK_VolUp | volume up - match android
sgSK_VolDown | volume down - same
sgSK_Power | power button - same
sgSK_Camera | camera - same
sgSK_KeyCount |
enum sgObject::SystemResourceEnum

시스템 내부 리소스 종류

열거형 멤버
sgRS_StartBuffer | 내부 리소스 참고
sgRS_Default | 설정 안됨
sgRS_Logo | 로고
sgRS_Location | GPS 위치
sgRS_Compass | 방위
sgRS_ScaleBar | 스케일바
sgRS_Scale | 스케일 문자
sgRS_IndexMapWidget | 인덱스지도 객체 GUI
sgRS_MapCtrlWidget | 내부 지도 제어 객체 GUI
sgRS_ZoomLevelWidget | 지도 확대축소 레벨 객체 GUI
sgRS_MotionBtn | 방향센서 제어 버튼 객체 GUI
sgRS_LocationBtn | 위치센서 제어 버튼 객체 GUI
enum sgObject::SystemSymbolEnum

시스템 심볼

열거형 멤버
sgSym_DistanceLine
sgSym_MeasureText
sgSym_MeasureBText
sgSym_AreaLine
sgSym_MeasureVertex
sgSym_ZoomLine
sgSym_SnapLine
sgSym_MovingGeom
sgSym_TempGeom
sgSym_MagnifyBox
sgSym_TooltipText
sgSym_TooltipBox
sgSym_SnapGrid
sgSym_Count
enum sgObject::TapPositionEnum

탭 GUI 객체의 Tap 위치 종류

열거형 멤버
sgTP_North | 북쪽(화면 위쪽)
sgTP_South | 남쪽(화면 아래쪽)
sgTP_West | 서쪽(화면 왼쪽)
sgTP_East | 동쪽(화면 오른쪽)
enum sgObject::TimingModeEnum

애니메이션 시간 종류

열거형 멤버
sgTI_EASE_IN
sgTI_EASE_OUT
sgTI_EASE_IN_OUT
enum sgObject::ToolBarTypeEnum

툴바 객체 종류

열거형 멤버
sgTB_MapDiz | 공간 객체 일반편집 툴바
sgTB_MapNav | 지도 표시 툴바
sgTB_MapSelect | 공간 객체 선택 툴바
sgTB_MapMeasure | 측정 툴바
sgTB_Edit | 공간 객체 편집 툴바
sgTB_EditVertex | 공간 객체 점편집 툴바
sgTB_View | 지도 확대/축소 툴바
sgTB_LayerAdd | 레이어 추가 툴바
sgTB_VectorGeomProcess | 벡터 공간 연산 툴바
sgTB_VectorProcess | 벡터 연산 툴바
sgTB_RasterProcess | 래스터 연산 툴바
sgTB_SnapProperties | 스냅 상태 제어 툴바
sgTB_PrintFile | 출력창 내 파일 툴바
sgTB_PrintExport | 출력창 내 내보내기 툴바
sgTB_PrintView | 출력창 내 보기 툴바
sgTB_PrintLayout | 출력창 레이아웃 툴바
sgTB_PrintItem | 출력창 내 객체 추가 툴바
sgTB_End |
enum sgObject::TopoSyncMoveEnum

공간객체의 노드/버텍스 편집에 따른 주변 연결된 공간객체의 동시 이동 조건 종류

열거형 멤버
sgTS_None | 동시이동 없음
sgTS_Symbol2Symbol | 심볼이동시 심볼이동
sgTS_Symbol2Node | 심볼이동시 라인 끝점이동
sgTS_Symbol2Vertex | 심볼이동시 라인점 이동
sgTS_Node2Symbol | 라인끝점 이동시 심볼이동
sgTS_Node2Node | 라인끝점 이동시 라인 끝점이동
sgTS_Node2Vertex | 라인끝점 이동시 라인점 이동
sgTS_Vertex2Symbol | 라인점 이동시 심볼이동
sgTS_Vertex2Node | 라인점 이동시 라인끝점 이동
sgTS_Vertex2Vertex | 라인점 이동시 라인점 이동
sgTS_ComplexSymbolVertexStand | 심볼, 라인끝점/라인점 우선 이동
enum sgObject::TransactionEnum

트랜잭션 종류

열거형 멤버
sgTN_AutoCommit | 자동 저장
sgTN_ManualCommit | 수동 저장
sgTN_UnBind | 저장 안함
enum sgObject::TransitionModeEnum

애니매이션 알고리즘 종류

열거형 멤버
sgTR_LINEAR
sgTR_SINE
sgTR_QUINT
sgTR_QUART
sgTR_QUAD
sgTR_EXPO
sgTR_ELASTIC
sgTR_CUBIC
sgTR_CIRC
sgTR_BOUNCE
sgTR_BACK
enum sgObject::VariantTypeEnum

파라메터 자료형 타입 종류

열거형 멤버
sgVT_None
sgVT_Bool
sgVT_Int
sgVT_Short
sgVT_Long
sgVT_Float
sgVT_Double
sgVT_String
sgVT_Handle
enum sgObject::VolumeTypeEnum

체적 위치 종류

열거형 멤버
sgVT_Above | 기준 위쪽
sgVT_Below | 기준 아래쪽
enum sgObject::WebServerTypeEnum

지도 OpenAPI 서버 종류

열거형 멤버
sgOA_GOOGLEMAP | 구글
sgOA_YAHOOMAP | 야후
sgOA_BINGMAP | 마이크로소프트 빙지도
sgOA_VWORLD_2D | 브이월드 2D
sgOA_VWORLD_3D | 브이월드 3D
sgOA_NAVERMAP | 네이버 포털
sgOA_DAUMMAP | 다음 포털
sgOA_KTMAP | KT 포털
sgOA_AGS | ArcGIS Online Service.
sgOA_TMS | 서버 (tms)
enum sgObject::WebServiceTypeEnum

웹서비스 지도 유형

열거형 멤버
sgWS_Default | 기본값
sgWS_OpenAPI | OpenAPI 지도
sgWS_WMS | WMS 지도
sgWS_WFS | WFS 지도
sgWS_GWFS | GWFS(Server를 통한 확장WFS) 지도
sgWS_LTM | LTM(Level Tiled Map) 지도

함수 문서화

sgObject::importlib ( "stdole32.tlb" )
sgObject::importlib ( "stdole2.tlb" )
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
다음은 모든 네임스페이스 멤버들의 목록입니다. 각 멤버들은 해당 멤버의 네임스페이스 문서화 페이지의 링크를 가지고 있습니다. :

- a -

  • AccessModeEnum : sgObject
  • AlignPositionEnum : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
다음은 모든 네임스페이스 멤버들의 목록입니다. 각 멤버들은 해당 멤버의 네임스페이스 문서화 페이지의 링크를 가지고 있습니다. :

- c -

  • Camera3DModeEnum : sgObject
  • CanvasTypeEnum : sgObject
  • ChartTypeEnum : sgObject
  • ColorInterpretationEnum : sgObject
  • CursorEnum : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
다음은 모든 네임스페이스 멤버들의 목록입니다. 각 멤버들은 해당 멤버의 네임스페이스 문서화 페이지의 링크를 가지고 있습니다. :

- d -

  • DiagramTypeEnum : sgObject
  • DockAreaEnum : sgObject
  • DockFeatureEnum : sgObject
  • Draw3DTypeEnum : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
다음은 모든 네임스페이스 멤버들의 목록입니다. 각 멤버들은 해당 멤버의 네임스페이스 문서화 페이지의 링크를 가지고 있습니다. :

- e -

  • EditActionTypeEnum : sgObject
  • EditedTypeEnum : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
다음은 모든 네임스페이스 멤버들의 목록입니다. 각 멤버들은 해당 멤버의 네임스페이스 문서화 페이지의 링크를 가지고 있습니다. :

- f -

  • FeatureTypeStyleEnum : sgObject
  • FileFormatEnum : sgObject
  • FilterTypeEnum : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
다음은 모든 네임스페이스 멤버들의 목록입니다. 각 멤버들은 해당 멤버의 네임스페이스 문서화 페이지의 링크를 가지고 있습니다. :

- g -

  • GeometryTypeEnum : sgObject
  • GraphTypeEnum : sgObject
  • GridColorTypeEnum : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
다음은 모든 네임스페이스 멤버들의 목록입니다. 각 멤버들은 해당 멤버의 네임스페이스 문서화 페이지의 링크를 가지고 있습니다. :

- h -

  • HitObjectTypeEnum : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
다음은 모든 네임스페이스 멤버들의 목록입니다. 각 멤버들은 해당 멤버의 네임스페이스 문서화 페이지의 링크를 가지고 있습니다. :

- i -

  • importlib() : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
다음은 모든 네임스페이스 멤버들의 목록입니다. 각 멤버들은 해당 멤버의 네임스페이스 문서화 페이지의 링크를 가지고 있습니다. :

- l -

  • LabelPositionTypeEnum : sgObject
  • LabelTypeEnum : sgObject
  • LayerType3DEnum : sgObject
  • LineCapEnum : sgObject
  • LineJoinEnum : sgObject
  • LocationSensorTypeEnum : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
다음은 모든 네임스페이스 멤버들의 목록입니다. 각 멤버들은 해당 멤버의 네임스페이스 문서화 페이지의 링크를 가지고 있습니다. :

- m -

  • MapMoveEnum : sgObject
  • MapRotateEnum : sgObject
  • MouseButtonTypeEnum : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
다음은 모든 네임스페이스 멤버들의 목록입니다. 각 멤버들은 해당 멤버의 네임스페이스 문서화 페이지의 링크를 가지고 있습니다. :

- n -

  • NetworkAlgorithmEnum : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
다음은 모든 네임스페이스 멤버들의 목록입니다. 각 멤버들은 해당 멤버의 네임스페이스 문서화 페이지의 링크를 가지고 있습니다. :

- o -

  • OFTBinary : sgObject
  • OFTDate : sgObject
  • OFTDateTime : sgObject
  • OFTInteger : sgObject
  • OFTInteger64 : sgObject
  • OFTInteger64List : sgObject
  • OFTIntegerList : sgObject
  • OFTMaxType : sgObject
  • OFTReal : sgObject
  • OFTRealList : sgObject
  • OFTString : sgObject
  • OFTStringList : sgObject
  • OFTTime : sgObject
  • OFTWideString : sgObject
  • OFTWideStringList : sgObject
  • OGRErr : sgObject
  • OGRFieldType : sgObject
  • OGRwkbGeometryType : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
다음은 모든 네임스페이스 멤버들의 목록입니다. 각 멤버들은 해당 멤버의 네임스페이스 문서화 페이지의 링크를 가지고 있습니다. :

- p -

  • PaletteInterpretationEnum : sgObject
  • ParameterType : sgObject
  • PointLocationEnum : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
다음은 모든 네임스페이스 멤버들의 목록입니다. 각 멤버들은 해당 멤버의 네임스페이스 문서화 페이지의 링크를 가지고 있습니다. :

- r -

  • RepeatModeEnum : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
다음은 모든 네임스페이스 멤버들의 목록입니다. 각 멤버들은 해당 멤버의 네임스페이스 문서화 페이지의 링크를 가지고 있습니다. :

- s -

  • SampleDimensionTypeEnum : sgObject
  • ScreenModeEnum : sgObject
  • SensorTypeEnum : sgObject
  • sg3DT_Auto : sgObject
  • sg3DT_Box : sgObject
  • sg3DT_Capsule : sgObject
  • sg3DT_Cone : sgObject
  • sg3DT_Cylinder : sgObject
  • sg3DT_Geometry : sgObject
  • sg3DT_Polygon : sgObject
  • sg3DT_Sphere : sgObject
  • sgAC_Circle : sgObject
  • sgAC_End : sgObject
  • sgAC_Free : sgObject
  • sgAC_Line : sgObject
  • sgAC_Point : sgObject
  • sgAC_Polygon : sgObject
  • sgAC_Rectangle : sgObject
  • sgAM_Create : sgObject
  • sgAM_CreateCopy : sgObject
  • sgAM_Delete : sgObject
  • sgAM_Open : sgObject
  • sgAP_BottomCenter : sgObject
  • sgAP_BottomLeft : sgObject
  • sgAP_BottomRight : sgObject
  • sgAP_CenterCenter : sgObject
  • sgAP_CenterLeft : sgObject
  • sgAP_CenterRight : sgObject
  • sgAP_None : sgObject
  • sgAP_TopCenter : sgObject
  • sgAP_TopLeft : sgObject
  • sgAP_TopRight : sgObject
  • sgCI_AlphaBand : sgObject
  • sgCI_BlackBand : sgObject
  • sgCI_BlueBand : sgObject
  • sgCI_CyanBand : sgObject
  • sgCI_GrayIndex : sgObject
  • sgCI_GreenBand : sgObject
  • sgCI_HueBand : sgObject
  • sgCI_LightnessBand : sgObject
  • sgCI_MagentaBand : sgObject
  • sgCI_PaletteIndex : sgObject
  • sgCI_RedBand : sgObject
  • sgCI_SaturationBand : sgObject
  • sgCI_Undefined : sgObject
  • sgCI_YCbCr_CbBand : sgObject
  • sgCI_YCbCr_CrBand : sgObject
  • sgCI_YCbCr_YBand : sgObject
  • sgCI_YellowBand : sgObject
  • sgCM3_Eye : sgObject
  • sgCM3_Focal : sgObject
  • sgCS_AnnoEndMove : sgObject
  • sgCS_AnnoMove : sgObject
  • sgCS_AnnoRotate : sgObject
  • sgCS_EditBreak : sgObject
  • sgCS_EditExtend : sgObject
  • sgCS_EditTrim : sgObject
  • sgCS_End : sgObject
  • sgCS_MapInsert : sgObject
  • sgCS_MapSelectObject : sgObject
  • sgCS_MapZoomIn : sgObject
  • sgCS_MapZoomOut : sgObject
  • sgCS_MapZoomPan : sgObject
  • sgCS_Null : sgObject
  • sgCS_VertexAdd : sgObject
  • sgCS_VertexDelete : sgObject
  • sgCS_VertexMove : sgObject
  • sgCT_2D : sgObject
  • sgCT_2DPIE : sgObject
  • sgCT_3D : sgObject
  • sgCT_3DAREA : sgObject
  • sgCT_3DBAR : sgObject
  • sgCT_3DCOMBO_HLC_AREA : sgObject
  • sgCT_3DCOMBO_HLC_BAR : sgObject
  • sgCT_3DCOMBO_LINE_AREA : sgObject
  • sgCT_3DCOMBO_LINE_BAR : sgObject
  • sgCT_3DCOMBO_LINE_LINE : sgObject
  • sgCT_3DFLOATINGBAR : sgObject
  • sgCT_3DHILOCLOSE : sgObject
  • sgCT_3DLINE : sgObject
  • sgCT_3DPIE : sgObject
  • sgCT_AR : sgObject
  • sgCT_AREA : sgObject
  • sgCT_BAR : sgObject
  • sgCT_COMBO_HLC_AREA : sgObject
  • sgCT_COMBO_HLC_BAR : sgObject
  • sgCT_COMBO_LINE_AREA : sgObject
  • sgCT_COMBO_LINE_BAR : sgObject
  • sgCT_COMBO_LINE_LINE : sgObject
  • sgCT_EARTH : sgObject
  • sgCT_FLOATINGBAR : sgObject
  • sgCT_GRAPHIC : sgObject
  • sgCT_HILOCLOSE : sgObject
  • sgCT_LINE : sgObject
  • sgCT_NULL : sgObject
  • sgDA_All : sgObject
  • sgDA_Bottom : sgObject
  • sgDA_Central : sgObject
  • sgDA_Left : sgObject
  • sgDA_No : sgObject
  • sgDA_Right : sgObject
  • sgDA_Top : sgObject
  • sgDF_AllFeature : sgObject
  • sgDF_Closable : sgObject
  • sgDF_FeatureMask : sgObject
  • sgDF_Floatable : sgObject
  • sgDF_Movable : sgObject
  • sgDF_NoFeatures : sgObject
  • sgDF_Reserved : sgObject
  • sgDF_VerticalTitleBar : sgObject
  • sgET_Delete : sgObject
  • sgET_Insert : sgObject
  • sgET_Null : sgObject
  • sgET_Update : sgObject
  • sgFF_DB_Altibase : sgObject
  • sgFF_DB_CUBRID : sgObject
  • sgFF_DB_DB2 : sgObject
  • sgFF_DB_INFORMIX : sgObject
  • sgFF_DB_Kairos : sgObject
  • sgFF_DB_MYSQL : sgObject
  • sgFF_DB_ORACLE : sgObject
  • sgFF_DB_POSTGIS : sgObject
  • sgFF_DB_RDBMS : sgObject
  • sgFF_DB_SQLSERVER : sgObject
  • sgFF_DB_Tibero : sgObject
  • sgFF_DB_ZEUS : sgObject
  • sgFF_GIS_CSV : sgObject
  • sgFF_GIS_DGN : sgObject
  • sgFF_GIS_DWG : sgObject
  • sgFF_GIS_DXF : sgObject
  • sgFF_GIS_GEOJSON : sgObject
  • sgFF_GIS_GML : sgObject
  • sgFF_GIS_GPX : sgObject
  • sgFF_GIS_KML : sgObject
  • sgFF_GIS_S57 : sgObject
  • sgFF_GIS_SHP : sgObject
  • sgFF_GIS_TAB : sgObject
  • sgFF_IMG_BMP : sgObject
  • sgFF_IMG_GIF : sgObject
  • sgFF_IMG_JPG : sgObject
  • sgFF_IMG_PNG : sgObject
  • sgFF_IMG_TIF : sgObject
  • sgFF_IMG_UNKNOWN : sgObject
  • sgFS_Default : sgObject
  • sgFS_GridDefault : sgObject
  • sgFS_GridFreakOut : sgObject
  • sgFS_GridPseudo : sgObject
  • sgFS_GridRamp : sgObject
  • sgFT_BLUR : sgObject
  • sgFT_BRIGHTNESS : sgObject
  • sgFT_CONTRAST : sgObject
  • sgFT_DROP_SHADOW : sgObject
  • sgFT_FILTER_TYPE_LAST : sgObject
  • sgFT_GRAYSCALE : sgObject
  • sgFT_HUE_ROTATE : sgObject
  • sgFT_INVERT : sgObject
  • sgFT_OPACITY : sgObject
  • sgFT_SATURATE : sgObject
  • sgFT_SEPIA : sgObject
  • sgFT_Unknown : sgObject
  • sgGC_Discrete : sgObject
  • sgGC_Exact : sgObject
  • sgGC_Interpolated : sgObject
  • sgGT_dot : sgObject
  • sgGT_dotty : sgObject
  • sgGT_GeometryCollection : sgObject
  • sgGT_GeometryCollection25D : sgObject
  • sgGT_lefty : sgObject
  • sgGT_LinearRing : sgObject
  • sgGT_LineString : sgObject
  • sgGT_LineString25D : sgObject
  • sgGT_MultiLineString : sgObject
  • sgGT_MultiLineString25D : sgObject
  • sgGT_MultiPoint : sgObject
  • sgGT_MultiPoint25D : sgObject
  • sgGT_MultiPolygon : sgObject
  • sgGT_MultiPolygon25D : sgObject
  • sgGT_neato : sgObject
  • sgGT_None : sgObject
  • sgGT_Point : sgObject
  • sgGT_Point25D : sgObject
  • sgGT_Polygon : sgObject
  • sgGT_Polygon25D : sgObject
  • sgGT_Unknown : sgObject
  • sgHT_All : sgObject
  • sgHT_AnnoLabel : sgObject
  • sgHT_AnnoLine : sgObject
  • sgHT_AttrLabel : sgObject
  • sgHT_Geometry : sgObject
  • sgHT_Unknown : sgObject
  • sgIM_LinearLine : sgObject
  • sgIM_PolyhedralLine : sgObject
  • sgIM_RadialLine : sgObject
  • sgLC_AnchorMask : sgObject
  • sgLC_ArrowAnchor : sgObject
  • sgLC_ArrowAnchor1 : sgObject
  • sgLC_ArrowAnchor2 : sgObject
  • sgLC_Custom : sgObject
  • sgLC_DiamondAnchor : sgObject
  • sgLC_Flat : sgObject
  • sgLC_NoAnchor : sgObject
  • sgLC_Round : sgObject
  • sgLC_RoundAnchor : sgObject
  • sgLC_Square : sgObject
  • sgLC_SquareAnchor : sgObject
  • sgLC_Triangle : sgObject
  • sgLJ_Bevel : sgObject
  • sgLJ_Mitre : sgObject
  • sgLJ_Round : sgObject
  • sgLP_GeoFirstCenter : sgObject
  • sgLP_GeoFirstPointOnSurface : sgObject
  • sgLP_GeoMapInterMBRCenter : sgObject
  • sgLP_GeoMBRCenter : sgObject
  • sgLSR_NMEA : sgObject
  • sgLSR_RTK : sgObject
  • sgLSR_Unknown : sgObject
  • sgLT3_Default : sgObject
  • sgLT3_Elevation : sgObject
  • sgLT3_Image : sgObject
  • sgLT3_Mask : sgObject
  • sgLT3_Model : sgObject
  • sgLT3_Terrain : sgObject
  • sgLT_AnnoLabel : sgObject
  • sgLT_AttrLabel : sgObject
  • sgLT_AttrShortLabel : sgObject
  • sgLT_SymbolLabel : sgObject
  • sgLT_TipLabel : sgObject
  • sgMB_LeftButton : sgObject
  • sgMB_MidButton : sgObject
  • sgMB_NoButton : sgObject
  • sgMB_RightButton : sgObject
  • sgMB_WheelButton : sgObject
  • sgME_AutoRotate : sgObject
  • sgME_FixRotate : sgObject
  • sgMM_AutoMove : sgObject
  • sgMM_ManuMove : sgObject
  • sgMM_OneOnlyMove : sgObject
  • sgNA_Bellman_ford : sgObject
  • sgNA_Bfs : sgObject
  • sgNA_Bid_dijkstra : sgObject
  • sgNA_Dfs : sgObject
  • sgNA_Dijkstra : sgObject
  • sgNA_Fm_partition : sgObject
  • sgNA_Maxflow_ff : sgObject
  • sgNA_Maxflow_pp : sgObject
  • sgNA_Maxflow_sap : sgObject
  • sgNA_Min_tree : sgObject
  • sgNA_NULL : sgObject
  • sgNA_Planarity : sgObject
  • sgNA_Ratio_cut_partition : sgObject
  • sgNA_St_number : sgObject
  • sgNM_CenterPoint : sgObject
  • sgNM_END : sgObject
  • sgNM_EndPoint : sgObject
  • sgNM_ExtensionPoint : sgObject
  • sgNM_Geometry : sgObject
  • sgNM_GPSPoint : sgObject
  • sgNM_IntersectPoint : sgObject
  • sgNM_MidPoint : sgObject
  • sgNM_NearestPoint : sgObject
  • sgNM_NodePoint : sgObject
  • sgNM_NullPoint : sgObject
  • sgNM_OrthoPoint : sgObject
  • sgNM_PerpendicularPoint : sgObject
  • sgNM_RotatePoint : sgObject
  • sgNM_ScalePoint : sgObject
  • sgNM_VertPoint : sgObject
  • sgOA_AGS : sgObject
  • sgOA_BINGMAP : sgObject
  • sgOA_DAUMMAP : sgObject
  • sgOA_GOOGLEMAP : sgObject
  • sgOA_KTMAP : sgObject
  • sgOA_NAVERMAP : sgObject
  • sgOA_TMS : sgObject
  • sgOA_VWORLD_2D : sgObject
  • sgOA_VWORLD_3D : sgObject
  • sgOA_YAHOOMAP : sgObject
  • sgPI_CMYK : sgObject
  • sgPI_Gray : sgObject
  • sgPI_HLS : sgObject
  • sgPI_RGB : sgObject
  • sgPI_YCbCr : sgObject
  • sgPL_All : sgObject
  • sgPL_EndNode : sgObject
  • sgPL_Node : sgObject
  • sgPL_StartNode : sgObject
  • sgPL_Vertex : sgObject
  • sgPT_FeatureCollectionType : sgObject
  • sgPT_FloatingPointType : sgObject
  • sgPT_GridCoverageType : sgObject
  • sgPT_IntegerType : sgObject
  • sgPT_StringType : sgObject
  • sgRP_RESTART : sgObject
  • sgRP_REVERSE : sgObject
  • sgRS_Compass : sgObject
  • sgRS_Default : sgObject
  • sgRS_IndexMapWidget : sgObject
  • sgRS_Location : sgObject
  • sgRS_LocationBtn : sgObject
  • sgRS_Logo : sgObject
  • sgRS_MapCtrlWidget : sgObject
  • sgRS_MotionBtn : sgObject
  • sgRS_Scale : sgObject
  • sgRS_ScaleBar : sgObject
  • sgRS_StartBuffer : sgObject
  • sgRS_ZoomLevelWidget : sgObject
  • sgRT_Chart : sgObject
  • sgRT_Graph : sgObject
  • sgRT_UserDefine : sgObject
  • sgSD_ArcSDE : sgObject
  • sgSD_Geomedia : sgObject
  • sgSD_Smallworld : sgObject
  • sgSD_SpatialDBBlob : sgObject
  • sgSD_WKB : sgObject
  • sgSD_WKT : sgObject
  • sgSDT_Byte : sgObject
  • sgSDT_CFloat32 : sgObject
  • sgSDT_CFloat64 : sgObject
  • sgSDT_CInt16 : sgObject
  • sgSDT_CInt32 : sgObject
  • sgSDT_Float32 : sgObject
  • sgSDT_Float64 : sgObject
  • sgSDT_Int16 : sgObject
  • sgSDT_Int32 : sgObject
  • sgSDT_UInt16 : sgObject
  • sgSDT_UInt32 : sgObject
  • sgSDT_Unknown : sgObject
  • sgSK_0 : sgObject
  • sgSK_1 : sgObject
  • sgSK_2 : sgObject
  • sgSK_3 : sgObject
  • sgSK_4 : sgObject
  • sgSK_5 : sgObject
  • sgSK_6 : sgObject
  • sgSK_7 : sgObject
  • sgSK_8 : sgObject
  • sgSK_9 : sgObject
  • sgSK_Back : sgObject
  • sgSK_Camera : sgObject
  • sgSK_Control : sgObject
  • sgSK_Delete : sgObject
  • sgSK_Down : sgObject
  • sgSK_End : sgObject
  • sgSK_Enter : sgObject
  • sgSK_Escape : sgObject
  • sgSK_Hash : sgObject
  • sgSK_Home : sgObject
  • sgSK_KeyCount : sgObject
  • sgSK_Left : sgObject
  • sgSK_LeftSoftKey : sgObject
  • sgSK_NONE : sgObject
  • sgSK_Power : sgObject
  • sgSK_Right : sgObject
  • sgSK_RightSoftKey : sgObject
  • sgSK_Send : sgObject
  • sgSK_Shift : sgObject
  • sgSK_Star : sgObject
  • sgSK_Up : sgObject
  • sgSK_VolDown : sgObject
  • sgSK_VolUp : sgObject
  • sgSL_Default : sgObject
  • sgSL_Label : sgObject
  • sgSL_Line : sgObject
  • sgSL_Point : sgObject
  • sgSL_Polygon : sgObject
  • sgSM_AnnotationEndMove : sgObject
  • sgSM_AnnotationMove : sgObject
  • sgSM_AnnotationRotate : sgObject
  • sgSM_AreaMode : sgObject
  • sgSM_AutoPanningMode : sgObject
  • sgSM_DistanceMode : sgObject
  • sgSM_EditBreakGeometryMode : sgObject
  • sgSM_EditBreakMode : sgObject
  • sgSM_EditCopyMode : sgObject
  • sgSM_EditDeleteMode : sgObject
  • sgSM_EditDeleteRingMode : sgObject
  • sgSM_EditExtendMode : sgObject
  • sgSM_EditMoveMode : sgObject
  • sgSM_EditRotateMode : sgObject
  • sgSM_EditScaleMode : sgObject
  • sgSM_EditTrimMode : sgObject
  • sgSM_EditVertexAddMode : sgObject
  • sgSM_EditVertexDeleteMode : sgObject
  • sgSM_EditVertexMoveMode : sgObject
  • sgSM_End : sgObject
  • sgSM_InsertCircleMode : sgObject
  • sgSM_InsertFreelineMode : sgObject
  • sgSM_InsertPolygonMode : sgObject
  • sgSM_InsertPolylineMode : sgObject
  • sgSM_InsertRectangleMode : sgObject
  • sgSM_InsertRingMode : sgObject
  • sgSM_InsertSymbolMode : sgObject
  • sgSM_InsertTextMode : sgObject
  • sgSM_NullMode : sgObject
  • sgSM_PanningMode : sgObject
  • sgSM_PointGridMode : sgObject
  • sgSM_SelectCircleMode : sgObject
  • sgSM_SelectGeometryMode : sgObject
  • sgSM_SelectKeepCircleMode : sgObject
  • sgSM_SelectMode : sgObject
  • sgSM_SelectPolygonMode : sgObject
  • sgSM_SelectPolylineMode : sgObject
  • sgSM_SightMode : sgObject
  • sgSM_SingPostMode : sgObject
  • sgSM_StartBuffer : sgObject
  • sgSM_TerrainProfileMode : sgObject
  • sgSM_VolumeMode : sgObject
  • sgSM_ZoomInAreaMode : sgObject
  • sgSM_ZoomInMode : sgObject
  • sgSM_ZoomOutAreaMode : sgObject
  • sgSM_ZoomOutMode : sgObject
  • sgSO_Contains : sgObject
  • sgSO_Crosses : sgObject
  • sgSO_Disjoint : sgObject
  • sgSO_Equals : sgObject
  • sgSO_Intersects : sgObject
  • sgSO_Overlaps : sgObject
  • sgSO_Touches : sgObject
  • sgSO_Within : sgObject
  • sgSR_Location : sgObject
  • sgSR_Motion : sgObject
  • sgSR_Video : sgObject
  • sgST_Image : sgObject
  • sgST_Unknown : sgObject
  • sgST_Vector : sgObject
  • sgSym_AreaLine : sgObject
  • sgSym_Count : sgObject
  • sgSym_DistanceLine : sgObject
  • sgSym_MagnifyBox : sgObject
  • sgSym_MeasureBText : sgObject
  • sgSym_MeasureText : sgObject
  • sgSym_MeasureVertex : sgObject
  • sgSym_MovingGeom : sgObject
  • sgSym_SnapGrid : sgObject
  • sgSym_SnapLine : sgObject
  • sgSym_TempGeom : sgObject
  • sgSym_TooltipBox : sgObject
  • sgSym_TooltipText : sgObject
  • sgSym_ZoomLine : sgObject
  • sgTB_Edit : sgObject
  • sgTB_EditVertex : sgObject
  • sgTB_End : sgObject
  • sgTB_LayerAdd : sgObject
  • sgTB_MapDiz : sgObject
  • sgTB_MapMeasure : sgObject
  • sgTB_MapNav : sgObject
  • sgTB_MapSelect : sgObject
  • sgTB_PrintExport : sgObject
  • sgTB_PrintFile : sgObject
  • sgTB_PrintItem : sgObject
  • sgTB_PrintLayout : sgObject
  • sgTB_PrintView : sgObject
  • sgTB_RasterProcess : sgObject
  • sgTB_SnapProperties : sgObject
  • sgTB_VectorGeomProcess : sgObject
  • sgTB_VectorProcess : sgObject
  • sgTB_View : sgObject
  • sgTI_EASE_IN : sgObject
  • sgTI_EASE_IN_OUT : sgObject
  • sgTI_EASE_OUT : sgObject
  • sgTN_AutoCommit : sgObject
  • sgTN_ManualCommit : sgObject
  • sgTN_UnBind : sgObject
  • sgTP_East : sgObject
  • sgTP_North : sgObject
  • sgTP_South : sgObject
  • sgTP_West : sgObject
  • sgTR_BACK : sgObject
  • sgTR_BOUNCE : sgObject
  • sgTR_CIRC : sgObject
  • sgTR_CUBIC : sgObject
  • sgTR_ELASTIC : sgObject
  • sgTR_EXPO : sgObject
  • sgTR_LINEAR : sgObject
  • sgTR_QUAD : sgObject
  • sgTR_QUART : sgObject
  • sgTR_QUINT : sgObject
  • sgTR_SINE : sgObject
  • sgTS_ComplexSymbolVertexStand : sgObject
  • sgTS_Node2Node : sgObject
  • sgTS_Node2Symbol : sgObject
  • sgTS_Node2Vertex : sgObject
  • sgTS_None : sgObject
  • sgTS_Symbol2Node : sgObject
  • sgTS_Symbol2Symbol : sgObject
  • sgTS_Symbol2Vertex : sgObject
  • sgTS_Vertex2Node : sgObject
  • sgTS_Vertex2Symbol : sgObject
  • sgTS_Vertex2Vertex : sgObject
  • sgVT_Above : sgObject
  • sgVT_Below : sgObject
  • sgVT_Bool : sgObject
  • sgVT_Double : sgObject
  • sgVT_Float : sgObject
  • sgVT_Handle : sgObject
  • sgVT_Int : sgObject
  • sgVT_Long : sgObject
  • sgVT_None : sgObject
  • sgVT_Short : sgObject
  • sgVT_String : sgObject
  • sgWS_Default : sgObject
  • sgWS_GWFS : sgObject
  • sgWS_LTM : sgObject
  • sgWS_OpenAPI : sgObject
  • sgWS_WFS : sgObject
  • sgWS_WMS : sgObject
  • SightModeEnum : sgObject
  • SnapModeEnum : sgObject
  • SpatialDataTypeEnum : sgObject
  • SpatialOperatorEnum : sgObject
  • SymbolizerTypeEnum : sgObject
  • SymbolTypeEnum : sgObject
  • SystemKeyEnum : sgObject
  • SystemResourceEnum : sgObject
  • SystemSymbolEnum : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
다음은 모든 네임스페이스 멤버들의 목록입니다. 각 멤버들은 해당 멤버의 네임스페이스 문서화 페이지의 링크를 가지고 있습니다. :

- t -

  • TapPositionEnum : sgObject
  • TimingModeEnum : sgObject
  • ToolBarTypeEnum : sgObject
  • TopoSyncMoveEnum : sgObject
  • TransactionEnum : sgObject
  • TransitionModeEnum : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
다음은 모든 네임스페이스 멤버들의 목록입니다. 각 멤버들은 해당 멤버의 네임스페이스 문서화 페이지의 링크를 가지고 있습니다. :

- v -

  • VariantTypeEnum : sgObject
  • VolumeTypeEnum : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
다음은 모든 네임스페이스 멤버들의 목록입니다. 각 멤버들은 해당 멤버의 네임스페이스 문서화 페이지의 링크를 가지고 있습니다. :

- w -

  • WebServerTypeEnum : sgObject
  • WebServiceTypeEnum : sgObject
  • wkbCircularString : sgObject
  • wkbCircularStringM : sgObject
  • wkbCircularStringZ : sgObject
  • wkbCircularStringZM : sgObject
  • wkbCompoundCurve : sgObject
  • wkbCompoundCurveM : sgObject
  • wkbCompoundCurveZ : sgObject
  • wkbCompoundCurveZM : sgObject
  • wkbCurve : sgObject
  • wkbCurveM : sgObject
  • wkbCurvePolygon : sgObject
  • wkbCurvePolygonM : sgObject
  • wkbCurvePolygonZ : sgObject
  • wkbCurvePolygonZM : sgObject
  • wkbCurveZ : sgObject
  • wkbCurveZM : sgObject
  • wkbGeometryCollection : sgObject
  • wkbGeometryCollection25D : sgObject
  • wkbGeometryCollectionM : sgObject
  • wkbGeometryCollectionZM : sgObject
  • wkbLinearRing : sgObject
  • wkbLineString : sgObject
  • wkbLineString25D : sgObject
  • wkbLineStringM : sgObject
  • wkbLineStringZM : sgObject
  • wkbMultiCurve : sgObject
  • wkbMultiCurveM : sgObject
  • wkbMultiCurveZ : sgObject
  • wkbMultiCurveZM : sgObject
  • wkbMultiLineString : sgObject
  • wkbMultiLineString25D : sgObject
  • wkbMultiLineStringM : sgObject
  • wkbMultiLineStringZM : sgObject
  • wkbMultiPoint : sgObject
  • wkbMultiPoint25D : sgObject
  • wkbMultiPointM : sgObject
  • wkbMultiPointZM : sgObject
  • wkbMultiPolygon : sgObject
  • wkbMultiPolygon25D : sgObject
  • wkbMultiPolygonM : sgObject
  • wkbMultiPolygonZM : sgObject
  • wkbMultiSurface : sgObject
  • wkbMultiSurfaceM : sgObject
  • wkbMultiSurfaceZ : sgObject
  • wkbMultiSurfaceZM : sgObject
  • wkbNone : sgObject
  • wkbPoint : sgObject
  • wkbPoint25D : sgObject
  • wkbPointM : sgObject
  • wkbPointZM : sgObject
  • wkbPolygon : sgObject
  • wkbPolygon25D : sgObject
  • wkbPolygonM : sgObject
  • wkbPolygonZM : sgObject
  • wkbPolyhedralSurface : sgObject
  • wkbPolyhedralSurfaceM : sgObject
  • wkbPolyhedralSurfaceZ : sgObject
  • wkbPolyhedralSurfaceZM : sgObject
  • wkbSurface : sgObject
  • wkbSurfaceM : sgObject
  • wkbSurfaceZ : sgObject
  • wkbSurfaceZM : sgObject
  • wkbTIN : sgObject
  • wkbTINM : sgObject
  • wkbTINZ : sgObject
  • wkbTINZM : sgObject
  • wkbTriangle : sgObject
  • wkbTriangleM : sgObject
  • wkbTriangleZ : sgObject
  • wkbTriangleZM : sgObject
  • wkbUnknown : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • importlib() : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • v
  • w

- a -

  • AccessModeEnum : sgObject
  • AlignPositionEnum : sgObject

- c -

  • ChartTypeEnum : sgObject
  • ColorInterpretationEnum : sgObject
  • CursorEnum : sgObject

- d -

  • DiagramTypeEnum : sgObject
  • Draw3DTypeEnum : sgObject

- e -

  • EditedTypeEnum : sgObject

- f -

  • FeatureTypeStyleEnum : sgObject
  • FileFormatEnum : sgObject
  • FilterTypeEnum : sgObject

- g -

  • GeometryTypeEnum : sgObject
  • GraphTypeEnum : sgObject
  • GridColorTypeEnum : sgObject

- h -

  • HitObjectTypeEnum : sgObject

- l -

  • LabelPositionTypeEnum : sgObject
  • LabelTypeEnum : sgObject
  • LineCapEnum : sgObject
  • LineJoinEnum : sgObject
  • LocationSensorTypeEnum : sgObject

- m -

  • MapMoveEnum : sgObject
  • MapRotateEnum : sgObject
  • MouseButtonTypeEnum : sgObject

- o -

  • OGRErr : sgObject

- p -

  • PaletteInterpretationEnum : sgObject
  • ParameterType : sgObject
  • PointLocationEnum : sgObject

- r -

  • RepeatModeEnum : sgObject

- s -

  • SampleDimensionTypeEnum : sgObject
  • ScreenModeEnum : sgObject
  • SensorTypeEnum : sgObject
  • SightModeEnum : sgObject
  • SnapModeEnum : sgObject
  • SpatialDataTypeEnum : sgObject
  • SpatialOperatorEnum : sgObject
  • SymbolizerTypeEnum : sgObject
  • SymbolTypeEnum : sgObject
  • SystemKeyEnum : sgObject
  • SystemResourceEnum : sgObject
  • SystemSymbolEnum : sgObject

- t -

  • TimingModeEnum : sgObject
  • TopoSyncMoveEnum : sgObject
  • TransactionEnum : sgObject
  • TransitionModeEnum : sgObject

- v -

  • VariantTypeEnum : sgObject
  • VolumeTypeEnum : sgObject

- w -

  • WebServerTypeEnum : sgObject
  • WebServiceTypeEnum : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w

- a -

  • AccessModeEnum : sgObject
  • AlignPositionEnum : sgObject

- c -

  • Camera3DModeEnum : sgObject
  • CanvasTypeEnum : sgObject
  • ChartTypeEnum : sgObject
  • ColorInterpretationEnum : sgObject
  • CursorEnum : sgObject

- d -

  • DiagramTypeEnum : sgObject
  • DockAreaEnum : sgObject
  • DockFeatureEnum : sgObject
  • Draw3DTypeEnum : sgObject

- e -

  • EditActionTypeEnum : sgObject
  • EditedTypeEnum : sgObject

- f -

  • FeatureTypeStyleEnum : sgObject
  • FileFormatEnum : sgObject
  • FilterTypeEnum : sgObject

- g -

  • GeometryTypeEnum : sgObject
  • GraphTypeEnum : sgObject
  • GridColorTypeEnum : sgObject

- h -

  • HitObjectTypeEnum : sgObject

- l -

  • LabelPositionTypeEnum : sgObject
  • LabelTypeEnum : sgObject
  • LayerType3DEnum : sgObject
  • LineCapEnum : sgObject
  • LineJoinEnum : sgObject
  • LocationSensorTypeEnum : sgObject

- m -

  • MapMoveEnum : sgObject
  • MapRotateEnum : sgObject
  • MouseButtonTypeEnum : sgObject

- n -

  • NetworkAlgorithmEnum : sgObject

- o -

  • OGRFieldType : sgObject
  • OGRwkbGeometryType : sgObject

- p -

  • PaletteInterpretationEnum : sgObject
  • ParameterType : sgObject
  • PointLocationEnum : sgObject

- r -

  • RepeatModeEnum : sgObject

- s -

  • SampleDimensionTypeEnum : sgObject
  • ScreenModeEnum : sgObject
  • SensorTypeEnum : sgObject
  • SightModeEnum : sgObject
  • SnapModeEnum : sgObject
  • SpatialDataTypeEnum : sgObject
  • SpatialOperatorEnum : sgObject
  • SymbolizerTypeEnum : sgObject
  • SymbolTypeEnum : sgObject
  • SystemKeyEnum : sgObject
  • SystemResourceEnum : sgObject
  • SystemSymbolEnum : sgObject

- t -

  • TapPositionEnum : sgObject
  • TimingModeEnum : sgObject
  • ToolBarTypeEnum : sgObject
  • TopoSyncMoveEnum : sgObject
  • TransactionEnum : sgObject
  • TransitionModeEnum : sgObject

- v -

  • VariantTypeEnum : sgObject
  • VolumeTypeEnum : sgObject

- w -

  • WebServerTypeEnum : sgObject
  • WebServiceTypeEnum : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • o
  • s
  • w

- o -

  • OFTBinary : sgObject
  • OFTDate : sgObject
  • OFTDateTime : sgObject
  • OFTInteger : sgObject
  • OFTInteger64 : sgObject
  • OFTInteger64List : sgObject
  • OFTIntegerList : sgObject
  • OFTMaxType : sgObject
  • OFTReal : sgObject
  • OFTRealList : sgObject
  • OFTString : sgObject
  • OFTStringList : sgObject
  • OFTTime : sgObject
  • OFTWideString : sgObject
  • OFTWideStringList : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • o
  • s
  • w

- s -

  • sg3DT_Auto : sgObject
  • sg3DT_Box : sgObject
  • sg3DT_Capsule : sgObject
  • sg3DT_Cone : sgObject
  • sg3DT_Cylinder : sgObject
  • sg3DT_Geometry : sgObject
  • sg3DT_Polygon : sgObject
  • sg3DT_Sphere : sgObject
  • sgAC_Circle : sgObject
  • sgAC_End : sgObject
  • sgAC_Free : sgObject
  • sgAC_Line : sgObject
  • sgAC_Point : sgObject
  • sgAC_Polygon : sgObject
  • sgAC_Rectangle : sgObject
  • sgAM_Create : sgObject
  • sgAM_CreateCopy : sgObject
  • sgAM_Delete : sgObject
  • sgAM_Open : sgObject
  • sgAP_BottomCenter : sgObject
  • sgAP_BottomLeft : sgObject
  • sgAP_BottomRight : sgObject
  • sgAP_CenterCenter : sgObject
  • sgAP_CenterLeft : sgObject
  • sgAP_CenterRight : sgObject
  • sgAP_None : sgObject
  • sgAP_TopCenter : sgObject
  • sgAP_TopLeft : sgObject
  • sgAP_TopRight : sgObject
  • sgCI_AlphaBand : sgObject
  • sgCI_BlackBand : sgObject
  • sgCI_BlueBand : sgObject
  • sgCI_CyanBand : sgObject
  • sgCI_GrayIndex : sgObject
  • sgCI_GreenBand : sgObject
  • sgCI_HueBand : sgObject
  • sgCI_LightnessBand : sgObject
  • sgCI_MagentaBand : sgObject
  • sgCI_PaletteIndex : sgObject
  • sgCI_RedBand : sgObject
  • sgCI_SaturationBand : sgObject
  • sgCI_Undefined : sgObject
  • sgCI_YCbCr_CbBand : sgObject
  • sgCI_YCbCr_CrBand : sgObject
  • sgCI_YCbCr_YBand : sgObject
  • sgCI_YellowBand : sgObject
  • sgCM3_Eye : sgObject
  • sgCM3_Focal : sgObject
  • sgCS_AnnoEndMove : sgObject
  • sgCS_AnnoMove : sgObject
  • sgCS_AnnoRotate : sgObject
  • sgCS_EditBreak : sgObject
  • sgCS_EditExtend : sgObject
  • sgCS_EditTrim : sgObject
  • sgCS_End : sgObject
  • sgCS_MapInsert : sgObject
  • sgCS_MapSelectObject : sgObject
  • sgCS_MapZoomIn : sgObject
  • sgCS_MapZoomOut : sgObject
  • sgCS_MapZoomPan : sgObject
  • sgCS_Null : sgObject
  • sgCS_VertexAdd : sgObject
  • sgCS_VertexDelete : sgObject
  • sgCS_VertexMove : sgObject
  • sgCT_2D : sgObject
  • sgCT_2DPIE : sgObject
  • sgCT_3D : sgObject
  • sgCT_3DAREA : sgObject
  • sgCT_3DBAR : sgObject
  • sgCT_3DCOMBO_HLC_AREA : sgObject
  • sgCT_3DCOMBO_HLC_BAR : sgObject
  • sgCT_3DCOMBO_LINE_AREA : sgObject
  • sgCT_3DCOMBO_LINE_BAR : sgObject
  • sgCT_3DCOMBO_LINE_LINE : sgObject
  • sgCT_3DFLOATINGBAR : sgObject
  • sgCT_3DHILOCLOSE : sgObject
  • sgCT_3DLINE : sgObject
  • sgCT_3DPIE : sgObject
  • sgCT_AR : sgObject
  • sgCT_AREA : sgObject
  • sgCT_BAR : sgObject
  • sgCT_COMBO_HLC_AREA : sgObject
  • sgCT_COMBO_HLC_BAR : sgObject
  • sgCT_COMBO_LINE_AREA : sgObject
  • sgCT_COMBO_LINE_BAR : sgObject
  • sgCT_COMBO_LINE_LINE : sgObject
  • sgCT_EARTH : sgObject
  • sgCT_FLOATINGBAR : sgObject
  • sgCT_GRAPHIC : sgObject
  • sgCT_HILOCLOSE : sgObject
  • sgCT_LINE : sgObject
  • sgCT_NULL : sgObject
  • sgDA_All : sgObject
  • sgDA_Bottom : sgObject
  • sgDA_Central : sgObject
  • sgDA_Left : sgObject
  • sgDA_No : sgObject
  • sgDA_Right : sgObject
  • sgDA_Top : sgObject
  • sgDF_AllFeature : sgObject
  • sgDF_Closable : sgObject
  • sgDF_FeatureMask : sgObject
  • sgDF_Floatable : sgObject
  • sgDF_Movable : sgObject
  • sgDF_NoFeatures : sgObject
  • sgDF_Reserved : sgObject
  • sgDF_VerticalTitleBar : sgObject
  • sgET_Delete : sgObject
  • sgET_Insert : sgObject
  • sgET_Null : sgObject
  • sgET_Update : sgObject
  • sgFF_DB_Altibase : sgObject
  • sgFF_DB_CUBRID : sgObject
  • sgFF_DB_DB2 : sgObject
  • sgFF_DB_INFORMIX : sgObject
  • sgFF_DB_Kairos : sgObject
  • sgFF_DB_MYSQL : sgObject
  • sgFF_DB_ORACLE : sgObject
  • sgFF_DB_POSTGIS : sgObject
  • sgFF_DB_RDBMS : sgObject
  • sgFF_DB_SQLSERVER : sgObject
  • sgFF_DB_Tibero : sgObject
  • sgFF_DB_ZEUS : sgObject
  • sgFF_GIS_CSV : sgObject
  • sgFF_GIS_DGN : sgObject
  • sgFF_GIS_DWG : sgObject
  • sgFF_GIS_DXF : sgObject
  • sgFF_GIS_GEOJSON : sgObject
  • sgFF_GIS_GML : sgObject
  • sgFF_GIS_GPX : sgObject
  • sgFF_GIS_KML : sgObject
  • sgFF_GIS_S57 : sgObject
  • sgFF_GIS_SHP : sgObject
  • sgFF_GIS_TAB : sgObject
  • sgFF_IMG_BMP : sgObject
  • sgFF_IMG_GIF : sgObject
  • sgFF_IMG_JPG : sgObject
  • sgFF_IMG_PNG : sgObject
  • sgFF_IMG_TIF : sgObject
  • sgFF_IMG_UNKNOWN : sgObject
  • sgFS_Default : sgObject
  • sgFS_GridDefault : sgObject
  • sgFS_GridFreakOut : sgObject
  • sgFS_GridPseudo : sgObject
  • sgFS_GridRamp : sgObject
  • sgFT_BLUR : sgObject
  • sgFT_BRIGHTNESS : sgObject
  • sgFT_CONTRAST : sgObject
  • sgFT_DROP_SHADOW : sgObject
  • sgFT_FILTER_TYPE_LAST : sgObject
  • sgFT_GRAYSCALE : sgObject
  • sgFT_HUE_ROTATE : sgObject
  • sgFT_INVERT : sgObject
  • sgFT_OPACITY : sgObject
  • sgFT_SATURATE : sgObject
  • sgFT_SEPIA : sgObject
  • sgFT_Unknown : sgObject
  • sgGC_Discrete : sgObject
  • sgGC_Exact : sgObject
  • sgGC_Interpolated : sgObject
  • sgGT_dot : sgObject
  • sgGT_dotty : sgObject
  • sgGT_GeometryCollection : sgObject
  • sgGT_GeometryCollection25D : sgObject
  • sgGT_lefty : sgObject
  • sgGT_LinearRing : sgObject
  • sgGT_LineString : sgObject
  • sgGT_LineString25D : sgObject
  • sgGT_MultiLineString : sgObject
  • sgGT_MultiLineString25D : sgObject
  • sgGT_MultiPoint : sgObject
  • sgGT_MultiPoint25D : sgObject
  • sgGT_MultiPolygon : sgObject
  • sgGT_MultiPolygon25D : sgObject
  • sgGT_neato : sgObject
  • sgGT_None : sgObject
  • sgGT_Point : sgObject
  • sgGT_Point25D : sgObject
  • sgGT_Polygon : sgObject
  • sgGT_Polygon25D : sgObject
  • sgGT_Unknown : sgObject
  • sgHT_All : sgObject
  • sgHT_AnnoLabel : sgObject
  • sgHT_AnnoLine : sgObject
  • sgHT_AttrLabel : sgObject
  • sgHT_Geometry : sgObject
  • sgHT_Unknown : sgObject
  • sgIM_LinearLine : sgObject
  • sgIM_PolyhedralLine : sgObject
  • sgIM_RadialLine : sgObject
  • sgLC_AnchorMask : sgObject
  • sgLC_ArrowAnchor : sgObject
  • sgLC_ArrowAnchor1 : sgObject
  • sgLC_ArrowAnchor2 : sgObject
  • sgLC_Custom : sgObject
  • sgLC_DiamondAnchor : sgObject
  • sgLC_Flat : sgObject
  • sgLC_NoAnchor : sgObject
  • sgLC_Round : sgObject
  • sgLC_RoundAnchor : sgObject
  • sgLC_Square : sgObject
  • sgLC_SquareAnchor : sgObject
  • sgLC_Triangle : sgObject
  • sgLJ_Bevel : sgObject
  • sgLJ_Mitre : sgObject
  • sgLJ_Round : sgObject
  • sgLP_GeoFirstCenter : sgObject
  • sgLP_GeoFirstPointOnSurface : sgObject
  • sgLP_GeoMapInterMBRCenter : sgObject
  • sgLP_GeoMBRCenter : sgObject
  • sgLSR_NMEA : sgObject
  • sgLSR_RTK : sgObject
  • sgLSR_Unknown : sgObject
  • sgLT3_Default : sgObject
  • sgLT3_Elevation : sgObject
  • sgLT3_Image : sgObject
  • sgLT3_Mask : sgObject
  • sgLT3_Model : sgObject
  • sgLT3_Terrain : sgObject
  • sgLT_AnnoLabel : sgObject
  • sgLT_AttrLabel : sgObject
  • sgLT_AttrShortLabel : sgObject
  • sgLT_SymbolLabel : sgObject
  • sgLT_TipLabel : sgObject
  • sgMB_LeftButton : sgObject
  • sgMB_MidButton : sgObject
  • sgMB_NoButton : sgObject
  • sgMB_RightButton : sgObject
  • sgMB_WheelButton : sgObject
  • sgME_AutoRotate : sgObject
  • sgME_FixRotate : sgObject
  • sgMM_AutoMove : sgObject
  • sgMM_ManuMove : sgObject
  • sgMM_OneOnlyMove : sgObject
  • sgNA_Bellman_ford : sgObject
  • sgNA_Bfs : sgObject
  • sgNA_Bid_dijkstra : sgObject
  • sgNA_Dfs : sgObject
  • sgNA_Dijkstra : sgObject
  • sgNA_Fm_partition : sgObject
  • sgNA_Maxflow_ff : sgObject
  • sgNA_Maxflow_pp : sgObject
  • sgNA_Maxflow_sap : sgObject
  • sgNA_Min_tree : sgObject
  • sgNA_NULL : sgObject
  • sgNA_Planarity : sgObject
  • sgNA_Ratio_cut_partition : sgObject
  • sgNA_St_number : sgObject
  • sgNM_CenterPoint : sgObject
  • sgNM_END : sgObject
  • sgNM_EndPoint : sgObject
  • sgNM_ExtensionPoint : sgObject
  • sgNM_Geometry : sgObject
  • sgNM_GPSPoint : sgObject
  • sgNM_IntersectPoint : sgObject
  • sgNM_MidPoint : sgObject
  • sgNM_NearestPoint : sgObject
  • sgNM_NodePoint : sgObject
  • sgNM_NullPoint : sgObject
  • sgNM_OrthoPoint : sgObject
  • sgNM_PerpendicularPoint : sgObject
  • sgNM_RotatePoint : sgObject
  • sgNM_ScalePoint : sgObject
  • sgNM_VertPoint : sgObject
  • sgOA_AGS : sgObject
  • sgOA_BINGMAP : sgObject
  • sgOA_DAUMMAP : sgObject
  • sgOA_GOOGLEMAP : sgObject
  • sgOA_KTMAP : sgObject
  • sgOA_NAVERMAP : sgObject
  • sgOA_TMS : sgObject
  • sgOA_VWORLD_2D : sgObject
  • sgOA_VWORLD_3D : sgObject
  • sgOA_YAHOOMAP : sgObject
  • sgPI_CMYK : sgObject
  • sgPI_Gray : sgObject
  • sgPI_HLS : sgObject
  • sgPI_RGB : sgObject
  • sgPI_YCbCr : sgObject
  • sgPL_All : sgObject
  • sgPL_EndNode : sgObject
  • sgPL_Node : sgObject
  • sgPL_StartNode : sgObject
  • sgPL_Vertex : sgObject
  • sgPT_FeatureCollectionType : sgObject
  • sgPT_FloatingPointType : sgObject
  • sgPT_GridCoverageType : sgObject
  • sgPT_IntegerType : sgObject
  • sgPT_StringType : sgObject
  • sgRP_RESTART : sgObject
  • sgRP_REVERSE : sgObject
  • sgRS_Compass : sgObject
  • sgRS_Default : sgObject
  • sgRS_IndexMapWidget : sgObject
  • sgRS_Location : sgObject
  • sgRS_LocationBtn : sgObject
  • sgRS_Logo : sgObject
  • sgRS_MapCtrlWidget : sgObject
  • sgRS_MotionBtn : sgObject
  • sgRS_Scale : sgObject
  • sgRS_ScaleBar : sgObject
  • sgRS_StartBuffer : sgObject
  • sgRS_ZoomLevelWidget : sgObject
  • sgRT_Chart : sgObject
  • sgRT_Graph : sgObject
  • sgRT_UserDefine : sgObject
  • sgSD_ArcSDE : sgObject
  • sgSD_Geomedia : sgObject
  • sgSD_Smallworld : sgObject
  • sgSD_SpatialDBBlob : sgObject
  • sgSD_WKB : sgObject
  • sgSD_WKT : sgObject
  • sgSDT_Byte : sgObject
  • sgSDT_CFloat32 : sgObject
  • sgSDT_CFloat64 : sgObject
  • sgSDT_CInt16 : sgObject
  • sgSDT_CInt32 : sgObject
  • sgSDT_Float32 : sgObject
  • sgSDT_Float64 : sgObject
  • sgSDT_Int16 : sgObject
  • sgSDT_Int32 : sgObject
  • sgSDT_UInt16 : sgObject
  • sgSDT_UInt32 : sgObject
  • sgSDT_Unknown : sgObject
  • sgSK_0 : sgObject
  • sgSK_1 : sgObject
  • sgSK_2 : sgObject
  • sgSK_3 : sgObject
  • sgSK_4 : sgObject
  • sgSK_5 : sgObject
  • sgSK_6 : sgObject
  • sgSK_7 : sgObject
  • sgSK_8 : sgObject
  • sgSK_9 : sgObject
  • sgSK_Back : sgObject
  • sgSK_Camera : sgObject
  • sgSK_Control : sgObject
  • sgSK_Delete : sgObject
  • sgSK_Down : sgObject
  • sgSK_End : sgObject
  • sgSK_Enter : sgObject
  • sgSK_Escape : sgObject
  • sgSK_Hash : sgObject
  • sgSK_Home : sgObject
  • sgSK_KeyCount : sgObject
  • sgSK_Left : sgObject
  • sgSK_LeftSoftKey : sgObject
  • sgSK_NONE : sgObject
  • sgSK_Power : sgObject
  • sgSK_Right : sgObject
  • sgSK_RightSoftKey : sgObject
  • sgSK_Send : sgObject
  • sgSK_Shift : sgObject
  • sgSK_Star : sgObject
  • sgSK_Up : sgObject
  • sgSK_VolDown : sgObject
  • sgSK_VolUp : sgObject
  • sgSL_Default : sgObject
  • sgSL_Label : sgObject
  • sgSL_Line : sgObject
  • sgSL_Point : sgObject
  • sgSL_Polygon : sgObject
  • sgSM_AnnotationEndMove : sgObject
  • sgSM_AnnotationMove : sgObject
  • sgSM_AnnotationRotate : sgObject
  • sgSM_AreaMode : sgObject
  • sgSM_AutoPanningMode : sgObject
  • sgSM_DistanceMode : sgObject
  • sgSM_EditBreakGeometryMode : sgObject
  • sgSM_EditBreakMode : sgObject
  • sgSM_EditCopyMode : sgObject
  • sgSM_EditDeleteMode : sgObject
  • sgSM_EditDeleteRingMode : sgObject
  • sgSM_EditExtendMode : sgObject
  • sgSM_EditMoveMode : sgObject
  • sgSM_EditRotateMode : sgObject
  • sgSM_EditScaleMode : sgObject
  • sgSM_EditTrimMode : sgObject
  • sgSM_EditVertexAddMode : sgObject
  • sgSM_EditVertexDeleteMode : sgObject
  • sgSM_EditVertexMoveMode : sgObject
  • sgSM_End : sgObject
  • sgSM_InsertCircleMode : sgObject
  • sgSM_InsertFreelineMode : sgObject
  • sgSM_InsertPolygonMode : sgObject
  • sgSM_InsertPolylineMode : sgObject
  • sgSM_InsertRectangleMode : sgObject
  • sgSM_InsertRingMode : sgObject
  • sgSM_InsertSymbolMode : sgObject
  • sgSM_InsertTextMode : sgObject
  • sgSM_NullMode : sgObject
  • sgSM_PanningMode : sgObject
  • sgSM_PointGridMode : sgObject
  • sgSM_SelectCircleMode : sgObject
  • sgSM_SelectGeometryMode : sgObject
  • sgSM_SelectKeepCircleMode : sgObject
  • sgSM_SelectMode : sgObject
  • sgSM_SelectPolygonMode : sgObject
  • sgSM_SelectPolylineMode : sgObject
  • sgSM_SightMode : sgObject
  • sgSM_SingPostMode : sgObject
  • sgSM_StartBuffer : sgObject
  • sgSM_TerrainProfileMode : sgObject
  • sgSM_VolumeMode : sgObject
  • sgSM_ZoomInAreaMode : sgObject
  • sgSM_ZoomInMode : sgObject
  • sgSM_ZoomOutAreaMode : sgObject
  • sgSM_ZoomOutMode : sgObject
  • sgSO_Contains : sgObject
  • sgSO_Crosses : sgObject
  • sgSO_Disjoint : sgObject
  • sgSO_Equals : sgObject
  • sgSO_Intersects : sgObject
  • sgSO_Overlaps : sgObject
  • sgSO_Touches : sgObject
  • sgSO_Within : sgObject
  • sgSR_Location : sgObject
  • sgSR_Motion : sgObject
  • sgSR_Video : sgObject
  • sgST_Image : sgObject
  • sgST_Unknown : sgObject
  • sgST_Vector : sgObject
  • sgSym_AreaLine : sgObject
  • sgSym_Count : sgObject
  • sgSym_DistanceLine : sgObject
  • sgSym_MagnifyBox : sgObject
  • sgSym_MeasureBText : sgObject
  • sgSym_MeasureText : sgObject
  • sgSym_MeasureVertex : sgObject
  • sgSym_MovingGeom : sgObject
  • sgSym_SnapGrid : sgObject
  • sgSym_SnapLine : sgObject
  • sgSym_TempGeom : sgObject
  • sgSym_TooltipBox : sgObject
  • sgSym_TooltipText : sgObject
  • sgSym_ZoomLine : sgObject
  • sgTB_Edit : sgObject
  • sgTB_EditVertex : sgObject
  • sgTB_End : sgObject
  • sgTB_LayerAdd : sgObject
  • sgTB_MapDiz : sgObject
  • sgTB_MapMeasure : sgObject
  • sgTB_MapNav : sgObject
  • sgTB_MapSelect : sgObject
  • sgTB_PrintExport : sgObject
  • sgTB_PrintFile : sgObject
  • sgTB_PrintItem : sgObject
  • sgTB_PrintLayout : sgObject
  • sgTB_PrintView : sgObject
  • sgTB_RasterProcess : sgObject
  • sgTB_SnapProperties : sgObject
  • sgTB_VectorGeomProcess : sgObject
  • sgTB_VectorProcess : sgObject
  • sgTB_View : sgObject
  • sgTI_EASE_IN : sgObject
  • sgTI_EASE_IN_OUT : sgObject
  • sgTI_EASE_OUT : sgObject
  • sgTN_AutoCommit : sgObject
  • sgTN_ManualCommit : sgObject
  • sgTN_UnBind : sgObject
  • sgTP_East : sgObject
  • sgTP_North : sgObject
  • sgTP_South : sgObject
  • sgTP_West : sgObject
  • sgTR_BACK : sgObject
  • sgTR_BOUNCE : sgObject
  • sgTR_CIRC : sgObject
  • sgTR_CUBIC : sgObject
  • sgTR_ELASTIC : sgObject
  • sgTR_EXPO : sgObject
  • sgTR_LINEAR : sgObject
  • sgTR_QUAD : sgObject
  • sgTR_QUART : sgObject
  • sgTR_QUINT : sgObject
  • sgTR_SINE : sgObject
  • sgTS_ComplexSymbolVertexStand : sgObject
  • sgTS_Node2Node : sgObject
  • sgTS_Node2Symbol : sgObject
  • sgTS_Node2Vertex : sgObject
  • sgTS_None : sgObject
  • sgTS_Symbol2Node : sgObject
  • sgTS_Symbol2Symbol : sgObject
  • sgTS_Symbol2Vertex : sgObject
  • sgTS_Vertex2Node : sgObject
  • sgTS_Vertex2Symbol : sgObject
  • sgTS_Vertex2Vertex : sgObject
  • sgVT_Above : sgObject
  • sgVT_Below : sgObject
  • sgVT_Bool : sgObject
  • sgVT_Double : sgObject
  • sgVT_Float : sgObject
  • sgVT_Handle : sgObject
  • sgVT_Int : sgObject
  • sgVT_Long : sgObject
  • sgVT_None : sgObject
  • sgVT_Short : sgObject
  • sgVT_String : sgObject
  • sgWS_Default : sgObject
  • sgWS_GWFS : sgObject
  • sgWS_LTM : sgObject
  • sgWS_OpenAPI : sgObject
  • sgWS_WFS : sgObject
  • sgWS_WMS : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 네임스페이스 멤버

  • 네임스페이스 목록
  • 네임스페이스 멤버
  • 모두
  • 함수
  • 타입정의
  • 열거형 타입
  • 열거형 멤버
  • o
  • s
  • w

- w -

  • wkbCircularString : sgObject
  • wkbCircularStringM : sgObject
  • wkbCircularStringZ : sgObject
  • wkbCircularStringZM : sgObject
  • wkbCompoundCurve : sgObject
  • wkbCompoundCurveM : sgObject
  • wkbCompoundCurveZ : sgObject
  • wkbCompoundCurveZM : sgObject
  • wkbCurve : sgObject
  • wkbCurveM : sgObject
  • wkbCurvePolygon : sgObject
  • wkbCurvePolygonM : sgObject
  • wkbCurvePolygonZ : sgObject
  • wkbCurvePolygonZM : sgObject
  • wkbCurveZ : sgObject
  • wkbCurveZM : sgObject
  • wkbGeometryCollection : sgObject
  • wkbGeometryCollection25D : sgObject
  • wkbGeometryCollectionM : sgObject
  • wkbGeometryCollectionZM : sgObject
  • wkbLinearRing : sgObject
  • wkbLineString : sgObject
  • wkbLineString25D : sgObject
  • wkbLineStringM : sgObject
  • wkbLineStringZM : sgObject
  • wkbMultiCurve : sgObject
  • wkbMultiCurveM : sgObject
  • wkbMultiCurveZ : sgObject
  • wkbMultiCurveZM : sgObject
  • wkbMultiLineString : sgObject
  • wkbMultiLineString25D : sgObject
  • wkbMultiLineStringM : sgObject
  • wkbMultiLineStringZM : sgObject
  • wkbMultiPoint : sgObject
  • wkbMultiPoint25D : sgObject
  • wkbMultiPointM : sgObject
  • wkbMultiPointZM : sgObject
  • wkbMultiPolygon : sgObject
  • wkbMultiPolygon25D : sgObject
  • wkbMultiPolygonM : sgObject
  • wkbMultiPolygonZM : sgObject
  • wkbMultiSurface : sgObject
  • wkbMultiSurfaceM : sgObject
  • wkbMultiSurfaceZ : sgObject
  • wkbMultiSurfaceZM : sgObject
  • wkbNone : sgObject
  • wkbPoint : sgObject
  • wkbPoint25D : sgObject
  • wkbPointM : sgObject
  • wkbPointZM : sgObject
  • wkbPolygon : sgObject
  • wkbPolygon25D : sgObject
  • wkbPolygonM : sgObject
  • wkbPolygonZM : sgObject
  • wkbPolyhedralSurface : sgObject
  • wkbPolyhedralSurfaceM : sgObject
  • wkbPolyhedralSurfaceZ : sgObject
  • wkbPolyhedralSurfaceZM : sgObject
  • wkbSurface : sgObject
  • wkbSurfaceM : sgObject
  • wkbSurfaceZ : sgObject
  • wkbSurfaceZM : sgObject
  • wkbTIN : sgObject
  • wkbTINM : sgObject
  • wkbTINZ : sgObject
  • wkbTINZM : sgObject
  • wkbTriangle : sgObject
  • wkbTriangleM : sgObject
  • wkbTriangleZ : sgObject
  • wkbTriangleZM : sgObject
  • wkbUnknown : sgObject
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 목록

  • 클래스 목록
  • 클래스 색인
  • 클래스 계통도
  • 클래스 멤버
클래스 목록
다음은 클래스, 구조체, 공용체 그리고 인터페이스들입니다. (간략한 설명만을 보여줍니다) :
[상세 단계 12]
►N sgObject |
C _IApplicationControlEvents | 어플리케이션 ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다
C _IFeatureCanvasEvents | FeatureCanvas에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다
C _IFeatureLayerEvents | FeatureLayer 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다
C _IGraphicCanvasEvents | GraphicCanvas 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다
C _ILocationSensorEvents | LocationSensor 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다
C _IMap2DControlEvents | Map2D ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다
C _IMap2DEvents | Map2D 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다
C _IMap3DControlEvents | Map3D ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다
C _IMap3DEvents | Map3D 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다
C _IMapARControlEvents | MapAR ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다
C _IMapAREvents | MapAR 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다
C _IMapEarthControlEvents | MapEarth ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다
C _IMapEarthEvents | MapEarth 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다
C _IMotionSensorEvents | MotionSensor 객체에 발생하는 이벤트 처리를 위한 인터페이스를 제공한다
C _IVideoSensorEvents | Camera 장치와 연결하여 Video 수신 기능을 행하는 VideoSensor 객체에 이벤트 처리를 위한 인터페이스를 제공한다
C AggregateGraphic |
C Animator | Animator는 Graphic객체를 Animation하는 객체이다. 자세한 내용은 IAnimator 인터페이스에 대한 설명을 참고한다
C Annotation | Feature 객체의 주석 정보 (간단한 텍스트 정보)를 관리한다
C AnnotationLabel | AnnotationLabel는 Feature 객체의 주석 텍스트를 관리하는 객체이다
C Application |
C ApplicationControl |
C AttributeIndex | AttributeIndex 객체는 FeatureCollection 객체에 Spatial Indexing 기능을 제공하고, 이를 사용하여 빠른 공간 검색 (공간 연산을 통한 부분집합 검색) 기능을 FeatureCollection 객체에 제공한다
C Chart | Chart 클래스. 자세한 내용은 IChart 인터페이스에 대한 설명을 참고한다
C CommonFactory | CommonFactory 클래스. 자세한 내용은 ICommonFactory 인터페이스에 대한 설명을 참고한다
C CoverageFactory | CoverageFactory 클래스. 자세한 내용은 ICoverageFactory 인터페이스에 대한 설명을 참고한다
C DefaultTransaction | DefaultTransaction 객체는 작업의 전체 세트가 동시에 롤백 또는 커밋 할 수있는 작업을 제공합니다
C DisplayFactory | DisplayFactory 클래스. 자세한 내용은 IDisplayFactory 인터페이스에 대한 설명을 참고한다
C DockWidget |
C Feature | Feature 객체는 Object를 활용한 GIS 애플리케이션에서 실세계의 객체를 표현하는 기본 단위로 Feature 객체를 데이터베이스와 대응시키면 레코드 한 개와 대응된다
C FeatureAttributeDescriptor | FeatureAttributeDescriptor 객체는 Feature 객체에 저장된 일반 (속성) 정보 필드 한 개의 구조를 설명하는 객체이다. (데이터 타입 등)
C FeatureAttributeTreeWidget |
C FeatureCanvas | FeatureCanvas는 화면에 표현할 수 있는 여러 개의 FeatureLayer가 저장된 객체로 Map2D 객체를 통해 FeatureCanvas에 있는 Feature들을 실제 모니터 화면에 표현한다
C FeatureCollection | FeatureCollection은 같은 종류의 Feature 객체들의 집합을 관리하는 객체이다
C FeatureLayer | GIS에서는 데이터를 화면에 표현하기 위해 관리할 때 보통 Layer의 개념을 도입해 객체 종류별 관리를 한다
C FeatureQuery | FeatureQuery는 주어진 Query 조건에 맞는 Feature 객체를 선별하기 위한 기능을 FeatureCollection에 제공하는 객체이다
C FeatureType | FeatureType은 Feature 객체가 어떤 타입인지를 나타내는 객체이다
C FeatureTypeStyle | FeatureTypeStyle 클래스. 자세한 내용은 IFeatureTypeStyle 인터페이스에 대한 설명을 참고한다
C FeatureTypeStyleFactory | FeatureTypeStyleFactory는 FeatureStyle 객체 및 Symbolizer객체를 생성하는 객체이다
C FeatureTypeStyleRule | FeatureTypeStyleRule 클래스. 자세한 내용은 IFeatureTypeStyleRule 인터페이스에 대한 설명을 참고한다
C Fill | 자세한 설명은 IFill 설명을 참고한다
C Font | 자세한 설명은 IText 설명을 참고한다
C Generator3D | Generator3D 인터페이스는 2D를 3D로 변환하기 위한 객체이다
C GeographicTransform | GeographicTransform
C GeometryCollection | GeometryCollection은 기하 객체 모델의 GeometryCollection을 나타내는 객체이다
C GeometryFactory | GeometryFactory는 기하를 생성하는 기능을 제공하는 객체이다
C GPDLayerSource | [업데이트 예정]
C Graph | Graph 클래스. 자세한 내용은 IGraph 인터페이스에 대한 설명을 참고한다
C GraphicArc |
C GraphicCanvas |
C GraphicIcon |
C GraphicLabel |
C GraphicLineString |
C GraphicPolygon |
C GraphicRectangle |
C GraphicScaledImage |
C GridColorRampStyle | GridColorRampStyle 클래스. 자세한 내용은 IGridColorRampStyle 인터페이스에 대한 설명을 참고한다
C GridCoverage | GridCoverage 클래스. 자세한 내용은 IGridCoverage 인터페이스에 대한 설명을 참고한다
C GridCoverageProcessor | GridCoverageProcessor 클래스. 자세한 내용은 IGridCoverageProcessor 인터페이스에 대한 설명을 참고한다
C GridGeneralizeOp |
C GridHydrologyOp | GridHydrologyOp 클래스. 자세한 내용은 IGridHydrologyOp 인터페이스에 대한 설명을 참고한다
C GridInterpolationOp | GridInterpolationOp 클래스. 자세한 내용은 IGridInterpolationOp 인터페이스에 대한 설명을 참고한다
C GridMathOp | GridMathOp 클래스. 자세한 내용은 IGridMathOp 인터페이스에 대한 설명을 참고한다
C GridMorphometryOp | GridMorphometryOp 클래스. 자세한 내용은 IGridMorphometryOp 인터페이스에 대한 설명을 참고한다
C GridPreprocessOp | GridPreprocessOp 클래스. 자세한 내용은 IGridPreprocessOp 인터페이스에 대한 설명을 참고한다
C GridSurfaceOp | GridSurfaceOp 클래스. 자세한 내용은 IGridSurfaceOp 인터페이스에 대한 설명을 참고한다
C GridVisibilityOp | GridVisibilityOp 클래스. 자세한 내용은 IGridVisibilityOp 인터페이스에 대한 설명을 참고한다
C IAggregateGraphic | 다수의 그래픽 객체의 집합 형태를 그래픽화 하여 표현하는 인터페이스를 제공한다
C IAnimator | 그래픽 객체의 애니메이션 효과를 제공하는 인터페이스를 제공한다
C IAnnotation | Feature 객체의 주석 정보 (간단한 텍스트 정보)를 관리하는 주석 객체에 인터페이스를 제공한다
C IAnnotationLabel | Feature 객체의 주석 텍스트를 관리하는 라벨 객체에 인터페이스를 제공한다
C IApplication | 어플리케이션 위젯(최상의 위젯)을 제어하는 인터페이스를 제공한다
C IApplicationControl | 어플리케이션 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다
C IAttributeIndex | FeatureCollection 객체에 인덱싱 기능을 제공하는 AttributeIndex 객체의 인터페이스를 제공한다
C ICanvas | 지도 객체의 최상위 인터페이스로 2D/3D/AR 등 하위 상속 객체가 존재하며 모든 지도 객체의 공통 인터페이스를 제공한다
C IChart | 차트의 세부 속성을 설정하기 위한 인터페이스를 제공한다
C IColorModel | C API(linux, iOS, MacOS 등) : 중간이름 "GCM"를 덧붙여서 "OGR_GCM_"+메소드명으로 사용한다
C IColorRampList | 시스템에 유일하게 존재하는 GridColorRampStyle 형태의 래스터 일괄 표현 규정 리스트를 정의한 인터페이스를 제공한다
C ICommonFactory | 다양한 Factory객체 인터페이스를 생성할 수 있는 최상위 인터페이스를 제공한다
C ICoverage | 커버리지에 접근할 수 있도록 해주는 인터페이스이다
C ICoverageFactory | ICoverageFactory 인터페이스는 커버리지 관련된 객체를 생성하기 위하여 사용된다
C ICurve | 기하 명세에 정의된 커브의 일반 속성과 그러한 속성에 접근하기 위한 인터페이스를 제공한다
C IDefaultTransaction | 작업의 전체 세트가 동시에 롤백 또는 커밋 할 수있는 작업을 제공합니다
C IDisplayFactory | 화면에 표현되는 지도와 관련된 객체를 생성하기 위한 인터페이스를 제공한다
C IDockWidget | 도킹위젯을 제어하는 인터페이스를 제공한다
C IFeature | 실세계의 객체를 표현하는 기본 단위인 Feature 객체의 인터페이스를 제공한다
C IFeatureAttributeDescriptor | Feature 객체의 필드(속성) 객체로 FeatureType 객체는 FeatureAttributeDescriptor 객체의 집합이다
C IFeatureAttributeTreeWidget | 속성관리창을 제어하는 인터페이스를 제공한다
C IFeatureAttributeValidValue | C API(linux, iOS, MacOS 등) : 중간이름 "FAV"를 덧붙여서 "OGR_FAV_"+메소드명으로 사용한다
C IFeatureCanvas | 화면에 표현할 수 있는 여러 개의 FeatureLayer가 저장된 객체로 Map2D 객체를 통해 FeatureCanvas에 있는 Feature들을 실제 모니터 화면에 표현한다. (Document/View 구조에서 FeatureCanvas는 Document, Canvas2D는 View에 해당한다)
C IFeatureCollection | 같은 종류의 Feature 객체들의 집합을 관리하는 FeatureCollection 객체의 인터페이스를 제공한다
C IFeatureLayer | FeatureLayer 객체의 인터페이스를 제공한다
C IFeatureQuery | 주어진 쿼리 조건에 맞는 Feature 객체를 선별하기 위한 기능을 제공하는 인터페이스를 제공한다
C IFeatureStyleCollection | 자주 사용하는 FeatureStyle 객체의 집합을 관리하기 위한 인터페이스를 제공한다
C IFeatureType | Feature 객체가 어떤 타입인지를 나타내는 FeatureType 객체의 인터페이스를 제공한다
C IFeatureTypeStyle | FeatureCollection내의 Feature에 대한 속성 및 공간 정보에 따른 표현 방법을 기술하기 위해 사용된다. 예) 주제도
C IFeatureTypeStyleFactory | FeatureStyle의 생성 및 Symbolizer등 스타일 관련 객체를 생성하는 인터페이스를 제공한다
C IFeatureTypeStyleRule | FeatureTypeStyle의 규정을 정의하며 속성 및 스케일에 따른 표현 인터페이스를 제공한다
C IFill | Brush의 스타일을 표현하기 위한 인터페이스를 제공한다
C IFont | 글꼴의 스타일을 표현하기 위한 인터페이스를 제공한다
C IGenerator3D | 2D를 3D로 변환하기 위한 인터페이스를 제공한다
C IGeodeticSpatialReference | IGeodeticSpatialReference 인터페이스
C IGeographicCoordinateSystem | IGeographicCoordinateSystem 인터페이스
C IGeographicTransform | IGeographicTransform 인터페이스
C IGeometry | 기하 및 위치 정보(공간 좌표)를 갖는 기하의 기하 및 위치 정보 관리를 위한 인터페이스를 제공한다
C IGeometryCollection | 기하 및 위치 정보(공간 좌표)를 갖는 기하가 기본 기하(Point, LineString, Polygon 등)로 표현할 수 없는 복잡한 기하 구조를 갖는 경우 이를 표현할 수 있도록 해주는 인터페이스를 제공한다
C IGeometryFactory | Well Known Binary 및 Well Known Text 데이터를 통해 IGeometry 인터페이스를 갖는 객체를 생성하기 위한 인터페이스를 제공한다
C IGPDLayerSource | [업데이트 예정]
C IGraph | 그래프의 세부 속성을 설정하기 위한 인터페이스를 제공한다
C IGraphic | 그래픽 객체의 인터페이스를 제공한다
C IGraphicArc | 호의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다
C IGraphicCanvas | 실세계좌표를 기반으로 표현되는 지도객체와 달라 비축척 그래픽 객체에 기반한 객체로 단면도, 설계도와 같이 지리적 특성을
C IGraphicIcon | 아이콘의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다
C IGraphicLabel | 텍스트의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다
C IGraphicLineString | 라인의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다
C IGraphicPolygon | 폴리곤 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다
C IGraphicRectangle | 사각형의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다
C IGraphicScaledImage | 입력된 스케일과 이미지로 그래픽 객체를 표현하는 인터페이스를 제공한다
C IGridAnalysis |
C IGridColorRampItem | FeatureTypeStyleRule에서 상속된 객체로 GridTypeStyle의 Rule에 의해 정의되는 표현 색상에 대한 정보 및
C IGridColorRampStyle | GridTypeStyle로 부터 상속된 래스터를 위한 래스터 표현 규정을 일괄 정의한 인터페이스를 제공한다
C IGridCoverage | IGridCoverage 인터페이스는 데이터 공급 업체와 그리드를 (래스터) 분석 및 처리 기능을 제공하는 소프트웨어 공급 업체에 의해 소프트웨어 구현 간의 상호 운용성을 허용 방법을 정의합니다
C IGridCoverageProcessor | IGridCoverageProcessor 인터페이스는 그리드 커버리지 값에 접근할 수 있도록 해준다
C IGridGeneralizeOp | IGridGeneralizeOp 인터페이스
C IGridHydrologyOp | IGridHydrologyOp 인터페이스는 수문학(수로, 수문, 하천, 지하수 등) 등의 처리를 위한 그리드 커버리지 알고리즘 제어 인터페이스
C IGridInterpolationOp | IGridInterpolationOp 인터페이스는 그리드 보간 처리를 위한 그리드 커버리지 알고리즘 제어 인터페이스
C IGridMathOp | IGridMathOp 인터페이스는 산술연산 등의 처리를 위한 그리드 커버리지 알고리즘 제어 인터페이스
C IGridMorphometryOp | IGridMorphometryOp 인터페이스는 영상의 형태를 활용한 분석 알고리즘 제어 인터페이스
C IGridOperation | IGridOperation 인터페이스는 그리드 커버리지 처리 기능에 대한 정보를 제공한다
C IGridPreprocessOp | IGridPreprocessOp 인터페이스는 영상전처리를 위한 그리드 커버리지 알고리즘 제어 인터페이스
C IGridSampleDimension | IGridSampleDimension 인터페이스는 각각의 커버리지 샘플 차원에 대한 정보를 담고 있다
C IGridSurfaceOp | IGridSurfaceOp 인터페이스
C IGridTypeStyle | FeatureTypeStyle로 부터 상속된 래스터를 위한 래스터 표현 규정을 정의한 인터페이스를 제공한다
C IGridVisibilityOp | IGridVisibilityOp 인터페이스
C IHalo | 글꼴의 배경 스타일을 표현하기 위한 인터페이스를 제공한다
C IHistogram | IHistogram 인터페이스는 하나의 샘플차원의 그리드 값에 대한 히스토그램을 계산한다
C IImageSymbol | Feature 객체를 화면에 표시하기 위해 심볼이 필요할 수도 있는데 IImageSymbol 인터페이스는 이 중 이미지 타입의 심볼 정보를 관리하는 ImageSymbol 객체의 인터페이스를 제공한다
C IIndexMapWidget | 인덱스지도창 위젯을 관리하는 인터페이스를 제공한다
C ILayer | 레이어 객체 인테페이스를 제공한다
C ILayerSource | LayerSource 객체의 인터페이스를 제공한다
C ILayerSourceFactory | GIS 데이터를 갖고 있는 데이터소스로부터 데이터를 가져와 LayerSource를 생성하는 LayerSourceFactory 객체에 인터페이스를 제공한다
C ILayerTreeWidget | 레이어제어 관리창을 제어하는 인터페이스를 제공한다
C ILinearRing | 기하 명세에 정의된 LinearRing에 대한 일반적인 인터페이스를 제공한다. (현재는 프로퍼티 및 메소드가 없으나 LinearRing에 대한 프로퍼티 및 메소드 추가를 고려해 만들어 놓은 인터페이스이다)
C ILineString | 기하 명세에 정의된 LineString의 속성과 그 속성에 접근하는 인터페이스를 제공한다
C ILineSymbolizer | 선 스타일의 표현하는 방법 및 속성을 기술한다
C ILocationSensor | 위치 센서 장치와 연결하여 위치 정보 수신 및 기타 부수 자료의 집계하고 제공 인터페이스를 제공한다
C ILocationService | LBS의 주요 기능을 제공하는 인터페이스로 주소정보를 기반으로 해당위치의 Feature 객체를 검색하고,
C ImageSymbol | ImageSymbol은 Raster Image 심볼을 관리하는 객체이다
C IMap2D | 2D 지도를 관리하는 객체로 Canvas 객체로 부터 상속되었으며 사용자에게 지도를 표출하고 마우스 등 사용자 UI 인터페이스를 제공한다
C IMap2DControl | Map2D 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다
C IMap3D | Canvas객체로부터 상속된 Map3D 객체에 대한 인터페이스를 제공한다
C IMap3DCamera | 3D 지도의 카메라를 제어하기 위한 인터페이스를 제공한다
C IMap3DControl | Map3D 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다
C IMap3DLight | 3D 지도의 채광을 제어하기 위한 인터페이스를 제공한다
C IMapAR | Canvas객체로부터 상속받은 MapAR 객체에 대한 인터페이스를 제공한다
C IMapARControl | MapAR 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다
C IMapEarth | Canvas객체로부터 상속받은 MapEarth 객체에 대한 인터페이스를 제공한다
C IMapEarthControl | MapEarth 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다
C IMark | 심볼의 스타일을 표현하기 위한 인터페이스를 제공한다
C IMessage | 제품의 언어별 메시지 체계에 따라 입력된 메시지 정보 제공 인터페이스를 제공한다
C IMotionSensor | 자이로스코프 장치와 연결하여 방향각, 기우러짐, 가속도 및 기타 부수 자료를 집계 제공하는 인터페이스를 제공한다
C IMultiCurve | 기하명세의 MultiCurve에 대한 일반적인 인터페이스를 제공한다. (MultiCurve는 Curve가 여러 개 있는 것)
C IMultiLineString | 기하명세에 정의된 MultiLineString에 대한 일반적인 인터페이스를 제공한다. (MultiLineString은 LineString이 여러 개 있는 것)
C IMultiPoint | 기하 명세에 정의된 MultiPoint에 대한 일반적인 인터페이스를 제공한다
C IMultiPolygon | 기하 명세에 정의된 MultiPolygon에 대한 일반적인 인터페이스를 제공한다. (MultiPolygon은 Polygon이 여러 개 있는 것)
C IMultiSurface | Surface가 여러 개 있는 것으로, 기하명세의 MultiSurface에 대한 일반적인 인터페이스를 제공한다
C IndexMapWidget |
C INetworkCoverageAnalysis | INetworkCoverageAnalysis 인터페이스는 네트워크 연산을 위해 사용된다
C IParameter | IParameter 인터페이스
C IParameterInfo | IParameterInfo 인터페이스
C IParameters | IParameters 인터페이스
C IPoint | 기하 명세에 정의된 점에 대한 일반적인 인터페이스를 제공한다
C IPointSymbol | Feature 객체를 화면에 표시하기 위해 심볼이 필요할 수도 있는데 IPointSymbol 인터페이스는 이 중 벡터 타입의 심볼 정보를 관리하는 PointSymbol 객체의 인터페이스를 제공한다
C IPointSymbolizer | 심볼의 스타일을 표현하는 방법 및 속성을 기술한다
C IPointZ | 기하 명세에 정의된 Point를 3차원으로 확장하기 위한 인터페이스를 제공한다
C IPolygon | 기하 명세에 정의된 Polygon에 대한 일반적인 인터페이스를 제공한다
C IPolygonSymbolizer | 기하 내부 영역을 채우는 방법 및 속성을 기술한다
C IPrintLayoutItem | 출력창의 아이템을 제어하는 인터페이스를 제공한다
C IPrintLayoutWidget | 출력창을 제어하는 인터페이스를 제공한다
C IQueryCommand | 전체 비지니스 작업에 포함된 하나의 작업(쿼리)을 의미한다
C IQueryCommands | 전체 비지니스 작업에 포함된 하나의 작업(쿼리)들을 의미한다
C ISampleDimension | ISampleDimension 인터페이스는 각각의 커버리지 샘플 차원에 대한 정보를 담고 있다
C ISensor | 모든 센서(위치, 방향, 속도 외)의 상위 인터페이스로 센서의 공통 인터페이스를 제공한다
C ISpatialOperator | 기하에 다른 기하와의 공간연산 인터페이스를 제공한다
C ISpatialReference | ISpatialReference 인터페이스는 Geometry 객체가 참조하는 공간참조체계를 정의하는 인터페이스를 제공한다
C ISpatialReferenceFactory | ISpatialReferenceFactory 인터페이스
C ISpatialReferenceInfo | ISpatialReferenceInfo 인터페이스
C ISpatialRelation | 기하에 적용되는 공간 관련성 연산자들을 정의한다
C ISpatialRelation2 | 기하가 다른 기하와 공간적으로 어떤 관계에 있는지 테스트할 수 있는 인터페이스를 제공한다
C IStroke | 펜의 스타일을 표현하기 위한 인터페이스를 제공한다
C ISurface | 기하 명세에 정의된 Surface에 대한 일반적인 인터페이스를 제공한다
C ISymbol | Feature 객체를 화면에 표시하기 위해 심볼이 필요할 수도 있는데 ISymbol 인터페이스는 심볼 정보를 관리하는 Symbol 객체의 인터페이스를 제공한다
C ISymbolizer | Feature 객체를 화면에 표시하기 위해 필요한 그래픽 속성 (선굵기, 색 등)을 관리하는 FeatureStyle 객체의 인터페이스를 제공한다
C ITabWidget | 탭위젯 객체를 제어하는 인터페이스를 제공한다
C ITextSymbolizer | 라벨의 텍스트 스타일을 표현하기 위해 사용한다
C IUserDefinedWidget | 사용자 정의 UI 객체를 정의/표현하기 위한 공통 인터페이스를 제공한다
C IUtility | 일반적이지 않은 다양한 부수적인 기능 인터페이스를 제공한다
C IVectorAnalysis | 벡터 레이어에 있는 feature들을 이용해서 다양한 연산을 할 수 있도록 인터페이스를 제공합니다
C IVideo | 비디오의 세부 속성을 설정하기 위한 인터페이스를 제공한다
C IVideoSensor | 카메라 센서 및 동영상 서비스로 부터 영상 정보를 획득하고 표현하는 인터페이스를 제공한다
C IWidget | 위젯 객체를 관리하기 위한 최상의 인터페이스를 제공한다
C IWks | 기하에 Well Known Binary 표현과 Well Known Text 표현을 다루는 인터페이스를 제공한다
C IXMLDoc | XML파일을 관리, 분석 인터페이스를 제공한다
C IXMLElements | XMLDoc객체로부터 해석된 객체에 존재하는 다양한 정보 관리 인터페이스를 제공한다
C Layer | GIS에서는 데이터를 화면에 표현하기위해 관리할 때 보통 Layer의 개념을 도입해 객체 종류별 관리를 한다
C LayerSource | GIS에서는 데이터를 화면에 표현하기 위해 관리할 때 보통 Layer의 개념을 도입해 객체 종류별 관리를 한다
C LayerSourceFactory | LayerSourceFactory는 GIS 데이터를 갖고 있는 데이터소스로부터 데이터를 가져와 LayerSource를 생성하는 객체이다
C LayerTreeWidget |
C LinearRing | LinearRing은 기하 객체 모델의 LinearRing을 나타내는 객체이다
C LineString | LineString은 기하 객체 모델의 LineString을 나타내는 객체이다
C LocationSensor | LocationSensor은 GPS 장치와 연결하여 GPS 수신 기능을 행하는 객체이다. 자세한 내용은 ILocationSensor 에 대한 설명을 참고한다
C LocationService | 주소정보를 기반으로 해당위치의 Feature 객체를 검색하고, 관리하는 기능과 POI 기능을 제공하는 객체이다. 자세한 내용은 ILocationService 인터페이스에 대한 설명을 참고한다
C Map2D | Map2D 클래스는 FeatureCanvas 객체와 연동하여 Feature들의 Geometry 및 주석 정보를 화면에 그리고 화면으로부터 사용자 입력을 받는 등 실제 화면 제어를 담당하는 객체이다
C Map2DControl |
C Map3D | Map3D 클래스는 FeatureCanvas 객체와 연동하여 Feature들의 Geometry 및 주석 정보를 화면에 그리고 화면으로부터 사용자 입력을 받는 등 실제 화면 제어를 담당하는 객체이다. 자세한 내용은 IMap3D 에 대한 설명을 참고한다
C Map3DControl |
C MapAR | MapAR 클래스는 FeatureCanvas 객체와 연동하여 Feature들의 Geometry 및 주석 정보를 화면에 그리고 화면으로부터 사용자 입력을 받는 등 실제 화면 제어를 담당하는 객체이다. 자세한 내용은 IMapAR 에 대한 설명을 참고한다
C MapARControl |
C MapEarth | MapEarth 클래스는 FeatureCanvas 객체와 연동하여 Feature들의 Geometry 및 주석 정보를 화면에 그리고 화면으로부터 사용자 입력을 받는 등 실제 화면 제어를 담당하는 객체이다. 자세한 내용은 IMapEarth 에 대한 설명을 참고한다
C MapEarthControl |
C Mark | 자세한 설명은 IMark 설명을 참고한다
C Message | Message는 메시지파일에 따른 메시지를 출력하는 객체이다. 자세한 내용은 IMessage 인터페이스에 대한 설명을 참고한다
C MotionSensor | MotionSensor은 Gyroscope 장치와 연결하여 Motion 수신 기능을 행하는 객체이다. 자세한 내용은 IMotionSensor 에 대한 설명을 참고한다
C MultiLineString | MultiLineString은 기하 객체 모델의 MultiLineString을 나타내는 객체이다
C MultiPoint | MultiPoint는 기하 객체 모델의 MultiPoint를 나타내는 객체이다
C MultiPolygon | MultiPolygon은 기하 객체 모델의 MultiPolygon을 나타내는 객체이다
C NetworkCoverageAnalysis | NetworkCoverageAnalysis 클래스. 자세한 내용은 INetworkCoverageAnalysis 인터페이스에 대한 설명을 참고한다
C Parameter | Parameter
C ParameterInfo | ParameterInfo
C Parameters | Parameters
C Point | Point는 기하 객체 모델의 Point를 나타내는 객체이다
C PointSymbol | PointSymbol은 Vector로 그려진 심볼을 관리하는 객체이다
C Polygon | Polygon은 기하 객체 모델의 Polygon을 나타내는 객체이다
C QueryCommand | 자세한 설명은 IQueryCommand 설명을 참고한다
C QueryCommands | 자세한 설명은 IQueryCommands 설명을 참고한다
C SpatialReference | SpatialReference는 Geometry 객체가 참조하는 공간참조체계를 정의하는 객체이다
C SpatialReferenceFactory | SpatialReferenceFactory
C Stroke | 자세한 설명은 IStroke 설명을 참고한다
C Symbolizer | 자세한 설명은 ISymbolizer 설명을 참고한다
C TabWidget |
C UserDefinedWidget | UserDefinedWidget 클래스. 자세한 내용은 IUserDefinedWidget 인터페이스에 대한 설명을 참고한다
C Utility | Utility는 여러가지 부수적인 기능을 제공하는 객체이다. 자세한 내용은 IUtility 인터페이스에 대한 설명을 참고한다
C Video | Video 클래스. 자세한 내용은 IVideo 인터페이스에 대한 설명을 참고한다
C VideoSensor | VideoSensor은 Camera 장치와 연결하여 Video 수신 기능을 행하는 객체이다. 자세한 내용은 IVideoSensor 에 대한 설명을 참고한다
C XMLDoc | XMLDoc 클래스. 자세한 내용은 IXMLDoc 인터페이스에 대한 설명을 참고한다
C XMLElements | XMLElements 클래스. 자세한 내용은 IXMLElements 인터페이스에 대한 설명을 참고한다
C IDispatch |
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::_IApplicationControlEvents 인터페이스 참조

  • 클래스 색인
  • 클래스 계통도
  • 클래스 멤버
  • sgObject
  • _IApplicationControlEvents
sgObject::_IApplicationControlEvents 인터페이스 참조

어플리케이션 ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다. 더 자세히 ...

sgObject::_IApplicationControlEvents에 대한 상속 다이어그램 :
sgObject::_IApplicationControlEvents에 대한 협력 다이어그램:

상세한 설명

어플리케이션 ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다.

COM+ 인터페이스에만 존재하는 ActiveX 방식의 어플리케이션 컨트롤 객체의 이벤트

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::_IFeatureCanvasEvents 인터페이스 참조

  • sgObject
  • _IFeatureCanvasEvents
Public 멤버 함수 | 모든 멤버 목록
sgObject::_IFeatureCanvasEvents 인터페이스 참조

FeatureCanvas에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::_IFeatureCanvasEvents에 대한 협력 다이어그램:

Public 멤버 함수

void | FeatureSelected ()
void | FeatureDeSelected ()
void | FeatureInsert ()
void | FeatureInserted (IFeature *poFeature)
void | FeatureDelete ()
void | FeatureDeleted (IFeature *poFeature)
void | FeatureUpdate (IFeature *poFeature)
void | FeatureUpdated (IFeature *poFromFeature, IFeature *poToFeature)
void | Committed ()
void | Undid ()
void | LayerAdded (IFeatureLayer *poFeatureLayer)
void | LayerDelete (IFeatureLayer *poFeatureLayer)
void | LayerDeleted ()
void | LayerOrderChanged (IFeatureLayer *poFeatureLayer)
void | LayerVisibleChanged (IFeatureLayer *poFeatureLayer, VARIANT_BOOL on)
void | LayerSelectableChanged (IFeatureLayer *poFeatureLayer, VARIANT_BOOL on)
void | LayerActivated (IFeatureLayer *poFeatureLayer)
void | LayerStyleChanged (IFeatureLayer *poFeatureLayer)
void | LayerAnnotationChanged (IFeatureLayer *poFeatureLayer)
void | LayerTypeStyleChanged (IFeatureLayer *poFeatureLayer)
void | LayerExported (IFeatureLayer *poFeatureLayer)
void | LayerAttributeChange (IFeatureLayer *poFeatureLayer)
void | LayerAttributeChanged (IFeatureLayer *poFeatureLayer)
void | WorkspaceChanged ()
void | FeaturePreUpdate (IFeature *poFeature)
void | LayerDisplayNameChanged (IFeatureLayer *poFeatureLayer)
void | PreCommit ()
void | PreUndo ()
void | LayerEditableChanged (IFeatureLayer *poFeatureLayer, VARIANT_BOOL on)

상세한 설명

FeatureCanvas에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다.

멤버 함수 문서화

void sgObject::_IFeatureCanvasEvents::Committed ( )
void sgObject::_IFeatureCanvasEvents::FeatureDelete ( )
void sgObject::_IFeatureCanvasEvents::FeatureDeleted ( IFeature * poFeature )
void sgObject::_IFeatureCanvasEvents::FeatureDeSelected ( )
void sgObject::_IFeatureCanvasEvents::FeatureInsert ( )
void sgObject::_IFeatureCanvasEvents::FeatureInserted ( IFeature * poFeature )
void sgObject::_IFeatureCanvasEvents::FeaturePreUpdate ( IFeature * poFeature )
void sgObject::_IFeatureCanvasEvents::FeatureSelected ( )
void sgObject::_IFeatureCanvasEvents::FeatureUpdate ( IFeature * poFeature )
void sgObject::_IFeatureCanvasEvents::FeatureUpdated | ( | IFeature * | poFromFeature,
 |  | IFeature * | poToFeature
 | ) |  |
void sgObject::_IFeatureCanvasEvents::LayerActivated ( IFeatureLayer * poFeatureLayer )
void sgObject::_IFeatureCanvasEvents::LayerAdded ( IFeatureLayer * poFeatureLayer )
void sgObject::_IFeatureCanvasEvents::LayerAnnotationChanged ( IFeatureLayer * poFeatureLayer )
void sgObject::_IFeatureCanvasEvents::LayerAttributeChange ( IFeatureLayer * poFeatureLayer )
void sgObject::_IFeatureCanvasEvents::LayerAttributeChanged ( IFeatureLayer * poFeatureLayer )
void sgObject::_IFeatureCanvasEvents::LayerDelete ( IFeatureLayer * poFeatureLayer )
void sgObject::_IFeatureCanvasEvents::LayerDeleted ( )
void sgObject::_IFeatureCanvasEvents::LayerDisplayNameChanged ( IFeatureLayer * poFeatureLayer )
void sgObject::_IFeatureCanvasEvents::LayerEditableChanged | ( | IFeatureLayer * | poFeatureLayer,
 |  | VARIANT_BOOL | on
 | ) |  |
void sgObject::_IFeatureCanvasEvents::LayerExported ( IFeatureLayer * poFeatureLayer )
void sgObject::_IFeatureCanvasEvents::LayerOrderChanged ( IFeatureLayer * poFeatureLayer )
void sgObject::_IFeatureCanvasEvents::LayerSelectableChanged | ( | IFeatureLayer * | poFeatureLayer,
 |  | VARIANT_BOOL | on
 | ) |  |
void sgObject::_IFeatureCanvasEvents::LayerStyleChanged ( IFeatureLayer * poFeatureLayer )
void sgObject::_IFeatureCanvasEvents::LayerTypeStyleChanged ( IFeatureLayer * poFeatureLayer )
void sgObject::_IFeatureCanvasEvents::LayerVisibleChanged | ( | IFeatureLayer * | poFeatureLayer,
 |  | VARIANT_BOOL | on
 | ) |  |
void sgObject::_IFeatureCanvasEvents::PreCommit ( )
void sgObject::_IFeatureCanvasEvents::PreUndo ( )
void sgObject::_IFeatureCanvasEvents::Undid ( )
void sgObject::_IFeatureCanvasEvents::WorkspaceChanged ( )
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • _IFeatureCanvasEvents
sgObject::_IFeatureCanvasEvents 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::_IFeatureCanvasEvents (모든 상속된 멤버들도 포함합니다.)

Committed() | sgObject::_IFeatureCanvasEvents
FeatureDelete() | sgObject::_IFeatureCanvasEvents
FeatureDeleted(IFeature *poFeature) | sgObject::_IFeatureCanvasEvents
FeatureDeSelected() | sgObject::_IFeatureCanvasEvents
FeatureInsert() | sgObject::_IFeatureCanvasEvents
FeatureInserted(IFeature *poFeature) | sgObject::_IFeatureCanvasEvents
FeaturePreUpdate(IFeature *poFeature) | sgObject::_IFeatureCanvasEvents
FeatureSelected() | sgObject::_IFeatureCanvasEvents
FeatureUpdate(IFeature *poFeature) | sgObject::_IFeatureCanvasEvents
FeatureUpdated(IFeature *poFromFeature, IFeature *poToFeature) | sgObject::_IFeatureCanvasEvents
LayerActivated(IFeatureLayer *poFeatureLayer) | sgObject::_IFeatureCanvasEvents
LayerAdded(IFeatureLayer *poFeatureLayer) | sgObject::_IFeatureCanvasEvents
LayerAnnotationChanged(IFeatureLayer *poFeatureLayer) | sgObject::_IFeatureCanvasEvents
LayerAttributeChange(IFeatureLayer *poFeatureLayer) | sgObject::_IFeatureCanvasEvents
LayerAttributeChanged(IFeatureLayer *poFeatureLayer) | sgObject::_IFeatureCanvasEvents
LayerDelete(IFeatureLayer *poFeatureLayer) | sgObject::_IFeatureCanvasEvents
LayerDeleted() | sgObject::_IFeatureCanvasEvents
LayerDisplayNameChanged(IFeatureLayer *poFeatureLayer) | sgObject::_IFeatureCanvasEvents
LayerEditableChanged(IFeatureLayer *poFeatureLayer, VARIANT_BOOL on) | sgObject::_IFeatureCanvasEvents
LayerExported(IFeatureLayer *poFeatureLayer) | sgObject::_IFeatureCanvasEvents
LayerOrderChanged(IFeatureLayer *poFeatureLayer) | sgObject::_IFeatureCanvasEvents
LayerSelectableChanged(IFeatureLayer *poFeatureLayer, VARIANT_BOOL on) | sgObject::_IFeatureCanvasEvents
LayerStyleChanged(IFeatureLayer *poFeatureLayer) | sgObject::_IFeatureCanvasEvents
LayerTypeStyleChanged(IFeatureLayer *poFeatureLayer) | sgObject::_IFeatureCanvasEvents
LayerVisibleChanged(IFeatureLayer *poFeatureLayer, VARIANT_BOOL on) | sgObject::_IFeatureCanvasEvents
PreCommit() | sgObject::_IFeatureCanvasEvents
PreUndo() | sgObject::_IFeatureCanvasEvents
Undid() | sgObject::_IFeatureCanvasEvents
WorkspaceChanged() | sgObject::_IFeatureCanvasEvents
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::_IFeatureLayerEvents 인터페이스 참조

  • _IFeatureLayerEvents
sgObject::_IFeatureLayerEvents 인터페이스 참조

FeatureLayer 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::_IFeatureLayerEvents에 대한 상속 다이어그램 :
sgObject::_IFeatureLayerEvents에 대한 협력 다이어그램:

상세한 설명

FeatureLayer 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다.

(현재는 이벤트 메소드가 없으나 향후 추가를 고려해 만들어 놓은 인터페이스이다)

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::_IGraphicCanvasEvents 인터페이스 참조

  • _IGraphicCanvasEvents
sgObject::_IGraphicCanvasEvents 인터페이스 참조

GraphicCanvas 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::_IGraphicCanvasEvents에 대한 상속 다이어그램 :
sgObject::_IGraphicCanvasEvents에 대한 협력 다이어그램:

상세한 설명

GraphicCanvas 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::_ILocationSensorEvents 인터페이스 참조

  • _ILocationSensorEvents
Public 멤버 함수 | 모든 멤버 목록
sgObject::_ILocationSensorEvents 인터페이스 참조

LocationSensor 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::_ILocationSensorEvents에 대한 상속 다이어그램 :
sgObject::_ILocationSensorEvents에 대한 협력 다이어그램:

Public 멤버 함수

void | ProviderDisabled ()
GPS 장치의 상태가 연결해지되는 경우 발생한다. 더 자세히 ...
void | ProviderEnabled ()
GPS 장치의 상태가 연결되는 경우 발생한다. 더 자세히 ...
void | SensingValueChanged ()
GPS 장치로 부터 값이 들어 오는 경우 발생한다. 더 자세히 ...
void | Coordinates ([in] DOUBLE x, [in] DOUBLE y, [in] DOUBLE z)
GPS 장치로부터 현재위치가 들어오는 경우 발생한다. 더 자세히 ...
void | Time ([in] SHORT Hour, [in] SHORT Minute, [in] SHORT Second)
GPS 장치로부터 현재시간이 들어오는 경우 발생한다. 더 자세히 ...
void | Speed ([in] DOUBLE Speed)
GPS 장치의 이동속도가 들어오는 경우 발생한다. 더 자세히 ...
void | Satellite ([in] LONG SatelliteNumber, [in] VARIANT IDList, [in] VARIANT SingnalQualityList, [in] VARIANT UsedList, [in] VARIANT AzimuthList, [in] VARIANT ElevList)
GPS 장치의 수신위성정보가 들어오는 경우 발생한다. 더 자세히 ...

상세한 설명

LocationSensor 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다.

멤버 함수 문서화

void sgObject::_ILocationSensorEvents::Coordinates | ( | [in] DOUBLE | x,
 |  | [in] DOUBLE | y,
 |  | [in] DOUBLE | z
 | ) |  |

GPS 장치로부터 현재위치가 들어오는 경우 발생한다.

매개변수
x | - GPS 장치의 현재 위치의 X 좌표. LocationSensor 객체의 SpatialReference에 의해 변환된 값이다.
y | - GPS 장치의 현재 위치의 Y 좌표. LocationSensor 객체의 SpatialReference에 의해 변환된 값이다.
z | - GPS 장치의 현재 위치의 Z 좌표. LocationSensor 객체의 SpatialReference에 의해 변환된 값이다.
void sgObject::_ILocationSensorEvents::ProviderDisabled ( )

GPS 장치의 상태가 연결해지되는 경우 발생한다.

void sgObject::_ILocationSensorEvents::ProviderEnabled ( )

GPS 장치의 상태가 연결되는 경우 발생한다.

void sgObject::_ILocationSensorEvents::Satellite | ( | [in] LONG | SatelliteNumber,
 |  | [in] VARIANT | IDList,
 |  | [in] VARIANT | SingnalQualityList,
 |  | [in] VARIANT | UsedList,
 |  | [in] VARIANT | AzimuthList,
 |  | [in] VARIANT | ElevList
 | ) |  |

GPS 장치의 수신위성정보가 들어오는 경우 발생한다.

매개변수
SatelliteNumber | - 위성 개수
IDList | - 위성별 ID 번호
SingnalQualityList | - 위성별 수신된 전파강도(0~99)
UsedList | - 위성별 사용 가능 여부
AzimuthList | - 위성별 방향각(0~359 도)
ElevList | - 위성별 고도각(0~90 도)
void sgObject::_ILocationSensorEvents::SensingValueChanged ( )

GPS 장치로 부터 값이 들어 오는 경우 발생한다.

void sgObject::_ILocationSensorEvents::Speed ( [in] DOUBLE Speed )

GPS 장치의 이동속도가 들어오는 경우 발생한다.

매개변수
Speed - 이동 속도(knots)
void sgObject::_ILocationSensorEvents::Time | ( | [in] SHORT | Hour,
 |  | [in] SHORT | Minute,
 |  | [in] SHORT | Second
 | ) |  |

GPS 장치로부터 현재시간이 들어오는 경우 발생한다.

매개변수
Hour | - 시간
Minute | - 분
Second | - 초
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • _ILocationSensorEvents
sgObject::_ILocationSensorEvents 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::_ILocationSensorEvents (모든 상속된 멤버들도 포함합니다.)

Coordinates([in] DOUBLE x, [in] DOUBLE y, [in] DOUBLE z) | sgObject::_ILocationSensorEvents
ProviderDisabled() | sgObject::_ILocationSensorEvents
ProviderEnabled() | sgObject::_ILocationSensorEvents
Satellite([in] LONG SatelliteNumber, [in] VARIANT IDList, [in] VARIANT SingnalQualityList, [in] VARIANT UsedList, [in] VARIANT AzimuthList, [in] VARIANT ElevList) | sgObject::_ILocationSensorEvents
SensingValueChanged() | sgObject::_ILocationSensorEvents
Speed([in] DOUBLE Speed) | sgObject::_ILocationSensorEvents
Time([in] SHORT Hour, [in] SHORT Minute, [in] SHORT Second) | sgObject::_ILocationSensorEvents
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::_IMap2DControlEvents 인터페이스 참조

  • _IMap2DControlEvents
sgObject::_IMap2DControlEvents 인터페이스 참조

Map2D ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다. 더 자세히 ...

sgObject::_IMap2DControlEvents에 대한 상속 다이어그램 :
sgObject::_IMap2DControlEvents에 대한 협력 다이어그램:

상세한 설명

Map2D ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다.

COM+ 인터페이스에만 존재하는 ActiveX 방식의 Map2D 컨트롤 객체의 이벤트

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::_IMap2DEvents 인터페이스 참조

  • _IMap2DEvents
Public 멤버 함수 | 모든 멤버 목록
sgObject::_IMap2DEvents 인터페이스 참조

Map2D 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::_IMap2DEvents에 대한 상속 다이어그램 :
sgObject::_IMap2DEvents에 대한 협력 다이어그램:

Public 멤버 함수

void | Draw ()
객체들을 화면에 그리기 전에 발생한다. 더 자세히 ...
void | Drawed ()
객체들이 화면에 모두 그려진 후 발생한다. 더 자세히 ...
void | Snap (ScreenModeEnum eScreenMode, IFeature *poFeature, IGeometry *poGeometry, int nVertexIdx, SnapModeEnum eSnapType)
화면상에 Feature를 변경, 추가하기 위해 공간 객체를 변경 중 근처의 Feature에 스냅될 경우 발생한다. 더 자세히 ...
void | Snaped (ScreenModeEnum eScreenMode, IFeature *poFeature, IGeometry *poGeometry, int nVertexIdx, SnapModeEnum eSnapType)
화면상에 Feature를 변경, 추가하기 위해 공간 객체를 변경 중 근처의 Feature에 스냅된 경우 발생한다. 더 자세히 ...
void | SnapOut ()
화면상에 Feature를 변경, 추가하기 위해 공간 객체를 변경 중 근처의 Feature에 스냅를 벗어난 경우 발생한다. 더 자세히 ...
void | FeatureOver (IFeature *poFeature, IGeometry *poGeometry, IAnnotationLabel *poLabel)
화면상 Feature에 마우스를 올려놓은 경우 발생한다. 더 자세히 ...
void | FeatureOut (IFeature *poFeature, IGeometry *poGeometry, IAnnotationLabel *poLabel)
화면상 Feature에 마우스를 올려놓았다가 영역을 벗어난 경우 발생한다. 더 자세히 ...
void | Paint ()
화면이 갱신될 때 발생한다. (다른 창에 의한 갱신 포함) 더 자세히 ...
void | Click (int x, int y)
마우스를 클릭할 때 발생한다. 더 자세히 ...
void | DoubleClick (int x, int y)
마우스를 두번 연속 클릭할 때 발생한다. 더 자세히 ...
void | TouchMove (int x, int y)
마우스를 클릭하여 드래그할 때 발생한다. 더 자세히 ...
void | TouchUp (int type, int x, int y)
마우스버튼을 눌렀다 떼었을 때 발생한다. 더 자세히 ...
void | TouchDown (int type, int x, int y)
마우스버튼을 눌렀을 때 발생한다. 더 자세히 ...
void | LongClick (long x, long y)
마우스를 길게 클릭할 때 발생된다. 더 자세히 ...
void | RightClick (int x, int y)
마우스 오른쪽 버튼을 클릭할 때 발생한다. 더 자세히 ...
void | MapMove ()
지도의 중심이 이동될 때 발생된다. 더 자세히 ...
void | MapMoved ()
지도의 중심이 이동된 후 발생된다. 더 자세히 ...
void | MapExtendChange ()
지도의 외곽 좌표가 변경될 때 발생된다.(이동, 줌) 더 자세히 ...
void | MapExtendChanged ()
지도의 외곽 좌표가 변경된 후 발생된다.(이동, 줌) 더 자세히 ...
void | MapReSized (int width, int height)
지도 표현 크기(디바이스)가 변경된 후 발생된다. 더 자세히 ...
void | SensorAdded (SensorTypeEnum eType)
지도에서 센서가 추가된 경우 발생된다. 더 자세히 ...
void | SensorRemoved (SensorTypeEnum eType)
지도에서 센서가 제거될 때 발생된다. 더 자세히 ...
void | Exported ()
지도를 이미지로 내보낸 후 발생된다. 더 자세히 ...
void | ScreenModeChanged (ScreenModeEnum eScreenMode)
지도의 화면모드가 변경 후 발생된다. 더 자세히 ...
void | SelectModeChanged (SpatialOperatorEnum eSelectMode)
선택모드가 변경된 후 발생된다. 더 자세히 ...
void | SnapModeChanged ()
스냅모드가 변경된 후 발생된다. 더 자세히 ...
void | SyncMoveModeChanged ()
동시이동모드가 변경된 후 발생된다. 더 자세히 ...
void | MapControlChanged (int nCtrl)
지도 제어창 설정이 변경된 후 발생된다. 더 자세히 ...
void | Printed ()
지도를 출력창에서 출력하거나 다른 형태로 내보내기시 발생된다. 더 자세히 ...

상세한 설명

Map2D 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다.

멤버 함수 문서화

void sgObject::_IMap2DEvents::Click | ( | int | x,
 |  | int | y
 | ) |  |

마우스를 클릭할 때 발생한다.

매개변수
x | - 마우스의 좌표 X 값.
y | - 마우스의 좌표 Y 값.
void sgObject::_IMap2DEvents::DoubleClick | ( | int | x,
 |  | int | y
 | ) |  |

마우스를 두번 연속 클릭할 때 발생한다.

매개변수
x | - 마우스의 좌표 X 값.
y | - 마우스의 좌표 Y 값.
void sgObject::_IMap2DEvents::Draw ( )

객체들을 화면에 그리기 전에 발생한다.

void sgObject::_IMap2DEvents::Drawed ( )

객체들이 화면에 모두 그려진 후 발생한다.

void sgObject::_IMap2DEvents::Exported ( )

지도를 이미지로 내보낸 후 발생된다.

void sgObject::_IMap2DEvents::FeatureOut | ( | IFeature * | poFeature,
 |  | IGeometry * | poGeometry,
 |  | IAnnotationLabel * | poLabel
 | ) |  |

화면상 Feature에 마우스를 올려놓았다가 영역을 벗어난 경우 발생한다.

매개변수
poFeature | - 마우스가 올라갔었던 Feature 객체.
poGeometry | - 마우스가 올라갔었던 Feature의 Geometry 객체. 없으면 NULL(Feature의 Geometry가 MultiPoint, MultiLineString, MultiPolygon 및 GeometryCollection인 경우 해당 객체들 중 실제 선택된 Geometry)
poLabel | - 마우스가 올라갔었던 Feature의 AnnotationLabel 객체
void sgObject::_IMap2DEvents::FeatureOver | ( | IFeature * | poFeature,
 |  | IGeometry * | poGeometry,
 |  | IAnnotationLabel * | poLabel
 | ) |  |

화면상 Feature에 마우스를 올려놓은 경우 발생한다.

매개변수
poFeature | - 마우스가 올라간 Feature 객체.
poGeometry | - 마우스가 올라간 Feature의 Geometry 객체. 없으면 NULL(Feature의 Geometry가 MultiPoint, MultiLineString, MultiPolygon 및 GeometryCollection인 경우 해당 객체들 중 실제 선택된 Geometry)
poLabel | - 마우스가 올라간 Feature의 AnnotationLabel 객체
void sgObject::_IMap2DEvents::LongClick | ( | long | x,
 |  | long | y
 | ) |  |

마우스를 길게 클릭할 때 발생된다.

매개변수
x | - 마우스의 좌표 X 값.
y | - 마우스의 좌표 Y 값.
void sgObject::_IMap2DEvents::MapControlChanged ( int nCtrl )

지도 제어창 설정이 변경된 후 발생된다.

매개변수
nCtrl - 변경된 후 지도 제어창 설정모드
void sgObject::_IMap2DEvents::MapExtendChange ( )

지도의 외곽 좌표가 변경될 때 발생된다.(이동, 줌)

void sgObject::_IMap2DEvents::MapExtendChanged ( )

지도의 외곽 좌표가 변경된 후 발생된다.(이동, 줌)

void sgObject::_IMap2DEvents::MapMove ( )

지도의 중심이 이동될 때 발생된다.

void sgObject::_IMap2DEvents::MapMoved ( )

지도의 중심이 이동된 후 발생된다.

void sgObject::_IMap2DEvents::MapReSized | ( | int | width,
 |  | int | height
 | ) |  |

지도 표현 크기(디바이스)가 변경된 후 발생된다.

void sgObject::_IMap2DEvents::Paint ( )

화면이 갱신될 때 발생한다. (다른 창에 의한 갱신 포함)

void sgObject::_IMap2DEvents::Printed ( )

지도를 출력창에서 출력하거나 다른 형태로 내보내기시 발생된다.

void sgObject::_IMap2DEvents::RightClick | ( | int | x,
 |  | int | y
 | ) |  |

마우스 오른쪽 버튼을 클릭할 때 발생한다.

매개변수
x | - 마우스의 좌표 X 값.
y | - 마우스의 좌표 Y 값.
void sgObject::_IMap2DEvents::ScreenModeChanged ( ScreenModeEnum eScreenMode )

지도의 화면모드가 변경 후 발생된다.

void sgObject::_IMap2DEvents::SelectModeChanged ( SpatialOperatorEnum eSelectMode )

선택모드가 변경된 후 발생된다.

매개변수
eSelectMode - 변경된 후 선택모드
void sgObject::_IMap2DEvents::SensorAdded ( SensorTypeEnum eType )

지도에서 센서가 추가된 경우 발생된다.

void sgObject::_IMap2DEvents::SensorRemoved ( SensorTypeEnum eType )

지도에서 센서가 제거될 때 발생된다.

void sgObject::_IMap2DEvents::Snap | ( | ScreenModeEnum | eScreenMode,
 |  | IFeature * | poFeature,
 |  | IGeometry * | poGeometry,
 |  | int | nVertexIdx,
 |  | SnapModeEnum | eSnapType
 | ) |  |

화면상에 Feature를 변경, 추가하기 위해 공간 객체를 변경 중 근처의 Feature에 스냅될 경우 발생한다.

매개변수
eScreenMode | - 현재 Map2D의 ScreenMode 모드(버텍스 이동, 이동, 추가, 삭제 등)
poFeature | - 스냅될 Feature 객체. 없으면 NULL
poGeometry | - 스냅될 Feature의 Geometry 객체. 없으면 NULL(Feature의 Geometry가 MultiPoint, MultiLineString, MultiPolygon 및 GeometryCollection인 경우 해당 객체들 중 실제 스냅된 Geometry)
nVertexIdx | - 스냅될 Geometry의 Vertex 인덱스 번호
eSnapType | - 스냅될 형태 (예 : 시작점, 끝점, 근접점 등)
void sgObject::_IMap2DEvents::Snaped | ( | ScreenModeEnum | eScreenMode,
 |  | IFeature * | poFeature,
 |  | IGeometry * | poGeometry,
 |  | int | nVertexIdx,
 |  | SnapModeEnum | eSnapType
 | ) |  |

화면상에 Feature를 변경, 추가하기 위해 공간 객체를 변경 중 근처의 Feature에 스냅된 경우 발생한다.

매개변수
eScreenMode | - 현재 Map2D의 ScreenMode 모드(버텍스 이동, 이동, 추가, 삭제 등)
poFeature | - 현재 스냅된 Feature 객체. 없으면 NULL
poGeometry | - 현재 스냅된 Feature의 Geometry 객체. 없으면 NULL(Feature의 Geometry가 MultiPoint, MultiLineString, MultiPolygon 및 GeometryCollection인 경우 해당 객체들 중 실제 스냅된 Geometry)
nVertexIdx | - 현재 스냅된 Geometry의 Vertex 인덱스 번호
eSnapType | - 현재 스냅된 형태 (예 : 시작점, 끝점, 근접점 등)
void sgObject::_IMap2DEvents::SnapModeChanged ( )

스냅모드가 변경된 후 발생된다.

void sgObject::_IMap2DEvents::SnapOut ( )

화면상에 Feature를 변경, 추가하기 위해 공간 객체를 변경 중 근처의 Feature에 스냅를 벗어난 경우 발생한다.

void sgObject::_IMap2DEvents::SyncMoveModeChanged ( )

동시이동모드가 변경된 후 발생된다.

void sgObject::_IMap2DEvents::TouchDown | ( | int | type,
 |  | int | x,
 |  | int | y
 | ) |  |

마우스버튼을 눌렀을 때 발생한다.

매개변수
type | - 마우스 버튼의 종류(왼쪽, 오른쪽, 중간 등).
x | - 마우스의 좌표 X 값.
y | - 마우스의 좌표 Y 값.
void sgObject::_IMap2DEvents::TouchMove | ( | int | x,
 |  | int | y
 | ) |  |

마우스를 클릭하여 드래그할 때 발생한다.

매개변수
x | - 마우스의 좌표 X 값.
y | - 마우스의 좌표 Y 값.
void sgObject::_IMap2DEvents::TouchUp | ( | int | type,
 |  | int | x,
 |  | int | y
 | ) |  |

마우스버튼을 눌렀다 떼었을 때 발생한다.

매개변수
type | - 마우스 버튼의 종류(왼쪽, 오른쪽, 중간 등).
x | - 마우스의 좌표 X 값.
y | - 마우스의 좌표 Y 값.
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • _IMap2DEvents
sgObject::_IMap2DEvents 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::_IMap2DEvents (모든 상속된 멤버들도 포함합니다.)

Click(int x, int y) | sgObject::_IMap2DEvents
DoubleClick(int x, int y) | sgObject::_IMap2DEvents
Draw() | sgObject::_IMap2DEvents
Drawed() | sgObject::_IMap2DEvents
Exported() | sgObject::_IMap2DEvents
FeatureOut(IFeature *poFeature, IGeometry *poGeometry, IAnnotationLabel *poLabel) | sgObject::_IMap2DEvents
FeatureOver(IFeature *poFeature, IGeometry *poGeometry, IAnnotationLabel *poLabel) | sgObject::_IMap2DEvents
LongClick(long x, long y) | sgObject::_IMap2DEvents
MapControlChanged(int nCtrl) | sgObject::_IMap2DEvents
MapExtendChange() | sgObject::_IMap2DEvents
MapExtendChanged() | sgObject::_IMap2DEvents
MapMove() | sgObject::_IMap2DEvents
MapMoved() | sgObject::_IMap2DEvents
MapReSized(int width, int height) | sgObject::_IMap2DEvents
Paint() | sgObject::_IMap2DEvents
Printed() | sgObject::_IMap2DEvents
RightClick(int x, int y) | sgObject::_IMap2DEvents
ScreenModeChanged(ScreenModeEnum eScreenMode) | sgObject::_IMap2DEvents
SelectModeChanged(SpatialOperatorEnum eSelectMode) | sgObject::_IMap2DEvents
SensorAdded(SensorTypeEnum eType) | sgObject::_IMap2DEvents
SensorRemoved(SensorTypeEnum eType) | sgObject::_IMap2DEvents
Snap(ScreenModeEnum eScreenMode, IFeature *poFeature, IGeometry *poGeometry, int nVertexIdx, SnapModeEnum eSnapType) | sgObject::_IMap2DEvents
Snaped(ScreenModeEnum eScreenMode, IFeature *poFeature, IGeometry *poGeometry, int nVertexIdx, SnapModeEnum eSnapType) | sgObject::_IMap2DEvents
SnapModeChanged() | sgObject::_IMap2DEvents
SnapOut() | sgObject::_IMap2DEvents
SyncMoveModeChanged() | sgObject::_IMap2DEvents
TouchDown(int type, int x, int y) | sgObject::_IMap2DEvents
TouchMove(int x, int y) | sgObject::_IMap2DEvents
TouchUp(int type, int x, int y) | sgObject::_IMap2DEvents
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::_IMap3DControlEvents 인터페이스 참조

  • _IMap3DControlEvents
sgObject::_IMap3DControlEvents 인터페이스 참조

Map3D ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다. 더 자세히 ...

sgObject::_IMap3DControlEvents에 대한 상속 다이어그램 :
sgObject::_IMap3DControlEvents에 대한 협력 다이어그램:

상세한 설명

Map3D ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다.

COM+ 인터페이스에만 존재하는 ActiveX 방식의 Map3D 컨트롤 객체의 이벤트

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::_IMap3DEvents 인터페이스 참조

  • _IMap3DEvents
Public 멤버 함수 | 모든 멤버 목록
sgObject::_IMap3DEvents 인터페이스 참조

Map3D 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::_IMap3DEvents에 대한 상속 다이어그램 :
sgObject::_IMap3DEvents에 대한 협력 다이어그램:

Public 멤버 함수

void | Feature3DSelected (IFeatureLayer *poFtLayer, int nFID)
void | Feature3DDeSelected ()
void | ScreenModeChanged (ScreenModeEnum eScreenMode)
지도의 화면모드가 변경 후 발생된다. 더 자세히 ...

상세한 설명

Map3D 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다.

멤버 함수 문서화

void sgObject::_IMap3DEvents::Feature3DDeSelected ( )
void sgObject::_IMap3DEvents::Feature3DSelected | ( | IFeatureLayer * | poFtLayer,
 |  | int | nFID
 | ) |  |
void sgObject::_IMap3DEvents::ScreenModeChanged ( ScreenModeEnum eScreenMode )

지도의 화면모드가 변경 후 발생된다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • _IMap3DEvents
sgObject::_IMap3DEvents 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::_IMap3DEvents (모든 상속된 멤버들도 포함합니다.)

Feature3DDeSelected() | sgObject::_IMap3DEvents
Feature3DSelected(IFeatureLayer *poFtLayer, int nFID) | sgObject::_IMap3DEvents
ScreenModeChanged(ScreenModeEnum eScreenMode) | sgObject::_IMap3DEvents
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::_IMapARControlEvents 인터페이스 참조

  • _IMapARControlEvents
sgObject::_IMapARControlEvents 인터페이스 참조

MapAR ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다. 더 자세히 ...

sgObject::_IMapARControlEvents에 대한 상속 다이어그램 :
sgObject::_IMapARControlEvents에 대한 협력 다이어그램:

상세한 설명

MapAR ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다.

COM+ 인터페이스에만 존재하는 ActiveX 방식의 MapAR 컨트롤 객체의 이벤트

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::_IMapAREvents 인터페이스 참조

  • _IMapAREvents
Public 멤버 함수 | 모든 멤버 목록
sgObject::_IMapAREvents 인터페이스 참조

MapAR 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::_IMapAREvents에 대한 상속 다이어그램 :
sgObject::_IMapAREvents에 대한 협력 다이어그램:

Public 멤버 함수

void | Feature3DSelected (IFeatureLayer *poFtLayer, int nFID)
void | Feature3DDeSelected ()

상세한 설명

MapAR 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다.

멤버 함수 문서화

void sgObject::_IMapAREvents::Feature3DDeSelected ( )
void sgObject::_IMapAREvents::Feature3DSelected | ( | IFeatureLayer * | poFtLayer,
 |  | int | nFID
 | ) |  |
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • _IMapAREvents
sgObject::_IMapAREvents 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::_IMapAREvents (모든 상속된 멤버들도 포함합니다.)

Feature3DDeSelected() | sgObject::_IMapAREvents
Feature3DSelected(IFeatureLayer *poFtLayer, int nFID) | sgObject::_IMapAREvents
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::_IMapEarthControlEvents 인터페이스 참조

  • _IMapEarthControlEvents
sgObject::_IMapEarthControlEvents 인터페이스 참조

MapEarth ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다. 더 자세히 ...

sgObject::_IMapEarthControlEvents에 대한 상속 다이어그램 :
sgObject::_IMapEarthControlEvents에 대한 협력 다이어그램:

상세한 설명

MapEarth ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다.

COM+ 인터페이스에만 존재하는 ActiveX 방식의 MapEarth 컨트롤 객체의 이벤트

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::_IMapEarthEvents 인터페이스 참조

  • _IMapEarthEvents
Public 멤버 함수 | 모든 멤버 목록
sgObject::_IMapEarthEvents 인터페이스 참조

MapEarth 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::_IMapEarthEvents에 대한 상속 다이어그램 :
sgObject::_IMapEarthEvents에 대한 협력 다이어그램:

Public 멤버 함수

void | Feature3DSelected (IFeatureLayer *poFtLayer, int nFID)
void | Feature3DDeSelected ()
void | Click (int x, int y)
마우스를 클릭할 때 발생한다. 더 자세히 ...
void | DoubleClick (int x, int y)
마우스를 두번 연속 클릭할 때 발생한다. 더 자세히 ...
void | TouchMove (int x, int y)
마우스를 클릭하여 드래그할 때 발생한다. 더 자세히 ...
void | TouchUp (int type, int x, int y)
마우스버튼을 눌렀다 떼었을 때 발생한다. 더 자세히 ...
void | TouchDown (int type, int x, int y)
마우스버튼을 눌렀을 때 발생한다. 더 자세히 ...
void | LongClick (long x, long y)
마우스를 길게 클릭할 때 발생된다. 더 자세히 ...
void | RightClick (int x, int y)
마우스 오른쪽 버튼을 클릭할 때 발생한다. 더 자세히 ...
void | MapMove ()
지도의 중심이 이동될 때 발생된다. 더 자세히 ...
void | MapMoved ()
지도의 중심이 이동된 후 발생된다. 더 자세히 ...
void | MapExtendChange ()
지도의 외곽 좌표가 변경될 때 발생된다.(이동, 줌) 더 자세히 ...
void | MapExtendChanged ()
지도의 외곽 좌표가 변경된 후 발생된다.(이동, 줌) 더 자세히 ...
void | MapReSized (int width, int height)
지도 표현 크기(디바이스)가 변경된 후 발생된다. 더 자세히 ...
void | SensorAdded (SensorTypeEnum eType)
지도에서 센서가 추가된 경우 발생된다. 더 자세히 ...
void | SensorRemoved (SensorTypeEnum eType)
지도에서 센서가 제거될 때 발생된다. 더 자세히 ...
void | ScreenModeChanged (ScreenModeEnum eScreenMode)
지도의 화면모드가 변경 후 발생된다. 더 자세히 ...
void | Printed ()
지도를 출력창에서 출력하거나 다른 형태로 내보내기시 발생된다. 더 자세히 ...

상세한 설명

MapEarth 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다.

멤버 함수 문서화

void sgObject::_IMapEarthEvents::Click | ( | int | x,
 |  | int | y
 | ) |  |

마우스를 클릭할 때 발생한다.

매개변수
x | - 마우스의 좌표 X 값.
y | - 마우스의 좌표 Y 값.
void sgObject::_IMapEarthEvents::DoubleClick | ( | int | x,
 |  | int | y
 | ) |  |

마우스를 두번 연속 클릭할 때 발생한다.

매개변수
x | - 마우스의 좌표 X 값.
y | - 마우스의 좌표 Y 값.
void sgObject::_IMapEarthEvents::Feature3DDeSelected ( )
void sgObject::_IMapEarthEvents::Feature3DSelected | ( | IFeatureLayer * | poFtLayer,
 |  | int | nFID
 | ) |  |
void sgObject::_IMapEarthEvents::LongClick | ( | long | x,
 |  | long | y
 | ) |  |

마우스를 길게 클릭할 때 발생된다.

매개변수
x | - 마우스의 좌표 X 값.
y | - 마우스의 좌표 Y 값.
void sgObject::_IMapEarthEvents::MapExtendChange ( )

지도의 외곽 좌표가 변경될 때 발생된다.(이동, 줌)

void sgObject::_IMapEarthEvents::MapExtendChanged ( )

지도의 외곽 좌표가 변경된 후 발생된다.(이동, 줌)

void sgObject::_IMapEarthEvents::MapMove ( )

지도의 중심이 이동될 때 발생된다.

void sgObject::_IMapEarthEvents::MapMoved ( )

지도의 중심이 이동된 후 발생된다.

void sgObject::_IMapEarthEvents::MapReSized | ( | int | width,
 |  | int | height
 | ) |  |

지도 표현 크기(디바이스)가 변경된 후 발생된다.

void sgObject::_IMapEarthEvents::Printed ( )

지도를 출력창에서 출력하거나 다른 형태로 내보내기시 발생된다.

void sgObject::_IMapEarthEvents::RightClick | ( | int | x,
 |  | int | y
 | ) |  |

마우스 오른쪽 버튼을 클릭할 때 발생한다.

매개변수
x | - 마우스의 좌표 X 값.
y | - 마우스의 좌표 Y 값.
void sgObject::_IMapEarthEvents::ScreenModeChanged ( ScreenModeEnum eScreenMode )

지도의 화면모드가 변경 후 발생된다.

void sgObject::_IMapEarthEvents::SensorAdded ( SensorTypeEnum eType )

지도에서 센서가 추가된 경우 발생된다.

void sgObject::_IMapEarthEvents::SensorRemoved ( SensorTypeEnum eType )

지도에서 센서가 제거될 때 발생된다.

void sgObject::_IMapEarthEvents::TouchDown | ( | int | type,
 |  | int | x,
 |  | int | y
 | ) |  |

마우스버튼을 눌렀을 때 발생한다.

매개변수
type | - 마우스 버튼의 종류(왼쪽, 오른쪽, 중간 등).
x | - 마우스의 좌표 X 값.
y | - 마우스의 좌표 Y 값.
void sgObject::_IMapEarthEvents::TouchMove | ( | int | x,
 |  | int | y
 | ) |  |

마우스를 클릭하여 드래그할 때 발생한다.

매개변수
x | - 마우스의 좌표 X 값.
y | - 마우스의 좌표 Y 값.
void sgObject::_IMapEarthEvents::TouchUp | ( | int | type,
 |  | int | x,
 |  | int | y
 | ) |  |

마우스버튼을 눌렀다 떼었을 때 발생한다.

매개변수
type | - 마우스 버튼의 종류(왼쪽, 오른쪽, 중간 등).
x | - 마우스의 좌표 X 값.
y | - 마우스의 좌표 Y 값.
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • _IMapEarthEvents
sgObject::_IMapEarthEvents 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::_IMapEarthEvents (모든 상속된 멤버들도 포함합니다.)

Click(int x, int y) | sgObject::_IMapEarthEvents
DoubleClick(int x, int y) | sgObject::_IMapEarthEvents
Feature3DDeSelected() | sgObject::_IMapEarthEvents
Feature3DSelected(IFeatureLayer *poFtLayer, int nFID) | sgObject::_IMapEarthEvents
LongClick(long x, long y) | sgObject::_IMapEarthEvents
MapExtendChange() | sgObject::_IMapEarthEvents
MapExtendChanged() | sgObject::_IMapEarthEvents
MapMove() | sgObject::_IMapEarthEvents
MapMoved() | sgObject::_IMapEarthEvents
MapReSized(int width, int height) | sgObject::_IMapEarthEvents
Printed() | sgObject::_IMapEarthEvents
RightClick(int x, int y) | sgObject::_IMapEarthEvents
ScreenModeChanged(ScreenModeEnum eScreenMode) | sgObject::_IMapEarthEvents
SensorAdded(SensorTypeEnum eType) | sgObject::_IMapEarthEvents
SensorRemoved(SensorTypeEnum eType) | sgObject::_IMapEarthEvents
TouchDown(int type, int x, int y) | sgObject::_IMapEarthEvents
TouchMove(int x, int y) | sgObject::_IMapEarthEvents
TouchUp(int type, int x, int y) | sgObject::_IMapEarthEvents
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::_IMotionSensorEvents 인터페이스 참조

  • _IMotionSensorEvents
sgObject::_IMotionSensorEvents 인터페이스 참조

MotionSensor 객체에 발생하는 이벤트 처리를 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::_IMotionSensorEvents에 대한 상속 다이어그램 :
sgObject::_IMotionSensorEvents에 대한 협력 다이어그램:

상세한 설명

MotionSensor 객체에 발생하는 이벤트 처리를 위한 인터페이스를 제공한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::_IVideoSensorEvents 인터페이스 참조

  • _IVideoSensorEvents
sgObject::_IVideoSensorEvents 인터페이스 참조

Camera 장치와 연결하여 Video 수신 기능을 행하는 VideoSensor 객체에 이벤트 처리를 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::_IVideoSensorEvents에 대한 상속 다이어그램 :
sgObject::_IVideoSensorEvents에 대한 협력 다이어그램:

상세한 설명

Camera 장치와 연결하여 Video 수신 기능을 행하는 VideoSensor 객체에 이벤트 처리를 위한 인터페이스를 제공한다.

Camera 장치로부터 수신되는 정보는 _IVideoSensorEvents 인터페이스를 통해 이벤트로 제공된다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::AggregateGraphic 클래스 참조

  • AggregateGraphic
sgObject::AggregateGraphic 클래스 참조
sgObject::AggregateGraphic에 대한 협력 다이어그램:
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Animator 클래스 참조

  • Animator
sgObject::Animator 클래스 참조

Animator는 Graphic객체를 Animation하는 객체이다. 자세한 내용은 IAnimator 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::Animator에 대한 협력 다이어그램:

상세한 설명

Animator는 Graphic객체를 Animation하는 객체이다. 자세한 내용은 IAnimator 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Annotation 클래스 참조

  • Annotation
sgObject::Annotation 클래스 참조

Feature 객체의 주석 정보 (간단한 텍스트 정보)를 관리한다. 더 자세히 ...

sgObject::Annotation에 대한 협력 다이어그램:

상세한 설명

Feature 객체의 주석 정보 (간단한 텍스트 정보)를 관리한다.

자세한 설명은 IAnnotation 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::AnnotationLabel 클래스 참조

  • AnnotationLabel
sgObject::AnnotationLabel 클래스 참조

AnnotationLabel는 Feature 객체의 주석 텍스트를 관리하는 객체이다. 더 자세히 ...

sgObject::AnnotationLabel에 대한 협력 다이어그램:

상세한 설명

AnnotationLabel는 Feature 객체의 주석 텍스트를 관리하는 객체이다.

한 개의 Feature 객체는 여러 개의 주석 텍스트를 갖을 수 있다. 한 개의 주석 텍스트는 Label 객체를 통해 관리되며, Annotation 객체는 Label 객체의 집합을 관리한다. 자세한 설명은 IAnnotationLabel 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Application 클래스 참조

  • Application
sgObject::Application 클래스 참조
sgObject::Application에 대한 협력 다이어그램:
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ApplicationControl 클래스 참조

  • ApplicationControl
sgObject::ApplicationControl 클래스 참조
sgObject::ApplicationControl에 대한 협력 다이어그램:
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::AttributeIndex 클래스 참조

  • AttributeIndex
sgObject::AttributeIndex 클래스 참조

AttributeIndex 객체는 FeatureCollection 객체에 Spatial Indexing 기능을 제공하고, 이를 사용하여 빠른 공간 검색 (공간 연산을 통한 부분집합 검색) 기능을 FeatureCollection 객체에 제공한다. 더 자세히 ...

sgObject::AttributeIndex에 대한 협력 다이어그램:

상세한 설명

AttributeIndex 객체는 FeatureCollection 객체에 Spatial Indexing 기능을 제공하고, 이를 사용하여 빠른 공간 검색 (공간 연산을 통한 부분집합 검색) 기능을 FeatureCollection 객체에 제공한다.

자세한 설명은 IAttributeIndex 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Chart 클래스 참조

  • Chart
sgObject::Chart 클래스 참조

Chart 클래스. 자세한 내용은 IChart 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::Chart에 대한 협력 다이어그램:

상세한 설명

Chart 클래스. 자세한 내용은 IChart 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::CommonFactory 클래스 참조

  • CommonFactory
sgObject::CommonFactory 클래스 참조

CommonFactory 클래스. 자세한 내용은 ICommonFactory 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::CommonFactory에 대한 협력 다이어그램:

상세한 설명

CommonFactory 클래스. 자세한 내용은 ICommonFactory 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::CoverageFactory 클래스 참조

  • CoverageFactory
sgObject::CoverageFactory 클래스 참조

CoverageFactory 클래스. 자세한 내용은 ICoverageFactory 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::CoverageFactory에 대한 협력 다이어그램:

상세한 설명

CoverageFactory 클래스. 자세한 내용은 ICoverageFactory 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::DefaultTransaction 클래스 참조

  • DefaultTransaction
sgObject::DefaultTransaction 클래스 참조

DefaultTransaction 객체는 작업의 전체 세트가 동시에 롤백 또는 커밋 할 수있는 작업을 제공합니다. 더 자세히 ...

sgObject::DefaultTransaction에 대한 협력 다이어그램:

상세한 설명

DefaultTransaction 객체는 작업의 전체 세트가 동시에 롤백 또는 커밋 할 수있는 작업을 제공합니다.

자세한 설명은 IDefaultTransaction 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::DisplayFactory 클래스 참조

  • DisplayFactory
sgObject::DisplayFactory 클래스 참조

DisplayFactory 클래스. 자세한 내용은 IDisplayFactory 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::DisplayFactory에 대한 협력 다이어그램:

상세한 설명

DisplayFactory 클래스. 자세한 내용은 IDisplayFactory 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::DockWidget 클래스 참조

  • DockWidget
sgObject::DockWidget 클래스 참조
sgObject::DockWidget에 대한 협력 다이어그램:
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Feature 클래스 참조

  • Feature
sgObject::Feature 클래스 참조

Feature 객체는 Object를 활용한 GIS 애플리케이션에서 실세계의 객체를 표현하는 기본 단위로 Feature 객체를 데이터베이스와 대응시키면 레코드 한 개와 대응된다. 더 자세히 ...

sgObject::Feature에 대한 협력 다이어그램:

상세한 설명

Feature 객체는 Object를 활용한 GIS 애플리케이션에서 실세계의 객체를 표현하는 기본 단위로 Feature 객체를 데이터베이스와 대응시키면 레코드 한 개와 대응된다.

자세한 설명은 IFeature 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::FeatureAttributeDescriptor 클래스 참조

  • FeatureAttributeDescriptor
sgObject::FeatureAttributeDescriptor 클래스 참조

FeatureAttributeDescriptor 객체는 Feature 객체에 저장된 일반 (속성) 정보 필드 한 개의 구조를 설명하는 객체이다. (데이터 타입 등) 더 자세히 ...

sgObject::FeatureAttributeDescriptor에 대한 협력 다이어그램:

상세한 설명

FeatureAttributeDescriptor 객체는 Feature 객체에 저장된 일반 (속성) 정보 필드 한 개의 구조를 설명하는 객체이다. (데이터 타입 등)

자세한 설명은 IFeatureAttributeDescriptor 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::FeatureAttributeTreeWidget 클래스 참조

  • FeatureAttributeTreeWidget
sgObject::FeatureAttributeTreeWidget 클래스 참조
sgObject::FeatureAttributeTreeWidget에 대한 협력 다이어그램:
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::FeatureCanvas 클래스 참조

  • FeatureCanvas
sgObject::FeatureCanvas 클래스 참조

FeatureCanvas는 화면에 표현할 수 있는 여러 개의 FeatureLayer가 저장된 객체로 Map2D 객체를 통해 FeatureCanvas에 있는 Feature들을 실제 모니터 화면에 표현한다. 더 자세히 ...

sgObject::FeatureCanvas에 대한 협력 다이어그램:

상세한 설명

FeatureCanvas는 화면에 표현할 수 있는 여러 개의 FeatureLayer가 저장된 객체로 Map2D 객체를 통해 FeatureCanvas에 있는 Feature들을 실제 모니터 화면에 표현한다.

Document/View 구조에서 FeatureCanvas는 Document, Map2D는 View에 해당한다. 자세한 설명은 IFeatureCanvas 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::FeatureCollection 클래스 참조

  • FeatureCollection
sgObject::FeatureCollection 클래스 참조

FeatureCollection은 같은 종류의 Feature 객체들의 집합을 관리하는 객체이다. 더 자세히 ...

sgObject::FeatureCollection에 대한 협력 다이어그램:

상세한 설명

FeatureCollection은 같은 종류의 Feature 객체들의 집합을 관리하는 객체이다.

FeatureCollection 객체를 데이터베이스와 대응시키면 쿼리를 통해 얻어진 레코드들 혹은 테이블과 대응된다. 자세한 설명은 IFeatureCollection 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::FeatureLayer 클래스 참조

  • FeatureLayer
sgObject::FeatureLayer 클래스 참조

GIS에서는 데이터를 화면에 표현하기 위해 관리할 때 보통 Layer의 개념을 도입해 객체 종류별 관리를 한다. 더 자세히 ...

sgObject::FeatureLayer에 대한 협력 다이어그램:

상세한 설명

GIS에서는 데이터를 화면에 표현하기 위해 관리할 때 보통 Layer의 개념을 도입해 객체 종류별 관리를 한다.

FeatureLayer는 한 Layer에 속한 Feature들의 모음인 FeatureCollection을 갖고 있으며 이들을 화면에 표현하기 위한 정보를 갖고 있다. FeatureLayer는 LayerSource에서 Layer를 가져올 때 자동 생성된다. 자세한 설명은 IFeatureLayer 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::FeatureQuery 클래스 참조

  • FeatureQuery
sgObject::FeatureQuery 클래스 참조

FeatureQuery는 주어진 Query 조건에 맞는 Feature 객체를 선별하기 위한 기능을 FeatureCollection에 제공하는 객체이다. 더 자세히 ...

sgObject::FeatureQuery에 대한 협력 다이어그램:

상세한 설명

FeatureQuery는 주어진 Query 조건에 맞는 Feature 객체를 선별하기 위한 기능을 FeatureCollection에 제공하는 객체이다.

자세한 설명은 IFeatureQuery 설명을 참고한다

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::FeatureType 클래스 참조

  • FeatureType
sgObject::FeatureType 클래스 참조

FeatureType은 Feature 객체가 어떤 타입인지를 나타내는 객체이다. 더 자세히 ...

sgObject::FeatureType에 대한 협력 다이어그램:

상세한 설명

FeatureType은 Feature 객체가 어떤 타입인지를 나타내는 객체이다.

FeatureType 객체를 데이터베이스와 대응시키면 레코드의 구조를 나타내는 테이블 스키마에 대응된다. FeatureType 객체는 FeatureAttributeDescriptor 객체의 집합이다. 자세한 설명은 IFeatureType 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::FeatureTypeStyle 클래스 참조

  • FeatureTypeStyle
sgObject::FeatureTypeStyle 클래스 참조

FeatureTypeStyle 클래스. 자세한 내용은 IFeatureTypeStyle 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::FeatureTypeStyle에 대한 협력 다이어그램:

상세한 설명

FeatureTypeStyle 클래스. 자세한 내용은 IFeatureTypeStyle 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::FeatureTypeStyleFactory 클래스 참조

  • FeatureTypeStyleFactory
sgObject::FeatureTypeStyleFactory 클래스 참조

FeatureTypeStyleFactory는 FeatureStyle 객체 및 Symbolizer객체를 생성하는 객체이다. 더 자세히 ...

sgObject::FeatureTypeStyleFactory에 대한 협력 다이어그램:

상세한 설명

FeatureTypeStyleFactory는 FeatureStyle 객체 및 Symbolizer객체를 생성하는 객체이다.

자세한 설명은 IFeatureTypeStyleFactory 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::FeatureTypeStyleRule 클래스 참조

  • FeatureTypeStyleRule
sgObject::FeatureTypeStyleRule 클래스 참조

FeatureTypeStyleRule 클래스. 자세한 내용은 IFeatureTypeStyleRule 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::FeatureTypeStyleRule에 대한 협력 다이어그램:

상세한 설명

FeatureTypeStyleRule 클래스. 자세한 내용은 IFeatureTypeStyleRule 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Fill 클래스 참조

  • Fill
sgObject::Fill 클래스 참조

자세한 설명은 IFill 설명을 참고한다. 더 자세히 ...

sgObject::Fill에 대한 협력 다이어그램:

상세한 설명

자세한 설명은 IFill 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Font 클래스 참조

  • Font
sgObject::Font 클래스 참조

자세한 설명은 IText 설명을 참고한다. 더 자세히 ...

sgObject::Font에 대한 협력 다이어그램:

상세한 설명

자세한 설명은 IText 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Generator3D 클래스 참조

  • Generator3D
sgObject::Generator3D 클래스 참조

Generator3D 인터페이스는 2D를 3D로 변환하기 위한 객체이다. 더 자세히 ...

sgObject::Generator3D에 대한 협력 다이어그램:

상세한 설명

Generator3D 인터페이스는 2D를 3D로 변환하기 위한 객체이다.

자세한 설명은 IGenerator3D 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GeographicTransform 클래스 참조

  • GeographicTransform
sgObject::GeographicTransform 클래스 참조

GeographicTransform. 더 자세히 ...

sgObject::GeographicTransform에 대한 협력 다이어그램:

상세한 설명

GeographicTransform.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GeometryCollection 클래스 참조

  • GeometryCollection
sgObject::GeometryCollection 클래스 참조

GeometryCollection은 기하 객체 모델의 GeometryCollection을 나타내는 객체이다. 더 자세히 ...

sgObject::GeometryCollection에 대한 협력 다이어그램:

상세한 설명

GeometryCollection은 기하 객체 모델의 GeometryCollection을 나타내는 객체이다.

기하 컬렉션의 객체들은 IGeometrycollection 인터페이스를 제공한다. 이 IGeometry Collection 인터페이스는 기하 컬렉션 객체들의 구성 요소에 접근하기 위해 인덱스를 사용한다. 집합내의 구성 요소들의 순서는 컬렉션의 정의에 따라 순서화 된다. 자세한 설명은 IGeometryCollection 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GeometryFactory 클래스 참조

  • GeometryFactory
sgObject::GeometryFactory 클래스 참조

GeometryFactory는 기하를 생성하는 기능을 제공하는 객체이다. 더 자세히 ...

sgObject::GeometryFactory에 대한 협력 다이어그램:

상세한 설명

GeometryFactory는 기하를 생성하는 기능을 제공하는 객체이다.

IGeometryFactory 인터페이스는 주어진 기하의 잘 알려진 표현을 이용해서 기하를 생성하는데 이용되는 메소드들을 정의한다. 클라이언트는 표현된 기하타입을 미리 알지 못하더라도 기하생성이 가능하다. 이것은 주어진 잘 알려진 표현에서 다른 클래스에 포함되는 기하 객체 집합을 생성하는 간편한 방법을 제공한다. 자세한 설명은 IGeometryFactory 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GPDLayerSource 클래스 참조

  • GPDLayerSource
sgObject::GPDLayerSource 클래스 참조

[업데이트 예정] 더 자세히 ...

sgObject::GPDLayerSource에 대한 협력 다이어그램:

상세한 설명

[업데이트 예정]

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Graph 클래스 참조

  • Graph
sgObject::Graph 클래스 참조

Graph 클래스. 자세한 내용은 IGraph 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::Graph에 대한 협력 다이어그램:

상세한 설명

Graph 클래스. 자세한 내용은 IGraph 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GraphicArc 클래스 참조

  • GraphicArc
sgObject::GraphicArc 클래스 참조
sgObject::GraphicArc에 대한 협력 다이어그램:
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GraphicCanvas 클래스 참조

  • GraphicCanvas
sgObject::GraphicCanvas 클래스 참조
sgObject::GraphicCanvas에 대한 협력 다이어그램:
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GraphicIcon 클래스 참조

  • GraphicIcon
sgObject::GraphicIcon 클래스 참조
sgObject::GraphicIcon에 대한 협력 다이어그램:
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GraphicLabel 클래스 참조

  • GraphicLabel
sgObject::GraphicLabel 클래스 참조
sgObject::GraphicLabel에 대한 협력 다이어그램:
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GraphicLineString 클래스 참조

  • GraphicLineString
sgObject::GraphicLineString 클래스 참조
sgObject::GraphicLineString에 대한 협력 다이어그램:
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GraphicPolygon 클래스 참조

  • GraphicPolygon
sgObject::GraphicPolygon 클래스 참조
sgObject::GraphicPolygon에 대한 협력 다이어그램:
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GraphicRectangle 클래스 참조

  • GraphicRectangle
sgObject::GraphicRectangle 클래스 참조
sgObject::GraphicRectangle에 대한 협력 다이어그램:
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GraphicScaledImage 클래스 참조

  • GraphicScaledImage
sgObject::GraphicScaledImage 클래스 참조
sgObject::GraphicScaledImage에 대한 협력 다이어그램:
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GridColorRampStyle 클래스 참조

  • GridColorRampStyle
sgObject::GridColorRampStyle 클래스 참조

GridColorRampStyle 클래스. 자세한 내용은 IGridColorRampStyle 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::GridColorRampStyle에 대한 협력 다이어그램:

상세한 설명

GridColorRampStyle 클래스. 자세한 내용은 IGridColorRampStyle 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GridCoverage 클래스 참조

  • GridCoverage
sgObject::GridCoverage 클래스 참조

GridCoverage 클래스. 자세한 내용은 IGridCoverage 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::GridCoverage에 대한 협력 다이어그램:

상세한 설명

GridCoverage 클래스. 자세한 내용은 IGridCoverage 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GridCoverageProcessor 클래스 참조

  • GridCoverageProcessor
sgObject::GridCoverageProcessor 클래스 참조

GridCoverageProcessor 클래스. 자세한 내용은 IGridCoverageProcessor 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::GridCoverageProcessor에 대한 협력 다이어그램:

상세한 설명

GridCoverageProcessor 클래스. 자세한 내용은 IGridCoverageProcessor 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GridGeneralizeOp 클래스 참조

  • GridGeneralizeOp
sgObject::GridGeneralizeOp 클래스 참조
sgObject::GridGeneralizeOp에 대한 협력 다이어그램:
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GridHydrologyOp 클래스 참조

  • GridHydrologyOp
sgObject::GridHydrologyOp 클래스 참조

GridHydrologyOp 클래스. 자세한 내용은 IGridHydrologyOp 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::GridHydrologyOp에 대한 협력 다이어그램:

상세한 설명

GridHydrologyOp 클래스. 자세한 내용은 IGridHydrologyOp 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GridInterpolationOp 클래스 참조

  • GridInterpolationOp
sgObject::GridInterpolationOp 클래스 참조

GridInterpolationOp 클래스. 자세한 내용은 IGridInterpolationOp 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::GridInterpolationOp에 대한 협력 다이어그램:

상세한 설명

GridInterpolationOp 클래스. 자세한 내용은 IGridInterpolationOp 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GridMathOp 클래스 참조

  • GridMathOp
sgObject::GridMathOp 클래스 참조

GridMathOp 클래스. 자세한 내용은 IGridMathOp 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::GridMathOp에 대한 협력 다이어그램:

상세한 설명

GridMathOp 클래스. 자세한 내용은 IGridMathOp 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GridMorphometryOp 클래스 참조

  • GridMorphometryOp
sgObject::GridMorphometryOp 클래스 참조

GridMorphometryOp 클래스. 자세한 내용은 IGridMorphometryOp 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::GridMorphometryOp에 대한 협력 다이어그램:

상세한 설명

GridMorphometryOp 클래스. 자세한 내용은 IGridMorphometryOp 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GridPreprocessOp 클래스 참조

  • GridPreprocessOp
sgObject::GridPreprocessOp 클래스 참조

GridPreprocessOp 클래스. 자세한 내용은 IGridPreprocessOp 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::GridPreprocessOp에 대한 협력 다이어그램:

상세한 설명

GridPreprocessOp 클래스. 자세한 내용은 IGridPreprocessOp 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GridSurfaceOp 클래스 참조

  • GridSurfaceOp
sgObject::GridSurfaceOp 클래스 참조

GridSurfaceOp 클래스. 자세한 내용은 IGridSurfaceOp 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::GridSurfaceOp에 대한 협력 다이어그램:

상세한 설명

GridSurfaceOp 클래스. 자세한 내용은 IGridSurfaceOp 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::GridVisibilityOp 클래스 참조

  • GridVisibilityOp
sgObject::GridVisibilityOp 클래스 참조

GridVisibilityOp 클래스. 자세한 내용은 IGridVisibilityOp 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::GridVisibilityOp에 대한 협력 다이어그램:

상세한 설명

GridVisibilityOp 클래스. 자세한 내용은 IGridVisibilityOp 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IAggregateGraphic 인터페이스 참조

  • IAggregateGraphic
Public 멤버 함수 | 모든 멤버 목록
sgObject::IAggregateGraphic 인터페이스 참조

다수의 그래픽 객체의 집합 형태를 그래픽화 하여 표현하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::IAggregateGraphic에 대한 상속 다이어그램 :
sgObject::IAggregateGraphic에 대한 협력 다이어그램:

Public 멤버 함수

void | AddChild (IGraphic *child)
void | AddChildren (IGraphic *children, int nCnt)
void | RemoveChild (IGraphic *child)
void | RemoveChildren ()
IGraphic * | ReplaceChild (IGraphic *oldChild, IGraphic *newchild)
int | GetChildCount ()

상세한 설명

다수의 그래픽 객체의 집합 형태를 그래픽화 하여 표현하는 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "AGP"를 덧붙여서 "OGR_AGP_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.AggregateGraphic"

멤버 함수 문서화

void sgObject::IAggregateGraphic::AddChild ( IGraphic * child )
void sgObject::IAggregateGraphic::AddChildren | ( | IGraphic * | children,
 |  | int | nCnt
 | ) |  |
int sgObject::IAggregateGraphic::GetChildCount ( )
void sgObject::IAggregateGraphic::RemoveChild ( IGraphic * child )
void sgObject::IAggregateGraphic::RemoveChildren ( )
IGraphic* sgObject::IAggregateGraphic::ReplaceChild | ( | IGraphic * | oldChild,
 |  | IGraphic * | newchild
 | ) |  |
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IAggregateGraphic
sgObject::IAggregateGraphic 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IAggregateGraphic (모든 상속된 멤버들도 포함합니다.)

AddChild(IGraphic *child) | sgObject::IAggregateGraphic
AddChildren(IGraphic *children, int nCnt) | sgObject::IAggregateGraphic
GetChildCount() | sgObject::IAggregateGraphic
RemoveChild(IGraphic *child) | sgObject::IAggregateGraphic
RemoveChildren() | sgObject::IAggregateGraphic
ReplaceChild(IGraphic *oldChild, IGraphic *newchild) | sgObject::IAggregateGraphic
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IAnimator 인터페이스 참조

  • IAnimator
sgObject::IAnimator 인터페이스 참조

그래픽 객체의 애니메이션 효과를 제공하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::IAnimator에 대한 상속 다이어그램 :
sgObject::IAnimator에 대한 협력 다이어그램:

상세한 설명

그래픽 객체의 애니메이션 효과를 제공하는 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "AN"를 덧붙여서 "OGR_AN_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Animator"

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IAnnotation 인터페이스 참조

  • IAnnotation
Public 멤버 함수 | 모든 멤버 목록
sgObject::IAnnotation 인터페이스 참조

Feature 객체의 주석 정보 (간단한 텍스트 정보)를 관리하는 주석 객체에 인터페이스를 제공한다. 더 자세히 ...

sgObject::IAnnotation에 대한 상속 다이어그램 :
sgObject::IAnnotation에 대한 협력 다이어그램:

Public 멤버 함수

IFeature * GetFeature ()
주석 객체가 속한 Feature 객체를 반환한다. 더 자세히 ...
void | SetFeature ([in] IFeature *pdspFeature)
주석 객체가 속한 Feature 객체를 설정한다. 더 자세히 ...
int | GetSize ()
주석 객체에 소속된 Text 객체의 개수를 반환한다. 더 자세히 ...
IAnnotationLabel * | GetLabel ([in] int nIndex)
해당 인덱스의 라벨 객체를 가져온다. 더 자세히 ...
VARIANT_BOOL | Add ([in] IAnnotationLabel *pdspLabel)
라벨 객체를 추가한다. (인덱스 번호는 최종 인덱스 + 1) 더 자세히 ...
VARIANT_BOOL | Remove ([in] IAnnotationLabel *pdspLabel)
라벨 객체를 삭제한다. 더 자세히 ...
VARIANT_BOOL | RemoveAll ()
소속된 모든 라벨 객체를 삭제한다. 더 자세히 ...
void | Sort ()
소속된 라벨 객체를 정렬한다. 더 자세히 ...

상세한 설명

Feature 객체의 주석 정보 (간단한 텍스트 정보)를 관리하는 주석 객체에 인터페이스를 제공한다.

한 개의 Feature 객체가 여러 개의 주석 텍스트를 갖을 수 있게 지원한다. 한 개의 주석 텍스트는 Label 객체를 통해 관리되며, 주석 객체는 라벨 객체의 집합을 관리한다. C API(linux, iOS, MacOS 등) : 중간이름 "AT"를 덧붙여서 "OGR_AT_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Annotation"

멤버 함수 문서화

VARIANT_BOOL sgObject::IAnnotation::Add ( [in] IAnnotationLabel * pdspLabel )

라벨 객체를 추가한다. (인덱스 번호는 최종 인덱스 + 1)

매개변수
pdspLabel - 라벨 객체를 가리키는 포인터
반환값
성공이면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
IFeature* sgObject::IAnnotation::GetFeature ( )

주석 객체가 속한 Feature 객체를 반환한다.

반환값
주석 객체가 속한 Feature 객체의 포인터
IAnnotationLabel* sgObject::IAnnotation::GetLabel ( [in] int nIndex )

해당 인덱스의 라벨 객체를 가져온다.

매개변수
nIndex - 인덱스 번호
반환값
라벨 객체를 가리키는 포인터
int sgObject::IAnnotation::GetSize ( )

주석 객체에 소속된 Text 객체의 개수를 반환한다.

반환값
주석 객체에 소속된 Text 객체의 개수
VARIANT_BOOL sgObject::IAnnotation::Remove ( [in] IAnnotationLabel * pdspLabel )

라벨 객체를 삭제한다.

매개변수
pdspLabel - 삭제할 라벨 객체를 가리키는 포인터
반환값
성공이면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
VARIANT_BOOL sgObject::IAnnotation::RemoveAll ( )

소속된 모든 라벨 객체를 삭제한다.

반환값
성공이면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
void sgObject::IAnnotation::SetFeature ( [in] IFeature * pdspFeature )

주석 객체가 속한 Feature 객체를 설정한다.

반환값
주석 객체가 속한 Feature 객체의 포인터
void sgObject::IAnnotation::Sort ( )

소속된 라벨 객체를 정렬한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IAnnotation
sgObject::IAnnotation 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IAnnotation (모든 상속된 멤버들도 포함합니다.)

Add([in] IAnnotationLabel *pdspLabel) | sgObject::IAnnotation
GetFeature() | sgObject::IAnnotation
GetLabel([in] int nIndex) | sgObject::IAnnotation
GetSize() | sgObject::IAnnotation
Remove([in] IAnnotationLabel *pdspLabel) | sgObject::IAnnotation
RemoveAll() | sgObject::IAnnotation
SetFeature([in] IFeature *pdspFeature) | sgObject::IAnnotation
Sort() | sgObject::IAnnotation
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IAnnotationLabel 인터페이스 참조

  • IAnnotationLabel
Public 멤버 함수 | 모든 멤버 목록
sgObject::IAnnotationLabel 인터페이스 참조

Feature 객체의 주석 텍스트를 관리하는 라벨 객체에 인터페이스를 제공한다. 더 자세히 ...

sgObject::IAnnotationLabel에 대한 상속 다이어그램 :
sgObject::IAnnotationLabel에 대한 협력 다이어그램:

Public 멤버 함수

ILayer * GetLayer ()
해당 주석이 포함된 레이어를 반환한다. 더 자세히 ...
void | SetLayer ([in] ILayer *pdspLayer)
해당 주석이 포함된 레이어를 설정한다. 더 자세히 ...
BSTR | GetText ()
주석 텍스트를 반환한다. 더 자세히 ...
void | SetText ([in] BSTR bstrText)
주석 텍스트를 설정한다. 더 자세히 ...
int | GetOrder ()
주석 텍스트의 정렬을 위한 번호를 반환한다. 더 자세히 ...
void | SetOrder ([in] int nOrder)
주석 텍스트의 정렬을 위한 번호를 설정한다. 더 자세히 ...
IFeature * GetFeature ()
- sgObject::IFeature(으)로부터 상속된 Public 멤버 함수
ISymbolizer * GetSymbolizer ()
Feature 객체가 화면에 그려질 때 필요한 색상, 선굵기 등 그래픽 속성에 관련된 정보를 나타내는 Symbolizer 객체를 반환한다. 더 자세히 ...
void | SetSymbolizer (ISymbolizer *dspSymbolizer)
Feature 객체가 화면에 그려질 때 필요한 색상, 선굵기 등 그래픽 속성에 관련된 정보를 나타내는 Symbolizer 객체를 설정한다. 더 자세히 ...
IFeatureType * GetFeatureType ()
Feature 객체가 어떤 타입인지, 저장된 일반 (속성) 정보들의 타입 등에 대한 정보를 나타내는 FeatureType 객체를 반환한다. 더 자세히 ...
IGeometry * GetGeometry ()
Feature 객체가 갖는 기하 정보를 나타내는 기하를 반환한다. (위치 및 기하 정보) 더 자세히 ...
void | SetGeometry (IGeometry *dspGeom)
Feature 객체가 갖는 기하 정보를 나타내는 기하를 설정한다. (위치 및 기하 정보) 더 자세히 ...
IFeatureCollection * GetFeatureCollection ()
Feature 객체가 속한 FeatureCollection 객체를 반환한다. 더 자세히 ...
IAnnotation * GetAnnotation ()
Feature 객체에 대한 주석 정보를 나타내는 주석 객체를 반환한다. 더 자세히 ...
void | SetAnnotation (IAnnotation *dspAnno)
Feature 객체에 대한 주석 정보를 나타내는 주석 객체를 설정한다. 더 자세히 ...
int | GetID ()
Feature 객체를 식별하기 위한 ID를 반환한다. (데이터베이스의 Unique Key와 대응된다) 더 자세히 ...
void | SetID (int nVal)
Feature 객체를 식별하기 위한 ID를 설정한다. (데이터베이스의 Unique Key와 대응된다) 더 자세히 ...
long | GetData ()
사용자가 정의한 필터값을 반환한다. 더 자세히 ...
void | SetData (long filter)
Feature 사용자가 정의한 필터값을 설정한다. 더 자세히 ...
VARIANT_BOOL | GetVisible ()
Feature 객체를 화면에 보여줄지 여부를 반환한다. 더 자세히 ...
void | SetVisible (VARIANT_BOOL bVal)
Feature 객체를 화면에 보여줄지 여부를 설정한다. 더 자세히 ...
VARIANT_BOOL | GetSelected ()
Feature 객체의 선택가능 여부를 반환한다. 더 자세히 ...
void | SetSelected (VARIANT_BOOL bVal)
Feature 객체의 선택가능 여부를 설정한다. 더 자세히 ...
IGeometry * GetAnnotationLine ()
인출선을 가리키는 기하를 반환한다. (*인출선 : 시설물 등 근처에 주석이 많을 경우 선을 빼서 주석을 그리기 위한 용도로 쓰임) 더 자세히 ...
void | SetAnnotationLine (IGeometry *dspGeom)
인출선을 가리키는 기하를 설정한다. (*인출선 : 시설물 등 근처에 주석이 많을 경우 선을 빼서 주석을 그리기 위한 용도로 쓰임) 더 자세히 ...
VARIANT_BOOL | GetVisibleAnnotation ()
주석을 화면에 보여줄지 여부를 반환한다 더 자세히 ...
void | SetVisibleAnnotation (VARIANT_BOOL bVal)
주석을 화면에 보여줄지 여부를 설정한다 더 자세히 ...
VARIANT_BOOL | GetVisibleAnnotationLine ()
인출선을 화면에 보여줄지 여부를 반환한다. 더 자세히 ...
void | SetVisibleAnnotationLine (VARIANT_BOOL bVal)
인출선을 화면에 보여줄지 여부를 반환한다. 더 자세히 ...
IUserDefinedWidget * GetUserDefinedWidget ()
사용자가 정의한 위젯 객체(도표 등)인 UserDefinedWidget 객체를 반환한다. 더 자세히 ...
void | SetUserDefinedWidget (IUserDefinedWidget *dspWidget)
사용자가 정의한 위젯 객체(도표 등)인 UserDefinedWidget 객체를 설정한다. 더 자세히 ...
VARIANT_BOOL | GetVisibleUserDefinedWidget ()
사용자가 정의한 위젯 객체(도표 등)인 UserDefinedWidget 객체를 화면에 보여줄지 여부를 반환한다. 더 자세히 ...
void | SetVisibleUserDefinedWidget (VARIANT_BOOL bVal)
사용자가 정의한 위젯 객체(도표 등)인 UserDefinedWidget 객체를 화면에 보여줄지 여부를 설정한다. 더 자세히 ...
IGeometry * GetBounds ()
Feature 객체의 기하를 감싸는 최소 직사각형의 기하를 반환한다. 더 자세히 ...
void | SetAttribute ([in] VARIANT vtIdx, [in] VARIANT vtVal)
해당 인덱스로 Feature 객체의 일반 (속성) 정보 한 개를 저장한다. 더 자세히 ...
BSTR | GetAttributeToString ([in] VARIANT vtIdx)
해당 인덱스의 일반 (속성) 정보를 문자열로 반환한다. 더 자세히 ...
void | GetAttribute ([in] VARIANT vtIdx, [out] VARIANT *pVal)
해당 인덱스의 일반 (속성) 정보를 가져온다. 더 자세히 ...
void | Extent2D ([out] double *minX, [out] double *minY, [out] double *maxX, [out] double *maxY)
Feature 객체의 기하를 감싸는 최소 직사각형의 x, y 좌표를 Output 변수에 가져온다 더 자세히 ...
IFeature * Clone ()
해당 Feature 객체와 동일한 객체를 복사 생성하여 가져온다. 더 자세히 ...
VARIANT_BOOL | Equal ([in] IFeature *ft)
해당 Feature 객체와 동일한지 여부를 판단한다. 더 자세히 ...
void | ReCalculateExtent ()
해당 Feature의 범위를 다시 계산한다. 더 자세히 ...
void | CopyTo ([in] IFeature *ft)
double | GetMinXExtent2D ()
double | GetMinYExtent2D ()
double | GetMaxXExtent2D ()
double | GetMaxYExtent2D ()
IGridCoverage * GetGridCoverage ()
BSTR | GetAttributeAsString ([in] VARIANT vtIdx)
BSTR | GetAttributeAsStringByName ([in] BSTR strName)

상세한 설명

Feature 객체의 주석 텍스트를 관리하는 라벨 객체에 인터페이스를 제공한다.

한 개의 Feature 객체는 여러 개의 주석 텍스트를 갖을 수 있다. 한 개의 주석 텍스트는 라벨 객체를 통해 관리되며, 주석 객체는 라벨 객체의 집합을 관리한다. C API(linux, iOS, MacOS 등) : 중간이름 "LB"를 덧붙여서 "OGR_LB_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Label"

멤버 함수 문서화

IFeature* sgObject::IAnnotationLabel::GetFeature ( )
ILayer* sgObject::IAnnotationLabel::GetLayer ( )

해당 주석이 포함된 레이어를 반환한다.

반환값
해당 주석이 포함된 레이어
int sgObject::IAnnotationLabel::GetOrder ( )

주석 텍스트의 정렬을 위한 번호를 반환한다.

반환값
주석 텍스트의 정렬을 위한 번호
BSTR sgObject::IAnnotationLabel::GetText ( )

주석 텍스트를 반환한다.

반환값
주석 텍스트
void sgObject::IAnnotationLabel::SetLayer ( [in] ILayer * pdspLayer )

해당 주석이 포함된 레이어를 설정한다.

반환값
해당 주석이 포함된 레이어
void sgObject::IAnnotationLabel::SetOrder ( [in] int nOrder )

주석 텍스트의 정렬을 위한 번호를 설정한다.

매개변수
nOrder - 주석 텍스트의 정렬을 위한 번호
void sgObject::IAnnotationLabel::SetText ( [in] BSTR bstrText )

주석 텍스트를 설정한다.

매개변수
bstrText - 주석 텍스트
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IAnnotationLabel
sgObject::IAnnotationLabel 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IAnnotationLabel (모든 상속된 멤버들도 포함합니다.)

Clone() | sgObject::IFeature
CopyTo([in] IFeature *ft) | sgObject::IFeature
Equal([in] IFeature *ft) | sgObject::IFeature
Extent2D([out] double *minX, [out] double *minY, [out] double *maxX, [out] double *maxY) | sgObject::IFeature
GetAnnotation() | sgObject::IFeature
GetAnnotationLine() | sgObject::IFeature
GetAttribute([in] VARIANT vtIdx, [out] VARIANT *pVal) | sgObject::IFeature
GetAttributeAsString([in] VARIANT vtIdx) | sgObject::IFeature
GetAttributeAsStringByName([in] BSTR strName) | sgObject::IFeature
GetAttributeToString([in] VARIANT vtIdx) | sgObject::IFeature
GetBounds() | sgObject::IFeature
GetData() | sgObject::IFeature
GetFeature() | sgObject::IAnnotationLabel
GetFeatureCollection() | sgObject::IFeature
GetFeatureType() | sgObject::IFeature
GetGeometry() | sgObject::IFeature
GetGridCoverage() | sgObject::IFeature
GetID() | sgObject::IFeature
GetLayer() | sgObject::IAnnotationLabel
GetMaxXExtent2D() | sgObject::IFeature
GetMaxYExtent2D() | sgObject::IFeature
GetMinXExtent2D() | sgObject::IFeature
GetMinYExtent2D() | sgObject::IFeature
GetOrder() | sgObject::IAnnotationLabel
GetSelected() | sgObject::IFeature
GetSymbolizer() | sgObject::IFeature
GetText() | sgObject::IAnnotationLabel
GetUserDefinedWidget() | sgObject::IFeature
GetVisible() | sgObject::IFeature
GetVisibleAnnotation() | sgObject::IFeature
GetVisibleAnnotationLine() | sgObject::IFeature
GetVisibleUserDefinedWidget() | sgObject::IFeature
ReCalculateExtent() | sgObject::IFeature
SetAnnotation(IAnnotation *dspAnno) | sgObject::IFeature
SetAnnotationLine(IGeometry *dspGeom) | sgObject::IFeature
SetAttribute([in] VARIANT vtIdx, [in] VARIANT vtVal) | sgObject::IFeature
SetData(long filter) | sgObject::IFeature
SetGeometry(IGeometry *dspGeom) | sgObject::IFeature
SetID(int nVal) | sgObject::IFeature
SetLayer([in] ILayer *pdspLayer) | sgObject::IAnnotationLabel
SetOrder([in] int nOrder) | sgObject::IAnnotationLabel
SetSelected(VARIANT_BOOL bVal) | sgObject::IFeature
SetSymbolizer(ISymbolizer *dspSymbolizer) | sgObject::IFeature
SetText([in] BSTR bstrText) | sgObject::IAnnotationLabel
SetUserDefinedWidget(IUserDefinedWidget *dspWidget) | sgObject::IFeature
SetVisible(VARIANT_BOOL bVal) | sgObject::IFeature
SetVisibleAnnotation(VARIANT_BOOL bVal) | sgObject::IFeature
SetVisibleAnnotationLine(VARIANT_BOOL bVal) | sgObject::IFeature
SetVisibleUserDefinedWidget(VARIANT_BOOL bVal) | sgObject::IFeature
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IApplication 인터페이스 참조

  • IApplication
Public 멤버 함수 | 모든 멤버 목록
sgObject::IApplication 인터페이스 참조

어플리케이션 위젯(최상의 위젯)을 제어하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::IApplication에 대한 상속 다이어그램 :
sgObject::IApplication에 대한 협력 다이어그램:

Public 멤버 함수

ICommonFactory * GetCommonFactory ()
시스템 내부의 CommonFactory를 반환 더 자세히 ...
VARIANT_BOOL | GetDisplayToolBarByType ([in] ToolBarTypeEnum eType)
ToolBarTypeEnum 에 해당하는 툴바 객체의 보이기 여부 더 자세히 ...
void | SetDisplayToolBarByType ([in] ToolBarTypeEnum eType, [in]VARIANT_BOOL bDisplay)
VARIANT_BOOL | GetDisplayMenuBar ()
메뉴바 객체의 보이기 여부 더 자세히 ...
void | SetDisplayMenuBar (VARIANT_BOOL bVal)
void | SetDisplayToolBar (VARIANT_BOOL bVal)
모든 툴바 객체의 보이기 여부 더 자세히 ...
VARIANT_BOOL | GetDisplayStatusBar ()
상태바 객체의 보이기 여부 더 자세히 ...
void | SetDisplayStatusBar (VARIANT_BOOL bVal)
VARIANT_BOOL | GetDisplayEditActionByType ([in]EditActionTypeEnum eAction)
EditActionTypeEnum 에 해당하는 툴바버튼 객체의 보이기 여부 더 자세히 ...
void | SetDisplayEditActionByType ([in]EditActionTypeEnum eAction, [in]VARIANT_BOOL bType)
void | AddDockWidget (DockAreaEnum eArea, IWidget *dspDockWidget)
도킹위젯 객체의 추가 더 자세히 ...
void | TabifyDockWidget (IWidget *dspFirst, IWidget *dspSecond)
기존 도킹 위젯 위에 겹쳐서 추가 더 자세히 ...
BSTR | GetTitle ()
윈도우창의 제목을 반환한다. 더 자세히 ...
void | DeleteToolBarByType ([in] ToolBarTypeEnum eType)
EditActionTypeEnum에 해당하는 툴바를 삭제한다. 더 자세히 ...
void | KeyDown ([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags)
IPrintLayoutWidget * | ShowPrintLayoutWidget ([in] BSTR strTitle, [in] ICanvas *dspCanvas)
출력폼 창을 띄운다. 더 자세히 ...
void | AddMenu ([in] BSTR strKeyName, [in] BSTR strName, [in] BSTR strParentMenuKeyName)
메뉴를 추가한다. 더 자세히 ...
void | AddAction ([in] BSTR strKeyName, [in] BSTR strName, [in] BSTR strMenuKeyName, [in] BSTR strIconFileName, [in] BSTR strClickFunc)
메뉴에 실행버튼를 추가한다. 더 자세히 ...
void | RunScript ([in] BSTR strCommand, [in] VARIANT_BOOL bDebug)
외부 스크립트 파일을 실행한다. 더 자세히 ...
void | SendActionEvent ([in] BSTR strName)
메뉴 중에 해당 이름의 객체를 찾아 실행시켜 준다. 더 자세히 ...
- sgObject::IWidget(으)로부터 상속된 Public 멤버 함수
void | Initialize ([in] ULONG_PTR h)
위젯 초기화 더 자세히 ...
void | ReSize ([in] int x, [in] int y, [in] int cx, [in] int cy)
위젯 객체의 크기를 재설정 한다. 더 자세히 ...
void | AddWidget ([in] IWidget *dspWidget)
현재 위젯에 하부로 위젯을 추가한다. 더 자세히 ...
void | AddWidgetByLayout ([in] IWidget *dspWidget, [in] int row, [in] int col)
현재 위젯에 종, 횡 위치에 위젯을 추가한다. 더 자세히 ...
void | SetQtUiObjectVisible ([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue)
위젯의 해당 오브젝트 객체의 보이기 여부를 설정한다. 더 자세히 ...
long | GetBackColor ()
위젯이 사용하는 배경 색상 정보 더 자세히 ...
void | SetBackColor ([in] long color)
void | SetCanvas (ICanvas *poCanvas)
위젯을 특정(2D, 3D, Earth 등) 지도창으로 설정한다. 더 자세히 ...
IFeatureCanvas * GetFeatureCanvas ()
위젯이 사용하는 FeatureCanvas 정보 더 자세히 ...
void | SetFeatureCanvas (IFeatureCanvas *poFtCvs)
void | SetFeatureLayer (IFeatureLayer *poFtLayer)
위젯이 사용하는 FeatureLayer 정보 더 자세히 ...
void | SetLayer (ILayer *poLayer)
위젯이 사용하는 레이어 정보 더 자세히 ...
BSTR | GetFlag ()
위젯이 사용하는 문자열 파라메터 정보 더 자세히 ...
void | SetFlag (BSTR bstrFlag)
void | SetWidth (int nWidth)
위젯의 가로크기를 설정한다. 더 자세히 ...
int | SetHeight (int nHeight)
위젯의 세로크기를 설정한다. 더 자세히 ...
void | Destroy ()

상세한 설명

어플리케이션 위젯(최상의 위젯)을 제어하는 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "APP"를 덧붙여서 "OGR_APP_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Application"

멤버 함수 문서화

void sgObject::IApplication::AddAction | ( | [in] BSTR | strKeyName,
 |  | [in] BSTR | strName,
 |  | [in] BSTR | strMenuKeyName,
 |  | [in] BSTR | strIconFileName,
 |  | [in] BSTR | strClickFunc
 | ) |  |

메뉴에 실행버튼를 추가한다.

매개변수
strKeyName | - 내부적으로 사용하는 변수키 이름
strName | - 표현 이름
strMenuKeyName | - 상위 메뉴키 이름
strIconFileName | - 아이콘 파일명
strClickFunc | - 실행버튼을 눌렀을 경우 실행스크립트 정의
void sgObject::IApplication::AddDockWidget | ( | DockAreaEnum | eArea,
 |  | IWidget * | dspDockWidget
 | ) |  |

도킹위젯 객체의 추가

매개변수
eArea | - 도킹 위치
dspDockWidget | - 도킹 위젯
void sgObject::IApplication::AddMenu | ( | [in] BSTR | strKeyName,
 |  | [in] BSTR | strName,
 |  | [in] BSTR | strParentMenuKeyName
 | ) |  |

메뉴를 추가한다.

매개변수
strKeyName | - 내부적으로 사용하는 변수키 이름
strName | - 표현 이름
strParentMenuKeyName | - 상위 메뉴키 이름(빈값일 경우 최상위 메뉴)
void sgObject::IApplication::DeleteToolBarByType ( [in] ToolBarTypeEnum eType )

EditActionTypeEnum에 해당하는 툴바를 삭제한다.

ICommonFactory* sgObject::IApplication::GetCommonFactory ( )

시스템 내부의 CommonFactory를 반환

VARIANT_BOOL sgObject::IApplication::GetDisplayEditActionByType ( [in] EditActionTypeEnum eAction )

EditActionTypeEnum 에 해당하는 툴바버튼 객체의 보이기 여부

VARIANT_BOOL sgObject::IApplication::GetDisplayMenuBar ( )

메뉴바 객체의 보이기 여부

VARIANT_BOOL sgObject::IApplication::GetDisplayStatusBar ( )

상태바 객체의 보이기 여부

VARIANT_BOOL sgObject::IApplication::GetDisplayToolBarByType ( [in] ToolBarTypeEnum eType )

ToolBarTypeEnum 에 해당하는 툴바 객체의 보이기 여부

BSTR sgObject::IApplication::GetTitle ( )

윈도우창의 제목을 반환한다.

void sgObject::IApplication::KeyDown | ( | [in] LONG | nChar,
 |  | [in] LONG | nRepCnt,
 |  | [in] LONG | nFlags
 | ) |  |
void sgObject::IApplication::RunScript | ( | [in] BSTR | strCommand,
 |  | [in] VARIANT_BOOL | bDebug
 | ) |  |

외부 스크립트 파일을 실행한다.

매개변수
strCommand | - 스크립트 파일명
bDebug | - 디버깅창 사용 여부
void sgObject::IApplication::SendActionEvent ( [in] BSTR strName )

메뉴 중에 해당 이름의 객체를 찾아 실행시켜 준다.

매개변수
strName - 메뉴 이름
void sgObject::IApplication::SetDisplayEditActionByType | ( | [in] EditActionTypeEnum | eAction,
 |  | [in] VARIANT_BOOL | bType
 | ) |  |
void sgObject::IApplication::SetDisplayMenuBar ( VARIANT_BOOL bVal )
void sgObject::IApplication::SetDisplayStatusBar ( VARIANT_BOOL bVal )
void sgObject::IApplication::SetDisplayToolBar ( VARIANT_BOOL bVal )

모든 툴바 객체의 보이기 여부

void sgObject::IApplication::SetDisplayToolBarByType | ( | [in] ToolBarTypeEnum | eType,
 |  | [in] VARIANT_BOOL | bDisplay
 | ) |  |
IPrintLayoutWidget* sgObject::IApplication::ShowPrintLayoutWidget | ( | [in] BSTR | strTitle,
 |  | [in] ICanvas * | dspCanvas
 | ) |  |

출력폼 창을 띄운다.

void sgObject::IApplication::TabifyDockWidget | ( | IWidget * | dspFirst,
 |  | IWidget * | dspSecond
 | ) |  |

기존 도킹 위젯 위에 겹쳐서 추가

매개변수
dspFirst | - 기존 도킹 위젯
dspSecond | - 겹쳐 추가된 위젯
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IApplication
sgObject::IApplication 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IApplication (모든 상속된 멤버들도 포함합니다.)

AddAction([in] BSTR strKeyName, [in] BSTR strName, [in] BSTR strMenuKeyName, [in] BSTR strIconFileName, [in] BSTR strClickFunc) | sgObject::IApplication
AddDockWidget(DockAreaEnum eArea, IWidget *dspDockWidget) | sgObject::IApplication
AddMenu([in] BSTR strKeyName, [in] BSTR strName, [in] BSTR strParentMenuKeyName) | sgObject::IApplication
AddWidget([in] IWidget *dspWidget) | sgObject::IWidget
AddWidgetByLayout([in] IWidget *dspWidget, [in] int row, [in] int col) | sgObject::IWidget
DeleteToolBarByType([in] ToolBarTypeEnum eType) | sgObject::IApplication
Destroy() | sgObject::IWidget
GetBackColor() | sgObject::IWidget
GetCommonFactory() | sgObject::IApplication
GetDisplayEditActionByType([in]EditActionTypeEnum eAction) | sgObject::IApplication
GetDisplayMenuBar() | sgObject::IApplication
GetDisplayStatusBar() | sgObject::IApplication
GetDisplayToolBarByType([in] ToolBarTypeEnum eType) | sgObject::IApplication
GetFeatureCanvas() | sgObject::IWidget
GetFlag() | sgObject::IWidget
GetTitle() | sgObject::IApplication
Initialize([in] ULONG_PTR h) | sgObject::IWidget
KeyDown([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags) | sgObject::IApplication
ReSize([in] int x, [in] int y, [in] int cx, [in] int cy) | sgObject::IWidget
RunScript([in] BSTR strCommand, [in] VARIANT_BOOL bDebug) | sgObject::IApplication
SendActionEvent([in] BSTR strName) | sgObject::IApplication
SetBackColor([in] long color) | sgObject::IWidget
SetCanvas(ICanvas *poCanvas) | sgObject::IWidget
SetDisplayEditActionByType([in]EditActionTypeEnum eAction, [in]VARIANT_BOOL bType) | sgObject::IApplication
SetDisplayMenuBar(VARIANT_BOOL bVal) | sgObject::IApplication
SetDisplayStatusBar(VARIANT_BOOL bVal) | sgObject::IApplication
SetDisplayToolBar(VARIANT_BOOL bVal) | sgObject::IApplication
SetDisplayToolBarByType([in] ToolBarTypeEnum eType, [in]VARIANT_BOOL bDisplay) | sgObject::IApplication
SetFeatureCanvas(IFeatureCanvas *poFtCvs) | sgObject::IWidget
SetFeatureLayer(IFeatureLayer *poFtLayer) | sgObject::IWidget
SetFlag(BSTR bstrFlag) | sgObject::IWidget
SetHeight(int nHeight) | sgObject::IWidget
SetLayer(ILayer *poLayer) | sgObject::IWidget
SetQtUiObjectVisible([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue) | sgObject::IWidget
SetWidth(int nWidth) | sgObject::IWidget
ShowPrintLayoutWidget([in] BSTR strTitle, [in] ICanvas *dspCanvas) | sgObject::IApplication
TabifyDockWidget(IWidget *dspFirst, IWidget *dspSecond) | sgObject::IApplication
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IApplicationControl 인터페이스 참조

  • IApplicationControl
Public 멤버 함수 | 모든 멤버 목록
sgObject::IApplicationControl 인터페이스 참조

어플리케이션 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다. 더 자세히 ...

sgObject::IApplicationControl에 대한 상속 다이어그램 :
sgObject::IApplicationControl에 대한 협력 다이어그램:

Public 멤버 함수

IApplication * GetApplication ()
컨트롤내에 생성된 어플리케이션 인터페이스 더 자세히 ...

상세한 설명

어플리케이션 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다.

COM+ 인터페이스에만 존재하는 ActiveX 방식의 어플리케이션 객체

멤버 함수 문서화

IApplication* sgObject::IApplicationControl::GetApplication ( )

컨트롤내에 생성된 어플리케이션 인터페이스

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IApplicationControl
sgObject::IApplicationControl 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IApplicationControl (모든 상속된 멤버들도 포함합니다.)

GetApplication() sgObject::IApplicationControl
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IAttributeIndex 인터페이스 참조

  • IAttributeIndex
Public 멤버 함수 | 모든 멤버 목록
sgObject::IAttributeIndex 인터페이스 참조

FeatureCollection 객체에 인덱싱 기능을 제공하는 AttributeIndex 객체의 인터페이스를 제공한다. 더 자세히 ...

sgObject::IAttributeIndex에 대한 상속 다이어그램 :
sgObject::IAttributeIndex에 대한 협력 다이어그램:

Public 멤버 함수

IFeatureCollection * GetFeatureCollection ()
공간 인덱싱을 할 FeatureCollection 객체를 반환한다. 더 자세히 ...
void | SetFeatureCollection (IFeatureCollection *dspFtCol)
Spatial Indexing을 할 FeatureCollection 객체를 설정한다. 더 자세히 ...
void | Create (VARIANT colIndex)
FeatureCollection 객체에 공간 인덱스를 생성한다. 더 자세히 ...
void | Remove (VARIANT colIndex)
FeatureCollection 객체에 생성된 공간 인덱스를 삭제한다. 더 자세히 ...
void | Clear ()
공간 인덱싱을 초기화한다. 더 자세히 ...
IFeatureCollection * | SubCollection ([in] IGeometry *dspGeometry, [in] SpatialOperatorEnum eOper)
FeatureCollection에 속한 Feature 들의 매개변수 기하 와의 공간 관계를 테스트하여 적합한 것들로 이루어진 FeatureCollection 을 가져온다. 더 자세히 ...
int | AddToIndex ([in] IFeature *dspFeature)
int | RemoveFromIndex ([in] IFeature *dspFeature)

상세한 설명

FeatureCollection 객체에 인덱싱 기능을 제공하는 AttributeIndex 객체의 인터페이스를 제공한다.

AttributeIndex 객체는 FeatureCollection 객체에 인덱싱 기능을 제공하고, 이를 사용하여 빠른 검색 (공간 연산의 경우 부분집합 검색) 기능을 FeatureCollection 객체에 제공한다. 현재 버전은 속성에 관한 B+Tree 인덱스를 지원하지 않으며 공간 인덱스만을 지원한다. 공간인덱스에 의한 빠른 검색은 공각 객체의 MBR(최소 경계 사각형)을 기준으로 함으로 Point 객체의 경우 정확한 결과이나 다른 객체는 ISpatialRelation 인터페이스를 활용하여 재연산하여 사용해야 한다.

멤버 함수 문서화

int sgObject::IAttributeIndex::AddToIndex ( [in] IFeature * dspFeature )
void sgObject::IAttributeIndex::Clear ( )

공간 인덱싱을 초기화한다.

void sgObject::IAttributeIndex::Create ( VARIANT colIndex )

FeatureCollection 객체에 공간 인덱스를 생성한다.

매개변수
colIndex - 인덱스를 만들 칼럼 번호를 의미한다.(현재 버전은 기하에 관한 QuadTree Index(추후 GridTree, R*Tree 등을 지원할 예정)만을 지원함으로 인덱스 번호를 넣을 필요가 없으나 속성 인덱스를 지원하는 버전에서 지원 예정)
IFeatureCollection* sgObject::IAttributeIndex::GetFeatureCollection ( )

공간 인덱싱을 할 FeatureCollection 객체를 반환한다.

반환값
공간 인덱싱을 할 FeatureCollection 객체
void sgObject::IAttributeIndex::Remove ( VARIANT colIndex )

FeatureCollection 객체에 생성된 공간 인덱스를 삭제한다.

매개변수
colIndex - 인덱스를 삭제할 칼럼 번호를 의미한다.(현재 버전은 기하에 관한 QuadTree Index(추후 GridTree, R*Tree 등을 지원할 예정)만을 지원함으로 인덱스 번호를 넣을 필요가 없으나 속성 인덱스를 지원하는 버전에서 지원 예정)
int sgObject::IAttributeIndex::RemoveFromIndex ( [in] IFeature * dspFeature )
void sgObject::IAttributeIndex::SetFeatureCollection ( IFeatureCollection * dspFtCol )

Spatial Indexing을 할 FeatureCollection 객체를 설정한다.

반환값
dspFtCol - Spatial Indexing을 할 FeatureCollection 객체
IFeatureCollection* sgObject::IAttributeIndex::SubCollection | ( | [in] IGeometry * | dspGeometry,
 |  | [in] SpatialOperatorEnum | eOper
 | ) |  |

FeatureCollection에 속한 Feature 들의 매개변수 기하 와의 공간 관계를 테스트하여 적합한 것들로 이루어진 FeatureCollection 을 가져온다.

(eOper는 현재 Intersection 연산만 지원되며 추후 확장 지원 예정) 결과는 인덱스를 통해 MBR연산에 의한 결과만을 반환함으로 정확한 연산을 위해 반드시 ISpatialRelation 인터페이스를 통해 재계산해서 사용해야 한다.(단, IPoint 객체의 경우 완전한 결과임으로 바로 사용이 가능)

매개변수
dspGeometry | - 공간 관계를 테스트할 기하
eOper | - 공간 관계를 테스트할 연산
반환값
공간 관계 테스트를 만족하는 Feature 들로 이루어진 FeatureCollection 객체를 가리키는 포인터
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IAttributeIndex
sgObject::IAttributeIndex 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IAttributeIndex (모든 상속된 멤버들도 포함합니다.)

AddToIndex([in] IFeature *dspFeature) | sgObject::IAttributeIndex
Clear() | sgObject::IAttributeIndex
Create(VARIANT colIndex) | sgObject::IAttributeIndex
GetFeatureCollection() | sgObject::IAttributeIndex
Remove(VARIANT colIndex) | sgObject::IAttributeIndex
RemoveFromIndex([in] IFeature *dspFeature) | sgObject::IAttributeIndex
SetFeatureCollection(IFeatureCollection *dspFtCol) | sgObject::IAttributeIndex
SubCollection([in] IGeometry *dspGeometry, [in] SpatialOperatorEnum eOper) | sgObject::IAttributeIndex
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ICanvas 인터페이스 참조

  • ICanvas
Public 멤버 함수 | 모든 멤버 목록
sgObject::ICanvas 인터페이스 참조

지도 객체의 최상위 인터페이스로 2D/3D/AR 등 하위 상속 객체가 존재하며 모든 지도 객체의 공통 인터페이스를 제공한다. 더 자세히 ...

sgObject::ICanvas에 대한 상속 다이어그램 :
sgObject::ICanvas에 대한 협력 다이어그램:

Public 멤버 함수

HRESULT | GetCommonFactory ([out, retval] ICommonFactory **pVal)
CommonFactory를 가져온다. 더 자세히 ...
HRESULT | GetCanvasType ([out, retval] CanvasTypeEnum *pVal)
지도 (Canvas 객체) 종류를 반환한다. 더 자세히 ...
HRESULT | GetTitle ([out, retval] BSTR *pVal)
지도 (Canvas 객체) 이름 더 자세히 ...
HRESULT | SetTitle ([in] BSTR newVal)
HRESULT | GetState ([out, retval] int *pVal)
화면 (Canvas 객체) 상태 더 자세히 ...
HRESULT | SetState ([in] int newVal)
HRESULT | GetFeatureCanvas ([out, retval] IFeatureCanvas **pVal)
지도에 표현되는 FeatureLayer(공간정보레이어)를 관리하는 FeatureCanvas 정보 더 자세히 ...
HRESULT | SetFeatureCanvas ([in] IFeatureCanvas *pVal)
HRESULT | GetBackColor ([out, retval] long *pVal)
배경색(RGB) 더 자세히 ...
HRESULT | SetBackColor ([in] long newVal)
HRESULT | GetMapControl ([out, retval] long *pVal)
지도에 표시되는 제어창(방위, 스케일바 등) 더 자세히 ...
HRESULT | SetMapControl ([in] long newVal)
HRESULT | VisibleMapControl ([in] SystemResourceEnum type, [in] VARIANT_BOOL bVisible)
지도에 표시할 제어창의 종류를 설정한다. 더 자세히 ...
HRESULT | GetMapMoveMode ([out, retval] MapMoveEnum *pVal)
위치센서 정보 수신에 따른 지도의 자동 이동 여부 더 자세히 ...
HRESULT | SetMapMoveMode ([in] MapMoveEnum type)
HRESULT | GetMapRotateMode ([out, retval] MapRotateEnum *pVal)
위치센서 정보 수신 중 이동에 따른 지도 방향 자동 회전 여부 더 자세히 ...
HRESULT | SetMapRotateMode ([in] MapRotateEnum type)
HRESULT | SetLocationSensor ([in] ILocationSensor *pdspSensor)
지도에서 사용할 위치센서를 지정한다. 더 자세히 ...
HRESULT | SetMotionSensor ([in] IMotionSensor *pdspSensor)
지도에서 사용할 모션센서를 지정한다. 더 자세히 ...
HRESULT | SetVideoSensor ([in] IVideoSensor *pdspSensor)
지도에서 사용할 비디오센서를 지정한다. 더 자세히 ...
HRESULT | RemoveSensor ([in] ISensor *pdspSensor)
지도에서 사용중인 센서를 삭제한다. 더 자세히 ...
HRESULT | GetObjectiveSpatialReference ([out, retval] ISpatialReference **pVal)
지도의 실질 공간 좌표 체계 더 자세히 ...
HRESULT | SetObjectiveSpatialReference ([in] ISpatialReference *pVal)
HRESULT | Initialize ([in] ULONG_PTR h)
지도를 그려야 할 객체의 핸들을 초기화 한다. 더 자세히 ...
HRESULT | Invalidate ()
지도를 다시 그리도록 한다. 더 자세히 ...
HRESULT | ExportImage ([in]FileFormatEnum nFileType, [in]BSTR pVal)
지도화면을 이미지 파일로 내보낸다. 더 자세히 ...
HRESULT | AddControl ([in] long fid, [in] IUserDefinedWidget *dspUDBox)
외부 컨트롤을 지도상에 추가한다. 더 자세히 ...
HRESULT | RemoveControl ([in] long fid)
AddControl에 의해 입력된 외부 컨트롤을 지도상에서 삭제한다. 더 자세히 ...
HRESULT | RemoveAllControl ()
AddControl에 의해 입력된 모든 외부 컨트롤을 지도상에서 삭제한다. 더 자세히 ...
HRESULT | GetHittestSize ([out, retval] int *pVal)
화면에서 객체 선택을 위한 검색 픽셀 범위 더 자세히 ...
HRESULT | SetHittestSize ([in] int newVal)
HRESULT | ForceStopRender ()
화면 렌더링 중지 더 자세히 ...
HRESULT | MouseMove ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 마우스 이동 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | LButtonDown ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 왼쪽 마우스의 버튼을 누른 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | LButtonUp ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 왼쪽 마우스의 눌린 버튼을 놓았다는 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | RButtonDown ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 오른쪽 마우스의 버튼을 누른 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | RButtonUp ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 오른쪽 마우스의 눌린 버튼을 놓았다는 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | DblClick ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 왼쪽 마우스를 더블클릭 했음을 강제로 설정한다. 더 자세히 ...
HRESULT | ReSize ([in] LONG nType, [in] int cx, [in] int cy)
지도의 크기를 조정했음으로 강제로 설정한다. 더 자세히 ...
HRESULT | KeyDown ([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags)
지도에서 특정 키를 눌렀음을 강제로 설정한다. 더 자세히 ...
HRESULT | KeyUp ([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags)
지도에서 특정 키를 떼었음을 강제로 설정한다. 더 자세히 ...
HRESULT | MButtonDown ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 중간 마우스의 버튼을 누른 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | MButtonUp ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 중간 마우스의 눌린 버튼을 놓았다는 정보를 강제로 설정한다. 더 자세히 ...

상세한 설명

지도 객체의 최상위 인터페이스로 2D/3D/AR 등 하위 상속 객체가 존재하며 모든 지도 객체의 공통 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "CVS"를 덧붙여서 "OGR_CVS_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Canvas"

멤버 함수 문서화

HRESULT sgObject::ICanvas::AddControl | ( | [in] long | fid,
 |  | [in] IUserDefinedWidget * | dspUDBox
 | ) |  |

외부 컨트롤을 지도상에 추가한다.

매개변수
fid | - 컨트롤 ID
dspUDBox | - 외부 컨트롤 정의 객체 (Widget 인터페이스의 Initialize를 활용하여 외부 컨트롤의 핸들을 설정한 객체)
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::DblClick | ( | [in] LONG | nFlags,
 |  | [in] int | x,
 |  | [in] int | y,
 |  | [in] void * | owner
 | ) |  |

지도에 왼쪽 마우스를 더블클릭 했음을 강제로 설정한다.

매개변수
nFlags | - OnLButtonDblClk()의 파라미터 nFlags
x | - OnLButtonDblClk()의 파라미터 point.x
y | - OnLButtonDblClk()의 파라미터 point.y
owner | - 마우스 상태 정보
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::ExportImage | ( | [in] FileFormatEnum | nFileType,
 |  | [in] BSTR | pVal
 | ) |  |

지도화면을 이미지 파일로 내보낸다.

매개변수
nFileType | - 생성될 이미지 파일 포맷
pVal | - 생성될 이미지 파일 이름
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::ForceStopRender ( )

화면 렌더링 중지

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::GetBackColor ( [out, retval] long * pVal )

배경색(RGB)

HRESULT sgObject::ICanvas::GetCanvasType ( [out, retval] CanvasTypeEnum * pVal )

지도 (Canvas 객체) 종류를 반환한다.

HRESULT sgObject::ICanvas::GetCommonFactory ( [out, retval] ICommonFactory ** pVal )

CommonFactory를 가져온다.

CommonFactory로 생성할 수 있는 Factory로는 DisplayFactory(map이 보여질 화면 그래픽 객체), CRSFactory(공간 좌표 체계), GeometryFactory(공간 좌표 체계에 따른 객체), LayerSourceFactory(레이어 소스), FeatureTypeStyleFactory(Feature 스타일), CoverageFactory(Coverage)가 있고 Parameters, Parameter, Utility를 생성할 수 있다.

  • Java의 경우 : CommonFactory를 생성하여 반환한다.
    매개변수
    pVal - 생성된 CommonFactory를 저장하는 변수
    반환값
    S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::GetFeatureCanvas ( [out, retval] IFeatureCanvas ** pVal )

지도에 표현되는 FeatureLayer(공간정보레이어)를 관리하는 FeatureCanvas 정보

HRESULT sgObject::ICanvas::GetHittestSize ( [out, retval] int * pVal )

화면에서 객체 선택을 위한 검색 픽셀 범위

HRESULT sgObject::ICanvas::GetMapControl ( [out, retval] long * pVal )

지도에 표시되는 제어창(방위, 스케일바 등)

HRESULT sgObject::ICanvas::GetMapMoveMode ( [out, retval] MapMoveEnum * pVal )

위치센서 정보 수신에 따른 지도의 자동 이동 여부

HRESULT sgObject::ICanvas::GetMapRotateMode ( [out, retval] MapRotateEnum * pVal )

위치센서 정보 수신 중 이동에 따른 지도 방향 자동 회전 여부

HRESULT sgObject::ICanvas::GetObjectiveSpatialReference ( [out, retval] ISpatialReference ** pVal )

지도의 실질 공간 좌표 체계

HRESULT sgObject::ICanvas::GetState ( [out, retval] int * pVal )

화면 (Canvas 객체) 상태

HRESULT sgObject::ICanvas::GetTitle ( [out, retval] BSTR * pVal )

지도 (Canvas 객체) 이름

HRESULT sgObject::ICanvas::Initialize ( [in] ULONG_PTR h )

지도를 그려야 할 객체의 핸들을 초기화 한다.

매개변수
h - 지도를 그려야 할 객체의 외부 핸들
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::Invalidate ( )

지도를 다시 그리도록 한다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::KeyDown | ( | [in] LONG | nChar,
 |  | [in] LONG | nRepCnt,
 |  | [in] LONG | nFlags
 | ) |  |

지도에서 특정 키를 눌렀음을 강제로 설정한다.

매개변수
nChar | - OnKeyDown()의 파라미터 nChar
nRepCnt | - OnKeyDown()의 파라미터 nRepCnt
nFlags | - OnKeyDown()의 파라미터 nFlags
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::KeyUp | ( | [in] LONG | nChar,
 |  | [in] LONG | nRepCnt,
 |  | [in] LONG | nFlags
 | ) |  |

지도에서 특정 키를 떼었음을 강제로 설정한다.

매개변수
nChar | - OnKeyUp()의 파라미터 nChar
nRepCnt | - OnKeyUp()의 파라미터 nRepCnt
nFlags | - OnKeyUp()의 파라미터 nFlags
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::LButtonDown | ( | [in] LONG | nFlags,
 |  | [in] int | x,
 |  | [in] int | y,
 |  | [in] void * | owner
 | ) |  |

지도에 왼쪽 마우스의 버튼을 누른 정보를 강제로 설정한다.

매개변수
nFlags | - OnLButtonDown()의 파라미터 nFlags
x | - OnLButtonDown()의 파라미터 point.x
y | - OnLButtonDown()의 파라미터 point.y
owner | - 마우스 상태 정보
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::LButtonUp | ( | [in] LONG | nFlags,
 |  | [in] int | x,
 |  | [in] int | y,
 |  | [in] void * | owner
 | ) |  |

지도에 왼쪽 마우스의 눌린 버튼을 놓았다는 정보를 강제로 설정한다.

매개변수
nFlags | - OnLButtonUp()의 파라미터 nFlags
x | - OnLButtonUp()의 파라미터 point.x
y | - OnLButtonUp()의 파라미터 point.y
owner | - 마우스 상태 정보
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::MButtonDown | ( | [in] LONG | nFlags,
 |  | [in] int | x,
 |  | [in] int | y,
 |  | [in] void * | owner
 | ) |  |

지도에 중간 마우스의 버튼을 누른 정보를 강제로 설정한다.

매개변수
nFlags | - OnMButtonDown()의 파라미터 nFlags
x | - OnMButtonDown()의 파라미터 point.x
y | - OnMButtonDown()의 파라미터 point.y
owner | - 마우스 상태 정보
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::MButtonUp | ( | [in] LONG | nFlags,
 |  | [in] int | x,
 |  | [in] int | y,
 |  | [in] void * | owner
 | ) |  |

지도에 중간 마우스의 눌린 버튼을 놓았다는 정보를 강제로 설정한다.

매개변수
nFlags | - OnMButtonUp()의 파라미터 nFlags
x | - OnMButtonUp()의 파라미터 point.x
y | - OnMButtonUp()의 파라미터 point.y
owner | - 마우스 상태 정보
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::MouseMove | ( | [in] LONG | nFlags,
 |  | [in] int | x,
 |  | [in] int | y,
 |  | [in] void * | owner
 | ) |  |

지도에 마우스 이동 정보를 강제로 설정한다.

매개변수
nFlags | - OnMouseMove()의 파라미터 nFlags
x | - OnMouseMove()의 파라미터 point.x
y | - OnMouseMove()의 파라미터 point.y
owner | - 마우스 상태 정보
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::RButtonDown | ( | [in] LONG | nFlags,
 |  | [in] int | x,
 |  | [in] int | y,
 |  | [in] void * | owner
 | ) |  |

지도에 오른쪽 마우스의 버튼을 누른 정보를 강제로 설정한다.

매개변수
nFlags | - OnRButtonDown()의 파라미터 nFlags
x | - OnRButtonDown()의 파라미터 point.x
y | - OnRButtonDown()의 파라미터 point.y
owner | - 마우스 상태 정보
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::RButtonUp | ( | [in] LONG | nFlags,
 |  | [in] int | x,
 |  | [in] int | y,
 |  | [in] void * | owner
 | ) |  |

지도에 오른쪽 마우스의 눌린 버튼을 놓았다는 정보를 강제로 설정한다.

매개변수
nFlags | - OnRButtonUp()의 파라미터 nFlags
x | - OnRButtonUp()의 파라미터 point.x
y | - OnRButtonUp()의 파라미터 point.y
owner | - 마우스 상태 정보
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::RemoveAllControl ( )

AddControl에 의해 입력된 모든 외부 컨트롤을 지도상에서 삭제한다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::RemoveControl ( [in] long fid )

AddControl에 의해 입력된 외부 컨트롤을 지도상에서 삭제한다.

매개변수
fid - 삭제 대상 컨트롤 ID
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::RemoveSensor ( [in] ISensor * pdspSensor )

지도에서 사용중인 센서를 삭제한다.

매개변수
pdspSensor - 센서 객체
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::ReSize | ( | [in] LONG | nType,
 |  | [in] int | cx,
 |  | [in] int | cy
 | ) |  |

지도의 크기를 조정했음으로 강제로 설정한다.

매개변수
nType | - OnSize()의 파라미터 nType
cx | - OnSize()의 파라미터 cx
cy | - OnSize()의 파라미터 cy
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::SetBackColor ( [in] long newVal )
HRESULT sgObject::ICanvas::SetFeatureCanvas ( [in] IFeatureCanvas * pVal )
HRESULT sgObject::ICanvas::SetHittestSize ( [in] int newVal )
HRESULT sgObject::ICanvas::SetLocationSensor ( [in] ILocationSensor * pdspSensor )

지도에서 사용할 위치센서를 지정한다.

매개변수
pdspSensor - 위치 센서 객체
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::SetMapControl ( [in] long newVal )
HRESULT sgObject::ICanvas::SetMapMoveMode ( [in] MapMoveEnum type )
HRESULT sgObject::ICanvas::SetMapRotateMode ( [in] MapRotateEnum type )
HRESULT sgObject::ICanvas::SetMotionSensor ( [in] IMotionSensor * pdspSensor )

지도에서 사용할 모션센서를 지정한다.

매개변수
pdspSensor - 모션 센서 객체
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::SetObjectiveSpatialReference ( [in] ISpatialReference * pVal )
HRESULT sgObject::ICanvas::SetState ( [in] int newVal )
HRESULT sgObject::ICanvas::SetTitle ( [in] BSTR newVal )
HRESULT sgObject::ICanvas::SetVideoSensor ( [in] IVideoSensor * pdspSensor )

지도에서 사용할 비디오센서를 지정한다.

매개변수
pdspSensor - 비디오 센서 객체
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ICanvas::VisibleMapControl | ( | [in] SystemResourceEnum | type,
 |  | [in] VARIANT_BOOL | bVisible
 | ) |  |

지도에 표시할 제어창의 종류를 설정한다.

기존에 표시되는 컨트롤 정보는 지도 제어 속성에 저장되어 있는데 여기에 매개변수 type에 지정된 컨트롤을 추가 혹은 제거한다.

매개변수
type | - 화면에 표시되는 컨트롤
bVisible | - 추가 시 TRUE, 삭제 시 FALSE
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ICanvas
sgObject::ICanvas 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ICanvas (모든 상속된 멤버들도 포함합니다.)

AddControl([in] long fid, [in] IUserDefinedWidget *dspUDBox) | sgObject::ICanvas
DblClick([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
ExportImage([in]FileFormatEnum nFileType, [in]BSTR pVal) | sgObject::ICanvas
ForceStopRender() | sgObject::ICanvas
GetBackColor([out, retval] long *pVal) | sgObject::ICanvas
GetCanvasType([out, retval] CanvasTypeEnum *pVal) | sgObject::ICanvas
GetCommonFactory([out, retval] ICommonFactory **pVal) | sgObject::ICanvas
GetFeatureCanvas([out, retval] IFeatureCanvas **pVal) | sgObject::ICanvas
GetHittestSize([out, retval] int *pVal) | sgObject::ICanvas
GetMapControl([out, retval] long *pVal) | sgObject::ICanvas
GetMapMoveMode([out, retval] MapMoveEnum *pVal) | sgObject::ICanvas
GetMapRotateMode([out, retval] MapRotateEnum *pVal) | sgObject::ICanvas
GetObjectiveSpatialReference([out, retval] ISpatialReference **pVal) | sgObject::ICanvas
GetState([out, retval] int *pVal) | sgObject::ICanvas
GetTitle([out, retval] BSTR *pVal) | sgObject::ICanvas
Initialize([in] ULONG_PTR h) | sgObject::ICanvas
Invalidate() | sgObject::ICanvas
KeyDown([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags) | sgObject::ICanvas
KeyUp([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags) | sgObject::ICanvas
LButtonDown([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
LButtonUp([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
MButtonDown([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
MButtonUp([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
MouseMove([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
RButtonDown([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
RButtonUp([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
RemoveAllControl() | sgObject::ICanvas
RemoveControl([in] long fid) | sgObject::ICanvas
RemoveSensor([in] ISensor *pdspSensor) | sgObject::ICanvas
ReSize([in] LONG nType, [in] int cx, [in] int cy) | sgObject::ICanvas
SetBackColor([in] long newVal) | sgObject::ICanvas
SetFeatureCanvas([in] IFeatureCanvas *pVal) | sgObject::ICanvas
SetHittestSize([in] int newVal) | sgObject::ICanvas
SetLocationSensor([in] ILocationSensor *pdspSensor) | sgObject::ICanvas
SetMapControl([in] long newVal) | sgObject::ICanvas
SetMapMoveMode([in] MapMoveEnum type) | sgObject::ICanvas
SetMapRotateMode([in] MapRotateEnum type) | sgObject::ICanvas
SetMotionSensor([in] IMotionSensor *pdspSensor) | sgObject::ICanvas
SetObjectiveSpatialReference([in] ISpatialReference *pVal) | sgObject::ICanvas
SetState([in] int newVal) | sgObject::ICanvas
SetTitle([in] BSTR newVal) | sgObject::ICanvas
SetVideoSensor([in] IVideoSensor *pdspSensor) | sgObject::ICanvas
VisibleMapControl([in] SystemResourceEnum type, [in] VARIANT_BOOL bVisible) | sgObject::ICanvas
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IChart 인터페이스 참조

  • IChart
Public 멤버 함수 | 모든 멤버 목록
sgObject::IChart 인터페이스 참조

차트의 세부 속성을 설정하기 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::IChart에 대한 상속 다이어그램 :
sgObject::IChart에 대한 협력 다이어그램:

Public 멤버 함수

int | IsEqual ([in] IChart *pdspOtherChart)
주어진 차트의 속성(크기, 종류, Feature의 설정 정보 등)이 동일한지의 여부를 반환한다. 더 자세히 ...
void | InitDataset ([in] int nNumDataSeries, [in] int nNumAttributes)
차트의 자료를 설정하기 위해 초기화 수행 더 자세히 ...
void | SetDataSeries ([in] int index, [in] VARIANT pfValues, [in] BSTR strLabels, [in] BSTR strColors)
차트의 자료 계열별 값 리스트, 값의 제목 리스트, 색상 리스트를 설정한다. 더 자세히 ...
void | SetParameter ([in] IParameter *pdspParam)
차트의 다양한 세부 속성을 제어한다. 더 자세히 ...
void | SetDataSeriesFromString ([in] int index, [in] BSTR strValues, [in] BSTR strLabels, [in] BSTR strColors)
차트의 자료 계열별 값 리스트, 값의 제목 리스트, 색상 리스트를 설정한다. 더 자세히 ...
VARIANT_BOOL | GetTransparent ()
차트 배경색의 투명 여부를 반환한다. 더 자세히 ...
void | SetTransparent (VARIANT_BOOL bTrans)
차트 배경색의 투명 여부 더 자세히 ...
ChartTypeEnum GetChartType ()
차트의 종류 더 자세히 ...
void | SetChartType (ChartTypeEnum eType)
int | GetNumDataSeries ()
차트에 표현되는 자료계열의 수 더 자세히 ...
OLE_COLOR | GetLineColor ()
차트의 축 색상 더 자세히 ...
void | SetLineColor (OLE_COLOR color)
OLE_COLOR | GetBackgroundColor ()
차트 내부의 배경색 더 자세히 ...
void | SetBackgroundColor (OLE_COLOR color)
BSTR | GetFeatureFields ()
Feature에 의한 차트의 경우 표현될 필드의 문자리스트 예) "A B C". 더 자세히 ...
void | SetFeatureFields (BSTR bstrFields)
BSTR | GetFeatureLables ()
Feature에 의한 차트의 경우 표현될 필드의 가상 명칭 문자리스트 예) "A1 B1 C1". 더 자세히 ...
void | SetFeatureLables (BSTR bstrLables)
BSTR | GetFeatureColors ()
Feature에 의한 차트의 경우 (파이 차트와 같이) 필드별 색상(RGB칼라의 문자열) 리스트 예) "0 10234 4563". 더 자세히 ...
void | SetFeatureColors (BSTR bstrColors)
- sgObject::IUserDefinedWidget(으)로부터 상속된 Public 멤버 함수
AlignPositionEnum GetPosition ()
Feature를 기준으로한 객체의 기준점 상대 위치 더 자세히 ...
void | SetPosition ([in] AlignPositionEnum pos)
int | GetRelateX ()
기준점으로부터 X 이격거리 더 자세히 ...
void | SetRelateX ([in] int x)
int | GetRelateY ()
기준점으로부터 Y 이격거리 더 자세히 ...
void | SetRelateY ([in] int y)
VARIANT_BOOL | IsExteriorHandle ()
외부 핸들인지의 여부 더 자세히 ...
void | SetExteriorHandle ([in] VARIANT_BOOL val)
VARIANT_BOOL | ExportImage (FileFormatEnum nFileType, BSTR bstrVal)
차트를 지정된 파일형태로 내보낸다. 더 자세히 ...
- sgObject::IWidget(으)로부터 상속된 Public 멤버 함수
void | Initialize ([in] ULONG_PTR h)
위젯 초기화 더 자세히 ...
void | ReSize ([in] int x, [in] int y, [in] int cx, [in] int cy)
위젯 객체의 크기를 재설정 한다. 더 자세히 ...
void | AddWidget ([in] IWidget *dspWidget)
현재 위젯에 하부로 위젯을 추가한다. 더 자세히 ...
void | AddWidgetByLayout ([in] IWidget *dspWidget, [in] int row, [in] int col)
현재 위젯에 종, 횡 위치에 위젯을 추가한다. 더 자세히 ...
void | SetQtUiObjectVisible ([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue)
위젯의 해당 오브젝트 객체의 보이기 여부를 설정한다. 더 자세히 ...
long | GetBackColor ()
위젯이 사용하는 배경 색상 정보 더 자세히 ...
void | SetBackColor ([in] long color)
void | SetCanvas (ICanvas *poCanvas)
위젯을 특정(2D, 3D, Earth 등) 지도창으로 설정한다. 더 자세히 ...
IFeatureCanvas * GetFeatureCanvas ()
위젯이 사용하는 FeatureCanvas 정보 더 자세히 ...
void | SetFeatureCanvas (IFeatureCanvas *poFtCvs)
void | SetFeatureLayer (IFeatureLayer *poFtLayer)
위젯이 사용하는 FeatureLayer 정보 더 자세히 ...
void | SetLayer (ILayer *poLayer)
위젯이 사용하는 레이어 정보 더 자세히 ...
BSTR | GetFlag ()
위젯이 사용하는 문자열 파라메터 정보 더 자세히 ...
void | SetFlag (BSTR bstrFlag)
void | SetWidth (int nWidth)
위젯의 가로크기를 설정한다. 더 자세히 ...
int | SetHeight (int nHeight)
위젯의 세로크기를 설정한다. 더 자세히 ...
void | Destroy ()

상세한 설명

차트의 세부 속성을 설정하기 위한 인터페이스를 제공한다.

주제도와 같이 개별 Feature의 속성값을 활용하여 지도위에 Feature별 차트를 설정할 수 있다. 하나의 차트에 다양한 속성 정보를 설정하여 별도의 창에서 사용이 가능하다. 예) 래스터 정보의 히스토그램 C API(linux, iOS, MacOS 등) : 중간이름 "CT"를 덧붙여서 "OGR_CT_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Chart"

멤버 함수 문서화

OLE_COLOR sgObject::IChart::GetBackgroundColor ( )

차트 내부의 배경색

ChartTypeEnum sgObject::IChart::GetChartType ( )

차트의 종류

BSTR sgObject::IChart::GetFeatureColors ( )

Feature에 의한 차트의 경우 (파이 차트와 같이) 필드별 색상(RGB칼라의 문자열) 리스트 예) "0 10234 4563".

BSTR sgObject::IChart::GetFeatureFields ( )

Feature에 의한 차트의 경우 표현될 필드의 문자리스트 예) "A B C".

BSTR sgObject::IChart::GetFeatureLables ( )

Feature에 의한 차트의 경우 표현될 필드의 가상 명칭 문자리스트 예) "A1 B1 C1".

OLE_COLOR sgObject::IChart::GetLineColor ( )

차트의 축 색상

int sgObject::IChart::GetNumDataSeries ( )

차트에 표현되는 자료계열의 수

VARIANT_BOOL sgObject::IChart::GetTransparent ( )

차트 배경색의 투명 여부를 반환한다.

void sgObject::IChart::InitDataset | ( | [in] int | nNumDataSeries,
 |  | [in] int | nNumAttributes
 | ) |  |

차트의 자료를 설정하기 위해 초기화 수행

매개변수
nNumDataSeries | - 자료의 계열수(Feature의 속성값을 사용하는 경우 1로 설정)
nNumAttributes | - 자료의 계열별 자료의 수(Feature의 속성값을 사용하는 경우 필드의 개수로 설정)
int sgObject::IChart::IsEqual ( [in] IChart * pdspOtherChart )

주어진 차트의 속성(크기, 종류, Feature의 설정 정보 등)이 동일한지의 여부를 반환한다.

void sgObject::IChart::SetBackgroundColor ( OLE_COLOR color )
void sgObject::IChart::SetChartType ( ChartTypeEnum eType )
void sgObject::IChart::SetDataSeries | ( | [in] int | index,
 |  | [in] VARIANT | pfValues,
 |  | [in] BSTR | strLabels,
 |  | [in] BSTR | strColors
 | ) |  |

차트의 자료 계열별 값 리스트, 값의 제목 리스트, 색상 리스트를 설정한다.

매개변수
index | - 자료의 계열 인덱스 번호
pfValues | - 해당 자료 계열의 값 리스트
strLabels | - 해당 자료 계열의 제목 문자 리스트
strColors | - 해당 자료 계열의 색상 문자 리스트
void sgObject::IChart::SetDataSeriesFromString | ( | [in] int | index,
 |  | [in] BSTR | strValues,
 |  | [in] BSTR | strLabels,
 |  | [in] BSTR | strColors
 | ) |  |

차트의 자료 계열별 값 리스트, 값의 제목 리스트, 색상 리스트를 설정한다.

매개변수
index | - 자료의 계열 인덱스 번호
strValues | - 해당 자료 계열의 값 문자 리스트
strLabels | - 해당 자료 계열의 제목 문자 리스트
strColors | - 해당 자료 계열의 색상 문자 리스트
void sgObject::IChart::SetFeatureColors ( BSTR bstrColors )
void sgObject::IChart::SetFeatureFields ( BSTR bstrFields )
void sgObject::IChart::SetFeatureLables ( BSTR bstrLables )
void sgObject::IChart::SetLineColor ( OLE_COLOR color )
void sgObject::IChart::SetParameter ( [in] IParameter * pdspParam )

차트의 다양한 세부 속성을 제어한다.

매개변수
pdspParam - 차트의 세부 속성 파라메터 인터페이스 예) Name : "title", String : "Sample Chart"
void sgObject::IChart::SetTransparent ( VARIANT_BOOL bTrans )

차트 배경색의 투명 여부

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IChart
sgObject::IChart 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IChart (모든 상속된 멤버들도 포함합니다.)

AddWidget([in] IWidget *dspWidget) | sgObject::IWidget
AddWidgetByLayout([in] IWidget *dspWidget, [in] int row, [in] int col) | sgObject::IWidget
Destroy() | sgObject::IWidget
ExportImage(FileFormatEnum nFileType, BSTR bstrVal) | sgObject::IUserDefinedWidget
GetBackColor() | sgObject::IWidget
GetBackgroundColor() | sgObject::IChart
GetChartType() | sgObject::IChart
GetFeatureCanvas() | sgObject::IWidget
GetFeatureColors() | sgObject::IChart
GetFeatureFields() | sgObject::IChart
GetFeatureLables() | sgObject::IChart
GetFlag() | sgObject::IWidget
GetLineColor() | sgObject::IChart
GetNumDataSeries() | sgObject::IChart
GetPosition() | sgObject::IUserDefinedWidget
GetRelateX() | sgObject::IUserDefinedWidget
GetRelateY() | sgObject::IUserDefinedWidget
GetTransparent() | sgObject::IChart
InitDataset([in] int nNumDataSeries, [in] int nNumAttributes) | sgObject::IChart
Initialize([in] ULONG_PTR h) | sgObject::IWidget
IsEqual([in] IChart *pdspOtherChart) | sgObject::IChart
IsExteriorHandle() | sgObject::IUserDefinedWidget
ReSize([in] int x, [in] int y, [in] int cx, [in] int cy) | sgObject::IWidget
SetBackColor([in] long color) | sgObject::IWidget
SetBackgroundColor(OLE_COLOR color) | sgObject::IChart
SetCanvas(ICanvas *poCanvas) | sgObject::IWidget
SetChartType(ChartTypeEnum eType) | sgObject::IChart
SetDataSeries([in] int index, [in] VARIANT pfValues, [in] BSTR strLabels, [in] BSTR strColors) | sgObject::IChart
SetDataSeriesFromString([in] int index, [in] BSTR strValues, [in] BSTR strLabels, [in] BSTR strColors) | sgObject::IChart
SetExteriorHandle([in] VARIANT_BOOL val) | sgObject::IUserDefinedWidget
SetFeatureCanvas(IFeatureCanvas *poFtCvs) | sgObject::IWidget
SetFeatureColors(BSTR bstrColors) | sgObject::IChart
SetFeatureFields(BSTR bstrFields) | sgObject::IChart
SetFeatureLables(BSTR bstrLables) | sgObject::IChart
SetFeatureLayer(IFeatureLayer *poFtLayer) | sgObject::IWidget
SetFlag(BSTR bstrFlag) | sgObject::IWidget
SetHeight(int nHeight) | sgObject::IWidget
SetLayer(ILayer *poLayer) | sgObject::IWidget
SetLineColor(OLE_COLOR color) | sgObject::IChart
SetParameter([in] IParameter *pdspParam) | sgObject::IChart
SetPosition([in] AlignPositionEnum pos) | sgObject::IUserDefinedWidget
SetQtUiObjectVisible([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue) | sgObject::IWidget
SetRelateX([in] int x) | sgObject::IUserDefinedWidget
SetRelateY([in] int y) | sgObject::IUserDefinedWidget
SetTransparent(VARIANT_BOOL bTrans) | sgObject::IChart
SetWidth(int nWidth) | sgObject::IWidget
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IColorModel 인터페이스 참조

  • IColorModel
Public 멤버 함수 | 모든 멤버 목록
sgObject::IColorModel 인터페이스 참조

C API(linux, iOS, MacOS 등) : 중간이름 "GCM"를 덧붙여서 "OGR_GCM_"+메소드명으로 사용한다. 더 자세히 ...

sgObject::IColorModel에 대한 상속 다이어그램 :
sgObject::IColorModel에 대한 협력 다이어그램:

Public 멤버 함수

PaletteInterpretationEnum GetInterpretation ()
long | GetNumColor ()
void | GetColor (int index, short *c1, short *c2, short *c3, short *c4)
void | SetColor (int index, short c1, short c2, short c3, short c4)
int | GetColorAsRGB ([in] long index)

상세한 설명

C API(linux, iOS, MacOS 등) : 중간이름 "GCM"를 덧붙여서 "OGR_GCM_"+메소드명으로 사용한다.

Java(SWT, Android) Package명 : "net.sgsrc.map.jni.ColorModel"

멤버 함수 문서화

void sgObject::IColorModel::GetColor | ( | int | index,
 |  | short * | c1,
 |  | short * | c2,
 |  | short * | c3,
 |  | short * | c4
 | ) |  |
int sgObject::IColorModel::GetColorAsRGB ( [in] long index )
PaletteInterpretationEnum sgObject::IColorModel::GetInterpretation ( )
long sgObject::IColorModel::GetNumColor ( )
void sgObject::IColorModel::SetColor | ( | int | index,
 |  | short | c1,
 |  | short | c2,
 |  | short | c3,
 |  | short | c4
 | ) |  |
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IColorModel
sgObject::IColorModel 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IColorModel (모든 상속된 멤버들도 포함합니다.)

GetColor(int index, short *c1, short *c2, short *c3, short *c4) | sgObject::IColorModel
GetColorAsRGB([in] long index) | sgObject::IColorModel
GetInterpretation() | sgObject::IColorModel
GetNumColor() | sgObject::IColorModel
SetColor(int index, short c1, short c2, short c3, short c4) | sgObject::IColorModel
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IColorRampList 인터페이스 참조

  • IColorRampList
Public 멤버 함수 | 모든 멤버 목록
sgObject::IColorRampList 인터페이스 참조

시스템에 유일하게 존재하는 GridColorRampStyle 형태의 래스터 일괄 표현 규정 리스트를 정의한 인터페이스를 제공한다. 더 자세히 ...

sgObject::IColorRampList에 대한 상속 다이어그램 :
sgObject::IColorRampList에 대한 협력 다이어그램:

Public 멤버 함수

int | GetSize ()
시스템 칼라램프 리스트의 개수를 반환한다. 더 자세히 ...
IGridColorRampStyle * | GetColorRamp ([in] int index)
인덱스 번호에 해당하는 시스템 칼라램프를 반환한다. 더 자세히 ...
IGridColorRampStyle * | GetColorRampByName ([in] BSTR newVal)
인덱스 이름에 해당하는 시스템 칼라램프를 반환한다. 더 자세히 ...
BOOL | AddColorRamp ([in] BSTR name, [in] IGridColorRampStyle *dspRamp)
시스템 칼라램프 리스트에 새로운 칼라램프를 추가한다. 더 자세히 ...
void | RemoveColorRamp ([in] BSTR name)
시스템 칼라램프 리스트에서 주어진 칼라램프를 삭제한다. 더 자세히 ...
BSTR | GetName ([in] int index)
인덱스 번호에 해당하는 시스템 칼라램프의 이름을 반환한다. 더 자세히 ...

상세한 설명

시스템에 유일하게 존재하는 GridColorRampStyle 형태의 래스터 일괄 표현 규정 리스트를 정의한 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "CRL"를 덧붙여서 "OGR_CRL_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.ColorRampList"

멤버 함수 문서화

BOOL sgObject::IColorRampList::AddColorRamp | ( | [in] BSTR | name,
 |  | [in] IGridColorRampStyle * | dspRamp
 | ) |  |

시스템 칼라램프 리스트에 새로운 칼라램프를 추가한다.

매개변수
name | - 칼라램프의 이름
dspRamp | - 추가될 새로운 칼라램프
반환값
성공 여부
IGridColorRampStyle* sgObject::IColorRampList::GetColorRamp ( [in] int index )

인덱스 번호에 해당하는 시스템 칼라램프를 반환한다.

매개변수
index - 칼라램프의 인덱스 번호
반환값
칼라램프
IGridColorRampStyle* sgObject::IColorRampList::GetColorRampByName ( [in] BSTR newVal )

인덱스 이름에 해당하는 시스템 칼라램프를 반환한다.

매개변수
newVal - 칼라램프의 이름
반환값
칼라램프
BSTR sgObject::IColorRampList::GetName ( [in] int index )

인덱스 번호에 해당하는 시스템 칼라램프의 이름을 반환한다.

매개변수
index - 칼라램프의 인덱스 번호
int sgObject::IColorRampList::GetSize ( )

시스템 칼라램프 리스트의 개수를 반환한다.

반환값
리스트 개수
void sgObject::IColorRampList::RemoveColorRamp ( [in] BSTR name )

시스템 칼라램프 리스트에서 주어진 칼라램프를 삭제한다.

매개변수
name - 칼라램프의 이름
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IColorRampList
sgObject::IColorRampList 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IColorRampList (모든 상속된 멤버들도 포함합니다.)

AddColorRamp([in] BSTR name, [in] IGridColorRampStyle *dspRamp) | sgObject::IColorRampList
GetColorRamp([in] int index) | sgObject::IColorRampList
GetColorRampByName([in] BSTR newVal) | sgObject::IColorRampList
GetName([in] int index) | sgObject::IColorRampList
GetSize() | sgObject::IColorRampList
RemoveColorRamp([in] BSTR name) | sgObject::IColorRampList
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ICommonFactory 인터페이스 참조

  • ICommonFactory
Public 멤버 함수 | 모든 멤버 목록
sgObject::ICommonFactory 인터페이스 참조

다양한 Factory객체 인터페이스를 생성할 수 있는 최상위 인터페이스를 제공한다. 더 자세히 ...

sgObject::ICommonFactory에 대한 상속 다이어그램 :
sgObject::ICommonFactory에 대한 협력 다이어그램:

Public 멤버 함수

IDisplayFactory * GetDisplayFactory ()
시스템 내부에 존재하는 DisplayFactory를 반환 더 자세히 ...
ISpatialReferenceFactory * CreateCRSFactory ()
새로운 CRSFactory를 생성 후 반환 더 자세히 ...
IGeometryFactory * | CreateGeometryFactory ([in] ISpatialReference *srs)
새로운 GeometryFactory를 생성 후 반환 더 자세히 ...
ILayerSourceFactory * GetLayerSourceFactory ()
시스템 내부에 존재하는 LayerSourceFactory를 반환 더 자세히 ...
IFeatureTypeStyleFactory * CreateFeatureTypeStyleFactory ()
새로운 FeatureTypeStyleFactory를 생성 후 반환 더 자세히 ...
ICoverageFactory * CreateCoverageFactory ()
새로운 CoverageFactory를 생성 후 반환 더 자세히 ...
IParameters * CreateParameters ()
새로운 Parameters 객체를 생성 후 반환 더 자세히 ...
IParameter * CreateParameter ()
새로운 Parameter 객체를 생성 후 반환 더 자세히 ...
IUtility * CreateUtility ()
새로운 Utility 객체를 생성 후 반환 더 자세히 ...
IMessage * CreateMessage ()
새로운 Message 객체를 생성 후 반환 더 자세히 ...
IAnimator * CreateAnimator ()
새로운 Animator 객체를 생성 후 반환 더 자세히 ...
ILocationSensor * GetLocationSensor ()
시스템 내부의 위치센서 객체를 검색 반환 더 자세히 ...
IMotionSensor * GetMotionSensor ()
시스템 내부의 동작센서 객체를 검색 반환 더 자세히 ...
IVideoSensor * GetVideoSensor ()
시스템 내부의 카메라센서 객체를 검색 반환 더 자세히 ...
IColorRampList * GetColorRampList ()
시스템 내부의 칼라램프리스트 객체를 반환 더 자세히 ...
ILayerSource * GetSystemLayerSource ()
시스템 내부의 시스템레이어소스를 반환 더 자세히 ...
IFeatureType * | CreateFeatureType (BSTR strName)
Layer 스키마 구조체를 생성하여 반환 더 자세히 ...
IFeatureAttributeDescriptor * | CreateFeatureAttributeDescriptor (BSTR strName, int nDataType)
Layer 스키마의 필드를 생성하여 반환 더 자세히 ...
IFeatureQuery * CreateFeatureQuery ()
질의 조건 객체를 생성하여 반환 더 자세히 ...
IAttributeIndex * CreateAttributeIndex ()
인덱싱 기능을 제공하는 AttributeIndex 객체를 생성하여 반환 더 자세히 ...
ILocationService * CreateLocationService ()
위치서비스 객체를 생성 반환 더 자세히 ...

상세한 설명

다양한 Factory객체 인터페이스를 생성할 수 있는 최상위 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "CF"를 덧붙여서 "OGR_CF_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.CommonFactory"

멤버 함수 문서화

IAnimator* sgObject::ICommonFactory::CreateAnimator ( )

새로운 Animator 객체를 생성 후 반환

IAttributeIndex* sgObject::ICommonFactory::CreateAttributeIndex ( )

인덱싱 기능을 제공하는 AttributeIndex 객체를 생성하여 반환

ICoverageFactory* sgObject::ICommonFactory::CreateCoverageFactory ( )

새로운 CoverageFactory를 생성 후 반환

ISpatialReferenceFactory* sgObject::ICommonFactory::CreateCRSFactory ( )

새로운 CRSFactory를 생성 후 반환

IFeatureAttributeDescriptor* sgObject::ICommonFactory::CreateFeatureAttributeDescriptor | ( | BSTR | strName,
 |  | int | nDataType
 | ) |  |

Layer 스키마의 필드를 생성하여 반환

IFeatureQuery* sgObject::ICommonFactory::CreateFeatureQuery ( )

질의 조건 객체를 생성하여 반환

IFeatureType* sgObject::ICommonFactory::CreateFeatureType ( BSTR strName )

Layer 스키마 구조체를 생성하여 반환

IFeatureTypeStyleFactory* sgObject::ICommonFactory::CreateFeatureTypeStyleFactory ( )

새로운 FeatureTypeStyleFactory를 생성 후 반환

IGeometryFactory* sgObject::ICommonFactory::CreateGeometryFactory ( [in] ISpatialReference * srs )

새로운 GeometryFactory를 생성 후 반환

ILocationService* sgObject::ICommonFactory::CreateLocationService ( )

위치서비스 객체를 생성 반환

IMessage* sgObject::ICommonFactory::CreateMessage ( )

새로운 Message 객체를 생성 후 반환

IParameter* sgObject::ICommonFactory::CreateParameter ( )

새로운 Parameter 객체를 생성 후 반환

IParameters* sgObject::ICommonFactory::CreateParameters ( )

새로운 Parameters 객체를 생성 후 반환

IUtility* sgObject::ICommonFactory::CreateUtility ( )

새로운 Utility 객체를 생성 후 반환

IColorRampList* sgObject::ICommonFactory::GetColorRampList ( )

시스템 내부의 칼라램프리스트 객체를 반환

IDisplayFactory* sgObject::ICommonFactory::GetDisplayFactory ( )

시스템 내부에 존재하는 DisplayFactory를 반환

ILayerSourceFactory* sgObject::ICommonFactory::GetLayerSourceFactory ( )

시스템 내부에 존재하는 LayerSourceFactory를 반환

ILocationSensor* sgObject::ICommonFactory::GetLocationSensor ( )

시스템 내부의 위치센서 객체를 검색 반환

IMotionSensor* sgObject::ICommonFactory::GetMotionSensor ( )

시스템 내부의 동작센서 객체를 검색 반환

ILayerSource* sgObject::ICommonFactory::GetSystemLayerSource ( )

시스템 내부의 시스템레이어소스를 반환

IVideoSensor* sgObject::ICommonFactory::GetVideoSensor ( )

시스템 내부의 카메라센서 객체를 검색 반환

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ICommonFactory
sgObject::ICommonFactory 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ICommonFactory (모든 상속된 멤버들도 포함합니다.)

CreateAnimator() | sgObject::ICommonFactory
CreateAttributeIndex() | sgObject::ICommonFactory
CreateCoverageFactory() | sgObject::ICommonFactory
CreateCRSFactory() | sgObject::ICommonFactory
CreateFeatureAttributeDescriptor(BSTR strName, int nDataType) | sgObject::ICommonFactory
CreateFeatureQuery() | sgObject::ICommonFactory
CreateFeatureType(BSTR strName) | sgObject::ICommonFactory
CreateFeatureTypeStyleFactory() | sgObject::ICommonFactory
CreateGeometryFactory([in] ISpatialReference *srs) | sgObject::ICommonFactory
CreateLocationService() | sgObject::ICommonFactory
CreateMessage() | sgObject::ICommonFactory
CreateParameter() | sgObject::ICommonFactory
CreateParameters() | sgObject::ICommonFactory
CreateUtility() | sgObject::ICommonFactory
GetColorRampList() | sgObject::ICommonFactory
GetDisplayFactory() | sgObject::ICommonFactory
GetLayerSourceFactory() | sgObject::ICommonFactory
GetLocationSensor() | sgObject::ICommonFactory
GetMotionSensor() | sgObject::ICommonFactory
GetSystemLayerSource() | sgObject::ICommonFactory
GetVideoSensor() | sgObject::ICommonFactory
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ICoverage 인터페이스 참조

  • ICoverage
Public 멤버 함수 | 모든 멤버 목록
sgObject::ICoverage 인터페이스 참조

커버리지에 접근할 수 있도록 해주는 인터페이스이다 더 자세히 ...

sgObject::ICoverage에 대한 상속 다이어그램 :
sgObject::ICoverage에 대한 협력 다이어그램:

Public 멤버 함수

long | GetNumSampleDimensions ()
커버리지에 대한 샘플차원의 개수(GridCoverage의 경우 Band의 개수) 더 자세히 ...
ISpatialReference * GetCoordinateSystem ()
커버리지에 대한 공간좌표계 더 자세히 ...
IGeometry * GetEnvelope ()
커버리지에 대한 MBR 범위 더 자세히 ...
ISampleDimension * | GetSampleDimension ([in] LONG Index)
커버리지에 대한 샘플차원 정보를 가져온다. 더 자세히 ...
void | Extent2D ([out] double *minX, [out] double *minY, [out] double *maxX, [out] double *maxY)

상세한 설명

커버리지에 접근할 수 있도록 해주는 인터페이스이다

커버리지의 중요한 속성은 해당 도메인 내의 어떤 점에 대한 해당 값을 생성해낼 수 있어야한다는 것이며, 커버리지가 내부적으로 어떻게 표현되는지는 관심사항이 아니다. 커버리지를 내부적으로 표현하는 방법에 대한 것은 다음의 예를 참고하면 된다.

  1. 커버리지는 평면을 모두 타일로 쪼갠 폴리곤의 집합으로 표현할 수 있다. 이 말은 각각의 점은 하나의 폴리곤에 정확히 매칭되고, 따라서 하나의 점에 대한 커버리지의 값은 그 점을 포함하고 있는 폴리곤의 속성값이다.
  2. 커버리지는 그리드의 값으로 표현될 수 있다. 하나의 점에 대한 커버리지의 값은 그 점에 위치가 가장 가까운 그리드 값이 된다.
  3. 커버리지는 수학 함수에 의해 표현될 수 있다. 하나의 점에 대한 커버리지의 값은 단지 점의 좌표를 인자로 가지는 함수의 반환값이다.
  4. 커버리지는 1,2,3의 조합으로 표현될 수 있다. 예를 들어, 커버리지는 다항식의 집합에 대하여 유효한 수학 함수의 조합으로 표현될 수 있다. C API(linux, iOS, MacOS 등) : 중간이름 "CVG"를 덧붙여서 "OGR_CVG_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Coverage"

멤버 함수 문서화

void sgObject::ICoverage::Extent2D | ( | [out] double * | minX,
 |  | [out] double * | minY,
 |  | [out] double * | maxX,
 |  | [out] double * | maxY
 | ) |  |
ISpatialReference* sgObject::ICoverage::GetCoordinateSystem ( )

커버리지에 대한 공간좌표계

IGeometry* sgObject::ICoverage::GetEnvelope ( )

커버리지에 대한 MBR 범위

long sgObject::ICoverage::GetNumSampleDimensions ( )

커버리지에 대한 샘플차원의 개수(GridCoverage의 경우 Band의 개수)

ISampleDimension* sgObject::ICoverage::GetSampleDimension ( [in] LONG Index )

커버리지에 대한 샘플차원 정보를 가져온다.

그리드 커버리지의 경우, 샘플 차원은 밴드를 가리킨다. 샘플 차원정보는 자료형, 설명, 데이터 없음 값, 최소 및 최대값 그리고 컬러테이블 등의 것들에 대한 내용을 포함한다. 커버리지는 최소한 1개 이상의 샘플 차원을 가져야 한다.

매개변수
Index - index 가져오고자 하는 샘플 차원의 인덱스. n 샘플차원의 경우 0에서 n-1까지의 값을 가질 수 있다.
반환값
SampleDimension 참조
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ICoverage
sgObject::ICoverage 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ICoverage (모든 상속된 멤버들도 포함합니다.)

Extent2D([out] double *minX, [out] double *minY, [out] double *maxX, [out] double *maxY) | sgObject::ICoverage
GetCoordinateSystem() | sgObject::ICoverage
GetEnvelope() | sgObject::ICoverage
GetNumSampleDimensions() | sgObject::ICoverage
GetSampleDimension([in] LONG Index) | sgObject::ICoverage
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ICoverageFactory 인터페이스 참조

  • ICoverageFactory
Public 멤버 함수 | 모든 멤버 목록
sgObject::ICoverageFactory 인터페이스 참조

ICoverageFactory 인터페이스는 커버리지 관련된 객체를 생성하기 위하여 사용된다. 더 자세히 ...

sgObject::ICoverageFactory에 대한 상속 다이어그램 :
sgObject::ICoverageFactory에 대한 협력 다이어그램:

Public 멤버 함수

IGridCoverageProcessor * CreateGridCoverageProcessor ()
IGridCoverageProcessor를 생성한다. 더 자세히 ...
INetworkCoverageAnalysis * CreateNetworkCoverageAnalysis ()
INetworkCoverageAnalysis를 생성한다. 더 자세히 ...

상세한 설명

ICoverageFactory 인터페이스는 커버리지 관련된 객체를 생성하기 위하여 사용된다.

멤버 함수 문서화

IGridCoverageProcessor* sgObject::ICoverageFactory::CreateGridCoverageProcessor ( )

IGridCoverageProcessor를 생성한다.

INetworkCoverageAnalysis* sgObject::ICoverageFactory::CreateNetworkCoverageAnalysis ( )

INetworkCoverageAnalysis를 생성한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ICoverageFactory
sgObject::ICoverageFactory 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ICoverageFactory (모든 상속된 멤버들도 포함합니다.)

CreateGridCoverageProcessor() | sgObject::ICoverageFactory
CreateNetworkCoverageAnalysis() | sgObject::ICoverageFactory
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ICurve 인터페이스 참조

  • ICurve
Public 멤버 함수 | 모든 멤버 목록
sgObject::ICurve 인터페이스 참조

기하 명세에 정의된 커브의 일반 속성과 그러한 속성에 접근하기 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::ICurve에 대한 상속 다이어그램 :
sgObject::ICurve에 대한 협력 다이어그램:

Public 멤버 함수

double | GetLength ()
커브의 길이를 반환한다. 더 자세히 ...
VARIANT_BOOL | IsClosed ()
커브가 닫혀있는지 여부 (커브는 시작점과 종료점이 동일하면 닫혀있는 것)를 반환한다. 더 자세히 ...
IPoint * StartPoint ()
커브의 시작 점을 가져온다. 더 자세히 ...
IPoint * EndPoint ()
커브의 종료 점을 가져온다. 더 자세히 ...
IPoint * | Value ([in] double t)
시작 점에서 거리 t만큼 떨어져 있는 점을 가져온다. 더 자세히 ...
- sgObject::IGeometry(으)로부터 상속된 Public 멤버 함수
long | GetDimension ()
Geometry 객체의 차원 (0, 1, 2차원) 이다. 더 자세히 ...
ISpatialReference * GetSpatialReference ()
Geometry 객체가 참조하는 공간참조체계 (좌표체계) 이다. 더 자세히 ...
void | SetSpatialReference (ISpatialReference *pVal)
VARIANT_BOOL | IsEmpty ()
비어있는 Geometry 객체인지 나타낸다 (일반 프로그래밍 시 변수의 NULL과 유사) 더 자세히 ...
VARIANT_BOOL | IsSimple ()
기하가 심플한지 여부를 나타낸다. 더 자세히 ...
GeometryTypeEnum GetGeometryType ()
Geometry 객체의 구체적인 타입이다. 더 자세히 ...
void | SetEmpty ()
기하를 비어있는 기하로 만든다. 더 자세히 ...
IGeometry * Envelope ()
기하를 감싸는 최소 직사각형을 가져온다. 더 자세히 ...
IGeometry * Clone ()
해당 기하와 동일한 객체를 생성하여 가져온다. 더 자세히 ...
IGeometry * | Project ([in] ISpatialReference *newSystem)
기하를 새로운 공간참조체계로 투영해 만든 새로운 기하를 가져온다. 더 자세히 ...
void | Extent2D ([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY)
기하를 감싸는 최소 직사각형의 x, y 좌표를 Output 변수에 가져온다. 더 자세히 ...
IWks * GetWks ()
ISpatialRelation * GetSpatialRelation ()
ISpatialRelation2 * GetSpatialRelation2 ()
ISpatialOperator * GetSpatialOperator ()

상세한 설명

기하 명세에 정의된 커브의 일반 속성과 그러한 속성에 접근하기 위한 인터페이스를 제공한다.

커브에 대한 정의 및 기타 정보는 Knowledge Base의 Geometry를 참고한다. C API(linux, iOS, MacOS 등) : 중간이름 "G"를 덧붙여서 "OGR_G_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Geometry"

멤버 함수 문서화

IPoint* sgObject::ICurve::EndPoint ( )

커브의 종료 점을 가져온다.

반환값
커브의 종료 점 객체
double sgObject::ICurve::GetLength ( )

커브의 길이를 반환한다.

반환값
double - 커브의 길이
VARIANT_BOOL sgObject::ICurve::IsClosed ( )

커브가 닫혀있는지 여부 (커브는 시작점과 종료점이 동일하면 닫혀있는 것)를 반환한다.

반환값
닫혀있다면 VARIANT_TRUE, 닫혀있지 않다면 VARIANT_FALSE
IPoint* sgObject::ICurve::StartPoint ( )

커브의 시작 점을 가져온다.

반환값
커브의 시작 점 객체
IPoint* sgObject::ICurve::Value ( [in] double t )

시작 점에서 거리 t만큼 떨어져 있는 점을 가져온다.

매개변수
t - 시작 점로부터 떨어져 있는 거리
반환값
거리 t만큼 떨어져 있는 점 객체
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ICurve
sgObject::ICurve 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ICurve (모든 상속된 멤버들도 포함합니다.)

Clone() | sgObject::IGeometry
EndPoint() | sgObject::ICurve
Envelope() | sgObject::IGeometry
Extent2D([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY) | sgObject::IGeometry
GetDimension() | sgObject::IGeometry
GetGeometryType() | sgObject::IGeometry
GetLength() | sgObject::ICurve
GetSpatialOperator() | sgObject::IGeometry
GetSpatialReference() | sgObject::IGeometry
GetSpatialRelation() | sgObject::IGeometry
GetSpatialRelation2() | sgObject::IGeometry
GetWks() | sgObject::IGeometry
IsClosed() | sgObject::ICurve
IsEmpty() | sgObject::IGeometry
IsSimple() | sgObject::IGeometry
Project([in] ISpatialReference *newSystem) | sgObject::IGeometry
SetEmpty() | sgObject::IGeometry
SetSpatialReference(ISpatialReference *pVal) | sgObject::IGeometry
StartPoint() | sgObject::ICurve
Value([in] double t) | sgObject::ICurve
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IDefaultTransaction 인터페이스 참조

  • IDefaultTransaction
Public 멤버 함수 | 모든 멤버 목록
sgObject::IDefaultTransaction 인터페이스 참조

작업의 전체 세트가 동시에 롤백 또는 커밋 할 수있는 작업을 제공합니다. 더 자세히 ...

sgObject::IDefaultTransaction에 대한 상속 다이어그램 :
sgObject::IDefaultTransaction에 대한 협력 다이어그램:

Public 멤버 함수

IQueryCommands * BeforeQueryCommands ()
Transaction처리 충돌 시 회복작업을 위해 필요한, QueryCommands에 대한 기록을 반환한다. 더 자세히 ...
IQueryCommands * AfterQueryCommands ()
Transaction처리 이후 비지니스 로직 처리에 필요한 QueryCommands에 대한 기록을 반환한다. 더 자세히 ...
VARIANT_BOOL | Commit (void)
수행 된 작업 중 마지막 작업을 저장합니다. 더 자세히 ...
VARIANT_BOOL | Rollback (void)
수행된 작업 중 마지막 작업 직전에 수행된 작업으로 돌아갑니다. 더 자세히 ...

상세한 설명

작업의 전체 세트가 동시에 롤백 또는 커밋 할 수있는 작업을 제공합니다.

멤버 함수 문서화

IQueryCommands* sgObject::IDefaultTransaction::AfterQueryCommands ( )

Transaction처리 이후 비지니스 로직 처리에 필요한 QueryCommands에 대한 기록을 반환한다.

(Transaction:정보의 교환이나 데이터베이스의 갱신 등 연관되는 작업들에 대한 일련의 연속으로, 하나의 논리적 기능을 수행하기 위한 작업의 단위로서 데이터베이스의 일관된 상태를또 다른 일관된 상태로 변환시킴)

IQueryCommands* sgObject::IDefaultTransaction::BeforeQueryCommands ( )

Transaction처리 충돌 시 회복작업을 위해 필요한, QueryCommands에 대한 기록을 반환한다.

(Transaction:정보의 교환이나 데이터베이스의 갱신 등 연관되는 작업들에 대한 일련의 연속으로, 하나의 논리적 기능을 수행하기 위한 작업의 단위로서 데이터베이스의 일관된 상태를 또 다른 일관된 상태로 변환시킴)

VARIANT_BOOL sgObject::IDefaultTransaction::Commit ( void )

수행 된 작업 중 마지막 작업을 저장합니다.

반환값
성공하면 VARIANT_TRUE, 실패하면 VARIANT_FALSE
VARIANT_BOOL sgObject::IDefaultTransaction::Rollback ( void )

수행된 작업 중 마지막 작업 직전에 수행된 작업으로 돌아갑니다.

반환값
성공하면 VARIANT_TRUE, 실패하면 VARIANT_FALSE
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IDefaultTransaction
sgObject::IDefaultTransaction 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IDefaultTransaction (모든 상속된 멤버들도 포함합니다.)

AfterQueryCommands() | sgObject::IDefaultTransaction
BeforeQueryCommands() | sgObject::IDefaultTransaction
Commit(void) | sgObject::IDefaultTransaction
Rollback(void) | sgObject::IDefaultTransaction
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IDisplayFactory 인터페이스 참조

  • IDisplayFactory
Public 멤버 함수 | 모든 멤버 목록
sgObject::IDisplayFactory 인터페이스 참조

화면에 표현되는 지도와 관련된 객체를 생성하기 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::IDisplayFactory에 대한 상속 다이어그램 :
sgObject::IDisplayFactory에 대한 협력 다이어그램:

Public 멤버 함수

ICanvas * | CreateCanvas ([in] long handle, [in]BSTR CanvasName)
지도객체를 생성하여 반환 더 자세히 ...
IWidget * | CreateWidget ([in]BSTR WidgetName)
위젯(다이알로그 형태)객체를 생성하여 반환 더 자세히 ...
IFeatureCanvas * CreateFeatureCanvas ()
새로운 FeatureCanvas 객체를 생성하여 반환 더 자세히 ...
IIndexMapWidget * CreateWidgetToIndexMap ()
새로운 인덱스지도 위젯 객체를 생성하여 반환 더 자세히 ...
ILayerTreeWidget * CreateWidgetToLayerTree ()
새로운 레이어제어관리 위젯 객체를 생성하여 반환 더 자세히 ...
IFeatureAttributeTreeWidget * CreateWidgetToFeatureAttributeTree ()
새로운 속성값관리 위젯 객체를 생성하여 반환 더 자세히 ...
IDispatch * | CreateGraphic ([in]BSTR bstrName)
새로운 그래픽 객체를 생성하여 반환 더 자세히 ...
IDispatch * | CreateGraphicFromFeature ([in]IFeature *ft, [in]ICanvas *canvas)
새로운 그래픽 객체를 피쳐를 기준으로 생성하여 반환 더 자세히 ...
IDispatch * | CreateGraphicFromGeometry ([in]IGeometry *geom, [in]ICanvas *canvas)
새로운 그래픽 객체를 기하 객체를 기준으로 생성하여 반환 더 자세히 ...
IApplication * CreateApplication ()
새로운 어플리케이션(최상위 위젯) 위젯 객체를 생성하여 반환 더 자세히 ...

상세한 설명

화면에 표현되는 지도와 관련된 객체를 생성하기 위한 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "DF"를 덧붙여서 "OGR_DF_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.DisplayFactory"

멤버 함수 문서화

IApplication* sgObject::IDisplayFactory::CreateApplication ( )

새로운 어플리케이션(최상위 위젯) 위젯 객체를 생성하여 반환

ICanvas* sgObject::IDisplayFactory::CreateCanvas | ( | [in] long | handle,
 |  | [in] BSTR | CanvasName
 | ) |  |

지도객체를 생성하여 반환

매개변수
handle | - 지도를 그리기 위한 외부 핸들
CanvasName | - 지도의 종류 문자열 예) "map2d", "map3d", "mapearth", "mapar"
반환값
생성된 지도객체
IFeatureCanvas* sgObject::IDisplayFactory::CreateFeatureCanvas ( )

새로운 FeatureCanvas 객체를 생성하여 반환

IDispatch* sgObject::IDisplayFactory::CreateGraphic ( [in] BSTR bstrName )

새로운 그래픽 객체를 생성하여 반환

IDispatch* sgObject::IDisplayFactory::CreateGraphicFromFeature | ( | [in] IFeature * | ft,
 |  | [in] ICanvas * | canvas
 | ) |  |

새로운 그래픽 객체를 피쳐를 기준으로 생성하여 반환

IDispatch* sgObject::IDisplayFactory::CreateGraphicFromGeometry | ( | [in] IGeometry * | geom,
 |  | [in] ICanvas * | canvas
 | ) |  |

새로운 그래픽 객체를 기하 객체를 기준으로 생성하여 반환

IWidget* sgObject::IDisplayFactory::CreateWidget ( [in] BSTR WidgetName )

위젯(다이알로그 형태)객체를 생성하여 반환

매개변수
WidgetName - 위젯의 종류 문자열 예) "LayerTreeWidget", "FeatureAttributeTreeWidget"
반환값
생성된 위젯객체
IFeatureAttributeTreeWidget* sgObject::IDisplayFactory::CreateWidgetToFeatureAttributeTree ( )

새로운 속성값관리 위젯 객체를 생성하여 반환

IIndexMapWidget* sgObject::IDisplayFactory::CreateWidgetToIndexMap ( )

새로운 인덱스지도 위젯 객체를 생성하여 반환

ILayerTreeWidget* sgObject::IDisplayFactory::CreateWidgetToLayerTree ( )

새로운 레이어제어관리 위젯 객체를 생성하여 반환

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IDisplayFactory
sgObject::IDisplayFactory 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IDisplayFactory (모든 상속된 멤버들도 포함합니다.)

CreateApplication() | sgObject::IDisplayFactory
CreateCanvas([in] long handle, [in]BSTR CanvasName) | sgObject::IDisplayFactory
CreateFeatureCanvas() | sgObject::IDisplayFactory
CreateGraphic([in]BSTR bstrName) | sgObject::IDisplayFactory
CreateGraphicFromFeature([in]IFeature *ft, [in]ICanvas *canvas) | sgObject::IDisplayFactory
CreateGraphicFromGeometry([in]IGeometry *geom, [in]ICanvas *canvas) | sgObject::IDisplayFactory
CreateWidget([in]BSTR WidgetName) | sgObject::IDisplayFactory
CreateWidgetToFeatureAttributeTree() | sgObject::IDisplayFactory
CreateWidgetToIndexMap() | sgObject::IDisplayFactory
CreateWidgetToLayerTree() | sgObject::IDisplayFactory
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IDockWidget 인터페이스 참조

  • IDockWidget
Public 멤버 함수 | 모든 멤버 목록
sgObject::IDockWidget 인터페이스 참조

도킹위젯을 제어하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::IDockWidget에 대한 상속 다이어그램 :
sgObject::IDockWidget에 대한 협력 다이어그램:

Public 멤버 함수

void | SetWidget ([in] BSTR bstrTitle, [in] IWidget *dspWidget)
도킹 위젯에 포함되는 위젯을 설정한다. 더 자세히 ...
ICanvas * | SetCanvas ([in] BSTR bstrTitle, [in] BSTR bstrCanvasType)
도킹 위젯에 포함되는 지도객체를 설정한다. 더 자세히 ...
void | SetAllowedAreas ([in] short nAreas)
도킹 위젯이 도킹가능한 위치를 설정한다. 더 자세히 ...
short | GetFeatures ()
도킹 위젯의 위젯 스타일을 가져온다. \ nFeaturees - DockFeatureEnum 값의 조합값 더 자세히 ...
void | SetFeatures (short nFeaturees)
도킹 위젯의 위젯 스타일을 설정한다. 더 자세히 ...
- sgObject::IWidget(으)로부터 상속된 Public 멤버 함수
void | Initialize ([in] ULONG_PTR h)
위젯 초기화 더 자세히 ...
void | ReSize ([in] int x, [in] int y, [in] int cx, [in] int cy)
위젯 객체의 크기를 재설정 한다. 더 자세히 ...
void | AddWidget ([in] IWidget *dspWidget)
현재 위젯에 하부로 위젯을 추가한다. 더 자세히 ...
void | AddWidgetByLayout ([in] IWidget *dspWidget, [in] int row, [in] int col)
현재 위젯에 종, 횡 위치에 위젯을 추가한다. 더 자세히 ...
void | SetQtUiObjectVisible ([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue)
위젯의 해당 오브젝트 객체의 보이기 여부를 설정한다. 더 자세히 ...
long | GetBackColor ()
위젯이 사용하는 배경 색상 정보 더 자세히 ...
void | SetBackColor ([in] long color)
void | SetCanvas (ICanvas *poCanvas)
위젯을 특정(2D, 3D, Earth 등) 지도창으로 설정한다. 더 자세히 ...
IFeatureCanvas * GetFeatureCanvas ()
위젯이 사용하는 FeatureCanvas 정보 더 자세히 ...
void | SetFeatureCanvas (IFeatureCanvas *poFtCvs)
void | SetFeatureLayer (IFeatureLayer *poFtLayer)
위젯이 사용하는 FeatureLayer 정보 더 자세히 ...
void | SetLayer (ILayer *poLayer)
위젯이 사용하는 레이어 정보 더 자세히 ...
BSTR | GetFlag ()
위젯이 사용하는 문자열 파라메터 정보 더 자세히 ...
void | SetFlag (BSTR bstrFlag)
void | SetWidth (int nWidth)
위젯의 가로크기를 설정한다. 더 자세히 ...
int | SetHeight (int nHeight)
위젯의 세로크기를 설정한다. 더 자세히 ...
void | Destroy ()

상세한 설명

도킹위젯을 제어하는 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "DW"를 덧붙여서 "OGR_DW_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.DockWidget"

멤버 함수 문서화

short sgObject::IDockWidget::GetFeatures ( )

도킹 위젯의 위젯 스타일을 가져온다. \ nFeaturees - DockFeatureEnum 값의 조합값

void sgObject::IDockWidget::SetAllowedAreas ( [in] short nAreas )

도킹 위젯이 도킹가능한 위치를 설정한다.

매개변수
nAreas - DockAreaEnum 값의 조합값
ICanvas* sgObject::IDockWidget::SetCanvas | ( | [in] BSTR | bstrTitle,
 |  | [in] BSTR | bstrCanvasType
 | ) |  |

도킹 위젯에 포함되는 지도객체를 설정한다.

매개변수
bstrTitle | - 도킹 위젯을 제목
bstrCanvasType | - 도킹 위젯에 포함되는 지도문자열 예) "map2d"
void sgObject::IDockWidget::SetFeatures ( short nFeaturees )

도킹 위젯의 위젯 스타일을 설정한다.

매개변수
nFeaturees - DockFeatureEnum 값의 조합값
void sgObject::IDockWidget::SetWidget | ( | [in] BSTR | bstrTitle,
 |  | [in] IWidget * | dspWidget
 | ) |  |

도킹 위젯에 포함되는 위젯을 설정한다.

매개변수
bstrTitle | - 도킹 위젯을 제목
dspWidget | - 도킹 위젯에 포함되는 위젯
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IDockWidget
sgObject::IDockWidget 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IDockWidget (모든 상속된 멤버들도 포함합니다.)

AddWidget([in] IWidget *dspWidget) | sgObject::IWidget
AddWidgetByLayout([in] IWidget *dspWidget, [in] int row, [in] int col) | sgObject::IWidget
Destroy() | sgObject::IWidget
GetBackColor() | sgObject::IWidget
GetFeatureCanvas() | sgObject::IWidget
GetFeatures() | sgObject::IDockWidget
GetFlag() | sgObject::IWidget
Initialize([in] ULONG_PTR h) | sgObject::IWidget
ReSize([in] int x, [in] int y, [in] int cx, [in] int cy) | sgObject::IWidget
SetAllowedAreas([in] short nAreas) | sgObject::IDockWidget
SetBackColor([in] long color) | sgObject::IWidget
SetCanvas([in] BSTR bstrTitle, [in] BSTR bstrCanvasType) | sgObject::IDockWidget
sgObject::IWidget::SetCanvas(ICanvas *poCanvas) | sgObject::IWidget
SetFeatureCanvas(IFeatureCanvas *poFtCvs) | sgObject::IWidget
SetFeatureLayer(IFeatureLayer *poFtLayer) | sgObject::IWidget
SetFeatures(short nFeaturees) | sgObject::IDockWidget
SetFlag(BSTR bstrFlag) | sgObject::IWidget
SetHeight(int nHeight) | sgObject::IWidget
SetLayer(ILayer *poLayer) | sgObject::IWidget
SetQtUiObjectVisible([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue) | sgObject::IWidget
SetWidget([in] BSTR bstrTitle, [in] IWidget *dspWidget) | sgObject::IDockWidget
SetWidth(int nWidth) | sgObject::IWidget
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IFeature 인터페이스 참조

  • IFeature
Public 멤버 함수 | 모든 멤버 목록
sgObject::IFeature 인터페이스 참조

실세계의 객체를 표현하는 기본 단위인 Feature 객체의 인터페이스를 제공한다. 더 자세히 ...

sgObject::IFeature에 대한 상속 다이어그램 :
sgObject::IFeature에 대한 협력 다이어그램:

Public 멤버 함수

ISymbolizer * GetSymbolizer ()
Feature 객체가 화면에 그려질 때 필요한 색상, 선굵기 등 그래픽 속성에 관련된 정보를 나타내는 Symbolizer 객체를 반환한다. 더 자세히 ...
void | SetSymbolizer (ISymbolizer *dspSymbolizer)
Feature 객체가 화면에 그려질 때 필요한 색상, 선굵기 등 그래픽 속성에 관련된 정보를 나타내는 Symbolizer 객체를 설정한다. 더 자세히 ...
IFeatureType * GetFeatureType ()
Feature 객체가 어떤 타입인지, 저장된 일반 (속성) 정보들의 타입 등에 대한 정보를 나타내는 FeatureType 객체를 반환한다. 더 자세히 ...
IGeometry * GetGeometry ()
Feature 객체가 갖는 기하 정보를 나타내는 기하를 반환한다. (위치 및 기하 정보) 더 자세히 ...
void | SetGeometry (IGeometry *dspGeom)
Feature 객체가 갖는 기하 정보를 나타내는 기하를 설정한다. (위치 및 기하 정보) 더 자세히 ...
IFeatureCollection * GetFeatureCollection ()
Feature 객체가 속한 FeatureCollection 객체를 반환한다. 더 자세히 ...
IAnnotation * GetAnnotation ()
Feature 객체에 대한 주석 정보를 나타내는 주석 객체를 반환한다. 더 자세히 ...
void | SetAnnotation (IAnnotation *dspAnno)
Feature 객체에 대한 주석 정보를 나타내는 주석 객체를 설정한다. 더 자세히 ...
int | GetID ()
Feature 객체를 식별하기 위한 ID를 반환한다. (데이터베이스의 Unique Key와 대응된다) 더 자세히 ...
void | SetID (int nVal)
Feature 객체를 식별하기 위한 ID를 설정한다. (데이터베이스의 Unique Key와 대응된다) 더 자세히 ...
long | GetData ()
사용자가 정의한 필터값을 반환한다. 더 자세히 ...
void | SetData (long filter)
Feature 사용자가 정의한 필터값을 설정한다. 더 자세히 ...
VARIANT_BOOL | GetVisible ()
Feature 객체를 화면에 보여줄지 여부를 반환한다. 더 자세히 ...
void | SetVisible (VARIANT_BOOL bVal)
Feature 객체를 화면에 보여줄지 여부를 설정한다. 더 자세히 ...
VARIANT_BOOL | GetSelected ()
Feature 객체의 선택가능 여부를 반환한다. 더 자세히 ...
void | SetSelected (VARIANT_BOOL bVal)
Feature 객체의 선택가능 여부를 설정한다. 더 자세히 ...
IGeometry * GetAnnotationLine ()
인출선을 가리키는 기하를 반환한다. (*인출선 : 시설물 등 근처에 주석이 많을 경우 선을 빼서 주석을 그리기 위한 용도로 쓰임) 더 자세히 ...
void | SetAnnotationLine (IGeometry *dspGeom)
인출선을 가리키는 기하를 설정한다. (*인출선 : 시설물 등 근처에 주석이 많을 경우 선을 빼서 주석을 그리기 위한 용도로 쓰임) 더 자세히 ...
VARIANT_BOOL | GetVisibleAnnotation ()
주석을 화면에 보여줄지 여부를 반환한다 더 자세히 ...
void | SetVisibleAnnotation (VARIANT_BOOL bVal)
주석을 화면에 보여줄지 여부를 설정한다 더 자세히 ...
VARIANT_BOOL | GetVisibleAnnotationLine ()
인출선을 화면에 보여줄지 여부를 반환한다. 더 자세히 ...
void | SetVisibleAnnotationLine (VARIANT_BOOL bVal)
인출선을 화면에 보여줄지 여부를 반환한다. 더 자세히 ...
IUserDefinedWidget * GetUserDefinedWidget ()
사용자가 정의한 위젯 객체(도표 등)인 UserDefinedWidget 객체를 반환한다. 더 자세히 ...
void | SetUserDefinedWidget (IUserDefinedWidget *dspWidget)
사용자가 정의한 위젯 객체(도표 등)인 UserDefinedWidget 객체를 설정한다. 더 자세히 ...
VARIANT_BOOL | GetVisibleUserDefinedWidget ()
사용자가 정의한 위젯 객체(도표 등)인 UserDefinedWidget 객체를 화면에 보여줄지 여부를 반환한다. 더 자세히 ...
void | SetVisibleUserDefinedWidget (VARIANT_BOOL bVal)
사용자가 정의한 위젯 객체(도표 등)인 UserDefinedWidget 객체를 화면에 보여줄지 여부를 설정한다. 더 자세히 ...
IGeometry * GetBounds ()
Feature 객체의 기하를 감싸는 최소 직사각형의 기하를 반환한다. 더 자세히 ...
void | SetAttribute ([in] VARIANT vtIdx, [in] VARIANT vtVal)
해당 인덱스로 Feature 객체의 일반 (속성) 정보 한 개를 저장한다. 더 자세히 ...
BSTR | GetAttributeToString ([in] VARIANT vtIdx)
해당 인덱스의 일반 (속성) 정보를 문자열로 반환한다. 더 자세히 ...
void | GetAttribute ([in] VARIANT vtIdx, [out] VARIANT *pVal)
해당 인덱스의 일반 (속성) 정보를 가져온다. 더 자세히 ...
void | Extent2D ([out] double *minX, [out] double *minY, [out] double *maxX, [out] double *maxY)
Feature 객체의 기하를 감싸는 최소 직사각형의 x, y 좌표를 Output 변수에 가져온다 더 자세히 ...
IFeature * Clone ()
해당 Feature 객체와 동일한 객체를 복사 생성하여 가져온다. 더 자세히 ...
VARIANT_BOOL | Equal ([in] IFeature *ft)
해당 Feature 객체와 동일한지 여부를 판단한다. 더 자세히 ...
void | ReCalculateExtent ()
해당 Feature의 범위를 다시 계산한다. 더 자세히 ...
void | CopyTo ([in] IFeature *ft)
double | GetMinXExtent2D ()
double | GetMinYExtent2D ()
double | GetMaxXExtent2D ()
double | GetMaxYExtent2D ()
IGridCoverage * GetGridCoverage ()
BSTR | GetAttributeAsString ([in] VARIANT vtIdx)
BSTR | GetAttributeAsStringByName ([in] BSTR strName)

상세한 설명

실세계의 객체를 표현하는 기본 단위인 Feature 객체의 인터페이스를 제공한다.

(Feature 객체를 데이터베이스와 대응시키면 레코드 한 개와 대응된다) Feature 객체는 실세계 객체의 일반 (속성) 정보 및 기하 정보를 관리한다. 관리되는 일반 (속성) 정보에 대한 구조는 FeatureType 객체로 관리한다. 또한 Feature 객체를 화면에 표시하기 위해 필요한 그래픽 속성은 FeatureStyle 객체로 관리한다. 또 주석 객체를 통해 주석 정보 (간단한 텍스트 정보)를 관리할 수도 있다. Feature 객체는 Object 애플리케이션에서 보통 FeatureCollection에 소속되어 FeatureLayer로 관리된다. C API(linux, iOS, MacOS 등) : 중간이름 "F"를 덧붙여서 "OGR_F_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Feature"

멤버 함수 문서화

IFeature* sgObject::IFeature::Clone ( )

해당 Feature 객체와 동일한 객체를 복사 생성하여 가져온다.

속성으로 갖고 있는 Geometry와 FeatureAttribute, FeatureStyle, Annotation, ID를 새로 생성하여 기존값과 동일하게 설정하여 가져온다. ID까지 복사함으로 추후 객체를 다시 추가하는 경우 ID를 새로 설정하여 사용하는 것이 좋다.

반환값
새로 생성된 Feature 객체를 가리키는 포인터
void sgObject::IFeature::CopyTo ( [in] IFeature * ft )
VARIANT_BOOL sgObject::IFeature::Equal ( [in] IFeature * ft )

해당 Feature 객체와 동일한지 여부를 판단한다.

속성으로 갖고 있는 기하와 FeatureAttribute, FeatureStyle, Annotation, ID등을 비교하여 같을 경우 참을 반환한다.

매개변수
ft - 비교할 Feature 객체
반환값
두 Feature가 동일할 경우 VARIANT_TRUE, 다를 경우 VARIANT_FALSE
void sgObject::IFeature::Extent2D | ( | [out] double * | minX,
 |  | [out] double * | minY,
 |  | [out] double * | maxX,
 |  | [out] double * | maxY
 | ) |  |

Feature 객체의 기하를 감싸는 최소 직사각형의 x, y 좌표를 Output 변수에 가져온다

매개변수
minX | - 직사각형의 최소 x 좌표값을 넣을 Output 변수
minY | - 직사각형의 최소 y 좌표값을 넣을 Output 변수
maxX | - 직사각형의 최대 x 좌표값을 넣을 Output 변수
maxY | - 직사각형의 최대 y 좌표값을 넣을 Output 변수
IAnnotation* sgObject::IFeature::GetAnnotation ( )

Feature 객체에 대한 주석 정보를 나타내는 주석 객체를 반환한다.

반환값
Annotation 객체의 포인터
IGeometry* sgObject::IFeature::GetAnnotationLine ( )

인출선을 가리키는 기하를 반환한다. (*인출선 : 시설물 등 근처에 주석이 많을 경우 선을 빼서 주석을 그리기 위한 용도로 쓰임)

반환값
인출선을 가리키는 기하의 포인터
void sgObject::IFeature::GetAttribute | ( | [in] VARIANT | vtIdx,
 |  | [out] VARIANT * | pVal
 | ) |  |

해당 인덱스의 일반 (속성) 정보를 가져온다.

vt를 VT_I2, VT_I4, VT_INT, VT_UI2, VT_UI4, VT_UINT, VT_R4, VT_R8, VT_BSTR 중 하나로 하고 데이터 값을 알맞은 변수에 넣는다. (즉, vt에 어떤 값이 들어있는지 확인해서, 그 타입의 변수에 데이터를 넣거나 빼면 된다.)

매개변수
vtIdx | - 인덱스 번호
pVal | - 일반 (속성) 정보를 가져올 Output 변수
BSTR sgObject::IFeature::GetAttributeAsString ( [in] VARIANT vtIdx )
BSTR sgObject::IFeature::GetAttributeAsStringByName ( [in] BSTR strName )
BSTR sgObject::IFeature::GetAttributeToString ( [in] VARIANT vtIdx )

해당 인덱스의 일반 (속성) 정보를 문자열로 반환한다.

vt를 VT_I2, VT_I4, VT_INT, VT_UI2, VT_UI4, VT_UINT, VT_R4, VT_R8, VT_BSTR 중 하나로 하고 데이터 값을 알맞은 변수에 넣는다. (즉, vt에 어떤 값이 들어있는지 확인해서, 그 타입의 변수에 데이터를 넣거나 빼면 된다.)

매개변수
vtIdx - 인덱스 번호
반환값
일반 (속성) 정보의 문자열 값
IGeometry* sgObject::IFeature::GetBounds ( )

Feature 객체의 기하를 감싸는 최소 직사각형의 기하를 반환한다.

반환값
최소 직사각형 기하를 가리키는 포인터
long sgObject::IFeature::GetData ( )

사용자가 정의한 필터값을 반환한다.

반환값
사용자가 정의한 필터값
IFeatureCollection* sgObject::IFeature::GetFeatureCollection ( )

Feature 객체가 속한 FeatureCollection 객체를 반환한다.

반환값
FeatureCollection 객체의 포인터
IFeatureType* sgObject::IFeature::GetFeatureType ( )

Feature 객체가 어떤 타입인지, 저장된 일반 (속성) 정보들의 타입 등에 대한 정보를 나타내는 FeatureType 객체를 반환한다.

(데이터베이스의 테이블 스키마에 대응된다)

반환값
FeatureType 객체의 포인터
IGeometry* sgObject::IFeature::GetGeometry ( )

Feature 객체가 갖는 기하 정보를 나타내는 기하를 반환한다. (위치 및 기하 정보)

반환값
기하의 포인터
IGridCoverage* sgObject::IFeature::GetGridCoverage ( )
int sgObject::IFeature::GetID ( )

Feature 객체를 식별하기 위한 ID를 반환한다. (데이터베이스의 Unique Key와 대응된다)

반환값
Feature 객체를 식별하기 위한 ID값
double sgObject::IFeature::GetMaxXExtent2D ( )
double sgObject::IFeature::GetMaxYExtent2D ( )
double sgObject::IFeature::GetMinXExtent2D ( )
double sgObject::IFeature::GetMinYExtent2D ( )
VARIANT_BOOL sgObject::IFeature::GetSelected ( )

Feature 객체의 선택가능 여부를 반환한다.

반환값
선택이 가능하면 VARIANT_TRUE, 불가능하면 VARIANT_FALSE
ISymbolizer* sgObject::IFeature::GetSymbolizer ( )

Feature 객체가 화면에 그려질 때 필요한 색상, 선굵기 등 그래픽 속성에 관련된 정보를 나타내는 Symbolizer 객체를 반환한다.

반환값
Symbolizer 객체
IUserDefinedWidget* sgObject::IFeature::GetUserDefinedWidget ( )

사용자가 정의한 위젯 객체(도표 등)인 UserDefinedWidget 객체를 반환한다.

반환값
도표 등을 나타내는 UserDefinedWidget 객체의 포인터
VARIANT_BOOL sgObject::IFeature::GetVisible ( )

Feature 객체를 화면에 보여줄지 여부를 반환한다.

반환값
보여준다면 VARIANT_TRUE, 보여주지 않는다면 VARIANT_FALSE
VARIANT_BOOL sgObject::IFeature::GetVisibleAnnotation ( )

주석을 화면에 보여줄지 여부를 반환한다

반환값
보여준다면 VARIANT_TRUE, 보여주지 않는다면 VARIANT_FALSE
VARIANT_BOOL sgObject::IFeature::GetVisibleAnnotationLine ( )

인출선을 화면에 보여줄지 여부를 반환한다.

반환값
보여준다면 VARIANT_TRUE, 보여주지 않는다면 VARIANT_FALSE
VARIANT_BOOL sgObject::IFeature::GetVisibleUserDefinedWidget ( )

사용자가 정의한 위젯 객체(도표 등)인 UserDefinedWidget 객체를 화면에 보여줄지 여부를 반환한다.

반환값
보여준다면 VARIANT_TRUE, 보여주지 않는다면 VARIANT_FALSE
void sgObject::IFeature::ReCalculateExtent ( )

해당 Feature의 범위를 다시 계산한다.

sgObject::IFeatureCollection에서 구현되었습니다.

void sgObject::IFeature::SetAnnotation ( IAnnotation * dspAnno )

Feature 객체에 대한 주석 정보를 나타내는 주석 객체를 설정한다.

매개변수
dspAnno - Annotation 객체의 포인터
void sgObject::IFeature::SetAnnotationLine ( IGeometry * dspGeom )

인출선을 가리키는 기하를 설정한다. (*인출선 : 시설물 등 근처에 주석이 많을 경우 선을 빼서 주석을 그리기 위한 용도로 쓰임)

반환값
dspGeom - 인출선을 가리키는 기하의 포인터
void sgObject::IFeature::SetAttribute | ( | [in] VARIANT | vtIdx,
 |  | [in] VARIANT | vtVal
 | ) |  |

해당 인덱스로 Feature 객체의 일반 (속성) 정보 한 개를 저장한다.

vt를 VT_I2, VT_I4, VT_INT, VT_UI2, VT_UI4, VT_UINT, VT_R4, VT_R8, VT_BSTR 중 하나로 하고 데이터 값을 알맞은 변수에 넣는다. (즉, vt에 어떤 값이 들어있는지 확인해서, 그 타입의 변수에 데이터를 넣거나 빼면 된다.)

매개변수
vtIdx | - 인덱스 번호
vtVal | - 일반 (속성) 정보
void sgObject::IFeature::SetData ( long filter )

Feature 사용자가 정의한 필터값을 설정한다.

매개변수
filter - 사용자가 정의한 필터값
void sgObject::IFeature::SetGeometry ( IGeometry * dspGeom )

Feature 객체가 갖는 기하 정보를 나타내는 기하를 설정한다. (위치 및 기하 정보)

매개변수
dspGeom - 기하의 포인터
void sgObject::IFeature::SetID ( int nVal )

Feature 객체를 식별하기 위한 ID를 설정한다. (데이터베이스의 Unique Key와 대응된다)

매개변수
nVal - Feature 객체를 식별하기 위한 ID값
void sgObject::IFeature::SetSelected ( VARIANT_BOOL bVal )

Feature 객체의 선택가능 여부를 설정한다.

매개변수
bVal - 선택이 가능하면 VARIANT_TRUE, 불가능하면 VARIANT_FALSE
void sgObject::IFeature::SetSymbolizer ( ISymbolizer * dspSymbolizer )

Feature 객체가 화면에 그려질 때 필요한 색상, 선굵기 등 그래픽 속성에 관련된 정보를 나타내는 Symbolizer 객체를 설정한다.

매개변수
dspSymbolizer - Symbolizer 객체
void sgObject::IFeature::SetUserDefinedWidget ( IUserDefinedWidget * dspWidget )

사용자가 정의한 위젯 객체(도표 등)인 UserDefinedWidget 객체를 설정한다.

매개변수
dspWidget - 도표 등을 나타내는 UserDefinedWidget 객체의 포인터
void sgObject::IFeature::SetVisible ( VARIANT_BOOL bVal )

Feature 객체를 화면에 보여줄지 여부를 설정한다.

매개변수
bVal - 보여준다면 VARIANT_TRUE, 보여주지 않는다면 VARIANT_FALSE
void sgObject::IFeature::SetVisibleAnnotation ( VARIANT_BOOL bVal )

주석을 화면에 보여줄지 여부를 설정한다

매개변수
bVal - 보여준다면 VARIANT_TRUE, 보여주지 않는다면 VARIANT_FALSE
void sgObject::IFeature::SetVisibleAnnotationLine ( VARIANT_BOOL bVal )

인출선을 화면에 보여줄지 여부를 반환한다.

매개변수
bVal - 보여준다면 VARIANT_TRUE, 보여주지 않는다면 VARIANT_FALSE
void sgObject::IFeature::SetVisibleUserDefinedWidget ( VARIANT_BOOL bVal )

사용자가 정의한 위젯 객체(도표 등)인 UserDefinedWidget 객체를 화면에 보여줄지 여부를 설정한다.

매개변수
bVal - 보여준다면 VARIANT_TRUE, 보여주지 않는다면 VARIANT_FALSE
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IFeature
sgObject::IFeature 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IFeature (모든 상속된 멤버들도 포함합니다.)

Clone() | sgObject::IFeature
CopyTo([in] IFeature *ft) | sgObject::IFeature
Equal([in] IFeature *ft) | sgObject::IFeature
Extent2D([out] double *minX, [out] double *minY, [out] double *maxX, [out] double *maxY) | sgObject::IFeature
GetAnnotation() | sgObject::IFeature
GetAnnotationLine() | sgObject::IFeature
GetAttribute([in] VARIANT vtIdx, [out] VARIANT *pVal) | sgObject::IFeature
GetAttributeAsString([in] VARIANT vtIdx) | sgObject::IFeature
GetAttributeAsStringByName([in] BSTR strName) | sgObject::IFeature
GetAttributeToString([in] VARIANT vtIdx) | sgObject::IFeature
GetBounds() | sgObject::IFeature
GetData() | sgObject::IFeature
GetFeatureCollection() | sgObject::IFeature
GetFeatureType() | sgObject::IFeature
GetGeometry() | sgObject::IFeature
GetGridCoverage() | sgObject::IFeature
GetID() | sgObject::IFeature
GetMaxXExtent2D() | sgObject::IFeature
GetMaxYExtent2D() | sgObject::IFeature
GetMinXExtent2D() | sgObject::IFeature
GetMinYExtent2D() | sgObject::IFeature
GetSelected() | sgObject::IFeature
GetSymbolizer() | sgObject::IFeature
GetUserDefinedWidget() | sgObject::IFeature
GetVisible() | sgObject::IFeature
GetVisibleAnnotation() | sgObject::IFeature
GetVisibleAnnotationLine() | sgObject::IFeature
GetVisibleUserDefinedWidget() | sgObject::IFeature
ReCalculateExtent() | sgObject::IFeature
SetAnnotation(IAnnotation *dspAnno) | sgObject::IFeature
SetAnnotationLine(IGeometry *dspGeom) | sgObject::IFeature
SetAttribute([in] VARIANT vtIdx, [in] VARIANT vtVal) | sgObject::IFeature
SetData(long filter) | sgObject::IFeature
SetGeometry(IGeometry *dspGeom) | sgObject::IFeature
SetID(int nVal) | sgObject::IFeature
SetSelected(VARIANT_BOOL bVal) | sgObject::IFeature
SetSymbolizer(ISymbolizer *dspSymbolizer) | sgObject::IFeature
SetUserDefinedWidget(IUserDefinedWidget *dspWidget) | sgObject::IFeature
SetVisible(VARIANT_BOOL bVal) | sgObject::IFeature
SetVisibleAnnotation(VARIANT_BOOL bVal) | sgObject::IFeature
SetVisibleAnnotationLine(VARIANT_BOOL bVal) | sgObject::IFeature
SetVisibleUserDefinedWidget(VARIANT_BOOL bVal) | sgObject::IFeature
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IFeatureAttributeDescriptor 인터페이스 참조

  • IFeatureAttributeDescriptor
Public 멤버 함수 | 모든 멤버 목록
sgObject::IFeatureAttributeDescriptor 인터페이스 참조

Feature 객체의 필드(속성) 객체로 FeatureType 객체는 FeatureAttributeDescriptor 객체의 집합이다. 더 자세히 ...

sgObject::IFeatureAttributeDescriptor에 대한 상속 다이어그램 :
sgObject::IFeatureAttributeDescriptor에 대한 협력 다이어그램:

Public 멤버 함수

int | GetDataType ()
필드의 데이터 타입을 반환한다. 더 자세히 ...
void | SetDataType (int nVal)
필드의 데이터 타입을 설정한다. 더 자세히 ...
BSTR | GetName ()
필드 이름(데이터베이스 테이블의 필드명과 동일)을 반환한다. 더 자세히 ...
void | SetName (BSTR bstrName)
필드 이름(데이터베이스 테이블의 필드명과 동일)을 설정한다. 더 자세히 ...
int | GetSize ()
필드의 최대 크기를 반환한다. 더 자세히 ...
void | SetSize (int nSize)
필드의 최대 크기를 설정한다. 더 자세히 ...
int | GetPrecision ()
실수형 데이터의 경우 정밀도(Precision:출력되어야 하는 소수점 이하의 자리 수)을 반환한다. 더 자세히 ...
void | SetPrecision (int nPrecision)
실수형 데이터의 경우 정밀도(Precision:출력되어야 하는 소수점 이하의 자리 수)을 설정한다. 더 자세히 ...
int | GetMinimumOccurrences ()
해당 DataType으로 입력할 수 있는 값의 최소값을 반환한다. 더 자세히 ...
void | SetMinimumOccurrences (int nVal)
해당 DataType으로 입력할 수 있는 값의 최소값을 설정한다. 더 자세히 ...
int | GetMaximumOccurrences ()
해당 DataType으로 입력할 수 있는 값의 최대값을 반환한다. 더 자세히 ...
void | SetMaximumOccurrences (int nVal)
해당 DataType으로 입력할 수 있는 값의 최대값을 설정한다. 더 자세히 ...
BSTR | GetTitle ()
필드 이름(데이터베이스 테이블의 필드명)에 사용자가 알아보기 쉽게 제목을 붙이는데 이 제목을 반환한다. 더 자세히 ...
void | SetTitle (BSTR bstrTitle)
필드(Attribute) 이름(데이터베이스 테이블의 필드명)에 사용자가 알아보기 쉽게 제목을 붙이는데 이 제목을 설정한다. 더 자세히 ...
ILayer * GetReferLayer ()
특정 레이어끼리 연결하기 위한 정보를 갖고 있는 레이어의 포인터를 반환한다. 더 자세히 ...
void | SetReferLayer (ILayer *dspLayer)
특정 레이어끼리 연결하기 위한 정보를 갖고 있는 레이어의 포인터를 설정한다. 더 자세히 ...
IFeatureAttributeDescriptor * GetReferField ()
특정 필드끼리 연결하기 위한 정보를 갖고 있는 FeatureAttributeDescriptor 객체의 포인터를 반환한다. 더 자세히 ...
void | SetReferField (IFeatureAttributeDescriptor *val)
특정 필드끼리 연결하기 위한 정보를 갖고 있는 FeatureAttributeDescriptor 객체의 포인터를 설정한다. 더 자세히 ...
BSTR | GetReferLayerName ()
특정 레이어끼리 연결하기 위한 정보를 갖고 있는 레이어의 이름을 반환한다. 더 자세히 ...
void | SetReferLayerName (BSTR val)
특정 레이어끼리 연결하기 위한 정보를 갖고 있는 레이어의 이름을 설정한다. 더 자세히 ...
BSTR | GetReferFieldName ()
특정 필드끼리 연결하기 위한 정보를 갖고 있는 FeatureAttributeDescriptor 객체의 이름을 반환한다. 더 자세히 ...
void | SetReferFieldName (BSTR val)
특정 필드끼리 연결하기 위한 정보를 갖고 있는 FeatureAttributeDescriptor 객체의 이름을 설정한다. 더 자세히 ...
int | GetVisibleAuth ()
필드를 보이거나 숨기거나 할 수 있는 데, 이러한 보이기/숨기기에 대한 권한값을 반환한다. 더 자세히 ...
void | SetVisibleAuth (int val)
필드를 보이거나 숨기거나 할 수 있는 데, 이러한 보이기/숨기기에 대한 권한값을 설정한다. 더 자세히 ...
int | GetEditableAuth ()
필드를 수정할 수 있거나 수정할 수 없게할 수 있는데, 이러한 수정 가능/불가능에 대한 권한값을 반환한다. 더 자세히 ...
void | SetEditableAuth (int val)
필드를 수정할 수 있거나 수정할 수 없게할 수 있는데, 이러한 수정 가능/불가능에 대한 권한값을 설정한다. 더 자세히 ...
VARIANT_BOOL | IsNullable ()
필드값이 NULL이 될수 있는지 여부를 반환한다. 더 자세히 ...
void | SetNullable (VARIANT_BOOL val)
필드값이 NULL이 될수 있는지 여부를 설정한다. 더 자세히 ...
VARIANT_BOOL | GetIsSeqKey ()
시퀀스(자동으로 테이블의 행에 대한 유일한 번호를 생성) 키의 설정여부 더 자세히 ...
void | SetIsSeqKey (VARIANT_BOOL val)
int | GetValidValueSize ()
올바른 값 리스트의 크기 더 자세히 ...
IFeatureAttributeValidValue * | GetValidValue (int idx)
IFeatureAttributeDescriptor * Clone ()
복사된 FeatureAttributeDescriptor 객체를 반환한다. 더 자세히 ...

상세한 설명

Feature 객체의 필드(속성) 객체로 FeatureType 객체는 FeatureAttributeDescriptor 객체의 집합이다.

(Feature 객체에 저장된 일반 (속성) 정보 필드 한 개의 구조를 설명하는 것이 FeatureAttributeDescriptor 객체) (FeatureType 객체를 테이블 스키마와 대응시키면 테이블의 한 칼럼의 스키마에 대응된다) C API(linux, iOS, MacOS 등) : 중간이름 "FAD"를 덧붙여서 "OGR_FAD_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.FeatureAttributeDescriptor"

멤버 함수 문서화

IFeatureAttributeDescriptor* sgObject::IFeatureAttributeDescriptor::Clone ( )

복사된 FeatureAttributeDescriptor 객체를 반환한다.

반환값
FeatureAttributeDescriptor 객체의 포인터
int sgObject::IFeatureAttributeDescriptor::GetDataType ( )

필드의 데이터 타입을 반환한다.

int sgObject::IFeatureAttributeDescriptor::GetEditableAuth ( )

필드를 수정할 수 있거나 수정할 수 없게할 수 있는데, 이러한 수정 가능/불가능에 대한 권한값을 반환한다.

반환값
권한값
VARIANT_BOOL sgObject::IFeatureAttributeDescriptor::GetIsSeqKey ( )

시퀀스(자동으로 테이블의 행에 대한 유일한 번호를 생성) 키의 설정여부

int sgObject::IFeatureAttributeDescriptor::GetMaximumOccurrences ( )

해당 DataType으로 입력할 수 있는 값의 최대값을 반환한다.

반환값
해당 DataType으로 입력할 수 있는 값의 최대값
int sgObject::IFeatureAttributeDescriptor::GetMinimumOccurrences ( )

해당 DataType으로 입력할 수 있는 값의 최소값을 반환한다.

반환값
해당 DataType으로 입력할 수 있는 값의 최소값
BSTR sgObject::IFeatureAttributeDescriptor::GetName ( )

필드 이름(데이터베이스 테이블의 필드명과 동일)을 반환한다.

반환값
필드 이름(데이터베이스 테이블의 필드명과 동일)
int sgObject::IFeatureAttributeDescriptor::GetPrecision ( )

실수형 데이터의 경우 정밀도(Precision:출력되어야 하는 소수점 이하의 자리 수)을 반환한다.

반환값
정밀도(Precision:출력되어야 하는 소수점 이하의 자리 수)
IFeatureAttributeDescriptor* sgObject::IFeatureAttributeDescriptor::GetReferField ( )

특정 필드끼리 연결하기 위한 정보를 갖고 있는 FeatureAttributeDescriptor 객체의 포인터를 반환한다.

반환값
FeatureAttributeDescriptor의 포인터
BSTR sgObject::IFeatureAttributeDescriptor::GetReferFieldName ( )

특정 필드끼리 연결하기 위한 정보를 갖고 있는 FeatureAttributeDescriptor 객체의 이름을 반환한다.

반환값
FeatureAttributeDescriptor 객체의 이름
ILayer* sgObject::IFeatureAttributeDescriptor::GetReferLayer ( )

특정 레이어끼리 연결하기 위한 정보를 갖고 있는 레이어의 포인터를 반환한다.

반환값
레이어의 포인터
BSTR sgObject::IFeatureAttributeDescriptor::GetReferLayerName ( )

특정 레이어끼리 연결하기 위한 정보를 갖고 있는 레이어의 이름을 반환한다.

반환값
레이어의 이름
int sgObject::IFeatureAttributeDescriptor::GetSize ( )

필드의 최대 크기를 반환한다.

반환값
필드의 최대 크기
BSTR sgObject::IFeatureAttributeDescriptor::GetTitle ( )

필드 이름(데이터베이스 테이블의 필드명)에 사용자가 알아보기 쉽게 제목을 붙이는데 이 제목을 반환한다.

반환값
필드 이름(데이터베이스 테이블의 필드명)에 사용자가 알아보기 쉽게 붙인 제목
IFeatureAttributeValidValue* sgObject::IFeatureAttributeDescriptor::GetValidValue ( int idx )
매개변수
idx - 인덱스 번호에 해당하는 올바른 값 객체를 반환한다.
반환값
int sgObject::IFeatureAttributeDescriptor::GetValidValueSize ( )

올바른 값 리스트의 크기

반환값
int sgObject::IFeatureAttributeDescriptor::GetVisibleAuth ( )

필드를 보이거나 숨기거나 할 수 있는 데, 이러한 보이기/숨기기에 대한 권한값을 반환한다.

반환값
권한값
VARIANT_BOOL sgObject::IFeatureAttributeDescriptor::IsNullable ( )

필드값이 NULL이 될수 있는지 여부를 반환한다.

반환값
VARIANT_TRUE면 가능, VARIANT_FALSE면 불가능
void sgObject::IFeatureAttributeDescriptor::SetDataType ( int nVal )

필드의 데이터 타입을 설정한다.

매개변수
nVal -
void sgObject::IFeatureAttributeDescriptor::SetEditableAuth ( int val )

필드를 수정할 수 있거나 수정할 수 없게할 수 있는데, 이러한 수정 가능/불가능에 대한 권한값을 설정한다.

매개변수
val - 권한값
void sgObject::IFeatureAttributeDescriptor::SetIsSeqKey ( VARIANT_BOOL val )
void sgObject::IFeatureAttributeDescriptor::SetMaximumOccurrences ( int nVal )

해당 DataType으로 입력할 수 있는 값의 최대값을 설정한다.

매개변수
nVal - 해당 DataType으로 입력할 수 있는 값의 최대값
void sgObject::IFeatureAttributeDescriptor::SetMinimumOccurrences ( int nVal )

해당 DataType으로 입력할 수 있는 값의 최소값을 설정한다.

매개변수
nVal - 해당 DataType으로 입력할 수 있는 값의 최소값
void sgObject::IFeatureAttributeDescriptor::SetName ( BSTR bstrName )

필드 이름(데이터베이스 테이블의 필드명과 동일)을 설정한다.

반환값
bstrName - 필드 이름(데이터베이스 테이블의 필드명과 동일)
void sgObject::IFeatureAttributeDescriptor::SetNullable ( VARIANT_BOOL val )

필드값이 NULL이 될수 있는지 여부를 설정한다.

매개변수
val - VARIANT_TRUE면 가능, VARIANT_FALSE면 불가능
void sgObject::IFeatureAttributeDescriptor::SetPrecision ( int nPrecision )

실수형 데이터의 경우 정밀도(Precision:출력되어야 하는 소수점 이하의 자리 수)을 설정한다.

매개변수
nPrecision - 정밀도(Precision:출력되어야 하는 소수점 이하의 자리 수)
void sgObject::IFeatureAttributeDescriptor::SetReferField ( IFeatureAttributeDescriptor * val )

특정 필드끼리 연결하기 위한 정보를 갖고 있는 FeatureAttributeDescriptor 객체의 포인터를 설정한다.

매개변수
val - FeatureAttributeDescriptor 객체의 포인터
void sgObject::IFeatureAttributeDescriptor::SetReferFieldName ( BSTR val )

특정 필드끼리 연결하기 위한 정보를 갖고 있는 FeatureAttributeDescriptor 객체의 이름을 설정한다.

매개변수
val - FeatureAttributeDescriptor 객체의 이름
void sgObject::IFeatureAttributeDescriptor::SetReferLayer ( ILayer * dspLayer )

특정 레이어끼리 연결하기 위한 정보를 갖고 있는 레이어의 포인터를 설정한다.

매개변수
dspLayer - 레이어의 포인터
void sgObject::IFeatureAttributeDescriptor::SetReferLayerName ( BSTR val )

특정 레이어끼리 연결하기 위한 정보를 갖고 있는 레이어의 이름을 설정한다.

매개변수
val - 레이어의 이름
void sgObject::IFeatureAttributeDescriptor::SetSize ( int nSize )

필드의 최대 크기를 설정한다.

매개변수
nSize - 필드의 최대 크기
void sgObject::IFeatureAttributeDescriptor::SetTitle ( BSTR bstrTitle )

필드(Attribute) 이름(데이터베이스 테이블의 필드명)에 사용자가 알아보기 쉽게 제목을 붙이는데 이 제목을 설정한다.

매개변수
bstrTitle - 필드(Attribute) 이름(데이터베이스 테이블의 필드명)에 사용자가 알아보기 쉽게 붙인 제목
void sgObject::IFeatureAttributeDescriptor::SetVisibleAuth ( int val )

필드를 보이거나 숨기거나 할 수 있는 데, 이러한 보이기/숨기기에 대한 권한값을 설정한다.

매개변수
val - 권한값
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IFeatureAttributeDescriptor
sgObject::IFeatureAttributeDescriptor 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IFeatureAttributeDescriptor (모든 상속된 멤버들도 포함합니다.)

Clone() | sgObject::IFeatureAttributeDescriptor
GetDataType() | sgObject::IFeatureAttributeDescriptor
GetEditableAuth() | sgObject::IFeatureAttributeDescriptor
GetIsSeqKey() | sgObject::IFeatureAttributeDescriptor
GetMaximumOccurrences() | sgObject::IFeatureAttributeDescriptor
GetMinimumOccurrences() | sgObject::IFeatureAttributeDescriptor
GetName() | sgObject::IFeatureAttributeDescriptor
GetPrecision() | sgObject::IFeatureAttributeDescriptor
GetReferField() | sgObject::IFeatureAttributeDescriptor
GetReferFieldName() | sgObject::IFeatureAttributeDescriptor
GetReferLayer() | sgObject::IFeatureAttributeDescriptor
GetReferLayerName() | sgObject::IFeatureAttributeDescriptor
GetSize() | sgObject::IFeatureAttributeDescriptor
GetTitle() | sgObject::IFeatureAttributeDescriptor
GetValidValue(int idx) | sgObject::IFeatureAttributeDescriptor
GetValidValueSize() | sgObject::IFeatureAttributeDescriptor
GetVisibleAuth() | sgObject::IFeatureAttributeDescriptor
IsNullable() | sgObject::IFeatureAttributeDescriptor
SetDataType(int nVal) | sgObject::IFeatureAttributeDescriptor
SetEditableAuth(int val) | sgObject::IFeatureAttributeDescriptor
SetIsSeqKey(VARIANT_BOOL val) | sgObject::IFeatureAttributeDescriptor
SetMaximumOccurrences(int nVal) | sgObject::IFeatureAttributeDescriptor
SetMinimumOccurrences(int nVal) | sgObject::IFeatureAttributeDescriptor
SetName(BSTR bstrName) | sgObject::IFeatureAttributeDescriptor
SetNullable(VARIANT_BOOL val) | sgObject::IFeatureAttributeDescriptor
SetPrecision(int nPrecision) | sgObject::IFeatureAttributeDescriptor
SetReferField(IFeatureAttributeDescriptor *val) | sgObject::IFeatureAttributeDescriptor
SetReferFieldName(BSTR val) | sgObject::IFeatureAttributeDescriptor
SetReferLayer(ILayer *dspLayer) | sgObject::IFeatureAttributeDescriptor
SetReferLayerName(BSTR val) | sgObject::IFeatureAttributeDescriptor
SetSize(int nSize) | sgObject::IFeatureAttributeDescriptor
SetTitle(BSTR bstrTitle) | sgObject::IFeatureAttributeDescriptor
SetVisibleAuth(int val) | sgObject::IFeatureAttributeDescriptor
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IFeatureAttributeTreeWidget 인터페이스 참조

  • IFeatureAttributeTreeWidget
Public 멤버 함수 | 모든 멤버 목록
sgObject::IFeatureAttributeTreeWidget 인터페이스 참조

속성관리창을 제어하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::IFeatureAttributeTreeWidget에 대한 상속 다이어그램 :
sgObject::IFeatureAttributeTreeWidget에 대한 협력 다이어그램:

Public 멤버 함수

int | IndexOfSelectedItem ()
속성관리창에서 선택 중인 속성 필드의 인덱스 번호를 반환한다. 더 자세히 ...
VARIANT_BOOL | GetDisplayToolBar ()
속성관리창에서 상단의 툴바의 보기 상태를 반환한다. 더 자세히 ...
void | SetDisplayToolBar ([in] VARIANT_BOOL bVal)
속성관리창에서 상단의 툴바의 보기 상태를 제어한다. 더 자세히 ...
void | SetDisplayContextMenu ([in] VARIANT_BOOL bVal)
속성관리창에서 내부의 팝업창의 보기 상태를 제어한다. 더 자세히 ...
- sgObject::IWidget(으)로부터 상속된 Public 멤버 함수
void | Initialize ([in] ULONG_PTR h)
위젯 초기화 더 자세히 ...
void | ReSize ([in] int x, [in] int y, [in] int cx, [in] int cy)
위젯 객체의 크기를 재설정 한다. 더 자세히 ...
void | AddWidget ([in] IWidget *dspWidget)
현재 위젯에 하부로 위젯을 추가한다. 더 자세히 ...
void | AddWidgetByLayout ([in] IWidget *dspWidget, [in] int row, [in] int col)
현재 위젯에 종, 횡 위치에 위젯을 추가한다. 더 자세히 ...
void | SetQtUiObjectVisible ([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue)
위젯의 해당 오브젝트 객체의 보이기 여부를 설정한다. 더 자세히 ...
long | GetBackColor ()
위젯이 사용하는 배경 색상 정보 더 자세히 ...
void | SetBackColor ([in] long color)
void | SetCanvas (ICanvas *poCanvas)
위젯을 특정(2D, 3D, Earth 등) 지도창으로 설정한다. 더 자세히 ...
IFeatureCanvas * GetFeatureCanvas ()
위젯이 사용하는 FeatureCanvas 정보 더 자세히 ...
void | SetFeatureCanvas (IFeatureCanvas *poFtCvs)
void | SetFeatureLayer (IFeatureLayer *poFtLayer)
위젯이 사용하는 FeatureLayer 정보 더 자세히 ...
void | SetLayer (ILayer *poLayer)
위젯이 사용하는 레이어 정보 더 자세히 ...
BSTR | GetFlag ()
위젯이 사용하는 문자열 파라메터 정보 더 자세히 ...
void | SetFlag (BSTR bstrFlag)
void | SetWidth (int nWidth)
위젯의 가로크기를 설정한다. 더 자세히 ...
int | SetHeight (int nHeight)
위젯의 세로크기를 설정한다. 더 자세히 ...
void | Destroy ()

상세한 설명

속성관리창을 제어하는 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "AWG"를 덧붙여서 "OGR_AWG_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.FeatureAttributeTreeWidget"

멤버 함수 문서화

VARIANT_BOOL sgObject::IFeatureAttributeTreeWidget::GetDisplayToolBar ( )

속성관리창에서 상단의 툴바의 보기 상태를 반환한다.

int sgObject::IFeatureAttributeTreeWidget::IndexOfSelectedItem ( )

속성관리창에서 선택 중인 속성 필드의 인덱스 번호를 반환한다.

void sgObject::IFeatureAttributeTreeWidget::SetDisplayContextMenu ( [in] VARIANT_BOOL bVal )

속성관리창에서 내부의 팝업창의 보기 상태를 제어한다.

void sgObject::IFeatureAttributeTreeWidget::SetDisplayToolBar ( [in] VARIANT_BOOL bVal )

속성관리창에서 상단의 툴바의 보기 상태를 제어한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IFeatureAttributeTreeWidget
sgObject::IFeatureAttributeTreeWidget 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IFeatureAttributeTreeWidget (모든 상속된 멤버들도 포함합니다.)

AddWidget([in] IWidget *dspWidget) | sgObject::IWidget
AddWidgetByLayout([in] IWidget *dspWidget, [in] int row, [in] int col) | sgObject::IWidget
Destroy() | sgObject::IWidget
GetBackColor() | sgObject::IWidget
GetDisplayToolBar() | sgObject::IFeatureAttributeTreeWidget
GetFeatureCanvas() | sgObject::IWidget
GetFlag() | sgObject::IWidget
IndexOfSelectedItem() | sgObject::IFeatureAttributeTreeWidget
Initialize([in] ULONG_PTR h) | sgObject::IWidget
ReSize([in] int x, [in] int y, [in] int cx, [in] int cy) | sgObject::IWidget
SetBackColor([in] long color) | sgObject::IWidget
SetCanvas(ICanvas *poCanvas) | sgObject::IWidget
SetDisplayContextMenu([in] VARIANT_BOOL bVal) | sgObject::IFeatureAttributeTreeWidget
SetDisplayToolBar([in] VARIANT_BOOL bVal) | sgObject::IFeatureAttributeTreeWidget
SetFeatureCanvas(IFeatureCanvas *poFtCvs) | sgObject::IWidget
SetFeatureLayer(IFeatureLayer *poFtLayer) | sgObject::IWidget
SetFlag(BSTR bstrFlag) | sgObject::IWidget
SetHeight(int nHeight) | sgObject::IWidget
SetLayer(ILayer *poLayer) | sgObject::IWidget
SetQtUiObjectVisible([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue) | sgObject::IWidget
SetWidth(int nWidth) | sgObject::IWidget
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IFeatureAttributeValidValue 인터페이스 참조

  • IFeatureAttributeValidValue
Public 멤버 함수 | 모든 멤버 목록
sgObject::IFeatureAttributeValidValue 인터페이스 참조

C API(linux, iOS, MacOS 등) : 중간이름 "FAV"를 덧붙여서 "OGR_FAV_"+메소드명으로 사용한다. 더 자세히 ...

sgObject::IFeatureAttributeValidValue에 대한 상속 다이어그램 :
sgObject::IFeatureAttributeValidValue에 대한 협력 다이어그램:

Public 멤버 함수

VARIANT_BOOL | IsValid ([in] IFeature *feature)
값의 유효 여부를 확인한다. 더 자세히 ...
BSTR | GetValueKeyValue ()
키값을 반환한다. 더 자세히 ...
BSTR | GetValueExpression ()
값의 표현식을 반환한다. 더 자세히 ...
BSTR | GetValueAlias ()
값의 별명을 반환한다. 더 자세히 ...

상세한 설명

C API(linux, iOS, MacOS 등) : 중간이름 "FAV"를 덧붙여서 "OGR_FAV_"+메소드명으로 사용한다.

Feature의 속성 내 값의 키, 표현 방법 등과 관련된 인터페이스를 제공한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.FeatureAttributeValidValue"

멤버 함수 문서화

BSTR sgObject::IFeatureAttributeValidValue::GetValueAlias ( )

값의 별명을 반환한다.

반환값
BSTR sgObject::IFeatureAttributeValidValue::GetValueExpression ( )

값의 표현식을 반환한다.

반환값
BSTR sgObject::IFeatureAttributeValidValue::GetValueKeyValue ( )

키값을 반환한다.

반환값
키값
VARIANT_BOOL sgObject::IFeatureAttributeValidValue::IsValid ( [in] IFeature * feature )

값의 유효 여부를 확인한다.

반환값
키값
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IFeatureAttributeValidValue
sgObject::IFeatureAttributeValidValue 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IFeatureAttributeValidValue (모든 상속된 멤버들도 포함합니다.)

GetValueAlias() | sgObject::IFeatureAttributeValidValue
GetValueExpression() | sgObject::IFeatureAttributeValidValue
GetValueKeyValue() | sgObject::IFeatureAttributeValidValue
IsValid([in] IFeature *feature) | sgObject::IFeatureAttributeValidValue
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IFeatureCanvas 인터페이스 참조

  • IFeatureCanvas
Public 멤버 함수 | 모든 멤버 목록
sgObject::IFeatureCanvas 인터페이스 참조

화면에 표현할 수 있는 여러 개의 FeatureLayer가 저장된 객체로 Map2D 객체를 통해 FeatureCanvas에 있는 Feature들을 실제 모니터 화면에 표현한다. (Document/View 구조에서 FeatureCanvas는 Document, Canvas2D는 View에 해당한다) 더 자세히 ...

sgObject::IFeatureCanvas에 대한 상속 다이어그램 :
sgObject::IFeatureCanvas에 대한 협력 다이어그램:

Public 멤버 함수

HRESULT | GetSize ([out, retval] int *pVal)
FeatureCanvas에 속한 FeatureLayer의 개수를 반환한다. 더 자세히 ...
HRESULT | GetActive ([out, retval] IFeatureLayer **pVal)
활성화된 FeatureLayer를 반환한다. 더 자세히 ...
HRESULT | SetActive ([in] VARIANT newVal)
활성화될 FeatureLayer를 설정한다. 더 자세히 ...
HRESULT | GetSelection ([out, retval] IFeatureCollection **pVal)
화면에서 사용자에 의해 선택된 Feature들의 집합(FeatureCollection)을 반환한다. 더 자세히 ...
HRESULT | GetFlashset ([out, retval] IFeatureCollection **pVal)
화면에서 깜박이도록 설정한 Feature 객체들의 집합(FeatureCollection)을 반환한다. 더 자세히 ...
HRESULT | GetTransaction ([out, retval] IDefaultTransaction **pVal)
디스크 트랜젝션관련 객체을 반환한다. 더 자세히 ...
HRESULT | GetFeatureAtPoint ([in] double x, [in] double y, [in] double buffer, [out, retval] IFeature **pVal)
해당 점에 위치한 Feature 객체를 가져온다. 더 자세히 ...
HRESULT | GetFeaturesAtPoint ([in] double x, [in] double y, [in] double buffer, [out, retval] IFeatureCollection **pVal)
해당 점에 위치한 Feature 객체들의 모임을 가져온다. 더 자세히 ...
HRESULT | Contains ([in] IFeatureLayer *other, [out, retval] VARIANT_BOOL *pVal)
해당 FeatureLayer가 속하는지 여부를 반환한다. 더 자세히 ...
HRESULT | AddFeatureLayer ([in] IFeatureLayer *layer)
FeatureCanvas에 FeatureLayer를 추가한다. 더 자세히 ...
HRESULT | DeleteFeatureLayer ([in] IFeatureLayer *layer)
FeatureCanvas에서 FeatureLayer를 삭제한다. 더 자세히 ...
HRESULT | GetFeatureLayer ([in] int nIdx, [out, retval] IFeatureLayer **pVal)
해당 인덱스의 FeatureLayer를 가져온다. 더 자세히 ...
HRESULT | DeleteFeatureCollection ([in] IFeatureCollection *pFtCol, [out, retval] long *size)
해당 FeatureCollection의 모든 Feature를 삭제한다. 더 자세히 ...
HRESULT | GetIndexOfFeatureLayer ([in] IFeatureLayer *pFtLayer, [out, retval] int *nIndex)
해당 FeatureLayer의 인덱스를 가져온다. 더 자세히 ...
HRESULT | Undo ()
바로 전 1회의 트랜젝션 결과를 FeatureCanvas 내의 Feature의 Geometry 정보나 혹은 일반 속성 정보 변경 혹은 Feature의 추가나 삭제를 Rollback한다. 더 자세히 ...
HRESULT | Commit ()
바로 전 1회의 트랜젝션 결과를 FeatureCanvas 내의 Feature의 Geeometry 정보나 혹은 일반 속성 정보 변경을 레이어를 통해 데이터 소스에 저장한다. 더 자세히 ...
HRESULT | Copy ()
선택된 Feature들을 클립보드에 복사한다. 더 자세히 ...
HRESULT | Paste ()
Object 내부 클립보드에 복사된 Feature들을 활성화된 FeatureLayer (Active)에 붙여넣기 한다. 더 자세히 ...
HRESULT | Cut ()
선택된 Feature들을 클립보드를 이용해 잘라내기 처리한다. 더 자세히 ...
HRESULT | GetFeatureLayerByName ([in] BSTR strLayerName, [out, retval] IFeatureLayer **pVal)
해당 레이어명과 동일한 첫번째 FeatureLayer를 가져온다. 더 자세히 ...
HRESULT | GetFeatureLayerByID ([in] BSTR strLayerID, [out, retval] IFeatureLayer **pVal)
해당 레이어ID과 동일한 첫번째 FeatureLayer를 가져온다. 더 자세히 ...
HRESULT | GetFeatureLayerByLayer ([in] ILayer *dspLayer, [out, retval] IFeatureLayer **pVal)
해당 레이어와 동일한 첫번째 FeatureLayer를 가져온다. 더 자세히 ...
HRESULT | MoveTo ([in] IFeatureLayer *poFtLayer, [in] int nToIdx, [out, retval] VARIANT_BOOL *pVal)
FeatureLayer 리스트에서 FeatureLayer의 위치를 해당 인덱스로 옮긴다. (화면 표시 순서 제어) 더 자세히 ...
HRESULT | Invalidate ()
화면을 갱신한다. 더 자세히 ...
HRESULT | ReCalculateExtent ([in, defaultvalue(0)] VARIANT_BOOL bForceAll)
전체 범위를 다시 계산한다. 더 자세히 ...
HRESULT | AddLayerSource ([in] BSTR pszConnStr, [out, retval] ILayerSource **pVal)
연결 문자열을 해석하여 생성된 LayerSource를 FeatureCanvas에 추가한다. 더 자세히 ...
HRESULT | DeleteFeatureLayerAll ()
FeatureCanvas에 추가된 모든 FeatureLayer를 해제하여 초기화 한다. 더 자세히 ...
HRESULT | ShowOpenVectorLayerWidget ([in] BSTR strTitle, [out, retval] int *nSuccessNum)
벡터파일을 열어 LayerSource를 생성하여 FeatureCanvas에 추가한다. 더 자세히 ...
HRESULT | ShowOpenRasterLayerWidget ([in] BSTR strTitle, [out, retval] int *nSuccessNum)
래스터파일을 열어 LayerSource를 생성하여 FeatureCanvas에 추가한다. 더 자세히 ...
HRESULT | ShowOpenWebLayerWidget ()
웹 지도를 여는 창을 연다. 더 자세히 ...
HRESULT | ShowNewVectorLayerWidget ()
새로운 벡터레이어를 생성하는 창을 연다. 더 자세히 ...
HRESULT | GetConnectStringFromFileName ([in] BSTR pszFileName, [out, retval] BSTR *pszConnStr)
입력된 파일명으로 레이어 생성에 적합한 연결 문자열을 생성한다. 더 자세히 ...
HRESULT | GetLayerSourceFromFileName ([in] BSTR pszFileName, [out, retval] ILayerSource **pLayerSrc)
입력된 파일명으로 레이어소스를 생성한다. 더 자세히 ...
HRESULT | CreateTemporaryLayer ([in] IFeatureType *poFtType, [in] VARIANT_BOOL bAutoLoad, [out, retval] IFeatureLayer **pFtLayer)
임시레이어를 생성한다. 더 자세히 ...
HRESULT | RemoveSymbol ([in] ILayerSource *poLyrSrc, [in] ISymbolizer *poStyle)
레이어소스와 연결된 Symbolizer을 삭제한다. 더 자세히 ...
HRESULT | SetTerrainOptions ([in] BSTR strOptions)
전체 범위를 다시 계산한다. 더 자세히 ...
HRESULT | ReadWorkspace ([in] BSTR strXMLFileName)
작업공간파일(*.gws)을 열어 저장된 정보로 복원한다. 더 자세히 ...
HRESULT | WriteWorkspace ([in] BSTR strXMLFileName)
작업공간파일(*.gws)로 현재 상태를 저장한다. 더 자세히 ...
HRESULT | GetWorkspace ([out, retval] BSTR *strXMLFileName)
사용중인 작업공간파일(*.gws)명을 반환한다. 더 자세히 ...
HRESULT | SetSelectedFeature ([in] IFeature *pdspSelectFeature, [in] VARIANT_BOOL bIsAdd)
주어진 객체를 선택하고 이벤트를 발생시킨다. 더 자세히 ...
HRESULT | GetDisplaySpatialReference ([out, retval] ISpatialReference **pVal)
지도의 표현 공간 좌표 체계 더 자세히 ...
HRESULT | SetDisplaySpatialReference ([in] ISpatialReference *pVal)
HRESULT | ForceStopRender ()

상세한 설명

화면에 표현할 수 있는 여러 개의 FeatureLayer가 저장된 객체로 Map2D 객체를 통해 FeatureCanvas에 있는 Feature들을 실제 모니터 화면에 표현한다. (Document/View 구조에서 FeatureCanvas는 Document, Canvas2D는 View에 해당한다)

Map2D는 사용자에게 보여줄 화면을 그려주는 것과 마우스 등 사용자 입력을 받는 역할을 담당한다. 또한 사용자와의 인터페이스를 Feature 단위로 프로그래밍할 수 있도록 지원하는 역할도 한다. (사용자가 Map2D에서 기하를 선택한 경우 FeatureCanvas는 선택된 Feature들의 집합 정보를 가져올 수 있다) 하나의 FeatureCanvas를 여러 개의 Map2D에 연결하여 서로 다른 창에서 하나의 데이터를 표현할 수도 있다. FeatureCanvas 객체에 속성 및 메소드를 제공한다. C API(linux, iOS, MacOS 등) : 중간이름 "FV"를 덧붙여서 "OGR_FV_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.FeatureCanvas"

멤버 함수 문서화

HRESULT sgObject::IFeatureCanvas::AddFeatureLayer ( [in] IFeatureLayer * layer )

FeatureCanvas에 FeatureLayer를 추가한다.

매개변수
layer - 추가할 FeatureLayer 객체를 가리키는 포인터
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::AddLayerSource | ( | [in] BSTR | pszConnStr,
 |  | [out, retval] ILayerSource ** | pVal
 | ) |  |

연결 문자열을 해석하여 생성된 LayerSource를 FeatureCanvas에 추가한다.

매개변수
pszConnStr | - 연결 문자열
pVal | - 성공하면 생성된 LayerSource의 이중포인터, 실패하면 0이 저장된다.
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::Commit ( )

바로 전 1회의 트랜젝션 결과를 FeatureCanvas 내의 Feature의 Geeometry 정보나 혹은 일반 속성 정보 변경을 레이어를 통해 데이터 소스에 저장한다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::Contains | ( | [in] IFeatureLayer * | other,
 |  | [out, retval] VARIANT_BOOL * | pVal
 | ) |  |

해당 FeatureLayer가 속하는지 여부를 반환한다.

매개변수
other | - FeatureLayer 객체를 가리키는 포인터
pVal | - 해당 FeatureLayer가 속하는지 여부가 저장된다.
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::Copy ( )

선택된 Feature들을 클립보드에 복사한다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::CreateTemporaryLayer | ( | [in] IFeatureType * | poFtType,
 |  | [in] VARIANT_BOOL | bAutoLoad,
 |  | [out, retval] IFeatureLayer ** | pFtLayer
 | ) |  |

임시레이어를 생성한다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::Cut ( )

선택된 Feature들을 클립보드를 이용해 잘라내기 처리한다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::DeleteFeatureCollection | ( | [in] IFeatureCollection * | pFtCol,
 |  | [out, retval] long * | size
 | ) |  |

해당 FeatureCollection의 모든 Feature를 삭제한다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::DeleteFeatureLayer ( [in] IFeatureLayer * layer )

FeatureCanvas에서 FeatureLayer를 삭제한다.

매개변수
layer - 삭제할 FeatureLayer 객체를 가리키는 포인터
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::DeleteFeatureLayerAll ( )

FeatureCanvas에 추가된 모든 FeatureLayer를 해제하여 초기화 한다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::ForceStopRender ( )
HRESULT sgObject::IFeatureCanvas::GetActive ( [out, retval] IFeatureLayer ** pVal )

활성화된 FeatureLayer를 반환한다.

매개변수
pVal - 활성화된 FeatureLayer가 저장된다.
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::GetConnectStringFromFileName | ( | [in] BSTR | pszFileName,
 |  | [out, retval] BSTR * | pszConnStr
 | ) |  |

입력된 파일명으로 레이어 생성에 적합한 연결 문자열을 생성한다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::GetDisplaySpatialReference ( [out, retval] ISpatialReference ** pVal )

지도의 표현 공간 좌표 체계

HRESULT sgObject::IFeatureCanvas::GetFeatureAtPoint | ( | [in] double | x,
 |  | [in] double | y,
 |  | [in] double | buffer,
 |  | [out, retval] IFeature ** | pVal
 | ) |  |

해당 점에 위치한 Feature 객체를 가져온다.

매개변수
x | - 점의 x 좌표
y | - 좀의 y 좌표
buffer | - 가져올 범위
pVal | - 해당 점에 위치한 Feature 객체가 저장된다.
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::GetFeatureLayer | ( | [in] int | nIdx,
 |  | [out, retval] IFeatureLayer ** | pVal
 | ) |  |

해당 인덱스의 FeatureLayer를 가져온다.

매개변수
nIdx | - 인덱스 번호
pVal | - 해당 인덱스의 FeatureLayer가 저장된다.
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::GetFeatureLayerByID | ( | [in] BSTR | strLayerID,
 |  | [out, retval] IFeatureLayer ** | pVal
 | ) |  |

해당 레이어ID과 동일한 첫번째 FeatureLayer를 가져온다.

매개변수
strLayerID | - 레이어ID
pVal | - 해당 레이어ID의 FeatureLayer가 저장된다.
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::GetFeatureLayerByLayer | ( | [in] ILayer * | dspLayer,
 |  | [out, retval] IFeatureLayer ** | pVal
 | ) |  |

해당 레이어와 동일한 첫번째 FeatureLayer를 가져온다.

매개변수
dspLayer | - 레이어 객체
pVal | - 해당 레이어객체의 FeatureLayer가 저장된다.
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::GetFeatureLayerByName | ( | [in] BSTR | strLayerName,
 |  | [out, retval] IFeatureLayer ** | pVal
 | ) |  |

해당 레이어명과 동일한 첫번째 FeatureLayer를 가져온다.

매개변수
strLayerName | - 레이어명
pVal | - 해당 레이어명의 FeatureLayer가 저장된다.
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::GetFeaturesAtPoint | ( | [in] double | x,
 |  | [in] double | y,
 |  | [in] double | buffer,
 |  | [out, retval] IFeatureCollection ** | pVal
 | ) |  |

해당 점에 위치한 Feature 객체들의 모임을 가져온다.

매개변수
x | - 점의 x 좌표
y | - 점의 y 좌표
buffer | - 가져올 범위
pVal | - 해당 점에 위치한 Feature 객체들의 모임이 저장된다.
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::GetFlashset ( [out, retval] IFeatureCollection ** pVal )

화면에서 깜박이도록 설정한 Feature 객체들의 집합(FeatureCollection)을 반환한다.

매개변수
pVal - 화면에서 깜박이도록 설정한 Feature 객체들의 집합(FeatureCollection)
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::GetIndexOfFeatureLayer | ( | [in] IFeatureLayer * | pFtLayer,
 |  | [out, retval] int * | nIndex
 | ) |  |

해당 FeatureLayer의 인덱스를 가져온다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::GetLayerSourceFromFileName | ( | [in] BSTR | pszFileName,
 |  | [out, retval] ILayerSource ** | pLayerSrc
 | ) |  |

입력된 파일명으로 레이어소스를 생성한다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::GetSelection ( [out, retval] IFeatureCollection ** pVal )

화면에서 사용자에 의해 선택된 Feature들의 집합(FeatureCollection)을 반환한다.

매개변수
pVal - 화면에서 사용자에 의해 선택된 Feature들의 집합(FeatureCollection)이 저장된다.
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::GetSize ( [out, retval] int * pVal )

FeatureCanvas에 속한 FeatureLayer의 개수를 반환한다.

매개변수
pVal - FeatureCanvas에 속한 FeatureLayer의 개수
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::GetTransaction ( [out, retval] IDefaultTransaction ** pVal )

디스크 트랜젝션관련 객체을 반환한다.

매개변수
pVal - 디스크 트랜젝션관련 객체가 저장된다.
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::GetWorkspace ( [out, retval] BSTR * strXMLFileName )

사용중인 작업공간파일(*.gws)명을 반환한다.

매개변수
strXMLFileName - 작업공간파일 이름 S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::Invalidate ( )

화면을 갱신한다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::MoveTo | ( | [in] IFeatureLayer * | poFtLayer,
 |  | [in] int | nToIdx,
 |  | [out, retval] VARIANT_BOOL * | pVal
 | ) |  |

FeatureLayer 리스트에서 FeatureLayer의 위치를 해당 인덱스로 옮긴다. (화면 표시 순서 제어)

매개변수
poFtLayer | - 위치를 옮길 FeatureLayer 객체
nToIdx | - 새 위치의 인덱스 번호
pVal | - 성공 여부 성공이면 VARIANT_TRUE, 실패면 VARIANT_FALSE
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::Paste ( )

Object 내부 클립보드에 복사된 Feature들을 활성화된 FeatureLayer (Active)에 붙여넣기 한다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::ReadWorkspace ( [in] BSTR strXMLFileName )

작업공간파일(*.gws)을 열어 저장된 정보로 복원한다.

매개변수
strXMLFileName - 작업공간파일 이름 S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::ReCalculateExtent ( [in, defaultvalue(0)] VARIANT_BOOL bForceAll )

전체 범위를 다시 계산한다.

매개변수
bForceAll - VARIANT_TRUE이면 모든 객체 확인, VARIANT_FALSE이면 FeatureLayer에서 관리하는 Feature들의 집합만 확인
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::RemoveSymbol | ( | [in] ILayerSource * | poLyrSrc,
 |  | [in] ISymbolizer * | poStyle
 | ) |  |

레이어소스와 연결된 Symbolizer을 삭제한다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::SetActive ( [in] VARIANT newVal )

활성화될 FeatureLayer를 설정한다.

매개변수
newVal - 활성화될 FeatureLayer을 입력한다.
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::SetDisplaySpatialReference ( [in] ISpatialReference * pVal )
HRESULT sgObject::IFeatureCanvas::SetSelectedFeature | ( | [in] IFeature * | pdspSelectFeature,
 |  | [in] VARIANT_BOOL | bIsAdd
 | ) |  |

주어진 객체를 선택하고 이벤트를 발생시킨다.

매개변수
pdspSelectFeature | - 선택 예정 객체
bIsAdd | - 기존 선택된 객체에 추가 여부 (추가하지 않는 경우 기존 선택 객체는 선택 취소) S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::SetTerrainOptions ( [in] BSTR strOptions )

전체 범위를 다시 계산한다.

매개변수
strOptions - 3D의 지형정보의 설정값을 변경 sample_ratio - 고도 그리드의 샘플링 비율(기본값 1.0) vertical_scale - 고도값의 과장치(기본값 1.0) S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::ShowNewVectorLayerWidget ( )

새로운 벡터레이어를 생성하는 창을 연다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::ShowOpenRasterLayerWidget | ( | [in] BSTR | strTitle,
 |  | [out, retval] int * | nSuccessNum
 | ) |  |

래스터파일을 열어 LayerSource를 생성하여 FeatureCanvas에 추가한다.

매개변수
strTitle | - GUI 타이틀명
nSuccessNum | - 성공한 파일 개수
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::ShowOpenVectorLayerWidget | ( | [in] BSTR | strTitle,
 |  | [out, retval] int * | nSuccessNum
 | ) |  |

벡터파일을 열어 LayerSource를 생성하여 FeatureCanvas에 추가한다.

매개변수
strTitle | - GUI 타이틀명
nSuccessNum | - 성공한 파일 개수
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::ShowOpenWebLayerWidget ( )

웹 지도를 여는 창을 연다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::Undo ( )

바로 전 1회의 트랜젝션 결과를 FeatureCanvas 내의 Feature의 Geometry 정보나 혹은 일반 속성 정보 변경 혹은 Feature의 추가나 삭제를 Rollback한다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureCanvas::WriteWorkspace ( [in] BSTR strXMLFileName )

작업공간파일(*.gws)로 현재 상태를 저장한다.

매개변수
strXMLFileName - 작업공간파일 이름 S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IFeatureCanvas
sgObject::IFeatureCanvas 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IFeatureCanvas (모든 상속된 멤버들도 포함합니다.)

AddFeatureLayer([in] IFeatureLayer *layer) | sgObject::IFeatureCanvas
AddLayerSource([in] BSTR pszConnStr, [out, retval] ILayerSource **pVal) | sgObject::IFeatureCanvas
Commit() | sgObject::IFeatureCanvas
Contains([in] IFeatureLayer *other, [out, retval] VARIANT_BOOL *pVal) | sgObject::IFeatureCanvas
Copy() | sgObject::IFeatureCanvas
CreateTemporaryLayer([in] IFeatureType *poFtType, [in] VARIANT_BOOL bAutoLoad, [out, retval] IFeatureLayer **pFtLayer) | sgObject::IFeatureCanvas
Cut() | sgObject::IFeatureCanvas
DeleteFeatureCollection([in] IFeatureCollection *pFtCol, [out, retval] long *size) | sgObject::IFeatureCanvas
DeleteFeatureLayer([in] IFeatureLayer *layer) | sgObject::IFeatureCanvas
DeleteFeatureLayerAll() | sgObject::IFeatureCanvas
ForceStopRender() | sgObject::IFeatureCanvas
GetActive([out, retval] IFeatureLayer **pVal) | sgObject::IFeatureCanvas
GetConnectStringFromFileName([in] BSTR pszFileName, [out, retval] BSTR *pszConnStr) | sgObject::IFeatureCanvas
GetDisplaySpatialReference([out, retval] ISpatialReference **pVal) | sgObject::IFeatureCanvas
GetFeatureAtPoint([in] double x, [in] double y, [in] double buffer, [out, retval] IFeature **pVal) | sgObject::IFeatureCanvas
GetFeatureLayer([in] int nIdx, [out, retval] IFeatureLayer **pVal) | sgObject::IFeatureCanvas
GetFeatureLayerByID([in] BSTR strLayerID, [out, retval] IFeatureLayer **pVal) | sgObject::IFeatureCanvas
GetFeatureLayerByLayer([in] ILayer *dspLayer, [out, retval] IFeatureLayer **pVal) | sgObject::IFeatureCanvas
GetFeatureLayerByName([in] BSTR strLayerName, [out, retval] IFeatureLayer **pVal) | sgObject::IFeatureCanvas
GetFeaturesAtPoint([in] double x, [in] double y, [in] double buffer, [out, retval] IFeatureCollection **pVal) | sgObject::IFeatureCanvas
GetFlashset([out, retval] IFeatureCollection **pVal) | sgObject::IFeatureCanvas
GetIndexOfFeatureLayer([in] IFeatureLayer *pFtLayer, [out, retval] int *nIndex) | sgObject::IFeatureCanvas
GetLayerSourceFromFileName([in] BSTR pszFileName, [out, retval] ILayerSource **pLayerSrc) | sgObject::IFeatureCanvas
GetSelection([out, retval] IFeatureCollection **pVal) | sgObject::IFeatureCanvas
GetSize([out, retval] int *pVal) | sgObject::IFeatureCanvas
GetTransaction([out, retval] IDefaultTransaction **pVal) | sgObject::IFeatureCanvas
GetWorkspace([out, retval] BSTR *strXMLFileName) | sgObject::IFeatureCanvas
Invalidate() | sgObject::IFeatureCanvas
MoveTo([in] IFeatureLayer *poFtLayer, [in] int nToIdx, [out, retval] VARIANT_BOOL *pVal) | sgObject::IFeatureCanvas
Paste() | sgObject::IFeatureCanvas
ReadWorkspace([in] BSTR strXMLFileName) | sgObject::IFeatureCanvas
ReCalculateExtent([in, defaultvalue(0)] VARIANT_BOOL bForceAll) | sgObject::IFeatureCanvas
RemoveSymbol([in] ILayerSource *poLyrSrc, [in] ISymbolizer *poStyle) | sgObject::IFeatureCanvas
SetActive([in] VARIANT newVal) | sgObject::IFeatureCanvas
SetDisplaySpatialReference([in] ISpatialReference *pVal) | sgObject::IFeatureCanvas
SetSelectedFeature([in] IFeature *pdspSelectFeature, [in] VARIANT_BOOL bIsAdd) | sgObject::IFeatureCanvas
SetTerrainOptions([in] BSTR strOptions) | sgObject::IFeatureCanvas
ShowNewVectorLayerWidget() | sgObject::IFeatureCanvas
ShowOpenRasterLayerWidget([in] BSTR strTitle, [out, retval] int *nSuccessNum) | sgObject::IFeatureCanvas
ShowOpenVectorLayerWidget([in] BSTR strTitle, [out, retval] int *nSuccessNum) | sgObject::IFeatureCanvas
ShowOpenWebLayerWidget() | sgObject::IFeatureCanvas
Undo() | sgObject::IFeatureCanvas
WriteWorkspace([in] BSTR strXMLFileName) | sgObject::IFeatureCanvas
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IFeatureCollection 인터페이스 참조

  • IFeatureCollection
Public 멤버 함수 | 모든 멤버 목록
sgObject::IFeatureCollection 인터페이스 참조

같은 종류의 Feature 객체들의 집합을 관리하는 FeatureCollection 객체의 인터페이스를 제공한다. 더 자세히 ...

sgObject::IFeatureCollection에 대한 상속 다이어그램 :
sgObject::IFeatureCollection에 대한 협력 다이어그램:

Public 멤버 함수

VARIANT_BOOL | IsEmpty ()
현재 소속된 Feature 객체가 없는지 여부를 반환한다. 더 자세히 ...
int | GetSize ()
소속된 Feature 객체의 개수를 반환한다. 더 자세히 ...
LONG | GetLabelSize ([in] ILayer *dspLayer)
레이어에서 생성된 Feature 개수를 반환한다. 단, 해당 레이어의 참조 레이어라면 라벨의 개수를 반환한다. 더 자세히 ...
TransactionEnum GetTransaction ()
트랜잭션 수행 타입을 반환한다. 더 자세히 ...
void | SetTransaction (TransactionEnum eVal)
트랜잭션 수행 타입을 설정한다. 더 자세히 ...
IFeature * GetFeature ()
Feature 리스트에서 현재 위치의 Feature 객체를 반환한다. 더 자세히 ...
IFeatureLayer * GetFeatureLayer ()
FeatureCollection 객체가 속한 FeatureLayer 객체를 반환한다. 더 자세히 ...
VARIANT_BOOL | IsRefer ()
FeatureCollection이 참조 객체를 포함하는 Collection 인지의 여부를 반환한다. 더 자세히 ...
void | SetRefer (VARIANT_BOOL bVal)
FeatureCollection이 참조 객체를 포함하는 Collection 인지의 여부를 반환한다. 더 자세히 ...
VARIANT_BOOL | Contains ([in] IFeature *other)
매개변수 Feature 객체가 이 FeatureCollection에 소속되어 있는지 여부를 테스트한다. 더 자세히 ...
VARIANT_BOOL | ContainsAll ([in] IFeatureCollection *others)
매개변수 FeatureCollection의 모든 Feature 객체가 이 FeatureCollection에 소속되어 있는지 여부를 테스트한다. 더 자세히 ...
IFeature * | Add ([in] IFeature *other)
매개변수 Feature 객체를 이 FeatureCollection에 추가한다. 더 자세히 ...
VARIANT_BOOL | AddAll ([in] IFeatureCollection *others)
매개변수 FeatureCollection의 모든 Feature 객체를 이 FeatureCollection에 추가한다. 더 자세히 ...
void | Clear ()
FeatureCollection의 내용을 비우고 초기화한다. 더 자세히 ...
VARIANT_BOOL | Remove ([in] IFeature *other)
매개변수 Feature 객체를 이 FeatureCollection에서 삭제한다. FeatureCanvas로 부터 Undo, Commit과 같은 트랜젝션 제어를 지원한다. 더 자세히 ...
VARIANT_BOOL | RemoveAll ([in] IFeatureCollection *others)
매개변수 FeatureCollection의 모든 Feature 객체를 이 FeatureCollection에서 삭제한다. 더 자세히 ...
VARIANT_BOOL | RetainAll ([in] IFeatureCollection *others)
매개변수 FeatureCollection에 속한 모든 Feature 객체가 이 FeatureCollection 객체와 같은지 여부를 판단한다. 더 자세히 ...
IFeatureCollection * | SubCollection ([in] IFeatureQuery *poFilter)
FeatureQuery 객체에 작성된 검색조건으로 이 FeatureCollection을 검색하여 조건을 만족하는 Feature 객체로 구성된 부분집합 FeatureCollection을 만든다. 더 자세히 ...
void | Close ()
FeatureCollection 객체의 모든 Feature를 삭제하고 초기화 한다. 더 자세히 ...
VARIANT_BOOL | MoveNext ()
다음 Feature 객체로 리스트의 위치를 이동한다. 더 자세히 ...
VARIANT_BOOL | MoveFirst ()
Feature 리스트의 맨 앞으로 위치를 이동한다. 더 자세히 ...
VARIANT_BOOL | MovePrevious ()
이전 FeatureStyle 객체로 리스트의 위치를 이동한다. 더 자세히 ...
VARIANT_BOOL | MoveLast ()
마지막 FeatureStyle 객체로 리스트의 위치를 이동한다. 더 자세히 ...
IFeature * | SetFeature ([in] IFeature *NewFeature)
NewFeature 객체의 ID와 동일한 객체를 찾아 신규 객체로 대체한다. 더 자세히 ...
IFeature * CreateFeature ()
FeatureType에 따라 새 Feature 객체를 생성한다. 더 자세히 ...
BSTR | ExportLTM ([in] BSTR strLayerID, [in] IGeometry *poTileEnv, [in] BSTR strFilePath, [in] short nLevel, [in] long nX, [in] long nY, [in] VARIANT_BOOL bAdd, [in] short nFlag, [in] VARIANT_BOOL bDegreeUnit, [in] short nAnnoFieldIndex, [in] VARIANT_BOOL bClip, [in] float fVersion)
LTM 압축 파일을 생성한다. 더 자세히 ...
void | ReCalculateExtent ()
해당 FeatureCollection에서 전체 범위를 다시 계산한다. 더 자세히 ...
IFeature * | GetFeatureFromFID (long nFID)
Feature 리스트에서 FID로 검색된 Feature 객체를 반환한다. 더 자세히 ...
IFeature * GetFeatureInterface ()
IVectorAnalysis * GetVectorAnalysis ()
- sgObject::IFeature(으)로부터 상속된 Public 멤버 함수
ISymbolizer * GetSymbolizer ()
Feature 객체가 화면에 그려질 때 필요한 색상, 선굵기 등 그래픽 속성에 관련된 정보를 나타내는 Symbolizer 객체를 반환한다. 더 자세히 ...
void | SetSymbolizer (ISymbolizer *dspSymbolizer)
Feature 객체가 화면에 그려질 때 필요한 색상, 선굵기 등 그래픽 속성에 관련된 정보를 나타내는 Symbolizer 객체를 설정한다. 더 자세히 ...
IFeatureType * GetFeatureType ()
Feature 객체가 어떤 타입인지, 저장된 일반 (속성) 정보들의 타입 등에 대한 정보를 나타내는 FeatureType 객체를 반환한다. 더 자세히 ...
IGeometry * GetGeometry ()
Feature 객체가 갖는 기하 정보를 나타내는 기하를 반환한다. (위치 및 기하 정보) 더 자세히 ...
void | SetGeometry (IGeometry *dspGeom)
Feature 객체가 갖는 기하 정보를 나타내는 기하를 설정한다. (위치 및 기하 정보) 더 자세히 ...
IFeatureCollection * GetFeatureCollection ()
Feature 객체가 속한 FeatureCollection 객체를 반환한다. 더 자세히 ...
IAnnotation * GetAnnotation ()
Feature 객체에 대한 주석 정보를 나타내는 주석 객체를 반환한다. 더 자세히 ...
void | SetAnnotation (IAnnotation *dspAnno)
Feature 객체에 대한 주석 정보를 나타내는 주석 객체를 설정한다. 더 자세히 ...
int | GetID ()
Feature 객체를 식별하기 위한 ID를 반환한다. (데이터베이스의 Unique Key와 대응된다) 더 자세히 ...
void | SetID (int nVal)
Feature 객체를 식별하기 위한 ID를 설정한다. (데이터베이스의 Unique Key와 대응된다) 더 자세히 ...
long | GetData ()
사용자가 정의한 필터값을 반환한다. 더 자세히 ...
void | SetData (long filter)
Feature 사용자가 정의한 필터값을 설정한다. 더 자세히 ...
VARIANT_BOOL | GetVisible ()
Feature 객체를 화면에 보여줄지 여부를 반환한다. 더 자세히 ...
void | SetVisible (VARIANT_BOOL bVal)
Feature 객체를 화면에 보여줄지 여부를 설정한다. 더 자세히 ...
VARIANT_BOOL | GetSelected ()
Feature 객체의 선택가능 여부를 반환한다. 더 자세히 ...
void | SetSelected (VARIANT_BOOL bVal)
Feature 객체의 선택가능 여부를 설정한다. 더 자세히 ...
IGeometry * GetAnnotationLine ()
인출선을 가리키는 기하를 반환한다. (*인출선 : 시설물 등 근처에 주석이 많을 경우 선을 빼서 주석을 그리기 위한 용도로 쓰임) 더 자세히 ...
void | SetAnnotationLine (IGeometry *dspGeom)
인출선을 가리키는 기하를 설정한다. (*인출선 : 시설물 등 근처에 주석이 많을 경우 선을 빼서 주석을 그리기 위한 용도로 쓰임) 더 자세히 ...
VARIANT_BOOL | GetVisibleAnnotation ()
주석을 화면에 보여줄지 여부를 반환한다 더 자세히 ...
void | SetVisibleAnnotation (VARIANT_BOOL bVal)
주석을 화면에 보여줄지 여부를 설정한다 더 자세히 ...
VARIANT_BOOL | GetVisibleAnnotationLine ()
인출선을 화면에 보여줄지 여부를 반환한다. 더 자세히 ...
void | SetVisibleAnnotationLine (VARIANT_BOOL bVal)
인출선을 화면에 보여줄지 여부를 반환한다. 더 자세히 ...
IUserDefinedWidget * GetUserDefinedWidget ()
사용자가 정의한 위젯 객체(도표 등)인 UserDefinedWidget 객체를 반환한다. 더 자세히 ...
void | SetUserDefinedWidget (IUserDefinedWidget *dspWidget)
사용자가 정의한 위젯 객체(도표 등)인 UserDefinedWidget 객체를 설정한다. 더 자세히 ...
VARIANT_BOOL | GetVisibleUserDefinedWidget ()
사용자가 정의한 위젯 객체(도표 등)인 UserDefinedWidget 객체를 화면에 보여줄지 여부를 반환한다. 더 자세히 ...
void | SetVisibleUserDefinedWidget (VARIANT_BOOL bVal)
사용자가 정의한 위젯 객체(도표 등)인 UserDefinedWidget 객체를 화면에 보여줄지 여부를 설정한다. 더 자세히 ...
IGeometry * GetBounds ()
Feature 객체의 기하를 감싸는 최소 직사각형의 기하를 반환한다. 더 자세히 ...
void | SetAttribute ([in] VARIANT vtIdx, [in] VARIANT vtVal)
해당 인덱스로 Feature 객체의 일반 (속성) 정보 한 개를 저장한다. 더 자세히 ...
BSTR | GetAttributeToString ([in] VARIANT vtIdx)
해당 인덱스의 일반 (속성) 정보를 문자열로 반환한다. 더 자세히 ...
void | GetAttribute ([in] VARIANT vtIdx, [out] VARIANT *pVal)
해당 인덱스의 일반 (속성) 정보를 가져온다. 더 자세히 ...
void | Extent2D ([out] double *minX, [out] double *minY, [out] double *maxX, [out] double *maxY)
Feature 객체의 기하를 감싸는 최소 직사각형의 x, y 좌표를 Output 변수에 가져온다 더 자세히 ...
IFeature * Clone ()
해당 Feature 객체와 동일한 객체를 복사 생성하여 가져온다. 더 자세히 ...
VARIANT_BOOL | Equal ([in] IFeature *ft)
해당 Feature 객체와 동일한지 여부를 판단한다. 더 자세히 ...
void | CopyTo ([in] IFeature *ft)
double | GetMinXExtent2D ()
double | GetMinYExtent2D ()
double | GetMaxXExtent2D ()
double | GetMaxYExtent2D ()
IGridCoverage * GetGridCoverage ()
BSTR | GetAttributeAsString ([in] VARIANT vtIdx)
BSTR | GetAttributeAsStringByName ([in] BSTR strName)

상세한 설명

같은 종류의 Feature 객체들의 집합을 관리하는 FeatureCollection 객체의 인터페이스를 제공한다.

(FeatureCollection 객체를 데이터베이스와 대응시키면 쿼리를 통해 얻어진 레코드들 혹은 테이블 전체 레코드와 대응된다) Feature 객체는 Object 애플리케이션에서 보통 FeatureCollection에 소속되어 FeatureLayer로 관리된다. C API(linux, iOS, MacOS 등) : 중간이름 "FC"를 덧붙여서 "OGR_FC_"+메소드명으로 사용할 수 있습니다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.FeatureCollection"

멤버 함수 문서화

IFeature* sgObject::IFeatureCollection::Add ( [in] IFeature * other )

매개변수 Feature 객체를 이 FeatureCollection에 추가한다.

Reference 프로퍼티 값에 따라 Feature 객체를 새로 만들어 추가하던지 매개변수 Feature 객체의 포인터를 저장하던지 한다. Reference 가 FALSE인 경우 모든 값을 복사하여 신규 객체를 생성하여 추가하며 속성값이 존재하는 경우 추가하려고 하는 FeatureCollection의 FeatureType(필드 구조)과 동일한 필드명과 필드타입에 대해서만 값을 복사하여 추가한다. FeatureCanvas로 부터 Undo, Commit과 같은 트랜젝션 제어를 지원한다.

매개변수
other - 추가할 Feature 객체를 가리키는 포인터
반환값
성공이면 추가된 Feature 객체를 가리키는 포인터, 그렇지 않으면 NULL
VARIANT_BOOL sgObject::IFeatureCollection::AddAll ( [in] IFeatureCollection * others )

매개변수 FeatureCollection의 모든 Feature 객체를 이 FeatureCollection에 추가한다.

Reference 프로퍼티 값에 따라 Feature 객체를 새로 만들어 추가하던지 매개변수 Feature 객체의 포인터를 저장하던지 한다. Reference 가 FALSE인 경우 모든 값을 복사하여 신규 객체를 생성하여 추가하며 속성값이 존재하는 경우 추가하려고 하는 FeatureCollection의 FeatureType(필드 구조)과 동일한 필드명과 필드타입에 대해서만 값을 복사하여 추가한다. FeatureCanvas로부터 Undo, Commit과 같은 트랜젝션 제어를 지원한다.

매개변수
others - FeatureCollection 객체를 가리키는 포인터
반환값
성공이면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
void sgObject::IFeatureCollection::Clear ( )

FeatureCollection의 내용을 비우고 초기화한다.

void sgObject::IFeatureCollection::Close ( )

FeatureCollection 객체의 모든 Feature를 삭제하고 초기화 한다.

VARIANT_BOOL sgObject::IFeatureCollection::Contains ( [in] IFeature * other )

매개변수 Feature 객체가 이 FeatureCollection에 소속되어 있는지 여부를 테스트한다.

매개변수
other - 테스트 할 Feature 객체를 가리키는 포인터
반환값
소속되어 있으면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE 매개 변수로 오는 Feature가 소스 기하 내에 완전히 포함되면 참을 반환한다. 이것은 소스기하와 비교할 기하의 순서를 역으로 했을 때의 Within 연산과 같다.
VARIANT_BOOL sgObject::IFeatureCollection::ContainsAll ( [in] IFeatureCollection * others )

매개변수 FeatureCollection의 모든 Feature 객체가 이 FeatureCollection에 소속되어 있는지 여부를 테스트한다.

매개변수
others - FeatureCollection 객체를 가리키는 포인터
반환값
모두 소속되어 있으면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
IFeature* sgObject::IFeatureCollection::CreateFeature ( )

FeatureType에 따라 새 Feature 객체를 생성한다.

반환값
성공이면 생성된 Feature 객체를 가리키는 포인터를 반환하고, 실패하면 NULL을 반환한다.
BSTR sgObject::IFeatureCollection::ExportLTM | ( | [in] BSTR | strLayerID,
 |  | [in] IGeometry * | poTileEnv,
 |  | [in] BSTR | strFilePath,
 |  | [in] short | nLevel,
 |  | [in] long | nX,
 |  | [in] long | nY,
 |  | [in] VARIANT_BOOL | bAdd,
 |  | [in] short | nFlag,
 |  | [in] VARIANT_BOOL | bDegreeUnit,
 |  | [in] short | nAnnoFieldIndex,
 |  | [in] VARIANT_BOOL | bClip,
 |  | [in] float | fVersion
 | ) |  |

LTM 압축 파일을 생성한다.

매개변수
strLayerID | - 생성 레이어명
poTileEnv | - 기준 도곽 공간 폴리곤 객체
strFilePath | - 저장 위치 폴더
nLevel | - 저장 레벨
nX | - 기준 도곽 인덱스 X번호
nY | - 기준 도곽 인덱스 Y번호
bAdd | - 기존 압축 파일이 있는 경우 파일 뒤에 추가 여부
nFlag | - Feature별 특수 플래그 (POI인덱스 번호 등)
bDegreeUnit | - 공간객체의 좌표계 단위가 도분초 여부
nAnnoFieldIndex | - 주석 또는 속성으로 내보내기 위한 필드 인덱스
bClip | - 도곽을 기준으로 intersaction 연산 결과만 저장 여부
fVersion | - 저장 포맷 버전
반환값
메소드가 실행되면 생성된 파일명이 반환된다.
IFeature* sgObject::IFeatureCollection::GetFeature ( )

Feature 리스트에서 현재 위치의 Feature 객체를 반환한다.

반환값
Feature 리스트에서 현재 위치의 Feature 객체를 가리키는 포인터
IFeature* sgObject::IFeatureCollection::GetFeatureFromFID ( long nFID )

Feature 리스트에서 FID로 검색된 Feature 객체를 반환한다.

반환값
Feature 리스트에서 FID로 검색된 Feature 객체를 가리키는 포인터
IFeature* sgObject::IFeatureCollection::GetFeatureInterface ( )
IFeatureLayer* sgObject::IFeatureCollection::GetFeatureLayer ( )

FeatureCollection 객체가 속한 FeatureLayer 객체를 반환한다.

반환값
FeatureCollection 객체가 속한 FeatureLayer 객체를 가리키는 포인터
LONG sgObject::IFeatureCollection::GetLabelSize ( [in] ILayer * dspLayer )

레이어에서 생성된 Feature 개수를 반환한다. 단, 해당 레이어의 참조 레이어라면 라벨의 개수를 반환한다.

(ReferLayer : 특정 레이어끼리 연결하기 위한 정보를 갖고 있는 레이어)

매개변수
dspLayer - 레이어 또는 해당 레이어의 참조 레이어
반환값
Feature 개수 또는 라벨의 개수
int sgObject::IFeatureCollection::GetSize ( )

소속된 Feature 객체의 개수를 반환한다.

반환값
소속된 Feature 객체의 개수
TransactionEnum sgObject::IFeatureCollection::GetTransaction ( )

트랜잭션 수행 타입을 반환한다.

반환값
트랜잭션 타입
IVectorAnalysis* sgObject::IFeatureCollection::GetVectorAnalysis ( )
VARIANT_BOOL sgObject::IFeatureCollection::IsEmpty ( )

현재 소속된 Feature 객체가 없는지 여부를 반환한다.

반환값
비어있으면 VARIANT_TRUE, 비어있지 않으면 VARIANT_FALSE
VARIANT_BOOL sgObject::IFeatureCollection::IsRefer ( )

FeatureCollection이 참조 객체를 포함하는 Collection 인지의 여부를 반환한다.

반환값
포함하고 있으면 VARIANT_TRUE, 포함하고 있지 않으면 VARIANT_FALSE
VARIANT_BOOL sgObject::IFeatureCollection::MoveFirst ( )

Feature 리스트의 맨 앞으로 위치를 이동한다.

반환값
성공이면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
VARIANT_BOOL sgObject::IFeatureCollection::MoveLast ( )

마지막 FeatureStyle 객체로 리스트의 위치를 이동한다.

반환값
성공이면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
VARIANT_BOOL sgObject::IFeatureCollection::MoveNext ( )

다음 Feature 객체로 리스트의 위치를 이동한다.

반환값
성공이면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
VARIANT_BOOL sgObject::IFeatureCollection::MovePrevious ( )

이전 FeatureStyle 객체로 리스트의 위치를 이동한다.

반환값
성공이면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
void sgObject::IFeatureCollection::ReCalculateExtent ( )

해당 FeatureCollection에서 전체 범위를 다시 계산한다.

sgObject::IFeature를 구현.

VARIANT_BOOL sgObject::IFeatureCollection::Remove ( [in] IFeature * other )

매개변수 Feature 객체를 이 FeatureCollection에서 삭제한다. FeatureCanvas로 부터 Undo, Commit과 같은 트랜젝션 제어를 지원한다.

매개변수
other - 삭제할 Feature 객체를 가리키는 포인터
반환값
성공이면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
VARIANT_BOOL sgObject::IFeatureCollection::RemoveAll ( [in] IFeatureCollection * others )

매개변수 FeatureCollection의 모든 Feature 객체를 이 FeatureCollection에서 삭제한다.

FeatureCanvas로 부터 Undo, Commit과 같은 트랜젝션 제어를 지원한다.

매개변수
others - 모든 Feature 객체를 삭제할 FeatureCollection 객체의 포인터
반환값
성공이면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
VARIANT_BOOL sgObject::IFeatureCollection::RetainAll ( [in] IFeatureCollection * others )

매개변수 FeatureCollection에 속한 모든 Feature 객체가 이 FeatureCollection 객체와 같은지 여부를 판단한다.

매개변수
others - FeatureCollection 객체를 가리키는 포인터
반환값
성공이면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
IFeature* sgObject::IFeatureCollection::SetFeature ( [in] IFeature * NewFeature )

NewFeature 객체의 ID와 동일한 객체를 찾아 신규 객체로 대체한다.

Feature를 직접 수정하지 않고 SetFeature를 사용하는 경우 FeatureCanvas로 부터 Undo, Commit과 같은 트랜젝션 제어를 지원한다.

매개변수
NewFeature - 변경 Feature 객체
반환값
성공이면 추가된 Feature 객체를 가리키는 포인터, 그렇지 않으면 NULL.
void sgObject::IFeatureCollection::SetRefer ( VARIANT_BOOL bVal )

FeatureCollection이 참조 객체를 포함하는 Collection 인지의 여부를 반환한다.

반환값
bVal - 포함하고 있으면 VARIANT_TRUE, 포함하고 있지 않으면 VARIANT_FALSE
void sgObject::IFeatureCollection::SetTransaction ( TransactionEnum eVal )

트랜잭션 수행 타입을 설정한다.

매개변수
eVal - 설정 트랜잭션 타입
IFeatureCollection* sgObject::IFeatureCollection::SubCollection ( [in] IFeatureQuery * poFilter )

FeatureQuery 객체에 작성된 검색조건으로 이 FeatureCollection을 검색하여 조건을 만족하는 Feature 객체로 구성된 부분집합 FeatureCollection을 만든다.

Feature 객체는 새로 생성하지 않고 포인터를 복사하여 부분집합 FeatureCollection을 만든다.

매개변수
poFilter - FeatureQuery 객체를 가리키는 포인터. 이 객체는 Compile() 메소드를 성공한 상태여야 한다.
반환값
부분집합 FeatureCollection 객체를 가리키는 포인터
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IFeatureCollection
sgObject::IFeatureCollection 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IFeatureCollection (모든 상속된 멤버들도 포함합니다.)

Add([in] IFeature *other) | sgObject::IFeatureCollection
AddAll([in] IFeatureCollection *others) | sgObject::IFeatureCollection
Clear() | sgObject::IFeatureCollection
Clone() | sgObject::IFeature
Close() | sgObject::IFeatureCollection
Contains([in] IFeature *other) | sgObject::IFeatureCollection
ContainsAll([in] IFeatureCollection *others) | sgObject::IFeatureCollection
CopyTo([in] IFeature *ft) | sgObject::IFeature
CreateFeature() | sgObject::IFeatureCollection
Equal([in] IFeature *ft) | sgObject::IFeature
ExportLTM([in] BSTR strLayerID, [in] IGeometry *poTileEnv, [in] BSTR strFilePath, [in] short nLevel, [in] long nX, [in] long nY, [in] VARIANT_BOOL bAdd, [in] short nFlag, [in] VARIANT_BOOL bDegreeUnit, [in] short nAnnoFieldIndex, [in] VARIANT_BOOL bClip, [in] float fVersion) | sgObject::IFeatureCollection
Extent2D([out] double *minX, [out] double *minY, [out] double *maxX, [out] double *maxY) | sgObject::IFeature
GetAnnotation() | sgObject::IFeature
GetAnnotationLine() | sgObject::IFeature
GetAttribute([in] VARIANT vtIdx, [out] VARIANT *pVal) | sgObject::IFeature
GetAttributeAsString([in] VARIANT vtIdx) | sgObject::IFeature
GetAttributeAsStringByName([in] BSTR strName) | sgObject::IFeature
GetAttributeToString([in] VARIANT vtIdx) | sgObject::IFeature
GetBounds() | sgObject::IFeature
GetData() | sgObject::IFeature
GetFeature() | sgObject::IFeatureCollection
GetFeatureCollection() | sgObject::IFeature
GetFeatureFromFID(long nFID) | sgObject::IFeatureCollection
GetFeatureInterface() | sgObject::IFeatureCollection
GetFeatureLayer() | sgObject::IFeatureCollection
GetFeatureType() | sgObject::IFeature
GetGeometry() | sgObject::IFeature
GetGridCoverage() | sgObject::IFeature
GetID() | sgObject::IFeature
GetLabelSize([in] ILayer *dspLayer) | sgObject::IFeatureCollection
GetMaxXExtent2D() | sgObject::IFeature
GetMaxYExtent2D() | sgObject::IFeature
GetMinXExtent2D() | sgObject::IFeature
GetMinYExtent2D() | sgObject::IFeature
GetSelected() | sgObject::IFeature
GetSize() | sgObject::IFeatureCollection
GetSymbolizer() | sgObject::IFeature
GetTransaction() | sgObject::IFeatureCollection
GetUserDefinedWidget() | sgObject::IFeature
GetVectorAnalysis() | sgObject::IFeatureCollection
GetVisible() | sgObject::IFeature
GetVisibleAnnotation() | sgObject::IFeature
GetVisibleAnnotationLine() | sgObject::IFeature
GetVisibleUserDefinedWidget() | sgObject::IFeature
IsEmpty() | sgObject::IFeatureCollection
IsRefer() | sgObject::IFeatureCollection
MoveFirst() | sgObject::IFeatureCollection
MoveLast() | sgObject::IFeatureCollection
MoveNext() | sgObject::IFeatureCollection
MovePrevious() | sgObject::IFeatureCollection
ReCalculateExtent() | sgObject::IFeatureCollection
Remove([in] IFeature *other) | sgObject::IFeatureCollection
RemoveAll([in] IFeatureCollection *others) | sgObject::IFeatureCollection
RetainAll([in] IFeatureCollection *others) | sgObject::IFeatureCollection
SetAnnotation(IAnnotation *dspAnno) | sgObject::IFeature
SetAnnotationLine(IGeometry *dspGeom) | sgObject::IFeature
SetAttribute([in] VARIANT vtIdx, [in] VARIANT vtVal) | sgObject::IFeature
SetData(long filter) | sgObject::IFeature
SetFeature([in] IFeature *NewFeature) | sgObject::IFeatureCollection
SetGeometry(IGeometry *dspGeom) | sgObject::IFeature
SetID(int nVal) | sgObject::IFeature
SetRefer(VARIANT_BOOL bVal) | sgObject::IFeatureCollection
SetSelected(VARIANT_BOOL bVal) | sgObject::IFeature
SetSymbolizer(ISymbolizer *dspSymbolizer) | sgObject::IFeature
SetTransaction(TransactionEnum eVal) | sgObject::IFeatureCollection
SetUserDefinedWidget(IUserDefinedWidget *dspWidget) | sgObject::IFeature
SetVisible(VARIANT_BOOL bVal) | sgObject::IFeature
SetVisibleAnnotation(VARIANT_BOOL bVal) | sgObject::IFeature
SetVisibleAnnotationLine(VARIANT_BOOL bVal) | sgObject::IFeature
SetVisibleUserDefinedWidget(VARIANT_BOOL bVal) | sgObject::IFeature
SubCollection([in] IFeatureQuery *poFilter) | sgObject::IFeatureCollection
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IFeatureLayer 인터페이스 참조

  • IFeatureLayer
Public 멤버 함수 | 모든 멤버 목록
sgObject::IFeatureLayer 인터페이스 참조

FeatureLayer 객체의 인터페이스를 제공한다. 더 자세히 ...

sgObject::IFeatureLayer에 대한 상속 다이어그램 :
sgObject::IFeatureLayer에 대한 협력 다이어그램:

Public 멤버 함수

HRESULT | GetFeatureCanvas ([out, retval] IFeatureCanvas **pFtCvs)
해당 FeatureLayer를 관리하는 FeatureCanvas를 반환한다. 더 자세히 ...
HRESULT | GetFeatureCollection ([out, retval] IFeatureCollection **pVal)
FeatureLayer에서 관리하는 Feature들의 집합(FeatureCollection)을 나타낸다. 더 자세히 ...
HRESULT | SetFeatureCollection ([in] IFeatureCollection *newVal)
FeatureLayer에서 관리하는 Feature들의 집합(FeatureCollection)을 설정한다. 더 자세히 ...
HRESULT | GetLayer ([out, retval] ILayer **pVal)
FeatureLayer를 생성한 Layer 객체를 나타낸다. 더 자세히 ...
HRESULT | GetLayerSource ([out, retval] ILayerSource **pVal)
Layer를 생성한 LayerSource 객체를 나타낸다. 더 자세히 ...
HRESULT | Export ([in] ILayerSource *poDstLS, [in] BSTR szDstName, [in] VARIANT vSelFields, [in] VARIANT_BOOL bAppend, [in] LONG eGType, [in] VARIANT_BOOL bOverwrite, [in] VARIANT_BOOL bTransform, [in] VARIANT_BOOL bOnlySelected, [in, optional] VARIANT szSourceSRS, [in, optional] VARIANT szOutputSRS, [in, optional] VARIANT szFilter, [in, optional] VARIANT nMapIndex, [in, optional] VARIANT szOptions)
해당 FeatureLayer를 다른 데이터소스로 export한다. 더 자세히 ...
HRESULT | AddAttribute ([in] IFeatureAttributeDescriptor *pFeatureType, [out, retval] IFeatureAttributeDescriptor **poRetVal)
FeatureLayer Schema에 속성을 추가한다. 더 자세히 ...
HRESULT | RemoveAttribute ([in] VARIANT vtIdx, [out, retval] VARIANT_BOOL *pVal)
FeatureLayer Schema에서 해당 인덱스의 속성을 제거한다. 더 자세히 ...
HRESULT | SetAttribute ([in] VARIANT vtIdx, [in] IFeatureAttributeDescriptor *pFeatureType, [out, retval] IFeatureAttributeDescriptor **poRetVal)
FeatureLayer Schema에서 해당 인덱스의 속성을 변경한다. 더 자세히 ...
HRESULT | GetDriverType ([out, retval] BSTR *pszType)
주제도작성을 위한 창을 연다. 더 자세히 ...
HRESULT | ShowStyleWidget ()
스타일 관리를 위한 창을 연다. 더 자세히 ...
HRESULT | ShowTypeStyleWidget ()
주제도작성을 위한 창을 연다. 더 자세히 ...
HRESULT | ShowLabelWidget ()
속성주석 생성을 위한 창을 연다. 더 자세히 ...
HRESULT | ShowExportLayerWidget ()
공간정보 파일로 내보내기 위한 윈도우를 연다. 더 자세히 ...
HRESULT | ShowFeatureTableWidget ([in] ICanvas *pCanvas)
검색 및 속성수정을 위한 속성 테이블창을 연다. 더 자세히 ...
HRESULT | ShowLayerPropertyWidget ([in] BSTR szFlag)
레이어의 정보를 확인하기 위한 창을 연다. 더 자세히 ...
HRESULT | ShowFieldCalculatorWidget ()
레이어의 속성값을 계산하여 특정 값으로 표현하기 위한 창을 연다. 더 자세히 ...
HRESULT | ShowFeatureTypeEditWidget ()
레이어의 FeatureType을 입력, 수정, 삭제 하기 위한 창을 연다. 더 자세히 ...
HRESULT | ShowCRSWidget ()
레이어의 공간좌표체계를 입력하기 위한 창을 연다. 더 자세히 ...
HRESULT | Refresh ([out, retval] VARIANT_BOOL *bRetVal)
GWFS, Project 레이어에 한해 현재 로딩되어 있는 피쳐객체들의 설정된 속성(SetRefreshTime 설정값)을 갱신한다. 더 자세히 ...
HRESULT | SetRefreshTime ([in] BSTR szFieldList, [in] BSTR szCheckTimeField, [in] VARIANT_BOOL bIncludeSystemField, [in] int nRefreshTerm)
GWFS 레이어에 한해 갱신 주기에 따라 자동으로 로딩되어 있는 피쳐 객체들의 값을 갱신한다. 더 자세히 ...

상세한 설명

FeatureLayer 객체의 인터페이스를 제공한다.

GIS에서는 데이터를 화면에 표현하기 위해 관리할 때 보통 레이어의 개념을 도입해 객체 종류별 관리를 한다. LayerSourceFactory가 생성하는 LayerSource는 이렇게 레이어 단위로 관리되는 데이터의 전체 구조 (레이어의 모음) 이다. Layer 객체는 레이어에 속한 Feature들을 관리하는 FeatureLayer 객체를 갖고 있다. FeatureLayer는 FeatureCollection을 갖고 있으며 이들을 화면에 표현하기 위한 정보를 갖고 있다. FeatureLayer는 LayerSource에서 레이어를 가져올 때 자동 생성된다. C API(linux, iOS, MacOS 등) : 중간이름 "FL"를 덧붙여서 "OGR_FL_"+메소드명으로 사용할 수 있습니다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.FeatureLayer"

멤버 함수 문서화

HRESULT sgObject::IFeatureLayer::AddAttribute | ( | [in] IFeatureAttributeDescriptor * | pFeatureType,
 |  | [out, retval] IFeatureAttributeDescriptor ** | poRetVal
 | ) |  |

FeatureLayer Schema에 속성을 추가한다.

매개변수
pFeatureType | - 속성 FeatureType 포인터
poRetVal | - 추가가 성공했을 때 반환하는 FeatureType 포인터
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureLayer::Export | ( | [in] ILayerSource * | poDstLS,
 |  | [in] BSTR | szDstName,
 |  | [in] VARIANT | vSelFields,
 |  | [in] VARIANT_BOOL | bAppend,
 |  | [in] LONG | eGType,
 |  | [in] VARIANT_BOOL | bOverwrite,
 |  | [in] VARIANT_BOOL | bTransform,
 |  | [in] VARIANT_BOOL | bOnlySelected,
 |  | [in, optional] VARIANT | szSourceSRS,
 |  | [in, optional] VARIANT | szOutputSRS,
 |  | [in, optional] VARIANT | szFilter,
 |  | [in, optional] VARIANT | nMapIndex,
 |  | [in, optional] VARIANT | szOptions
 | ) |  |

해당 FeatureLayer를 다른 데이터소스로 export한다.

매개변수
poDstLS | - 다른 데이터소스로 만들어질 LayerSource
szDstName | - export할 LayerSource 이름
vSelFields | - export할 필드들
bAppend | - 기존에 파일에 있는 내용을 삭제하지 않고 추가할지 여부. (VARIANT_TRUE면 삭제하지 않고 추가, VARIANT_FALSE면 삭제하고 추가)
eGType | - 해당 Layer의 Feature들의 Geometry 타입. GeometryTypeEnum Constant로 지정하면 됨
bOverwrite | - 해당 Layer의 Feature들의 삭제 여부
bTransform | - 좌표체계 변환 여부
szSourceSRS | - 소스의 좌표체계
szOutputSRS | - export될 LayerSource의 좌표체계
szFilter | - 필터 내용 [옵션]
nMapIndex | - 지도 인덱스 번호 [옵션]
szOptions | - 기타 설정 옵션 [옵션]
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureLayer::GetDriverType ( [out, retval] BSTR * pszType )

주제도작성을 위한 창을 연다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureLayer::GetFeatureCanvas ( [out, retval] IFeatureCanvas ** pFtCvs )

해당 FeatureLayer를 관리하는 FeatureCanvas를 반환한다.

매개변수
pFtCvs - 해당 FeatureLayer를 관리하는 FeatureCanvas의 포인터
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureLayer::GetFeatureCollection ( [out, retval] IFeatureCollection ** pVal )

FeatureLayer에서 관리하는 Feature들의 집합(FeatureCollection)을 나타낸다.

매개변수
pVal - FeatureLayer에서 관리하는 Feature들의 집합(FeatureCollection)의 포인터
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureLayer::GetLayer ( [out, retval] ILayer ** pVal )

FeatureLayer를 생성한 Layer 객체를 나타낸다.

매개변수
pVal - FeatureLayer를 생성한 Layer 객체의 이중 포인터(포인터의 포인터)
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureLayer::GetLayerSource ( [out, retval] ILayerSource ** pVal )

Layer를 생성한 LayerSource 객체를 나타낸다.

매개변수
pVal - Layer를 생성한 LayerSource 객체의 이중 포인터(포인터의 포인터)
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureLayer::Refresh ( [out, retval] VARIANT_BOOL * bRetVal )

GWFS, Project 레이어에 한해 현재 로딩되어 있는 피쳐객체들의 설정된 속성(SetRefreshTime 설정값)을 갱신한다.

매개변수
bRetVal - 성공 여부를 반환한다.
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureLayer::RemoveAttribute | ( | [in] VARIANT | vtIdx,
 |  | [out, retval] VARIANT_BOOL * | pVal
 | ) |  |

FeatureLayer Schema에서 해당 인덱스의 속성을 제거한다.

매개변수
vtIdx | - 속성 인덱스
pVal | - 제거 성공 여부
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureLayer::SetAttribute | ( | [in] VARIANT | vtIdx,
 |  | [in] IFeatureAttributeDescriptor * | pFeatureType,
 |  | [out, retval] IFeatureAttributeDescriptor ** | poRetVal
 | ) |  |

FeatureLayer Schema에서 해당 인덱스의 속성을 변경한다.

매개변수
vtIdx | - 속성 인덱스
pFeatureType | - 속성 FeatureType 포인터
poRetVal | - 변경에 성공했을 때 반환하는 FeatureType 포인터
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureLayer::SetFeatureCollection ( [in] IFeatureCollection * newVal )

FeatureLayer에서 관리하는 Feature들의 집합(FeatureCollection)을 설정한다.

매개변수
newVal - FeatureLayer에서 관리하는 Feature들의 집합(FeatureCollection)의 포인터
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureLayer::SetRefreshTime | ( | [in] BSTR | szFieldList,
 |  | [in] BSTR | szCheckTimeField,
 |  | [in] VARIANT_BOOL | bIncludeSystemField,
 |  | [in] int | nRefreshTerm
 | ) |  |

GWFS 레이어에 한해 갱신 주기에 따라 자동으로 로딩되어 있는 피쳐 객체들의 값을 갱신한다.

매개변수
szFieldList | - 갱신 속성 필드 리스트(','를 구분자로 여러 필드를 설정)
szCheckTimeField | - 갱신 조건에 사용되는 최종 변경시간 필드(변경 시간 필드를 설정하지 않으면 전체를 비교함으로 성능이 저하됨)
bIncludeSystemField | - 공간 정보, 주석 등 시스템 내부적으로 사용하는 필드에 대한 갱신 여부
nRefreshTerm | - 자동 갱신 주기(단위 : 밀리세컨드)
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureLayer::ShowCRSWidget ( )

레이어의 공간좌표체계를 입력하기 위한 창을 연다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureLayer::ShowExportLayerWidget ( )

공간정보 파일로 내보내기 위한 윈도우를 연다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureLayer::ShowFeatureTableWidget ( [in] ICanvas * pCanvas )

검색 및 속성수정을 위한 속성 테이블창을 연다.

매개변수
pCanvas - 열기를 시도할 Canvas 객체
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureLayer::ShowFeatureTypeEditWidget ( )

레이어의 FeatureType을 입력, 수정, 삭제 하기 위한 창을 연다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureLayer::ShowFieldCalculatorWidget ( )

레이어의 속성값을 계산하여 특정 값으로 표현하기 위한 창을 연다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureLayer::ShowLabelWidget ( )

속성주석 생성을 위한 창을 연다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureLayer::ShowLayerPropertyWidget ( [in] BSTR szFlag )

레이어의 정보를 확인하기 위한 창을 연다.

매개변수
szFlag - 창이 열릴 떄 초기에 보여질 정보창의 번호
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureLayer::ShowStyleWidget ( )

스타일 관리를 위한 창을 연다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IFeatureLayer::ShowTypeStyleWidget ( )

주제도작성을 위한 창을 연다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IFeatureLayer
sgObject::IFeatureLayer 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IFeatureLayer (모든 상속된 멤버들도 포함합니다.)

AddAttribute([in] IFeatureAttributeDescriptor *pFeatureType, [out, retval] IFeatureAttributeDescriptor **poRetVal) | sgObject::IFeatureLayer
Export([in] ILayerSource *poDstLS, [in] BSTR szDstName, [in] VARIANT vSelFields, [in] VARIANT_BOOL bAppend, [in] LONG eGType, [in] VARIANT_BOOL bOverwrite, [in] VARIANT_BOOL bTransform, [in] VARIANT_BOOL bOnlySelected, [in, optional] VARIANT szSourceSRS, [in, optional] VARIANT szOutputSRS, [in, optional] VARIANT szFilter, [in, optional] VARIANT nMapIndex, [in, optional] VARIANT szOptions) | sgObject::IFeatureLayer
GetDriverType([out, retval] BSTR *pszType) | sgObject::IFeatureLayer
GetFeatureCanvas([out, retval] IFeatureCanvas **pFtCvs) | sgObject::IFeatureLayer
GetFeatureCollection([out, retval] IFeatureCollection **pVal) | sgObject::IFeatureLayer
GetLayer([out, retval] ILayer **pVal) | sgObject::IFeatureLayer
GetLayerSource([out, retval] ILayerSource **pVal) | sgObject::IFeatureLayer
Refresh([out, retval] VARIANT_BOOL *bRetVal) | sgObject::IFeatureLayer
RemoveAttribute([in] VARIANT vtIdx, [out, retval] VARIANT_BOOL *pVal) | sgObject::IFeatureLayer
SetAttribute([in] VARIANT vtIdx, [in] IFeatureAttributeDescriptor *pFeatureType, [out, retval] IFeatureAttributeDescriptor **poRetVal) | sgObject::IFeatureLayer
SetFeatureCollection([in] IFeatureCollection *newVal) | sgObject::IFeatureLayer
SetRefreshTime([in] BSTR szFieldList, [in] BSTR szCheckTimeField, [in] VARIANT_BOOL bIncludeSystemField, [in] int nRefreshTerm) | sgObject::IFeatureLayer
ShowCRSWidget() | sgObject::IFeatureLayer
ShowExportLayerWidget() | sgObject::IFeatureLayer
ShowFeatureTableWidget([in] ICanvas *pCanvas) | sgObject::IFeatureLayer
ShowFeatureTypeEditWidget() | sgObject::IFeatureLayer
ShowFieldCalculatorWidget() | sgObject::IFeatureLayer
ShowLabelWidget() | sgObject::IFeatureLayer
ShowLayerPropertyWidget([in] BSTR szFlag) | sgObject::IFeatureLayer
ShowStyleWidget() | sgObject::IFeatureLayer
ShowTypeStyleWidget() | sgObject::IFeatureLayer
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IFeatureQuery 인터페이스 참조

  • IFeatureQuery
Public 멤버 함수 | 모든 멤버 목록
sgObject::IFeatureQuery 인터페이스 참조

주어진 쿼리 조건에 맞는 Feature 객체를 선별하기 위한 기능을 제공하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::IFeatureQuery에 대한 상속 다이어그램 :
sgObject::IFeatureQuery에 대한 협력 다이어그램:

Public 멤버 함수

VARIANT_BOOL | Compile ([in] IFeatureType *dspFeatureType, [in] BSTR strQuery)
주어진 질의로, 주어진 FeatureType의 Feature 객체를 찾는 검색조건을 만들어낸다. 더 자세히 ...
VARIANT_BOOL | SelectCompile ([in] IFeatureType *dspFeatureType, [in] BSTR strQuery)
주어진 표현식으로 FeatureType의 필드값을 이용하여 결과를 만들어낸다. 더 자세히 ...
VARIANT_BOOL | Evaluate ([in] IFeature *dspFeature)
Compile된 검색조건에 주어진 Feature 객체가 합당한지 테스트한다. 더 자세히 ...
BSTR | GetAttributeAsString ([in] IFeature *dspFeature, int index)
SelectCompile된 표현식에 주어진 Feature 객체의 적정한 연산결과값을 반환한다. 더 자세히 ...

상세한 설명

주어진 쿼리 조건에 맞는 Feature 객체를 선별하기 위한 기능을 제공하는 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "FQ"를 덧붙여서 "OGR_FQ_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.FeatureQuery"

멤버 함수 문서화

VARIANT_BOOL sgObject::IFeatureQuery::Compile | ( | [in] IFeatureType * | dspFeatureType,
 |  | [in] BSTR | strQuery
 | ) |  |

주어진 질의로, 주어진 FeatureType의 Feature 객체를 찾는 검색조건을 만들어낸다.

Compile된 FeatureQuery 객체로 한 개의 Feature 객체 단위로 검색조건 만족 여부를 테스트할 수도 있고, FeatureCollection의 SubCollection()을 통해 FeatureCollection의 부분집합을 생성할 수도 있다.

매개변수
dspFeatureType | - 검색될 Feature 객체의 FeatureType
strQuery | - 검색조건을 만들 Query문으로 일반적인 SQL문장의 Where 조건절과 유사하며 다음과 같은 구문을 지원한다. [ (, ), OR, AND, NOT, NOT LIKE, NOT IN, <=, >=, =, !=, <>, <, >, LIKE, ILIKE, IN, IS NULL, IS NOT NULL]
반환값
검색조건을 생성하는데 오류가 없으면 VARIANT_TRUE, 있으면 VARIANT_FALSE
VARIANT_BOOL sgObject::IFeatureQuery::Evaluate ( [in] IFeature * dspFeature )

Compile된 검색조건에 주어진 Feature 객체가 합당한지 테스트한다.

매개변수
dspFeature - 테스트할 Feature 객체
반환값
합당하면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
BSTR sgObject::IFeatureQuery::GetAttributeAsString | ( | [in] IFeature * | dspFeature,
 |  | int | index
 | ) |  |

SelectCompile된 표현식에 주어진 Feature 객체의 적정한 연산결과값을 반환한다.

여러개의 필드 연산인 경우 인덱스번호에 따라 해당 필드의 표현식 결과값을 반환한다.

매개변수
dspFeature | - 표현식으로 연산할 Feature 객체
index | - 필드 표현식의 인덱스 순서
반환값
필드 표현식 중 인덱스 번호에 해당하는 필드의 결과값을 문자로 반환한다.
VARIANT_BOOL sgObject::IFeatureQuery::SelectCompile | ( | [in] IFeatureType * | dspFeatureType,
 |  | [in] BSTR | strQuery
 | ) |  |

주어진 표현식으로 FeatureType의 필드값을 이용하여 결과를 만들어낸다.

Compile된 FeatureQuery 객체로 개별 Feature 객체 단위로 표현식에 따른 결과값을 획득할 수 있다. 여러개의 필드 표현식을 입력할 수 있으며 필드간 구분은 ,를 사용한다.

매개변수
dspFeatureType | - 표현식에 사용할 Feature 객체의 FeatureType
strQuery | - 표현식을 만들 Query문으로 일반적인 SQL문장의 Select 필드절과 유사하며 다음과 같은 구문을 지원한다. [필드명, 필드간 연산식(+, -, *, /), CAST, CONCAT, SBUSTR]
반환값
표현식을 생성하는데 오류가 없으면 VARIANT_TRUE, 있으면 VARIANT_FALSE
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IFeatureQuery
sgObject::IFeatureQuery 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IFeatureQuery (모든 상속된 멤버들도 포함합니다.)

Compile([in] IFeatureType *dspFeatureType, [in] BSTR strQuery) | sgObject::IFeatureQuery
Evaluate([in] IFeature *dspFeature) | sgObject::IFeatureQuery
GetAttributeAsString([in] IFeature *dspFeature, int index) | sgObject::IFeatureQuery
SelectCompile([in] IFeatureType *dspFeatureType, [in] BSTR strQuery) | sgObject::IFeatureQuery
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IFeatureStyleCollection 인터페이스 참조

  • IFeatureStyleCollection
Public 멤버 함수 | 모든 멤버 목록
sgObject::IFeatureStyleCollection 인터페이스 참조

자주 사용하는 FeatureStyle 객체의 집합을 관리하기 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::IFeatureStyleCollection에 대한 상속 다이어그램 :
sgObject::IFeatureStyleCollection에 대한 협력 다이어그램:

Public 멤버 함수

int | GetSize ()
소속된 Symbolizer 객체의 개수를 반환한다. 더 자세히 ...
ISymbolizer * FeatureStyle ()
현재 인덱스에 해당하는 Symbolizer 객체를 반환한다. 더 자세히 ...
ISymbolizer * | Add (BSTR strStyleName, ISymbolizer *pdispStyle)
FeatureStyle 객체를 복사하여 생성한 후 해당 스타일 이름으로 추가한다. 더 자세히 ...
void | Remove (BSTR strStyleName)
해당 스타일 이름의 Symbolizer 객체를 제거한다. 더 자세히 ...
void | Close ()
FeatureStyleCollection의 사용을 종료한다. 더 자세히 ...
VARIANT_BOOL | MoveFirst ()
Symbolizer 리스트의 맨 앞으로 위치를 이동한다. 더 자세히 ...
VARIANT_BOOL | MoveNext ()
다음 Symbolizer 객체로 리스트의 위치를 이동한다. 더 자세히 ...
VARIANT_BOOL | MovePrevious ()
이전 Symbolizer 객체로 리스트의 위치를 이동한다. 더 자세히 ...
ISymbolizer * | GetFeatureStyle (VARIANT vtIdx)
해당 인덱스 위치의 Symbolizer 객체를 가져온다. 더 자세히 ...

상세한 설명

자주 사용하는 FeatureStyle 객체의 집합을 관리하기 위한 인터페이스를 제공한다.

멤버 함수 문서화

ISymbolizer* sgObject::IFeatureStyleCollection::Add | ( | BSTR | strStyleName,
 |  | ISymbolizer * | pdispStyle
 | ) |  |

FeatureStyle 객체를 복사하여 생성한 후 해당 스타일 이름으로 추가한다.

매개변수
strStyleName | - 스타일 이름. 스타일 이름은 FeatureStyleCollection 내에서 유일해야 한다. (식별자로 사용됨)
pdispStyle | - Symbolizer 객체를 가리키는 포인터
반환값
성공이면 새로운 FeatureStyle 객체를 가리키는 포인터, 그렇지 않으면 NULL
void sgObject::IFeatureStyleCollection::Close ( )

FeatureStyleCollection의 사용을 종료한다.

ISymbolizer* sgObject::IFeatureStyleCollection::FeatureStyle ( )

현재 인덱스에 해당하는 Symbolizer 객체를 반환한다.

ISymbolizer* sgObject::IFeatureStyleCollection::GetFeatureStyle ( VARIANT vtIdx )

해당 인덱스 위치의 Symbolizer 객체를 가져온다.

매개변수
vtIdx - 인덱스 번호
반환값
FeatureStyle 객체를 가리키는 포인터
int sgObject::IFeatureStyleCollection::GetSize ( )

소속된 Symbolizer 객체의 개수를 반환한다.

VARIANT_BOOL sgObject::IFeatureStyleCollection::MoveFirst ( )

Symbolizer 리스트의 맨 앞으로 위치를 이동한다.

반환값
성공하면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
VARIANT_BOOL sgObject::IFeatureStyleCollection::MoveNext ( )

다음 Symbolizer 객체로 리스트의 위치를 이동한다.

반환값
성공하면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
VARIANT_BOOL sgObject::IFeatureStyleCollection::MovePrevious ( )

이전 Symbolizer 객체로 리스트의 위치를 이동한다.

반환값
성공하면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
void sgObject::IFeatureStyleCollection::Remove ( BSTR strStyleName )

해당 스타일 이름의 Symbolizer 객체를 제거한다.

매개변수
strStyleName - 스타일 이름
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IFeatureStyleCollection
sgObject::IFeatureStyleCollection 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IFeatureStyleCollection (모든 상속된 멤버들도 포함합니다.)

Add(BSTR strStyleName, ISymbolizer *pdispStyle) | sgObject::IFeatureStyleCollection
Close() | sgObject::IFeatureStyleCollection
FeatureStyle() | sgObject::IFeatureStyleCollection
GetFeatureStyle(VARIANT vtIdx) | sgObject::IFeatureStyleCollection
GetSize() | sgObject::IFeatureStyleCollection
MoveFirst() | sgObject::IFeatureStyleCollection
MoveNext() | sgObject::IFeatureStyleCollection
MovePrevious() | sgObject::IFeatureStyleCollection
Remove(BSTR strStyleName) | sgObject::IFeatureStyleCollection
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IFeatureType 인터페이스 참조

  • IFeatureType
Public 멤버 함수 | 모든 멤버 목록
sgObject::IFeatureType 인터페이스 참조

Feature 객체가 어떤 타입인지를 나타내는 FeatureType 객체의 인터페이스를 제공한다. 더 자세히 ...

sgObject::IFeatureType에 대한 상속 다이어그램 :
sgObject::IFeatureType에 대한 협력 다이어그램:

Public 멤버 함수

BSTR | GetName ()
FeatureType 이름을 반환한다. 더 자세히 ...
void | SetName (BSTR bstrName)
FeatureType 이름을 설정한다. 더 자세히 ...
BSTR | GetPreferredPrefix ()
해당 FeatureType을 외부에 공개할 때 사용할 Namespace Prefix(그룹명)을 반환한다. 더 자세히 ...
void | SetPreferredPrefix (BSTR bstrVal)
해당 FeatureType을 외부에 공개할 때 사용할 Namespace Prefix(그룹명)을 설정한다. 더 자세히 ...
int | GetSize ()
Feature 객체에 저장된 일반 (속성) 정보의 개수(데이터베이스 레코드의 필드 수)를 반환한다. 더 자세히 ...
GeometryTypeEnum GetGeometryType ()
Feature 객체의 속성 중에 GeometryType의 속성 정보를 반환한다. 더 자세히 ...
void | SetGeometryType (GeometryTypeEnum eType)
Feature 객체의 속성 중에 GeometryType의 속성 정보를 설정한다. 더 자세히 ...
IFeatureAttributeDescriptor * | AttributeDescriptor ([in] VARIANT vtIdx)
해당 인덱스의 FeatureAttributeDescriptor 객체(Feature 객체에 저장된 일반 (속성) 정보 필드 한 개의 구조를 설명)를 반환한다. 더 자세히 ...
IFeatureAttributeDescriptor * DefaultShapeAttribute ()
기본 FeatureAttributeDescriptor 객체를 반환한다. 더 자세히 ...
IFeatureAttributeDescriptor * | Add ([in] IFeatureAttributeDescriptor *pFeatureType)
FeatureAttributeDescriptor 객체를 추가한다. (인덱스 번호는 최종 인덱스 + 1) 더 자세히 ...
VARIANT_BOOL | Remove ([in] VARIANT vtIdx)
해당 인덱스의 FeatureType을 삭제한다. 더 자세히 ...
IFeatureAttributeDescriptor * | SetAttribute ([in] VARIANT vtIdx, [in] IFeatureAttributeDescriptor *pFeatureType)
해당 인덱스의 FeatureAttributeDescriptor를 변경하고 FeatureAttributeDescriptor 객체를 반환한다. 더 자세히 ...
IFeatureType * Clone ()
복사된 FeatureType객체를 반환한다. 더 자세히 ...
int | GetIndex ([in]BSTR pszName)
명칭에 해당하는 인덱스를 반환한다. 더 자세히 ...

상세한 설명

Feature 객체가 어떤 타입인지를 나타내는 FeatureType 객체의 인터페이스를 제공한다.

Feature 객체는 실세계 객체의 일반 (속성) 정보 및 기하 정보를 관리한다. FeatureAttributeDescriptor 객체는 Feature 객체에 저장된 일반 (속성) 정보 필드 한 개의 구조를 설명한다. (데이터 타입 등) FeatureType 객체는 FeatureAttributeDescriptor 객체의 집합이다. (FeatureType 객체를 데이터베이스와 대응시키면 레코드의 구조를 나타내는 테이블 스키마에 대응된다) C API(linux, iOS, MacOS 등) : 중간이름 "FT"를 덧붙여서 "OGR_FT_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.FeatureType"

멤버 함수 문서화

IFeatureAttributeDescriptor* sgObject::IFeatureType::Add ( [in] IFeatureAttributeDescriptor * pFeatureType )

FeatureAttributeDescriptor 객체를 추가한다. (인덱스 번호는 최종 인덱스 + 1)

매개변수
pFeatureType - FeatureAttributeDescriptor 객체를 가리키는 포인터
IFeatureAttributeDescriptor* sgObject::IFeatureType::AttributeDescriptor ( [in] VARIANT vtIdx )

해당 인덱스의 FeatureAttributeDescriptor 객체(Feature 객체에 저장된 일반 (속성) 정보 필드 한 개의 구조를 설명)를 반환한다.

매개변수
vtIdx - 인덱스 번호
반환값
FeatureAttributeDescriptor 객체를 가리키는 포인터
IFeatureType* sgObject::IFeatureType::Clone ( )

복사된 FeatureType객체를 반환한다.

반환값
FeatureType 객체를 가리키는 포인터
IFeatureAttributeDescriptor* sgObject::IFeatureType::DefaultShapeAttribute ( )

기본 FeatureAttributeDescriptor 객체를 반환한다.

반환값
FeatureAttributeDescriptor 객체를 가리키는 포인터
GeometryTypeEnum sgObject::IFeatureType::GetGeometryType ( )

Feature 객체의 속성 중에 GeometryType의 속성 정보를 반환한다.

반환값
int sgObject::IFeatureType::GetIndex ( [in] BSTR pszName )

명칭에 해당하는 인덱스를 반환한다.

매개변수
pszName - 찾고자하는 인덱스의 명칭
반환값
명칭에 해당하는 인덱스
BSTR sgObject::IFeatureType::GetName ( )

FeatureType 이름을 반환한다.

반환값
FeatureType 이름
BSTR sgObject::IFeatureType::GetPreferredPrefix ( )

해당 FeatureType을 외부에 공개할 때 사용할 Namespace Prefix(그룹명)을 반환한다.

반환값
Namespace Prefix(그룹명)
int sgObject::IFeatureType::GetSize ( )

Feature 객체에 저장된 일반 (속성) 정보의 개수(데이터베이스 레코드의 필드 수)를 반환한다.

SetSize는 지원하지 않습니다.

반환값
일반 (속성) 정보의 개수(데이터베이스 레코드의 필드 수)
VARIANT_BOOL sgObject::IFeatureType::Remove ( [in] VARIANT vtIdx )

해당 인덱스의 FeatureType을 삭제한다.

매개변수
vtIdx - 인덱스 번호
반환값
삭제 성공 여부(성공했으면 VARIANT_TRUE, 실패했으면 VARIANT_FALSE).
IFeatureAttributeDescriptor* sgObject::IFeatureType::SetAttribute | ( | [in] VARIANT | vtIdx,
 |  | [in] IFeatureAttributeDescriptor * | pFeatureType
 | ) |  |

해당 인덱스의 FeatureAttributeDescriptor를 변경하고 FeatureAttributeDescriptor 객체를 반환한다.

매개변수
vtIdx | - 인덱스 번호
pFeatureType | - 새로운 FeatureAttributeDescriptor 포인터
반환값
FeatureAttributeDescriptor 객체를 가리키는 포인터
void sgObject::IFeatureType::SetGeometryType ( GeometryTypeEnum eType )

Feature 객체의 속성 중에 GeometryType의 속성 정보를 설정한다.

매개변수
eType -
void sgObject::IFeatureType::SetName ( BSTR bstrName )

FeatureType 이름을 설정한다.

매개변수
bstrName - FeatureType 이름
void sgObject::IFeatureType::SetPreferredPrefix ( BSTR bstrVal )

해당 FeatureType을 외부에 공개할 때 사용할 Namespace Prefix(그룹명)을 설정한다.

매개변수
bstrVal - Namespace Prefix(그룹명)
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IFeatureType
sgObject::IFeatureType 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IFeatureType (모든 상속된 멤버들도 포함합니다.)

Add([in] IFeatureAttributeDescriptor *pFeatureType) | sgObject::IFeatureType
AttributeDescriptor([in] VARIANT vtIdx) | sgObject::IFeatureType
Clone() | sgObject::IFeatureType
DefaultShapeAttribute() | sgObject::IFeatureType
GetGeometryType() | sgObject::IFeatureType
GetIndex([in]BSTR pszName) | sgObject::IFeatureType
GetName() | sgObject::IFeatureType
GetPreferredPrefix() | sgObject::IFeatureType
GetSize() | sgObject::IFeatureType
Remove([in] VARIANT vtIdx) | sgObject::IFeatureType
SetAttribute([in] VARIANT vtIdx, [in] IFeatureAttributeDescriptor *pFeatureType) | sgObject::IFeatureType
SetGeometryType(GeometryTypeEnum eType) | sgObject::IFeatureType
SetName(BSTR bstrName) | sgObject::IFeatureType
SetPreferredPrefix(BSTR bstrVal) | sgObject::IFeatureType
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IFeatureTypeStyle 인터페이스 참조

  • IFeatureTypeStyle
Public 멤버 함수 | 모든 멤버 목록
sgObject::IFeatureTypeStyle 인터페이스 참조

FeatureCollection내의 Feature에 대한 속성 및 공간 정보에 따른 표현 방법을 기술하기 위해 사용된다. 예) 주제도 더 자세히 ...

sgObject::IFeatureTypeStyle에 대한 상속 다이어그램 :
sgObject::IFeatureTypeStyle에 대한 협력 다이어그램:

Public 멤버 함수

int | GetSize ()
설정된 규정의 개수를 반환한다. 더 자세히 ...
FeatureTypeStyleEnum GetStyleType ()
설정된 규정의 채색 방법을 반환한다. 더 자세히 ...
void | SetStyleType (FeatureTypeStyleEnum eType)
채색 규정을 설정한다. 더 자세히 ...
ISymbolizer * GetElseFilterFeatureStyle ()
규정에 의해 설정되지 않는 값들의 심볼(스타일) 규정을 반환한다. 더 자세히 ...
void | SetElseFilterFeatureStyle ([in] ISymbolizer *pdsSymbol)
규정에 의해 설정되지 않는 값들의 심볼(스타일) 규정을 설정한다. 더 자세히 ...
void | AddRule ([in] IFeatureTypeStyleRule *pdsRule)
규정을 추가한다. 더 자세히 ...
IFeatureTypeStyleRule * | GetRule ([in] long idx)
해당 인덱스번호의 규정을 반환한다. 더 자세히 ...
void | RemoveRule ([in] IFeatureTypeStyleRule *pdsRule)
규정을 삭제한다. 더 자세히 ...
void | RemoveAll ()
설정한 모든 규정을 삭제한다. 더 자세히 ...
VARIANT_BOOL | GetElseFilterVisible ()
규정의 보기여부를 반환한다. 더 자세히 ...
void | SetElseFilterVisible (VARIANT_BOOL bVisible)
규정을 보기여부를 설정한다. 더 자세히 ...

상세한 설명

FeatureCollection내의 Feature에 대한 속성 및 공간 정보에 따른 표현 방법을 기술하기 위해 사용된다. 예) 주제도

내부의 FeatureTypeStyleRule에 의해 표현(Render) 여부 및 표현 방법(Symbolizer)이 결정된다. C API(linux, iOS, MacOS 등) : 중간이름 "FTS"를 덧붙여서 "OGR_FTS_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.FeatureTypeStyle"

멤버 함수 문서화

void sgObject::IFeatureTypeStyle::AddRule ( [in] IFeatureTypeStyleRule * pdsRule )

규정을 추가한다.

매개변수
pdsRule - 설정할 규정값
ISymbolizer* sgObject::IFeatureTypeStyle::GetElseFilterFeatureStyle ( )

규정에 의해 설정되지 않는 값들의 심볼(스타일) 규정을 반환한다.

VARIANT_BOOL sgObject::IFeatureTypeStyle::GetElseFilterVisible ( )

규정의 보기여부를 반환한다.

IFeatureTypeStyleRule* sgObject::IFeatureTypeStyle::GetRule ( [in] long idx )

해당 인덱스번호의 규정을 반환한다.

매개변수
idx - 규정 인덱스 번호(0부터 시작)
int sgObject::IFeatureTypeStyle::GetSize ( )

설정된 규정의 개수를 반환한다.

FeatureTypeStyleEnum sgObject::IFeatureTypeStyle::GetStyleType ( )

설정된 규정의 채색 방법을 반환한다.

void sgObject::IFeatureTypeStyle::RemoveAll ( )

설정한 모든 규정을 삭제한다.

void sgObject::IFeatureTypeStyle::RemoveRule ( [in] IFeatureTypeStyleRule * pdsRule )

규정을 삭제한다.

매개변수
pdsRule - 삭제할 규정값
void sgObject::IFeatureTypeStyle::SetElseFilterFeatureStyle ( [in] ISymbolizer * pdsSymbol )

규정에 의해 설정되지 않는 값들의 심볼(스타일) 규정을 설정한다.

매개변수
pdsSymbol - 설정할 심볼값
void sgObject::IFeatureTypeStyle::SetElseFilterVisible ( VARIANT_BOOL bVisible )

규정을 보기여부를 설정한다.

void sgObject::IFeatureTypeStyle::SetStyleType ( FeatureTypeStyleEnum eType )

채색 규정을 설정한다.

매개변수
eType - 설정할 채색 규정값
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IFeatureTypeStyle
sgObject::IFeatureTypeStyle 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IFeatureTypeStyle (모든 상속된 멤버들도 포함합니다.)

AddRule([in] IFeatureTypeStyleRule *pdsRule) | sgObject::IFeatureTypeStyle
GetElseFilterFeatureStyle() | sgObject::IFeatureTypeStyle
GetElseFilterVisible() | sgObject::IFeatureTypeStyle
GetRule([in] long idx) | sgObject::IFeatureTypeStyle
GetSize() | sgObject::IFeatureTypeStyle
GetStyleType() | sgObject::IFeatureTypeStyle
RemoveAll() | sgObject::IFeatureTypeStyle
RemoveRule([in] IFeatureTypeStyleRule *pdsRule) | sgObject::IFeatureTypeStyle
SetElseFilterFeatureStyle([in] ISymbolizer *pdsSymbol) | sgObject::IFeatureTypeStyle
SetElseFilterVisible(VARIANT_BOOL bVisible) | sgObject::IFeatureTypeStyle
SetStyleType(FeatureTypeStyleEnum eType) | sgObject::IFeatureTypeStyle
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IFeatureTypeStyleFactory 인터페이스 참조

  • IFeatureTypeStyleFactory
Public 멤버 함수 | 모든 멤버 목록
sgObject::IFeatureTypeStyleFactory 인터페이스 참조

FeatureStyle의 생성 및 Symbolizer등 스타일 관련 객체를 생성하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::IFeatureTypeStyleFactory에 대한 상속 다이어그램 :
sgObject::IFeatureTypeStyleFactory에 대한 협력 다이어그램:

Public 멤버 함수

IFeatureTypeStyle * CreateFeatureTypeStyle ()
FeatureTypeStyle 객체를 생성하여 반환한다. 더 자세히 ...
ISymbolizer * CreateSymbolizer ()
Symbolizer 객체를 생성하여 반환한다. 더 자세히 ...
IFill * CreateFillStyle ()
Fill 객체를 생성하여 반환한다. 더 자세히 ...
IStroke * CreateStrokeStyle ()
Stroke 객체를 생성하여 반환한다. 더 자세히 ...
IMark * CreateMarkStyle ()
Mark 객체를 생성하여 반환한다. 더 자세히 ...
IFont * CreateFontStyle ()
Font 객체를 생성하여 반환한다. 더 자세히 ...
IFeatureTypeStyleRule * CreateFeatureTypeStyleRule ()
FeatureTypeStyleRule 객체를 생성하여 반환한다. 더 자세히 ...
IFeatureTypeStyle * CreateFeatureTypeStyleFromXML ([in] BSTR bstrXmlFile)
FeatureTypeStyle 객체를 JTS(xml featuretypestyle file)파일을 이용하여 생성하여 반환한다. 더 자세히 ...

상세한 설명

FeatureStyle의 생성 및 Symbolizer등 스타일 관련 객체를 생성하는 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "FSF"를 덧붙여서 "OGR_FSF_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.FeatureTypeStyleFactory"

멤버 함수 문서화

IFeatureTypeStyle* sgObject::IFeatureTypeStyleFactory::CreateFeatureTypeStyle ( )

FeatureTypeStyle 객체를 생성하여 반환한다.

반환값
생성된 FeatureTypeStyle 객체의 포인터
IFeatureTypeStyle* sgObject::IFeatureTypeStyleFactory::CreateFeatureTypeStyleFromXML ( [in] BSTR bstrXmlFile )

FeatureTypeStyle 객체를 JTS(xml featuretypestyle file)파일을 이용하여 생성하여 반환한다.

반환값
생성된 FeatureTypeStyle 객체의 포인터
IFeatureTypeStyleRule* sgObject::IFeatureTypeStyleFactory::CreateFeatureTypeStyleRule ( )

FeatureTypeStyleRule 객체를 생성하여 반환한다.

반환값
생성된 FeatureTypeStyleRule 객체의 포인터
IFill* sgObject::IFeatureTypeStyleFactory::CreateFillStyle ( )

Fill 객체를 생성하여 반환한다.

반환값
생성된 Fill 객체의 포인터
IFont* sgObject::IFeatureTypeStyleFactory::CreateFontStyle ( )

Font 객체를 생성하여 반환한다.

반환값
생성된 Font 객체의 포인터
IMark* sgObject::IFeatureTypeStyleFactory::CreateMarkStyle ( )

Mark 객체를 생성하여 반환한다.

반환값
생성된 Mark 객체의 포인터
IStroke* sgObject::IFeatureTypeStyleFactory::CreateStrokeStyle ( )

Stroke 객체를 생성하여 반환한다.

반환값
생성된 Stroke 객체의 포인터
ISymbolizer* sgObject::IFeatureTypeStyleFactory::CreateSymbolizer ( )

Symbolizer 객체를 생성하여 반환한다.

반환값
생성된 Symbolizer 객체의 포인터
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IFeatureTypeStyleFactory
sgObject::IFeatureTypeStyleFactory 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IFeatureTypeStyleFactory (모든 상속된 멤버들도 포함합니다.)

CreateFeatureTypeStyle() | sgObject::IFeatureTypeStyleFactory
CreateFeatureTypeStyleFromXML([in] BSTR bstrXmlFile) | sgObject::IFeatureTypeStyleFactory
CreateFeatureTypeStyleRule() | sgObject::IFeatureTypeStyleFactory
CreateFillStyle() | sgObject::IFeatureTypeStyleFactory
CreateFontStyle() | sgObject::IFeatureTypeStyleFactory
CreateMarkStyle() | sgObject::IFeatureTypeStyleFactory
CreateStrokeStyle() | sgObject::IFeatureTypeStyleFactory
CreateSymbolizer() | sgObject::IFeatureTypeStyleFactory
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IFeatureTypeStyleRule 인터페이스 참조

  • IFeatureTypeStyleRule
Public 멤버 함수 | 모든 멤버 목록
sgObject::IFeatureTypeStyleRule 인터페이스 참조

FeatureTypeStyle의 규정을 정의하며 속성 및 스케일에 따른 표현 인터페이스를 제공한다. 더 자세히 ...

sgObject::IFeatureTypeStyleRule에 대한 상속 다이어그램 :
sgObject::IFeatureTypeStyleRule에 대한 협력 다이어그램:

Public 멤버 함수

BSTR | GetTitle ()
설정 규정의 제목 더 자세히 ...
void | SetTitle (BSTR szVal)
BSTR | GetFilter ()
규정의 조건문으로 SQL문의 Where조건과 유사 더 자세히 ...
void | SetFilter (BSTR szVal)
DOUBLE | GetMinScaleDenominator ()
해당 규정이 적용되는 최소 화면 스케일 더 자세히 ...
void | SetMinScaleDenominator (DOUBLE dVal)
DOUBLE | GetMaxScaleDenominator ()
해당 규정이 적용되는 최대 화면 스케일 더 자세히 ...
void | SetMaxScaleDenominator (DOUBLE dVal)
ISymbolizer * GetSymbolizer ()
규정에 해당하는 Feature를 그리기 위한 심볼(스타일) 더 자세히 ...
void | SetSymbolizer (ISymbolizer *pdspVal)
void | SetFeatureStyleColor (OLE_COLOR color)
규정에 해당하는 Feature를 그리기 위한 기본 색상(기본 심볼(스타일)타입 사용)을 설정한다. 더 자세히 ...
VARIANT_BOOL | IsValidFilter (IFeatureType *pdsFtType, IFeature *pdsFt)
해당 Feature가 규정에 적용된 필터값에 유효한지 여부를 반환한다. 더 자세히 ...
IFeatureTypeStyle * GetFeatureTypeStyle ()
규정이 포함된 상위 FeatureTypeStyle을 반환한다. 더 자세히 ...
IFeatureTypeStyleRule * Clone ()
규정의 복제본을 반환한다. 더 자세히 ...
VARIANT_BOOL | GetVisible ()
규정의 보기여부를 반환한다. 더 자세히 ...
void | SetVisible (VARIANT_BOOL bVisible)
규정을 보기여부를 설정한다. 더 자세히 ...

상세한 설명

FeatureTypeStyle의 규정을 정의하며 속성 및 스케일에 따른 표현 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "FTR"를 덧붙여서 "OGR_FTR_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.FeatureTypeStyleRule"

멤버 함수 문서화

IFeatureTypeStyleRule* sgObject::IFeatureTypeStyleRule::Clone ( )

규정의 복제본을 반환한다.

IFeatureTypeStyle* sgObject::IFeatureTypeStyleRule::GetFeatureTypeStyle ( )

규정이 포함된 상위 FeatureTypeStyle을 반환한다.

BSTR sgObject::IFeatureTypeStyleRule::GetFilter ( )

규정의 조건문으로 SQL문의 Where조건과 유사

DOUBLE sgObject::IFeatureTypeStyleRule::GetMaxScaleDenominator ( )

해당 규정이 적용되는 최대 화면 스케일

DOUBLE sgObject::IFeatureTypeStyleRule::GetMinScaleDenominator ( )

해당 규정이 적용되는 최소 화면 스케일

ISymbolizer* sgObject::IFeatureTypeStyleRule::GetSymbolizer ( )

규정에 해당하는 Feature를 그리기 위한 심볼(스타일)

BSTR sgObject::IFeatureTypeStyleRule::GetTitle ( )

설정 규정의 제목

VARIANT_BOOL sgObject::IFeatureTypeStyleRule::GetVisible ( )

규정의 보기여부를 반환한다.

VARIANT_BOOL sgObject::IFeatureTypeStyleRule::IsValidFilter | ( | IFeatureType * | pdsFtType,
 |  | IFeature * | pdsFt
 | ) |  |

해당 Feature가 규정에 적용된 필터값에 유효한지 여부를 반환한다.

매개변수
pdsFtType | - 해당 Feature의 스키마 객체(FeatureType)
pdsFt | - 유효 여부를 판단할 Feature 객체
반환값
TRUE/FALSE - 유효 여부
void sgObject::IFeatureTypeStyleRule::SetFeatureStyleColor ( OLE_COLOR color )

규정에 해당하는 Feature를 그리기 위한 기본 색상(기본 심볼(스타일)타입 사용)을 설정한다.

매개변수
color - 기본 색상
void sgObject::IFeatureTypeStyleRule::SetFilter ( BSTR szVal )
void sgObject::IFeatureTypeStyleRule::SetMaxScaleDenominator ( DOUBLE dVal )
void sgObject::IFeatureTypeStyleRule::SetMinScaleDenominator ( DOUBLE dVal )
void sgObject::IFeatureTypeStyleRule::SetSymbolizer ( ISymbolizer * pdspVal )
void sgObject::IFeatureTypeStyleRule::SetTitle ( BSTR szVal )
void sgObject::IFeatureTypeStyleRule::SetVisible ( VARIANT_BOOL bVisible )

규정을 보기여부를 설정한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IFeatureTypeStyleRule
sgObject::IFeatureTypeStyleRule 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IFeatureTypeStyleRule (모든 상속된 멤버들도 포함합니다.)

Clone() | sgObject::IFeatureTypeStyleRule
GetFeatureTypeStyle() | sgObject::IFeatureTypeStyleRule
GetFilter() | sgObject::IFeatureTypeStyleRule
GetMaxScaleDenominator() | sgObject::IFeatureTypeStyleRule
GetMinScaleDenominator() | sgObject::IFeatureTypeStyleRule
GetSymbolizer() | sgObject::IFeatureTypeStyleRule
GetTitle() | sgObject::IFeatureTypeStyleRule
GetVisible() | sgObject::IFeatureTypeStyleRule
IsValidFilter(IFeatureType *pdsFtType, IFeature *pdsFt) | sgObject::IFeatureTypeStyleRule
SetFeatureStyleColor(OLE_COLOR color) | sgObject::IFeatureTypeStyleRule
SetFilter(BSTR szVal) | sgObject::IFeatureTypeStyleRule
SetMaxScaleDenominator(DOUBLE dVal) | sgObject::IFeatureTypeStyleRule
SetMinScaleDenominator(DOUBLE dVal) | sgObject::IFeatureTypeStyleRule
SetSymbolizer(ISymbolizer *pdspVal) | sgObject::IFeatureTypeStyleRule
SetTitle(BSTR szVal) | sgObject::IFeatureTypeStyleRule
SetVisible(VARIANT_BOOL bVisible) | sgObject::IFeatureTypeStyleRule
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IFill 인터페이스 참조

  • IFill
Public 멤버 함수 | 모든 멤버 목록
sgObject::IFill 인터페이스 참조

Brush의 스타일을 표현하기 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::IFill에 대한 상속 다이어그램 :
sgObject::IFill에 대한 협력 다이어그램:

Public 멤버 함수

BSTR | GetStyleString ()
면 스타일을 문자열 형태로 반환한다. 더 자세히 ...
BSTR | GetForeColor ()
면의 색상을 문자열 형태로 반환한다. 더 자세히 ...
void | SetForeColor (BSTR bstrColor)
면의 색상을 문자열 형태로 설정한다. 더 자세히 ...
BSTR | GetBackColor ()
면의 바탕 색상을 문자열 형태로 반환한다. 더 자세히 ...
void | SetBackColor (BSTR bstrColor)
면의 바탕 색상을 문자열 형태로 설정한다. 더 자세히 ...
BSTR | GetID ()
면의 ID를 반환한다. 더 자세히 ...
void | SetID (BSTR bstrId)
면의 ID를 설정한다. 더 자세히 ...
double | GetAngle ()
면 패턴의 회전 각도(도, 반시계 방향)를 반환한다. 더 자세히 ...
void | SetAngle (double dfAngle)
면 패턴의 회전 각도(도, 반시계 방향)를 설정한다. 더 자세히 ...
double | GetSize ()
면 패턴의 크기를 반환한다. 더 자세히 ...
void | SetSize (double dfSize)
면 패턴의 크기를 설정한다. 더 자세히 ...
double | GetSpacingX ()
면 스타일의 X축 간격을 반환한다. 더 자세히 ...
void | SetSpacingX (double dfX)
면 스타일의 X축 간격을 설정한다. 더 자세히 ...
double | GetSpacingY ()
면 스타일의 Y축 간격을 반환한다. 더 자세히 ...
void | SetSpacingY (double dfY)
면 스타일의 Y축 간격을 설정한다. 더 자세히 ...
int | GetPriority ()
우선적으로 그려야할 순서를 반환한다. 더 자세히 ...
void | SetPriority (int nPriority)
우선적으로 그려야할 순서를 설정한다. 더 자세히 ...

상세한 설명

Brush의 스타일을 표현하기 위한 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "FI"를 덧붙여서 "OGR_FI_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Fill"

멤버 함수 문서화

double sgObject::IFill::GetAngle ( )

면 패턴의 회전 각도(도, 반시계 방향)를 반환한다.

BSTR sgObject::IFill::GetBackColor ( )

면의 바탕 색상을 문자열 형태로 반환한다.

BSTR sgObject::IFill::GetForeColor ( )

면의 색상을 문자열 형태로 반환한다.

BSTR sgObject::IFill::GetID ( )

면의 ID를 반환한다.

int sgObject::IFill::GetPriority ( )

우선적으로 그려야할 순서를 반환한다.

double sgObject::IFill::GetSize ( )

면 패턴의 크기를 반환한다.

double sgObject::IFill::GetSpacingX ( )

면 스타일의 X축 간격을 반환한다.

double sgObject::IFill::GetSpacingY ( )

면 스타일의 Y축 간격을 반환한다.

BSTR sgObject::IFill::GetStyleString ( )

면 스타일을 문자열 형태로 반환한다.

void sgObject::IFill::SetAngle ( double dfAngle )

면 패턴의 회전 각도(도, 반시계 방향)를 설정한다.

void sgObject::IFill::SetBackColor ( BSTR bstrColor )

면의 바탕 색상을 문자열 형태로 설정한다.

void sgObject::IFill::SetForeColor ( BSTR bstrColor )

면의 색상을 문자열 형태로 설정한다.

void sgObject::IFill::SetID ( BSTR bstrId )

면의 ID를 설정한다.

void sgObject::IFill::SetPriority ( int nPriority )

우선적으로 그려야할 순서를 설정한다.

void sgObject::IFill::SetSize ( double dfSize )

면 패턴의 크기를 설정한다.

void sgObject::IFill::SetSpacingX ( double dfX )

면 스타일의 X축 간격을 설정한다.

void sgObject::IFill::SetSpacingY ( double dfY )

면 스타일의 Y축 간격을 설정한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IFill
sgObject::IFill 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IFill (모든 상속된 멤버들도 포함합니다.)

GetAngle() | sgObject::IFill
GetBackColor() | sgObject::IFill
GetForeColor() | sgObject::IFill
GetID() | sgObject::IFill
GetPriority() | sgObject::IFill
GetSize() | sgObject::IFill
GetSpacingX() | sgObject::IFill
GetSpacingY() | sgObject::IFill
GetStyleString() | sgObject::IFill
SetAngle(double dfAngle) | sgObject::IFill
SetBackColor(BSTR bstrColor) | sgObject::IFill
SetForeColor(BSTR bstrColor) | sgObject::IFill
SetID(BSTR bstrId) | sgObject::IFill
SetPriority(int nPriority) | sgObject::IFill
SetSize(double dfSize) | sgObject::IFill
SetSpacingX(double dfX) | sgObject::IFill
SetSpacingY(double dfY) | sgObject::IFill
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IFont 인터페이스 참조

  • IFont
Public 멤버 함수 | 모든 멤버 목록
sgObject::IFont 인터페이스 참조

글꼴의 스타일을 표현하기 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::IFont에 대한 상속 다이어그램 :
sgObject::IFont에 대한 협력 다이어그램:

Public 멤버 함수

BSTR | GetStyleString ()
텍스트 스타일을 문자열 형태로 반환한다. 더 자세히 ...
BSTR | GetFontName ()
텍스트의 글꼴을 반환한다. 더 자세히 ...
void | SetFontName (BSTR bstrFontName)
텍스트의 글꼴을 설정한다. 더 자세히 ...
double | GetSize ()
글꼴의 크기를 반환한다. 더 자세히 ...
void | SetSize (double dfSize)
글꼴의 크기를 설정한다. 더 자세히 ...
BSTR | GetTextString ()
고정적으로 표현될 텍스트를 반환한다. 더 자세히 ...
void | SetTextString (BSTR bstrText)
고정적으로 표현될 텍스트를 설정한다. 더 자세히 ...
double | GetAngle ()
회전 각도(도, 반시계 방향)를 반환한다. 더 자세히 ...
void | SetAngle (double dfAngle)
회전 각도(도, 반시계 방향)를 설정한다. 더 자세히 ...
BSTR | GetForeColor ()
글꼴의 색상을 문자열 형태로 반환한다. 더 자세히 ...
void | SetForeColor (BSTR bstrColor)
글꼴의 색상을 문자열 형태로 설정한다. 더 자세히 ...
BSTR | GetBackColor ()
글꼴의 배경 색상을 문자열 형태로 반환한다. 더 자세히 ...
void | SetBackColor (BSTR bstrColor)
글꼴의 색상을 문자열 형태로 설정한다. 더 자세히 ...
BSTR | GetPlacement ()
텍스트를 어떤 형상을 기준으로 그릴지 여부를 반환한다. 더 자세히 ...
void | SetPlacement (BSTR bstrPlacement)
텍스트를 어떤 형상을 기준으로 그릴지 여부를 설정한다. 더 자세히 ...
int | GetAnchor ()
기하를 기준으로한 텍스트 표현 위치를 반환한다. 더 자세히 ...
void | SetAnchor (int nAnchor)
기하를 기준으로한 텍스트 표현 위치를 설정한다. 더 자세히 ...
double | GetSpacingX ()
텍스트 스타일의 X축 간격을 반환한다. 더 자세히 ...
void | SetSpacingX (double dfX)
텍스트 스타일의 X축 간격을 설정한다. 더 자세히 ...
double | GetSpacingY ()
텍스트 스타일의 Y축 간격을 반환한다. 더 자세히 ...
void | SetSpacingY (double dfY)
텍스트 스타일의 Y축 간격을 설정한다. 더 자세히 ...
double | GetPerp ()
텍스트 스타일의 Perp을 반환한다. 더 자세히 ...
void | SetPerp (double dfPerp)
텍스트 스타일의 Perp을 설정환한다. 더 자세히 ...
int | GetBold ()
글꼴을 굵게 표현할지 여부를 반환한다. 더 자세히 ...
void | SetBold (int bBold)
글꼴을 굵게 표현할지 여부를 설정한다. 더 자세히 ...
int | GetItalic ()
글꼴을 기울임꼴로 표현할지 여부를 반환한다. 더 자세히 ...
void | SetItalic (int bItalic)
글꼴을 기울임꼴로 표현할지 여부를 설정한다. 더 자세히 ...
int | GetUnderline ()
밑줄을 표현할지 여부를 반환한다. 더 자세히 ...
void | SetUnderline (int bUnderline)
밑줄을 표현할지 여부를 설정한다. 더 자세히 ...
int | GetPriority ()
그려야하는 순서를 정의하는 값을 반환한다. 더 자세히 ...
void | SetPriority (int nPriority)
그려야하는 순서를 정의하는 값을 설정한다. 더 자세히 ...
int | GetStrikeout ()
취소선을 표현할지 여부를 반환한다. 더 자세히 ...
void | SetStrikeout (int bStrikeout)
취소선을 표현할지 여부를 설정한다. 더 자세히 ...
double | GetStretch ()
텍스트의 Stretch를 반환한다. 더 자세히 ...
void | SetStretch (double dfStretch)
텍스트의 Stretch를 설정한다. 더 자세히 ...
BSTR | GetAdjustmentHor ()
취소선을 수평 조절값을 반환한다. 더 자세히 ...
void | SetAdjustmentHor (BSTR bstrAdjustmentHor)
취소선을 수평 조절값을 설정한다. 더 자세히 ...
BSTR | GetAdjustmentVert ()
취소선을 수직 조절값을 반환한다. 더 자세히 ...
void | SetAdjustmentVert (BSTR bstrAdjustmentVert)
취소선을 수직 조절값을 설정한다. 더 자세히 ...
BSTR | GetShadowColor ()
그림자 색상을 반환한다. 더 자세히 ...
void | SetShadowColor (BSTR vShadowColor)
그림자 색상을 설정한다. 더 자세히 ...
int | GetShadowSpacingX ()
그림자의 X축 간격을 반환한다. 더 자세히 ...
void | SetShadowSpacingX (int nInterval)
그림자의 X축 간격을 설정한다. 더 자세히 ...
int | GetShadowSpacingY ()
그림자의 Y축 간격을 반환한다. 더 자세히 ...
void | SetShadowSpacingY (int nInterval)
그림자의 Y축 간격을 설정한다. 더 자세히 ...
BSTR | GetOutlineColor ()
윤곽선의 색상을 문자열 형태로 반환한다. 더 자세히 ...
void | SetOutlineColor (BSTR bstrOutlineColor)
윤곽선의 색상을 문자열 형태로 설정한다. 더 자세히 ...
int | GetOutlineWidth ()
윤곽선의 크기를 반환한다. 더 자세히 ...
void | SetOutlineWidth (int nInterval)
윤곽선의 크기를 설정한다. 더 자세히 ...
int | GetShadowWidth ()
그림자의 두께를 반환한다. 더 자세히 ...
void | SetShadowWidth (int nInterval)
그림자의 두께를 설정한다. 더 자세히 ...
double | GetBoxPaddingX ()
배경 박스를 이동할 X 위치를 반환한다. 더 자세히 ...
void | SetBoxPaddingX (double dX)
배경 박스를 이동할 X 위치를 설정한다. 더 자세히 ...
double | GetBoxPaddingY ()
배경 박스를 이동할 Y 위치를 반환한다. 더 자세히 ...
void | SetBoxPaddingY (double dY)
배경 박스를 이동할 Y 위치를 설정한다. 더 자세히 ...
BSTR | GetTextAngle ()
회전각 필드명을 반환한다. 더 자세히 ...
void | SetTextAngle (BSTR bstrAngleField)
회전각 필드명을 설정한다. 더 자세히 ...

상세한 설명

글꼴의 스타일을 표현하기 위한 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "FO"를 덧붙여서 "OGR_FO_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Font"

멤버 함수 문서화

BSTR sgObject::IFont::GetAdjustmentHor ( )

취소선을 수평 조절값을 반환한다.

BSTR sgObject::IFont::GetAdjustmentVert ( )

취소선을 수직 조절값을 반환한다.

int sgObject::IFont::GetAnchor ( )

기하를 기준으로한 텍스트 표현 위치를 반환한다.

double sgObject::IFont::GetAngle ( )

회전 각도(도, 반시계 방향)를 반환한다.

BSTR sgObject::IFont::GetBackColor ( )

글꼴의 배경 색상을 문자열 형태로 반환한다.

int sgObject::IFont::GetBold ( )

글꼴을 굵게 표현할지 여부를 반환한다.

double sgObject::IFont::GetBoxPaddingX ( )

배경 박스를 이동할 X 위치를 반환한다.

double sgObject::IFont::GetBoxPaddingY ( )

배경 박스를 이동할 Y 위치를 반환한다.

BSTR sgObject::IFont::GetFontName ( )

텍스트의 글꼴을 반환한다.

BSTR sgObject::IFont::GetForeColor ( )

글꼴의 색상을 문자열 형태로 반환한다.

int sgObject::IFont::GetItalic ( )

글꼴을 기울임꼴로 표현할지 여부를 반환한다.

BSTR sgObject::IFont::GetOutlineColor ( )

윤곽선의 색상을 문자열 형태로 반환한다.

int sgObject::IFont::GetOutlineWidth ( )

윤곽선의 크기를 반환한다.

double sgObject::IFont::GetPerp ( )

텍스트 스타일의 Perp을 반환한다.

BSTR sgObject::IFont::GetPlacement ( )

텍스트를 어떤 형상을 기준으로 그릴지 여부를 반환한다.

int sgObject::IFont::GetPriority ( )

그려야하는 순서를 정의하는 값을 반환한다.

BSTR sgObject::IFont::GetShadowColor ( )

그림자 색상을 반환한다.

int sgObject::IFont::GetShadowSpacingX ( )

그림자의 X축 간격을 반환한다.

int sgObject::IFont::GetShadowSpacingY ( )

그림자의 Y축 간격을 반환한다.

int sgObject::IFont::GetShadowWidth ( )

그림자의 두께를 반환한다.

double sgObject::IFont::GetSize ( )

글꼴의 크기를 반환한다.

double sgObject::IFont::GetSpacingX ( )

텍스트 스타일의 X축 간격을 반환한다.

double sgObject::IFont::GetSpacingY ( )

텍스트 스타일의 Y축 간격을 반환한다.

double sgObject::IFont::GetStretch ( )

텍스트의 Stretch를 반환한다.

int sgObject::IFont::GetStrikeout ( )

취소선을 표현할지 여부를 반환한다.

BSTR sgObject::IFont::GetStyleString ( )

텍스트 스타일을 문자열 형태로 반환한다.

BSTR sgObject::IFont::GetTextAngle ( )

회전각 필드명을 반환한다.

BSTR sgObject::IFont::GetTextString ( )

고정적으로 표현될 텍스트를 반환한다.

int sgObject::IFont::GetUnderline ( )

밑줄을 표현할지 여부를 반환한다.

void sgObject::IFont::SetAdjustmentHor ( BSTR bstrAdjustmentHor )

취소선을 수평 조절값을 설정한다.

void sgObject::IFont::SetAdjustmentVert ( BSTR bstrAdjustmentVert )

취소선을 수직 조절값을 설정한다.

void sgObject::IFont::SetAnchor ( int nAnchor )

기하를 기준으로한 텍스트 표현 위치를 설정한다.

void sgObject::IFont::SetAngle ( double dfAngle )

회전 각도(도, 반시계 방향)를 설정한다.

void sgObject::IFont::SetBackColor ( BSTR bstrColor )

글꼴의 색상을 문자열 형태로 설정한다.

void sgObject::IFont::SetBold ( int bBold )

글꼴을 굵게 표현할지 여부를 설정한다.

void sgObject::IFont::SetBoxPaddingX ( double dX )

배경 박스를 이동할 X 위치를 설정한다.

void sgObject::IFont::SetBoxPaddingY ( double dY )

배경 박스를 이동할 Y 위치를 설정한다.

void sgObject::IFont::SetFontName ( BSTR bstrFontName )

텍스트의 글꼴을 설정한다.

void sgObject::IFont::SetForeColor ( BSTR bstrColor )

글꼴의 색상을 문자열 형태로 설정한다.

void sgObject::IFont::SetItalic ( int bItalic )

글꼴을 기울임꼴로 표현할지 여부를 설정한다.

void sgObject::IFont::SetOutlineColor ( BSTR bstrOutlineColor )

윤곽선의 색상을 문자열 형태로 설정한다.

void sgObject::IFont::SetOutlineWidth ( int nInterval )

윤곽선의 크기를 설정한다.

void sgObject::IFont::SetPerp ( double dfPerp )

텍스트 스타일의 Perp을 설정환한다.

void sgObject::IFont::SetPlacement ( BSTR bstrPlacement )

텍스트를 어떤 형상을 기준으로 그릴지 여부를 설정한다.

void sgObject::IFont::SetPriority ( int nPriority )

그려야하는 순서를 정의하는 값을 설정한다.

void sgObject::IFont::SetShadowColor ( BSTR vShadowColor )

그림자 색상을 설정한다.

void sgObject::IFont::SetShadowSpacingX ( int nInterval )

그림자의 X축 간격을 설정한다.

void sgObject::IFont::SetShadowSpacingY ( int nInterval )

그림자의 Y축 간격을 설정한다.

void sgObject::IFont::SetShadowWidth ( int nInterval )

그림자의 두께를 설정한다.

void sgObject::IFont::SetSize ( double dfSize )

글꼴의 크기를 설정한다.

void sgObject::IFont::SetSpacingX ( double dfX )

텍스트 스타일의 X축 간격을 설정한다.

void sgObject::IFont::SetSpacingY ( double dfY )

텍스트 스타일의 Y축 간격을 설정한다.

void sgObject::IFont::SetStretch ( double dfStretch )

텍스트의 Stretch를 설정한다.

void sgObject::IFont::SetStrikeout ( int bStrikeout )

취소선을 표현할지 여부를 설정한다.

void sgObject::IFont::SetTextAngle ( BSTR bstrAngleField )

회전각 필드명을 설정한다.

void sgObject::IFont::SetTextString ( BSTR bstrText )

고정적으로 표현될 텍스트를 설정한다.

void sgObject::IFont::SetUnderline ( int bUnderline )

밑줄을 표현할지 여부를 설정한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IFont
sgObject::IFont 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IFont (모든 상속된 멤버들도 포함합니다.)

GetAdjustmentHor() | sgObject::IFont
GetAdjustmentVert() | sgObject::IFont
GetAnchor() | sgObject::IFont
GetAngle() | sgObject::IFont
GetBackColor() | sgObject::IFont
GetBold() | sgObject::IFont
GetBoxPaddingX() | sgObject::IFont
GetBoxPaddingY() | sgObject::IFont
GetFontName() | sgObject::IFont
GetForeColor() | sgObject::IFont
GetItalic() | sgObject::IFont
GetOutlineColor() | sgObject::IFont
GetOutlineWidth() | sgObject::IFont
GetPerp() | sgObject::IFont
GetPlacement() | sgObject::IFont
GetPriority() | sgObject::IFont
GetShadowColor() | sgObject::IFont
GetShadowSpacingX() | sgObject::IFont
GetShadowSpacingY() | sgObject::IFont
GetShadowWidth() | sgObject::IFont
GetSize() | sgObject::IFont
GetSpacingX() | sgObject::IFont
GetSpacingY() | sgObject::IFont
GetStretch() | sgObject::IFont
GetStrikeout() | sgObject::IFont
GetStyleString() | sgObject::IFont
GetTextAngle() | sgObject::IFont
GetTextString() | sgObject::IFont
GetUnderline() | sgObject::IFont
SetAdjustmentHor(BSTR bstrAdjustmentHor) | sgObject::IFont
SetAdjustmentVert(BSTR bstrAdjustmentVert) | sgObject::IFont
SetAnchor(int nAnchor) | sgObject::IFont
SetAngle(double dfAngle) | sgObject::IFont
SetBackColor(BSTR bstrColor) | sgObject::IFont
SetBold(int bBold) | sgObject::IFont
SetBoxPaddingX(double dX) | sgObject::IFont
SetBoxPaddingY(double dY) | sgObject::IFont
SetFontName(BSTR bstrFontName) | sgObject::IFont
SetForeColor(BSTR bstrColor) | sgObject::IFont
SetItalic(int bItalic) | sgObject::IFont
SetOutlineColor(BSTR bstrOutlineColor) | sgObject::IFont
SetOutlineWidth(int nInterval) | sgObject::IFont
SetPerp(double dfPerp) | sgObject::IFont
SetPlacement(BSTR bstrPlacement) | sgObject::IFont
SetPriority(int nPriority) | sgObject::IFont
SetShadowColor(BSTR vShadowColor) | sgObject::IFont
SetShadowSpacingX(int nInterval) | sgObject::IFont
SetShadowSpacingY(int nInterval) | sgObject::IFont
SetShadowWidth(int nInterval) | sgObject::IFont
SetSize(double dfSize) | sgObject::IFont
SetSpacingX(double dfX) | sgObject::IFont
SetSpacingY(double dfY) | sgObject::IFont
SetStretch(double dfStretch) | sgObject::IFont
SetStrikeout(int bStrikeout) | sgObject::IFont
SetTextAngle(BSTR bstrAngleField) | sgObject::IFont
SetTextString(BSTR bstrText) | sgObject::IFont
SetUnderline(int bUnderline) | sgObject::IFont
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGenerator3D 인터페이스 참조

  • IGenerator3D
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGenerator3D 인터페이스 참조

2D를 3D로 변환하기 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::IGenerator3D에 대한 상속 다이어그램 :
sgObject::IGenerator3D에 대한 협력 다이어그램:

Public 멤버 함수

BSTR | GetHeightAttribute ()
높이 값을 갖는 필드명을 반환한다. 더 자세히 ...
void | SetHeightAttribute ([in] BSTR val)
BSTR | GetRadiusAttribute ()
반지름 값을 갖는 필드명을 반환한다. 더 자세히 ...
void | SetRadiusAttribute ([in] BSTR val)
BSTR | GetTypeAttribute ()
3D 변환유형 값을 갖는 필드명을 반환한다. 더 자세히 ...
void | SetTypeAttribute ([in] BSTR val)
BSTR | GetZAttribute ()
Z좌표 값을 갖는 필드명을 반환한다. 더 자세히 ...
void | SetZAttribute ([in] BSTR val)
double | GetDefaultValueHeight ()
높이 기본값을 반환한다. 더 자세히 ...
void | SetDefaultValueHeight ([in] double val)
double | GetDefaultValueRadius ()
반지름 기본값을 반환한다. 더 자세히 ...
void | SetDefaultValueRadius ([in] double val)
int | GetDefaultValueType ()
3D 변환유형 기본값을 반환한다. 더 자세히 ...
void | SetDefaultValueType ([in] int val)
double | GetDefaultValueZ ()
Z 기본값을 반환한다. 더 자세히 ...
void | SetDefaultValueZ ([in] double val)

상세한 설명

2D를 3D로 변환하기 위한 인터페이스를 제공한다.

멤버 함수 문서화

double sgObject::IGenerator3D::GetDefaultValueHeight ( )

높이 기본값을 반환한다.

반환값
높이 기본값
double sgObject::IGenerator3D::GetDefaultValueRadius ( )

반지름 기본값을 반환한다.

반환값
반지름 기본값
int sgObject::IGenerator3D::GetDefaultValueType ( )

3D 변환유형 기본값을 반환한다.

반환값
3D 변환유형 기본값
double sgObject::IGenerator3D::GetDefaultValueZ ( )

Z 기본값을 반환한다.

반환값
Z 기본값
BSTR sgObject::IGenerator3D::GetHeightAttribute ( )

높이 값을 갖는 필드명을 반환한다.

반환값
높이 값을 갖는 필드명
BSTR sgObject::IGenerator3D::GetRadiusAttribute ( )

반지름 값을 갖는 필드명을 반환한다.

반환값
반지름 값을 갖는 필드명
BSTR sgObject::IGenerator3D::GetTypeAttribute ( )

3D 변환유형 값을 갖는 필드명을 반환한다.

반환값
3D 변환유형 값을 갖는 필드명
BSTR sgObject::IGenerator3D::GetZAttribute ( )

Z좌표 값을 갖는 필드명을 반환한다.

반환값
Z좌표 값을 갖는 필드명
void sgObject::IGenerator3D::SetDefaultValueHeight ( [in] double val )
void sgObject::IGenerator3D::SetDefaultValueRadius ( [in] double val )
void sgObject::IGenerator3D::SetDefaultValueType ( [in] int val )
void sgObject::IGenerator3D::SetDefaultValueZ ( [in] double val )
void sgObject::IGenerator3D::SetHeightAttribute ( [in] BSTR val )
void sgObject::IGenerator3D::SetRadiusAttribute ( [in] BSTR val )
void sgObject::IGenerator3D::SetTypeAttribute ( [in] BSTR val )
void sgObject::IGenerator3D::SetZAttribute ( [in] BSTR val )
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGenerator3D
sgObject::IGenerator3D 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGenerator3D (모든 상속된 멤버들도 포함합니다.)

GetDefaultValueHeight() | sgObject::IGenerator3D
GetDefaultValueRadius() | sgObject::IGenerator3D
GetDefaultValueType() | sgObject::IGenerator3D
GetDefaultValueZ() | sgObject::IGenerator3D
GetHeightAttribute() | sgObject::IGenerator3D
GetRadiusAttribute() | sgObject::IGenerator3D
GetTypeAttribute() | sgObject::IGenerator3D
GetZAttribute() | sgObject::IGenerator3D
SetDefaultValueHeight([in] double val) | sgObject::IGenerator3D
SetDefaultValueRadius([in] double val) | sgObject::IGenerator3D
SetDefaultValueType([in] int val) | sgObject::IGenerator3D
SetDefaultValueZ([in] double val) | sgObject::IGenerator3D
SetHeightAttribute([in] BSTR val) | sgObject::IGenerator3D
SetRadiusAttribute([in] BSTR val) | sgObject::IGenerator3D
SetTypeAttribute([in] BSTR val) | sgObject::IGenerator3D
SetZAttribute([in] BSTR val) | sgObject::IGenerator3D
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGeodeticSpatialReference 인터페이스 참조

  • IGeodeticSpatialReference
모든 멤버 목록
sgObject::IGeodeticSpatialReference 인터페이스 참조

IGeodeticSpatialReference 인터페이스 더 자세히 ...

sgObject::IGeodeticSpatialReference에 대한 상속 다이어그램 :
sgObject::IGeodeticSpatialReference에 대한 협력 다이어그램:

추가로 상속된 멤버들

- sgObject::ISpatialReference(으)로부터 상속된 Public 멤버 함수
void | Destroy ()
VARIANT_BOOL | ImportFromWkt ([in] BSTR strWkt)
VARIANT_BOOL | ImportFromProj4 ([in] BSTR strProj4)
BSTR | ExportToWkt ()
BSTR | ExportToProj4 ()
VARIANT_BOOL | SetFromUserInput ([in] BSTR strInput)
void | ShowSRSWidget ()
BSTR | GetEPSGName ()
void | SetAuthority ([in] BSTR strTargetKey, [in] BSTR strAuthority, [in] int nCode)
BSTR | GetAuthorityCode ([in] BSTR strTargetKey)
BSTR | GetAuthorityName ([in] BSTR strTargetKey)
VARIANT_BOOL | IsSame ([in] ISpatialReference *otherCRS)
ISpatialReference * Clone ()
- sgObject::ISpatialReferenceInfo(으)로부터 상속된 Public 멤버 함수
BSTR | GetWellKnownText ()

상세한 설명

IGeodeticSpatialReference 인터페이스

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGeodeticSpatialReference
sgObject::IGeodeticSpatialReference 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGeodeticSpatialReference (모든 상속된 멤버들도 포함합니다.)

Clone() | sgObject::ISpatialReference
Destroy() | sgObject::ISpatialReference
ExportToProj4() | sgObject::ISpatialReference
ExportToWkt() | sgObject::ISpatialReference
GetAuthorityCode([in] BSTR strTargetKey) | sgObject::ISpatialReference
GetAuthorityName([in] BSTR strTargetKey) | sgObject::ISpatialReference
GetEPSGName() | sgObject::ISpatialReference
GetWellKnownText() | sgObject::ISpatialReferenceInfo
ImportFromProj4([in] BSTR strProj4) | sgObject::ISpatialReference
ImportFromWkt([in] BSTR strWkt) | sgObject::ISpatialReference
IsSame([in] ISpatialReference *otherCRS) | sgObject::ISpatialReference
SetAuthority([in] BSTR strTargetKey, [in] BSTR strAuthority, [in] int nCode) | sgObject::ISpatialReference
SetFromUserInput([in] BSTR strInput) | sgObject::ISpatialReference
ShowSRSWidget() | sgObject::ISpatialReference
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGeographicCoordinateSystem 인터페이스 참조

  • IGeographicCoordinateSystem
모든 멤버 목록
sgObject::IGeographicCoordinateSystem 인터페이스 참조

IGeographicCoordinateSystem 인터페이스 더 자세히 ...

sgObject::IGeographicCoordinateSystem에 대한 상속 다이어그램 :
sgObject::IGeographicCoordinateSystem에 대한 협력 다이어그램:

추가로 상속된 멤버들

- sgObject::ISpatialReference(으)로부터 상속된 Public 멤버 함수
void | Destroy ()
VARIANT_BOOL | ImportFromWkt ([in] BSTR strWkt)
VARIANT_BOOL | ImportFromProj4 ([in] BSTR strProj4)
BSTR | ExportToWkt ()
BSTR | ExportToProj4 ()
VARIANT_BOOL | SetFromUserInput ([in] BSTR strInput)
void | ShowSRSWidget ()
BSTR | GetEPSGName ()
void | SetAuthority ([in] BSTR strTargetKey, [in] BSTR strAuthority, [in] int nCode)
BSTR | GetAuthorityCode ([in] BSTR strTargetKey)
BSTR | GetAuthorityName ([in] BSTR strTargetKey)
VARIANT_BOOL | IsSame ([in] ISpatialReference *otherCRS)
ISpatialReference * Clone ()
- sgObject::ISpatialReferenceInfo(으)로부터 상속된 Public 멤버 함수
BSTR | GetWellKnownText ()

상세한 설명

IGeographicCoordinateSystem 인터페이스

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGeographicCoordinateSystem
sgObject::IGeographicCoordinateSystem 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGeographicCoordinateSystem (모든 상속된 멤버들도 포함합니다.)

Clone() | sgObject::ISpatialReference
Destroy() | sgObject::ISpatialReference
ExportToProj4() | sgObject::ISpatialReference
ExportToWkt() | sgObject::ISpatialReference
GetAuthorityCode([in] BSTR strTargetKey) | sgObject::ISpatialReference
GetAuthorityName([in] BSTR strTargetKey) | sgObject::ISpatialReference
GetEPSGName() | sgObject::ISpatialReference
GetWellKnownText() | sgObject::ISpatialReferenceInfo
ImportFromProj4([in] BSTR strProj4) | sgObject::ISpatialReference
ImportFromWkt([in] BSTR strWkt) | sgObject::ISpatialReference
IsSame([in] ISpatialReference *otherCRS) | sgObject::ISpatialReference
SetAuthority([in] BSTR strTargetKey, [in] BSTR strAuthority, [in] int nCode) | sgObject::ISpatialReference
SetFromUserInput([in] BSTR strInput) | sgObject::ISpatialReference
ShowSRSWidget() | sgObject::ISpatialReference
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGeographicTransform 인터페이스 참조

  • IGeographicTransform
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGeographicTransform 인터페이스 참조

IGeographicTransform 인터페이스 더 자세히 ...

sgObject::IGeographicTransform에 대한 상속 다이어그램 :
sgObject::IGeographicTransform에 대한 협력 다이어그램:

Public 멤버 함수

IGeographicCoordinateSystem * GetSourceCS ()
void | SetSourceCS (IGeographicCoordinateSystem *cs)
IGeographicCoordinateSystem * GetTargetCS ()
void | SetTargetCS (IGeographicCoordinateSystem *cs)
void | Forward ([in, out] IGeometry *geom)
void | Inverse ([in, out] IGeometry *geom)
- sgObject::ISpatialReferenceInfo(으)로부터 상속된 Public 멤버 함수
BSTR | GetWellKnownText ()

상세한 설명

IGeographicTransform 인터페이스

멤버 함수 문서화

void sgObject::IGeographicTransform::Forward ( [in, out] IGeometry * geom )
IGeographicCoordinateSystem* sgObject::IGeographicTransform::GetSourceCS ( )
IGeographicCoordinateSystem* sgObject::IGeographicTransform::GetTargetCS ( )
void sgObject::IGeographicTransform::Inverse ( [in, out] IGeometry * geom )
void sgObject::IGeographicTransform::SetSourceCS ( IGeographicCoordinateSystem * cs )
void sgObject::IGeographicTransform::SetTargetCS ( IGeographicCoordinateSystem * cs )
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGeographicTransform
sgObject::IGeographicTransform 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGeographicTransform (모든 상속된 멤버들도 포함합니다.)

Forward([in, out] IGeometry *geom) | sgObject::IGeographicTransform
GetSourceCS() | sgObject::IGeographicTransform
GetTargetCS() | sgObject::IGeographicTransform
GetWellKnownText() | sgObject::ISpatialReferenceInfo
Inverse([in, out] IGeometry *geom) | sgObject::IGeographicTransform
SetSourceCS(IGeographicCoordinateSystem *cs) | sgObject::IGeographicTransform
SetTargetCS(IGeographicCoordinateSystem *cs) | sgObject::IGeographicTransform
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGeometry 인터페이스 참조

  • IGeometry
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGeometry 인터페이스 참조

기하 및 위치 정보(공간 좌표)를 갖는 기하의 기하 및 위치 정보 관리를 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::IGeometry에 대한 상속 다이어그램 :
sgObject::IGeometry에 대한 협력 다이어그램:

Public 멤버 함수

long | GetDimension ()
Geometry 객체의 차원 (0, 1, 2차원) 이다. 더 자세히 ...
ISpatialReference * GetSpatialReference ()
Geometry 객체가 참조하는 공간참조체계 (좌표체계) 이다. 더 자세히 ...
void | SetSpatialReference (ISpatialReference *pVal)
VARIANT_BOOL | IsEmpty ()
비어있는 Geometry 객체인지 나타낸다 (일반 프로그래밍 시 변수의 NULL과 유사) 더 자세히 ...
VARIANT_BOOL | IsSimple ()
기하가 심플한지 여부를 나타낸다. 더 자세히 ...
GeometryTypeEnum GetGeometryType ()
Geometry 객체의 구체적인 타입이다. 더 자세히 ...
void | SetEmpty ()
기하를 비어있는 기하로 만든다. 더 자세히 ...
IGeometry * Envelope ()
기하를 감싸는 최소 직사각형을 가져온다. 더 자세히 ...
IGeometry * Clone ()
해당 기하와 동일한 객체를 생성하여 가져온다. 더 자세히 ...
IGeometry * | Project ([in] ISpatialReference *newSystem)
기하를 새로운 공간참조체계로 투영해 만든 새로운 기하를 가져온다. 더 자세히 ...
void | Extent2D ([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY)
기하를 감싸는 최소 직사각형의 x, y 좌표를 Output 변수에 가져온다. 더 자세히 ...
IWks * GetWks ()
ISpatialRelation * GetSpatialRelation ()
ISpatialRelation2 * GetSpatialRelation2 ()
ISpatialOperator * GetSpatialOperator ()

상세한 설명

기하 및 위치 정보(공간 좌표)를 갖는 기하의 기하 및 위치 정보 관리를 위한 인터페이스를 제공한다.

모든 기하의 최상위 루트 인터페이스로서, 인스턴스를 만들지 못하는 추상 클래스이다. 모든 기하 객체는 Geometry 인터페이스를 지원해야 한다. C API(linux, iOS, MacOS 등) : 중간이름 "G"를 덧붙여서 "OGR_G_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Geometry"

멤버 함수 문서화

IGeometry* sgObject::IGeometry::Clone ( )

해당 기하와 동일한 객체를 생성하여 가져온다.

소스 기하 객체와 동일한 새로운 기하 객체를 생성하여 반환한다.

반환값
새로운 기하를 가리키는 포인터
IGeometry* sgObject::IGeometry::Envelope ( )

기하를 감싸는 최소 직사각형을 가져온다.

기하에 대한 경계 외피를 반환한다. 외피(envelope)의 각 면은 기하 공간 참조 좌표계의 각 면과 평행해야 한다.

반환값
최소 직사각형을 나타내는 기하의 포인터
void sgObject::IGeometry::Extent2D | ( | [in] double * | minX,
 |  | [in] double * | minY,
 |  | [in] double * | maxX,
 |  | [in] double * | maxY
 | ) |  |

기하를 감싸는 최소 직사각형의 x, y 좌표를 Output 변수에 가져온다.

Envelope ( ) 함수는 최소 직사각형 기하의 포인터를 반환하는데 비해 이 함수는 Output 변수에 좌표값을 가져온다.

매개변수
minX | - 직사각형의 최소 x 좌표값을 넣을 Output 변수
minY | - 직사각형의 최소 y 좌표값을 넣을 Output 변수
maxX | - 직사각형의 최대 x 좌표값을 넣을 Output 변수
maxY | - 직사각형의 최대 y 좌표값을 넣을 Output 변수
반환값
없음
long sgObject::IGeometry::GetDimension ( )

Geometry 객체의 차원 (0, 1, 2차원) 이다.

GeometryTypeEnum sgObject::IGeometry::GetGeometryType ( )

Geometry 객체의 구체적인 타입이다.

ISpatialOperator* sgObject::IGeometry::GetSpatialOperator ( )
ISpatialReference* sgObject::IGeometry::GetSpatialReference ( )

Geometry 객체가 참조하는 공간참조체계 (좌표체계) 이다.

ISpatialRelation* sgObject::IGeometry::GetSpatialRelation ( )
ISpatialRelation2* sgObject::IGeometry::GetSpatialRelation2 ( )
IWks* sgObject::IGeometry::GetWks ( )
VARIANT_BOOL sgObject::IGeometry::IsEmpty ( )

비어있는 Geometry 객체인지 나타낸다 (일반 프로그래밍 시 변수의 NULL과 유사)

반환값
즉, 기하 객체가 비었다면 참(VARIANT_TRUE)을 반환한다.
만약 참이면, 기하 객체는 좌표공간에 대해서 공집합, ø을 표현한다.
VARIANT_BOOL sgObject::IGeometry::IsSimple ( )

기하가 심플한지 여부를 나타낸다.

인스턴스를 생성할 수 있는 기하 클래스에 대한 기술에는 클래스의 인스턴스가 심플로 분류되는 상세한 조건을 포함할 것이다.

반환값
즉, 기하 객체가 자체 교차점(self intersection)이나 자체 접촉점(self tangency)과 같은
변칙적인 기하 점을 가지지 않았다면 참(VARIANT_TRUE)을 반환한다.
IGeometry* sgObject::IGeometry::Project ( [in] ISpatialReference * newSystem )

기하를 새로운 공간참조체계로 투영해 만든 새로운 기하를 가져온다.

매개변수
newSystem - 소스 기하가 투영될 좌표 시스템에 대한 정의
반환값
새로운 기하를 가리키는 포인터
void sgObject::IGeometry::SetEmpty ( )

기하를 비어있는 기하로 만든다.

기하가 비어있다 함은 어떠한 기하 정보도 없음을 의미한다.

void sgObject::IGeometry::SetSpatialReference ( ISpatialReference * pVal )
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGeometry
sgObject::IGeometry 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGeometry (모든 상속된 멤버들도 포함합니다.)

Clone() | sgObject::IGeometry
Envelope() | sgObject::IGeometry
Extent2D([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY) | sgObject::IGeometry
GetDimension() | sgObject::IGeometry
GetGeometryType() | sgObject::IGeometry
GetSpatialOperator() | sgObject::IGeometry
GetSpatialReference() | sgObject::IGeometry
GetSpatialRelation() | sgObject::IGeometry
GetSpatialRelation2() | sgObject::IGeometry
GetWks() | sgObject::IGeometry
IsEmpty() | sgObject::IGeometry
IsSimple() | sgObject::IGeometry
Project([in] ISpatialReference *newSystem) | sgObject::IGeometry
SetEmpty() | sgObject::IGeometry
SetSpatialReference(ISpatialReference *pVal) | sgObject::IGeometry
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGeometryCollection 인터페이스 참조

  • IGeometryCollection
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGeometryCollection 인터페이스 참조

기하 및 위치 정보(공간 좌표)를 갖는 기하가 기본 기하(Point, LineString, Polygon 등)로 표현할 수 없는 복잡한 기하 구조를 갖는 경우 이를 표현할 수 있도록 해주는 인터페이스를 제공한다. 더 자세히 ...

sgObject::IGeometryCollection에 대한 상속 다이어그램 :
sgObject::IGeometryCollection에 대한 협력 다이어그램:

Public 멤버 함수

long | GetNumGeometries ()
복잡한 기하 구조를 표현하는데 사용된 부품 기하의 개수를 반환한다. 더 자세히 ...
IGeometry * | Geometry ([in] long index)
해당 인덱스로 추가된 부품 기하를 가져온다. (GeometryColloection 내의 특정 색인에서의 기하를 반환한다.) 더 자세히 ...
VARIANT_BOOL | Add ([in] IGeometry *obj)
기하를 추가한다. 더 자세히 ...
- sgObject::IGeometry(으)로부터 상속된 Public 멤버 함수
long | GetDimension ()
Geometry 객체의 차원 (0, 1, 2차원) 이다. 더 자세히 ...
ISpatialReference * GetSpatialReference ()
Geometry 객체가 참조하는 공간참조체계 (좌표체계) 이다. 더 자세히 ...
void | SetSpatialReference (ISpatialReference *pVal)
VARIANT_BOOL | IsEmpty ()
비어있는 Geometry 객체인지 나타낸다 (일반 프로그래밍 시 변수의 NULL과 유사) 더 자세히 ...
VARIANT_BOOL | IsSimple ()
기하가 심플한지 여부를 나타낸다. 더 자세히 ...
GeometryTypeEnum GetGeometryType ()
Geometry 객체의 구체적인 타입이다. 더 자세히 ...
void | SetEmpty ()
기하를 비어있는 기하로 만든다. 더 자세히 ...
IGeometry * Envelope ()
기하를 감싸는 최소 직사각형을 가져온다. 더 자세히 ...
IGeometry * Clone ()
해당 기하와 동일한 객체를 생성하여 가져온다. 더 자세히 ...
IGeometry * | Project ([in] ISpatialReference *newSystem)
기하를 새로운 공간참조체계로 투영해 만든 새로운 기하를 가져온다. 더 자세히 ...
void | Extent2D ([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY)
기하를 감싸는 최소 직사각형의 x, y 좌표를 Output 변수에 가져온다. 더 자세히 ...
IWks * GetWks ()
ISpatialRelation * GetSpatialRelation ()
ISpatialRelation2 * GetSpatialRelation2 ()
ISpatialOperator * GetSpatialOperator ()

상세한 설명

기하 및 위치 정보(공간 좌표)를 갖는 기하가 기본 기하(Point, LineString, Polygon 등)로 표현할 수 없는 복잡한 기하 구조를 갖는 경우 이를 표현할 수 있도록 해주는 인터페이스를 제공한다.

기본 기하(Point, LineString, Polygon 등)의 조합으로 복잡한 기하 구조를 표현하게 한다. 기하 컬렉션의 객체들은 IGeometryCollection 인터페이스를 제공한다. 이 IGeometryCollection 인터페이스는 기하 컬렉션 객체들의 구성 요소에 접곤하기 위해 인덱스를 상용한다. 집합내의 구성 요소들의 순서는 컬렉션의 정의에 따라 순서화 된다. C API(linux, iOS, MacOS 등) : 중간이름 "G"를 덧붙여서 "OGR_G_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Geometry"

멤버 함수 문서화

VARIANT_BOOL sgObject::IGeometryCollection::Add ( [in] IGeometry * obj )

기하를 추가한다.

매개변수
obj - 추가될 기하를 가리키는 포인터
반환값
성공이면 VARIANT_TRUE, 실패면 VARIANT_FALSE
IGeometry* sgObject::IGeometryCollection::Geometry ( [in] long index )

해당 인덱스로 추가된 부품 기하를 가져온다. (GeometryColloection 내의 특정 색인에서의 기하를 반환한다.)

이 인터페이스의 소비자는 컬렉션에 대한 특정 요소를 직접 참조할 수 있도록 한다.
어떠한 복사본도 만들어지지 않으며, 색인의 범위는 0부터 NumGeometries -1 까지이다.

매개변수
index - 인덱스 번호(반환할 요소의 색인)
반환값
부품 기하를 가리키는 포인터
long sgObject::IGeometryCollection::GetNumGeometries ( )

복잡한 기하 구조를 표현하는데 사용된 부품 기하의 개수를 반환한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGeometryCollection
sgObject::IGeometryCollection 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGeometryCollection (모든 상속된 멤버들도 포함합니다.)

Add([in] IGeometry *obj) | sgObject::IGeometryCollection
Clone() | sgObject::IGeometry
Envelope() | sgObject::IGeometry
Extent2D([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY) | sgObject::IGeometry
Geometry([in] long index) | sgObject::IGeometryCollection
GetDimension() | sgObject::IGeometry
GetGeometryType() | sgObject::IGeometry
GetNumGeometries() | sgObject::IGeometryCollection
GetSpatialOperator() | sgObject::IGeometry
GetSpatialReference() | sgObject::IGeometry
GetSpatialRelation() | sgObject::IGeometry
GetSpatialRelation2() | sgObject::IGeometry
GetWks() | sgObject::IGeometry
IsEmpty() | sgObject::IGeometry
IsSimple() | sgObject::IGeometry
Project([in] ISpatialReference *newSystem) | sgObject::IGeometry
SetEmpty() | sgObject::IGeometry
SetSpatialReference(ISpatialReference *pVal) | sgObject::IGeometry
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGeometryFactory 인터페이스 참조

  • IGeometryFactory
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGeometryFactory 인터페이스 참조

Well Known Binary 및 Well Known Text 데이터를 통해 IGeometry 인터페이스를 갖는 객체를 생성하기 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::IGeometryFactory에 대한 상속 다이어그램 :
sgObject::IGeometryFactory에 대한 협력 다이어그램:

Public 멤버 함수

IGeometry * | CreateFromWKB ([in] VARIANT wkb, [in, defaultvalue(NULL)] ISpatialReference *spatialRef)
Well Known Binary로 표현된 정보로 기하를 생성한다. 더 자세히 ...
IGeometry * | CreateFromWKT ([in] BSTR wkt, [in, defaultvalue(NULL)] ISpatialReference *spatialRef)
Well Known Text로 표현된 정보로 기하를 생성한다. 더 자세히 ...

상세한 설명

Well Known Binary 및 Well Known Text 데이터를 통해 IGeometry 인터페이스를 갖는 객체를 생성하기 위한 인터페이스를 제공한다.

이 때 Well Known Binary 및 Well Known Text 데이터가 나타내는 기하의 타입(Point, LineString, Polygon, GeometryCollection 등)을 몰라도 생성이 가능하다. (생성된 기하의 포인터가 IGeometry*로 리턴되므로 기하의 타입은 GeometryType 어트리뷰트를 통해 알 수 있다.) Well Known Binary 및 Well Known Text에 대한 내용은 Knowledge Base를 참고한다.
IGeometryFactory 인터페이스는 주어진 기하의 잘 알려진 표현을 이용해서 기하를 생성하는데 이용되는 메소드들을 정의한다. 이때 클라이언트는 표현된 기하타입을 미리 알지 못하더라도 기하 생성이 가능하다. 이것은 주어진 잘 알려진 표현에서 다른 클래스에 포함되는 기하 객체 집합을 생성하는 간편한 방법을 제공한다. C API(linux, iOS, MacOS 등) : 중간이름 "GF"를 덧붙여서 "OGR_GF_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.GeometryFactory"

멤버 함수 문서화

IGeometry* sgObject::IGeometryFactory::CreateFromWKB | ( | [in] VARIANT | wkb,
 |  | [in, defaultvalue(NULL)] ISpatialReference * | spatialRef
 | ) |  |

Well Known Binary로 표현된 정보로 기하를 생성한다.

매개변수
wkb | - 기하를 표현하는 Well Known Binary. VARIANT 변수의 parray->pvData에 Well Known Binary 데이터 넣는다. VARIANT 변수의 vt에는 VT_ARRAY | VT_UI1를 넣는다.
spatialRef | - 기하가 참조하는 공간좌표체계. 참조하는 공간참조체계가 정의되어 있지 않다면 NULL. [default = NULL]
반환값
생성된 기하를 가리키는 포인터
IGeometry* sgObject::IGeometryFactory::CreateFromWKT | ( | [in] BSTR | wkt,
 |  | [in, defaultvalue(NULL)] ISpatialReference * | spatialRef
 | ) |  |

Well Known Text로 표현된 정보로 기하를 생성한다.

매개변수
wkt | - 기하를 표현하는 Well Known Text
spatialRef | - 기하가 참조하는 공간좌표체계 참조하는 공간참조체계가 정의되어 있지 않다면 NULL [default = NULL]
반환값
생성된 기하를 가리키는 포인터
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGeometryFactory
sgObject::IGeometryFactory 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGeometryFactory (모든 상속된 멤버들도 포함합니다.)

CreateFromWKB([in] VARIANT wkb, [in, defaultvalue(NULL)] ISpatialReference *spatialRef) | sgObject::IGeometryFactory
CreateFromWKT([in] BSTR wkt, [in, defaultvalue(NULL)] ISpatialReference *spatialRef) | sgObject::IGeometryFactory
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGPDLayerSource 인터페이스 참조

  • IGPDLayerSource
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGPDLayerSource 인터페이스 참조

[업데이트 예정] 더 자세히 ...

sgObject::IGPDLayerSource에 대한 상속 다이어그램 :
sgObject::IGPDLayerSource에 대한 협력 다이어그램:

Public 멤버 함수

int | GetUserSize ()
[업데이트 예정] 더 자세히 ...
void | AddUser ([in] BSTR UserName, [in] BSTR UserPwd, [in] BSTR Data, [in] BSTR ValidDate)
[업데이트 예정] 더 자세히 ...
void | RemoveUser ([in] BSTR UserName)
[업데이트 예정] 더 자세히 ...
void | SetUser ([in] BSTR UserName, [in] BSTR UserPwd, [in] BSTR Data, [in] BSTR ValidDate)
[업데이트 예정] 더 자세히 ...
void | GetUser ([in] short Index, [out] BSTR *UserName, [out] BSTR *Data, [out] BSTR *ValidDate)
[업데이트 예정] 더 자세히 ...
- sgObject::ILayerSource(으)로부터 상속된 Public 멤버 함수
BSTR | GetIcon ()
LayerSource을 나타내는 아이콘 파일의 위치를 문자열을 반환한다. 더 자세히 ...
void | SetIcon (BSTR bstrVal)
아이콘 파일의 위치를 담은 문자열을 통해서 LayerSource의 아이콘을 변경한다. 더 자세히 ...
BSTR | GetDisplayName ()
표현되는 LayerSource 이름을 반환한다. 더 자세히 ...
void | SetDisplayName (BSTR bstrName)
표현되는 LayerSource 이름을 변경한다. 더 자세히 ...
BSTR | GetDescription ()
LayerSource에 대한 설명을 반환한다. 더 자세히 ...
void | SetDescription (BSTR bstrDesc)
LayerSource에 대한 설명을 변경한다. 더 자세히 ...
int | GetSize ()
속해 있는 레이어의 개수를 반환한다. 더 자세히 ...
BSTR | GetDriverType ()
LayerSource에 대한 드라이버종류을 반환한다. 더 자세히 ...
ILayer * | GetLayer (VARIANT vtIdx)
해당 인덱스의 레이어 객체를 반환한다. 더 자세히 ...
ILayer * | CreateLayer ([in] BSTR pszName, [in, defaultvalue(NULL)] ISpatialReference *poSpatialRef, [in, defaultvalue(0)] int eGType, [in, optional] VARIANT papszOptions)
LayerSource에 레이어 객체를 생성하여 추가한다. 더 자세히 ...
ILayer * | ExecuteSQL ([in] BSTR pszStatement, [in] BSTR pszDialect, [in, optional] VARIANT vtParam)
SQL문을 처리할 수 있는 데이터소스의 경우 SQL문을 수행시키고, 다른 데이터소스의 경우 해당하는 데이터소스에 적합한 동작을 수행한다 . 더 자세히 ...
VARIANT_BOOL | DeleteLayer ([in] BSTR pszName)
레이어 이름에 해당하는 레이어를 지운다. 더 자세히 ...
VARIANT_BOOL | RenameLayer ([in] BSTR pszName, [in] BSTR pszToName)
레이어 이름을 변경한다. 더 자세히 ...
int | GetLayerCount ()
속해 있는 레이어의 개수를 반환한다. 더 자세히 ...
BSTR | ExecuteSQLToString ([in] BSTR pszStatement, [in] BSTR pszDialect, [in] BSTR pszFeatureSeper, [in] BSTR pszAttrSeper)
ExecuteSQL 함수의 결과를 문자열로 반환한다. 더 자세히 ...
int | GetAffectedCount ()
ExecuteSQL 실행에 따라 영향을 받은 레코드수를 반환한다. 더 자세히 ...

상세한 설명

[업데이트 예정]

멤버 함수 문서화

void sgObject::IGPDLayerSource::AddUser | ( | [in] BSTR | UserName,
 |  | [in] BSTR | UserPwd,
 |  | [in] BSTR | Data,
 |  | [in] BSTR | ValidDate
 | ) |  |

[업데이트 예정]

void sgObject::IGPDLayerSource::GetUser | ( | [in] short | Index,
 |  | [out] BSTR * | UserName,
 |  | [out] BSTR * | Data,
 |  | [out] BSTR * | ValidDate
 | ) |  |

[업데이트 예정]

int sgObject::IGPDLayerSource::GetUserSize ( )

[업데이트 예정]

void sgObject::IGPDLayerSource::RemoveUser ( [in] BSTR UserName )

[업데이트 예정]

void sgObject::IGPDLayerSource::SetUser | ( | [in] BSTR | UserName,
 |  | [in] BSTR | UserPwd,
 |  | [in] BSTR | Data,
 |  | [in] BSTR | ValidDate
 | ) |  |

[업데이트 예정]

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGPDLayerSource
sgObject::IGPDLayerSource 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGPDLayerSource (모든 상속된 멤버들도 포함합니다.)

AddUser([in] BSTR UserName, [in] BSTR UserPwd, [in] BSTR Data, [in] BSTR ValidDate) | sgObject::IGPDLayerSource
CreateLayer([in] BSTR pszName, [in, defaultvalue(NULL)] ISpatialReference *poSpatialRef, [in, defaultvalue(0)] int eGType, [in, optional] VARIANT papszOptions) | sgObject::ILayerSource
DeleteLayer([in] BSTR pszName) | sgObject::ILayerSource
ExecuteSQL([in] BSTR pszStatement, [in] BSTR pszDialect, [in, optional] VARIANT vtParam) | sgObject::ILayerSource
ExecuteSQLToString([in] BSTR pszStatement, [in] BSTR pszDialect, [in] BSTR pszFeatureSeper, [in] BSTR pszAttrSeper) | sgObject::ILayerSource
GetAffectedCount() | sgObject::ILayerSource
GetDescription() | sgObject::ILayerSource
GetDisplayName() | sgObject::ILayerSource
GetDriverType() | sgObject::ILayerSource
GetIcon() | sgObject::ILayerSource
GetLayer(VARIANT vtIdx) | sgObject::ILayerSource
GetLayerCount() | sgObject::ILayerSource
GetSize() | sgObject::ILayerSource
GetUser([in] short Index, [out] BSTR *UserName, [out] BSTR *Data, [out] BSTR *ValidDate) | sgObject::IGPDLayerSource
GetUserSize() | sgObject::IGPDLayerSource
RemoveUser([in] BSTR UserName) | sgObject::IGPDLayerSource
RenameLayer([in] BSTR pszName, [in] BSTR pszToName) | sgObject::ILayerSource
SetDescription(BSTR bstrDesc) | sgObject::ILayerSource
SetDisplayName(BSTR bstrName) | sgObject::ILayerSource
SetIcon(BSTR bstrVal) | sgObject::ILayerSource
SetUser([in] BSTR UserName, [in] BSTR UserPwd, [in] BSTR Data, [in] BSTR ValidDate) | sgObject::IGPDLayerSource
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGraph 인터페이스 참조

  • IGraph
모든 멤버 목록
sgObject::IGraph 인터페이스 참조

그래프의 세부 속성을 설정하기 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::IGraph에 대한 상속 다이어그램 :
sgObject::IGraph에 대한 협력 다이어그램:

추가로 상속된 멤버들

- sgObject::IUserDefinedWidget(으)로부터 상속된 Public 멤버 함수
AlignPositionEnum GetPosition ()
Feature를 기준으로한 객체의 기준점 상대 위치 더 자세히 ...
void | SetPosition ([in] AlignPositionEnum pos)
int | GetRelateX ()
기준점으로부터 X 이격거리 더 자세히 ...
void | SetRelateX ([in] int x)
int | GetRelateY ()
기준점으로부터 Y 이격거리 더 자세히 ...
void | SetRelateY ([in] int y)
VARIANT_BOOL | IsExteriorHandle ()
외부 핸들인지의 여부 더 자세히 ...
void | SetExteriorHandle ([in] VARIANT_BOOL val)
VARIANT_BOOL | ExportImage (FileFormatEnum nFileType, BSTR bstrVal)
차트를 지정된 파일형태로 내보낸다. 더 자세히 ...
- sgObject::IWidget(으)로부터 상속된 Public 멤버 함수
void | Initialize ([in] ULONG_PTR h)
위젯 초기화 더 자세히 ...
void | ReSize ([in] int x, [in] int y, [in] int cx, [in] int cy)
위젯 객체의 크기를 재설정 한다. 더 자세히 ...
void | AddWidget ([in] IWidget *dspWidget)
현재 위젯에 하부로 위젯을 추가한다. 더 자세히 ...
void | AddWidgetByLayout ([in] IWidget *dspWidget, [in] int row, [in] int col)
현재 위젯에 종, 횡 위치에 위젯을 추가한다. 더 자세히 ...
void | SetQtUiObjectVisible ([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue)
위젯의 해당 오브젝트 객체의 보이기 여부를 설정한다. 더 자세히 ...
long | GetBackColor ()
위젯이 사용하는 배경 색상 정보 더 자세히 ...
void | SetBackColor ([in] long color)
void | SetCanvas (ICanvas *poCanvas)
위젯을 특정(2D, 3D, Earth 등) 지도창으로 설정한다. 더 자세히 ...
IFeatureCanvas * GetFeatureCanvas ()
위젯이 사용하는 FeatureCanvas 정보 더 자세히 ...
void | SetFeatureCanvas (IFeatureCanvas *poFtCvs)
void | SetFeatureLayer (IFeatureLayer *poFtLayer)
위젯이 사용하는 FeatureLayer 정보 더 자세히 ...
void | SetLayer (ILayer *poLayer)
위젯이 사용하는 레이어 정보 더 자세히 ...
BSTR | GetFlag ()
위젯이 사용하는 문자열 파라메터 정보 더 자세히 ...
void | SetFlag (BSTR bstrFlag)
void | SetWidth (int nWidth)
위젯의 가로크기를 설정한다. 더 자세히 ...
int | SetHeight (int nHeight)
위젯의 세로크기를 설정한다. 더 자세히 ...
void | Destroy ()

상세한 설명

그래프의 세부 속성을 설정하기 위한 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "GP"를 덧붙여서 "OGR_GP_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Graph"

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGraph
sgObject::IGraph 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGraph (모든 상속된 멤버들도 포함합니다.)

AddWidget([in] IWidget *dspWidget) | sgObject::IWidget
AddWidgetByLayout([in] IWidget *dspWidget, [in] int row, [in] int col) | sgObject::IWidget
Destroy() | sgObject::IWidget
ExportImage(FileFormatEnum nFileType, BSTR bstrVal) | sgObject::IUserDefinedWidget
GetBackColor() | sgObject::IWidget
GetFeatureCanvas() | sgObject::IWidget
GetFlag() | sgObject::IWidget
GetPosition() | sgObject::IUserDefinedWidget
GetRelateX() | sgObject::IUserDefinedWidget
GetRelateY() | sgObject::IUserDefinedWidget
Initialize([in] ULONG_PTR h) | sgObject::IWidget
IsExteriorHandle() | sgObject::IUserDefinedWidget
ReSize([in] int x, [in] int y, [in] int cx, [in] int cy) | sgObject::IWidget
SetBackColor([in] long color) | sgObject::IWidget
SetCanvas(ICanvas *poCanvas) | sgObject::IWidget
SetExteriorHandle([in] VARIANT_BOOL val) | sgObject::IUserDefinedWidget
SetFeatureCanvas(IFeatureCanvas *poFtCvs) | sgObject::IWidget
SetFeatureLayer(IFeatureLayer *poFtLayer) | sgObject::IWidget
SetFlag(BSTR bstrFlag) | sgObject::IWidget
SetHeight(int nHeight) | sgObject::IWidget
SetLayer(ILayer *poLayer) | sgObject::IWidget
SetPosition([in] AlignPositionEnum pos) | sgObject::IUserDefinedWidget
SetQtUiObjectVisible([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue) | sgObject::IWidget
SetRelateX([in] int x) | sgObject::IUserDefinedWidget
SetRelateY([in] int y) | sgObject::IUserDefinedWidget
SetWidth(int nWidth) | sgObject::IWidget
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGraphic 인터페이스 참조

  • IGraphic
sgObject::IGraphic 인터페이스 참조

그래픽 객체의 인터페이스를 제공한다. 더 자세히 ...

sgObject::IGraphic에 대한 상속 다이어그램 :
sgObject::IGraphic에 대한 협력 다이어그램:

상세한 설명

그래픽 객체의 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "GP"를 덧붙여서 "OGR_GP_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Graphic"

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGraphicArc 인터페이스 참조

  • IGraphicArc
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGraphicArc 인터페이스 참조

호의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::IGraphicArc에 대한 상속 다이어그램 :
sgObject::IGraphicArc에 대한 협력 다이어그램:

Public 멤버 함수

void | SetCenter ([in] float x, [in] float y)
void | GetCenter ([out] float *x, [out] float *y)
void | SetWidth ([in] float w)
float | GetWidth ()
void | SetHeight ([in] float h)
float | GetHeight ()
void | SetStart ([in] float a)
float | GetStart ()
void | SetEnd ([in] float a)
float | GetEnd ()
VARIANT_BOOL | IsCircle ()
VARIANT_BOOL | IsClosedEllipse ()
VARIANT_BOOL | IsAllowingExtentsChang ()
void | SetAllowingExtentsChang (VARIANT_BOOL)

상세한 설명

호의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "GPA"를 덧붙여서 "OGR_GPA_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.GraphicArc"

멤버 함수 문서화

void sgObject::IGraphicArc::GetCenter | ( | [out] float * | x,
 |  | [out] float * | y
 | ) |  |
float sgObject::IGraphicArc::GetEnd ( )
float sgObject::IGraphicArc::GetHeight ( )
float sgObject::IGraphicArc::GetStart ( )
float sgObject::IGraphicArc::GetWidth ( )
VARIANT_BOOL sgObject::IGraphicArc::IsAllowingExtentsChang ( )
VARIANT_BOOL sgObject::IGraphicArc::IsCircle ( )
VARIANT_BOOL sgObject::IGraphicArc::IsClosedEllipse ( )
void sgObject::IGraphicArc::SetAllowingExtentsChang ( VARIANT_BOOL )
void sgObject::IGraphicArc::SetCenter | ( | [in] float | x,
 |  | [in] float | y
 | ) |  |
void sgObject::IGraphicArc::SetEnd ( [in] float a )
void sgObject::IGraphicArc::SetHeight ( [in] float h )
void sgObject::IGraphicArc::SetStart ( [in] float a )
void sgObject::IGraphicArc::SetWidth ( [in] float w )
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGraphicArc
sgObject::IGraphicArc 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGraphicArc (모든 상속된 멤버들도 포함합니다.)

GetCenter([out] float *x, [out] float *y) | sgObject::IGraphicArc
GetEnd() | sgObject::IGraphicArc
GetHeight() | sgObject::IGraphicArc
GetStart() | sgObject::IGraphicArc
GetWidth() | sgObject::IGraphicArc
IsAllowingExtentsChang() | sgObject::IGraphicArc
IsCircle() | sgObject::IGraphicArc
IsClosedEllipse() | sgObject::IGraphicArc
SetAllowingExtentsChang(VARIANT_BOOL) | sgObject::IGraphicArc
SetCenter([in] float x, [in] float y) | sgObject::IGraphicArc
SetEnd([in] float a) | sgObject::IGraphicArc
SetHeight([in] float h) | sgObject::IGraphicArc
SetStart([in] float a) | sgObject::IGraphicArc
SetWidth([in] float w) | sgObject::IGraphicArc
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGraphicCanvas 인터페이스 참조

  • IGraphicCanvas
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGraphicCanvas 인터페이스 참조

실세계좌표를 기반으로 표현되는 지도객체와 달라 비축척 그래픽 객체에 기반한 객체로 단면도, 설계도와 같이 지리적 특성을 더 자세히 ...

sgObject::IGraphicCanvas에 대한 상속 다이어그램 :
sgObject::IGraphicCanvas에 대한 협력 다이어그램:

Public 멤버 함수

HRESULT | Add ([in]BSTR bstrKey, [in]IGraphic *pdspGraphic)
그래픽 객체를 추가한다. 더 자세히 ...
HRESULT | Remove ([in]IGraphic *pdspGraphic)
그래픽 객체를 삭제한다. 더 자세히 ...
HRESULT | Clear ()
그래픽 객체를 모두 삭제한다. 더 자세히 ...
HRESULT | RemoveFromKey ([in]BSTR bstrKey)
그래픽 객체를 삭제한다. 더 자세히 ...
HRESULT | GetTopGraphicAt ([in] float mx, [in] float my, [out, retval] IGraphic **pdspGraphic)
해당 위치에 존재하는 그래픽 객체 중 최 상위에 있는 그래픽 객체를 반환한다. 더 자세히 ...
HRESULT | GetGraphicsAt ([in] float mx, [in] float my, [out, retval] IAggregateGraphic **pdspAggGraphic)
해당 위치에 존재하는 그래픽 객체를 모두 반환한다. 더 자세히 ...
- sgObject::ICanvas(으)로부터 상속된 Public 멤버 함수
HRESULT | GetCommonFactory ([out, retval] ICommonFactory **pVal)
CommonFactory를 가져온다. 더 자세히 ...
HRESULT | GetCanvasType ([out, retval] CanvasTypeEnum *pVal)
지도 (Canvas 객체) 종류를 반환한다. 더 자세히 ...
HRESULT | GetTitle ([out, retval] BSTR *pVal)
지도 (Canvas 객체) 이름 더 자세히 ...
HRESULT | SetTitle ([in] BSTR newVal)
HRESULT | GetState ([out, retval] int *pVal)
화면 (Canvas 객체) 상태 더 자세히 ...
HRESULT | SetState ([in] int newVal)
HRESULT | GetFeatureCanvas ([out, retval] IFeatureCanvas **pVal)
지도에 표현되는 FeatureLayer(공간정보레이어)를 관리하는 FeatureCanvas 정보 더 자세히 ...
HRESULT | SetFeatureCanvas ([in] IFeatureCanvas *pVal)
HRESULT | GetBackColor ([out, retval] long *pVal)
배경색(RGB) 더 자세히 ...
HRESULT | SetBackColor ([in] long newVal)
HRESULT | GetMapControl ([out, retval] long *pVal)
지도에 표시되는 제어창(방위, 스케일바 등) 더 자세히 ...
HRESULT | SetMapControl ([in] long newVal)
HRESULT | VisibleMapControl ([in] SystemResourceEnum type, [in] VARIANT_BOOL bVisible)
지도에 표시할 제어창의 종류를 설정한다. 더 자세히 ...
HRESULT | GetMapMoveMode ([out, retval] MapMoveEnum *pVal)
위치센서 정보 수신에 따른 지도의 자동 이동 여부 더 자세히 ...
HRESULT | SetMapMoveMode ([in] MapMoveEnum type)
HRESULT | GetMapRotateMode ([out, retval] MapRotateEnum *pVal)
위치센서 정보 수신 중 이동에 따른 지도 방향 자동 회전 여부 더 자세히 ...
HRESULT | SetMapRotateMode ([in] MapRotateEnum type)
HRESULT | SetLocationSensor ([in] ILocationSensor *pdspSensor)
지도에서 사용할 위치센서를 지정한다. 더 자세히 ...
HRESULT | SetMotionSensor ([in] IMotionSensor *pdspSensor)
지도에서 사용할 모션센서를 지정한다. 더 자세히 ...
HRESULT | SetVideoSensor ([in] IVideoSensor *pdspSensor)
지도에서 사용할 비디오센서를 지정한다. 더 자세히 ...
HRESULT | RemoveSensor ([in] ISensor *pdspSensor)
지도에서 사용중인 센서를 삭제한다. 더 자세히 ...
HRESULT | GetObjectiveSpatialReference ([out, retval] ISpatialReference **pVal)
지도의 실질 공간 좌표 체계 더 자세히 ...
HRESULT | SetObjectiveSpatialReference ([in] ISpatialReference *pVal)
HRESULT | Initialize ([in] ULONG_PTR h)
지도를 그려야 할 객체의 핸들을 초기화 한다. 더 자세히 ...
HRESULT | Invalidate ()
지도를 다시 그리도록 한다. 더 자세히 ...
HRESULT | ExportImage ([in]FileFormatEnum nFileType, [in]BSTR pVal)
지도화면을 이미지 파일로 내보낸다. 더 자세히 ...
HRESULT | AddControl ([in] long fid, [in] IUserDefinedWidget *dspUDBox)
외부 컨트롤을 지도상에 추가한다. 더 자세히 ...
HRESULT | RemoveControl ([in] long fid)
AddControl에 의해 입력된 외부 컨트롤을 지도상에서 삭제한다. 더 자세히 ...
HRESULT | RemoveAllControl ()
AddControl에 의해 입력된 모든 외부 컨트롤을 지도상에서 삭제한다. 더 자세히 ...
HRESULT | GetHittestSize ([out, retval] int *pVal)
화면에서 객체 선택을 위한 검색 픽셀 범위 더 자세히 ...
HRESULT | SetHittestSize ([in] int newVal)
HRESULT | ForceStopRender ()
화면 렌더링 중지 더 자세히 ...
HRESULT | MouseMove ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 마우스 이동 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | LButtonDown ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 왼쪽 마우스의 버튼을 누른 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | LButtonUp ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 왼쪽 마우스의 눌린 버튼을 놓았다는 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | RButtonDown ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 오른쪽 마우스의 버튼을 누른 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | RButtonUp ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 오른쪽 마우스의 눌린 버튼을 놓았다는 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | DblClick ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 왼쪽 마우스를 더블클릭 했음을 강제로 설정한다. 더 자세히 ...
HRESULT | ReSize ([in] LONG nType, [in] int cx, [in] int cy)
지도의 크기를 조정했음으로 강제로 설정한다. 더 자세히 ...
HRESULT | KeyDown ([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags)
지도에서 특정 키를 눌렀음을 강제로 설정한다. 더 자세히 ...
HRESULT | KeyUp ([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags)
지도에서 특정 키를 떼었음을 강제로 설정한다. 더 자세히 ...
HRESULT | MButtonDown ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 중간 마우스의 버튼을 누른 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | MButtonUp ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 중간 마우스의 눌린 버튼을 놓았다는 정보를 강제로 설정한다. 더 자세히 ...

상세한 설명

실세계좌표를 기반으로 표현되는 지도객체와 달라 비축척 그래픽 객체에 기반한 객체로 단면도, 설계도와 같이 지리적 특성을

지니지 않은 화면을 구성할 수 있는 인터페이스를 제공한다. C API(linux, iOS, MacOS 등) : 중간이름 "GCV"를 덧붙여서 "OGR_GCV_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.GraphicCanvas"

멤버 함수 문서화

HRESULT sgObject::IGraphicCanvas::Add | ( | [in] BSTR | bstrKey,
 |  | [in] IGraphic * | pdspGraphic
 | ) |  |

그래픽 객체를 추가한다.

HRESULT sgObject::IGraphicCanvas::Clear ( )

그래픽 객체를 모두 삭제한다.

HRESULT sgObject::IGraphicCanvas::GetGraphicsAt | ( | [in] float | mx,
 |  | [in] float | my,
 |  | [out, retval] IAggregateGraphic ** | pdspAggGraphic
 | ) |  |

해당 위치에 존재하는 그래픽 객체를 모두 반환한다.

HRESULT sgObject::IGraphicCanvas::GetTopGraphicAt | ( | [in] float | mx,
 |  | [in] float | my,
 |  | [out, retval] IGraphic ** | pdspGraphic
 | ) |  |

해당 위치에 존재하는 그래픽 객체 중 최 상위에 있는 그래픽 객체를 반환한다.

HRESULT sgObject::IGraphicCanvas::Remove ( [in] IGraphic * pdspGraphic )

그래픽 객체를 삭제한다.

HRESULT sgObject::IGraphicCanvas::RemoveFromKey ( [in] BSTR bstrKey )

그래픽 객체를 삭제한다.

생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGraphicCanvas
sgObject::IGraphicCanvas 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGraphicCanvas (모든 상속된 멤버들도 포함합니다.)

Add([in]BSTR bstrKey, [in]IGraphic *pdspGraphic) | sgObject::IGraphicCanvas
AddControl([in] long fid, [in] IUserDefinedWidget *dspUDBox) | sgObject::ICanvas
Clear() | sgObject::IGraphicCanvas
DblClick([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
ExportImage([in]FileFormatEnum nFileType, [in]BSTR pVal) | sgObject::ICanvas
ForceStopRender() | sgObject::ICanvas
GetBackColor([out, retval] long *pVal) | sgObject::ICanvas
GetCanvasType([out, retval] CanvasTypeEnum *pVal) | sgObject::ICanvas
GetCommonFactory([out, retval] ICommonFactory **pVal) | sgObject::ICanvas
GetFeatureCanvas([out, retval] IFeatureCanvas **pVal) | sgObject::ICanvas
GetGraphicsAt([in] float mx, [in] float my, [out, retval] IAggregateGraphic **pdspAggGraphic) | sgObject::IGraphicCanvas
GetHittestSize([out, retval] int *pVal) | sgObject::ICanvas
GetMapControl([out, retval] long *pVal) | sgObject::ICanvas
GetMapMoveMode([out, retval] MapMoveEnum *pVal) | sgObject::ICanvas
GetMapRotateMode([out, retval] MapRotateEnum *pVal) | sgObject::ICanvas
GetObjectiveSpatialReference([out, retval] ISpatialReference **pVal) | sgObject::ICanvas
GetState([out, retval] int *pVal) | sgObject::ICanvas
GetTitle([out, retval] BSTR *pVal) | sgObject::ICanvas
GetTopGraphicAt([in] float mx, [in] float my, [out, retval] IGraphic **pdspGraphic) | sgObject::IGraphicCanvas
Initialize([in] ULONG_PTR h) | sgObject::ICanvas
Invalidate() | sgObject::ICanvas
KeyDown([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags) | sgObject::ICanvas
KeyUp([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags) | sgObject::ICanvas
LButtonDown([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
LButtonUp([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
MButtonDown([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
MButtonUp([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
MouseMove([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
RButtonDown([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
RButtonUp([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
Remove([in]IGraphic *pdspGraphic) | sgObject::IGraphicCanvas
RemoveAllControl() | sgObject::ICanvas
RemoveControl([in] long fid) | sgObject::ICanvas
RemoveFromKey([in]BSTR bstrKey) | sgObject::IGraphicCanvas
RemoveSensor([in] ISensor *pdspSensor) | sgObject::ICanvas
ReSize([in] LONG nType, [in] int cx, [in] int cy) | sgObject::ICanvas
SetBackColor([in] long newVal) | sgObject::ICanvas
SetFeatureCanvas([in] IFeatureCanvas *pVal) | sgObject::ICanvas
SetHittestSize([in] int newVal) | sgObject::ICanvas
SetLocationSensor([in] ILocationSensor *pdspSensor) | sgObject::ICanvas
SetMapControl([in] long newVal) | sgObject::ICanvas
SetMapMoveMode([in] MapMoveEnum type) | sgObject::ICanvas
SetMapRotateMode([in] MapRotateEnum type) | sgObject::ICanvas
SetMotionSensor([in] IMotionSensor *pdspSensor) | sgObject::ICanvas
SetObjectiveSpatialReference([in] ISpatialReference *pVal) | sgObject::ICanvas
SetState([in] int newVal) | sgObject::ICanvas
SetTitle([in] BSTR newVal) | sgObject::ICanvas
SetVideoSensor([in] IVideoSensor *pdspSensor) | sgObject::ICanvas
VisibleMapControl([in] SystemResourceEnum type, [in] VARIANT_BOOL bVisible) | sgObject::ICanvas
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGraphicIcon 인터페이스 참조

  • IGraphicIcon
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGraphicIcon 인터페이스 참조

아이콘의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::IGraphicIcon에 대한 상속 다이어그램 :
sgObject::IGraphicIcon에 대한 협력 다이어그램:

Public 멤버 함수

void | SetIconFromString ([in] BSTR bstrFilePath)
void | SetPosition ([in] float x, [in] float y)
void | GetPosition ([out] float *x, [out] float *y)
void | SetOffset ([in] float x, [in] float y)
void | GetOffset ([out] float *x, [out] float *y)

상세한 설명

아이콘의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "GPI"를 덧붙여서 "OGR_GPI_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.GraphicIcon"

멤버 함수 문서화

void sgObject::IGraphicIcon::GetOffset | ( | [out] float * | x,
 |  | [out] float * | y
 | ) |  |
void sgObject::IGraphicIcon::GetPosition | ( | [out] float * | x,
 |  | [out] float * | y
 | ) |  |
void sgObject::IGraphicIcon::SetIconFromString ( [in] BSTR bstrFilePath )
void sgObject::IGraphicIcon::SetOffset | ( | [in] float | x,
 |  | [in] float | y
 | ) |  |
void sgObject::IGraphicIcon::SetPosition | ( | [in] float | x,
 |  | [in] float | y
 | ) |  |
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGraphicIcon
sgObject::IGraphicIcon 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGraphicIcon (모든 상속된 멤버들도 포함합니다.)

GetOffset([out] float *x, [out] float *y) | sgObject::IGraphicIcon
GetPosition([out] float *x, [out] float *y) | sgObject::IGraphicIcon
SetIconFromString([in] BSTR bstrFilePath) | sgObject::IGraphicIcon
SetOffset([in] float x, [in] float y) | sgObject::IGraphicIcon
SetPosition([in] float x, [in] float y) | sgObject::IGraphicIcon
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGraphicLabel 인터페이스 참조

  • IGraphicLabel
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGraphicLabel 인터페이스 참조

텍스트의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::IGraphicLabel에 대한 상속 다이어그램 :
sgObject::IGraphicLabel에 대한 협력 다이어그램:

Public 멤버 함수

BSTR | GetText ()
그래픽 객체로 표현될 텍스트를 설정한다. 더 자세히 ...
void | SetText ([in] BSTR bstrText)
int | GetTextSize ()
그래픽 객체로 표현될 텍스트의 크기를 반환한다. 더 자세히 ...
void | SetTextSize (int nSize)
void | SetXAnchor (int anchor)
그래픽 객체의 X축 앵커를 설정/반환 한다. 더 자세히 ...
int | GetXAnchor ()
void | SetYAnchor (int anchor)
그래픽 객체의 Y축 앵커를 설정한다. 더 자세히 ...
int | GetYAnchor ()
void | SetPosition ([in] float x, [in] float y)
그래픽 객체로 표현될 텍스트의 위치를 설정한다. 더 자세히 ...
void | GetPosition ([out] float *x, [out] float *y)
그래픽 객체로 표현될 텍스트의 위치를 반환한다. 더 자세히 ...

상세한 설명

텍스트의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "GPT"를 덧붙여서 "OGR_GPT_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.GraphicLabel"

멤버 함수 문서화

void sgObject::IGraphicLabel::GetPosition | ( | [out] float * | x,
 |  | [out] float * | y
 | ) |  |

그래픽 객체로 표현될 텍스트의 위치를 반환한다.

BSTR sgObject::IGraphicLabel::GetText ( )

그래픽 객체로 표현될 텍스트를 설정한다.

int sgObject::IGraphicLabel::GetTextSize ( )

그래픽 객체로 표현될 텍스트의 크기를 반환한다.

int sgObject::IGraphicLabel::GetXAnchor ( )
int sgObject::IGraphicLabel::GetYAnchor ( )
void sgObject::IGraphicLabel::SetPosition | ( | [in] float | x,
 |  | [in] float | y
 | ) |  |

그래픽 객체로 표현될 텍스트의 위치를 설정한다.

void sgObject::IGraphicLabel::SetText ( [in] BSTR bstrText )
void sgObject::IGraphicLabel::SetTextSize ( int nSize )
void sgObject::IGraphicLabel::SetXAnchor ( int anchor )

그래픽 객체의 X축 앵커를 설정/반환 한다.

void sgObject::IGraphicLabel::SetYAnchor ( int anchor )

그래픽 객체의 Y축 앵커를 설정한다.

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGraphicLabel
sgObject::IGraphicLabel 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGraphicLabel (모든 상속된 멤버들도 포함합니다.)

GetPosition([out] float *x, [out] float *y) | sgObject::IGraphicLabel
GetText() | sgObject::IGraphicLabel
GetTextSize() | sgObject::IGraphicLabel
GetXAnchor() | sgObject::IGraphicLabel
GetYAnchor() | sgObject::IGraphicLabel
SetPosition([in] float x, [in] float y) | sgObject::IGraphicLabel
SetText([in] BSTR bstrText) | sgObject::IGraphicLabel
SetTextSize(int nSize) | sgObject::IGraphicLabel
SetXAnchor(int anchor) | sgObject::IGraphicLabel
SetYAnchor(int anchor) | sgObject::IGraphicLabel
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGraphicLineString 인터페이스 참조

  • IGraphicLineString
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGraphicLineString 인터페이스 참조

라인의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::IGraphicLineString에 대한 상속 다이어그램 :
sgObject::IGraphicLineString에 대한 협력 다이어그램:

Public 멤버 함수

void | AddPoint ([in] float x, [in] float y)
객체의 가장 뒤에 점을 추가한다. 더 자세히 ...
void | DeletePoint ([in] int index)
해당 인덱스의 점을 제거한다. 더 자세히 ...
void | InsertPoint ([in] int index, [in] float x, [in] float y)
해당 인덱스에 점을 추가한다. 더 자세히 ...
void | SetPoint ([in] int index, [in] float x, [in] float y)
해당 인덱스에 점의 좌표를 변경한다. 더 자세히 ...
VARIANT_BOOL | IsClosed ()
닫혀있는지 여부를 반환한다. (시작점과 종료점이 동일여부) 더 자세히 ...

상세한 설명

라인의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "GPL"를 덧붙여서 "OGR_GPL_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.GraphicLineString"

멤버 함수 문서화

void sgObject::IGraphicLineString::AddPoint | ( | [in] float | x,
 |  | [in] float | y
 | ) |  |

객체의 가장 뒤에 점을 추가한다.

매개변수
x | - 추가될 점 객체의 x 좌표
y | - 추가될 점 객체의 y 좌표
void sgObject::IGraphicLineString::DeletePoint ( [in] int index )

해당 인덱스의 점을 제거한다.

매개변수
index - 인덱스 번호
void sgObject::IGraphicLineString::InsertPoint | ( | [in] int | index,
 |  | [in] float | x,
 |  | [in] float | y
 | ) |  |

해당 인덱스에 점을 추가한다.

매개변수
index | - 추가할 인덱스 번호
x | - 추가될 점 객체의 x 좌표
y | - 추가될 점 객체의 y 좌표
VARIANT_BOOL sgObject::IGraphicLineString::IsClosed ( )

닫혀있는지 여부를 반환한다. (시작점과 종료점이 동일여부)

void sgObject::IGraphicLineString::SetPoint | ( | [in] int | index,
 |  | [in] float | x,
 |  | [in] float | y
 | ) |  |

해당 인덱스에 점의 좌표를 변경한다.

매개변수
index | - 변경할 인덱스 번호
x | - 변경될 점 객체의 x 좌표
y | - 변경될 점 객체의 y 좌표
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGraphicLineString
sgObject::IGraphicLineString 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGraphicLineString (모든 상속된 멤버들도 포함합니다.)

AddPoint([in] float x, [in] float y) | sgObject::IGraphicLineString
DeletePoint([in] int index) | sgObject::IGraphicLineString
InsertPoint([in] int index, [in] float x, [in] float y) | sgObject::IGraphicLineString
IsClosed() | sgObject::IGraphicLineString
SetPoint([in] int index, [in] float x, [in] float y) | sgObject::IGraphicLineString
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGraphicPolygon 인터페이스 참조

  • IGraphicPolygon
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGraphicPolygon 인터페이스 참조

폴리곤 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::IGraphicPolygon에 대한 상속 다이어그램 :
sgObject::IGraphicPolygon에 대한 협력 다이어그램:

Public 멤버 함수

void | GetExteriorPoint ([in] int index, [out] float *x, [out] float *y)
void | AddExteriorPoint ([in] float x, [in] float y)
void | InsertExteriorPoint ([in] int index, [in] float x, [in] float y)
void | SetExteriorPoint ([in] int index, [in] float x, [in] float y)
void | RemoveExteriorPoint ([in] int index)
int | GetNumExteriorPoints ()
void | GetInteriorPoint ([in] int index, [in] int interiorRingIndex, [out] float *x, [out] float *y)
void | AddInteriorPoint ([in] int interiorRingIndex, [in] float x, [in] float y)
void | InsertInteriorPoint ([in] int index, [in] int interiorRingIndex, [in] float x, [in] float y)
void | SetInteriorPoint ([in] int index, [in] int interiorRingIndex, [in] float x, [in] float y)
void | RemoveInteriorPoint ([in] int index, [in] int interiorRingIndex)
int | GetNumInteriorPoints ([in] int interiorRingIndex)
void | RemoveInteriorRing ([in] int interiorRingIndex)
int | GetNumInteriorRings ()
void | SetPathType ([in] int pathType)
int | GetPathType ()
VARIANT_BOOL | IsAllowingNewVertices ()
void | SetAllowingNewVertices ([in] VARIANT_BOOL newValue)

상세한 설명

폴리곤 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "GPP"를 덧붙여서 "OGR_GPP_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.GraphicPolygon"

멤버 함수 문서화

void sgObject::IGraphicPolygon::AddExteriorPoint | ( | [in] float | x,
 |  | [in] float | y
 | ) |  |
void sgObject::IGraphicPolygon::AddInteriorPoint | ( | [in] int | interiorRingIndex,
 |  | [in] float | x,
 |  | [in] float | y
 | ) |  |
void sgObject::IGraphicPolygon::GetExteriorPoint | ( | [in] int | index,
 |  | [out] float * | x,
 |  | [out] float * | y
 | ) |  |
void sgObject::IGraphicPolygon::GetInteriorPoint | ( | [in] int | index,
 |  | [in] int | interiorRingIndex,
 |  | [out] float * | x,
 |  | [out] float * | y
 | ) |  |
int sgObject::IGraphicPolygon::GetNumExteriorPoints ( )
int sgObject::IGraphicPolygon::GetNumInteriorPoints ( [in] int interiorRingIndex )
int sgObject::IGraphicPolygon::GetNumInteriorRings ( )
int sgObject::IGraphicPolygon::GetPathType ( )
void sgObject::IGraphicPolygon::InsertExteriorPoint | ( | [in] int | index,
 |  | [in] float | x,
 |  | [in] float | y
 | ) |  |
void sgObject::IGraphicPolygon::InsertInteriorPoint | ( | [in] int | index,
 |  | [in] int | interiorRingIndex,
 |  | [in] float | x,
 |  | [in] float | y
 | ) |  |
VARIANT_BOOL sgObject::IGraphicPolygon::IsAllowingNewVertices ( )
void sgObject::IGraphicPolygon::RemoveExteriorPoint ( [in] int index )
void sgObject::IGraphicPolygon::RemoveInteriorPoint | ( | [in] int | index,
 |  | [in] int | interiorRingIndex
 | ) |  |
void sgObject::IGraphicPolygon::RemoveInteriorRing ( [in] int interiorRingIndex )
void sgObject::IGraphicPolygon::SetAllowingNewVertices ( [in] VARIANT_BOOL newValue )
void sgObject::IGraphicPolygon::SetExteriorPoint | ( | [in] int | index,
 |  | [in] float | x,
 |  | [in] float | y
 | ) |  |
void sgObject::IGraphicPolygon::SetInteriorPoint | ( | [in] int | index,
 |  | [in] int | interiorRingIndex,
 |  | [in] float | x,
 |  | [in] float | y
 | ) |  |
void sgObject::IGraphicPolygon::SetPathType ( [in] int pathType )
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGraphicPolygon
sgObject::IGraphicPolygon 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGraphicPolygon (모든 상속된 멤버들도 포함합니다.)

AddExteriorPoint([in] float x, [in] float y) | sgObject::IGraphicPolygon
AddInteriorPoint([in] int interiorRingIndex, [in] float x, [in] float y) | sgObject::IGraphicPolygon
GetExteriorPoint([in] int index, [out] float *x, [out] float *y) | sgObject::IGraphicPolygon
GetInteriorPoint([in] int index, [in] int interiorRingIndex, [out] float *x, [out] float *y) | sgObject::IGraphicPolygon
GetNumExteriorPoints() | sgObject::IGraphicPolygon
GetNumInteriorPoints([in] int interiorRingIndex) | sgObject::IGraphicPolygon
GetNumInteriorRings() | sgObject::IGraphicPolygon
GetPathType() | sgObject::IGraphicPolygon
InsertExteriorPoint([in] int index, [in] float x, [in] float y) | sgObject::IGraphicPolygon
InsertInteriorPoint([in] int index, [in] int interiorRingIndex, [in] float x, [in] float y) | sgObject::IGraphicPolygon
IsAllowingNewVertices() | sgObject::IGraphicPolygon
RemoveExteriorPoint([in] int index) | sgObject::IGraphicPolygon
RemoveInteriorPoint([in] int index, [in] int interiorRingIndex) | sgObject::IGraphicPolygon
RemoveInteriorRing([in] int interiorRingIndex) | sgObject::IGraphicPolygon
SetAllowingNewVertices([in] VARIANT_BOOL newValue) | sgObject::IGraphicPolygon
SetExteriorPoint([in] int index, [in] float x, [in] float y) | sgObject::IGraphicPolygon
SetInteriorPoint([in] int index, [in] int interiorRingIndex, [in] float x, [in] float y) | sgObject::IGraphicPolygon
SetPathType([in] int pathType) | sgObject::IGraphicPolygon
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGraphicRectangle 인터페이스 참조

  • IGraphicRectangle
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGraphicRectangle 인터페이스 참조

사각형의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::IGraphicRectangle에 대한 상속 다이어그램 :
sgObject::IGraphicRectangle에 대한 협력 다이어그램:

Public 멤버 함수

void | SetCenter ([in] float x, [in] float y)
void | GetCenter ([out] float *x, [out] float *y)
void | SetWidth ([in] float w)
float | GetWidth ()
void | SetHeight ([in] float h)
float | GetHeight ()
VARIANT_BOOL | IsAllowingRotation ()
void | SetAllowingRotation ([in] VARIANT_BOOL)
VARIANT_BOOL | IsAllowingExtentsChang ()
void | SetAllowingExtentsChang ([in] VARIANT_BOOL)
float | GetRoundX ()
void | SetRoundX ([in] float x)
float | GetRoundY ()
void | SetRoundY ([in] float y)

상세한 설명

사각형의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "GPR"를 덧붙여서 "OGR_GPR_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.GraphicRectangle"

멤버 함수 문서화

void sgObject::IGraphicRectangle::GetCenter | ( | [out] float * | x,
 |  | [out] float * | y
 | ) |  |
float sgObject::IGraphicRectangle::GetHeight ( )
float sgObject::IGraphicRectangle::GetRoundX ( )
float sgObject::IGraphicRectangle::GetRoundY ( )
float sgObject::IGraphicRectangle::GetWidth ( )
VARIANT_BOOL sgObject::IGraphicRectangle::IsAllowingExtentsChang ( )
VARIANT_BOOL sgObject::IGraphicRectangle::IsAllowingRotation ( )
void sgObject::IGraphicRectangle::SetAllowingExtentsChang ( [in] VARIANT_BOOL )
void sgObject::IGraphicRectangle::SetAllowingRotation ( [in] VARIANT_BOOL )
void sgObject::IGraphicRectangle::SetCenter | ( | [in] float | x,
 |  | [in] float | y
 | ) |  |
void sgObject::IGraphicRectangle::SetHeight ( [in] float h )
void sgObject::IGraphicRectangle::SetRoundX ( [in] float x )
void sgObject::IGraphicRectangle::SetRoundY ( [in] float y )
void sgObject::IGraphicRectangle::SetWidth ( [in] float w )
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGraphicRectangle
sgObject::IGraphicRectangle 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGraphicRectangle (모든 상속된 멤버들도 포함합니다.)

GetCenter([out] float *x, [out] float *y) | sgObject::IGraphicRectangle
GetHeight() | sgObject::IGraphicRectangle
GetRoundX() | sgObject::IGraphicRectangle
GetRoundY() | sgObject::IGraphicRectangle
GetWidth() | sgObject::IGraphicRectangle
IsAllowingExtentsChang() | sgObject::IGraphicRectangle
IsAllowingRotation() | sgObject::IGraphicRectangle
SetAllowingExtentsChang([in] VARIANT_BOOL) | sgObject::IGraphicRectangle
SetAllowingRotation([in] VARIANT_BOOL) | sgObject::IGraphicRectangle
SetCenter([in] float x, [in] float y) | sgObject::IGraphicRectangle
SetHeight([in] float h) | sgObject::IGraphicRectangle
SetRoundX([in] float x) | sgObject::IGraphicRectangle
SetRoundY([in] float y) | sgObject::IGraphicRectangle
SetWidth([in] float w) | sgObject::IGraphicRectangle
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGraphicScaledImage 인터페이스 참조

  • IGraphicScaledImage
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGraphicScaledImage 인터페이스 참조

입력된 스케일과 이미지로 그래픽 객체를 표현하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::IGraphicScaledImage에 대한 상속 다이어그램 :
sgObject::IGraphicScaledImage에 대한 협력 다이어그램:

Public 멤버 함수

void | SetScaledImageFromString ([in] BSTR bstrFileName)
void | SetUpperLeft ([in] float x, [in] float y)
void | GetUpperLeft ([out] float *x, [out] float *y)
void | SetLowerRight ([in] float x, [in] float y)
void | GetLowerRight ([out] float *x, [out] float *y)
void | SetIntensity ([in] int intensity)
int | GetIntensity ()
void | SetTransparency ([in] int transparency)
int | GetTransparency ()
void | SetCRS ([in] ISpatialReference *crs)
ISpatialReference * GetCRS ()

상세한 설명

입력된 스케일과 이미지로 그래픽 객체를 표현하는 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "GPS"를 덧붙여서 "OGR_GPS_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.GraphicScaledImage"

멤버 함수 문서화

ISpatialReference* sgObject::IGraphicScaledImage::GetCRS ( )
int sgObject::IGraphicScaledImage::GetIntensity ( )
void sgObject::IGraphicScaledImage::GetLowerRight | ( | [out] float * | x,
 |  | [out] float * | y
 | ) |  |
int sgObject::IGraphicScaledImage::GetTransparency ( )
void sgObject::IGraphicScaledImage::GetUpperLeft | ( | [out] float * | x,
 |  | [out] float * | y
 | ) |  |
void sgObject::IGraphicScaledImage::SetCRS ( [in] ISpatialReference * crs )
void sgObject::IGraphicScaledImage::SetIntensity ( [in] int intensity )
void sgObject::IGraphicScaledImage::SetLowerRight | ( | [in] float | x,
 |  | [in] float | y
 | ) |  |
void sgObject::IGraphicScaledImage::SetScaledImageFromString ( [in] BSTR bstrFileName )
void sgObject::IGraphicScaledImage::SetTransparency ( [in] int transparency )
void sgObject::IGraphicScaledImage::SetUpperLeft | ( | [in] float | x,
 |  | [in] float | y
 | ) |  |
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGraphicScaledImage
sgObject::IGraphicScaledImage 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGraphicScaledImage (모든 상속된 멤버들도 포함합니다.)

GetCRS() | sgObject::IGraphicScaledImage
GetIntensity() | sgObject::IGraphicScaledImage
GetLowerRight([out] float *x, [out] float *y) | sgObject::IGraphicScaledImage
GetTransparency() | sgObject::IGraphicScaledImage
GetUpperLeft([out] float *x, [out] float *y) | sgObject::IGraphicScaledImage
SetCRS([in] ISpatialReference *crs) | sgObject::IGraphicScaledImage
SetIntensity([in] int intensity) | sgObject::IGraphicScaledImage
SetLowerRight([in] float x, [in] float y) | sgObject::IGraphicScaledImage
SetScaledImageFromString([in] BSTR bstrFileName) | sgObject::IGraphicScaledImage
SetTransparency([in] int transparency) | sgObject::IGraphicScaledImage
SetUpperLeft([in] float x, [in] float y) | sgObject::IGraphicScaledImage
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGridAnalysis 인터페이스 참조

  • IGridAnalysis
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGridAnalysis 인터페이스 참조
sgObject::IGridAnalysis에 대한 상속 다이어그램 :
sgObject::IGridAnalysis에 대한 협력 다이어그램:

Public 멤버 함수

double | GetMinValue (int sampleDimension)
double | GetMaxValue (int sampleDimension)
double | GetMeanValue (int sampleDimension)
double | GetMedianValue (int sampleDimension)
double | GetModeValue (int sampleDimension)
double | GetStandardDeviation (int sampleDimension)
IHistogram * | GetHistogram (int sampleDimension, double minimumEntryValue, double maximumEntryValue, int numberEntries)

멤버 함수 문서화

IHistogram* sgObject::IGridAnalysis::GetHistogram | ( | int | sampleDimension,
 |  | double | minimumEntryValue,
 |  | double | maximumEntryValue,
 |  | int | numberEntries
 | ) |  |
double sgObject::IGridAnalysis::GetMaxValue ( int sampleDimension )
double sgObject::IGridAnalysis::GetMeanValue ( int sampleDimension )
double sgObject::IGridAnalysis::GetMedianValue ( int sampleDimension )
double sgObject::IGridAnalysis::GetMinValue ( int sampleDimension )
double sgObject::IGridAnalysis::GetModeValue ( int sampleDimension )
double sgObject::IGridAnalysis::GetStandardDeviation ( int sampleDimension )
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGridAnalysis
sgObject::IGridAnalysis 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGridAnalysis (모든 상속된 멤버들도 포함합니다.)

GetHistogram(int sampleDimension, double minimumEntryValue, double maximumEntryValue, int numberEntries) | sgObject::IGridAnalysis
GetMaxValue(int sampleDimension) | sgObject::IGridAnalysis
GetMeanValue(int sampleDimension) | sgObject::IGridAnalysis
GetMedianValue(int sampleDimension) | sgObject::IGridAnalysis
GetMinValue(int sampleDimension) | sgObject::IGridAnalysis
GetModeValue(int sampleDimension) | sgObject::IGridAnalysis
GetStandardDeviation(int sampleDimension) | sgObject::IGridAnalysis
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGridColorRampItem 인터페이스 참조

  • IGridColorRampItem
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGridColorRampItem 인터페이스 참조

FeatureTypeStyleRule에서 상속된 객체로 GridTypeStyle의 Rule에 의해 정의되는 표현 색상에 대한 정보 및 더 자세히 ...

sgObject::IGridColorRampItem에 대한 상속 다이어그램 :
sgObject::IGridColorRampItem에 대한 협력 다이어그램:

Public 멤버 함수

DOUBLE | GetValue ()
래스터 표현 규정의 값 더 자세히 ...
void | SetValue (DOUBLE dVal)
OLE_COLOR | GetColor ()
래스터 표현 규정의 색상 더 자세히 ...
void | SetColor (OLE_COLOR color)
- sgObject::IFeatureTypeStyleRule(으)로부터 상속된 Public 멤버 함수
BSTR | GetTitle ()
설정 규정의 제목 더 자세히 ...
void | SetTitle (BSTR szVal)
BSTR | GetFilter ()
규정의 조건문으로 SQL문의 Where조건과 유사 더 자세히 ...
void | SetFilter (BSTR szVal)
DOUBLE | GetMinScaleDenominator ()
해당 규정이 적용되는 최소 화면 스케일 더 자세히 ...
void | SetMinScaleDenominator (DOUBLE dVal)
DOUBLE | GetMaxScaleDenominator ()
해당 규정이 적용되는 최대 화면 스케일 더 자세히 ...
void | SetMaxScaleDenominator (DOUBLE dVal)
ISymbolizer * GetSymbolizer ()
규정에 해당하는 Feature를 그리기 위한 심볼(스타일) 더 자세히 ...
void | SetSymbolizer (ISymbolizer *pdspVal)
void | SetFeatureStyleColor (OLE_COLOR color)
규정에 해당하는 Feature를 그리기 위한 기본 색상(기본 심볼(스타일)타입 사용)을 설정한다. 더 자세히 ...
VARIANT_BOOL | IsValidFilter (IFeatureType *pdsFtType, IFeature *pdsFt)
해당 Feature가 규정에 적용된 필터값에 유효한지 여부를 반환한다. 더 자세히 ...
IFeatureTypeStyle * GetFeatureTypeStyle ()
규정이 포함된 상위 FeatureTypeStyle을 반환한다. 더 자세히 ...
IFeatureTypeStyleRule * Clone ()
규정의 복제본을 반환한다. 더 자세히 ...
VARIANT_BOOL | GetVisible ()
규정의 보기여부를 반환한다. 더 자세히 ...
void | SetVisible (VARIANT_BOOL bVisible)
규정을 보기여부를 설정한다. 더 자세히 ...

상세한 설명

FeatureTypeStyleRule에서 상속된 객체로 GridTypeStyle의 Rule에 의해 정의되는 표현 색상에 대한 정보 및

표현 색상에 대해 일괄 설정 인터페이스를 제공한다. C API(linux, iOS, MacOS 등) : 중간이름 "GCI"를 덧붙여서 "OGR_GCI_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.GridColorRampItem"

멤버 함수 문서화

OLE_COLOR sgObject::IGridColorRampItem::GetColor ( )

래스터 표현 규정의 색상

DOUBLE sgObject::IGridColorRampItem::GetValue ( )

래스터 표현 규정의 값

void sgObject::IGridColorRampItem::SetColor ( OLE_COLOR color )
void sgObject::IGridColorRampItem::SetValue ( DOUBLE dVal )
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGridColorRampItem
sgObject::IGridColorRampItem 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGridColorRampItem (모든 상속된 멤버들도 포함합니다.)

Clone() | sgObject::IFeatureTypeStyleRule
GetColor() | sgObject::IGridColorRampItem
GetFeatureTypeStyle() | sgObject::IFeatureTypeStyleRule
GetFilter() | sgObject::IFeatureTypeStyleRule
GetMaxScaleDenominator() | sgObject::IFeatureTypeStyleRule
GetMinScaleDenominator() | sgObject::IFeatureTypeStyleRule
GetSymbolizer() | sgObject::IFeatureTypeStyleRule
GetTitle() | sgObject::IFeatureTypeStyleRule
GetValue() | sgObject::IGridColorRampItem
GetVisible() | sgObject::IFeatureTypeStyleRule
IsValidFilter(IFeatureType *pdsFtType, IFeature *pdsFt) | sgObject::IFeatureTypeStyleRule
SetColor(OLE_COLOR color) | sgObject::IGridColorRampItem
SetFeatureStyleColor(OLE_COLOR color) | sgObject::IFeatureTypeStyleRule
SetFilter(BSTR szVal) | sgObject::IFeatureTypeStyleRule
SetMaxScaleDenominator(DOUBLE dVal) | sgObject::IFeatureTypeStyleRule
SetMinScaleDenominator(DOUBLE dVal) | sgObject::IFeatureTypeStyleRule
SetSymbolizer(ISymbolizer *pdspVal) | sgObject::IFeatureTypeStyleRule
SetTitle(BSTR szVal) | sgObject::IFeatureTypeStyleRule
SetValue(DOUBLE dVal) | sgObject::IGridColorRampItem
SetVisible(VARIANT_BOOL bVisible) | sgObject::IFeatureTypeStyleRule
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGridColorRampStyle 인터페이스 참조

  • IGridColorRampStyle
모든 멤버 목록
sgObject::IGridColorRampStyle 인터페이스 참조

GridTypeStyle로 부터 상속된 래스터를 위한 래스터 표현 규정을 일괄 정의한 인터페이스를 제공한다. 더 자세히 ...

sgObject::IGridColorRampStyle에 대한 상속 다이어그램 :
sgObject::IGridColorRampStyle에 대한 협력 다이어그램:

추가로 상속된 멤버들

- sgObject::IGridTypeStyle(으)로부터 상속된 Public 멤버 함수
GridColorTypeEnum GetGridColorType ()
색상값 규정의 범위에 들지 않는 값에 대한 색상 선정 알고리즘을 반환한다. 더 자세히 ...
void | SetGridColorType ([in] GridColorTypeEnum eType)
색상값 규정의 범위에 들지 않는 값에 대한 색상 선정 알고리즘을 설정한다. 더 자세히 ...
DOUBLE | GetMinimumValue ()
값 규정의 최소값을 반환한다. 더 자세히 ...
void | SetMinimumValue ([in] DOUBLE dVal)
값 규정의 최소값을 설정한다. 더 자세히 ...
DOUBLE | GetMaximumValue ()
값 규정의 최대값을 반환한다. 더 자세히 ...
void | SetMaximumValue ([in] DOUBLE dVal)
값 규정의 최대값을 설정한다. 더 자세히 ...
DOUBLE | GetStandardDeviation ()
값 규정의 표준편차값을 반환한다. 더 자세히 ...
void | SetStandardDeviation ([in] DOUBLE dVal)
값 규정의 표준편차값을 설정한다. 더 자세히 ...
long | GetShadeColor ([in] DOUBLE dVal)
입력된 값에 해당하는 색상을 알고리즘으로부터 반환한다. 더 자세히 ...
PaletteInterpretationEnum GetShadePaletteInterpretation ()
채색을 위해 사용할 색상 판별방법 반환한다. 더 자세히 ...
void | SetShadePaletteInterpretation ([in] PaletteInterpretationEnum interp)
채색을 위해 사용할 색상 판별방법을 설정 한다. 더 자세히 ...
void | ShadeColorInterpretationRemoveAll ()
채색을 위해 사용할 색상 판별방법에 해당하는 개별 밴드의 색상 정보를 모두 제거한다. 더 자세히 ...
void | ShadeColorInterpretationAdd ([in] int bandidx, [in] ColorInterpretationEnum bandtype)
채색을 위해 사용할 색상 판별방법에 해당하는 개별 밴드의 색상 정보를 설정한다. 더 자세히 ...
int | GetShadeColorInterpretationSize ()
채색을 위해 사용할 색상 판별방법에 해당하는 밴드별 정보의 개수를 반환한다. 더 자세히 ...
int | GetShadeIndexByOrder ([in] int bandidx)
채색을 위해 사용할 색상 판별방법에 해당 순서의 밴드번호를 반환한다. 더 자세히 ...
ColorInterpretationEnum | GetShadeColorInterpretationByOrder ([in] int bandidx)
채색을 위해 사용할 색상 판별방법에 해당 순서의 색상 정보를 반환한다. 더 자세히 ...
ColorInterpretationEnum | GetShadeColorInterpretation ([in] int bandidx)
채색을 위해 사용할 색상 판별방법에 해당 밴드번호의 색상 정보를 반환한다. 더 자세히 ...
int | GetShadeIndexByColorInterpretation ([in] ColorInterpretationEnum bandtype)
채색을 위해 사용할 색상 판별방법에 해당 색상 정보의 밴드번호를 반환한다. 더 자세히 ...
void | SetEffectFilter ([in] FilterTypeEnum eType, [in] double amount)
채색 효과를 추가 설정한다. 더 자세히 ...
void | RemoveEffectFilter ([in] FilterTypeEnum eType)
채색 효과를 제거한다. 더 자세히 ...
void | ClearEffectFilter ()
모든 채색 효과를 제거한다. 더 자세히 ...
double | GetEffectFilter ([in] FilterTypeEnum eType)
채색 효과로 설정한 값을 반환한다. 더 자세히 ...
- sgObject::IFeatureTypeStyle(으)로부터 상속된 Public 멤버 함수
int | GetSize ()
설정된 규정의 개수를 반환한다. 더 자세히 ...
FeatureTypeStyleEnum GetStyleType ()
설정된 규정의 채색 방법을 반환한다. 더 자세히 ...
void | SetStyleType (FeatureTypeStyleEnum eType)
채색 규정을 설정한다. 더 자세히 ...
ISymbolizer * GetElseFilterFeatureStyle ()
규정에 의해 설정되지 않는 값들의 심볼(스타일) 규정을 반환한다. 더 자세히 ...
void | SetElseFilterFeatureStyle ([in] ISymbolizer *pdsSymbol)
규정에 의해 설정되지 않는 값들의 심볼(스타일) 규정을 설정한다. 더 자세히 ...
void | AddRule ([in] IFeatureTypeStyleRule *pdsRule)
규정을 추가한다. 더 자세히 ...
IFeatureTypeStyleRule * | GetRule ([in] long idx)
해당 인덱스번호의 규정을 반환한다. 더 자세히 ...
void | RemoveRule ([in] IFeatureTypeStyleRule *pdsRule)
규정을 삭제한다. 더 자세히 ...
void | RemoveAll ()
설정한 모든 규정을 삭제한다. 더 자세히 ...
VARIANT_BOOL | GetElseFilterVisible ()
규정의 보기여부를 반환한다. 더 자세히 ...
void | SetElseFilterVisible (VARIANT_BOOL bVisible)
규정을 보기여부를 설정한다. 더 자세히 ...

상세한 설명

GridTypeStyle로 부터 상속된 래스터를 위한 래스터 표현 규정을 일괄 정의한 인터페이스를 제공한다.

시스템 내부에 설정된 기본 칼라램프스타일(고도, 경사, 향)에 사용된다. C API(linux, iOS, MacOS 등) : 중간이름 "GCS"를 덧붙여서 "OGR_GCS_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.GridColorRampStyle"

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGridColorRampStyle
sgObject::IGridColorRampStyle 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGridColorRampStyle (모든 상속된 멤버들도 포함합니다.)

AddRule([in] IFeatureTypeStyleRule *pdsRule) | sgObject::IFeatureTypeStyle
ClearEffectFilter() | sgObject::IGridTypeStyle
GetEffectFilter([in] FilterTypeEnum eType) | sgObject::IGridTypeStyle
GetElseFilterFeatureStyle() | sgObject::IFeatureTypeStyle
GetElseFilterVisible() | sgObject::IFeatureTypeStyle
GetGridColorType() | sgObject::IGridTypeStyle
GetMaximumValue() | sgObject::IGridTypeStyle
GetMinimumValue() | sgObject::IGridTypeStyle
GetRule([in] long idx) | sgObject::IFeatureTypeStyle
GetShadeColor([in] DOUBLE dVal) | sgObject::IGridTypeStyle
GetShadeColorInterpretation([in] int bandidx) | sgObject::IGridTypeStyle
GetShadeColorInterpretationByOrder([in] int bandidx) | sgObject::IGridTypeStyle
GetShadeColorInterpretationSize() | sgObject::IGridTypeStyle
GetShadeIndexByColorInterpretation([in] ColorInterpretationEnum bandtype) | sgObject::IGridTypeStyle
GetShadeIndexByOrder([in] int bandidx) | sgObject::IGridTypeStyle
GetShadePaletteInterpretation() | sgObject::IGridTypeStyle
GetSize() | sgObject::IFeatureTypeStyle
GetStandardDeviation() | sgObject::IGridTypeStyle
GetStyleType() | sgObject::IFeatureTypeStyle
RemoveAll() | sgObject::IFeatureTypeStyle
RemoveEffectFilter([in] FilterTypeEnum eType) | sgObject::IGridTypeStyle
RemoveRule([in] IFeatureTypeStyleRule *pdsRule) | sgObject::IFeatureTypeStyle
SetEffectFilter([in] FilterTypeEnum eType, [in] double amount) | sgObject::IGridTypeStyle
SetElseFilterFeatureStyle([in] ISymbolizer *pdsSymbol) | sgObject::IFeatureTypeStyle
SetElseFilterVisible(VARIANT_BOOL bVisible) | sgObject::IFeatureTypeStyle
SetGridColorType([in] GridColorTypeEnum eType) | sgObject::IGridTypeStyle
SetMaximumValue([in] DOUBLE dVal) | sgObject::IGridTypeStyle
SetMinimumValue([in] DOUBLE dVal) | sgObject::IGridTypeStyle
SetShadePaletteInterpretation([in] PaletteInterpretationEnum interp) | sgObject::IGridTypeStyle
SetStandardDeviation([in] DOUBLE dVal) | sgObject::IGridTypeStyle
SetStyleType(FeatureTypeStyleEnum eType) | sgObject::IFeatureTypeStyle
ShadeColorInterpretationAdd([in] int bandidx, [in] ColorInterpretationEnum bandtype) | sgObject::IGridTypeStyle
ShadeColorInterpretationRemoveAll() | sgObject::IGridTypeStyle
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGridCoverage 인터페이스 참조

  • IGridCoverage
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGridCoverage 인터페이스 참조

IGridCoverage 인터페이스는 데이터 공급 업체와 그리드를 (래스터) 분석 및 처리 기능을 제공하는 소프트웨어 공급 업체에 의해 소프트웨어 구현 간의 상호 운용성을 허용 방법을 정의합니다. 더 자세히 ...

sgObject::IGridCoverage에 대한 상속 다이어그램 :
sgObject::IGridCoverage에 대한 협력 다이어그램:

Public 멤버 함수

BSTR | GetDescription ()
그리드 설명을 설정, 반환한다. 더 자세히 ...
void | SetDescription (BSTR strValue)
int | GetNumRow ()
그리드 세로(종)수를 반환한다. 더 자세히 ...
int | GetNumColumn ()
그리드 가로(횡)수를 반환한다. 더 자세히 ...
BSTR | GetMetadataValue (BSTR strDomain)
그리드가 가지고 있는 도메인의 메타정보를 설정, 반환한다. 더 자세히 ...
void | SetMetadataValue (BSTR strDomain, BSTR strValueList)
BSTR | GetMetadataItemValue (BSTR strName, BSTR strDomain)
그리드가 가지고 있는 도메인 메타객체정보를 설정, 반환한다. 더 자세히 ...
void | SetMetadataItemValue (BSTR strName, BSTR strDomain, BSTR strValue)
IGridSampleDimension * | AddGridSampleDimension (SampleDimensionTypeEnum eType, BSTR strOptions)
그리드에 밴드를 추가한다. 더 자세히 ...
double | GetPixelUnit ()
ICoverage * GetCoverage ()
상속된 인터페이스 객체를 반환한다. 더 자세히 ...
IGridAnalysis * GetGridAnalysis ()
VARIANT_BOOL | SetValueInBoundary ([in] IPolygon *dspRangeGeom, [in] IParameters *dspParams)
샘플차원에서의 주어진 영역내 값을 변경한다. 더 자세히 ...
- sgObject::ICoverage(으)로부터 상속된 Public 멤버 함수
long | GetNumSampleDimensions ()
커버리지에 대한 샘플차원의 개수(GridCoverage의 경우 Band의 개수) 더 자세히 ...
ISpatialReference * GetCoordinateSystem ()
커버리지에 대한 공간좌표계 더 자세히 ...
IGeometry * GetEnvelope ()
커버리지에 대한 MBR 범위 더 자세히 ...
ISampleDimension * | GetSampleDimension ([in] LONG Index)
커버리지에 대한 샘플차원 정보를 가져온다. 더 자세히 ...
void | Extent2D ([out] double *minX, [out] double *minY, [out] double *maxX, [out] double *maxY)

상세한 설명

IGridCoverage 인터페이스는 데이터 공급 업체와 그리드를 (래스터) 분석 및 처리 기능을 제공하는 소프트웨어 공급 업체에 의해 소프트웨어 구현 간의 상호 운용성을 허용 방법을 정의합니다.

위성 이미지, 디지털 항공 사진, 디지털 고도 데이터, 래스터 좌표계의 연속된 각 지점(Point)의 값으로 대표되는 다각형과 라인을 사용하여 분석 결과 뷰잉, 히스토그램 계산, 이미지 공분산(결합확률 분포를 이루는 두 확률변가 변화하는 양상을 측정하는 척도), 기타 통계적 측정과 같은 커버리지 분석 결과를 나타낸다. 특징1 하나의 그리드 값마다 다양한 수의 비트값을 지닌다(bits per pixel) 특징2 그리드 좌표계를 갖는다. 좌표계를 통해 그리드 내의 개별 화소를 찾아갈 수 있다. 각 그리드 화소의 중심이 그리드 포인트 좌표가 된다. C API(linux, iOS, MacOS 등) : 중간이름 "GC"를 덧붙여서 "OGR_GC_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.GridCoverage"

멤버 함수 문서화

IGridSampleDimension* sgObject::IGridCoverage::AddGridSampleDimension | ( | SampleDimensionTypeEnum | eType,
 |  | BSTR | strOptions
 | ) |  |

그리드에 밴드를 추가한다.

매개변수
eType | - 밴드의 자료형
strOptions | - 밴드 생성 옵션
반환값
ICoverage* sgObject::IGridCoverage::GetCoverage ( )

상속된 인터페이스 객체를 반환한다.

반환값
BSTR sgObject::IGridCoverage::GetDescription ( )

그리드 설명을 설정, 반환한다.

반환값
IGridAnalysis* sgObject::IGridCoverage::GetGridAnalysis ( )
BSTR sgObject::IGridCoverage::GetMetadataItemValue | ( | BSTR | strName,
 |  | BSTR | strDomain
 | ) |  |

그리드가 가지고 있는 도메인 메타객체정보를 설정, 반환한다.

매개변수
strName | - 객체명
strDomain | - 도메인명
반환값
BSTR sgObject::IGridCoverage::GetMetadataValue ( BSTR strDomain )

그리드가 가지고 있는 도메인의 메타정보를 설정, 반환한다.

매개변수
strDomain - 도메인명
반환값
int sgObject::IGridCoverage::GetNumColumn ( )

그리드 가로(횡)수를 반환한다.

반환값
int sgObject::IGridCoverage::GetNumRow ( )

그리드 세로(종)수를 반환한다.

반환값
double sgObject::IGridCoverage::GetPixelUnit ( )
void sgObject::IGridCoverage::SetDescription ( BSTR strValue )
void sgObject::IGridCoverage::SetMetadataItemValue | ( | BSTR | strName,
 |  | BSTR | strDomain,
 |  | BSTR | strValue
 | ) |  |
void sgObject::IGridCoverage::SetMetadataValue | ( | BSTR | strDomain,
 |  | BSTR | strValueList
 | ) |  |
VARIANT_BOOL sgObject::IGridCoverage::SetValueInBoundary | ( | [in] IPolygon * | dspRangeGeom,
 |  | [in] IParameters * | dspParams
 | ) |  |

샘플차원에서의 주어진 영역내 값을 변경한다.

매개변수
dspRangeGeom | - 연산 영역 폴리곤 객체
dspParams | - 변경할 밴드 정보 및 값 리스트, 출력 정보
반환값
성공 여부
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGridCoverage
sgObject::IGridCoverage 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGridCoverage (모든 상속된 멤버들도 포함합니다.)

AddGridSampleDimension(SampleDimensionTypeEnum eType, BSTR strOptions) | sgObject::IGridCoverage
Extent2D([out] double *minX, [out] double *minY, [out] double *maxX, [out] double *maxY) | sgObject::ICoverage
GetCoordinateSystem() | sgObject::ICoverage
GetCoverage() | sgObject::IGridCoverage
GetDescription() | sgObject::IGridCoverage
GetEnvelope() | sgObject::ICoverage
GetGridAnalysis() | sgObject::IGridCoverage
GetMetadataItemValue(BSTR strName, BSTR strDomain) | sgObject::IGridCoverage
GetMetadataValue(BSTR strDomain) | sgObject::IGridCoverage
GetNumColumn() | sgObject::IGridCoverage
GetNumRow() | sgObject::IGridCoverage
GetNumSampleDimensions() | sgObject::ICoverage
GetPixelUnit() | sgObject::IGridCoverage
GetSampleDimension([in] LONG Index) | sgObject::ICoverage
SetDescription(BSTR strValue) | sgObject::IGridCoverage
SetMetadataItemValue(BSTR strName, BSTR strDomain, BSTR strValue) | sgObject::IGridCoverage
SetMetadataValue(BSTR strDomain, BSTR strValueList) | sgObject::IGridCoverage
SetValueInBoundary([in] IPolygon *dspRangeGeom, [in] IParameters *dspParams) | sgObject::IGridCoverage
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGridCoverageProcessor 인터페이스 참조

  • IGridCoverageProcessor
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGridCoverageProcessor 인터페이스 참조

IGridCoverageProcessor 인터페이스는 그리드 커버리지 값에 접근할 수 있도록 해준다. 더 자세히 ...

sgObject::IGridCoverageProcessor에 대한 상속 다이어그램 :
sgObject::IGridCoverageProcessor에 대한 협력 다이어그램:

Public 멤버 함수

long | GetNumOperations ()
GridCoverageProcessor에 의해 지원되는 기능의 개수 더 자세히 ...
IGridOperation * | GetOperation ([in] long index)
그리드 처리 기능에 대한 정보를 반환한다. 기능에 대한 정보는 기능의 명칭 및 그 매개변수들도 포함한다. 더 자세히 ...
IGridOperation * | GetOperationByName ([in] BSTR name)
VARIANT_BOOL | DoOperation ([in] BSTR operName, [in] IParameters *parameters)
그리드 커버리지에 처리 기능을 적용한다. 더 자세히 ...

상세한 설명

IGridCoverageProcessor 인터페이스는 그리드 커버리지 값에 접근할 수 있도록 해준다.

멤버 함수 문서화

VARIANT_BOOL sgObject::IGridCoverageProcessor::DoOperation | ( | [in] BSTR | operName,
 |  | [in] IParameters * | parameters
 | ) |  |

그리드 커버리지에 처리 기능을 적용한다.

매개변수
operName | - 그리드 커버리지에 적용할 처리 기능의 이름
parameters | - 처리 기능에 요구되는 매개변수에 대한 이름값들의 리스트
반환값
GridCoverage 객체 포인터
long sgObject::IGridCoverageProcessor::GetNumOperations ( )

GridCoverageProcessor에 의해 지원되는 기능의 개수

IGridOperation* sgObject::IGridCoverageProcessor::GetOperation ( [in] long index )

그리드 처리 기능에 대한 정보를 반환한다. 기능에 대한 정보는 기능의 명칭 및 그 매개변수들도 포함한다.

매개변수
index - 구하고자 하는 기능 정보의 인덱스
반환값
인덱스에 해당하는 그리드 연산자 객체 포인터 (GridOperation 참조)
IGridOperation* sgObject::IGridCoverageProcessor::GetOperationByName ( [in] BSTR name )
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGridCoverageProcessor
sgObject::IGridCoverageProcessor 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGridCoverageProcessor (모든 상속된 멤버들도 포함합니다.)

DoOperation([in] BSTR operName, [in] IParameters *parameters) | sgObject::IGridCoverageProcessor
GetNumOperations() | sgObject::IGridCoverageProcessor
GetOperation([in] long index) | sgObject::IGridCoverageProcessor
GetOperationByName([in] BSTR name) | sgObject::IGridCoverageProcessor
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGridGeneralizeOp 인터페이스 참조

  • IGridGeneralizeOp
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGridGeneralizeOp 인터페이스 참조

IGridGeneralizeOp 인터페이스 더 자세히 ...

sgObject::IGridGeneralizeOp에 대한 상속 다이어그램 :
sgObject::IGridGeneralizeOp에 대한 협력 다이어그램:

Public 멤버 함수

VARIANT_BOOL | Resample ([in] IParameters *params)
VARIANT_BOOL | Rasterize ([in] IParameters *params)
VARIANT_BOOL | Vectorize ([in] IParameters *params)
VARIANT_BOOL | Polygonize ([in] IParameters *params)
VARIANT_BOOL | Merge ([in] IParameters *params)
VARIANT_BOOL | Overview ([in] IParameters *params)
VARIANT_BOOL | TileIndex ([in] IParameters *params)
VARIANT_BOOL | Sieve ([in] IParameters *params)
VARIANT_BOOL | FillNodata ([in] IParameters *params)
VARIANT_BOOL | NearBlack ([in] IParameters *params)
VARIANT_BOOL | MakeTiles ([in] IParameters *params)
VARIANT_BOOL | MapTiles ([in] IParameters *params)
- sgObject::IGridOperation(으)로부터 상속된 Public 멤버 함수
IParameterInfo * | GetParameterInfo ([in] long index)
입력된 인덱스에 해당하는 매개변수의 정보를 반환한다. 더 자세히 ...
VARIANT_BOOL | Execute ([in] IParameters *params)
BSTR | GetName ()
처리 기능의 명칭 더 자세히 ...
BSTR | GetDescription ()
처리 기능의 설명. 설명이 없으면 빈 값이 된다. 더 자세히 ...
BSTR | GetVendor ()
판매자의 이름 더 자세히 ...
BSTR | GetDocURL ()
처리 기능에 관한 문서의 위치, 경로. 온라인 문서가 없으면, 이 값은 빈값이 된다. 더 자세히 ...
BSTR | GetVersion ()
처리 기능의 버전 더 자세히 ...
long | GetNumSources ()
기능을 위해 필요한 소스 그리드 커버리지의 개수 더 자세히 ...
long | GetNumParameters ()
기능을 위해 필요한 매개변수의 개수 더 자세히 ...

상세한 설명

IGridGeneralizeOp 인터페이스

멤버 함수 문서화

VARIANT_BOOL sgObject::IGridGeneralizeOp::FillNodata ( [in] IParameters * params )
VARIANT_BOOL sgObject::IGridGeneralizeOp::MakeTiles ( [in] IParameters * params )
VARIANT_BOOL sgObject::IGridGeneralizeOp::MapTiles ( [in] IParameters * params )
VARIANT_BOOL sgObject::IGridGeneralizeOp::Merge ( [in] IParameters * params )
VARIANT_BOOL sgObject::IGridGeneralizeOp::NearBlack ( [in] IParameters * params )
VARIANT_BOOL sgObject::IGridGeneralizeOp::Overview ( [in] IParameters * params )
VARIANT_BOOL sgObject::IGridGeneralizeOp::Polygonize ( [in] IParameters * params )
VARIANT_BOOL sgObject::IGridGeneralizeOp::Rasterize ( [in] IParameters * params )
VARIANT_BOOL sgObject::IGridGeneralizeOp::Resample ( [in] IParameters * params )
VARIANT_BOOL sgObject::IGridGeneralizeOp::Sieve ( [in] IParameters * params )
VARIANT_BOOL sgObject::IGridGeneralizeOp::TileIndex ( [in] IParameters * params )
VARIANT_BOOL sgObject::IGridGeneralizeOp::Vectorize ( [in] IParameters * params )
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGridGeneralizeOp
sgObject::IGridGeneralizeOp 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGridGeneralizeOp (모든 상속된 멤버들도 포함합니다.)

Execute([in] IParameters *params) | sgObject::IGridOperation
FillNodata([in] IParameters *params) | sgObject::IGridGeneralizeOp
GetDescription() | sgObject::IGridOperation
GetDocURL() | sgObject::IGridOperation
GetName() | sgObject::IGridOperation
GetNumParameters() | sgObject::IGridOperation
GetNumSources() | sgObject::IGridOperation
GetParameterInfo([in] long index) | sgObject::IGridOperation
GetVendor() | sgObject::IGridOperation
GetVersion() | sgObject::IGridOperation
MakeTiles([in] IParameters *params) | sgObject::IGridGeneralizeOp
MapTiles([in] IParameters *params) | sgObject::IGridGeneralizeOp
Merge([in] IParameters *params) | sgObject::IGridGeneralizeOp
NearBlack([in] IParameters *params) | sgObject::IGridGeneralizeOp
Overview([in] IParameters *params) | sgObject::IGridGeneralizeOp
Polygonize([in] IParameters *params) | sgObject::IGridGeneralizeOp
Rasterize([in] IParameters *params) | sgObject::IGridGeneralizeOp
Resample([in] IParameters *params) | sgObject::IGridGeneralizeOp
Sieve([in] IParameters *params) | sgObject::IGridGeneralizeOp
TileIndex([in] IParameters *params) | sgObject::IGridGeneralizeOp
Vectorize([in] IParameters *params) | sgObject::IGridGeneralizeOp
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGridHydrologyOp 인터페이스 참조

  • IGridHydrologyOp
모든 멤버 목록
sgObject::IGridHydrologyOp 인터페이스 참조

IGridHydrologyOp 인터페이스는 수문학(수로, 수문, 하천, 지하수 등) 등의 처리를 위한 그리드 커버리지 알고리즘 제어 인터페이스 더 자세히 ...

sgObject::IGridHydrologyOp에 대한 상속 다이어그램 :
sgObject::IGridHydrologyOp에 대한 협력 다이어그램:

추가로 상속된 멤버들

- sgObject::IGridOperation(으)로부터 상속된 Public 멤버 함수
IParameterInfo * | GetParameterInfo ([in] long index)
입력된 인덱스에 해당하는 매개변수의 정보를 반환한다. 더 자세히 ...
VARIANT_BOOL | Execute ([in] IParameters *params)
BSTR | GetName ()
처리 기능의 명칭 더 자세히 ...
BSTR | GetDescription ()
처리 기능의 설명. 설명이 없으면 빈 값이 된다. 더 자세히 ...
BSTR | GetVendor ()
판매자의 이름 더 자세히 ...
BSTR | GetDocURL ()
처리 기능에 관한 문서의 위치, 경로. 온라인 문서가 없으면, 이 값은 빈값이 된다. 더 자세히 ...
BSTR | GetVersion ()
처리 기능의 버전 더 자세히 ...
long | GetNumSources ()
기능을 위해 필요한 소스 그리드 커버리지의 개수 더 자세히 ...
long | GetNumParameters ()
기능을 위해 필요한 매개변수의 개수 더 자세히 ...

상세한 설명

IGridHydrologyOp 인터페이스는 수문학(수로, 수문, 하천, 지하수 등) 등의 처리를 위한 그리드 커버리지 알고리즘 제어 인터페이스

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGridHydrologyOp
sgObject::IGridHydrologyOp 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGridHydrologyOp (모든 상속된 멤버들도 포함합니다.)

Execute([in] IParameters *params) | sgObject::IGridOperation
GetDescription() | sgObject::IGridOperation
GetDocURL() | sgObject::IGridOperation
GetName() | sgObject::IGridOperation
GetNumParameters() | sgObject::IGridOperation
GetNumSources() | sgObject::IGridOperation
GetParameterInfo([in] long index) | sgObject::IGridOperation
GetVendor() | sgObject::IGridOperation
GetVersion() | sgObject::IGridOperation
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGridInterpolationOp 인터페이스 참조

  • IGridInterpolationOp
모든 멤버 목록
sgObject::IGridInterpolationOp 인터페이스 참조

IGridInterpolationOp 인터페이스는 그리드 보간 처리를 위한 그리드 커버리지 알고리즘 제어 인터페이스 더 자세히 ...

sgObject::IGridInterpolationOp에 대한 상속 다이어그램 :
sgObject::IGridInterpolationOp에 대한 협력 다이어그램:

추가로 상속된 멤버들

- sgObject::IGridOperation(으)로부터 상속된 Public 멤버 함수
IParameterInfo * | GetParameterInfo ([in] long index)
입력된 인덱스에 해당하는 매개변수의 정보를 반환한다. 더 자세히 ...
VARIANT_BOOL | Execute ([in] IParameters *params)
BSTR | GetName ()
처리 기능의 명칭 더 자세히 ...
BSTR | GetDescription ()
처리 기능의 설명. 설명이 없으면 빈 값이 된다. 더 자세히 ...
BSTR | GetVendor ()
판매자의 이름 더 자세히 ...
BSTR | GetDocURL ()
처리 기능에 관한 문서의 위치, 경로. 온라인 문서가 없으면, 이 값은 빈값이 된다. 더 자세히 ...
BSTR | GetVersion ()
처리 기능의 버전 더 자세히 ...
long | GetNumSources ()
기능을 위해 필요한 소스 그리드 커버리지의 개수 더 자세히 ...
long | GetNumParameters ()
기능을 위해 필요한 매개변수의 개수 더 자세히 ...

상세한 설명

IGridInterpolationOp 인터페이스는 그리드 보간 처리를 위한 그리드 커버리지 알고리즘 제어 인터페이스

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGridInterpolationOp
sgObject::IGridInterpolationOp 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGridInterpolationOp (모든 상속된 멤버들도 포함합니다.)

Execute([in] IParameters *params) | sgObject::IGridOperation
GetDescription() | sgObject::IGridOperation
GetDocURL() | sgObject::IGridOperation
GetName() | sgObject::IGridOperation
GetNumParameters() | sgObject::IGridOperation
GetNumSources() | sgObject::IGridOperation
GetParameterInfo([in] long index) | sgObject::IGridOperation
GetVendor() | sgObject::IGridOperation
GetVersion() | sgObject::IGridOperation
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGridMathOp 인터페이스 참조

  • IGridMathOp
모든 멤버 목록
sgObject::IGridMathOp 인터페이스 참조

IGridMathOp 인터페이스는 산술연산 등의 처리를 위한 그리드 커버리지 알고리즘 제어 인터페이스 더 자세히 ...

sgObject::IGridMathOp에 대한 상속 다이어그램 :
sgObject::IGridMathOp에 대한 협력 다이어그램:

추가로 상속된 멤버들

- sgObject::IGridOperation(으)로부터 상속된 Public 멤버 함수
IParameterInfo * | GetParameterInfo ([in] long index)
입력된 인덱스에 해당하는 매개변수의 정보를 반환한다. 더 자세히 ...
VARIANT_BOOL | Execute ([in] IParameters *params)
BSTR | GetName ()
처리 기능의 명칭 더 자세히 ...
BSTR | GetDescription ()
처리 기능의 설명. 설명이 없으면 빈 값이 된다. 더 자세히 ...
BSTR | GetVendor ()
판매자의 이름 더 자세히 ...
BSTR | GetDocURL ()
처리 기능에 관한 문서의 위치, 경로. 온라인 문서가 없으면, 이 값은 빈값이 된다. 더 자세히 ...
BSTR | GetVersion ()
처리 기능의 버전 더 자세히 ...
long | GetNumSources ()
기능을 위해 필요한 소스 그리드 커버리지의 개수 더 자세히 ...
long | GetNumParameters ()
기능을 위해 필요한 매개변수의 개수 더 자세히 ...

상세한 설명

IGridMathOp 인터페이스는 산술연산 등의 처리를 위한 그리드 커버리지 알고리즘 제어 인터페이스

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGridMathOp
sgObject::IGridMathOp 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGridMathOp (모든 상속된 멤버들도 포함합니다.)

Execute([in] IParameters *params) | sgObject::IGridOperation
GetDescription() | sgObject::IGridOperation
GetDocURL() | sgObject::IGridOperation
GetName() | sgObject::IGridOperation
GetNumParameters() | sgObject::IGridOperation
GetNumSources() | sgObject::IGridOperation
GetParameterInfo([in] long index) | sgObject::IGridOperation
GetVendor() | sgObject::IGridOperation
GetVersion() | sgObject::IGridOperation
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGridMorphometryOp 인터페이스 참조

  • IGridMorphometryOp
모든 멤버 목록
sgObject::IGridMorphometryOp 인터페이스 참조

IGridMorphometryOp 인터페이스는 영상의 형태를 활용한 분석 알고리즘 제어 인터페이스 더 자세히 ...

sgObject::IGridMorphometryOp에 대한 상속 다이어그램 :
sgObject::IGridMorphometryOp에 대한 협력 다이어그램:

추가로 상속된 멤버들

- sgObject::IGridOperation(으)로부터 상속된 Public 멤버 함수
IParameterInfo * | GetParameterInfo ([in] long index)
입력된 인덱스에 해당하는 매개변수의 정보를 반환한다. 더 자세히 ...
VARIANT_BOOL | Execute ([in] IParameters *params)
BSTR | GetName ()
처리 기능의 명칭 더 자세히 ...
BSTR | GetDescription ()
처리 기능의 설명. 설명이 없으면 빈 값이 된다. 더 자세히 ...
BSTR | GetVendor ()
판매자의 이름 더 자세히 ...
BSTR | GetDocURL ()
처리 기능에 관한 문서의 위치, 경로. 온라인 문서가 없으면, 이 값은 빈값이 된다. 더 자세히 ...
BSTR | GetVersion ()
처리 기능의 버전 더 자세히 ...
long | GetNumSources ()
기능을 위해 필요한 소스 그리드 커버리지의 개수 더 자세히 ...
long | GetNumParameters ()
기능을 위해 필요한 매개변수의 개수 더 자세히 ...

상세한 설명

IGridMorphometryOp 인터페이스는 영상의 형태를 활용한 분석 알고리즘 제어 인터페이스

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGridMorphometryOp
sgObject::IGridMorphometryOp 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGridMorphometryOp (모든 상속된 멤버들도 포함합니다.)

Execute([in] IParameters *params) | sgObject::IGridOperation
GetDescription() | sgObject::IGridOperation
GetDocURL() | sgObject::IGridOperation
GetName() | sgObject::IGridOperation
GetNumParameters() | sgObject::IGridOperation
GetNumSources() | sgObject::IGridOperation
GetParameterInfo([in] long index) | sgObject::IGridOperation
GetVendor() | sgObject::IGridOperation
GetVersion() | sgObject::IGridOperation
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGridOperation 인터페이스 참조

  • IGridOperation
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGridOperation 인터페이스 참조

IGridOperation 인터페이스는 그리드 커버리지 처리 기능에 대한 정보를 제공한다. 더 자세히 ...

sgObject::IGridOperation에 대한 상속 다이어그램 :
sgObject::IGridOperation에 대한 협력 다이어그램:

Public 멤버 함수

IParameterInfo * | GetParameterInfo ([in] long index)
입력된 인덱스에 해당하는 매개변수의 정보를 반환한다. 더 자세히 ...
VARIANT_BOOL | Execute ([in] IParameters *params)
BSTR | GetName ()
처리 기능의 명칭 더 자세히 ...
BSTR | GetDescription ()
처리 기능의 설명. 설명이 없으면 빈 값이 된다. 더 자세히 ...
BSTR | GetVendor ()
판매자의 이름 더 자세히 ...
BSTR | GetDocURL ()
처리 기능에 관한 문서의 위치, 경로. 온라인 문서가 없으면, 이 값은 빈값이 된다. 더 자세히 ...
BSTR | GetVersion ()
처리 기능의 버전 더 자세히 ...
long | GetNumSources ()
기능을 위해 필요한 소스 그리드 커버리지의 개수 더 자세히 ...
long | GetNumParameters ()
기능을 위해 필요한 매개변수의 개수 더 자세히 ...

상세한 설명

IGridOperation 인터페이스는 그리드 커버리지 처리 기능에 대한 정보를 제공한다.

기능의 이름, 설명, 기능을 위해 필요한 입력 그리드 커버리지의 수 등에 대한 정보를 담고 있다.

멤버 함수 문서화

VARIANT_BOOL sgObject::IGridOperation::Execute ( [in] IParameters * params )
BSTR sgObject::IGridOperation::GetDescription ( )

처리 기능의 설명. 설명이 없으면 빈 값이 된다.

BSTR sgObject::IGridOperation::GetDocURL ( )

처리 기능에 관한 문서의 위치, 경로. 온라인 문서가 없으면, 이 값은 빈값이 된다.

BSTR sgObject::IGridOperation::GetName ( )

처리 기능의 명칭

long sgObject::IGridOperation::GetNumParameters ( )

기능을 위해 필요한 매개변수의 개수

long sgObject::IGridOperation::GetNumSources ( )

기능을 위해 필요한 소스 그리드 커버리지의 개수

IParameterInfo* sgObject::IGridOperation::GetParameterInfo ( [in] long index )

입력된 인덱스에 해당하는 매개변수의 정보를 반환한다.

매개변수
index - 매개변수 정보 인덱스
반환값
변환된 매개변수 정보
BSTR sgObject::IGridOperation::GetVendor ( )

판매자의 이름

BSTR sgObject::IGridOperation::GetVersion ( )

처리 기능의 버전

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGridOperation
sgObject::IGridOperation 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGridOperation (모든 상속된 멤버들도 포함합니다.)

Execute([in] IParameters *params) | sgObject::IGridOperation
GetDescription() | sgObject::IGridOperation
GetDocURL() | sgObject::IGridOperation
GetName() | sgObject::IGridOperation
GetNumParameters() | sgObject::IGridOperation
GetNumSources() | sgObject::IGridOperation
GetParameterInfo([in] long index) | sgObject::IGridOperation
GetVendor() | sgObject::IGridOperation
GetVersion() | sgObject::IGridOperation
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGridPreprocessOp 인터페이스 참조

  • IGridPreprocessOp
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGridPreprocessOp 인터페이스 참조

IGridPreprocessOp 인터페이스는 영상전처리를 위한 그리드 커버리지 알고리즘 제어 인터페이스 더 자세히 ...

sgObject::IGridPreprocessOp에 대한 상속 다이어그램 :
sgObject::IGridPreprocessOp에 대한 협력 다이어그램:

Public 멤버 함수

VARIANT_BOOL | Warp ([in] IParameters *params)
- sgObject::IGridOperation(으)로부터 상속된 Public 멤버 함수
IParameterInfo * | GetParameterInfo ([in] long index)
입력된 인덱스에 해당하는 매개변수의 정보를 반환한다. 더 자세히 ...
VARIANT_BOOL | Execute ([in] IParameters *params)
BSTR | GetName ()
처리 기능의 명칭 더 자세히 ...
BSTR | GetDescription ()
처리 기능의 설명. 설명이 없으면 빈 값이 된다. 더 자세히 ...
BSTR | GetVendor ()
판매자의 이름 더 자세히 ...
BSTR | GetDocURL ()
처리 기능에 관한 문서의 위치, 경로. 온라인 문서가 없으면, 이 값은 빈값이 된다. 더 자세히 ...
BSTR | GetVersion ()
처리 기능의 버전 더 자세히 ...
long | GetNumSources ()
기능을 위해 필요한 소스 그리드 커버리지의 개수 더 자세히 ...
long | GetNumParameters ()
기능을 위해 필요한 매개변수의 개수 더 자세히 ...

상세한 설명

IGridPreprocessOp 인터페이스는 영상전처리를 위한 그리드 커버리지 알고리즘 제어 인터페이스

멤버 함수 문서화

VARIANT_BOOL sgObject::IGridPreprocessOp::Warp ( [in] IParameters * params )
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGridPreprocessOp
sgObject::IGridPreprocessOp 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGridPreprocessOp (모든 상속된 멤버들도 포함합니다.)

Execute([in] IParameters *params) | sgObject::IGridOperation
GetDescription() | sgObject::IGridOperation
GetDocURL() | sgObject::IGridOperation
GetName() | sgObject::IGridOperation
GetNumParameters() | sgObject::IGridOperation
GetNumSources() | sgObject::IGridOperation
GetParameterInfo([in] long index) | sgObject::IGridOperation
GetVendor() | sgObject::IGridOperation
GetVersion() | sgObject::IGridOperation
Warp([in] IParameters *params) | sgObject::IGridPreprocessOp
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGridSampleDimension 인터페이스 참조

  • IGridSampleDimension
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGridSampleDimension 인터페이스 참조

IGridSampleDimension 인터페이스는 각각의 커버리지 샘플 차원에 대한 정보를 담고 있다. 더 자세히 ...

sgObject::IGridSampleDimension에 대한 상속 다이어그램 :
sgObject::IGridSampleDimension에 대한 협력 다이어그램:

Public 멤버 함수

int | GetNumRow ()
int | GetNumColumn ()
IGridCoverage * GetGridCoverage ()
SampleDimensionTypeEnum GetSampleDimensionType ()
그리드 자료형 나타내는 코드값. 자료형에 대한 비트수를 가리킨다. 더 자세히 ...
ColorInterpretationEnum GetColorInterpretation ()
샘플차원의 컬러 해석방법. 샘플차원은 컬러 팔레트나 컬러 모델 성분으로 매핑될 수 있다. 더 자세히 ...
VARIANT_BOOL | SetColorInterpretation (ColorInterpretationEnum colorInterp)
IColorModel * GetColorTable ()
VARIANT_BOOL | SetColorTable (IColorModel *colorTable)
VARIANT_BOOL | GetHasArbitraryOverviews ()
int | GetNumOverviews ()
IGridSampleDimension * | GetOverview (int index)
double | GetNodataValue ()
해당 샘플차원에 대해 데이터 없음을 나타낼 수 있는 값. 낮은 정확도의 샘플차원의 경우 종종 이 값은 비어 있게 된다. 더 자세히 ...
VARIANT_BOOL | SetNodataValue (double nodataValue)
BSTR | GetCategoryNames ()
그리드 데이터 값에 대한 카테고리별 이름. 값에다 이름을 부여할 수 있다. 더 자세히 ...
VARIANT_BOOL | SetCategoryNames (BSTR strName)
double | GetMinimumValue ()
샘플차원에서의 최소값 더 자세히 ...
double | GetMaximumValue ()
샘플차원에서의 최대값 더 자세히 ...
VARIANT_BOOL | GetStatistics (double *pdfMin, double *pdfMax, double *pdfMean, double *pdfStdDev)
VARIANT_BOOL | SetStatistics (double Min, double Max, double Mean, double StdDev)
BSTR | GetUnits ()
VARIANT_BOOL | SetUnits (BSTR units)
double | GetOffset ()
VARIANT_BOOL | SetOffset (double offset)
double | GetScale ()
VARIANT_BOOL | SetScale (double scale)
double | GetValue (int x, int y)
샘플차원에서의 x, y 인덱스의 값을 반환하거나 설정한다. 더 자세히 ...
VARIANT_BOOL | SetValue (int x, int y, double dlValue)
double | GetValueFromCoordinate (double x, double y)
샘플차원에서의 x, y 좌표의 값을 반환하거나 설정한다. 더 자세히 ...

상세한 설명

IGridSampleDimension 인터페이스는 각각의 커버리지 샘플 차원에 대한 정보를 담고 있다.

이것은 어떠한 커버리지 형식에도 적용가능하다. 그리드 커버리지의 경우 샘플 차원은 각각의 밴드를 가리킨다. C API(linux, iOS, MacOS 등) : 중간이름 "GSD"를 덧붙여서 "OGR_GSD_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.GridSampleDimension"

멤버 함수 문서화

BSTR sgObject::IGridSampleDimension::GetCategoryNames ( )

그리드 데이터 값에 대한 카테고리별 이름. 값에다 이름을 부여할 수 있다.

배열의 첫 번째 항목은 “0” 값에 대한 것이다. 그리드 커버리지의 경우 카테고리 이름은 분류결과 데이터일 경우에만 유효하다.

ColorInterpretationEnum sgObject::IGridSampleDimension::GetColorInterpretation ( )

샘플차원의 컬러 해석방법. 샘플차원은 컬러 팔레트나 컬러 모델 성분으로 매핑될 수 있다.

샘플차원에 매칭되는 팔레트나 컬러 모델 성분이 없는 경우에는 Undefined가 된다.

IColorModel* sgObject::IGridSampleDimension::GetColorTable ( )
IGridCoverage* sgObject::IGridSampleDimension::GetGridCoverage ( )
VARIANT_BOOL sgObject::IGridSampleDimension::GetHasArbitraryOverviews ( )
double sgObject::IGridSampleDimension::GetMaximumValue ( )

샘플차원에서의 최대값

double sgObject::IGridSampleDimension::GetMinimumValue ( )

샘플차원에서의 최소값

double sgObject::IGridSampleDimension::GetNodataValue ( )

해당 샘플차원에 대해 데이터 없음을 나타낼 수 있는 값. 낮은 정확도의 샘플차원의 경우 종종 이 값은 비어 있게 된다.

int sgObject::IGridSampleDimension::GetNumColumn ( )
int sgObject::IGridSampleDimension::GetNumOverviews ( )
int sgObject::IGridSampleDimension::GetNumRow ( )
double sgObject::IGridSampleDimension::GetOffset ( )
IGridSampleDimension* sgObject::IGridSampleDimension::GetOverview ( int index )
SampleDimensionTypeEnum sgObject::IGridSampleDimension::GetSampleDimensionType ( )

그리드 자료형 나타내는 코드값. 자료형에 대한 비트수를 가리킨다.

double sgObject::IGridSampleDimension::GetScale ( )
VARIANT_BOOL sgObject::IGridSampleDimension::GetStatistics | ( | double * | pdfMin,
 |  | double * | pdfMax,
 |  | double * | pdfMean,
 |  | double * | pdfStdDev
 | ) |  |
BSTR sgObject::IGridSampleDimension::GetUnits ( )
double sgObject::IGridSampleDimension::GetValue | ( | int | x,
 |  | int | y
 | ) |  |

샘플차원에서의 x, y 인덱스의 값을 반환하거나 설정한다.

double sgObject::IGridSampleDimension::GetValueFromCoordinate | ( | double | x,
 |  | double | y
 | ) |  |

샘플차원에서의 x, y 좌표의 값을 반환하거나 설정한다.

VARIANT_BOOL sgObject::IGridSampleDimension::SetCategoryNames ( BSTR strName )
VARIANT_BOOL sgObject::IGridSampleDimension::SetColorInterpretation ( ColorInterpretationEnum colorInterp )
VARIANT_BOOL sgObject::IGridSampleDimension::SetColorTable ( IColorModel * colorTable )
VARIANT_BOOL sgObject::IGridSampleDimension::SetNodataValue ( double nodataValue )
VARIANT_BOOL sgObject::IGridSampleDimension::SetOffset ( double offset )
VARIANT_BOOL sgObject::IGridSampleDimension::SetScale ( double scale )
VARIANT_BOOL sgObject::IGridSampleDimension::SetStatistics | ( | double | Min,
 |  | double | Max,
 |  | double | Mean,
 |  | double | StdDev
 | ) |  |
VARIANT_BOOL sgObject::IGridSampleDimension::SetUnits ( BSTR units )
VARIANT_BOOL sgObject::IGridSampleDimension::SetValue | ( | int | x,
 |  | int | y,
 |  | double | dlValue
 | ) |  |
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGridSampleDimension
sgObject::IGridSampleDimension 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGridSampleDimension (모든 상속된 멤버들도 포함합니다.)

GetCategoryNames() | sgObject::IGridSampleDimension
GetColorInterpretation() | sgObject::IGridSampleDimension
GetColorTable() | sgObject::IGridSampleDimension
GetGridCoverage() | sgObject::IGridSampleDimension
GetHasArbitraryOverviews() | sgObject::IGridSampleDimension
GetMaximumValue() | sgObject::IGridSampleDimension
GetMinimumValue() | sgObject::IGridSampleDimension
GetNodataValue() | sgObject::IGridSampleDimension
GetNumColumn() | sgObject::IGridSampleDimension
GetNumOverviews() | sgObject::IGridSampleDimension
GetNumRow() | sgObject::IGridSampleDimension
GetOffset() | sgObject::IGridSampleDimension
GetOverview(int index) | sgObject::IGridSampleDimension
GetSampleDimensionType() | sgObject::IGridSampleDimension
GetScale() | sgObject::IGridSampleDimension
GetStatistics(double *pdfMin, double *pdfMax, double *pdfMean, double *pdfStdDev) | sgObject::IGridSampleDimension
GetUnits() | sgObject::IGridSampleDimension
GetValue(int x, int y) | sgObject::IGridSampleDimension
GetValueFromCoordinate(double x, double y) | sgObject::IGridSampleDimension
SetCategoryNames(BSTR strName) | sgObject::IGridSampleDimension
SetColorInterpretation(ColorInterpretationEnum colorInterp) | sgObject::IGridSampleDimension
SetColorTable(IColorModel *colorTable) | sgObject::IGridSampleDimension
SetNodataValue(double nodataValue) | sgObject::IGridSampleDimension
SetOffset(double offset) | sgObject::IGridSampleDimension
SetScale(double scale) | sgObject::IGridSampleDimension
SetStatistics(double Min, double Max, double Mean, double StdDev) | sgObject::IGridSampleDimension
SetUnits(BSTR units) | sgObject::IGridSampleDimension
SetValue(int x, int y, double dlValue) | sgObject::IGridSampleDimension
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGridSurfaceOp 인터페이스 참조

  • IGridSurfaceOp
모든 멤버 목록
sgObject::IGridSurfaceOp 인터페이스 참조

IGridSurfaceOp 인터페이스 더 자세히 ...

sgObject::IGridSurfaceOp에 대한 상속 다이어그램 :
sgObject::IGridSurfaceOp에 대한 협력 다이어그램:

추가로 상속된 멤버들

- sgObject::IGridOperation(으)로부터 상속된 Public 멤버 함수
IParameterInfo * | GetParameterInfo ([in] long index)
입력된 인덱스에 해당하는 매개변수의 정보를 반환한다. 더 자세히 ...
VARIANT_BOOL | Execute ([in] IParameters *params)
BSTR | GetName ()
처리 기능의 명칭 더 자세히 ...
BSTR | GetDescription ()
처리 기능의 설명. 설명이 없으면 빈 값이 된다. 더 자세히 ...
BSTR | GetVendor ()
판매자의 이름 더 자세히 ...
BSTR | GetDocURL ()
처리 기능에 관한 문서의 위치, 경로. 온라인 문서가 없으면, 이 값은 빈값이 된다. 더 자세히 ...
BSTR | GetVersion ()
처리 기능의 버전 더 자세히 ...
long | GetNumSources ()
기능을 위해 필요한 소스 그리드 커버리지의 개수 더 자세히 ...
long | GetNumParameters ()
기능을 위해 필요한 매개변수의 개수 더 자세히 ...

상세한 설명

IGridSurfaceOp 인터페이스

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGridSurfaceOp
sgObject::IGridSurfaceOp 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGridSurfaceOp (모든 상속된 멤버들도 포함합니다.)

Execute([in] IParameters *params) | sgObject::IGridOperation
GetDescription() | sgObject::IGridOperation
GetDocURL() | sgObject::IGridOperation
GetName() | sgObject::IGridOperation
GetNumParameters() | sgObject::IGridOperation
GetNumSources() | sgObject::IGridOperation
GetParameterInfo([in] long index) | sgObject::IGridOperation
GetVendor() | sgObject::IGridOperation
GetVersion() | sgObject::IGridOperation
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGridTypeStyle 인터페이스 참조

  • IGridTypeStyle
Public 멤버 함수 | 모든 멤버 목록
sgObject::IGridTypeStyle 인터페이스 참조

FeatureTypeStyle로 부터 상속된 래스터를 위한 래스터 표현 규정을 정의한 인터페이스를 제공한다. 더 자세히 ...

sgObject::IGridTypeStyle에 대한 상속 다이어그램 :
sgObject::IGridTypeStyle에 대한 협력 다이어그램:

Public 멤버 함수

GridColorTypeEnum GetGridColorType ()
색상값 규정의 범위에 들지 않는 값에 대한 색상 선정 알고리즘을 반환한다. 더 자세히 ...
void | SetGridColorType ([in] GridColorTypeEnum eType)
색상값 규정의 범위에 들지 않는 값에 대한 색상 선정 알고리즘을 설정한다. 더 자세히 ...
DOUBLE | GetMinimumValue ()
값 규정의 최소값을 반환한다. 더 자세히 ...
void | SetMinimumValue ([in] DOUBLE dVal)
값 규정의 최소값을 설정한다. 더 자세히 ...
DOUBLE | GetMaximumValue ()
값 규정의 최대값을 반환한다. 더 자세히 ...
void | SetMaximumValue ([in] DOUBLE dVal)
값 규정의 최대값을 설정한다. 더 자세히 ...
DOUBLE | GetStandardDeviation ()
값 규정의 표준편차값을 반환한다. 더 자세히 ...
void | SetStandardDeviation ([in] DOUBLE dVal)
값 규정의 표준편차값을 설정한다. 더 자세히 ...
long | GetShadeColor ([in] DOUBLE dVal)
입력된 값에 해당하는 색상을 알고리즘으로부터 반환한다. 더 자세히 ...
PaletteInterpretationEnum GetShadePaletteInterpretation ()
채색을 위해 사용할 색상 판별방법 반환한다. 더 자세히 ...
void | SetShadePaletteInterpretation ([in] PaletteInterpretationEnum interp)
채색을 위해 사용할 색상 판별방법을 설정 한다. 더 자세히 ...
void | ShadeColorInterpretationRemoveAll ()
채색을 위해 사용할 색상 판별방법에 해당하는 개별 밴드의 색상 정보를 모두 제거한다. 더 자세히 ...
void | ShadeColorInterpretationAdd ([in] int bandidx, [in] ColorInterpretationEnum bandtype)
채색을 위해 사용할 색상 판별방법에 해당하는 개별 밴드의 색상 정보를 설정한다. 더 자세히 ...
int | GetShadeColorInterpretationSize ()
채색을 위해 사용할 색상 판별방법에 해당하는 밴드별 정보의 개수를 반환한다. 더 자세히 ...
int | GetShadeIndexByOrder ([in] int bandidx)
채색을 위해 사용할 색상 판별방법에 해당 순서의 밴드번호를 반환한다. 더 자세히 ...
ColorInterpretationEnum | GetShadeColorInterpretationByOrder ([in] int bandidx)
채색을 위해 사용할 색상 판별방법에 해당 순서의 색상 정보를 반환한다. 더 자세히 ...
ColorInterpretationEnum | GetShadeColorInterpretation ([in] int bandidx)
채색을 위해 사용할 색상 판별방법에 해당 밴드번호의 색상 정보를 반환한다. 더 자세히 ...
int | GetShadeIndexByColorInterpretation ([in] ColorInterpretationEnum bandtype)
채색을 위해 사용할 색상 판별방법에 해당 색상 정보의 밴드번호를 반환한다. 더 자세히 ...
void | SetEffectFilter ([in] FilterTypeEnum eType, [in] double amount)
채색 효과를 추가 설정한다. 더 자세히 ...
void | RemoveEffectFilter ([in] FilterTypeEnum eType)
채색 효과를 제거한다. 더 자세히 ...
void | ClearEffectFilter ()
모든 채색 효과를 제거한다. 더 자세히 ...
double | GetEffectFilter ([in] FilterTypeEnum eType)
채색 효과로 설정한 값을 반환한다. 더 자세히 ...
- sgObject::IFeatureTypeStyle(으)로부터 상속된 Public 멤버 함수
int | GetSize ()
설정된 규정의 개수를 반환한다. 더 자세히 ...
FeatureTypeStyleEnum GetStyleType ()
설정된 규정의 채색 방법을 반환한다. 더 자세히 ...
void | SetStyleType (FeatureTypeStyleEnum eType)
채색 규정을 설정한다. 더 자세히 ...
ISymbolizer * GetElseFilterFeatureStyle ()
규정에 의해 설정되지 않는 값들의 심볼(스타일) 규정을 반환한다. 더 자세히 ...
void | SetElseFilterFeatureStyle ([in] ISymbolizer *pdsSymbol)
규정에 의해 설정되지 않는 값들의 심볼(스타일) 규정을 설정한다. 더 자세히 ...
void | AddRule ([in] IFeatureTypeStyleRule *pdsRule)
규정을 추가한다. 더 자세히 ...
IFeatureTypeStyleRule * | GetRule ([in] long idx)
해당 인덱스번호의 규정을 반환한다. 더 자세히 ...
void | RemoveRule ([in] IFeatureTypeStyleRule *pdsRule)
규정을 삭제한다. 더 자세히 ...
void | RemoveAll ()
설정한 모든 규정을 삭제한다. 더 자세히 ...
VARIANT_BOOL | GetElseFilterVisible ()
규정의 보기여부를 반환한다. 더 자세히 ...
void | SetElseFilterVisible (VARIANT_BOOL bVisible)
규정을 보기여부를 설정한다. 더 자세히 ...

상세한 설명

FeatureTypeStyle로 부터 상속된 래스터를 위한 래스터 표현 규정을 정의한 인터페이스를 제공한다.

래스터 밴드의 픽셀값을 표현하기 위한 규정으로 RGB 칼라와 같이 픽셀값이 여러개의 밴드 또는 단일 밴드(그레이칼라)로 색상을 의미하는 경우 별도의 처리가 필요 없으나 DEM과 같이 고도, 지형, 파장 등 색상으로 직접 변환하기 어려운 픽셀 값을 다양한 형태의 설정으로 색상으로 변경하는 인터페이스 C API(linux, iOS, MacOS 등) : 중간이름 "GTS"를 덧붙여서 "OGR_GTS_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.GridTypeStyle"

멤버 함수 문서화

void sgObject::IGridTypeStyle::ClearEffectFilter ( )

모든 채색 효과를 제거한다.

double sgObject::IGridTypeStyle::GetEffectFilter ( [in] FilterTypeEnum eType )

채색 효과로 설정한 값을 반환한다.

매개변수
eType - 채색 효과 종류
GridColorTypeEnum sgObject::IGridTypeStyle::GetGridColorType ( )

색상값 규정의 범위에 들지 않는 값에 대한 색상 선정 알고리즘을 반환한다.

DOUBLE sgObject::IGridTypeStyle::GetMaximumValue ( )

값 규정의 최대값을 반환한다.

DOUBLE sgObject::IGridTypeStyle::GetMinimumValue ( )

값 규정의 최소값을 반환한다.

long sgObject::IGridTypeStyle::GetShadeColor ( [in] DOUBLE dVal )

입력된 값에 해당하는 색상을 알고리즘으로부터 반환한다.

ColorInterpretationEnum sgObject::IGridTypeStyle::GetShadeColorInterpretation ( [in] int bandidx )

채색을 위해 사용할 색상 판별방법에 해당 밴드번호의 색상 정보를 반환한다.

매개변수
bandidx - 밴드 인덱스 번호
ColorInterpretationEnum sgObject::IGridTypeStyle::GetShadeColorInterpretationByOrder ( [in] int bandidx )

채색을 위해 사용할 색상 판별방법에 해당 순서의 색상 정보를 반환한다.

매개변수
bandidx - 밴드 인덱스 번호
int sgObject::IGridTypeStyle::GetShadeColorInterpretationSize ( )

채색을 위해 사용할 색상 판별방법에 해당하는 밴드별 정보의 개수를 반환한다.

int sgObject::IGridTypeStyle::GetShadeIndexByColorInterpretation ( [in] ColorInterpretationEnum bandtype )

채색을 위해 사용할 색상 판별방법에 해당 색상 정보의 밴드번호를 반환한다.

매개변수
bandtype - 색상 모델 타입
int sgObject::IGridTypeStyle::GetShadeIndexByOrder ( [in] int bandidx )

채색을 위해 사용할 색상 판별방법에 해당 순서의 밴드번호를 반환한다.

매개변수
bandidx - 밴드 인덱스 번호
PaletteInterpretationEnum sgObject::IGridTypeStyle::GetShadePaletteInterpretation ( )

채색을 위해 사용할 색상 판별방법 반환한다.

DOUBLE sgObject::IGridTypeStyle::GetStandardDeviation ( )

값 규정의 표준편차값을 반환한다.

void sgObject::IGridTypeStyle::RemoveEffectFilter ( [in] FilterTypeEnum eType )

채색 효과를 제거한다.

매개변수
eType - 채색 효과 종류
void sgObject::IGridTypeStyle::SetEffectFilter | ( | [in] FilterTypeEnum | eType,
 |  | [in] double | amount
 | ) |  |

채색 효과를 추가 설정한다.

매개변수
eType | - 채색 효과 종류
amount | - 채색 효과값 (범위값 : -1.0~1.0)
void sgObject::IGridTypeStyle::SetGridColorType ( [in] GridColorTypeEnum eType )

색상값 규정의 범위에 들지 않는 값에 대한 색상 선정 알고리즘을 설정한다.

void sgObject::IGridTypeStyle::SetMaximumValue ( [in] DOUBLE dVal )

값 규정의 최대값을 설정한다.

void sgObject::IGridTypeStyle::SetMinimumValue ( [in] DOUBLE dVal )

값 규정의 최소값을 설정한다.

void sgObject::IGridTypeStyle::SetShadePaletteInterpretation ( [in] PaletteInterpretationEnum interp )

채색을 위해 사용할 색상 판별방법을 설정 한다.

void sgObject::IGridTypeStyle::SetStandardDeviation ( [in] DOUBLE dVal )

값 규정의 표준편차값을 설정한다.

void sgObject::IGridTypeStyle::ShadeColorInterpretationAdd | ( | [in] int | bandidx,
 |  | [in] ColorInterpretationEnum | bandtype
 | ) |  |

채색을 위해 사용할 색상 판별방법에 해당하는 개별 밴드의 색상 정보를 설정한다.

매개변수
bandidx | - 밴드 인덱스 번호
bandtype | - 색상 모델 타입
void sgObject::IGridTypeStyle::ShadeColorInterpretationRemoveAll ( )

채색을 위해 사용할 색상 판별방법에 해당하는 개별 밴드의 색상 정보를 모두 제거한다.

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGridTypeStyle
sgObject::IGridTypeStyle 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGridTypeStyle (모든 상속된 멤버들도 포함합니다.)

AddRule([in] IFeatureTypeStyleRule *pdsRule) | sgObject::IFeatureTypeStyle
ClearEffectFilter() | sgObject::IGridTypeStyle
GetEffectFilter([in] FilterTypeEnum eType) | sgObject::IGridTypeStyle
GetElseFilterFeatureStyle() | sgObject::IFeatureTypeStyle
GetElseFilterVisible() | sgObject::IFeatureTypeStyle
GetGridColorType() | sgObject::IGridTypeStyle
GetMaximumValue() | sgObject::IGridTypeStyle
GetMinimumValue() | sgObject::IGridTypeStyle
GetRule([in] long idx) | sgObject::IFeatureTypeStyle
GetShadeColor([in] DOUBLE dVal) | sgObject::IGridTypeStyle
GetShadeColorInterpretation([in] int bandidx) | sgObject::IGridTypeStyle
GetShadeColorInterpretationByOrder([in] int bandidx) | sgObject::IGridTypeStyle
GetShadeColorInterpretationSize() | sgObject::IGridTypeStyle
GetShadeIndexByColorInterpretation([in] ColorInterpretationEnum bandtype) | sgObject::IGridTypeStyle
GetShadeIndexByOrder([in] int bandidx) | sgObject::IGridTypeStyle
GetShadePaletteInterpretation() | sgObject::IGridTypeStyle
GetSize() | sgObject::IFeatureTypeStyle
GetStandardDeviation() | sgObject::IGridTypeStyle
GetStyleType() | sgObject::IFeatureTypeStyle
RemoveAll() | sgObject::IFeatureTypeStyle
RemoveEffectFilter([in] FilterTypeEnum eType) | sgObject::IGridTypeStyle
RemoveRule([in] IFeatureTypeStyleRule *pdsRule) | sgObject::IFeatureTypeStyle
SetEffectFilter([in] FilterTypeEnum eType, [in] double amount) | sgObject::IGridTypeStyle
SetElseFilterFeatureStyle([in] ISymbolizer *pdsSymbol) | sgObject::IFeatureTypeStyle
SetElseFilterVisible(VARIANT_BOOL bVisible) | sgObject::IFeatureTypeStyle
SetGridColorType([in] GridColorTypeEnum eType) | sgObject::IGridTypeStyle
SetMaximumValue([in] DOUBLE dVal) | sgObject::IGridTypeStyle
SetMinimumValue([in] DOUBLE dVal) | sgObject::IGridTypeStyle
SetShadePaletteInterpretation([in] PaletteInterpretationEnum interp) | sgObject::IGridTypeStyle
SetStandardDeviation([in] DOUBLE dVal) | sgObject::IGridTypeStyle
SetStyleType(FeatureTypeStyleEnum eType) | sgObject::IFeatureTypeStyle
ShadeColorInterpretationAdd([in] int bandidx, [in] ColorInterpretationEnum bandtype) | sgObject::IGridTypeStyle
ShadeColorInterpretationRemoveAll() | sgObject::IGridTypeStyle
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IGridVisibilityOp 인터페이스 참조

  • IGridVisibilityOp
모든 멤버 목록
sgObject::IGridVisibilityOp 인터페이스 참조

IGridVisibilityOp 인터페이스 더 자세히 ...

sgObject::IGridVisibilityOp에 대한 상속 다이어그램 :
sgObject::IGridVisibilityOp에 대한 협력 다이어그램:

추가로 상속된 멤버들

- sgObject::IGridOperation(으)로부터 상속된 Public 멤버 함수
IParameterInfo * | GetParameterInfo ([in] long index)
입력된 인덱스에 해당하는 매개변수의 정보를 반환한다. 더 자세히 ...
VARIANT_BOOL | Execute ([in] IParameters *params)
BSTR | GetName ()
처리 기능의 명칭 더 자세히 ...
BSTR | GetDescription ()
처리 기능의 설명. 설명이 없으면 빈 값이 된다. 더 자세히 ...
BSTR | GetVendor ()
판매자의 이름 더 자세히 ...
BSTR | GetDocURL ()
처리 기능에 관한 문서의 위치, 경로. 온라인 문서가 없으면, 이 값은 빈값이 된다. 더 자세히 ...
BSTR | GetVersion ()
처리 기능의 버전 더 자세히 ...
long | GetNumSources ()
기능을 위해 필요한 소스 그리드 커버리지의 개수 더 자세히 ...
long | GetNumParameters ()
기능을 위해 필요한 매개변수의 개수 더 자세히 ...

상세한 설명

IGridVisibilityOp 인터페이스

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IGridVisibilityOp
sgObject::IGridVisibilityOp 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IGridVisibilityOp (모든 상속된 멤버들도 포함합니다.)

Execute([in] IParameters *params) | sgObject::IGridOperation
GetDescription() | sgObject::IGridOperation
GetDocURL() | sgObject::IGridOperation
GetName() | sgObject::IGridOperation
GetNumParameters() | sgObject::IGridOperation
GetNumSources() | sgObject::IGridOperation
GetParameterInfo([in] long index) | sgObject::IGridOperation
GetVendor() | sgObject::IGridOperation
GetVersion() | sgObject::IGridOperation
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IHalo 인터페이스 참조

  • IHalo
sgObject::IHalo 인터페이스 참조

글꼴의 배경 스타일을 표현하기 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::IHalo에 대한 상속 다이어그램 :
sgObject::IHalo에 대한 협력 다이어그램:

상세한 설명

글꼴의 배경 스타일을 표현하기 위한 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "HL"를 덧붙여서 "OGR_HL_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Halo"

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IHistogram 인터페이스 참조

  • IHistogram
Public 멤버 함수 | 모든 멤버 목록
sgObject::IHistogram 인터페이스 참조

IHistogram 인터페이스는 하나의 샘플차원의 그리드 값에 대한 히스토그램을 계산한다. 더 자세히 ...

sgObject::IHistogram에 대한 상속 다이어그램 :
sgObject::IHistogram에 대한 협력 다이어그램:

Public 멤버 함수

long | GetNumBucket ()
double | GetMinValue ()
double | GetMaxValue ()
long | CountPerBucket (int index)

상세한 설명

IHistogram 인터페이스는 하나의 샘플차원의 그리드 값에 대한 히스토그램을 계산한다.

C API(linux, iOS, MacOS 등) : 중간이름 "GH"를 덧붙여서 "OGR_GH_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Histogram"

멤버 함수 문서화

long sgObject::IHistogram::CountPerBucket ( int index )
double sgObject::IHistogram::GetMaxValue ( )
double sgObject::IHistogram::GetMinValue ( )
long sgObject::IHistogram::GetNumBucket ( )
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IHistogram
sgObject::IHistogram 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IHistogram (모든 상속된 멤버들도 포함합니다.)

CountPerBucket(int index) | sgObject::IHistogram
GetMaxValue() | sgObject::IHistogram
GetMinValue() | sgObject::IHistogram
GetNumBucket() | sgObject::IHistogram
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IImageSymbol 인터페이스 참조

  • IImageSymbol
Public 멤버 함수 | 모든 멤버 목록
sgObject::IImageSymbol 인터페이스 참조

Feature 객체를 화면에 표시하기 위해 심볼이 필요할 수도 있는데 IImageSymbol 인터페이스는 이 중 이미지 타입의 심볼 정보를 관리하는 ImageSymbol 객체의 인터페이스를 제공한다. 더 자세히 ...

sgObject::IImageSymbol에 대한 상속 다이어그램 :
sgObject::IImageSymbol에 대한 협력 다이어그램:

Public 멤버 함수

VARIANT | GetImage ()
이미지 심볼의 비트맵 혹은 파일명 더 자세히 ...
void | SetImage ([in] VARIANT image)
long | GetTransparent ()
투명도 조절 더 자세히 ...
void | SetTransparent ([in] long val)
- sgObject::ISymbol(으)로부터 상속된 Public 멤버 함수
BSTR | GetName ()
심볼의 이름 더 자세히 ...
BSTR | GetTitle ()
심볼의 제목 더 자세히 ...
BSTR | GetAbstract ()
심볼의 추상 개념 더 자세히 ...
SymbolTypeEnum GetSymbolType ()
관리하는 심볼의 타입 (이미지, 벡터) 더 자세히 ...

상세한 설명

Feature 객체를 화면에 표시하기 위해 심볼이 필요할 수도 있는데 IImageSymbol 인터페이스는 이 중 이미지 타입의 심볼 정보를 관리하는 ImageSymbol 객체의 인터페이스를 제공한다.

멤버 함수 문서화

VARIANT sgObject::IImageSymbol::GetImage ( )

이미지 심볼의 비트맵 혹은 파일명

long sgObject::IImageSymbol::GetTransparent ( )

투명도 조절

void sgObject::IImageSymbol::SetImage ( [in] VARIANT image )
void sgObject::IImageSymbol::SetTransparent ( [in] long val )
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IImageSymbol
sgObject::IImageSymbol 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IImageSymbol (모든 상속된 멤버들도 포함합니다.)

GetAbstract() | sgObject::ISymbol
GetImage() | sgObject::IImageSymbol
GetName() | sgObject::ISymbol
GetSymbolType() | sgObject::ISymbol
GetTitle() | sgObject::ISymbol
GetTransparent() | sgObject::IImageSymbol
SetImage([in] VARIANT image) | sgObject::IImageSymbol
SetTransparent([in] long val) | sgObject::IImageSymbol
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IIndexMapWidget 인터페이스 참조

  • IIndexMapWidget
Public 멤버 함수 | 모든 멤버 목록
sgObject::IIndexMapWidget 인터페이스 참조

인덱스지도창 위젯을 관리하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::IIndexMapWidget에 대한 상속 다이어그램 :
sgObject::IIndexMapWidget에 대한 협력 다이어그램:

Public 멤버 함수

ICanvas * GetCanvas ()
인덱스로 사용하고 있는 지도를 반환한다. 더 자세히 ...
void | AddFeatureLayer ([in] IFeatureLayer *dspFtLayer)
인덱스로 지도에 FeatureLayer를 추가한다. 더 자세히 ...
DOUBLE | GetScaleRatio ()
바탕 지도와 대비된 인덱스 지도 비율 축척 더 자세히 ...
void | SetScaleRatio ([in] DOUBLE dScale)
VARIANT_BOOL | GetIndexMapAutoMove ()
바탕 지도의 이동에 따라 인덱스 지도의 자동 위치 이동 여부 더 자세히 ...
void | SetIndexMapAutoMove ([in] VARIANT_BOOL bAuto)
VARIANT_BOOL | GetCanMoveIndexMap ()
인덱스 지도의 위치 이동에 따라 바탕 지도의 이동 여부 더 자세히 ...
void | SetCanMoveIndexMap ([in] VARIANT_BOOL bCanMoved)
- sgObject::IWidget(으)로부터 상속된 Public 멤버 함수
void | Initialize ([in] ULONG_PTR h)
위젯 초기화 더 자세히 ...
void | ReSize ([in] int x, [in] int y, [in] int cx, [in] int cy)
위젯 객체의 크기를 재설정 한다. 더 자세히 ...
void | AddWidget ([in] IWidget *dspWidget)
현재 위젯에 하부로 위젯을 추가한다. 더 자세히 ...
void | AddWidgetByLayout ([in] IWidget *dspWidget, [in] int row, [in] int col)
현재 위젯에 종, 횡 위치에 위젯을 추가한다. 더 자세히 ...
void | SetQtUiObjectVisible ([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue)
위젯의 해당 오브젝트 객체의 보이기 여부를 설정한다. 더 자세히 ...
long | GetBackColor ()
위젯이 사용하는 배경 색상 정보 더 자세히 ...
void | SetBackColor ([in] long color)
void | SetCanvas (ICanvas *poCanvas)
위젯을 특정(2D, 3D, Earth 등) 지도창으로 설정한다. 더 자세히 ...
IFeatureCanvas * GetFeatureCanvas ()
위젯이 사용하는 FeatureCanvas 정보 더 자세히 ...
void | SetFeatureCanvas (IFeatureCanvas *poFtCvs)
void | SetFeatureLayer (IFeatureLayer *poFtLayer)
위젯이 사용하는 FeatureLayer 정보 더 자세히 ...
void | SetLayer (ILayer *poLayer)
위젯이 사용하는 레이어 정보 더 자세히 ...
BSTR | GetFlag ()
위젯이 사용하는 문자열 파라메터 정보 더 자세히 ...
void | SetFlag (BSTR bstrFlag)
void | SetWidth (int nWidth)
위젯의 가로크기를 설정한다. 더 자세히 ...
int | SetHeight (int nHeight)
위젯의 세로크기를 설정한다. 더 자세히 ...
void | Destroy ()

상세한 설명

인덱스지도창 위젯을 관리하는 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "IWG"를 덧붙여서 "OGR_IWG_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.IndexMapWidget"

멤버 함수 문서화

void sgObject::IIndexMapWidget::AddFeatureLayer ( [in] IFeatureLayer * dspFtLayer )

인덱스로 지도에 FeatureLayer를 추가한다.

VARIANT_BOOL sgObject::IIndexMapWidget::GetCanMoveIndexMap ( )

인덱스 지도의 위치 이동에 따라 바탕 지도의 이동 여부

ICanvas* sgObject::IIndexMapWidget::GetCanvas ( )

인덱스로 사용하고 있는 지도를 반환한다.

VARIANT_BOOL sgObject::IIndexMapWidget::GetIndexMapAutoMove ( )

바탕 지도의 이동에 따라 인덱스 지도의 자동 위치 이동 여부

DOUBLE sgObject::IIndexMapWidget::GetScaleRatio ( )

바탕 지도와 대비된 인덱스 지도 비율 축척

void sgObject::IIndexMapWidget::SetCanMoveIndexMap ( [in] VARIANT_BOOL bCanMoved )
void sgObject::IIndexMapWidget::SetIndexMapAutoMove ( [in] VARIANT_BOOL bAuto )
void sgObject::IIndexMapWidget::SetScaleRatio ( [in] DOUBLE dScale )
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IIndexMapWidget
sgObject::IIndexMapWidget 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IIndexMapWidget (모든 상속된 멤버들도 포함합니다.)

AddFeatureLayer([in] IFeatureLayer *dspFtLayer) | sgObject::IIndexMapWidget
AddWidget([in] IWidget *dspWidget) | sgObject::IWidget
AddWidgetByLayout([in] IWidget *dspWidget, [in] int row, [in] int col) | sgObject::IWidget
Destroy() | sgObject::IWidget
GetBackColor() | sgObject::IWidget
GetCanMoveIndexMap() | sgObject::IIndexMapWidget
GetCanvas() | sgObject::IIndexMapWidget
GetFeatureCanvas() | sgObject::IWidget
GetFlag() | sgObject::IWidget
GetIndexMapAutoMove() | sgObject::IIndexMapWidget
GetScaleRatio() | sgObject::IIndexMapWidget
Initialize([in] ULONG_PTR h) | sgObject::IWidget
ReSize([in] int x, [in] int y, [in] int cx, [in] int cy) | sgObject::IWidget
SetBackColor([in] long color) | sgObject::IWidget
SetCanMoveIndexMap([in] VARIANT_BOOL bCanMoved) | sgObject::IIndexMapWidget
SetCanvas(ICanvas *poCanvas) | sgObject::IWidget
SetFeatureCanvas(IFeatureCanvas *poFtCvs) | sgObject::IWidget
SetFeatureLayer(IFeatureLayer *poFtLayer) | sgObject::IWidget
SetFlag(BSTR bstrFlag) | sgObject::IWidget
SetHeight(int nHeight) | sgObject::IWidget
SetIndexMapAutoMove([in] VARIANT_BOOL bAuto) | sgObject::IIndexMapWidget
SetLayer(ILayer *poLayer) | sgObject::IWidget
SetQtUiObjectVisible([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue) | sgObject::IWidget
SetScaleRatio([in] DOUBLE dScale) | sgObject::IIndexMapWidget
SetWidth(int nWidth) | sgObject::IWidget
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ILayer 인터페이스 참조

  • ILayer
Public 멤버 함수 | 모든 멤버 목록
sgObject::ILayer 인터페이스 참조

레이어 객체 인테페이스를 제공한다. 더 자세히 ...

sgObject::ILayer에 대한 상속 다이어그램 :
sgObject::ILayer에 대한 협력 다이어그램:

Public 멤버 함수

BSTR | GetName ()
레이어의 이름을 반환한다. (시스템에서 사용할 이름) 더 자세히 ...
void | SetName (BSTR szName)
레이어 이름을 입력한다. (시스템에서 사용할 이름) 더 자세히 ...
BSTR | GetTitle ()
레이어 제목을 반환한다. (사용자가 편리하게 사용하기 위해서 붙인 제목) 더 자세히 ...
void | SetTitle (BSTR szTitle)
레이어 제목을 입력한다. (사용자의 편의를 위해서 붙인 이름) 더 자세히 ...
BSTR | GetAbstract ()
레이어에 대한 설명을 문자열 형태로 반환한다. 더 자세히 ...
void | SetAbstract (BSTR szAbstract)
레이어에 대한 설명을 문자열 형태로 입력한다. 더 자세히 ...
BSTR | GetSymbolizer ()
레이어에 생성될 Feature들의 Symbolizer(기본 스타일)1 문자열을 반환한다. 더 자세히 ...
void | SetSymbolizer (BSTR szSymbolizer)
레이어에 생성될 Feature들의 Symbolizer(기본 Style) 문자열을 입력한다. 더 자세히 ...
ISpatialReference * GetSpatialReference ()
레이어가 참조하는 공간참조체계를 반환한다. 더 자세히 ...
void | SetSpatialReference (ISpatialReference *pdspSrs)
레이어가 참조하는 공간참조체계를 입력한다. 더 자세히 ...
IGeometry * GetBoundingBox ()
레이어가 표현하는 공간 영역(모든 Feature들은 이 영역 내에 존재해야 함)을 반환한다. 더 자세히 ...
double | GetMinScaleDenominator ()
레이어를 화면에 그릴 때 사용할 수 있는 최소 스케일 값을 반환한다. 더 자세히 ...
void | SetMinScaleDenominator (double dScale)
레이어를 화면에 그릴 때 사용할 수 있는 최소 스케일 값을 입력한다. 더 자세히 ...
double | GetMaxScaleDenominator ()
레이어를 화면에 그릴 때 사용할 수 있는 최대 스케일 값을 반환한다. 더 자세히 ...
void | SetMaxScaleDenominator (double dScale)
레이어를 화면에 그릴 때 사용할 수 있는 최대 스케일 값을 입력한다. 더 자세히 ...
double | GetLabelMinScaleDenominator ()
레이어의 주석을 화면에 그릴 때 사용할 수 있는 최소 스케일 값을 반환한다. 더 자세히 ...
void | SetLabelMinScaleDenominator (double dScale)
레이어의 주석을 화면에 그릴 때 사용할 수 있는 최소 스케일 값을 입력한다. 더 자세히 ...
double | GetLabelMaxScaleDenominator ()
레이어의 주석을 화면에 그릴 때 사용할 수 있는 최대 스케일 값을 반환한다. 더 자세히 ...
void | SetLabelMaxScaleDenominator (double dScale)
레이어의 주석을 화면에 그릴 때 사용할 수 있는 최대 스케일 값을 입력한다. 더 자세히 ...
VARIANT_BOOL | GetVisible ()
레이어를 화면에 표현할지 여부(보이기/숨기기)를 반환한다. 더 자세히 ...
void | SetVisible (VARIANT_BOOL bVisible)
레이어를 화면에 표현할지 여부(보이기/숨기기)를 설정한다. 더 자세히 ...
VARIANT_BOOL | GetSelectable ()
레이어의 선택 상태(선택 가능/선택 불가능)를 반환한다. 더 자세히 ...
void | SetSelectable (VARIANT_BOOL bSelectable)
레이어의 선택 상태(선택 가능/선택 불가능)를 설정한다. 더 자세히 ...
int | GetOrder ()
레이어의 정렬을 위한 번호를 반환한다. 더 자세히 ...
long | GetPageSize ()
Feature Fetch 개수의 단위(=PageSize). 즉, 레이어에서 가져오는 Feature 개수 단위를 반환한다. 더 자세히 ...
void | SetPageSize (long nPageSize)
Feature Fetch 개수의 단위(=PageSize). 즉, 레이어에서 가져오는 Feature 개수 단위를 입력한다. 더 자세히 ...
long | GetAbsolutePage ()
PageSize에 의해 Paging(레이어에 있는 전체 Feature 개수를 PageSize 단위로 나눔)된 현재 페이지번호를 반환한다. 더 자세히 ...
BSTR | GetLabelExpression ()
주석 표현식(속성 간의 연산 표현식)으로 주석 객체을 직접 생성하지 않고, 더 자세히 ...
void | SetLabelExpression (BSTR szExpression)
주석 표현식(속성 간의 연산 표현식)으로 주석 객체을 직접 생성하지 않고, 더 자세히 ...
BSTR | GetShortLabelExpression ()
주석 표현식(속성 간의 연산 표현식)으로 주석 객체을 직접 생성하지 않고, 더 자세히 ...
void | SetShortLabelExpression (BSTR szExpression)
주석 표현식(속성 간의 연산 표현식)으로 주석 객체을 직접 생성하지 않고, 더 자세히 ...
BSTR | GetToolTipExpression ()
툴팁(마우스를 객체 위에 올려두면 주석이 나타나는 형식) 주석의 라벨 문자열을 반환한다. 더 자세히 ...
void | SetToolTipExpression (BSTR szVal)
툴팁(마우스 포인터를 객체 위에 올려두면 정보가 나타나는 방식) 주석의 라벨 문자열을 입력한다. 더 자세히 ...
void | SetLayerOrder (VARIANT_BOOL bUp)
레이어의 정렬 위치를 한단계 위/아래로 이동한다. 더 자세히 ...
BSTR | GetAnnoLineAttribute ()
인출선라인을 나타내는 속성필드의 이름을 반환한다. (*인출선 : 시설물 등 근처에 주석이 많을 경우 선을 빼서 주석을 그리기 위한 용도로 쓰임) 더 자세히 ...
void | SetAnnoLineAttribute (BSTR szColunm)
인출선라인을 나타내는 속성필드의 이름을 입력한다. (*인출선 : 시설물 등 근처에 주석이 많을 경우 선을 빼서 주석을 그리기 위한 용도로 쓰임) 더 자세히 ...
BSTR | GetAnnoVisibleAttribute ()
주석의 표현 여부를 나타내는 필드의 이름을 반환한다. 더 자세히 ...
void | SetAnnoVisibleAttribute (BSTR szColunm)
주석의 표현 여부를 나타내는 필드의 이름을 입력한다. 더 자세히 ...
BSTR | GetAnnoLineVisibleAttribute ()
인출선 표현 여부를 나타내는 필드의 이름을 반환한다. (*인출선 : 시설물 등 근처에 주석이 많을 경우 선을 빼서 주석을 그리기 위한 용도로 쓰임) 더 자세히 ...
void | SetAnnoLineVisibleAttribute (BSTR szColunm)
인출선 표현 여부를 나타내는 필드의 이름을 입력한다. (*인출선 : 시설물 등 근처에 주석이 많을 경우 선을 빼서 주석을 그리기 위한 용도로 쓰임) 더 자세히 ...
BSTR | GetStyleAttribute ()
Feature별 스타일 필드의 이름을 반환한다. 더 자세히 ...
void | SetStyleAttribute (BSTR szColunm)
Feature별 스타일 필드의 이름을 입력한다. 더 자세히 ...
BSTR | GetAnnoXMLAttribute ()
XML 형태의 주석 필드의 이름을 반환한다. 더 자세히 ...
void | SetAnnoXMLAttribute (BSTR szColunm)
XML 형태의 주석 필드의 이름을 입력한다. 더 자세히 ...
BSTR | GetReferGeometryLayerName ()
공간 정보를 참조하는 레이어의 이름을 문자열로 반환한다. 더 자세히 ...
BSTR | GetGeometryColumn ()
공간 정보의 필드 이름을 나타내는 문자열을 반환한다. 더 자세히 ...
BSTR | GetFIDColumn ()
공간 정보의 필드 이름을 나타내는 문자열을 반환한다. 더 자세히 ...
BSTR | GetMapIdxColumn ()
공간 인덱스의 필드 이름을 나타내는 문자열을 반환한다. 더 자세히 ...
void | SetMapIdxColumn (BSTR szColunm)
공간 인덱스의 필드 이름을 나타내는 문자열을 입력한다. 더 자세히 ...
int | GetMapIdxLevel ()
공간 인덱스의 레벨을 반환한다. 더 자세히 ...
void | SetMapIdxLevel (int nLevel)
공간 인덱스의 레벨을 입력한다. 더 자세히 ...
VARIANT_BOOL | IsSystemField (int fieldindex)
레이어의 필드인덱스에 해당하는 필드가 시스템내부 정보인지 여부를 반환한다. 더 자세히 ...
BSTR | GetNodeLayerName ()
경로 추적에 사용되는 링크의 노드레이어 이름을 알아낸다. 더 자세히 ...
void | SetNodeLayerName (BSTR szName)
경로 추적에 사용되는 link의 노드레이어 이름을 입력한다. 더 자세히 ...
BSTR | GetNodeLayerStartIDColumn ()
노드레이어의 시작노드ID 컬럼 이름을 반환한다. 더 자세히 ...
void | SetNodeLayerStartIDColumn (BSTR szName)
노드레이어의 시작노드ID 컬럼 이름을 입력한다. 더 자세히 ...
BSTR | GetNodeLayerEndIDColumn ()
노드레이어의 도착노드ID 컬럼 이름을 반환한다. 더 자세히 ...
void | SetNodeLayerEndIDColumn (BSTR szName)
노드레이어의 도착노드ID 컬럼 이름을 입력한다. 더 자세히 ...
void | SetAttributeFilter (BSTR szFilter)
FeatureLayer를 가져올 때 Feature의 속성 필드 중 한 개의 값을 검사해서 더 자세히 ...
IFeatureType * GetFeatureType ()
레이어에 속한 Feature들의 타입(일반 속성 리스트)을 반환한다. 더 자세히 ...
void | SetFeatureType (IFeatureType *pdspFtType)
레이어에 속한 Feature들의 타입(일반 속성 리스트)을 입력한다. 더 자세히 ...
IParameters * GetParameters ()
다양한 매개변수형을 담을 수 있는 파라메터 객체를 반환한다. 더 자세히 ...
long | GetVisibleAuth ()
권한에 따라 레이어를 화면에 표현할지 여부(보이기/숨기기)에 대한 권한값을 반환한다. 더 자세히 ...
void | SetVisibleAuth (long nAuth)
권한에 따라 레이어를 화면에 표현할지 여부(보이기/숨기기)에 대한 권한값을 설정한다. 더 자세히 ...
long | GetEditableAuth ()
권한에 따라 레이어를 수정할 수 있을지 여부(수정 가능/불가능)에 대한 권한값을 반환한다. 더 자세히 ...
void | SetEditableAuth (long nAuth)
권한에 따라 레이어를 수정할 수 있을지 여부(수정 가능/불가능)에 대한 권한값을 설정한다. 더 자세히 ...
IFeatureTypeStyle * GetFeatureTypeStyle ()
Feature의 스타일을 바꿔 속성에 따라 서로 다른 표현을 원하는 경우 Symbolizer를 직접 수정하거나 FeatureTypeStyle를 활용한다. 더 자세히 ...
void | SetFeatureTypeStyle (IFeatureTypeStyle *pdspFtTypeStyle)
Feature의 스타일을 바꿔 속성에 따라 서로 다른 표현을 원하는 경우 Symbolizer를 직접 수정하거나 FeatureTypeStyle를 활용한다. 더 자세히 ...
IUserDefinedWidget * GetDiagram ()
사용자 정의 된 도표를 반환한다. 더 자세히 ...
void | SetDiagram (IUserDefinedWidget *dspWidget)
사용자 정의 된 도표를 설정한다. 더 자세히 ...
VARIANT_BOOL | Export (ILayerSource *poDstLS, BSTR szDstName, VARIANT vSelFields, VARIANT_BOOL bAppend, int eGType, VARIANT_BOOL bOverwrite, VARIANT_BOOL bTransform, [in, optional] VARIANT szSourceSRS, [in, optional] VARIANT szOutputSRS, [in, optional] VARIANT szFilter, [in, optional] VARIANT nMapIndex, [in, optional] VARIANT szOptions)
해당 레이어를 다른 데이터소스로 export (저장) 한다. 더 자세히 ...
void | AddToFeatureLayer (IFeatureLayer *pdspFtLayer)
해당 FeatureLayer의 FeatureCollection에 Feature들을 추가한다. 더 자세히 ...
IFeatureLayer * | GetFeatureLayer (ILayerSource *poLS)
Layer로부터 FeatureLayer를 생성한다. 더 자세히 ...
BSTR | GetCategory ()
그룹레이어로 표기하기 위한 카테고리값을 설정한다. 더 자세히 ...
void | SetCategory (BSTR name)
BSTR | GetLayerID ()
레이어의 이름, 설명과 관계 없이 별도로 사용하기 위한 Key를 설정한다. 더 자세히 ...
BSTR | GetLabelText ([in] LabelTypeEnum eLabelType, [in] IFeature *poFeature)
해당 객체의 주석타입(긴주석(일반), 짧은 주석, 툴팁 주석)에 따른 주석값을 반환한다. 더 자세히 ...
LabelPositionTypeEnum GetLabelPosition ()
속성 주석을 표현시 공간 객체로부터 기준점 선정 방법을 설정한다. 더 자세히 ...
void | SetLabelPosition (LabelPositionTypeEnum ePos)
속성 주석을 표현시 공간 객체로부터 기준점 선정 방법을 설정한다. 더 자세히 ...
BSTR | GetSymbolizer3D (BSTR strVarName)
3D Symbolizer(기본 스타일)에서 해당 변수의 값 문자열을 반환한다. 더 자세히 ...
IFeatureLayer * | CreateFeatureLayer (ILayerSource *poLS)
Layer로부터 FeatureLayer를 생성한다.(기존 GetFeatureLayer와 동일) 더 자세히 ...

상세한 설명

레이어 객체 인테페이스를 제공한다.

GIS에서는 데이터를 화면에 표현하기 위해 관리할 때 보통 레이어의 개념을 도입해 객체 종류별 관리를 한다. LayerSourceFactory가 생성하는 LayerSource는 이렇게 레이어 단위로 관리되는 데이터의 전체 구조 (레이어의 모음) 이다. 레이어 객체는 레이어에 속한 Feature들을 관리하는 FeatureLayer 객체를 갖고 있다. FeatureLayer는 FeatureCollection을 갖고 있으며 이들을 화면에 표현하기 위한 정보를 갖고 있다. 레이어의 FeatureLayer는 LayerSource에서 레이어를 가져올 때 자동 생성된다. C API(linux, iOS, MacOS 등) : 중간이름 "L"를 덧붙여서 "OGR_L_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Layer"

멤버 함수 문서화

void sgObject::ILayer::AddToFeatureLayer ( IFeatureLayer * pdspFtLayer )

해당 FeatureLayer의 FeatureCollection에 Feature들을 추가한다.

매개변수
pdspFtLayer - Feature들을 새로 추가할 FeatureLayer 객체를 가리키는 포인터
IFeatureLayer* sgObject::ILayer::CreateFeatureLayer ( ILayerSource * poLS )

Layer로부터 FeatureLayer를 생성한다.(기존 GetFeatureLayer와 동일)

매개변수
poLS - Layer가 포함된 LayerSource 객체를 가리키는 포인터
VARIANT_BOOL sgObject::ILayer::Export | ( | ILayerSource * | poDstLS,
 |  | BSTR | szDstName,
 |  | VARIANT | vSelFields,
 |  | VARIANT_BOOL | bAppend,
 |  | int | eGType,
 |  | VARIANT_BOOL | bOverwrite,
 |  | VARIANT_BOOL | bTransform,
 |  | [in, optional] VARIANT | szSourceSRS,
 |  | [in, optional] VARIANT | szOutputSRS,
 |  | [in, optional] VARIANT | szFilter,
 |  | [in, optional] VARIANT | nMapIndex,
 |  | [in, optional] VARIANT | szOptions
 | ) |  |

해당 레이어를 다른 데이터소스로 export (저장) 한다.

매개변수
poDstLS | - 다른 데이터소스로 만들어진 LayerSource
szDstName | - Export할 때 내보내는 결과 이름
vSelFields | - 내보낼 속성 필드명 리스트
bAppend | - 내보내기 결과로 기존에 존재하는 경우 추가할지 여부
eGType | - 해당 레이어의 Feature들의 기하 타입으로 GeometryTypeEnum Constant로 지정하면 됨(Shape파일의 경우 하나의 공간데이터 타입만 내보내기 가능함으로 지정)
bOverwrite | - 기존에 내보내기 결과가 존재하는 경우 기존 결과 삭제 여부
bTransform | - 좌표계 변환 여부
szSourceSRS | - 현재 레이어의 좌표계를 표현하는 Proj4타입 문자열 [optional]
szOutputSRS | - 내보내기 레이어의 좌표계를 표현하는 Proj4타입 문자열 [optional]
szFilter | - 필터 내용 [옵션]
nMapIndex | - 지도 인덱스 번호 [옵션]
szOptions | - 기타 설정 옵션 [옵션]
반환값
성공하면 VARIANT_TRUE, 실패하면 VARIANT_FALSE
long sgObject::ILayer::GetAbsolutePage ( )

PageSize에 의해 Paging(레이어에 있는 전체 Feature 개수를 PageSize 단위로 나눔)된 현재 페이지번호를 반환한다.

반환값
현재 Page번호
BSTR sgObject::ILayer::GetAbstract ( )

레이어에 대한 설명을 문자열 형태로 반환한다.

반환값
레이어에 대한 설명
BSTR sgObject::ILayer::GetAnnoLineAttribute ( )

인출선라인을 나타내는 속성필드의 이름을 반환한다. (*인출선 : 시설물 등 근처에 주석이 많을 경우 선을 빼서 주석을 그리기 위한 용도로 쓰임)

반환값
인출선라인을 나타내는 속성필드의 이름
BSTR sgObject::ILayer::GetAnnoLineVisibleAttribute ( )

인출선 표현 여부를 나타내는 필드의 이름을 반환한다. (*인출선 : 시설물 등 근처에 주석이 많을 경우 선을 빼서 주석을 그리기 위한 용도로 쓰임)

반환값
인출선 표현 여부를 나타내는 필드의 이름
BSTR sgObject::ILayer::GetAnnoVisibleAttribute ( )

주석의 표현 여부를 나타내는 필드의 이름을 반환한다.

반환값
주석의 표현 여부를 나타내는 필드의 이름
BSTR sgObject::ILayer::GetAnnoXMLAttribute ( )

XML 형태의 주석 필드의 이름을 반환한다.

반환값
XML 형태의 주석 필드의 이름
IGeometry* sgObject::ILayer::GetBoundingBox ( )

레이어가 표현하는 공간 영역(모든 Feature들은 이 영역 내에 존재해야 함)을 반환한다.

반환값
레이어가 표현하는 공간 영역(모든 Feature들은 이 영역 내에 존재해야 함)
BSTR sgObject::ILayer::GetCategory ( )

그룹레이어로 표기하기 위한 카테고리값을 설정한다.

IUserDefinedWidget* sgObject::ILayer::GetDiagram ( )

사용자 정의 된 도표를 반환한다.

반환값
사용자 정의 된 도표
long sgObject::ILayer::GetEditableAuth ( )

권한에 따라 레이어를 수정할 수 있을지 여부(수정 가능/불가능)에 대한 권한값을 반환한다.

반환값
권한값
IFeatureLayer* sgObject::ILayer::GetFeatureLayer ( ILayerSource * poLS )

Layer로부터 FeatureLayer를 생성한다.

매개변수
poLS - Layer가 포함된 LayerSource 객체를 가리키는 포인터
IFeatureType* sgObject::ILayer::GetFeatureType ( )

레이어에 속한 Feature들의 타입(일반 속성 리스트)을 반환한다.

반환값
레이어에 속한 Feature들의 타입을 나타내는 포인터
IFeatureTypeStyle* sgObject::ILayer::GetFeatureTypeStyle ( )

Feature의 스타일을 바꿔 속성에 따라 서로 다른 표현을 원하는 경우 Symbolizer를 직접 수정하거나 FeatureTypeStyle를 활용한다.

GetFeatureTypeStyle()을 이용하면 FeatureTypeStyle 객체의 포인터를 반환받을 수 있다.

반환값
FeatureTypeStyle 객체의 포인터
BSTR sgObject::ILayer::GetFIDColumn ( )

공간 정보의 필드 이름을 나타내는 문자열을 반환한다.

반환값
공간 정보의 필드 이름을 나타내는 문자열
BSTR sgObject::ILayer::GetGeometryColumn ( )

공간 정보의 필드 이름을 나타내는 문자열을 반환한다.

반환값
공간 정보의 필드 이름을 나타내는 문자열
BSTR sgObject::ILayer::GetLabelExpression ( )

주석 표현식(속성 간의 연산 표현식)으로 주석 객체을 직접 생성하지 않고,

Feature의 속성값의 연산 표현식만으로 주석 객체 생성 없이 임시로 화면상에 표현된다. 이때 화면에 표현되는 라벨 문자열을 반환한다.
여기서 LabelExpression은 LongLabelExpression을 의미하는 것으로 ShortLabelExpression와 구별된다. Long과 Short의 차이는 스케일을 기준으로 표현되는 주석의 길이이다.

반환값
라벨 문자열
double sgObject::ILayer::GetLabelMaxScaleDenominator ( )

레이어의 주석을 화면에 그릴 때 사용할 수 있는 최대 스케일 값을 반환한다.

반환값
레이어의 주석을 화면에 그릴 때 사용할 수 있는 최대 스케일 값
double sgObject::ILayer::GetLabelMinScaleDenominator ( )

레이어의 주석을 화면에 그릴 때 사용할 수 있는 최소 스케일 값을 반환한다.

반환값
레이어의 주석을 화면에 그릴 때 사용할 수 있는 최소 스케일 값
LabelPositionTypeEnum sgObject::ILayer::GetLabelPosition ( )

속성 주석을 표현시 공간 객체로부터 기준점 선정 방법을 설정한다.

반환값
주석 기준점 유형
BSTR sgObject::ILayer::GetLabelText | ( | [in] LabelTypeEnum | eLabelType,
 |  | [in] IFeature * | poFeature
 | ) |  |

해당 객체의 주석타입(긴주석(일반), 짧은 주석, 툴팁 주석)에 따른 주석값을 반환한다.

BSTR sgObject::ILayer::GetLayerID ( )

레이어의 이름, 설명과 관계 없이 별도로 사용하기 위한 Key를 설정한다.

BSTR sgObject::ILayer::GetMapIdxColumn ( )

공간 인덱스의 필드 이름을 나타내는 문자열을 반환한다.

반환값
공간 인덱스의 필드 이름을 나타내는 문자열
int sgObject::ILayer::GetMapIdxLevel ( )

공간 인덱스의 레벨을 반환한다.

반환값
공간 인덱스의 레벨
double sgObject::ILayer::GetMaxScaleDenominator ( )

레이어를 화면에 그릴 때 사용할 수 있는 최대 스케일 값을 반환한다.

반환값
레이어를 화면에 그릴 때 사용할 수 있는 최대 스케일 값
double sgObject::ILayer::GetMinScaleDenominator ( )

레이어를 화면에 그릴 때 사용할 수 있는 최소 스케일 값을 반환한다.

반환값
레이어를 화면에 그릴 때 사용할 수 있는 최소 스케일 값
BSTR sgObject::ILayer::GetName ( )

레이어의 이름을 반환한다. (시스템에서 사용할 이름)

반환값
레이어 이름의 문자열
BSTR sgObject::ILayer::GetNodeLayerEndIDColumn ( )

노드레이어의 도착노드ID 컬럼 이름을 반환한다.

반환값
노드레이어의 도착노드ID 컬럼 이름
BSTR sgObject::ILayer::GetNodeLayerName ( )

경로 추적에 사용되는 링크의 노드레이어 이름을 알아낸다.

반환값
링크의 노드레이어 이름 문자열
BSTR sgObject::ILayer::GetNodeLayerStartIDColumn ( )

노드레이어의 시작노드ID 컬럼 이름을 반환한다.

반환값
노드레이어의 시작노드ID 컬럼 이름
int sgObject::ILayer::GetOrder ( )

레이어의 정렬을 위한 번호를 반환한다.

반환값
레이어의 정렬을 위한 번호
long sgObject::ILayer::GetPageSize ( )

Feature Fetch 개수의 단위(=PageSize). 즉, 레이어에서 가져오는 Feature 개수 단위를 반환한다.

반환값
Feature Fetch 개수의 단위
IParameters* sgObject::ILayer::GetParameters ( )

다양한 매개변수형을 담을 수 있는 파라메터 객체를 반환한다.

반환값
파라메터 객체의 포인터
BSTR sgObject::ILayer::GetReferGeometryLayerName ( )

공간 정보를 참조하는 레이어의 이름을 문자열로 반환한다.

반환값
공간 정보를 참조하는 레이어의 이름 문자열
VARIANT_BOOL sgObject::ILayer::GetSelectable ( )

레이어의 선택 상태(선택 가능/선택 불가능)를 반환한다.

반환값
선택 가능일 경우 VARIANT_TRUE, 선택 불가능 일 경우 VARIANT_FALSE를 반환
BSTR sgObject::ILayer::GetShortLabelExpression ( )

주석 표현식(속성 간의 연산 표현식)으로 주석 객체을 직접 생성하지 않고,

Feature의 속성값의 연산 표현식만으로 주석 객체 생성 없이 임시로 화면상에 표현된다. 이때 화면에 표현되는 라벨 문자열을 반환한다.
여기서 ShortLabelExpression은 LongLabelExpression을 의미하는 LabelExpression와 구별된다. Long과 Short의 차이는 스케일을 기준으로 표현되는 주석의 길이이다.

반환값
라벨 문자열
ISpatialReference* sgObject::ILayer::GetSpatialReference ( )

레이어가 참조하는 공간참조체계를 반환한다.

반환값
레이어가 참조하는 공간참조체계
BSTR sgObject::ILayer::GetStyleAttribute ( )

Feature별 스타일 필드의 이름을 반환한다.

반환값
Feature별 스타일 필드의 이름
BSTR sgObject::ILayer::GetSymbolizer ( )

레이어에 생성될 Feature들의 Symbolizer(기본 스타일)1 문자열을 반환한다.

반환값
Symbolizer 문자열
BSTR sgObject::ILayer::GetSymbolizer3D ( BSTR strVarName )

3D Symbolizer(기본 스타일)에서 해당 변수의 값 문자열을 반환한다.

매개변수
strVarName - 3D 스타일 변수명
반환값
Symbolizer 값 문자열
BSTR sgObject::ILayer::GetTitle ( )

레이어 제목을 반환한다. (사용자가 편리하게 사용하기 위해서 붙인 제목)

반환값
레이어 제목의 문자열
BSTR sgObject::ILayer::GetToolTipExpression ( )

툴팁(마우스를 객체 위에 올려두면 주석이 나타나는 형식) 주석의 라벨 문자열을 반환한다.

반환값
툴팁 주석의 라벨 문자열
VARIANT_BOOL sgObject::ILayer::GetVisible ( )

레이어를 화면에 표현할지 여부(보이기/숨기기)를 반환한다.

반환값
보이기일 경우 VARIANT_TRUE, 숨기기일 경우 VARIANT_FALSE를 반환
long sgObject::ILayer::GetVisibleAuth ( )

권한에 따라 레이어를 화면에 표현할지 여부(보이기/숨기기)에 대한 권한값을 반환한다.

반환값
권한값
VARIANT_BOOL sgObject::ILayer::IsSystemField ( int fieldindex )

레이어의 필드인덱스에 해당하는 필드가 시스템내부 정보인지 여부를 반환한다.

매개변수
fieldindex - 필드 인덱스 번호
반환값
void sgObject::ILayer::SetAbstract ( BSTR szAbstract )

레이어에 대한 설명을 문자열 형태로 입력한다.

매개변수
szAbstract - 레이어에 대한 설명
void sgObject::ILayer::SetAnnoLineAttribute ( BSTR szColunm )

인출선라인을 나타내는 속성필드의 이름을 입력한다. (*인출선 : 시설물 등 근처에 주석이 많을 경우 선을 빼서 주석을 그리기 위한 용도로 쓰임)

매개변수
szColunm - 인출선라인을 나타내는 속성필드의 이름
void sgObject::ILayer::SetAnnoLineVisibleAttribute ( BSTR szColunm )

인출선 표현 여부를 나타내는 필드의 이름을 입력한다. (*인출선 : 시설물 등 근처에 주석이 많을 경우 선을 빼서 주석을 그리기 위한 용도로 쓰임)

매개변수
szColunm - 인출선 표현 여부를 나타내는 필드의 이름
void sgObject::ILayer::SetAnnoVisibleAttribute ( BSTR szColunm )

주석의 표현 여부를 나타내는 필드의 이름을 입력한다.

매개변수
szColunm - 주석의 표현 여부를 나타내는 필드의 이름
void sgObject::ILayer::SetAnnoXMLAttribute ( BSTR szColunm )

XML 형태의 주석 필드의 이름을 입력한다.

매개변수
szColunm - XML 형태의 주석 필드의 이름
void sgObject::ILayer::SetAttributeFilter ( BSTR szFilter )

FeatureLayer를 가져올 때 Feature의 속성 필드 중 한 개의 값을 검사해서

조건에 맞는 Feature들만 가져오게 하는 필터 문자열을 입력한다.

매개변수
szFilter - 조건에 맞는 Feature들만 가져오게 하는 필터 문자열
void sgObject::ILayer::SetCategory ( BSTR name )
void sgObject::ILayer::SetDiagram ( IUserDefinedWidget * dspWidget )

사용자 정의 된 도표를 설정한다.

매개변수
dspWidget - 사용자 정의 된 도표
void sgObject::ILayer::SetEditableAuth ( long nAuth )

권한에 따라 레이어를 수정할 수 있을지 여부(수정 가능/불가능)에 대한 권한값을 설정한다.

매개변수
nAuth - 권한값
void sgObject::ILayer::SetFeatureType ( IFeatureType * pdspFtType )

레이어에 속한 Feature들의 타입(일반 속성 리스트)을 입력한다.

매개변수
pdspFtType - 레이어에 속한 Feature들의 타입을 나타내는 포인터
void sgObject::ILayer::SetFeatureTypeStyle ( IFeatureTypeStyle * pdspFtTypeStyle )

Feature의 스타일을 바꿔 속성에 따라 서로 다른 표현을 원하는 경우 Symbolizer를 직접 수정하거나 FeatureTypeStyle를 활용한다.

SetFeatureTypeStyle()을 이용하면 매개변수로 전달한 FeatureTypeStyle로 설정할 수 있다.

매개변수
pdspFtTypeStyle - FeatureTypeStyle 객체의 포인터
void sgObject::ILayer::SetLabelExpression ( BSTR szExpression )

주석 표현식(속성 간의 연산 표현식)으로 주석 객체을 직접 생성하지 않고,

Feature의 속성값의 연산 표현식만으로 주석 객체 생성 없이 임시로 화면상에 표현된다. 이때 화면에 표현되는 라벨 문자열을 입력한다.
여기서 LabelExpression은 LongLabelExpression을 의미하는 것으로 ShortLabelExpression와 구별된다. Long과 Short는 스케일을 기준으로 표현되는 주석의 길이를 의미한다.

매개변수
szExpression - 라벨 문자열
void sgObject::ILayer::SetLabelMaxScaleDenominator ( double dScale )

레이어의 주석을 화면에 그릴 때 사용할 수 있는 최대 스케일 값을 입력한다.

매개변수
dScale - 레이어의 주석을 화면에 그릴 때 사용할 수 있는 최대 스케일 값
void sgObject::ILayer::SetLabelMinScaleDenominator ( double dScale )

레이어의 주석을 화면에 그릴 때 사용할 수 있는 최소 스케일 값을 입력한다.

매개변수
dScale - 레이어의 주석을 화면에 그릴 때 사용할 수 있는 최소 스케일 값
void sgObject::ILayer::SetLabelPosition ( LabelPositionTypeEnum ePos )

속성 주석을 표현시 공간 객체로부터 기준점 선정 방법을 설정한다.

매개변수
ePos - 주석 기준점 유형
void sgObject::ILayer::SetLayerOrder ( VARIANT_BOOL bUp )

레이어의 정렬 위치를 한단계 위/아래로 이동한다.

반환값
레이어 정렬을 한단계 위로 이동할지 여부
void sgObject::ILayer::SetMapIdxColumn ( BSTR szColunm )

공간 인덱스의 필드 이름을 나타내는 문자열을 입력한다.

매개변수
szColunm - 공간 인덱스의 필드 이름
void sgObject::ILayer::SetMapIdxLevel ( int nLevel )

공간 인덱스의 레벨을 입력한다.

매개변수
nLevel - 공간 인덱스의 레벨
void sgObject::ILayer::SetMaxScaleDenominator ( double dScale )

레이어를 화면에 그릴 때 사용할 수 있는 최대 스케일 값을 입력한다.

매개변수
dScale - 레이어를 화면에 그릴 때 사용할 수 있는 최대 스케일 값
void sgObject::ILayer::SetMinScaleDenominator ( double dScale )

레이어를 화면에 그릴 때 사용할 수 있는 최소 스케일 값을 입력한다.

매개변수
dScale - 레이어를 화면에 그릴 때 사용할 수 있는 최소 스케일 값
void sgObject::ILayer::SetName ( BSTR szName )

레이어 이름을 입력한다. (시스템에서 사용할 이름)

매개변수
szName - 레이어 이름의 문자열
void sgObject::ILayer::SetNodeLayerEndIDColumn ( BSTR szName )

노드레이어의 도착노드ID 컬럼 이름을 입력한다.

매개변수
szName - 노드레이어의 도착노드ID 컬럼 이름
void sgObject::ILayer::SetNodeLayerName ( BSTR szName )

경로 추적에 사용되는 link의 노드레이어 이름을 입력한다.

매개변수
szName - link의 노드레이어 이름 문자열
void sgObject::ILayer::SetNodeLayerStartIDColumn ( BSTR szName )

노드레이어의 시작노드ID 컬럼 이름을 입력한다.

매개변수
szName - 노드레이어의 시작노드ID 컬럼 이름
void sgObject::ILayer::SetPageSize ( long nPageSize )

Feature Fetch 개수의 단위(=PageSize). 즉, 레이어에서 가져오는 Feature 개수 단위를 입력한다.

매개변수
nPageSize - Feature Fetch 개수의 단위
void sgObject::ILayer::SetSelectable ( VARIANT_BOOL bSelectable )

레이어의 선택 상태(선택 가능/선택 불가능)를 설정한다.

매개변수
bSelectable - 선택 가능일 경우 VARIANT_TRUE, 선택 불가능 일 경우 VARIANT_FALSE를 입력한다.
void sgObject::ILayer::SetShortLabelExpression ( BSTR szExpression )

주석 표현식(속성 간의 연산 표현식)으로 주석 객체을 직접 생성하지 않고,

Feature의 속성값의 연산 표현식만으로 주석 객체 생성 없이 임시로 화면상에 표현된다. 이때 화면에 표현되는 라벨 문자열을 입력한다.
여기서 ShortLabelExpression은 LongLabelExpression을 의미하는 LabelExpression와 구별된다. Long과 Short는 스케일을 기준으로 표현되는 주석의 길이를 의미한다.

매개변수
szExpression - 라벨 문자열
void sgObject::ILayer::SetSpatialReference ( ISpatialReference * pdspSrs )

레이어가 참조하는 공간참조체계를 입력한다.

매개변수
pdspSrs - 레이어가 참조하는 공간참조체계
void sgObject::ILayer::SetStyleAttribute ( BSTR szColunm )

Feature별 스타일 필드의 이름을 입력한다.

매개변수
szColunm - Feature별 스타일 필드의 이름
void sgObject::ILayer::SetSymbolizer ( BSTR szSymbolizer )

레이어에 생성될 Feature들의 Symbolizer(기본 Style) 문자열을 입력한다.

매개변수
szSymbolizer - Symbolizer 문자열
void sgObject::ILayer::SetTitle ( BSTR szTitle )

레이어 제목을 입력한다. (사용자의 편의를 위해서 붙인 이름)

매개변수
szTitle - 레이어 제목의 문자열
void sgObject::ILayer::SetToolTipExpression ( BSTR szVal )

툴팁(마우스 포인터를 객체 위에 올려두면 정보가 나타나는 방식) 주석의 라벨 문자열을 입력한다.

매개변수
szVal - 툴팁 주석의 라벨 문자열
void sgObject::ILayer::SetVisible ( VARIANT_BOOL bVisible )

레이어를 화면에 표현할지 여부(보이기/숨기기)를 설정한다.

매개변수
bVisible - 보이기일 경우 VARIANT_TRUE, 숨기기일 경우 VARIANT_FALSE를 입력한다.
void sgObject::ILayer::SetVisibleAuth ( long nAuth )

권한에 따라 레이어를 화면에 표현할지 여부(보이기/숨기기)에 대한 권한값을 설정한다.

매개변수
nAuth - 권한값
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ILayer
sgObject::ILayer 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ILayer (모든 상속된 멤버들도 포함합니다.)

AddToFeatureLayer(IFeatureLayer *pdspFtLayer) | sgObject::ILayer
CreateFeatureLayer(ILayerSource *poLS) | sgObject::ILayer
Export(ILayerSource *poDstLS, BSTR szDstName, VARIANT vSelFields, VARIANT_BOOL bAppend, int eGType, VARIANT_BOOL bOverwrite, VARIANT_BOOL bTransform, [in, optional] VARIANT szSourceSRS, [in, optional] VARIANT szOutputSRS, [in, optional] VARIANT szFilter, [in, optional] VARIANT nMapIndex, [in, optional] VARIANT szOptions) | sgObject::ILayer
GetAbsolutePage() | sgObject::ILayer
GetAbstract() | sgObject::ILayer
GetAnnoLineAttribute() | sgObject::ILayer
GetAnnoLineVisibleAttribute() | sgObject::ILayer
GetAnnoVisibleAttribute() | sgObject::ILayer
GetAnnoXMLAttribute() | sgObject::ILayer
GetBoundingBox() | sgObject::ILayer
GetCategory() | sgObject::ILayer
GetDiagram() | sgObject::ILayer
GetEditableAuth() | sgObject::ILayer
GetFeatureLayer(ILayerSource *poLS) | sgObject::ILayer
GetFeatureType() | sgObject::ILayer
GetFeatureTypeStyle() | sgObject::ILayer
GetFIDColumn() | sgObject::ILayer
GetGeometryColumn() | sgObject::ILayer
GetLabelExpression() | sgObject::ILayer
GetLabelMaxScaleDenominator() | sgObject::ILayer
GetLabelMinScaleDenominator() | sgObject::ILayer
GetLabelPosition() | sgObject::ILayer
GetLabelText([in] LabelTypeEnum eLabelType, [in] IFeature *poFeature) | sgObject::ILayer
GetLayerID() | sgObject::ILayer
GetMapIdxColumn() | sgObject::ILayer
GetMapIdxLevel() | sgObject::ILayer
GetMaxScaleDenominator() | sgObject::ILayer
GetMinScaleDenominator() | sgObject::ILayer
GetName() | sgObject::ILayer
GetNodeLayerEndIDColumn() | sgObject::ILayer
GetNodeLayerName() | sgObject::ILayer
GetNodeLayerStartIDColumn() | sgObject::ILayer
GetOrder() | sgObject::ILayer
GetPageSize() | sgObject::ILayer
GetParameters() | sgObject::ILayer
GetReferGeometryLayerName() | sgObject::ILayer
GetSelectable() | sgObject::ILayer
GetShortLabelExpression() | sgObject::ILayer
GetSpatialReference() | sgObject::ILayer
GetStyleAttribute() | sgObject::ILayer
GetSymbolizer() | sgObject::ILayer
GetSymbolizer3D(BSTR strVarName) | sgObject::ILayer
GetTitle() | sgObject::ILayer
GetToolTipExpression() | sgObject::ILayer
GetVisible() | sgObject::ILayer
GetVisibleAuth() | sgObject::ILayer
IsSystemField(int fieldindex) | sgObject::ILayer
SetAbstract(BSTR szAbstract) | sgObject::ILayer
SetAnnoLineAttribute(BSTR szColunm) | sgObject::ILayer
SetAnnoLineVisibleAttribute(BSTR szColunm) | sgObject::ILayer
SetAnnoVisibleAttribute(BSTR szColunm) | sgObject::ILayer
SetAnnoXMLAttribute(BSTR szColunm) | sgObject::ILayer
SetAttributeFilter(BSTR szFilter) | sgObject::ILayer
SetCategory(BSTR name) | sgObject::ILayer
SetDiagram(IUserDefinedWidget *dspWidget) | sgObject::ILayer
SetEditableAuth(long nAuth) | sgObject::ILayer
SetFeatureType(IFeatureType *pdspFtType) | sgObject::ILayer
SetFeatureTypeStyle(IFeatureTypeStyle *pdspFtTypeStyle) | sgObject::ILayer
SetLabelExpression(BSTR szExpression) | sgObject::ILayer
SetLabelMaxScaleDenominator(double dScale) | sgObject::ILayer
SetLabelMinScaleDenominator(double dScale) | sgObject::ILayer
SetLabelPosition(LabelPositionTypeEnum ePos) | sgObject::ILayer
SetLayerOrder(VARIANT_BOOL bUp) | sgObject::ILayer
SetMapIdxColumn(BSTR szColunm) | sgObject::ILayer
SetMapIdxLevel(int nLevel) | sgObject::ILayer
SetMaxScaleDenominator(double dScale) | sgObject::ILayer
SetMinScaleDenominator(double dScale) | sgObject::ILayer
SetName(BSTR szName) | sgObject::ILayer
SetNodeLayerEndIDColumn(BSTR szName) | sgObject::ILayer
SetNodeLayerName(BSTR szName) | sgObject::ILayer
SetNodeLayerStartIDColumn(BSTR szName) | sgObject::ILayer
SetPageSize(long nPageSize) | sgObject::ILayer
SetSelectable(VARIANT_BOOL bSelectable) | sgObject::ILayer
SetShortLabelExpression(BSTR szExpression) | sgObject::ILayer
SetSpatialReference(ISpatialReference *pdspSrs) | sgObject::ILayer
SetStyleAttribute(BSTR szColunm) | sgObject::ILayer
SetSymbolizer(BSTR szSymbolizer) | sgObject::ILayer
SetTitle(BSTR szTitle) | sgObject::ILayer
SetToolTipExpression(BSTR szVal) | sgObject::ILayer
SetVisible(VARIANT_BOOL bVisible) | sgObject::ILayer
SetVisibleAuth(long nAuth) | sgObject::ILayer
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ILayerSource 인터페이스 참조

  • ILayerSource
Public 멤버 함수 | 모든 멤버 목록
sgObject::ILayerSource 인터페이스 참조

LayerSource 객체의 인터페이스를 제공한다. 더 자세히 ...

sgObject::ILayerSource에 대한 상속 다이어그램 :
sgObject::ILayerSource에 대한 협력 다이어그램:

Public 멤버 함수

BSTR | GetIcon ()
LayerSource을 나타내는 아이콘 파일의 위치를 문자열을 반환한다. 더 자세히 ...
void | SetIcon (BSTR bstrVal)
아이콘 파일의 위치를 담은 문자열을 통해서 LayerSource의 아이콘을 변경한다. 더 자세히 ...
BSTR | GetDisplayName ()
표현되는 LayerSource 이름을 반환한다. 더 자세히 ...
void | SetDisplayName (BSTR bstrName)
표현되는 LayerSource 이름을 변경한다. 더 자세히 ...
BSTR | GetDescription ()
LayerSource에 대한 설명을 반환한다. 더 자세히 ...
void | SetDescription (BSTR bstrDesc)
LayerSource에 대한 설명을 변경한다. 더 자세히 ...
int | GetSize ()
속해 있는 레이어의 개수를 반환한다. 더 자세히 ...
BSTR | GetDriverType ()
LayerSource에 대한 드라이버종류을 반환한다. 더 자세히 ...
ILayer * | GetLayer (VARIANT vtIdx)
해당 인덱스의 레이어 객체를 반환한다. 더 자세히 ...
ILayer * | CreateLayer ([in] BSTR pszName, [in, defaultvalue(NULL)] ISpatialReference *poSpatialRef, [in, defaultvalue(0)] int eGType, [in, optional] VARIANT papszOptions)
LayerSource에 레이어 객체를 생성하여 추가한다. 더 자세히 ...
ILayer * | ExecuteSQL ([in] BSTR pszStatement, [in] BSTR pszDialect, [in, optional] VARIANT vtParam)
SQL문을 처리할 수 있는 데이터소스의 경우 SQL문을 수행시키고, 다른 데이터소스의 경우 해당하는 데이터소스에 적합한 동작을 수행한다 . 더 자세히 ...
VARIANT_BOOL | DeleteLayer ([in] BSTR pszName)
레이어 이름에 해당하는 레이어를 지운다. 더 자세히 ...
VARIANT_BOOL | RenameLayer ([in] BSTR pszName, [in] BSTR pszToName)
레이어 이름을 변경한다. 더 자세히 ...
int | GetLayerCount ()
속해 있는 레이어의 개수를 반환한다. 더 자세히 ...
BSTR | ExecuteSQLToString ([in] BSTR pszStatement, [in] BSTR pszDialect, [in] BSTR pszFeatureSeper, [in] BSTR pszAttrSeper)
ExecuteSQL 함수의 결과를 문자열로 반환한다. 더 자세히 ...
int | GetAffectedCount ()
ExecuteSQL 실행에 따라 영향을 받은 레코드수를 반환한다. 더 자세히 ...

상세한 설명

LayerSource 객체의 인터페이스를 제공한다.

GIS에서는 데이터를 화면에 표현하기위해 관리할 때 보통 레이어의 개념을 도입해 객체 종류별 관리를 한다. LayerSourceFactory가 생성하는 LayerSource는 이렇게 레이어 단위로 관리되는 데이터의 전체 구조 (레이어의 모음) 이다. C API(linux, iOS, MacOS 등) : 중간이름 "LS"를 덧붙여서 "OGR_LS_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.LayerSource"

멤버 함수 문서화

ILayer* sgObject::ILayerSource::CreateLayer | ( | [in] BSTR | pszName,
 |  | [in, defaultvalue(NULL)] ISpatialReference * | poSpatialRef,
 |  | [in, defaultvalue(0)] int | eGType,
 |  | [in, optional] VARIANT | papszOptions
 | ) |  |

LayerSource에 레이어 객체를 생성하여 추가한다.

매개변수
pszName | - 레이어 이름
poSpatialRef | - 생성할 레이어가 참조할 공간참조체계. [default = NULL]
eGType | - 레이어에 속한 Feature들이 가질 기하 타입을 나타냄 GeometryTypeEnum Constant로 지정하면 됨. [default = 0]
papszOptions | - 추가 정보를 제공할 수 있는 옵션 문자열(추후 확장 예정)
반환값
생성된 레이어 객체를 가리키는 포인터 (실패시 NULL)
VARIANT_BOOL sgObject::ILayerSource::DeleteLayer ( [in] BSTR pszName )

레이어 이름에 해당하는 레이어를 지운다.

매개변수
pszName - Layer 이름
반환값
성공하면 VARIANT_TRUE, 실패하면 VARIANT_FALSE
ILayer* sgObject::ILayerSource::ExecuteSQL | ( | [in] BSTR | pszStatement,
 |  | [in] BSTR | pszDialect,
 |  | [in, optional] VARIANT | vtParam
 | ) |  |

SQL문을 처리할 수 있는 데이터소스의 경우 SQL문을 수행시키고, 다른 데이터소스의 경우 해당하는 데이터소스에 적합한 동작을 수행한다 .

매개변수
pszStatement | - ODBC나 LTM LayerSource에서 지원하는 SQL 문장 (SQL 지원 데이터소스인 경우) 혹은 이에 대응되는 동작을 하기 위한 문자열 (SQL 미지원 데이터소스인 경우)로 DBMS 질의문이나 Server에서 지원하는 OpenAPI 메소드 문장
pszDialect | - 실행을 위한 부수 설정 파라메터(예 : fid(id),geom(geom),mapidx(mapcode))
vtParam | - SQL 문장 등에 필요한 파라미터(예 : INSERT문장에서 Binary정보를 사용하는 경우 Binary 데이터 정보) [default = NULL]
반환값
VARIANT.vt의 타입이 VT_DISPATCH 이면 SELECT 결과로 생성된 Layer 객체 포인터, T_I4 이면 SQL문 실행 결과 영향을 받은 Row 수, VT_EMPTY이면 처리 결과가 없는 경우
BSTR sgObject::ILayerSource::ExecuteSQLToString | ( | [in] BSTR | pszStatement,
 |  | [in] BSTR | pszDialect,
 |  | [in] BSTR | pszFeatureSeper,
 |  | [in] BSTR | pszAttrSeper
 | ) |  |

ExecuteSQL 함수의 결과를 문자열로 반환한다.

매개변수
pszStatement | - ODBC나 LTM LayerSource에서 지원하는 SQL 문장 (SQL 지원 데이터소스인 경우) 혹은 이에 대응되는 동작을 하기 위한 문자열 (SQL 미지원 데이터소스인 경우)로 DBMS 질의문이나 Server에서 지원하는 OpenAPI 메소드 문장
pszDialect | - 실행을 위한 부수 설정 파라메터(예 : fid(id),geom(geom),mapidx(mapcode))
pszFeatureSeper | - 레코드 구분문자
pszAttrSeper | - 필드 구분문자
반환값
구분자에 의해 분리된 결과값
int sgObject::ILayerSource::GetAffectedCount ( )

ExecuteSQL 실행에 따라 영향을 받은 레코드수를 반환한다.

반환값
레코드수
BSTR sgObject::ILayerSource::GetDescription ( )

LayerSource에 대한 설명을 반환한다.

반환값
LayerSource에 대한 설명 문자열
BSTR sgObject::ILayerSource::GetDisplayName ( )

표현되는 LayerSource 이름을 반환한다.

반환값
LayerSource 이름 문자열
BSTR sgObject::ILayerSource::GetDriverType ( )

LayerSource에 대한 드라이버종류을 반환한다.

반환값
LayerSource에 대한 드라이버종류 문자열
BSTR sgObject::ILayerSource::GetIcon ( )

LayerSource을 나타내는 아이콘 파일의 위치를 문자열을 반환한다.

반환값
아이콘 파일의 위치를 담은 문자열
ILayer* sgObject::ILayerSource::GetLayer ( VARIANT vtIdx )

해당 인덱스의 레이어 객체를 반환한다.

매개변수
vtIdx - 인덱스 번호
반환값
레이어 객체를 가리키는 포인터
int sgObject::ILayerSource::GetLayerCount ( )

속해 있는 레이어의 개수를 반환한다.

반환값
속해 있는 레이어의 개수
int sgObject::ILayerSource::GetSize ( )

속해 있는 레이어의 개수를 반환한다.

  • C API, Java 의 경우 지원하지 않습니다.(GetLayerCount와 같은 기능)
    반환값
    속해 있는 레이어의 개수
VARIANT_BOOL sgObject::ILayerSource::RenameLayer | ( | [in] BSTR | pszName,
 |  | [in] BSTR | pszToName
 | ) |  |

레이어 이름을 변경한다.

매개변수
pszName | - 레이어 이름
pszToName | - 변경할 레이어 이름
반환값
성공하면 VARIANT_TRUE, 실패하면 VARIANT_FALSE
void sgObject::ILayerSource::SetDescription ( BSTR bstrDesc )

LayerSource에 대한 설명을 변경한다.

매개변수
bstrDesc - LayerSource 설명 문자열
void sgObject::ILayerSource::SetDisplayName ( BSTR bstrName )

표현되는 LayerSource 이름을 변경한다.

매개변수
bstrName - LayerSource 이름 문자열
void sgObject::ILayerSource::SetIcon ( BSTR bstrVal )

아이콘 파일의 위치를 담은 문자열을 통해서 LayerSource의 아이콘을 변경한다.

매개변수
bstrVal - 아이콘 파일의 위치를 담은 문자열
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ILayerSource
sgObject::ILayerSource 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ILayerSource (모든 상속된 멤버들도 포함합니다.)

CreateLayer([in] BSTR pszName, [in, defaultvalue(NULL)] ISpatialReference *poSpatialRef, [in, defaultvalue(0)] int eGType, [in, optional] VARIANT papszOptions) | sgObject::ILayerSource
DeleteLayer([in] BSTR pszName) | sgObject::ILayerSource
ExecuteSQL([in] BSTR pszStatement, [in] BSTR pszDialect, [in, optional] VARIANT vtParam) | sgObject::ILayerSource
ExecuteSQLToString([in] BSTR pszStatement, [in] BSTR pszDialect, [in] BSTR pszFeatureSeper, [in] BSTR pszAttrSeper) | sgObject::ILayerSource
GetAffectedCount() | sgObject::ILayerSource
GetDescription() | sgObject::ILayerSource
GetDisplayName() | sgObject::ILayerSource
GetDriverType() | sgObject::ILayerSource
GetIcon() | sgObject::ILayerSource
GetLayer(VARIANT vtIdx) | sgObject::ILayerSource
GetLayerCount() | sgObject::ILayerSource
GetSize() | sgObject::ILayerSource
RenameLayer([in] BSTR pszName, [in] BSTR pszToName) | sgObject::ILayerSource
SetDescription(BSTR bstrDesc) | sgObject::ILayerSource
SetDisplayName(BSTR bstrName) | sgObject::ILayerSource
SetIcon(BSTR bstrVal) | sgObject::ILayerSource
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ILayerSourceFactory 인터페이스 참조

  • ILayerSourceFactory
Public 멤버 함수 | 모든 멤버 목록
sgObject::ILayerSourceFactory 인터페이스 참조

GIS 데이터를 갖고 있는 데이터소스로부터 데이터를 가져와 LayerSource를 생성하는 LayerSourceFactory 객체에 인터페이스를 제공한다. 더 자세히 ...

sgObject::ILayerSourceFactory에 대한 상속 다이어그램 :
sgObject::ILayerSourceFactory에 대한 협력 다이어그램:

Public 멤버 함수

ILayerSource * | CreateLayerSource (BSTR provider)
GIS 데이터소스에 연결하여 데이터를 가져와 LayerSource를 만든다. 더 자세히 ...
VARIANT_BOOL | CanProcess (BSTR provider)
[업데이트 예정] 더 자세히 ...
ILayerSource * | CreateNewLayerSource (BSTR provider)
새 LayerSource를 만든다. 더 자세히 ...
BSTR | GetIcon ()
LayerSource을 나타내는 아이콘 파일의 위치를 문자열로 반환한다. 더 자세히 ...
void | SetIcon (BSTR icon)
아이콘 파일의 를 담은 문자열을 통해서 LayerSource의 아이콘을 변경한다. 더 자세히 ...
BSTR | GetDisplayName ()
LayerSourceFactory 이름을 가져온다. 더 자세히 ...
void | SetDisplayName (BSTR name)
LayerSourceFactory 이름을 변경한다. 더 자세히 ...
BSTR | GetDescription ()
LayerSourceFactroy에 대한 간략한 설명을 가져온다. 더 자세히 ...
void | SetDescription (BSTR desc)
LayerSourceFactory에 대한 간략한 설명을 변경한다. 더 자세히 ...
VARIANT_BOOL | IsAvailable ()
LayerSourceFactory 사용 가능 여부를 가져온다. 더 자세히 ...

상세한 설명

GIS 데이터를 갖고 있는 데이터소스로부터 데이터를 가져와 LayerSource를 생성하는 LayerSourceFactory 객체에 인터페이스를 제공한다.

GIS에서는 데이터를 화면에 표현하기위해 관리할 때 보통 레이어의 개념을 도입해 객체 종류별 관리를 한다. LayerSourceFactory가 생성하는 LayerSource는 이렇게 레이어 단위로 관리되는 데이터의 전체 구조 (레이어의 모음) 이다. C API(linux, iOS, MacOS 등) : 중간이름 "LF"를 덧붙여서 "OGR_LF_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.LayerSourceFactory"

멤버 함수 문서화

VARIANT_BOOL sgObject::ILayerSourceFactory::CanProcess ( BSTR provider )

[업데이트 예정]

ILayerSource* sgObject::ILayerSourceFactory::CreateLayerSource ( BSTR provider )

GIS 데이터소스에 연결하여 데이터를 가져와 LayerSource를 만든다.

Component Model Overview의 레이어의 이해 를 참조한다.

매개변수
provider - 데이터소스 연결 문자열
반환값
생성된 LayerSource를 가리키는 포인터
ILayerSource* sgObject::ILayerSourceFactory::CreateNewLayerSource ( BSTR provider )

새 LayerSource를 만든다.

매개변수
provider - 데이터소스 연결 문자열 Component Model Overview의 Layer의 이해 를 참조한다.
반환값
생성된 LayerSource를 가리키는 포인터
BSTR sgObject::ILayerSourceFactory::GetDescription ( )

LayerSourceFactroy에 대한 간략한 설명을 가져온다.

반환값
설명 문자열
BSTR sgObject::ILayerSourceFactory::GetDisplayName ( )

LayerSourceFactory 이름을 가져온다.

반환값
LayerSourceFactory 이름 문자열
BSTR sgObject::ILayerSourceFactory::GetIcon ( )

LayerSource을 나타내는 아이콘 파일의 위치를 문자열로 반환한다.

반환값
아이콘 파일의 위치를 담은 문자열
VARIANT_BOOL sgObject::ILayerSourceFactory::IsAvailable ( )

LayerSourceFactory 사용 가능 여부를 가져온다.

반환값
사용 가능하면 VARIANT_TRUE, 불가능하면 VARIANT_FALSE
void sgObject::ILayerSourceFactory::SetDescription ( BSTR desc )

LayerSourceFactory에 대한 간략한 설명을 변경한다.

매개변수
desc - 설명 문자열
void sgObject::ILayerSourceFactory::SetDisplayName ( BSTR name )

LayerSourceFactory 이름을 변경한다.

매개변수
name - LayerSourceFactory 이름 문자열
void sgObject::ILayerSourceFactory::SetIcon ( BSTR icon )

아이콘 파일의 를 담은 문자열을 통해서 LayerSource의 아이콘을 변경한다.

매개변수
icon - 아이콘 파일의 위치1를 담은 문자열
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ILayerSourceFactory
sgObject::ILayerSourceFactory 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ILayerSourceFactory (모든 상속된 멤버들도 포함합니다.)

CanProcess(BSTR provider) | sgObject::ILayerSourceFactory
CreateLayerSource(BSTR provider) | sgObject::ILayerSourceFactory
CreateNewLayerSource(BSTR provider) | sgObject::ILayerSourceFactory
GetDescription() | sgObject::ILayerSourceFactory
GetDisplayName() | sgObject::ILayerSourceFactory
GetIcon() | sgObject::ILayerSourceFactory
IsAvailable() | sgObject::ILayerSourceFactory
SetDescription(BSTR desc) | sgObject::ILayerSourceFactory
SetDisplayName(BSTR name) | sgObject::ILayerSourceFactory
SetIcon(BSTR icon) | sgObject::ILayerSourceFactory
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ILayerTreeWidget 인터페이스 참조

  • ILayerTreeWidget
Public 멤버 함수 | 모든 멤버 목록
sgObject::ILayerTreeWidget 인터페이스 참조

레이어제어 관리창을 제어하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::ILayerTreeWidget에 대한 상속 다이어그램 :
sgObject::ILayerTreeWidget에 대한 협력 다이어그램:

Public 멤버 함수

int | IndexOfSelectedItem ()
레이어제어창에서 선택 중인 레이어의 인덱스 번호를 반환한다. 더 자세히 ...
VARIANT_BOOL | GetDisplayToolBar ()
레이어제어창 상단의 툴바의 보기 상태를 반환한다. 더 자세히 ...
void | SetDisplayToolBar ([in] VARIANT_BOOL bVal)
레이어제어창 상단의 툴바의 보기 상태를 제어한다. 더 자세히 ...
void | SetDisplayContextMenu ([in] VARIANT_BOOL bVal)
레이어제어창 내부의 팝업창의 보기 상태를 제어한다. 더 자세히 ...
- sgObject::IWidget(으)로부터 상속된 Public 멤버 함수
void | Initialize ([in] ULONG_PTR h)
위젯 초기화 더 자세히 ...
void | ReSize ([in] int x, [in] int y, [in] int cx, [in] int cy)
위젯 객체의 크기를 재설정 한다. 더 자세히 ...
void | AddWidget ([in] IWidget *dspWidget)
현재 위젯에 하부로 위젯을 추가한다. 더 자세히 ...
void | AddWidgetByLayout ([in] IWidget *dspWidget, [in] int row, [in] int col)
현재 위젯에 종, 횡 위치에 위젯을 추가한다. 더 자세히 ...
void | SetQtUiObjectVisible ([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue)
위젯의 해당 오브젝트 객체의 보이기 여부를 설정한다. 더 자세히 ...
long | GetBackColor ()
위젯이 사용하는 배경 색상 정보 더 자세히 ...
void | SetBackColor ([in] long color)
void | SetCanvas (ICanvas *poCanvas)
위젯을 특정(2D, 3D, Earth 등) 지도창으로 설정한다. 더 자세히 ...
IFeatureCanvas * GetFeatureCanvas ()
위젯이 사용하는 FeatureCanvas 정보 더 자세히 ...
void | SetFeatureCanvas (IFeatureCanvas *poFtCvs)
void | SetFeatureLayer (IFeatureLayer *poFtLayer)
위젯이 사용하는 FeatureLayer 정보 더 자세히 ...
void | SetLayer (ILayer *poLayer)
위젯이 사용하는 레이어 정보 더 자세히 ...
BSTR | GetFlag ()
위젯이 사용하는 문자열 파라메터 정보 더 자세히 ...
void | SetFlag (BSTR bstrFlag)
void | SetWidth (int nWidth)
위젯의 가로크기를 설정한다. 더 자세히 ...
int | SetHeight (int nHeight)
위젯의 세로크기를 설정한다. 더 자세히 ...
void | Destroy ()

상세한 설명

레이어제어 관리창을 제어하는 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "LWG"를 덧붙여서 "OGR_LWG_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.LayerTreeWidget"

멤버 함수 문서화

VARIANT_BOOL sgObject::ILayerTreeWidget::GetDisplayToolBar ( )

레이어제어창 상단의 툴바의 보기 상태를 반환한다.

int sgObject::ILayerTreeWidget::IndexOfSelectedItem ( )

레이어제어창에서 선택 중인 레이어의 인덱스 번호를 반환한다.

void sgObject::ILayerTreeWidget::SetDisplayContextMenu ( [in] VARIANT_BOOL bVal )

레이어제어창 내부의 팝업창의 보기 상태를 제어한다.

void sgObject::ILayerTreeWidget::SetDisplayToolBar ( [in] VARIANT_BOOL bVal )

레이어제어창 상단의 툴바의 보기 상태를 제어한다.

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ILayerTreeWidget
sgObject::ILayerTreeWidget 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ILayerTreeWidget (모든 상속된 멤버들도 포함합니다.)

AddWidget([in] IWidget *dspWidget) | sgObject::IWidget
AddWidgetByLayout([in] IWidget *dspWidget, [in] int row, [in] int col) | sgObject::IWidget
Destroy() | sgObject::IWidget
GetBackColor() | sgObject::IWidget
GetDisplayToolBar() | sgObject::ILayerTreeWidget
GetFeatureCanvas() | sgObject::IWidget
GetFlag() | sgObject::IWidget
IndexOfSelectedItem() | sgObject::ILayerTreeWidget
Initialize([in] ULONG_PTR h) | sgObject::IWidget
ReSize([in] int x, [in] int y, [in] int cx, [in] int cy) | sgObject::IWidget
SetBackColor([in] long color) | sgObject::IWidget
SetCanvas(ICanvas *poCanvas) | sgObject::IWidget
SetDisplayContextMenu([in] VARIANT_BOOL bVal) | sgObject::ILayerTreeWidget
SetDisplayToolBar([in] VARIANT_BOOL bVal) | sgObject::ILayerTreeWidget
SetFeatureCanvas(IFeatureCanvas *poFtCvs) | sgObject::IWidget
SetFeatureLayer(IFeatureLayer *poFtLayer) | sgObject::IWidget
SetFlag(BSTR bstrFlag) | sgObject::IWidget
SetHeight(int nHeight) | sgObject::IWidget
SetLayer(ILayer *poLayer) | sgObject::IWidget
SetQtUiObjectVisible([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue) | sgObject::IWidget
SetWidth(int nWidth) | sgObject::IWidget
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ILinearRing 인터페이스 참조

  • ILinearRing
Public 멤버 함수 | 모든 멤버 목록
sgObject::ILinearRing 인터페이스 참조

기하 명세에 정의된 LinearRing에 대한 일반적인 인터페이스를 제공한다. (현재는 프로퍼티 및 메소드가 없으나 LinearRing에 대한 프로퍼티 및 메소드 추가를 고려해 만들어 놓은 인터페이스이다) 더 자세히 ...

sgObject::ILinearRing에 대한 상속 다이어그램 :
sgObject::ILinearRing에 대한 협력 다이어그램:

Public 멤버 함수

ILineString * GetLineString ()
LineString 객체로 형 변환한다. 더 자세히 ...
VARIANT_BOOL | IsPointInRing ([in] IPoint *dspPt)
해당 점이 내부에 포함되는지 여부를 반환한다. 더 자세히 ...
VARIANT_BOOL | IsPointOnRingBoundary ([in] IPoint *dspPt)
해당 점이 테두리선상에 있는지 여부를 반환한다. 더 자세히 ...
- sgObject::ILineString(으)로부터 상속된 Public 멤버 함수
long | GetNumPoints ()
LineString에 포함된 점의 개수를 반환한다. 더 자세히 ...
IGeometry * | SubLineString ([in, defaultvalue(0)] double dfLength, [in, defaultvalue(FALSE)] VARIANT_BOOL bReverse)
LineString의 부분 LineString을 가져온다. 더 자세히 ...
void | AddPoint ([in] double x, [in] double y)
객체의 가장 뒤에 점을 추가한다. 더 자세히 ...
void | RemovePoint ([in] long index)
해당 인덱스의 점을 제거한다. 더 자세히 ...
IPoint * | GetPoint ([in] long index)
특정 색인(index)에서의 점을 반환한다. 색인의 범위는 0부터 NumPoints -1 이다. 더 자세히 ...
double | GetX ([in] long index)
void | SetX ([in] long index, [in] double x)
double | GetY ([in] long index)
void | SetY ([in] long index, [in] double y)
ICurve * GetCurve ()
- sgObject::ICurve(으)로부터 상속된 Public 멤버 함수
double | GetLength ()
커브의 길이를 반환한다. 더 자세히 ...
VARIANT_BOOL | IsClosed ()
커브가 닫혀있는지 여부 (커브는 시작점과 종료점이 동일하면 닫혀있는 것)를 반환한다. 더 자세히 ...
IPoint * StartPoint ()
커브의 시작 점을 가져온다. 더 자세히 ...
IPoint * EndPoint ()
커브의 종료 점을 가져온다. 더 자세히 ...
IPoint * | Value ([in] double t)
시작 점에서 거리 t만큼 떨어져 있는 점을 가져온다. 더 자세히 ...
- sgObject::IGeometry(으)로부터 상속된 Public 멤버 함수
long | GetDimension ()
Geometry 객체의 차원 (0, 1, 2차원) 이다. 더 자세히 ...
ISpatialReference * GetSpatialReference ()
Geometry 객체가 참조하는 공간참조체계 (좌표체계) 이다. 더 자세히 ...
void | SetSpatialReference (ISpatialReference *pVal)
VARIANT_BOOL | IsEmpty ()
비어있는 Geometry 객체인지 나타낸다 (일반 프로그래밍 시 변수의 NULL과 유사) 더 자세히 ...
VARIANT_BOOL | IsSimple ()
기하가 심플한지 여부를 나타낸다. 더 자세히 ...
GeometryTypeEnum GetGeometryType ()
Geometry 객체의 구체적인 타입이다. 더 자세히 ...
void | SetEmpty ()
기하를 비어있는 기하로 만든다. 더 자세히 ...
IGeometry * Envelope ()
기하를 감싸는 최소 직사각형을 가져온다. 더 자세히 ...
IGeometry * Clone ()
해당 기하와 동일한 객체를 생성하여 가져온다. 더 자세히 ...
IGeometry * | Project ([in] ISpatialReference *newSystem)
기하를 새로운 공간참조체계로 투영해 만든 새로운 기하를 가져온다. 더 자세히 ...
void | Extent2D ([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY)
기하를 감싸는 최소 직사각형의 x, y 좌표를 Output 변수에 가져온다. 더 자세히 ...
IWks * GetWks ()
ISpatialRelation * GetSpatialRelation ()
ISpatialRelation2 * GetSpatialRelation2 ()
ISpatialOperator * GetSpatialOperator ()

상세한 설명

기하 명세에 정의된 LinearRing에 대한 일반적인 인터페이스를 제공한다. (현재는 프로퍼티 및 메소드가 없으나 LinearRing에 대한 프로퍼티 및 메소드 추가를 고려해 만들어 놓은 인터페이스이다)

LinearRing에 대한 정의 및 기타 정보는 Knowledge Base의 Geometry를 참고한다. C API(linux, iOS, MacOS 등) : 중간이름 "G"를 덧붙여서 "OGR_G_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Geometry"

멤버 함수 문서화

ILineString* sgObject::ILinearRing::GetLineString ( )

LineString 객체로 형 변환한다.

반환값
형 변환 객체(자신)
VARIANT_BOOL sgObject::ILinearRing::IsPointInRing ( [in] IPoint * dspPt )

해당 점이 내부에 포함되는지 여부를 반환한다.

매개변수
dspPt - 점 객체
반환값
포함여부
VARIANT_BOOL sgObject::ILinearRing::IsPointOnRingBoundary ( [in] IPoint * dspPt )

해당 점이 테두리선상에 있는지 여부를 반환한다.

매개변수
dspPt - 점 객체
반환값
포함여부
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ILinearRing
sgObject::ILinearRing 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ILinearRing (모든 상속된 멤버들도 포함합니다.)

AddPoint([in] double x, [in] double y) | sgObject::ILineString
Clone() | sgObject::IGeometry
EndPoint() | sgObject::ICurve
Envelope() | sgObject::IGeometry
Extent2D([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY) | sgObject::IGeometry
GetCurve() | sgObject::ILineString
GetDimension() | sgObject::IGeometry
GetGeometryType() | sgObject::IGeometry
GetLength() | sgObject::ICurve
GetLineString() | sgObject::ILinearRing
GetNumPoints() | sgObject::ILineString
GetPoint([in] long index) | sgObject::ILineString
GetSpatialOperator() | sgObject::IGeometry
GetSpatialReference() | sgObject::IGeometry
GetSpatialRelation() | sgObject::IGeometry
GetSpatialRelation2() | sgObject::IGeometry
GetWks() | sgObject::IGeometry
GetX([in] long index) | sgObject::ILineString
GetY([in] long index) | sgObject::ILineString
IsClosed() | sgObject::ICurve
IsEmpty() | sgObject::IGeometry
IsPointInRing([in] IPoint *dspPt) | sgObject::ILinearRing
IsPointOnRingBoundary([in] IPoint *dspPt) | sgObject::ILinearRing
IsSimple() | sgObject::IGeometry
Project([in] ISpatialReference *newSystem) | sgObject::IGeometry
RemovePoint([in] long index) | sgObject::ILineString
SetEmpty() | sgObject::IGeometry
SetSpatialReference(ISpatialReference *pVal) | sgObject::IGeometry
SetX([in] long index, [in] double x) | sgObject::ILineString
SetY([in] long index, [in] double y) | sgObject::ILineString
StartPoint() | sgObject::ICurve
SubLineString([in, defaultvalue(0)] double dfLength, [in, defaultvalue(FALSE)] VARIANT_BOOL bReverse) | sgObject::ILineString
Value([in] double t) | sgObject::ICurve
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ILineString 인터페이스 참조

  • ILineString
Public 멤버 함수 | 모든 멤버 목록
sgObject::ILineString 인터페이스 참조

기하 명세에 정의된 LineString의 속성과 그 속성에 접근하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::ILineString에 대한 상속 다이어그램 :
sgObject::ILineString에 대한 협력 다이어그램:

Public 멤버 함수

long | GetNumPoints ()
LineString에 포함된 점의 개수를 반환한다. 더 자세히 ...
IGeometry * | SubLineString ([in, defaultvalue(0)] double dfLength, [in, defaultvalue(FALSE)] VARIANT_BOOL bReverse)
LineString의 부분 LineString을 가져온다. 더 자세히 ...
void | AddPoint ([in] double x, [in] double y)
객체의 가장 뒤에 점을 추가한다. 더 자세히 ...
void | RemovePoint ([in] long index)
해당 인덱스의 점을 제거한다. 더 자세히 ...
IPoint * | GetPoint ([in] long index)
특정 색인(index)에서의 점을 반환한다. 색인의 범위는 0부터 NumPoints -1 이다. 더 자세히 ...
double | GetX ([in] long index)
void | SetX ([in] long index, [in] double x)
double | GetY ([in] long index)
void | SetY ([in] long index, [in] double y)
ICurve * GetCurve ()
- sgObject::ICurve(으)로부터 상속된 Public 멤버 함수
double | GetLength ()
커브의 길이를 반환한다. 더 자세히 ...
VARIANT_BOOL | IsClosed ()
커브가 닫혀있는지 여부 (커브는 시작점과 종료점이 동일하면 닫혀있는 것)를 반환한다. 더 자세히 ...
IPoint * StartPoint ()
커브의 시작 점을 가져온다. 더 자세히 ...
IPoint * EndPoint ()
커브의 종료 점을 가져온다. 더 자세히 ...
IPoint * | Value ([in] double t)
시작 점에서 거리 t만큼 떨어져 있는 점을 가져온다. 더 자세히 ...
- sgObject::IGeometry(으)로부터 상속된 Public 멤버 함수
long | GetDimension ()
Geometry 객체의 차원 (0, 1, 2차원) 이다. 더 자세히 ...
ISpatialReference * GetSpatialReference ()
Geometry 객체가 참조하는 공간참조체계 (좌표체계) 이다. 더 자세히 ...
void | SetSpatialReference (ISpatialReference *pVal)
VARIANT_BOOL | IsEmpty ()
비어있는 Geometry 객체인지 나타낸다 (일반 프로그래밍 시 변수의 NULL과 유사) 더 자세히 ...
VARIANT_BOOL | IsSimple ()
기하가 심플한지 여부를 나타낸다. 더 자세히 ...
GeometryTypeEnum GetGeometryType ()
Geometry 객체의 구체적인 타입이다. 더 자세히 ...
void | SetEmpty ()
기하를 비어있는 기하로 만든다. 더 자세히 ...
IGeometry * Envelope ()
기하를 감싸는 최소 직사각형을 가져온다. 더 자세히 ...
IGeometry * Clone ()
해당 기하와 동일한 객체를 생성하여 가져온다. 더 자세히 ...
IGeometry * | Project ([in] ISpatialReference *newSystem)
기하를 새로운 공간참조체계로 투영해 만든 새로운 기하를 가져온다. 더 자세히 ...
void | Extent2D ([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY)
기하를 감싸는 최소 직사각형의 x, y 좌표를 Output 변수에 가져온다. 더 자세히 ...
IWks * GetWks ()
ISpatialRelation * GetSpatialRelation ()
ISpatialRelation2 * GetSpatialRelation2 ()
ISpatialOperator * GetSpatialOperator ()

상세한 설명

기하 명세에 정의된 LineString의 속성과 그 속성에 접근하는 인터페이스를 제공한다.

LineString은 여러 점들을 직선으로 이어 만든 선이다. LineString에 대한 정의 및 기타 정보는 Knowledge Base의 Geometry를 참고한다. C API(linux, iOS, MacOS 등) : 중간이름 "G"를 덧붙여서 "OGR_G_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Geometry"

멤버 함수 문서화

void sgObject::ILineString::AddPoint | ( | [in] double | x,
 |  | [in] double | y
 | ) |  |

객체의 가장 뒤에 점을 추가한다.

매개변수
x | - 추가될 점 객체의 x 좌표
y | - 추가될 점 객체의 x 좌표
ICurve* sgObject::ILineString::GetCurve ( )
long sgObject::ILineString::GetNumPoints ( )

LineString에 포함된 점의 개수를 반환한다.

IPoint* sgObject::ILineString::GetPoint ( [in] long index )

특정 색인(index)에서의 점을 반환한다. 색인의 범위는 0부터 NumPoints -1 이다.

매개변수
index - 반환할 점의 색인(index 번호)
반환값
점의 기하 포인터
double sgObject::ILineString::GetX ( [in] long index )
double sgObject::ILineString::GetY ( [in] long index )
void sgObject::ILineString::RemovePoint ( [in] long index )

해당 인덱스의 점을 제거한다.

매개변수
index - 인덱스 번호
void sgObject::ILineString::SetX | ( | [in] long | index,
 |  | [in] double | x
 | ) |  |
void sgObject::ILineString::SetY | ( | [in] long | index,
 |  | [in] double | y
 | ) |  |
IGeometry* sgObject::ILineString::SubLineString | ( | [in, defaultvalue(0)] double | dfLength,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bReverse
 | ) |  |

LineString의 부분 LineString을 가져온다.

(시작점 혹은 종료점으로부터 주어진 길이의 LineString을 가져온다).

매개변수
dfLength - 부분 LineString의 길이 [default = 0]
bReverse - 부분 LineString의 방향 [default = FALSE]
TRUE : 본 LineString의 종료점을 시작점으로 하여 길이 dfLength의 LineString을 만든다.
FALSE : 본 LineString의 시작점을 시작점으로 하여 길이 dfLength의 LineString을 만든다.
반환값
새로 만들어진 부분 LineString의 기하 포인터
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ILineString
sgObject::ILineString 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ILineString (모든 상속된 멤버들도 포함합니다.)

AddPoint([in] double x, [in] double y) | sgObject::ILineString
Clone() | sgObject::IGeometry
EndPoint() | sgObject::ICurve
Envelope() | sgObject::IGeometry
Extent2D([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY) | sgObject::IGeometry
GetCurve() | sgObject::ILineString
GetDimension() | sgObject::IGeometry
GetGeometryType() | sgObject::IGeometry
GetLength() | sgObject::ICurve
GetNumPoints() | sgObject::ILineString
GetPoint([in] long index) | sgObject::ILineString
GetSpatialOperator() | sgObject::IGeometry
GetSpatialReference() | sgObject::IGeometry
GetSpatialRelation() | sgObject::IGeometry
GetSpatialRelation2() | sgObject::IGeometry
GetWks() | sgObject::IGeometry
GetX([in] long index) | sgObject::ILineString
GetY([in] long index) | sgObject::ILineString
IsClosed() | sgObject::ICurve
IsEmpty() | sgObject::IGeometry
IsSimple() | sgObject::IGeometry
Project([in] ISpatialReference *newSystem) | sgObject::IGeometry
RemovePoint([in] long index) | sgObject::ILineString
SetEmpty() | sgObject::IGeometry
SetSpatialReference(ISpatialReference *pVal) | sgObject::IGeometry
SetX([in] long index, [in] double x) | sgObject::ILineString
SetY([in] long index, [in] double y) | sgObject::ILineString
StartPoint() | sgObject::ICurve
SubLineString([in, defaultvalue(0)] double dfLength, [in, defaultvalue(FALSE)] VARIANT_BOOL bReverse) | sgObject::ILineString
Value([in] double t) | sgObject::ICurve
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ILineSymbolizer 인터페이스 참조

  • ILineSymbolizer
모든 멤버 목록
sgObject::ILineSymbolizer 인터페이스 참조

선 스타일의 표현하는 방법 및 속성을 기술한다. 더 자세히 ...

sgObject::ILineSymbolizer에 대한 상속 다이어그램 :
sgObject::ILineSymbolizer에 대한 협력 다이어그램:

추가로 상속된 멤버들

- sgObject::ISymbolizer(으)로부터 상속된 Public 멤버 함수
BSTR | GetName ()
Symbolizer 이름을 반환한다. (시스템에서 사용할 이름) 더 자세히 ...
void | SetName (BSTR bstrName)
Symbolizer 이름을 설정한다. (시스템에서 사용할 이름) 더 자세히 ...
double | GetMinScaleDenominator ()
화면에 표시할 때 Scale down할 수 있는 최소값을 반환한다. 더 자세히 ...
void | SetMinScaleDenominator (double dScale)
화면에 표시할 때 Scale down할 수 있는 최소값을 설정한다. 더 자세히 ...
double | GetMaxScaleDenominator ()
화면에 표시할 때 Scale up할 수 있는 최대값을 반환한다. 더 자세히 ...
void | SetMaxScaleDenominator (double dScale)
화면에 표시할 때 Scale up할 수 있는 최대값을 설정한다. 더 자세히 ...
void | AddStyleFromString (VARIANT vtIdx, BSTR bstrStyle)
해당 인덱스로 그래픽스타일을 추가한다. 더 자세히 ...
int | RemoveStyle (VARIANT vtIdx)
해당 인덱스의 그래픽스타일을 제거한다. 더 자세히 ...
BSTR | GetStyleToString (VARIANT vtIdx)
해당 인덱스의 그래픽스타일을 가져온다. 더 자세히 ...
ISymbolizer * Clone ()
Symbolizer를 복사하여 새로운 Symbolizer를 생성한다. 더 자세히 ...
SymbolizerTypeEnum GetSymbolizerType ()
Symbolizer의 타입을 반환한다. 더 자세히 ...
void | SetSymbolizerType (SymbolizerTypeEnum eType)
Symbolizer의 타입을 설정한다. 더 자세히 ...
IStroke * | GetStroke (BSTR bstrName)
라인 스타일 객체를 반환한다. 더 자세히 ...
IStroke * | SetStroke (BSTR bstrName, IStroke *poVal)
라인 스타일 객체를 설정한다. 더 자세히 ...
IFill * | GetFill (BSTR bstrName)
면 스타일 객체를 반환한다. 더 자세히 ...
IFill * | SetFill (BSTR bstrName, IFill *poVal)
면 스타일 객체를 설정한다. 더 자세히 ...
IMark * | GetMark (BSTR bstrName)
심볼 스타일 객체를 반환한다. 더 자세히 ...
IMark * | SetMark (BSTR bstrName, IMark *poVal)
심볼 스타일 객체를 설정한다. 더 자세히 ...
IFont * | GetFont (BSTR bstrName)
글꼴 스타일 객체를 반환한다. 더 자세히 ...
IFont * | SetFont (BSTR bstrName, IFont *poVal)
글꼴 스타일 객체를 설정한다. 더 자세히 ...

상세한 설명

선 스타일의 표현하는 방법 및 속성을 기술한다.

C API(linux, iOS, MacOS 등) : 중간이름 "SL"를 덧붙여서 "OGR_SL_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Symbolizer"

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ILineSymbolizer
sgObject::ILineSymbolizer 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ILineSymbolizer (모든 상속된 멤버들도 포함합니다.)

AddStyleFromString(VARIANT vtIdx, BSTR bstrStyle) | sgObject::ISymbolizer
Clone() | sgObject::ISymbolizer
GetFill(BSTR bstrName) | sgObject::ISymbolizer
GetFont(BSTR bstrName) | sgObject::ISymbolizer
GetMark(BSTR bstrName) | sgObject::ISymbolizer
GetMaxScaleDenominator() | sgObject::ISymbolizer
GetMinScaleDenominator() | sgObject::ISymbolizer
GetName() | sgObject::ISymbolizer
GetStroke(BSTR bstrName) | sgObject::ISymbolizer
GetStyleToString(VARIANT vtIdx) | sgObject::ISymbolizer
GetSymbolizerType() | sgObject::ISymbolizer
RemoveStyle(VARIANT vtIdx) | sgObject::ISymbolizer
SetFill(BSTR bstrName, IFill *poVal) | sgObject::ISymbolizer
SetFont(BSTR bstrName, IFont *poVal) | sgObject::ISymbolizer
SetMark(BSTR bstrName, IMark *poVal) | sgObject::ISymbolizer
SetMaxScaleDenominator(double dScale) | sgObject::ISymbolizer
SetMinScaleDenominator(double dScale) | sgObject::ISymbolizer
SetName(BSTR bstrName) | sgObject::ISymbolizer
SetStroke(BSTR bstrName, IStroke *poVal) | sgObject::ISymbolizer
SetSymbolizerType(SymbolizerTypeEnum eType) | sgObject::ISymbolizer
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ILocationSensor 인터페이스 참조

  • ILocationSensor
Public 멤버 함수 | 모든 멤버 목록
sgObject::ILocationSensor 인터페이스 참조

위치 센서 장치와 연결하여 위치 정보 수신 및 기타 부수 자료의 집계하고 제공 인터페이스를 제공한다. 더 자세히 ...

sgObject::ILocationSensor에 대한 상속 다이어그램 :
sgObject::ILocationSensor에 대한 협력 다이어그램:

Public 멤버 함수

HRESULT | GetPortNumber ([out, retval] short *pVal)
GPS 장치가 연결된 COM 포트 번호 더 자세히 ...
HRESULT | GetBaudRate ([out, retval] long *pVal)
GPS 장치와 COM 포트로 통신하는 속도 (Baud Rate) 더 자세히 ...
HRESULT | GetLocationSensorType ([out, retval] LocationSensorTypeEnum *pVal)
위치 센서의 타입을 반환한다. 더 자세히 ...
HRESULT | SetLocationSensorType ([in] LocationSensorTypeEnum type)
위치 센서의 타입을 설정한다. 더 자세히 ...
HRESULT | SetUnknownSensor ([in] int nStartPos, [in] int nUnitSize, [in] int nAdStartPos, [in] int nAdUnitSize, [in] int nHexStartPos, [in] int nHexUnitSize)
특수 센서의 센싱된 정보의 파싱을 위치, 길이 등 세부 정보를 설정한다. 더 자세히 ...
- sgObject::ISensor(으)로부터 상속된 Public 멤버 함수
HRESULT | Start ([in] IParameters *param, [out, retval] VARIANT_BOOL *bSuccess)
위치 센서의 경우 Sensor 장치를 COM 포트를 통해 사용한다. 더 자세히 ...
HRESULT | Stop ()
센서 장치의 사용을 끝낸다. 더 자세히 ...
HRESULT | IsServiceRunning ([out, retval] VARIANT_BOOL *retVal)
Sensor 장치를 사용할 수 있는지 여부 더 자세히 ...
HRESULT | GetLatestValueToXML ([out, retval] BSTR *retVal)
Sensor 장치에서 읽어온 최신 자료를 센서별 XML규격 형태로 반환한다. 더 자세히 ...

상세한 설명

위치 센서 장치와 연결하여 위치 정보 수신 및 기타 부수 자료의 집계하고 제공 인터페이스를 제공한다.

위치 센서로부터 수신되는 정보는 LocationSensorEvents 인터페이스를 통해 이벤트로 제공된다. C API(linux, iOS, MacOS 등) : 중간이름 "LSN"를 덧붙여서 "OGR_LSN</em>"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.LocationSensor"

멤버 함수 문서화

HRESULT sgObject::ILocationSensor::GetBaudRate ( [out, retval] long * pVal )

GPS 장치와 COM 포트로 통신하는 속도 (Baud Rate)

HRESULT sgObject::ILocationSensor::GetLocationSensorType ( [out, retval] LocationSensorTypeEnum * pVal )

위치 센서의 타입을 반환한다.

매개변수
pVal - Location 센서 타입
반환값
성공이면 S_OK, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ILocationSensor::GetPortNumber ( [out, retval] short * pVal )

GPS 장치가 연결된 COM 포트 번호

HRESULT sgObject::ILocationSensor::SetLocationSensorType ( [in] LocationSensorTypeEnum type )

위치 센서의 타입을 설정한다.

매개변수
type - Location 센서 타입
반환값
성공이면 S_OK, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ILocationSensor::SetUnknownSensor | ( | [in] int | nStartPos,
 |  | [in] int | nUnitSize,
 |  | [in] int | nAdStartPos,
 |  | [in] int | nAdUnitSize,
 |  | [in] int | nHexStartPos,
 |  | [in] int | nHexUnitSize
 | ) |  |

특수 센서의 센싱된 정보의 파싱을 위치, 길이 등 세부 정보를 설정한다.

매개변수
nStartPos | - 시작 위치
nUnitSize | - 단위 길이
nAdStartPos | - 유효 시작 위치
nAdUnitSize | - 유효 단위 길이
nHexStartPos | - 헥사 코드로 유효 시작 위치
nHexUnitSize | - 헥사 코드로 유효 단위 길이
반환값
성공이면 S_OK, 그렇지 않으면 HRESULT 에러코드
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ILocationSensor
sgObject::ILocationSensor 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ILocationSensor (모든 상속된 멤버들도 포함합니다.)

GetBaudRate([out, retval] long *pVal) | sgObject::ILocationSensor
GetLatestValueToXML([out, retval] BSTR *retVal) | sgObject::ISensor
GetLocationSensorType([out, retval] LocationSensorTypeEnum *pVal) | sgObject::ILocationSensor
GetPortNumber([out, retval] short *pVal) | sgObject::ILocationSensor
IsServiceRunning([out, retval] VARIANT_BOOL *retVal) | sgObject::ISensor
SetLocationSensorType([in] LocationSensorTypeEnum type) | sgObject::ILocationSensor
SetUnknownSensor([in] int nStartPos, [in] int nUnitSize, [in] int nAdStartPos, [in] int nAdUnitSize, [in] int nHexStartPos, [in] int nHexUnitSize) | sgObject::ILocationSensor
Start([in] IParameters *param, [out, retval] VARIANT_BOOL *bSuccess) | sgObject::ISensor
Stop() | sgObject::ISensor
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ILocationService 인터페이스 참조

  • ILocationService
Public 멤버 함수 | 모든 멤버 목록
sgObject::ILocationService 인터페이스 참조

LBS의 주요 기능을 제공하는 인터페이스로 주소정보를 기반으로 해당위치의 Feature 객체를 검색하고,. 더 자세히 ...

sgObject::ILocationService에 대한 상속 다이어그램 :
sgObject::ILocationService에 대한 협력 다이어그램:

Public 멤버 함수

ISpatialReference * GetSpatialReference ()
기준이 되는 공간참조체계를 나타낸다. 더 자세히 ...
void | SetSpatialReference ([in] ISpatialReference *crs)
BSTR | GeoCode ([in] BSTR strAddr, [in] BSTR strOption)
주소 정보를 받아 해당 주소의 위치에 좌표 정보를 반환한다. 더 자세히 ...
BSTR | RevGeoCode ([in] double x, [in] double y, [in] BSTR strOption, [in] ISpatialReference *poSrcSRS)
주어진 위치에서 가장 가까운 주소정보를 반환한다. 더 자세히 ...
BSTR | NearestName ([in] BSTR strKeyword, [in] BSTR strOption)
주어진 POI 정보에서 가장 가까운 주변 객체를 검색 문자열로 반환한다. 더 자세히 ...
BSTR | NearestPoint ([in] double x, [in] double y, [in] BSTR strKeyword, [in] BSTR strOption, [in] ISpatialReference *poSrcSRS)
주어진 위치와 POI정보에서 가장 가까운 객체를 검색 반환한다. 더 자세히 ...
BSTR | WithinDistance ([in] double x, [in] double y, [in] BSTR strKeyword, [in] double dlMinDist, [in] double dlMaxDist, [in] BSTR strOption, [in] ISpatialReference *poSrcSRS)
특정 위치에 범위내에 존재하는 POI 객체를 검색 반환한다. 더 자세히 ...
IFeatureCollection * | RouteDetermine ([in] IPoint *poStartPt, [in] IPoint *poEndPt, [in] ISpatialReference *poSrcSRS)
IFeatureLayer * | WithinFeature ([in] ILayerSource *SrcLayerSource, [in] ILayer *SrcLayer, [in] double x, [in] double y, [in] IParameters *Params)
해당 레이어에서 주어진 점을 포함하는 객체를 검색하여 피쳐레이어로 반환한다. 더 자세히 ...

상세한 설명

LBS의 주요 기능을 제공하는 인터페이스로 주소정보를 기반으로 해당위치의 Feature 객체를 검색하고,.

관리하는 기능 인터페이스를 제공한다.

멤버 함수 문서화

BSTR sgObject::ILocationService::GeoCode | ( | [in] BSTR | strAddr,
 |  | [in] BSTR | strOption
 | ) |  |

주소 정보를 받아 해당 주소의 위치에 좌표 정보를 반환한다.

매개변수
strAddr | - 주소
strOption | - 옵션
반환값
주소에 해당하는 점 객체를 정보 문자
ISpatialReference* sgObject::ILocationService::GetSpatialReference ( )

기준이 되는 공간참조체계를 나타낸다.

BSTR sgObject::ILocationService::NearestName | ( | [in] BSTR | strKeyword,
 |  | [in] BSTR | strOption
 | ) |  |

주어진 POI 정보에서 가장 가까운 주변 객체를 검색 문자열로 반환한다.

매개변수
strKeyword | - 검색키워드
strOption | - 옵션
반환값
검색된 정보의 좌표와 정보를 포함한 문자열
BSTR sgObject::ILocationService::NearestPoint | ( | [in] double | x,
 |  | [in] double | y,
 |  | [in] BSTR | strKeyword,
 |  | [in] BSTR | strOption,
 |  | [in] ISpatialReference * | poSrcSRS
 | ) |  |

주어진 위치와 POI정보에서 가장 가까운 객체를 검색 반환한다.

매개변수
x | - 검색 점 x 좌표
y | - 검색 점 y 좌표
strKeyword | - 검색키워드
strOption | - 옵션
poSrcSRS | - 검색 점 좌표계
반환값
검색된 정보의 좌표와 정보를 포함한 문자열
BSTR sgObject::ILocationService::RevGeoCode | ( | [in] double | x,
 |  | [in] double | y,
 |  | [in] BSTR | strOption,
 |  | [in] ISpatialReference * | poSrcSRS
 | ) |  |

주어진 위치에서 가장 가까운 주소정보를 반환한다.

매개변수
x | - 검색 점 x 좌표
y | - 검색 점 y 좌표
strOption | - 옵션
poSrcSRS | - 검색 점 좌표계
반환값
검색된 주소 문자 정보
IFeatureCollection* sgObject::ILocationService::RouteDetermine | ( | [in] IPoint * | poStartPt,
 |  | [in] IPoint * | poEndPt,
 |  | [in] ISpatialReference * | poSrcSRS
 | ) |  |
void sgObject::ILocationService::SetSpatialReference ( [in] ISpatialReference * crs )
BSTR sgObject::ILocationService::WithinDistance | ( | [in] double | x,
 |  | [in] double | y,
 |  | [in] BSTR | strKeyword,
 |  | [in] double | dlMinDist,
 |  | [in] double | dlMaxDist,
 |  | [in] BSTR | strOption,
 |  | [in] ISpatialReference * | poSrcSRS
 | ) |  |

특정 위치에 범위내에 존재하는 POI 객체를 검색 반환한다.

매개변수
x | - 검색 점 x 좌표
y | - 검색 점 y 좌표
strKeyword | - 검색키워드
dlMinDist | - 최소거리
dlMaxDist | - 최대거리
strOption | - 옵션
poSrcSRS | - 검색 점 좌표계
반환값
검색된 정보의 좌표와 정보를 포함한 문자열
IFeatureLayer* sgObject::ILocationService::WithinFeature | ( | [in] ILayerSource * | SrcLayerSource,
 |  | [in] ILayer * | SrcLayer,
 |  | [in] double | x,
 |  | [in] double | y,
 |  | [in] IParameters * | Params
 | ) |  |

해당 레이어에서 주어진 점을 포함하는 객체를 검색하여 피쳐레이어로 반환한다.

매개변수
SrcLayerSource | - 검색 대상 레이어의 레이어소스 객체
SrcLayer | - 검색 대상 레이어 객체
x | - 포함 여부 검색 대상 x 좌표
y | - 포함 여부 검색 대상 x 좌표
Params | - 검색 대상 객체의 속성 필드 참조 정보(x/long/lon - 검색 레이어의 x 중심점 필드명, y/lat - 검색 레이어의 y 중심점 필드명)
반환값
검색 결과를 포함한 레이어 객체. 검색된 결과는 새로운 Layer와 FeatureLayer로 반환됨으로 필요가 없는 경우 Layer와 해당 FeatureLayer를 삭제해야 한다.
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ILocationService
sgObject::ILocationService 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ILocationService (모든 상속된 멤버들도 포함합니다.)

GeoCode([in] BSTR strAddr, [in] BSTR strOption) | sgObject::ILocationService
GetSpatialReference() | sgObject::ILocationService
NearestName([in] BSTR strKeyword, [in] BSTR strOption) | sgObject::ILocationService
NearestPoint([in] double x, [in] double y, [in] BSTR strKeyword, [in] BSTR strOption, [in] ISpatialReference *poSrcSRS) | sgObject::ILocationService
RevGeoCode([in] double x, [in] double y, [in] BSTR strOption, [in] ISpatialReference *poSrcSRS) | sgObject::ILocationService
RouteDetermine([in] IPoint *poStartPt, [in] IPoint *poEndPt, [in] ISpatialReference *poSrcSRS) | sgObject::ILocationService
SetSpatialReference([in] ISpatialReference *crs) | sgObject::ILocationService
WithinDistance([in] double x, [in] double y, [in] BSTR strKeyword, [in] double dlMinDist, [in] double dlMaxDist, [in] BSTR strOption, [in] ISpatialReference *poSrcSRS) | sgObject::ILocationService
WithinFeature([in] ILayerSource *SrcLayerSource, [in] ILayer *SrcLayer, [in] double x, [in] double y, [in] IParameters *Params) | sgObject::ILocationService
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ImageSymbol 클래스 참조

  • ImageSymbol
sgObject::ImageSymbol 클래스 참조

ImageSymbol은 Raster Image 심볼을 관리하는 객체이다. 더 자세히 ...

sgObject::ImageSymbol에 대한 협력 다이어그램:

상세한 설명

ImageSymbol은 Raster Image 심볼을 관리하는 객체이다.

심볼은 Geometry를 가진 객체이지만 이를 표현하는 것보다 이를 대표하는 그림을 사용하는 것이 좋을 때 사용한다. 또한 주석 등에도 심볼을 사용할 수 있다. 자세한 설명은 IImageSymbol 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IMap2D 인터페이스 참조

  • IMap2D
Public 멤버 함수 | 모든 멤버 목록
sgObject::IMap2D 인터페이스 참조

2D 지도를 관리하는 객체로 Canvas 객체로 부터 상속되었으며 사용자에게 지도를 표출하고 마우스 등 사용자 UI 인터페이스를 제공한다. 더 자세히 ...

sgObject::IMap2D에 대한 상속 다이어그램 :
sgObject::IMap2D에 대한 협력 다이어그램:

Public 멤버 함수

HRESULT | GetScale ([in] VARIANT_BOOL bPixcelUnit, [out, retval] double *pVal)
FeatureCanvas이 Feature를 Map2D로 그리는데 사용된 축척 더 자세히 ...
HRESULT | SetScale ([in] double newVal, [in] VARIANT_BOOL bPixcelUnit)
HRESULT | GetRotate ([out, retval] short *pVal)
지도의 회전각도 더 자세히 ...
HRESULT | SetRotate ([in] short newVal)
HRESULT | GetScreenMode ([out, retval] ScreenModeEnum *pVal)
지도에서 사용자가 수행하려하는 동작 모드 더 자세히 ...
HRESULT | SetScreenMode ([in] ScreenModeEnum newVal)
HRESULT | GetSnapMode ([out, retval] long *pVal)
객체의 입력, 수정 과정에서 공간 객체의 스냅 모드 더 자세히 ...
HRESULT | SetSnapMode ([in] long newVal)
HRESULT | GetSelectMode ([out, retval] SpatialOperatorEnum *pVal)
지도에서 Feature 객체를 선택할 때 사용하는 객체 선택 방법 더 자세히 ...
HRESULT | SetSelectMode ([in] SpatialOperatorEnum newVal)
HRESULT | GetVisibleSmallGeometry ([out, retval] VARIANT_BOOL *pVal)
작은 Geometry 객체의 화면에 표시 여부 더 자세히 ...
HRESULT | SetVisibleSmallGeometry ([in] VARIANT_BOOL newVal)
HRESULT | GetSmallPixelSize ([out, retval] short *pVal)
작은 객체를 표현할 최소 픽셀 크기 더 자세히 ...
HRESULT | SetSmallPixelSize ([in] short newVal)
HRESULT | GetAntiAlias ([out, retval] VARIANT_BOOL *pVal)
지도를 화면에 그릴 때 부드러운 라인, 폴리곤으로 그릴지 여부 더 자세히 ...
HRESULT | SetAntiAlias ([in] VARIANT_BOOL newVal)
HRESULT | GetMinZoomScaleDenominator ([out, retval] double *pVal)
지도의 최대 축소 스케일 지정 더 자세히 ...
HRESULT | SetMinZoomScaleDenominator ([in] double newVal)
HRESULT | GetMaxZoomScaleDenominator ([out, retval] double *pVal)
지도의 최대 확대 스케일 지정 더 자세히 ...
HRESULT | SetMaxZoomScaleDenominator ([in] double newVal)
HRESULT | GetFillBrush ([out, retval] VARIANT_BOOL *pVal)
폴리곤 객체의 채워 그리기 여부 더 자세히 ...
HRESULT | SetFillBrush ([in] VARIANT_BOOL newVal)
HRESULT | GetSnapGrid ([out, retval] long *pVal)
지도의 스냅그리드 표현 및 스냅 픽셀 수 설정 더 자세히 ...
HRESULT | SetSnapGrid ([in] long newVal)
HRESULT | GetSyncMoveMode ([out, retval] long *pVal)
버텍스, 노드를 이동시 같은 좌표점을 가진 객체의 동시 이동 모드 설정 더 자세히 ...
HRESULT | SetSyncMoveMode ([in] long newVal)
HRESULT | GetPointOnSurface ([out, retval] VARIANT_BOOL *pVal)
폴리곤 객체를 선택할 경우 점 뿐 아니라 면을 선택했을 경우도 선택할지의 여부 더 자세히 ...
HRESULT | SetPointOnSurface ([in] VARIANT_BOOL newVal)
HRESULT | GetAutoScale ([out, retval] VARIANT_BOOL *pVal)
OpenAPI 레이어가 존재하는 경우 지도 이미지의 픽셀수에 따라 지도 스케일을 자동으로 설정할지 여부 더 자세히 ...
HRESULT | SetAutoScale ([in] VARIANT_BOOL newVal)
HRESULT | GetOverlapLabel ([out, retval] VARIANT_BOOL *pVal)
레이어별 속성 주석의 겹쳐 그리기 허용 여부 더 자세히 ...
HRESULT | SetOverlapLabel ([in] VARIANT_BOOL newVal)
HRESULT | GetFlickerSelected ([out, retval] VARIANT_BOOL *pVal)
객체 선택시 선택된 객체의 깜빡거림 허용 여부 더 자세히 ...
HRESULT | SetFlickerSelected ([in] VARIANT_BOOL newVal)
HRESULT | GetVisibleMagnifier ([out, retval] VARIANT_BOOL *pVal)
확대경 화면에 표시 여부 더 자세히 ...
HRESULT | SetVisibleMagnifier ([in] VARIANT_BOOL newVal)
HRESULT | GetMagnifierPixelSize ([out, retval] int *pVal)
확대경의 화면 픽셀 크기 더 자세히 ...
HRESULT | SetMagnifierPixelSize ([in] int newVal)
HRESULT | GetMagnifierScale ([out, retval] float *pVal)
확대경의 확대 배율 더 자세히 ...
HRESULT | SetMagnifierScale ([in] float newVal)
HRESULT | GetScaleBarRelativePos ([out] double *x, [out] double *y)
스케일바 상대 위치 이동값 더 자세히 ...
HRESULT | SetScaleBarRelativePos ([in] double x, [in] double y)
HRESULT | GetScaleBarShowType ([out, retval] AlignPositionEnum *showtype)
스케일바 상대 위치 더 자세히 ...
HRESULT | SetScaleBarShowType ([in] AlignPositionEnum showtype)
HRESULT | ZoomAll ()
FeatureCanvas의 모든 정보가 표시될 수 있도록 화면 스케일을 조정한다. 더 자세히 ...
HRESULT | ZoomRect ([in] double dlMinX, [in] double dlMinY, [in] double dlMaxX, [in] double dlMaxY)
매개변수로 지정한 사각형 영역만 보여주도록 화면 스케일을 조정한다. 더 자세히 ...
HRESULT | ZoomIn ()
화면 스케일을 확대한다. 더 자세히 ...
HRESULT | ZoomOut ()
화면 스케일을 축소한다. 더 자세히 ...
HRESULT | ZoomFeature (IFeature *obj)
해당 Feature가 화면에 가득차게 보여주도록 화면 스케일을 조정한다. 더 자세히 ...
HRESULT | ZoomToSelectedFeatures ()
선택된 Feature들을 화면에 가득차게 보여주도록 화면 스케일을 조정한다. 더 자세히 ...
HRESULT | ZoomGPS ([in] double zoomScale)
위치센서로부터 들어오는 위치로 화면의 중심을 이동 조정한다. 더 자세히 ...
HRESULT | ZoomCenter ([in] double dx, [in] double dy)
화면의 중심을 지정한 좌표로 이동한다. 더 자세히 ...
HRESULT | ZoomPrevious ()
바로 이전에 봤던 화면으로 이동한다. 더 자세히 ...
HRESULT | ZoomNext ()
이전 화면으로 이동된 경우에 바로 전(이후) 화면으로 이동한다. 더 자세히 ...
HRESULT | BoundingBox ([out] double *dlMinX, [out] double *dlMinY, [out] double *dlMaxX, [out] double *dlMaxY)
화면의 Frame 사각형이 표시하는 실세계 영역을 가져온다. 더 자세히 ...
HRESULT | DeviceToWorld ([in] float ix, [in] float iy, [out] double *pdx, [out] double *pdy)
지도 화면 좌표에 대응되는 실세계 좌표를 가져온다. 더 자세히 ...
HRESULT | DeviceToWorldZ ([in] float ix, [in] float iy, [out] DOUBLE *z)
지도 화면 좌표에 대응되는 실세계 좌표를 가져온다.(DEM이 있는 경우 Z값) 더 자세히 ...
HRESULT | WorldToDevice ([in] double dx, [in] double dy, [out] float *pix, [out] float *piy)
실세계 좌표에 해당하는 지도 화면 좌표를 가져온다. 더 자세히 ...
HRESULT | WorldToRasterPixel ([in] double dx, [in] double dy, [in] IFeature *pdspFt, [out] float *pix, [out] float *piy)
실세계 좌표에 해당하는 래스터 이미지의 픽셀 번호를 가져온다. 더 자세히 ...
HRESULT | RasterPixelToWorld ([in] float ix, [in] float iy, [in] IFeature *pdspFt, [out] double *pdx, [out] double *pdy)
래스터 이미지의 픽셀 번호에 해당하는 실세계 좌표를 가져온다. 더 자세히 ...
HRESULT | ExportImageToWorld ([in]BSTR pVal, long nNumPixelWidth, long nNumPixelHeight, [in] double dlMinX, [in] double dlMinY, [in] double dlMaxX, [in] double dlMaxY)
실세계 최대 최소 좌표에 해당하는 화면을 이미지 파일로 내보낸다. 더 자세히 ...
HRESULT | ExportToClipboard ([in] VARIANT_BOOL bOriginMap)
화면을 윈도우 클립보드로 내보낸다. 더 자세히 ...
HRESULT | GetMeasureLineStd ([out] double *x, [out] double *y)
줄자의 기준점 더 자세히 ...
HRESULT | SetMeasureLineStd ([in] double x, [in] double y)
HRESULT | GetMeasureLineStdLength ([out, retval] double *length)
줄자의 기준 눈금의 실거리 더 자세히 ...
HRESULT | SetMeasureLineStdLength ([in] double length)
HRESULT | GetMeasureLineSubUnitNum ([out] int *sub1, [out] int *sub2)
줄자의 기준 눈금당 보조 눈금의 개수 더 자세히 ...
HRESULT | SetMeasureLineSubUnitNum ([in] int sub1, [in] int sub2)
HRESULT | GetMeasureLineShowType ([out, retval] long *showtype)
줄자의 기준 눈금당 보조 눈금의 개수 더 자세히 ...
HRESULT | SetMeasureLineShowType ([in] long showtype)
HRESULT | ZoomToFeatureCollection ([in] IFeatureCollection *pdspFtCol)
해당 FeatureCollection의 영역이 화면에 가득차게 보여주도록 화면 스케일을 조정한다. 더 자세히 ...
HRESULT | GetRatioZoomScale ([out, retval] double *pVal)
확대 배율 더 자세히 ...
HRESULT | SetRatioZoomScale ([in] double newVal)
HRESULT | AnimateSelectedFeatureCollection ()
선택된 객체에 대해 선택애니메이션 효과를 준다. 더 자세히 ...
HRESULT | GetMinXBoundingBox ([out, retval] double *dlMinX)
화면의 Frame 사각형이 표시하는 실세계 영역을 가져온다. 더 자세히 ...
HRESULT | GetMinYBoundingBox ([out, retval] double *dlMinY)
HRESULT | GetMaxXBoundingBox ([out, retval] double *dlMaxX)
HRESULT | GetMaxYBoundingBox ([out, retval] double *dlMaxY)
HRESULT | SetSelectedSymbolizer ([in] ISymbolizer *poStyleTable)
선택된 객체에 대해 선택 스타일을 지정한다. 더 자세히 ...
HRESULT | SetSelectedSymbolizerFromString ([in] BSTR pszStyleString)
HRESULT | SetKeyEnable ([in] SystemKeyEnum type, [in] VARIANT_BOOL bVal)
지도창 내에서 키보드 및 마우스 버튼의 사용여부를 설정한다. 더 자세히 ...
HRESULT | GetXDeviceToWorld ([in] double ix, [in] double iy, [out, retval] double *pdx)
지도 화면 좌표에 대응되는 실세계 좌표를 가져온다. 더 자세히 ...
HRESULT | GetYDeviceToWorld ([in] double ix, [in] double iy, [out, retval] double *pdy)
HRESULT | GetXWorldToDevice ([in] double dx, [in] double dy, [out, retval] float *pix)
HRESULT | GetYWorldToDevice ([in] double dx, [in] double dy, [out, retval] float *piy)
HRESULT | ShowPrintLayoutWidget ([in] BSTR strTitle, [out, retval] IPrintLayoutWidget **dspWidget)
출력폼 창을 띄운다. 더 자세히 ...
HRESULT | GetUseDrawThread ([out, retval] VARIANT_BOOL *pVal)
화면에 그림을 그리거나 OpenAPI를 가져오는 과정에서 스레드를 사용할지 여부 더 자세히 ...
HRESULT | SetUseDrawThread ([in] VARIANT_BOOL newVal)
HRESULT | SetSelectedVertexSymbolizer ([in] ISymbolizer *poStyleTable)
선택된 객체의 버텍스, 노드의 표현 스타일을 지정한다. 더 자세히 ...
HRESULT | SetSelectedVertexSymbolizerFromString ([in] BSTR pszStyleString)
HRESULT | ExportScreenImage ([in] BSTR strFileName, [in] long nPosX, [in] long nPosY, [in] long nNumPixelWidth, [in] long nNumPixelHeight)
지도화면 영역을 화면 캡쳐하여 이미지 파일로 내보낸다. 지도 화면 위에 다른 외부 객체가 있는 경우도 함께 내보낸다. 더 자세히 ...
HRESULT | SetMouseButtonEnable ([in] MouseButtonTypeEnum eType, [in] VARIANT_BOOL bEnable)
지도창 내에서 마우스 버튼의 사용여부를 설정한다. 더 자세히 ...
HRESULT | SetDrawProgressEnable ([in] VARIANT_BOOL bEnable)
지도창 내에서 지도가 그려지는 상태바를 표현할지 여부를 설정한다. 더 자세히 ...
HRESULT | SetScaleBarSymbolizer ([in] ISymbolizer *poStyleTable)
스케일바의 표현 스타일을 지정한다. 더 자세히 ...
HRESULT | SetScaleBarSymbolizerFromString ([in] BSTR pszStyleString)
HRESULT | SetMouseCursor ([in] CursorEnum eCurType, [in] BSTR strFileName, [in] int clrTransparent, [in] int xHotspot, [in] int yHotspot)
마우스의 커서 모양을 변경한다. 더 자세히 ...
HRESULT | SetSystemSymbolizerFromString ([in] SystemSymbolEnum type, [in] BSTR bstrStyleString)
시스템내부리소스의 표현 스타일을 지정한다. 더 자세히 ...
HRESULT | DrawingGeometryAddPoint ([in] double x, [in] double y)
현재 화면상에 작도중인 객체에 맨뒤에 점을 추가한다. 더 자세히 ...
HRESULT | DrawingGeometryRemovePoint ([in] int nIndex)
현재 화면상에 작도중인 객체에 해당 인덱스 위치의 점을 삭제한다. 더 자세히 ...
HRESULT | DrawingGeometrySetPoint ([in] int nIndex, [in] double x, [in] double y)
현재 화면상에 작도중인 객체에 해당 인덱스 위치점의 위치를 설정한다. 더 자세히 ...
HRESULT | DrawingGeometryGetPoint ([in] int nIndex, [out] double *x, [out] double *y)
현재 화면상에 작도중인 객체에 해당 인덱스 위치점의 위치를 반환 한다. 더 자세히 ...
HRESULT | DrawingGeometryComplete ()
현재 화면상에 작도중인 객체의 작도를 완료한다. 더 자세히 ...
HRESULT | DrawingGeometrySize ()
현재 화면상에 작도중인 객체의 점의 개수를 반환한다. 더 자세히 ...
HRESULT | DrawingGeometryAddGPSPoint ()
현재 화면상에 작도중인 객체에 맨뒤에 위치센서로부터 들어온 최신값을 가진 점을 추가한다. 더 자세히 ...
HRESULT | GetMapControlRelativePos ([in] SystemResourceEnum eCtlType, [out] double *x, [out] double *y)
시스템 내부 지원 지도 제어 객체의 상대 위치 이동값 더 자세히 ...
HRESULT | SetMapControlRelativePos ([in] SystemResourceEnum eCtlType, [in] double x, [in] double y)
HRESULT | GetMapControlShowType ([in] SystemResourceEnum eCtlType, [out, retval] AlignPositionEnum *showtype)
시스템 내부 지원 지도 제어 객체의 상대 위치 더 자세히 ...
HRESULT | SetMapControlShowType ([in] SystemResourceEnum eCtlType, [in] AlignPositionEnum showtype)
HRESULT | GetScalePrecision ([out, retval] int *pVal)
스케일 문자 소수점 자리수 더 자세히 ...
HRESULT | SetScalePrecision ([in] int nPrecision)
HRESULT | SetMapControlImageFromFileName ([in] SystemResourceEnum eCtlType, [in] BSTR strFileName)
시스템 내부 지원 지도 제어 객체의 이미지 파일명 설정 더 자세히 ...
HRESULT | GetTransparentBackColor ([out, retval] VARIANT_BOOL *pVal)
이미지 내보내기시 배경화면을 투명처리할지 여부 더 자세히 ...
HRESULT | SetTransparentBackColor ([in] VARIANT_BOOL newVal)
HRESULT | GetMeasureValue ([out, retval] double *dValue)
측정 모드의 현재 측정 값 호출 더 자세히 ...
- sgObject::ICanvas(으)로부터 상속된 Public 멤버 함수
HRESULT | GetCommonFactory ([out, retval] ICommonFactory **pVal)
CommonFactory를 가져온다. 더 자세히 ...
HRESULT | GetCanvasType ([out, retval] CanvasTypeEnum *pVal)
지도 (Canvas 객체) 종류를 반환한다. 더 자세히 ...
HRESULT | GetTitle ([out, retval] BSTR *pVal)
지도 (Canvas 객체) 이름 더 자세히 ...
HRESULT | SetTitle ([in] BSTR newVal)
HRESULT | GetState ([out, retval] int *pVal)
화면 (Canvas 객체) 상태 더 자세히 ...
HRESULT | SetState ([in] int newVal)
HRESULT | GetFeatureCanvas ([out, retval] IFeatureCanvas **pVal)
지도에 표현되는 FeatureLayer(공간정보레이어)를 관리하는 FeatureCanvas 정보 더 자세히 ...
HRESULT | SetFeatureCanvas ([in] IFeatureCanvas *pVal)
HRESULT | GetBackColor ([out, retval] long *pVal)
배경색(RGB) 더 자세히 ...
HRESULT | SetBackColor ([in] long newVal)
HRESULT | GetMapControl ([out, retval] long *pVal)
지도에 표시되는 제어창(방위, 스케일바 등) 더 자세히 ...
HRESULT | SetMapControl ([in] long newVal)
HRESULT | VisibleMapControl ([in] SystemResourceEnum type, [in] VARIANT_BOOL bVisible)
지도에 표시할 제어창의 종류를 설정한다. 더 자세히 ...
HRESULT | GetMapMoveMode ([out, retval] MapMoveEnum *pVal)
위치센서 정보 수신에 따른 지도의 자동 이동 여부 더 자세히 ...
HRESULT | SetMapMoveMode ([in] MapMoveEnum type)
HRESULT | GetMapRotateMode ([out, retval] MapRotateEnum *pVal)
위치센서 정보 수신 중 이동에 따른 지도 방향 자동 회전 여부 더 자세히 ...
HRESULT | SetMapRotateMode ([in] MapRotateEnum type)
HRESULT | SetLocationSensor ([in] ILocationSensor *pdspSensor)
지도에서 사용할 위치센서를 지정한다. 더 자세히 ...
HRESULT | SetMotionSensor ([in] IMotionSensor *pdspSensor)
지도에서 사용할 모션센서를 지정한다. 더 자세히 ...
HRESULT | SetVideoSensor ([in] IVideoSensor *pdspSensor)
지도에서 사용할 비디오센서를 지정한다. 더 자세히 ...
HRESULT | RemoveSensor ([in] ISensor *pdspSensor)
지도에서 사용중인 센서를 삭제한다. 더 자세히 ...
HRESULT | GetObjectiveSpatialReference ([out, retval] ISpatialReference **pVal)
지도의 실질 공간 좌표 체계 더 자세히 ...
HRESULT | SetObjectiveSpatialReference ([in] ISpatialReference *pVal)
HRESULT | Initialize ([in] ULONG_PTR h)
지도를 그려야 할 객체의 핸들을 초기화 한다. 더 자세히 ...
HRESULT | Invalidate ()
지도를 다시 그리도록 한다. 더 자세히 ...
HRESULT | ExportImage ([in]FileFormatEnum nFileType, [in]BSTR pVal)
지도화면을 이미지 파일로 내보낸다. 더 자세히 ...
HRESULT | AddControl ([in] long fid, [in] IUserDefinedWidget *dspUDBox)
외부 컨트롤을 지도상에 추가한다. 더 자세히 ...
HRESULT | RemoveControl ([in] long fid)
AddControl에 의해 입력된 외부 컨트롤을 지도상에서 삭제한다. 더 자세히 ...
HRESULT | RemoveAllControl ()
AddControl에 의해 입력된 모든 외부 컨트롤을 지도상에서 삭제한다. 더 자세히 ...
HRESULT | GetHittestSize ([out, retval] int *pVal)
화면에서 객체 선택을 위한 검색 픽셀 범위 더 자세히 ...
HRESULT | SetHittestSize ([in] int newVal)
HRESULT | ForceStopRender ()
화면 렌더링 중지 더 자세히 ...
HRESULT | MouseMove ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 마우스 이동 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | LButtonDown ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 왼쪽 마우스의 버튼을 누른 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | LButtonUp ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 왼쪽 마우스의 눌린 버튼을 놓았다는 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | RButtonDown ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 오른쪽 마우스의 버튼을 누른 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | RButtonUp ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 오른쪽 마우스의 눌린 버튼을 놓았다는 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | DblClick ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 왼쪽 마우스를 더블클릭 했음을 강제로 설정한다. 더 자세히 ...
HRESULT | ReSize ([in] LONG nType, [in] int cx, [in] int cy)
지도의 크기를 조정했음으로 강제로 설정한다. 더 자세히 ...
HRESULT | KeyDown ([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags)
지도에서 특정 키를 눌렀음을 강제로 설정한다. 더 자세히 ...
HRESULT | KeyUp ([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags)
지도에서 특정 키를 떼었음을 강제로 설정한다. 더 자세히 ...
HRESULT | MButtonDown ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 중간 마우스의 버튼을 누른 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | MButtonUp ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 중간 마우스의 눌린 버튼을 놓았다는 정보를 강제로 설정한다. 더 자세히 ...

상세한 설명

2D 지도를 관리하는 객체로 Canvas 객체로 부터 상속되었으며 사용자에게 지도를 표출하고 마우스 등 사용자 UI 인터페이스를 제공한다.

모든 지도는 FeatureCanvas에 저장된 자료에 대해 화면에 표현하게 된다. FeatureCanvas는 내부에 여러 개의 FeatureLayer가 저장된 객체로 Map2D 객체를 통해 FeatureCanvas에 있는 Feature들을 실제 화면에 표현한다. 이 구조는 MVC 모델의 Document/View 구조와 유사하며 FeatureCanvas는 Document, Map2D는 View에 해당한다. C API(linux, iOS, MacOS 등) : 중간이름 "2D"를 덧붙여서 "OGR_2D_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Map2D"

멤버 함수 문서화

HRESULT sgObject::IMap2D::AnimateSelectedFeatureCollection ( )

선택된 객체에 대해 선택애니메이션 효과를 준다.

SetFlickerSelected 함수에 의해 선택효과가 켜져 있는 경우 지원하며 기본값이 켜져 있다.

HRESULT sgObject::IMap2D::BoundingBox | ( | [out] double * | dlMinX,
 |  | [out] double * | dlMinY,
 |  | [out] double * | dlMaxX,
 |  | [out] double * | dlMaxY
 | ) |  |

화면의 Frame 사각형이 표시하는 실세계 영역을 가져온다.

화면에 그려지는 FeatureCanvas의 Feature들이 참조하는 공간참조체계의 좌표값으로 가져온다.

  • Java의 경우 : 각각의 좌표값을 가져온 변수를 배열로 생성한다. 예) double dlMinX[] = new double[1]; double dlMinY[] = new double[1]; double dlMaxX[] = new double[1]; double dlMaxY[] = new double[1];
    매개변수
    dlMinX | - 화면에 표시되는 실세계 영역의 최소 X 좌표값을 가져올 변수
    dlMinY | - 화면에 표시되는 실세계 영역의 최소 Y 좌표값을 가져올 변수
    dlMaxX | - 화면에 표시되는 실세계 영역의 최대 X 좌표값을 가져올 변수
    dlMaxY | - 화면에 표시되는 실세계 영역의 최대 Y 좌표값을 가져올 변수
    반환값
    S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IMap2D::DeviceToWorld | ( | [in] float | ix,
 |  | [in] float | iy,
 |  | [out] double * | pdx,
 |  | [out] double * | pdy
 | ) |  |

지도 화면 좌표에 대응되는 실세계 좌표를 가져온다.

  • Java의 경우 : 실세계 좌표값을 가져온 변수를 배열로 생성한다. 예) double pdx[] = new double[1]; double pdy[] = new double[1];
    매개변수
    ix | - 지도 화면 좌표의 x 값
    iy | - 지도 화면 좌표의 y 값
    pdx | - 실세계 좌표의 x 값을 넣을 변수
    pdy | - 실세계 좌표의 y 값을 넣을 변수
    반환값
    S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IMap2D::DeviceToWorldZ | ( | [in] float | ix,
 |  | [in] float | iy,
 |  | [out] DOUBLE * | z
 | ) |  |

지도 화면 좌표에 대응되는 실세계 좌표를 가져온다.(DEM이 있는 경우 Z값)

  • Java의 경우 : 실세계 좌표값을 가져온 변수를 배열로 생성한다. 예) double z[] = new double[1];
    매개변수
    ix | - 지도 화면 좌표의 x 값
    iy | - 지도 화면 좌표의 y 값
    z | - 실세계 좌표의 z 값을 넣을 변수
    반환값
    S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IMap2D::DrawingGeometryAddGPSPoint ( )

현재 화면상에 작도중인 객체에 맨뒤에 위치센서로부터 들어온 최신값을 가진 점을 추가한다.

단, 현재 지도차에 위치센서가 추가되어 있어야 한다. 참조) ICanvas::AddSensor

HRESULT sgObject::IMap2D::DrawingGeometryAddPoint | ( | [in] double | x,
 |  | [in] double | y
 | ) |  |

현재 화면상에 작도중인 객체에 맨뒤에 점을 추가한다.

HRESULT sgObject::IMap2D::DrawingGeometryComplete ( )

현재 화면상에 작도중인 객체의 작도를 완료한다.

HRESULT sgObject::IMap2D::DrawingGeometryGetPoint | ( | [in] int | nIndex,
 |  | [out] double * | x,
 |  | [out] double * | y
 | ) |  |

현재 화면상에 작도중인 객체에 해당 인덱스 위치점의 위치를 반환 한다.

HRESULT sgObject::IMap2D::DrawingGeometryRemovePoint ( [in] int nIndex )

현재 화면상에 작도중인 객체에 해당 인덱스 위치의 점을 삭제한다.

HRESULT sgObject::IMap2D::DrawingGeometrySetPoint | ( | [in] int | nIndex,
 |  | [in] double | x,
 |  | [in] double | y
 | ) |  |

현재 화면상에 작도중인 객체에 해당 인덱스 위치점의 위치를 설정한다.

HRESULT sgObject::IMap2D::DrawingGeometrySize ( )

현재 화면상에 작도중인 객체의 점의 개수를 반환한다.

HRESULT sgObject::IMap2D::ExportImageToWorld | ( | [in] BSTR | pVal,
 |  | long | nNumPixelWidth,
 |  | long | nNumPixelHeight,
 |  | [in] double | dlMinX,
 |  | [in] double | dlMinY,
 |  | [in] double | dlMaxX,
 |  | [in] double | dlMaxY
 | ) |  |

실세계 최대 최소 좌표에 해당하는 화면을 이미지 파일로 내보낸다.

매개변수
pVal | - 생성될 이미지 파일 이름
nNumPixelWidth | - 생성될 이미지의 가로 픽셀수
nNumPixelHeight | - 생성될 이미지의 세로 픽셀수
dlMinX | - 실세계 최소 좌표의 X 값
dlMinY | - 실세계 최소 좌표의 Y 값
dlMaxX | - 실세계 최대 좌표의 X 값
dlMaxY | - 실세계 최대 좌표의 Y 값
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IMap2D::ExportScreenImage | ( | [in] BSTR | strFileName,
 |  | [in] long | nPosX,
 |  | [in] long | nPosY,
 |  | [in] long | nNumPixelWidth,
 |  | [in] long | nNumPixelHeight
 | ) |  |

지도화면 영역을 화면 캡쳐하여 이미지 파일로 내보낸다. 지도 화면 위에 다른 외부 객체가 있는 경우도 함께 내보낸다.

매개변수
strFileName | - 생성될 이미지 파일 이름
nPosX | - 기본값 0(지도화면 시작부분), 0이 아닌 경우 전체 화면을 기준으로 캡쳐하기 위한 시작 X위치
nPosY | - 기본값 0(지도화면 시작부분), 0이 아닌 경우 전체 화면을 기준으로 캡쳐하기 위한 시작 Y위치
nNumPixelWidth | - 기본값 0(지도화면 가로 크기), 캡쳐하기 위한 가로 크기
nNumPixelHeight | - 기본값 0(지도화면 세로 크기), 캡쳐하기 위한 세로 크기
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IMap2D::ExportToClipboard ( [in] VARIANT_BOOL bOriginMap )

화면을 윈도우 클립보드로 내보낸다.

매개변수
bOriginMap - 선택상태 표시가 없는 원본 지도를 내보낼지 여부
HRESULT sgObject::IMap2D::GetAntiAlias ( [out, retval] VARIANT_BOOL * pVal )

지도를 화면에 그릴 때 부드러운 라인, 폴리곤으로 그릴지 여부

HRESULT sgObject::IMap2D::GetAutoScale ( [out, retval] VARIANT_BOOL * pVal )

OpenAPI 레이어가 존재하는 경우 지도 이미지의 픽셀수에 따라 지도 스케일을 자동으로 설정할지 여부

HRESULT sgObject::IMap2D::GetFillBrush ( [out, retval] VARIANT_BOOL * pVal )

폴리곤 객체의 채워 그리기 여부

HRESULT sgObject::IMap2D::GetFlickerSelected ( [out, retval] VARIANT_BOOL * pVal )

객체 선택시 선택된 객체의 깜빡거림 허용 여부

HRESULT sgObject::IMap2D::GetMagnifierPixelSize ( [out, retval] int * pVal )

확대경의 화면 픽셀 크기

HRESULT sgObject::IMap2D::GetMagnifierScale ( [out, retval] float * pVal )

확대경의 확대 배율

HRESULT sgObject::IMap2D::GetMapControlRelativePos | ( | [in] SystemResourceEnum | eCtlType,
 |  | [out] double * | x,
 |  | [out] double * | y
 | ) |  |

시스템 내부 지원 지도 제어 객체의 상대 위치 이동값

HRESULT sgObject::IMap2D::GetMapControlShowType | ( | [in] SystemResourceEnum | eCtlType,
 |  | [out, retval] AlignPositionEnum * | showtype
 | ) |  |

시스템 내부 지원 지도 제어 객체의 상대 위치

HRESULT sgObject::IMap2D::GetMaxXBoundingBox ( [out, retval] double * dlMaxX )
HRESULT sgObject::IMap2D::GetMaxYBoundingBox ( [out, retval] double * dlMaxY )
HRESULT sgObject::IMap2D::GetMaxZoomScaleDenominator ( [out, retval] double * pVal )

지도의 최대 확대 스케일 지정

HRESULT sgObject::IMap2D::GetMeasureLineShowType ( [out, retval] long * showtype )

줄자의 기준 눈금당 보조 눈금의 개수

HRESULT sgObject::IMap2D::GetMeasureLineStd | ( | [out] double * | x,
 |  | [out] double * | y
 | ) |  |

줄자의 기준점

HRESULT sgObject::IMap2D::GetMeasureLineStdLength ( [out, retval] double * length )

줄자의 기준 눈금의 실거리

HRESULT sgObject::IMap2D::GetMeasureLineSubUnitNum | ( | [out] int * | sub1,
 |  | [out] int * | sub2
 | ) |  |

줄자의 기준 눈금당 보조 눈금의 개수

HRESULT sgObject::IMap2D::GetMeasureValue ( [out, retval] double * dValue )

측정 모드의 현재 측정 값 호출

매개변수
value - 측정 값
HRESULT sgObject::IMap2D::GetMinXBoundingBox ( [out, retval] double * dlMinX )

화면의 Frame 사각형이 표시하는 실세계 영역을 가져온다.

참조 : BoundingBox 위 함수를 사용하지 못하는 매크로 언어를 위한 추가 지원 API임

HRESULT sgObject::IMap2D::GetMinYBoundingBox ( [out, retval] double * dlMinY )
HRESULT sgObject::IMap2D::GetMinZoomScaleDenominator ( [out, retval] double * pVal )

지도의 최대 축소 스케일 지정

HRESULT sgObject::IMap2D::GetOverlapLabel ( [out, retval] VARIANT_BOOL * pVal )

레이어별 속성 주석의 겹쳐 그리기 허용 여부

HRESULT sgObject::IMap2D::GetPointOnSurface ( [out, retval] VARIANT_BOOL * pVal )

폴리곤 객체를 선택할 경우 점 뿐 아니라 면을 선택했을 경우도 선택할지의 여부

HRESULT sgObject::IMap2D::GetRatioZoomScale ( [out, retval] double * pVal )

확대 배율

HRESULT sgObject::IMap2D::GetRotate ( [out, retval] short * pVal )

지도의 회전각도

HRESULT sgObject::IMap2D::GetScale | ( | [in] VARIANT_BOOL | bPixcelUnit,
 |  | [out, retval] double * | pVal
 | ) |  |

FeatureCanvas이 Feature를 Map2D로 그리는데 사용된 축척

HRESULT sgObject::IMap2D::GetScaleBarRelativePos | ( | [out] double * | x,
 |  | [out] double * | y
 | ) |  |

스케일바 상대 위치 이동값

HRESULT sgObject::IMap2D::GetScaleBarShowType ( [out, retval] AlignPositionEnum * showtype )

스케일바 상대 위치

HRESULT sgObject::IMap2D::GetScalePrecision ( [out, retval] int * pVal )

스케일 문자 소수점 자리수

HRESULT sgObject::IMap2D::GetScreenMode ( [out, retval] ScreenModeEnum * pVal )

지도에서 사용자가 수행하려하는 동작 모드

HRESULT sgObject::IMap2D::GetSelectMode ( [out, retval] SpatialOperatorEnum * pVal )

지도에서 Feature 객체를 선택할 때 사용하는 객체 선택 방법

HRESULT sgObject::IMap2D::GetSmallPixelSize ( [out, retval] short * pVal )

작은 객체를 표현할 최소 픽셀 크기

HRESULT sgObject::IMap2D::GetSnapGrid ( [out, retval] long * pVal )

지도의 스냅그리드 표현 및 스냅 픽셀 수 설정

HRESULT sgObject::IMap2D::GetSnapMode ( [out, retval] long * pVal )

객체의 입력, 수정 과정에서 공간 객체의 스냅 모드

HRESULT sgObject::IMap2D::GetSyncMoveMode ( [out, retval] long * pVal )

버텍스, 노드를 이동시 같은 좌표점을 가진 객체의 동시 이동 모드 설정

TopoSyncMoveEnum 객체간의 OR 연산로 설정

HRESULT sgObject::IMap2D::GetTransparentBackColor ( [out, retval] VARIANT_BOOL * pVal )

이미지 내보내기시 배경화면을 투명처리할지 여부

HRESULT sgObject::IMap2D::GetUseDrawThread ( [out, retval] VARIANT_BOOL * pVal )

화면에 그림을 그리거나 OpenAPI를 가져오는 과정에서 스레드를 사용할지 여부

HRESULT sgObject::IMap2D::GetVisibleMagnifier ( [out, retval] VARIANT_BOOL * pVal )

확대경 화면에 표시 여부

HRESULT sgObject::IMap2D::GetVisibleSmallGeometry ( [out, retval] VARIANT_BOOL * pVal )

작은 Geometry 객체의 화면에 표시 여부

HRESULT sgObject::IMap2D::GetXDeviceToWorld | ( | [in] double | ix,
 |  | [in] double | iy,
 |  | [out, retval] double * | pdx
 | ) |  |

지도 화면 좌표에 대응되는 실세계 좌표를 가져온다.

참조 : GetDeviceToWorld 위 함수를 사용하지 못하는 매크로 언어를 위한 추가 지원 API임

HRESULT sgObject::IMap2D::GetXWorldToDevice | ( | [in] double | dx,
 |  | [in] double | dy,
 |  | [out, retval] float * | pix
 | ) |  |
HRESULT sgObject::IMap2D::GetYDeviceToWorld | ( | [in] double | ix,
 |  | [in] double | iy,
 |  | [out, retval] double * | pdy
 | ) |  |
HRESULT sgObject::IMap2D::GetYWorldToDevice | ( | [in] double | dx,
 |  | [in] double | dy,
 |  | [out, retval] float * | piy
 | ) |  |
HRESULT sgObject::IMap2D::RasterPixelToWorld | ( | [in] float | ix,
 |  | [in] float | iy,
 |  | [in] IFeature * | pdspFt,
 |  | [out] double * | pdx,
 |  | [out] double * | pdy
 | ) |  |

래스터 이미지의 픽셀 번호에 해당하는 실세계 좌표를 가져온다.

매개변수
ix | - 픽셀번호의 x 값
iy | - 픽셀번호의 y 값
pdspFt | - 래스터 이미지
pdx | - 실세계 좌표의 x 값을 넣을 변수
pdy | - 실세계 좌표의 y 값을 넣을 변수
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IMap2D::SetAntiAlias ( [in] VARIANT_BOOL newVal )
HRESULT sgObject::IMap2D::SetAutoScale ( [in] VARIANT_BOOL newVal )
HRESULT sgObject::IMap2D::SetDrawProgressEnable ( [in] VARIANT_BOOL bEnable )

지도창 내에서 지도가 그려지는 상태바를 표현할지 여부를 설정한다.

HRESULT sgObject::IMap2D::SetFillBrush ( [in] VARIANT_BOOL newVal )
HRESULT sgObject::IMap2D::SetFlickerSelected ( [in] VARIANT_BOOL newVal )
HRESULT sgObject::IMap2D::SetKeyEnable | ( | [in] SystemKeyEnum | type,
 |  | [in] VARIANT_BOOL | bVal
 | ) |  |

지도창 내에서 키보드 및 마우스 버튼의 사용여부를 설정한다.

HRESULT sgObject::IMap2D::SetMagnifierPixelSize ( [in] int newVal )
HRESULT sgObject::IMap2D::SetMagnifierScale ( [in] float newVal )
HRESULT sgObject::IMap2D::SetMapControlImageFromFileName | ( | [in] SystemResourceEnum | eCtlType,
 |  | [in] BSTR | strFileName
 | ) |  |

시스템 내부 지원 지도 제어 객체의 이미지 파일명 설정

HRESULT sgObject::IMap2D::SetMapControlRelativePos | ( | [in] SystemResourceEnum | eCtlType,
 |  | [in] double | x,
 |  | [in] double | y
 | ) |  |
HRESULT sgObject::IMap2D::SetMapControlShowType | ( | [in] SystemResourceEnum | eCtlType,
 |  | [in] AlignPositionEnum | showtype
 | ) |  |
HRESULT sgObject::IMap2D::SetMaxZoomScaleDenominator ( [in] double newVal )
HRESULT sgObject::IMap2D::SetMeasureLineShowType ( [in] long showtype )
HRESULT sgObject::IMap2D::SetMeasureLineStd | ( | [in] double | x,
 |  | [in] double | y
 | ) |  |
HRESULT sgObject::IMap2D::SetMeasureLineStdLength ( [in] double length )
HRESULT sgObject::IMap2D::SetMeasureLineSubUnitNum | ( | [in] int | sub1,
 |  | [in] int | sub2
 | ) |  |
HRESULT sgObject::IMap2D::SetMinZoomScaleDenominator ( [in] double newVal )
HRESULT sgObject::IMap2D::SetMouseButtonEnable | ( | [in] MouseButtonTypeEnum | eType,
 |  | [in] VARIANT_BOOL | bEnable
 | ) |  |

지도창 내에서 마우스 버튼의 사용여부를 설정한다.

HRESULT sgObject::IMap2D::SetMouseCursor | ( | [in] CursorEnum | eCurType,
 |  | [in] BSTR | strFileName,
 |  | [in] int | clrTransparent,
 |  | [in] int | xHotspot,
 |  | [in] int | yHotspot
 | ) |  |

마우스의 커서 모양을 변경한다.

매개변수
eCurType | - 커서의 종류
strFileName | - 읽어드릴 비트맵 커서 파일명
clrTransparent | - 해당 비트맵 파일 중 투명처리할 색상
xHotspot | - 커서의 X 중심점
yHotspot | - 커서의 Y 중심점
HRESULT sgObject::IMap2D::SetOverlapLabel ( [in] VARIANT_BOOL newVal )
HRESULT sgObject::IMap2D::SetPointOnSurface ( [in] VARIANT_BOOL newVal )
HRESULT sgObject::IMap2D::SetRatioZoomScale ( [in] double newVal )
HRESULT sgObject::IMap2D::SetRotate ( [in] short newVal )
HRESULT sgObject::IMap2D::SetScale | ( | [in] double | newVal,
 |  | [in] VARIANT_BOOL | bPixcelUnit
 | ) |  |
HRESULT sgObject::IMap2D::SetScaleBarRelativePos | ( | [in] double | x,
 |  | [in] double | y
 | ) |  |
HRESULT sgObject::IMap2D::SetScaleBarShowType ( [in] AlignPositionEnum showtype )
HRESULT sgObject::IMap2D::SetScaleBarSymbolizer ( [in] ISymbolizer * poStyleTable )

스케일바의 표현 스타일을 지정한다.

HRESULT sgObject::IMap2D::SetScaleBarSymbolizerFromString ( [in] BSTR pszStyleString )
HRESULT sgObject::IMap2D::SetScalePrecision ( [in] int nPrecision )
HRESULT sgObject::IMap2D::SetScreenMode ( [in] ScreenModeEnum newVal )
HRESULT sgObject::IMap2D::SetSelectedSymbolizer ( [in] ISymbolizer * poStyleTable )

선택된 객체에 대해 선택 스타일을 지정한다.

HRESULT sgObject::IMap2D::SetSelectedSymbolizerFromString ( [in] BSTR pszStyleString )
HRESULT sgObject::IMap2D::SetSelectedVertexSymbolizer ( [in] ISymbolizer * poStyleTable )

선택된 객체의 버텍스, 노드의 표현 스타일을 지정한다.

HRESULT sgObject::IMap2D::SetSelectedVertexSymbolizerFromString ( [in] BSTR pszStyleString )
HRESULT sgObject::IMap2D::SetSelectMode ( [in] SpatialOperatorEnum newVal )
HRESULT sgObject::IMap2D::SetSmallPixelSize ( [in] short newVal )
HRESULT sgObject::IMap2D::SetSnapGrid ( [in] long newVal )
HRESULT sgObject::IMap2D::SetSnapMode ( [in] long newVal )
HRESULT sgObject::IMap2D::SetSyncMoveMode ( [in] long newVal )
HRESULT sgObject::IMap2D::SetSystemSymbolizerFromString | ( | [in] SystemSymbolEnum | type,
 |  | [in] BSTR | bstrStyleString
 | ) |  |

시스템내부리소스의 표현 스타일을 지정한다.

HRESULT sgObject::IMap2D::SetTransparentBackColor ( [in] VARIANT_BOOL newVal )
HRESULT sgObject::IMap2D::SetUseDrawThread ( [in] VARIANT_BOOL newVal )
HRESULT sgObject::IMap2D::SetVisibleMagnifier ( [in] VARIANT_BOOL newVal )
HRESULT sgObject::IMap2D::SetVisibleSmallGeometry ( [in] VARIANT_BOOL newVal )
HRESULT sgObject::IMap2D::ShowPrintLayoutWidget | ( | [in] BSTR | strTitle,
 |  | [out, retval] IPrintLayoutWidget ** | dspWidget
 | ) |  |

출력폼 창을 띄운다.

HRESULT sgObject::IMap2D::WorldToDevice | ( | [in] double | dx,
 |  | [in] double | dy,
 |  | [out] float * | pix,
 |  | [out] float * | piy
 | ) |  |

실세계 좌표에 해당하는 지도 화면 좌표를 가져온다.

  • Java의 경우 : 실세계 좌표값을 가져온 변수를 배열로 생성한다. 예) int pix[] = new int[1]; int piy[] = new int[1];
    매개변수
    dx | - 실세계 좌표의 x 값
    dy | - 실세계 좌표의 y 값
    pix | - 지도 화면 좌표의 x 값을 넣을 변수
    piy | - 지도 화면 좌표의 y 값을 넣을 변수
    반환값
    S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IMap2D::WorldToRasterPixel | ( | [in] double | dx,
 |  | [in] double | dy,
 |  | [in] IFeature * | pdspFt,
 |  | [out] float * | pix,
 |  | [out] float * | piy
 | ) |  |

실세계 좌표에 해당하는 래스터 이미지의 픽셀 번호를 가져온다.

매개변수
dx | - 실세계 좌표의 x 값
dy | - 실세계 좌표의 y 값
pdspFt | - 래스터 이미지
pix | - 픽셀번호의 x 값을 넣을 변수
piy | - 픽셀번호의 y 값을 넣을 변수
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IMap2D::ZoomAll ( )

FeatureCanvas의 모든 정보가 표시될 수 있도록 화면 스케일을 조정한다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IMap2D::ZoomCenter | ( | [in] double | dx,
 |  | [in] double | dy
 | ) |  |

화면의 중심을 지정한 좌표로 이동한다.

매개변수
dx | - 새로운 화면 중심의 x 좌표 (실세계 좌표)
dy | - 새로운 화면 중심의 y 좌표 (실세계 좌표)
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IMap2D::ZoomFeature ( IFeature * obj )

해당 Feature가 화면에 가득차게 보여주도록 화면 스케일을 조정한다.

매개변수
obj - 보여줄 Feature 객체를 가리키는 포인터
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IMap2D::ZoomGPS ( [in] double zoomScale )

위치센서로부터 들어오는 위치로 화면의 중심을 이동 조정한다.

매개변수
zoomScale - scale 값
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IMap2D::ZoomIn ( )

화면 스케일을 확대한다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IMap2D::ZoomNext ( )

이전 화면으로 이동된 경우에 바로 전(이후) 화면으로 이동한다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IMap2D::ZoomOut ( )

화면 스케일을 축소한다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IMap2D::ZoomPrevious ( )

바로 이전에 봤던 화면으로 이동한다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IMap2D::ZoomRect | ( | [in] double | dlMinX,
 |  | [in] double | dlMinY,
 |  | [in] double | dlMaxX,
 |  | [in] double | dlMaxY
 | ) |  |

매개변수로 지정한 사각형 영역만 보여주도록 화면 스케일을 조정한다.

매개변수
dlMinX | - 사각형 영역의 최소 X 좌표값 (실세계 좌표)
dlMinY | - 사각형 영역의 최소 Y 좌표값 (실세계 좌표)
dlMaxX | - 사각형 영역의 최대 X 좌표값 (실세계 좌표)
dlMaxY | - 사각형 영역의 최대 Y 좌표값 (실세계 좌표)
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IMap2D::ZoomToFeatureCollection ( [in] IFeatureCollection * pdspFtCol )

해당 FeatureCollection의 영역이 화면에 가득차게 보여주도록 화면 스케일을 조정한다.

매개변수
pdspFtCol - 보여줄 FeatureCollection 객체를 가리키는 포인터
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IMap2D::ZoomToSelectedFeatures ( )

선택된 Feature들을 화면에 가득차게 보여주도록 화면 스케일을 조정한다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IMap2D
sgObject::IMap2D 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IMap2D (모든 상속된 멤버들도 포함합니다.)

AddControl([in] long fid, [in] IUserDefinedWidget *dspUDBox) | sgObject::ICanvas
AnimateSelectedFeatureCollection() | sgObject::IMap2D
BoundingBox([out] double *dlMinX, [out] double *dlMinY, [out] double *dlMaxX, [out] double *dlMaxY) | sgObject::IMap2D
DblClick([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
DeviceToWorld([in] float ix, [in] float iy, [out] double *pdx, [out] double *pdy) | sgObject::IMap2D
DeviceToWorldZ([in] float ix, [in] float iy, [out] DOUBLE *z) | sgObject::IMap2D
DrawingGeometryAddGPSPoint() | sgObject::IMap2D
DrawingGeometryAddPoint([in] double x, [in] double y) | sgObject::IMap2D
DrawingGeometryComplete() | sgObject::IMap2D
DrawingGeometryGetPoint([in] int nIndex, [out] double *x, [out] double *y) | sgObject::IMap2D
DrawingGeometryRemovePoint([in] int nIndex) | sgObject::IMap2D
DrawingGeometrySetPoint([in] int nIndex, [in] double x, [in] double y) | sgObject::IMap2D
DrawingGeometrySize() | sgObject::IMap2D
ExportImage([in]FileFormatEnum nFileType, [in]BSTR pVal) | sgObject::ICanvas
ExportImageToWorld([in]BSTR pVal, long nNumPixelWidth, long nNumPixelHeight, [in] double dlMinX, [in] double dlMinY, [in] double dlMaxX, [in] double dlMaxY) | sgObject::IMap2D
ExportScreenImage([in] BSTR strFileName, [in] long nPosX, [in] long nPosY, [in] long nNumPixelWidth, [in] long nNumPixelHeight) | sgObject::IMap2D
ExportToClipboard([in] VARIANT_BOOL bOriginMap) | sgObject::IMap2D
ForceStopRender() | sgObject::ICanvas
GetAntiAlias([out, retval] VARIANT_BOOL *pVal) | sgObject::IMap2D
GetAutoScale([out, retval] VARIANT_BOOL *pVal) | sgObject::IMap2D
GetBackColor([out, retval] long *pVal) | sgObject::ICanvas
GetCanvasType([out, retval] CanvasTypeEnum *pVal) | sgObject::ICanvas
GetCommonFactory([out, retval] ICommonFactory **pVal) | sgObject::ICanvas
GetFeatureCanvas([out, retval] IFeatureCanvas **pVal) | sgObject::ICanvas
GetFillBrush([out, retval] VARIANT_BOOL *pVal) | sgObject::IMap2D
GetFlickerSelected([out, retval] VARIANT_BOOL *pVal) | sgObject::IMap2D
GetHittestSize([out, retval] int *pVal) | sgObject::ICanvas
GetMagnifierPixelSize([out, retval] int *pVal) | sgObject::IMap2D
GetMagnifierScale([out, retval] float *pVal) | sgObject::IMap2D
GetMapControl([out, retval] long *pVal) | sgObject::ICanvas
GetMapControlRelativePos([in] SystemResourceEnum eCtlType, [out] double *x, [out] double *y) | sgObject::IMap2D
GetMapControlShowType([in] SystemResourceEnum eCtlType, [out, retval] AlignPositionEnum *showtype) | sgObject::IMap2D
GetMapMoveMode([out, retval] MapMoveEnum *pVal) | sgObject::ICanvas
GetMapRotateMode([out, retval] MapRotateEnum *pVal) | sgObject::ICanvas
GetMaxXBoundingBox([out, retval] double *dlMaxX) | sgObject::IMap2D
GetMaxYBoundingBox([out, retval] double *dlMaxY) | sgObject::IMap2D
GetMaxZoomScaleDenominator([out, retval] double *pVal) | sgObject::IMap2D
GetMeasureLineShowType([out, retval] long *showtype) | sgObject::IMap2D
GetMeasureLineStd([out] double *x, [out] double *y) | sgObject::IMap2D
GetMeasureLineStdLength([out, retval] double *length) | sgObject::IMap2D
GetMeasureLineSubUnitNum([out] int *sub1, [out] int *sub2) | sgObject::IMap2D
GetMeasureValue([out, retval] double *dValue) | sgObject::IMap2D
GetMinXBoundingBox([out, retval] double *dlMinX) | sgObject::IMap2D
GetMinYBoundingBox([out, retval] double *dlMinY) | sgObject::IMap2D
GetMinZoomScaleDenominator([out, retval] double *pVal) | sgObject::IMap2D
GetObjectiveSpatialReference([out, retval] ISpatialReference **pVal) | sgObject::ICanvas
GetOverlapLabel([out, retval] VARIANT_BOOL *pVal) | sgObject::IMap2D
GetPointOnSurface([out, retval] VARIANT_BOOL *pVal) | sgObject::IMap2D
GetRatioZoomScale([out, retval] double *pVal) | sgObject::IMap2D
GetRotate([out, retval] short *pVal) | sgObject::IMap2D
GetScale([in] VARIANT_BOOL bPixcelUnit, [out, retval] double *pVal) | sgObject::IMap2D
GetScaleBarRelativePos([out] double *x, [out] double *y) | sgObject::IMap2D
GetScaleBarShowType([out, retval] AlignPositionEnum *showtype) | sgObject::IMap2D
GetScalePrecision([out, retval] int *pVal) | sgObject::IMap2D
GetScreenMode([out, retval] ScreenModeEnum *pVal) | sgObject::IMap2D
GetSelectMode([out, retval] SpatialOperatorEnum *pVal) | sgObject::IMap2D
GetSmallPixelSize([out, retval] short *pVal) | sgObject::IMap2D
GetSnapGrid([out, retval] long *pVal) | sgObject::IMap2D
GetSnapMode([out, retval] long *pVal) | sgObject::IMap2D
GetState([out, retval] int *pVal) | sgObject::ICanvas
GetSyncMoveMode([out, retval] long *pVal) | sgObject::IMap2D
GetTitle([out, retval] BSTR *pVal) | sgObject::ICanvas
GetTransparentBackColor([out, retval] VARIANT_BOOL *pVal) | sgObject::IMap2D
GetUseDrawThread([out, retval] VARIANT_BOOL *pVal) | sgObject::IMap2D
GetVisibleMagnifier([out, retval] VARIANT_BOOL *pVal) | sgObject::IMap2D
GetVisibleSmallGeometry([out, retval] VARIANT_BOOL *pVal) | sgObject::IMap2D
GetXDeviceToWorld([in] double ix, [in] double iy, [out, retval] double *pdx) | sgObject::IMap2D
GetXWorldToDevice([in] double dx, [in] double dy, [out, retval] float *pix) | sgObject::IMap2D
GetYDeviceToWorld([in] double ix, [in] double iy, [out, retval] double *pdy) | sgObject::IMap2D
GetYWorldToDevice([in] double dx, [in] double dy, [out, retval] float *piy) | sgObject::IMap2D
Initialize([in] ULONG_PTR h) | sgObject::ICanvas
Invalidate() | sgObject::ICanvas
KeyDown([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags) | sgObject::ICanvas
KeyUp([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags) | sgObject::ICanvas
LButtonDown([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
LButtonUp([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
MButtonDown([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
MButtonUp([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
MouseMove([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
RasterPixelToWorld([in] float ix, [in] float iy, [in] IFeature *pdspFt, [out] double *pdx, [out] double *pdy) | sgObject::IMap2D
RButtonDown([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
RButtonUp([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
RemoveAllControl() | sgObject::ICanvas
RemoveControl([in] long fid) | sgObject::ICanvas
RemoveSensor([in] ISensor *pdspSensor) | sgObject::ICanvas
ReSize([in] LONG nType, [in] int cx, [in] int cy) | sgObject::ICanvas
SetAntiAlias([in] VARIANT_BOOL newVal) | sgObject::IMap2D
SetAutoScale([in] VARIANT_BOOL newVal) | sgObject::IMap2D
SetBackColor([in] long newVal) | sgObject::ICanvas
SetDrawProgressEnable([in] VARIANT_BOOL bEnable) | sgObject::IMap2D
SetFeatureCanvas([in] IFeatureCanvas *pVal) | sgObject::ICanvas
SetFillBrush([in] VARIANT_BOOL newVal) | sgObject::IMap2D
SetFlickerSelected([in] VARIANT_BOOL newVal) | sgObject::IMap2D
SetHittestSize([in] int newVal) | sgObject::ICanvas
SetKeyEnable([in] SystemKeyEnum type, [in] VARIANT_BOOL bVal) | sgObject::IMap2D
SetLocationSensor([in] ILocationSensor *pdspSensor) | sgObject::ICanvas
SetMagnifierPixelSize([in] int newVal) | sgObject::IMap2D
SetMagnifierScale([in] float newVal) | sgObject::IMap2D
SetMapControl([in] long newVal) | sgObject::ICanvas
SetMapControlImageFromFileName([in] SystemResourceEnum eCtlType, [in] BSTR strFileName) | sgObject::IMap2D
SetMapControlRelativePos([in] SystemResourceEnum eCtlType, [in] double x, [in] double y) | sgObject::IMap2D
SetMapControlShowType([in] SystemResourceEnum eCtlType, [in] AlignPositionEnum showtype) | sgObject::IMap2D
SetMapMoveMode([in] MapMoveEnum type) | sgObject::ICanvas
SetMapRotateMode([in] MapRotateEnum type) | sgObject::ICanvas
SetMaxZoomScaleDenominator([in] double newVal) | sgObject::IMap2D
SetMeasureLineShowType([in] long showtype) | sgObject::IMap2D
SetMeasureLineStd([in] double x, [in] double y) | sgObject::IMap2D
SetMeasureLineStdLength([in] double length) | sgObject::IMap2D
SetMeasureLineSubUnitNum([in] int sub1, [in] int sub2) | sgObject::IMap2D
SetMinZoomScaleDenominator([in] double newVal) | sgObject::IMap2D
SetMotionSensor([in] IMotionSensor *pdspSensor) | sgObject::ICanvas
SetMouseButtonEnable([in] MouseButtonTypeEnum eType, [in] VARIANT_BOOL bEnable) | sgObject::IMap2D
SetMouseCursor([in] CursorEnum eCurType, [in] BSTR strFileName, [in] int clrTransparent, [in] int xHotspot, [in] int yHotspot) | sgObject::IMap2D
SetObjectiveSpatialReference([in] ISpatialReference *pVal) | sgObject::ICanvas
SetOverlapLabel([in] VARIANT_BOOL newVal) | sgObject::IMap2D
SetPointOnSurface([in] VARIANT_BOOL newVal) | sgObject::IMap2D
SetRatioZoomScale([in] double newVal) | sgObject::IMap2D
SetRotate([in] short newVal) | sgObject::IMap2D
SetScale([in] double newVal, [in] VARIANT_BOOL bPixcelUnit) | sgObject::IMap2D
SetScaleBarRelativePos([in] double x, [in] double y) | sgObject::IMap2D
SetScaleBarShowType([in] AlignPositionEnum showtype) | sgObject::IMap2D
SetScaleBarSymbolizer([in] ISymbolizer *poStyleTable) | sgObject::IMap2D
SetScaleBarSymbolizerFromString([in] BSTR pszStyleString) | sgObject::IMap2D
SetScalePrecision([in] int nPrecision) | sgObject::IMap2D
SetScreenMode([in] ScreenModeEnum newVal) | sgObject::IMap2D
SetSelectedSymbolizer([in] ISymbolizer *poStyleTable) | sgObject::IMap2D
SetSelectedSymbolizerFromString([in] BSTR pszStyleString) | sgObject::IMap2D
SetSelectedVertexSymbolizer([in] ISymbolizer *poStyleTable) | sgObject::IMap2D
SetSelectedVertexSymbolizerFromString([in] BSTR pszStyleString) | sgObject::IMap2D
SetSelectMode([in] SpatialOperatorEnum newVal) | sgObject::IMap2D
SetSmallPixelSize([in] short newVal) | sgObject::IMap2D
SetSnapGrid([in] long newVal) | sgObject::IMap2D
SetSnapMode([in] long newVal) | sgObject::IMap2D
SetState([in] int newVal) | sgObject::ICanvas
SetSyncMoveMode([in] long newVal) | sgObject::IMap2D
SetSystemSymbolizerFromString([in] SystemSymbolEnum type, [in] BSTR bstrStyleString) | sgObject::IMap2D
SetTitle([in] BSTR newVal) | sgObject::ICanvas
SetTransparentBackColor([in] VARIANT_BOOL newVal) | sgObject::IMap2D
SetUseDrawThread([in] VARIANT_BOOL newVal) | sgObject::IMap2D
SetVideoSensor([in] IVideoSensor *pdspSensor) | sgObject::ICanvas
SetVisibleMagnifier([in] VARIANT_BOOL newVal) | sgObject::IMap2D
SetVisibleSmallGeometry([in] VARIANT_BOOL newVal) | sgObject::IMap2D
ShowPrintLayoutWidget([in] BSTR strTitle, [out, retval] IPrintLayoutWidget **dspWidget) | sgObject::IMap2D
VisibleMapControl([in] SystemResourceEnum type, [in] VARIANT_BOOL bVisible) | sgObject::ICanvas
WorldToDevice([in] double dx, [in] double dy, [out] float *pix, [out] float *piy) | sgObject::IMap2D
WorldToRasterPixel([in] double dx, [in] double dy, [in] IFeature *pdspFt, [out] float *pix, [out] float *piy) | sgObject::IMap2D
ZoomAll() | sgObject::IMap2D
ZoomCenter([in] double dx, [in] double dy) | sgObject::IMap2D
ZoomFeature(IFeature *obj) | sgObject::IMap2D
ZoomGPS([in] double zoomScale) | sgObject::IMap2D
ZoomIn() | sgObject::IMap2D
ZoomNext() | sgObject::IMap2D
ZoomOut() | sgObject::IMap2D
ZoomPrevious() | sgObject::IMap2D
ZoomRect([in] double dlMinX, [in] double dlMinY, [in] double dlMaxX, [in] double dlMaxY) | sgObject::IMap2D
ZoomToFeatureCollection([in] IFeatureCollection *pdspFtCol) | sgObject::IMap2D
ZoomToSelectedFeatures() | sgObject::IMap2D
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IMap2DControl 인터페이스 참조

  • IMap2DControl
Public 멤버 함수 | 모든 멤버 목록
sgObject::IMap2DControl 인터페이스 참조

Map2D 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다. 더 자세히 ...

sgObject::IMap2DControl에 대한 상속 다이어그램 :
sgObject::IMap2DControl에 대한 협력 다이어그램:

Public 멤버 함수

IMap2D * GetMap2D ()
컨트롤내에 생성된 Map2D 인터페이스 더 자세히 ...
IFeatureCanvas * GetFeatureCanvas ()
컨트롤내에 생성된 FeatureCanvas 인터페이스 더 자세히 ...

상세한 설명

Map2D 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다.

COM+ 인터페이스에만 존재하는 ActiveX 방식의 Map2D 객체

멤버 함수 문서화

IFeatureCanvas* sgObject::IMap2DControl::GetFeatureCanvas ( )

컨트롤내에 생성된 FeatureCanvas 인터페이스

IMap2D* sgObject::IMap2DControl::GetMap2D ( )

컨트롤내에 생성된 Map2D 인터페이스

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IMap2DControl
sgObject::IMap2DControl 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IMap2DControl (모든 상속된 멤버들도 포함합니다.)

GetFeatureCanvas() | sgObject::IMap2DControl
GetMap2D() | sgObject::IMap2DControl
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IMap3D 인터페이스 참조

  • IMap3D
Public 멤버 함수 | 모든 멤버 목록
sgObject::IMap3D 인터페이스 참조

Canvas객체로부터 상속된 Map3D 객체에 대한 인터페이스를 제공한다. 더 자세히 ...

sgObject::IMap3D에 대한 상속 다이어그램 :
sgObject::IMap3D에 대한 협력 다이어그램:

Public 멤버 함수

HRESULT | GetMap3DCamera ([out, retval] IMap3DCamera **pVal)
기본 카메라 객체를 반환한다. 더 자세히 ...
HRESULT | GetMap3DLight ([out, retval] IMap3DLight **pVal)
기본 라이트 객체를 반환한다. 더 자세히 ...
- sgObject::ICanvas(으)로부터 상속된 Public 멤버 함수
HRESULT | GetCommonFactory ([out, retval] ICommonFactory **pVal)
CommonFactory를 가져온다. 더 자세히 ...
HRESULT | GetCanvasType ([out, retval] CanvasTypeEnum *pVal)
지도 (Canvas 객체) 종류를 반환한다. 더 자세히 ...
HRESULT | GetTitle ([out, retval] BSTR *pVal)
지도 (Canvas 객체) 이름 더 자세히 ...
HRESULT | SetTitle ([in] BSTR newVal)
HRESULT | GetState ([out, retval] int *pVal)
화면 (Canvas 객체) 상태 더 자세히 ...
HRESULT | SetState ([in] int newVal)
HRESULT | GetFeatureCanvas ([out, retval] IFeatureCanvas **pVal)
지도에 표현되는 FeatureLayer(공간정보레이어)를 관리하는 FeatureCanvas 정보 더 자세히 ...
HRESULT | SetFeatureCanvas ([in] IFeatureCanvas *pVal)
HRESULT | GetBackColor ([out, retval] long *pVal)
배경색(RGB) 더 자세히 ...
HRESULT | SetBackColor ([in] long newVal)
HRESULT | GetMapControl ([out, retval] long *pVal)
지도에 표시되는 제어창(방위, 스케일바 등) 더 자세히 ...
HRESULT | SetMapControl ([in] long newVal)
HRESULT | VisibleMapControl ([in] SystemResourceEnum type, [in] VARIANT_BOOL bVisible)
지도에 표시할 제어창의 종류를 설정한다. 더 자세히 ...
HRESULT | GetMapMoveMode ([out, retval] MapMoveEnum *pVal)
위치센서 정보 수신에 따른 지도의 자동 이동 여부 더 자세히 ...
HRESULT | SetMapMoveMode ([in] MapMoveEnum type)
HRESULT | GetMapRotateMode ([out, retval] MapRotateEnum *pVal)
위치센서 정보 수신 중 이동에 따른 지도 방향 자동 회전 여부 더 자세히 ...
HRESULT | SetMapRotateMode ([in] MapRotateEnum type)
HRESULT | SetLocationSensor ([in] ILocationSensor *pdspSensor)
지도에서 사용할 위치센서를 지정한다. 더 자세히 ...
HRESULT | SetMotionSensor ([in] IMotionSensor *pdspSensor)
지도에서 사용할 모션센서를 지정한다. 더 자세히 ...
HRESULT | SetVideoSensor ([in] IVideoSensor *pdspSensor)
지도에서 사용할 비디오센서를 지정한다. 더 자세히 ...
HRESULT | RemoveSensor ([in] ISensor *pdspSensor)
지도에서 사용중인 센서를 삭제한다. 더 자세히 ...
HRESULT | GetObjectiveSpatialReference ([out, retval] ISpatialReference **pVal)
지도의 실질 공간 좌표 체계 더 자세히 ...
HRESULT | SetObjectiveSpatialReference ([in] ISpatialReference *pVal)
HRESULT | Initialize ([in] ULONG_PTR h)
지도를 그려야 할 객체의 핸들을 초기화 한다. 더 자세히 ...
HRESULT | Invalidate ()
지도를 다시 그리도록 한다. 더 자세히 ...
HRESULT | ExportImage ([in]FileFormatEnum nFileType, [in]BSTR pVal)
지도화면을 이미지 파일로 내보낸다. 더 자세히 ...
HRESULT | AddControl ([in] long fid, [in] IUserDefinedWidget *dspUDBox)
외부 컨트롤을 지도상에 추가한다. 더 자세히 ...
HRESULT | RemoveControl ([in] long fid)
AddControl에 의해 입력된 외부 컨트롤을 지도상에서 삭제한다. 더 자세히 ...
HRESULT | RemoveAllControl ()
AddControl에 의해 입력된 모든 외부 컨트롤을 지도상에서 삭제한다. 더 자세히 ...
HRESULT | GetHittestSize ([out, retval] int *pVal)
화면에서 객체 선택을 위한 검색 픽셀 범위 더 자세히 ...
HRESULT | SetHittestSize ([in] int newVal)
HRESULT | ForceStopRender ()
화면 렌더링 중지 더 자세히 ...
HRESULT | MouseMove ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 마우스 이동 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | LButtonDown ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 왼쪽 마우스의 버튼을 누른 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | LButtonUp ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 왼쪽 마우스의 눌린 버튼을 놓았다는 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | RButtonDown ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 오른쪽 마우스의 버튼을 누른 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | RButtonUp ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 오른쪽 마우스의 눌린 버튼을 놓았다는 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | DblClick ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 왼쪽 마우스를 더블클릭 했음을 강제로 설정한다. 더 자세히 ...
HRESULT | ReSize ([in] LONG nType, [in] int cx, [in] int cy)
지도의 크기를 조정했음으로 강제로 설정한다. 더 자세히 ...
HRESULT | KeyDown ([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags)
지도에서 특정 키를 눌렀음을 강제로 설정한다. 더 자세히 ...
HRESULT | KeyUp ([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags)
지도에서 특정 키를 떼었음을 강제로 설정한다. 더 자세히 ...
HRESULT | MButtonDown ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 중간 마우스의 버튼을 누른 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | MButtonUp ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 중간 마우스의 눌린 버튼을 놓았다는 정보를 강제로 설정한다. 더 자세히 ...

상세한 설명

Canvas객체로부터 상속된 Map3D 객체에 대한 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "3D"를 덧붙여서 "OGR_3D_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Map3D"

멤버 함수 문서화

HRESULT sgObject::IMap3D::GetMap3DCamera ( [out, retval] IMap3DCamera ** pVal )

기본 카메라 객체를 반환한다.

HRESULT sgObject::IMap3D::GetMap3DLight ( [out, retval] IMap3DLight ** pVal )

기본 라이트 객체를 반환한다.

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IMap3D
sgObject::IMap3D 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IMap3D (모든 상속된 멤버들도 포함합니다.)

AddControl([in] long fid, [in] IUserDefinedWidget *dspUDBox) | sgObject::ICanvas
DblClick([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
ExportImage([in]FileFormatEnum nFileType, [in]BSTR pVal) | sgObject::ICanvas
ForceStopRender() | sgObject::ICanvas
GetBackColor([out, retval] long *pVal) | sgObject::ICanvas
GetCanvasType([out, retval] CanvasTypeEnum *pVal) | sgObject::ICanvas
GetCommonFactory([out, retval] ICommonFactory **pVal) | sgObject::ICanvas
GetFeatureCanvas([out, retval] IFeatureCanvas **pVal) | sgObject::ICanvas
GetHittestSize([out, retval] int *pVal) | sgObject::ICanvas
GetMap3DCamera([out, retval] IMap3DCamera **pVal) | sgObject::IMap3D
GetMap3DLight([out, retval] IMap3DLight **pVal) | sgObject::IMap3D
GetMapControl([out, retval] long *pVal) | sgObject::ICanvas
GetMapMoveMode([out, retval] MapMoveEnum *pVal) | sgObject::ICanvas
GetMapRotateMode([out, retval] MapRotateEnum *pVal) | sgObject::ICanvas
GetObjectiveSpatialReference([out, retval] ISpatialReference **pVal) | sgObject::ICanvas
GetState([out, retval] int *pVal) | sgObject::ICanvas
GetTitle([out, retval] BSTR *pVal) | sgObject::ICanvas
Initialize([in] ULONG_PTR h) | sgObject::ICanvas
Invalidate() | sgObject::ICanvas
KeyDown([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags) | sgObject::ICanvas
KeyUp([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags) | sgObject::ICanvas
LButtonDown([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
LButtonUp([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
MButtonDown([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
MButtonUp([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
MouseMove([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
RButtonDown([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
RButtonUp([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
RemoveAllControl() | sgObject::ICanvas
RemoveControl([in] long fid) | sgObject::ICanvas
RemoveSensor([in] ISensor *pdspSensor) | sgObject::ICanvas
ReSize([in] LONG nType, [in] int cx, [in] int cy) | sgObject::ICanvas
SetBackColor([in] long newVal) | sgObject::ICanvas
SetFeatureCanvas([in] IFeatureCanvas *pVal) | sgObject::ICanvas
SetHittestSize([in] int newVal) | sgObject::ICanvas
SetLocationSensor([in] ILocationSensor *pdspSensor) | sgObject::ICanvas
SetMapControl([in] long newVal) | sgObject::ICanvas
SetMapMoveMode([in] MapMoveEnum type) | sgObject::ICanvas
SetMapRotateMode([in] MapRotateEnum type) | sgObject::ICanvas
SetMotionSensor([in] IMotionSensor *pdspSensor) | sgObject::ICanvas
SetObjectiveSpatialReference([in] ISpatialReference *pVal) | sgObject::ICanvas
SetState([in] int newVal) | sgObject::ICanvas
SetTitle([in] BSTR newVal) | sgObject::ICanvas
SetVideoSensor([in] IVideoSensor *pdspSensor) | sgObject::ICanvas
VisibleMapControl([in] SystemResourceEnum type, [in] VARIANT_BOOL bVisible) | sgObject::ICanvas
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IMap3DCamera 인터페이스 참조

  • IMap3DCamera
Public 멤버 함수 | 모든 멤버 목록
sgObject::IMap3DCamera 인터페이스 참조

3D 지도의 카메라를 제어하기 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::IMap3DCamera에 대한 상속 다이어그램 :
sgObject::IMap3DCamera에 대한 협력 다이어그램:

Public 멤버 함수

void | SetViewpoint ([in]double x_or_lon, [in]double y_or_lat, [in]double z, [in]double heading_deg, [in]double pitch_deg, [in]double range, [in] double duration_s)
카메라의 뷰포트를 설정한다. 더 자세히 ...
void | GetViewpoint ([out] double *x_or_lon, [out] double *y_or_lat, [out] double *z, [out] double *heading_deg, [out] double *pitch_deg, [out] double *range)
카메라의 현재 뷰포트를 설정한다. 더 자세히 ...
void | ZoomIn ()
화면을 확대한다. 더 자세히 ...
void | ZoomOut ()
화면을 축소한다. 더 자세히 ...
void | ZoomAll ()
전체 화면으로 이동한다. 더 자세히 ...
void | SetDefaultViewpoint ([in] double x_or_lon, [in] double y_or_lat, [in] double z, [in] double heading_deg, [in] double pitch_deg, [in] double range)
카메라의 기본 뷰포트를 설정한다. 더 자세히 ...
void | GetDefaultViewpoint ([out] double *x_or_lon, [out] double *y_or_lat, [out] double *z, [out] double *heading_deg, [out] double *pitch_deg, [out] double *range)
void | SetMinMaxPitch ([in] int min, [in] int max)
카메라의 수평각 최대/최소값 더 자세히 ...
void | GetMinMaxPitch ([out] int *min, [out] int *max)

상세한 설명

3D 지도의 카메라를 제어하기 위한 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "3DC"를 덧붙여서 "OGR_3DC_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Map3DCamera"

멤버 함수 문서화

void sgObject::IMap3DCamera::GetDefaultViewpoint | ( | [out] double * | x_or_lon,
 |  | [out] double * | y_or_lat,
 |  | [out] double * | z,
 |  | [out] double * | heading_deg,
 |  | [out] double * | pitch_deg,
 |  | [out] double * | range
 | ) |  |
void sgObject::IMap3DCamera::GetMinMaxPitch | ( | [out] int * | min,
 |  | [out] int * | max
 | ) |  |
void sgObject::IMap3DCamera::GetViewpoint | ( | [out] double * | x_or_lon,
 |  | [out] double * | y_or_lat,
 |  | [out] double * | z,
 |  | [out] double * | heading_deg,
 |  | [out] double * | pitch_deg,
 |  | [out] double * | range
 | ) |  |

카메라의 현재 뷰포트를 설정한다.

매개변수
x_or_lon | - 목표 위치 x좌표(경도)
y_or_lat | - 목표 위치 y좌표(위도)
z | - 목표 위치 z좌표(고도-미터)
heading_deg | - 목표 지점을 바라보는 정북기준 각도
pitch_deg | - 목표 지점을 바라보는 수평 각도
range | - 목표 지점으로부터의 카메라까지 거리
void sgObject::IMap3DCamera::SetDefaultViewpoint | ( | [in] double | x_or_lon,
 |  | [in] double | y_or_lat,
 |  | [in] double | z,
 |  | [in] double | heading_deg,
 |  | [in] double | pitch_deg,
 |  | [in] double | range
 | ) |  |

카메라의 기본 뷰포트를 설정한다.

매개변수
x_or_lon | - 목표 위치 x좌표(경도)
y_or_lat | - 목표 위치 y좌표(위도)
z | - 목표 위치 z좌표(고도-미터)
heading_deg | - 목표 지점을 바라보는 정북기준 각도
pitch_deg | - 목표 지점을 바라보는 수평 각도
range | - 목표 지점으로부터의 카메라까지 거리
void sgObject::IMap3DCamera::SetMinMaxPitch | ( | [in] int | min,
 |  | [in] int | max
 | ) |  |

카메라의 수평각 최대/최소값

매개변수
min | - 최소각
max | - 최대각
void sgObject::IMap3DCamera::SetViewpoint | ( | [in] double | x_or_lon,
 |  | [in] double | y_or_lat,
 |  | [in] double | z,
 |  | [in] double | heading_deg,
 |  | [in] double | pitch_deg,
 |  | [in] double | range,
 |  | [in] double | duration_s
 | ) |  |

카메라의 뷰포트를 설정한다.

매개변수
x_or_lon | - 목표 위치 x좌표(경도)
y_or_lat | - 목표 위치 y좌표(위도)
z | - 목표 위치 z좌표(고도-미터)
heading_deg | - 목표 지점을 바라보는 정북기준 각도
pitch_deg | - 목표 지점을 바라보는 수평 각도
range | - 목표 지점으로부터의 카메라까지 거리
duration_s | - 목표 지점으로 카메라가 이동하는데 걸리는 시간
void sgObject::IMap3DCamera::ZoomAll ( )

전체 화면으로 이동한다.

void sgObject::IMap3DCamera::ZoomIn ( )

화면을 확대한다.

void sgObject::IMap3DCamera::ZoomOut ( )

화면을 축소한다.

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IMap3DCamera
sgObject::IMap3DCamera 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IMap3DCamera (모든 상속된 멤버들도 포함합니다.)

GetDefaultViewpoint([out] double *x_or_lon, [out] double *y_or_lat, [out] double *z, [out] double *heading_deg, [out] double *pitch_deg, [out] double *range) | sgObject::IMap3DCamera
GetMinMaxPitch([out] int *min, [out] int *max) | sgObject::IMap3DCamera
GetViewpoint([out] double *x_or_lon, [out] double *y_or_lat, [out] double *z, [out] double *heading_deg, [out] double *pitch_deg, [out] double *range) | sgObject::IMap3DCamera
SetDefaultViewpoint([in] double x_or_lon, [in] double y_or_lat, [in] double z, [in] double heading_deg, [in] double pitch_deg, [in] double range) | sgObject::IMap3DCamera
SetMinMaxPitch([in] int min, [in] int max) | sgObject::IMap3DCamera
SetViewpoint([in]double x_or_lon, [in]double y_or_lat, [in]double z, [in]double heading_deg, [in]double pitch_deg, [in]double range, [in] double duration_s) | sgObject::IMap3DCamera
ZoomAll() | sgObject::IMap3DCamera
ZoomIn() | sgObject::IMap3DCamera
ZoomOut() | sgObject::IMap3DCamera
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IMap3DControl 인터페이스 참조

  • IMap3DControl
Public 멤버 함수 | 모든 멤버 목록
sgObject::IMap3DControl 인터페이스 참조

Map3D 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다. 더 자세히 ...

sgObject::IMap3DControl에 대한 상속 다이어그램 :
sgObject::IMap3DControl에 대한 협력 다이어그램:

Public 멤버 함수

IMap3D * GetMap3D ()
컨트롤내에 생성된 Map3D 인터페이스 더 자세히 ...
IFeatureCanvas * GetFeatureCanvas ()
컨트롤내에 생성된 FeatureCanvas 인터페이스 더 자세히 ...

상세한 설명

Map3D 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다.

COM+ 인터페이스에만 존재하는 ActiveX 방식의 Map3D 객체

멤버 함수 문서화

IFeatureCanvas* sgObject::IMap3DControl::GetFeatureCanvas ( )

컨트롤내에 생성된 FeatureCanvas 인터페이스

IMap3D* sgObject::IMap3DControl::GetMap3D ( )

컨트롤내에 생성된 Map3D 인터페이스

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IMap3DControl
sgObject::IMap3DControl 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IMap3DControl (모든 상속된 멤버들도 포함합니다.)

GetFeatureCanvas() | sgObject::IMap3DControl
GetMap3D() | sgObject::IMap3DControl
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IMap3DLight 인터페이스 참조

  • IMap3DLight
sgObject::IMap3DLight 인터페이스 참조

3D 지도의 채광을 제어하기 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::IMap3DLight에 대한 상속 다이어그램 :
sgObject::IMap3DLight에 대한 협력 다이어그램:

상세한 설명

3D 지도의 채광을 제어하기 위한 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "3DL"를 덧붙여서 "OGR_3DL_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Map3DLight"

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IMapAR 인터페이스 참조

  • IMapAR
Public 멤버 함수 | 모든 멤버 목록
sgObject::IMapAR 인터페이스 참조

Canvas객체로부터 상속받은 MapAR 객체에 대한 인터페이스를 제공한다. 더 자세히 ...

sgObject::IMapAR에 대한 상속 다이어그램 :
sgObject::IMapAR에 대한 협력 다이어그램:

Public 멤버 함수

HRESULT | GetMap3DCamera ([out, retval] IMap3DCamera **pVal)
HRESULT | GetMap3DLight ([out, retval] IMap3DLight **pVal)
- sgObject::ICanvas(으)로부터 상속된 Public 멤버 함수
HRESULT | GetCommonFactory ([out, retval] ICommonFactory **pVal)
CommonFactory를 가져온다. 더 자세히 ...
HRESULT | GetCanvasType ([out, retval] CanvasTypeEnum *pVal)
지도 (Canvas 객체) 종류를 반환한다. 더 자세히 ...
HRESULT | GetTitle ([out, retval] BSTR *pVal)
지도 (Canvas 객체) 이름 더 자세히 ...
HRESULT | SetTitle ([in] BSTR newVal)
HRESULT | GetState ([out, retval] int *pVal)
화면 (Canvas 객체) 상태 더 자세히 ...
HRESULT | SetState ([in] int newVal)
HRESULT | GetFeatureCanvas ([out, retval] IFeatureCanvas **pVal)
지도에 표현되는 FeatureLayer(공간정보레이어)를 관리하는 FeatureCanvas 정보 더 자세히 ...
HRESULT | SetFeatureCanvas ([in] IFeatureCanvas *pVal)
HRESULT | GetBackColor ([out, retval] long *pVal)
배경색(RGB) 더 자세히 ...
HRESULT | SetBackColor ([in] long newVal)
HRESULT | GetMapControl ([out, retval] long *pVal)
지도에 표시되는 제어창(방위, 스케일바 등) 더 자세히 ...
HRESULT | SetMapControl ([in] long newVal)
HRESULT | VisibleMapControl ([in] SystemResourceEnum type, [in] VARIANT_BOOL bVisible)
지도에 표시할 제어창의 종류를 설정한다. 더 자세히 ...
HRESULT | GetMapMoveMode ([out, retval] MapMoveEnum *pVal)
위치센서 정보 수신에 따른 지도의 자동 이동 여부 더 자세히 ...
HRESULT | SetMapMoveMode ([in] MapMoveEnum type)
HRESULT | GetMapRotateMode ([out, retval] MapRotateEnum *pVal)
위치센서 정보 수신 중 이동에 따른 지도 방향 자동 회전 여부 더 자세히 ...
HRESULT | SetMapRotateMode ([in] MapRotateEnum type)
HRESULT | SetLocationSensor ([in] ILocationSensor *pdspSensor)
지도에서 사용할 위치센서를 지정한다. 더 자세히 ...
HRESULT | SetMotionSensor ([in] IMotionSensor *pdspSensor)
지도에서 사용할 모션센서를 지정한다. 더 자세히 ...
HRESULT | SetVideoSensor ([in] IVideoSensor *pdspSensor)
지도에서 사용할 비디오센서를 지정한다. 더 자세히 ...
HRESULT | RemoveSensor ([in] ISensor *pdspSensor)
지도에서 사용중인 센서를 삭제한다. 더 자세히 ...
HRESULT | GetObjectiveSpatialReference ([out, retval] ISpatialReference **pVal)
지도의 실질 공간 좌표 체계 더 자세히 ...
HRESULT | SetObjectiveSpatialReference ([in] ISpatialReference *pVal)
HRESULT | Initialize ([in] ULONG_PTR h)
지도를 그려야 할 객체의 핸들을 초기화 한다. 더 자세히 ...
HRESULT | Invalidate ()
지도를 다시 그리도록 한다. 더 자세히 ...
HRESULT | ExportImage ([in]FileFormatEnum nFileType, [in]BSTR pVal)
지도화면을 이미지 파일로 내보낸다. 더 자세히 ...
HRESULT | AddControl ([in] long fid, [in] IUserDefinedWidget *dspUDBox)
외부 컨트롤을 지도상에 추가한다. 더 자세히 ...
HRESULT | RemoveControl ([in] long fid)
AddControl에 의해 입력된 외부 컨트롤을 지도상에서 삭제한다. 더 자세히 ...
HRESULT | RemoveAllControl ()
AddControl에 의해 입력된 모든 외부 컨트롤을 지도상에서 삭제한다. 더 자세히 ...
HRESULT | GetHittestSize ([out, retval] int *pVal)
화면에서 객체 선택을 위한 검색 픽셀 범위 더 자세히 ...
HRESULT | SetHittestSize ([in] int newVal)
HRESULT | ForceStopRender ()
화면 렌더링 중지 더 자세히 ...
HRESULT | MouseMove ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 마우스 이동 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | LButtonDown ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 왼쪽 마우스의 버튼을 누른 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | LButtonUp ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 왼쪽 마우스의 눌린 버튼을 놓았다는 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | RButtonDown ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 오른쪽 마우스의 버튼을 누른 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | RButtonUp ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 오른쪽 마우스의 눌린 버튼을 놓았다는 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | DblClick ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 왼쪽 마우스를 더블클릭 했음을 강제로 설정한다. 더 자세히 ...
HRESULT | ReSize ([in] LONG nType, [in] int cx, [in] int cy)
지도의 크기를 조정했음으로 강제로 설정한다. 더 자세히 ...
HRESULT | KeyDown ([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags)
지도에서 특정 키를 눌렀음을 강제로 설정한다. 더 자세히 ...
HRESULT | KeyUp ([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags)
지도에서 특정 키를 떼었음을 강제로 설정한다. 더 자세히 ...
HRESULT | MButtonDown ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 중간 마우스의 버튼을 누른 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | MButtonUp ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 중간 마우스의 눌린 버튼을 놓았다는 정보를 강제로 설정한다. 더 자세히 ...

상세한 설명

Canvas객체로부터 상속받은 MapAR 객체에 대한 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "3D"를 덧붙여서 "OGR_3D_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.MapAR"

멤버 함수 문서화

HRESULT sgObject::IMapAR::GetMap3DCamera ( [out, retval] IMap3DCamera ** pVal )
HRESULT sgObject::IMapAR::GetMap3DLight ( [out, retval] IMap3DLight ** pVal )
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IMapAR
sgObject::IMapAR 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IMapAR (모든 상속된 멤버들도 포함합니다.)

AddControl([in] long fid, [in] IUserDefinedWidget *dspUDBox) | sgObject::ICanvas
DblClick([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
ExportImage([in]FileFormatEnum nFileType, [in]BSTR pVal) | sgObject::ICanvas
ForceStopRender() | sgObject::ICanvas
GetBackColor([out, retval] long *pVal) | sgObject::ICanvas
GetCanvasType([out, retval] CanvasTypeEnum *pVal) | sgObject::ICanvas
GetCommonFactory([out, retval] ICommonFactory **pVal) | sgObject::ICanvas
GetFeatureCanvas([out, retval] IFeatureCanvas **pVal) | sgObject::ICanvas
GetHittestSize([out, retval] int *pVal) | sgObject::ICanvas
GetMap3DCamera([out, retval] IMap3DCamera **pVal) | sgObject::IMapAR
GetMap3DLight([out, retval] IMap3DLight **pVal) | sgObject::IMapAR
GetMapControl([out, retval] long *pVal) | sgObject::ICanvas
GetMapMoveMode([out, retval] MapMoveEnum *pVal) | sgObject::ICanvas
GetMapRotateMode([out, retval] MapRotateEnum *pVal) | sgObject::ICanvas
GetObjectiveSpatialReference([out, retval] ISpatialReference **pVal) | sgObject::ICanvas
GetState([out, retval] int *pVal) | sgObject::ICanvas
GetTitle([out, retval] BSTR *pVal) | sgObject::ICanvas
Initialize([in] ULONG_PTR h) | sgObject::ICanvas
Invalidate() | sgObject::ICanvas
KeyDown([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags) | sgObject::ICanvas
KeyUp([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags) | sgObject::ICanvas
LButtonDown([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
LButtonUp([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
MButtonDown([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
MButtonUp([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
MouseMove([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
RButtonDown([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
RButtonUp([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
RemoveAllControl() | sgObject::ICanvas
RemoveControl([in] long fid) | sgObject::ICanvas
RemoveSensor([in] ISensor *pdspSensor) | sgObject::ICanvas
ReSize([in] LONG nType, [in] int cx, [in] int cy) | sgObject::ICanvas
SetBackColor([in] long newVal) | sgObject::ICanvas
SetFeatureCanvas([in] IFeatureCanvas *pVal) | sgObject::ICanvas
SetHittestSize([in] int newVal) | sgObject::ICanvas
SetLocationSensor([in] ILocationSensor *pdspSensor) | sgObject::ICanvas
SetMapControl([in] long newVal) | sgObject::ICanvas
SetMapMoveMode([in] MapMoveEnum type) | sgObject::ICanvas
SetMapRotateMode([in] MapRotateEnum type) | sgObject::ICanvas
SetMotionSensor([in] IMotionSensor *pdspSensor) | sgObject::ICanvas
SetObjectiveSpatialReference([in] ISpatialReference *pVal) | sgObject::ICanvas
SetState([in] int newVal) | sgObject::ICanvas
SetTitle([in] BSTR newVal) | sgObject::ICanvas
SetVideoSensor([in] IVideoSensor *pdspSensor) | sgObject::ICanvas
VisibleMapControl([in] SystemResourceEnum type, [in] VARIANT_BOOL bVisible) | sgObject::ICanvas
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IMapARControl 인터페이스 참조

  • IMapARControl
Public 멤버 함수 | 모든 멤버 목록
sgObject::IMapARControl 인터페이스 참조

MapAR 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다. 더 자세히 ...

sgObject::IMapARControl에 대한 상속 다이어그램 :
sgObject::IMapARControl에 대한 협력 다이어그램:

Public 멤버 함수

IMapAR * GetMapAR ()
컨트롤내에 생성된 MapAR 인터페이스 더 자세히 ...
IFeatureCanvas * GetFeatureCanvas ()
컨트롤내에 생성된 FeatureCanvas 인터페이스 더 자세히 ...

상세한 설명

MapAR 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다.

COM+ 인터페이스에만 존재하는 ActiveX 방식의 MapAR 객체

멤버 함수 문서화

IFeatureCanvas* sgObject::IMapARControl::GetFeatureCanvas ( )

컨트롤내에 생성된 FeatureCanvas 인터페이스

IMapAR* sgObject::IMapARControl::GetMapAR ( )

컨트롤내에 생성된 MapAR 인터페이스

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IMapARControl
sgObject::IMapARControl 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IMapARControl (모든 상속된 멤버들도 포함합니다.)

GetFeatureCanvas() | sgObject::IMapARControl
GetMapAR() | sgObject::IMapARControl
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IMapEarth 인터페이스 참조

  • IMapEarth
Public 멤버 함수 | 모든 멤버 목록
sgObject::IMapEarth 인터페이스 참조

Canvas객체로부터 상속받은 MapEarth 객체에 대한 인터페이스를 제공한다. 더 자세히 ...

sgObject::IMapEarth에 대한 상속 다이어그램 :
sgObject::IMapEarth에 대한 협력 다이어그램:

Public 멤버 함수

HRESULT | GetMap3DCamera ([out, retval] IMap3DCamera **pVal)
기본 카메라 객체를 반환한다. 더 자세히 ...
HRESULT | GetMap3DLight ([out, retval] IMap3DLight **pVal)
기본 라이트 객체를 반환한다. 더 자세히 ...
HRESULT | GetScreenMode ([out, retval] ScreenModeEnum *pVal)
지도에서 사용자가 수행하려하는 동작 모드 더 자세히 ...
HRESULT | SetScreenMode ([in] ScreenModeEnum newVal)
HRESULT | GetSightMode ([out, retval] SightModeEnum *pVal)
가시권 분석 종류 모드 더 자세히 ...
HRESULT | SetSightMode ([in] SightModeEnum newVal)
HRESULT | SetShadowEnable ([in] VARIANT_BOOL bEnable, [in] VARIANT_BOOL bPersp, [in] VARIANT_BOOL bParallel, [in] float ambientBrightness)
그림자 효과를 설정한다. 더 자세히 ...
HRESULT | GetShadowEnable ([out] VARIANT_BOOL *bEnable, [out] VARIANT_BOOL *bPersp, [out] VARIANT_BOOL *bParallel, [out] float *ambientBrightness)
HRESULT | SetSkyDateTime ([in] VARIANT_BOOL bEnable, [in] int year, [in] int month, [in] int day, [in] int hour)
태양광 효과를 설정한다. 더 자세히 ...
HRESULT | GetSkyDateTime ([out] VARIANT_BOOL *bEnable, [out] int *year, [out] int *month, [out] int *day, [out] int *hour)
HRESULT | SetOceanEnable ([in] VARIANT_BOOL bEnable, [in] BSTR strOptions)
해양(물) 효과를 설정한다. 해당 효과는 이미지레이어의 마스크레이어가 설정된 경우에만 적용된다. 더 자세히 ...
HRESULT | GetOceanEnable ([in] VARIANT_BOOL *bEnable)
HRESULT | ZoomToFeatureCollection ([in] IFeatureCollection *pdspFtCol)
해당 FeatureCollection의 영역이 화면에 가득차게 보여주도록 카메라 스케일을 조정한다. 더 자세히 ...
HRESULT | CreateViewshed ([in]SightModeEnum eType, [in]double sx, [in]double sy, [in]double sz, [in]double ex, [in]double ey, [in]double ez, [out, retval] VARIANT_BOOL *bResult)
모드에 해당하는 가시권 분석 객체를 생성한다. 더 자세히 ...
HRESULT | SetViewshedParam ([in]SightModeEnum eType, [in]double radius, [in]int numSpokes, [in]VARIANT_BOOL fill, [in]double startAzim, [in]double endAzim, [in]double startElev, [in]double endElev, [in]double spacing)
모드에 해당하는 가시권 분석 객체를 생성한다. 더 자세히 ...
HRESULT | SetViewshedColor ([in]SightModeEnum eType, [in]long goodColor, [in]long badColor, [in]long outlineColor)
모드에 해당하는 가시권 분석 객체를 생성한다. 더 자세히 ...
HRESULT | ClearViewshed ()
생성된 가시권 분석 객체를 반납한다. 더 자세히 ...
- sgObject::ICanvas(으)로부터 상속된 Public 멤버 함수
HRESULT | GetCommonFactory ([out, retval] ICommonFactory **pVal)
CommonFactory를 가져온다. 더 자세히 ...
HRESULT | GetCanvasType ([out, retval] CanvasTypeEnum *pVal)
지도 (Canvas 객체) 종류를 반환한다. 더 자세히 ...
HRESULT | GetTitle ([out, retval] BSTR *pVal)
지도 (Canvas 객체) 이름 더 자세히 ...
HRESULT | SetTitle ([in] BSTR newVal)
HRESULT | GetState ([out, retval] int *pVal)
화면 (Canvas 객체) 상태 더 자세히 ...
HRESULT | SetState ([in] int newVal)
HRESULT | GetFeatureCanvas ([out, retval] IFeatureCanvas **pVal)
지도에 표현되는 FeatureLayer(공간정보레이어)를 관리하는 FeatureCanvas 정보 더 자세히 ...
HRESULT | SetFeatureCanvas ([in] IFeatureCanvas *pVal)
HRESULT | GetBackColor ([out, retval] long *pVal)
배경색(RGB) 더 자세히 ...
HRESULT | SetBackColor ([in] long newVal)
HRESULT | GetMapControl ([out, retval] long *pVal)
지도에 표시되는 제어창(방위, 스케일바 등) 더 자세히 ...
HRESULT | SetMapControl ([in] long newVal)
HRESULT | VisibleMapControl ([in] SystemResourceEnum type, [in] VARIANT_BOOL bVisible)
지도에 표시할 제어창의 종류를 설정한다. 더 자세히 ...
HRESULT | GetMapMoveMode ([out, retval] MapMoveEnum *pVal)
위치센서 정보 수신에 따른 지도의 자동 이동 여부 더 자세히 ...
HRESULT | SetMapMoveMode ([in] MapMoveEnum type)
HRESULT | GetMapRotateMode ([out, retval] MapRotateEnum *pVal)
위치센서 정보 수신 중 이동에 따른 지도 방향 자동 회전 여부 더 자세히 ...
HRESULT | SetMapRotateMode ([in] MapRotateEnum type)
HRESULT | SetLocationSensor ([in] ILocationSensor *pdspSensor)
지도에서 사용할 위치센서를 지정한다. 더 자세히 ...
HRESULT | SetMotionSensor ([in] IMotionSensor *pdspSensor)
지도에서 사용할 모션센서를 지정한다. 더 자세히 ...
HRESULT | SetVideoSensor ([in] IVideoSensor *pdspSensor)
지도에서 사용할 비디오센서를 지정한다. 더 자세히 ...
HRESULT | RemoveSensor ([in] ISensor *pdspSensor)
지도에서 사용중인 센서를 삭제한다. 더 자세히 ...
HRESULT | GetObjectiveSpatialReference ([out, retval] ISpatialReference **pVal)
지도의 실질 공간 좌표 체계 더 자세히 ...
HRESULT | SetObjectiveSpatialReference ([in] ISpatialReference *pVal)
HRESULT | Initialize ([in] ULONG_PTR h)
지도를 그려야 할 객체의 핸들을 초기화 한다. 더 자세히 ...
HRESULT | Invalidate ()
지도를 다시 그리도록 한다. 더 자세히 ...
HRESULT | ExportImage ([in]FileFormatEnum nFileType, [in]BSTR pVal)
지도화면을 이미지 파일로 내보낸다. 더 자세히 ...
HRESULT | AddControl ([in] long fid, [in] IUserDefinedWidget *dspUDBox)
외부 컨트롤을 지도상에 추가한다. 더 자세히 ...
HRESULT | RemoveControl ([in] long fid)
AddControl에 의해 입력된 외부 컨트롤을 지도상에서 삭제한다. 더 자세히 ...
HRESULT | RemoveAllControl ()
AddControl에 의해 입력된 모든 외부 컨트롤을 지도상에서 삭제한다. 더 자세히 ...
HRESULT | GetHittestSize ([out, retval] int *pVal)
화면에서 객체 선택을 위한 검색 픽셀 범위 더 자세히 ...
HRESULT | SetHittestSize ([in] int newVal)
HRESULT | ForceStopRender ()
화면 렌더링 중지 더 자세히 ...
HRESULT | MouseMove ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 마우스 이동 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | LButtonDown ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 왼쪽 마우스의 버튼을 누른 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | LButtonUp ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 왼쪽 마우스의 눌린 버튼을 놓았다는 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | RButtonDown ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 오른쪽 마우스의 버튼을 누른 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | RButtonUp ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 오른쪽 마우스의 눌린 버튼을 놓았다는 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | DblClick ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 왼쪽 마우스를 더블클릭 했음을 강제로 설정한다. 더 자세히 ...
HRESULT | ReSize ([in] LONG nType, [in] int cx, [in] int cy)
지도의 크기를 조정했음으로 강제로 설정한다. 더 자세히 ...
HRESULT | KeyDown ([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags)
지도에서 특정 키를 눌렀음을 강제로 설정한다. 더 자세히 ...
HRESULT | KeyUp ([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags)
지도에서 특정 키를 떼었음을 강제로 설정한다. 더 자세히 ...
HRESULT | MButtonDown ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 중간 마우스의 버튼을 누른 정보를 강제로 설정한다. 더 자세히 ...
HRESULT | MButtonUp ([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner)
지도에 중간 마우스의 눌린 버튼을 놓았다는 정보를 강제로 설정한다. 더 자세히 ...

상세한 설명

Canvas객체로부터 상속받은 MapEarth 객체에 대한 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "3D"를 덧붙여서 "OGR_3D_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.MapEarth"

멤버 함수 문서화

HRESULT sgObject::IMapEarth::ClearViewshed ( )

생성된 가시권 분석 객체를 반납한다.

반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IMapEarth::CreateViewshed | ( | [in] SightModeEnum | eType,
 |  | [in] double | sx,
 |  | [in] double | sy,
 |  | [in] double | sz,
 |  | [in] double | ex,
 |  | [in] double | ey,
 |  | [in] double | ez,
 |  | [out, retval] VARIANT_BOOL * | bResult
 | ) |  |

모드에 해당하는 가시권 분석 객체를 생성한다.

매개변수
eType | - 가시권 분석 종류 모드
sx | - 시작 위치 x 좌표(경도)
sy | - 시작 위치 y 좌표(위도)
sz | - 시작 위치 z 좌표(고도-미터)
ex | - 목표 위치 x 좌표(경도)
ey | - 목표 위치 y 좌표(위도)
ez | - 목표 위치 z 좌표(고도-미터)
bResult | - 가시권 분석 객체 생성 여부 반환
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IMapEarth::GetMap3DCamera ( [out, retval] IMap3DCamera ** pVal )

기본 카메라 객체를 반환한다.

HRESULT sgObject::IMapEarth::GetMap3DLight ( [out, retval] IMap3DLight ** pVal )

기본 라이트 객체를 반환한다.

HRESULT sgObject::IMapEarth::GetOceanEnable ( [in] VARIANT_BOOL * bEnable )
HRESULT sgObject::IMapEarth::GetScreenMode ( [out, retval] ScreenModeEnum * pVal )

지도에서 사용자가 수행하려하는 동작 모드

HRESULT sgObject::IMapEarth::GetShadowEnable | ( | [out] VARIANT_BOOL * | bEnable,
 |  | [out] VARIANT_BOOL * | bPersp,
 |  | [out] VARIANT_BOOL * | bParallel,
 |  | [out] float * | ambientBrightness
 | ) |  |
HRESULT sgObject::IMapEarth::GetSightMode ( [out, retval] SightModeEnum * pVal )

가시권 분석 종류 모드

HRESULT sgObject::IMapEarth::GetSkyDateTime | ( | [out] VARIANT_BOOL * | bEnable,
 |  | [out] int * | year,
 |  | [out] int * | month,
 |  | [out] int * | day,
 |  | [out] int * | hour
 | ) |  |
HRESULT sgObject::IMapEarth::SetOceanEnable | ( | [in] VARIANT_BOOL | bEnable,
 |  | [in] BSTR | strOptions
 | ) |  |

해양(물) 효과를 설정한다. 해당 효과는 이미지레이어의 마스크레이어가 설정된 경우에만 적용된다.

매개변수
bEnable | - 효과 켜기/끄기
strOptions | - 기타 옵션
HRESULT sgObject::IMapEarth::SetScreenMode ( [in] ScreenModeEnum newVal )
HRESULT sgObject::IMapEarth::SetShadowEnable | ( | [in] VARIANT_BOOL | bEnable,
 |  | [in] VARIANT_BOOL | bPersp,
 |  | [in] VARIANT_BOOL | bParallel,
 |  | [in] float | ambientBrightness
 | ) |  |

그림자 효과를 설정한다.

매개변수
bEnable | - 효과 켜기/끄기
bPersp | - 투시투영 여부(아닌 경우 직교투영으로 설정)
bParallel | - 평행식 분할 여부(아닌 경우 계단식 분할)
ambientBrightness | - 주변광 밝기(0~1.0)
HRESULT sgObject::IMapEarth::SetSightMode ( [in] SightModeEnum newVal )
HRESULT sgObject::IMapEarth::SetSkyDateTime | ( | [in] VARIANT_BOOL | bEnable,
 |  | [in] int | year,
 |  | [in] int | month,
 |  | [in] int | day,
 |  | [in] int | hour
 | ) |  |

태양광 효과를 설정한다.

매개변수
bEnable | - 효과 켜기/끄기
year | - 년
month | - 월
day | - 일
hour | - 시(세계표준시기준)
HRESULT sgObject::IMapEarth::SetViewshedColor | ( | [in] SightModeEnum | eType,
 |  | [in] long | goodColor,
 |  | [in] long | badColor,
 |  | [in] long | outlineColor
 | ) |  |

모드에 해당하는 가시권 분석 객체를 생성한다.

매개변수
eType | - 가시권 분석 종류 모드
goodColor | - 가시 표시 색상
badColor | - 비가시 표시 색상
outlineColor | - 방사형 가시권 객체 경계 표시 색상
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IMapEarth::SetViewshedParam | ( | [in] SightModeEnum | eType,
 |  | [in] double | radius,
 |  | [in] int | numSpokes,
 |  | [in] VARIANT_BOOL | fill,
 |  | [in] double | startAzim,
 |  | [in] double | endAzim,
 |  | [in] double | startElev,
 |  | [in] double | endElev,
 |  | [in] double | spacing
 | ) |  |

모드에 해당하는 가시권 분석 객체를 생성한다.

매개변수
eType | - 가시권 분석 종류 모드
radius | - 방사형 가시권 객체 반경
numSpokes | - 방사형 가시권 객체 바퀴살의 수
fill | - 방사형 가시권 객체를 채울지 여부
startAzim | - 시작 방위 각도
endAzim | - 끝 방위 각도
startElev | - 시작 고도 각도
endElev | - 끝 고도 각도
spacing | - 분석 각도 단위
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::IMapEarth::ZoomToFeatureCollection ( [in] IFeatureCollection * pdspFtCol )

해당 FeatureCollection의 영역이 화면에 가득차게 보여주도록 카메라 스케일을 조정한다.

매개변수
pdspFtCol - 보여줄 IFeatureCollection 객체를 가리키는 포인터
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IMapEarth
sgObject::IMapEarth 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IMapEarth (모든 상속된 멤버들도 포함합니다.)

AddControl([in] long fid, [in] IUserDefinedWidget *dspUDBox) | sgObject::ICanvas
ClearViewshed() | sgObject::IMapEarth
CreateViewshed([in]SightModeEnum eType, [in]double sx, [in]double sy, [in]double sz, [in]double ex, [in]double ey, [in]double ez, [out, retval] VARIANT_BOOL *bResult) | sgObject::IMapEarth
DblClick([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
ExportImage([in]FileFormatEnum nFileType, [in]BSTR pVal) | sgObject::ICanvas
ForceStopRender() | sgObject::ICanvas
GetBackColor([out, retval] long *pVal) | sgObject::ICanvas
GetCanvasType([out, retval] CanvasTypeEnum *pVal) | sgObject::ICanvas
GetCommonFactory([out, retval] ICommonFactory **pVal) | sgObject::ICanvas
GetFeatureCanvas([out, retval] IFeatureCanvas **pVal) | sgObject::ICanvas
GetHittestSize([out, retval] int *pVal) | sgObject::ICanvas
GetMap3DCamera([out, retval] IMap3DCamera **pVal) | sgObject::IMapEarth
GetMap3DLight([out, retval] IMap3DLight **pVal) | sgObject::IMapEarth
GetMapControl([out, retval] long *pVal) | sgObject::ICanvas
GetMapMoveMode([out, retval] MapMoveEnum *pVal) | sgObject::ICanvas
GetMapRotateMode([out, retval] MapRotateEnum *pVal) | sgObject::ICanvas
GetObjectiveSpatialReference([out, retval] ISpatialReference **pVal) | sgObject::ICanvas
GetOceanEnable([in] VARIANT_BOOL *bEnable) | sgObject::IMapEarth
GetScreenMode([out, retval] ScreenModeEnum *pVal) | sgObject::IMapEarth
GetShadowEnable([out] VARIANT_BOOL *bEnable, [out] VARIANT_BOOL *bPersp, [out] VARIANT_BOOL *bParallel, [out] float *ambientBrightness) | sgObject::IMapEarth
GetSightMode([out, retval] SightModeEnum *pVal) | sgObject::IMapEarth
GetSkyDateTime([out] VARIANT_BOOL *bEnable, [out] int *year, [out] int *month, [out] int *day, [out] int *hour) | sgObject::IMapEarth
GetState([out, retval] int *pVal) | sgObject::ICanvas
GetTitle([out, retval] BSTR *pVal) | sgObject::ICanvas
Initialize([in] ULONG_PTR h) | sgObject::ICanvas
Invalidate() | sgObject::ICanvas
KeyDown([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags) | sgObject::ICanvas
KeyUp([in] LONG nChar, [in] LONG nRepCnt, [in] LONG nFlags) | sgObject::ICanvas
LButtonDown([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
LButtonUp([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
MButtonDown([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
MButtonUp([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
MouseMove([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
RButtonDown([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
RButtonUp([in] LONG nFlags, [in] int x, [in] int y, [in] void *owner) | sgObject::ICanvas
RemoveAllControl() | sgObject::ICanvas
RemoveControl([in] long fid) | sgObject::ICanvas
RemoveSensor([in] ISensor *pdspSensor) | sgObject::ICanvas
ReSize([in] LONG nType, [in] int cx, [in] int cy) | sgObject::ICanvas
SetBackColor([in] long newVal) | sgObject::ICanvas
SetFeatureCanvas([in] IFeatureCanvas *pVal) | sgObject::ICanvas
SetHittestSize([in] int newVal) | sgObject::ICanvas
SetLocationSensor([in] ILocationSensor *pdspSensor) | sgObject::ICanvas
SetMapControl([in] long newVal) | sgObject::ICanvas
SetMapMoveMode([in] MapMoveEnum type) | sgObject::ICanvas
SetMapRotateMode([in] MapRotateEnum type) | sgObject::ICanvas
SetMotionSensor([in] IMotionSensor *pdspSensor) | sgObject::ICanvas
SetObjectiveSpatialReference([in] ISpatialReference *pVal) | sgObject::ICanvas
SetOceanEnable([in] VARIANT_BOOL bEnable, [in] BSTR strOptions) | sgObject::IMapEarth
SetScreenMode([in] ScreenModeEnum newVal) | sgObject::IMapEarth
SetShadowEnable([in] VARIANT_BOOL bEnable, [in] VARIANT_BOOL bPersp, [in] VARIANT_BOOL bParallel, [in] float ambientBrightness) | sgObject::IMapEarth
SetSightMode([in] SightModeEnum newVal) | sgObject::IMapEarth
SetSkyDateTime([in] VARIANT_BOOL bEnable, [in] int year, [in] int month, [in] int day, [in] int hour) | sgObject::IMapEarth
SetState([in] int newVal) | sgObject::ICanvas
SetTitle([in] BSTR newVal) | sgObject::ICanvas
SetVideoSensor([in] IVideoSensor *pdspSensor) | sgObject::ICanvas
SetViewshedColor([in]SightModeEnum eType, [in]long goodColor, [in]long badColor, [in]long outlineColor) | sgObject::IMapEarth
SetViewshedParam([in]SightModeEnum eType, [in]double radius, [in]int numSpokes, [in]VARIANT_BOOL fill, [in]double startAzim, [in]double endAzim, [in]double startElev, [in]double endElev, [in]double spacing) | sgObject::IMapEarth
VisibleMapControl([in] SystemResourceEnum type, [in] VARIANT_BOOL bVisible) | sgObject::ICanvas
ZoomToFeatureCollection([in] IFeatureCollection *pdspFtCol) | sgObject::IMapEarth
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IMapEarthControl 인터페이스 참조

  • IMapEarthControl
Public 멤버 함수 | 모든 멤버 목록
sgObject::IMapEarthControl 인터페이스 참조

MapEarth 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다. 더 자세히 ...

sgObject::IMapEarthControl에 대한 상속 다이어그램 :
sgObject::IMapEarthControl에 대한 협력 다이어그램:

Public 멤버 함수

IMapEarth * GetMapEarth ()
컨트롤내에 생성된 MapEarth 인터페이스 더 자세히 ...
IFeatureCanvas * GetFeatureCanvas ()
컨트롤내에 생성된 FeatureCanvas 인터페이스 더 자세히 ...

상세한 설명

MapEarth 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다.

COM+ 인터페이스에만 존재하는 ActiveX 방식의 MapEarth 객체

멤버 함수 문서화

IFeatureCanvas* sgObject::IMapEarthControl::GetFeatureCanvas ( )

컨트롤내에 생성된 FeatureCanvas 인터페이스

IMapEarth* sgObject::IMapEarthControl::GetMapEarth ( )

컨트롤내에 생성된 MapEarth 인터페이스

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IMapEarthControl
sgObject::IMapEarthControl 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IMapEarthControl (모든 상속된 멤버들도 포함합니다.)

GetFeatureCanvas() | sgObject::IMapEarthControl
GetMapEarth() | sgObject::IMapEarthControl
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IMark 인터페이스 참조

  • IMark
Public 멤버 함수 | 모든 멤버 목록
sgObject::IMark 인터페이스 참조

심볼의 스타일을 표현하기 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::IMark에 대한 상속 다이어그램 :
sgObject::IMark에 대한 협력 다이어그램:

Public 멤버 함수

BSTR | GetStyleString ()
심볼 스타일을 문자열 형태로 반환한다. 더 자세히 ...
BSTR | GetID ()
심볼의 ID를 반환한다. 더 자세히 ...
void | SetID (BSTR bstrId)
심볼의 ID를 설정한다. 더 자세히 ...
double | GetAngle ()
심볼의 회전 각도(도, 반 시계 방향)를 반환한다. 더 자세히 ...
void | SetAngle (double dfAngle)
심볼의 회전 각도(도, 반 시계 방향)를 설정한다. 더 자세히 ...
BSTR | GetColor ()
심볼의 색상을 문자열 형태로 반환한다. 더 자세히 ...
void | SetColor (BSTR bstrColor)
심볼의 색상을 문자열 형태로 설정한다. 더 자세히 ...
double | GetSize ()
심볼의 크기를 반환한다. 더 자세히 ...
void | SetSize (double dfSize)
심볼의 크기를 설정한다. 더 자세히 ...
double | GetSpacingX ()
심볼 스타일의 X축 간격을 반환한다. 더 자세히 ...
void | SetSpacingX (double dfX)
심볼 스타일의 X축 간격을 설정한다. 더 자세히 ...
double | GetSpacingY ()
심볼 스타일의 Y축 간격을 반환한다. 더 자세히 ...
void | SetSpacingY (double dfY)
심볼 스타일의 Y축 간격을 설정한다. 더 자세히 ...
double | GetStep ()
심볼 스타일의 스텝을 반환한다. 더 자세히 ...
void | SetStep (double dfStep)
심볼 스타일의 스텝을 설정한다. 더 자세히 ...
double | GetOffset ()
심볼 스타일의 오프셋을 반환한다. 더 자세히 ...
void | SetOffset (double dfOffset)
심볼 스타일의 오프셋을 설정한다. 더 자세히 ...
double | GetPerp ()
심볼 스타일의 Perp을 반환한다. 더 자세히 ...
void | SetPerp (double dfPerp)
심볼 스타일의 Perp을 반환한다. 더 자세히 ...
int | GetPriority ()
우선적으로 그려야할 순서를 반환한다. 더 자세히 ...
void | SetPriority (int nPriority)
우선적으로 그려야할 순서를 설정한다. 더 자세히 ...
BSTR | GetFontName ()
텍스트 심볼의 글꼴를 반환한다. 더 자세히 ...
void | SetFontName (BSTR bstrFontName)
텍스트 심볼의 글꼴를 설정한다. 더 자세히 ...
BSTR | GetOColor ()
심볼의 윤곽선 색상을 문자열 형태로 반환한다. 더 자세히 ...
void | SetOColor (BSTR bstrColor)
심볼의 윤곽선 색상을 문자열 형태로 설정한다. 더 자세히 ...
BSTR | GetLinePattern ()
심볼의 라인 패턴을 반환한다. 더 자세히 ...
void | SetLinePattern (BSTR bstrLinePtn)
심볼의 라인 패턴을 설정한다. 더 자세히 ...
BSTR | GetTextAngle ()
심볼의 회전각 필드명을 반환한다. 더 자세히 ...
void | SetTextAngle (BSTR bstrAngleField)
심볼의 회전각 필드명을 설정한다. 더 자세히 ...

상세한 설명

심볼의 스타일을 표현하기 위한 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "MK"를 덧붙여서 "OGR_MK_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Mark"

멤버 함수 문서화

double sgObject::IMark::GetAngle ( )

심볼의 회전 각도(도, 반 시계 방향)를 반환한다.

BSTR sgObject::IMark::GetColor ( )

심볼의 색상을 문자열 형태로 반환한다.

BSTR sgObject::IMark::GetFontName ( )

텍스트 심볼의 글꼴를 반환한다.

BSTR sgObject::IMark::GetID ( )

심볼의 ID를 반환한다.

BSTR sgObject::IMark::GetLinePattern ( )

심볼의 라인 패턴을 반환한다.

BSTR sgObject::IMark::GetOColor ( )

심볼의 윤곽선 색상을 문자열 형태로 반환한다.

double sgObject::IMark::GetOffset ( )

심볼 스타일의 오프셋을 반환한다.

double sgObject::IMark::GetPerp ( )

심볼 스타일의 Perp을 반환한다.

int sgObject::IMark::GetPriority ( )

우선적으로 그려야할 순서를 반환한다.

double sgObject::IMark::GetSize ( )

심볼의 크기를 반환한다.

double sgObject::IMark::GetSpacingX ( )

심볼 스타일의 X축 간격을 반환한다.

double sgObject::IMark::GetSpacingY ( )

심볼 스타일의 Y축 간격을 반환한다.

double sgObject::IMark::GetStep ( )

심볼 스타일의 스텝을 반환한다.

BSTR sgObject::IMark::GetStyleString ( )

심볼 스타일을 문자열 형태로 반환한다.

BSTR sgObject::IMark::GetTextAngle ( )

심볼의 회전각 필드명을 반환한다.

void sgObject::IMark::SetAngle ( double dfAngle )

심볼의 회전 각도(도, 반 시계 방향)를 설정한다.

void sgObject::IMark::SetColor ( BSTR bstrColor )

심볼의 색상을 문자열 형태로 설정한다.

void sgObject::IMark::SetFontName ( BSTR bstrFontName )

텍스트 심볼의 글꼴를 설정한다.

void sgObject::IMark::SetID ( BSTR bstrId )

심볼의 ID를 설정한다.

void sgObject::IMark::SetLinePattern ( BSTR bstrLinePtn )

심볼의 라인 패턴을 설정한다.

void sgObject::IMark::SetOColor ( BSTR bstrColor )

심볼의 윤곽선 색상을 문자열 형태로 설정한다.

void sgObject::IMark::SetOffset ( double dfOffset )

심볼 스타일의 오프셋을 설정한다.

void sgObject::IMark::SetPerp ( double dfPerp )

심볼 스타일의 Perp을 반환한다.

void sgObject::IMark::SetPriority ( int nPriority )

우선적으로 그려야할 순서를 설정한다.

void sgObject::IMark::SetSize ( double dfSize )

심볼의 크기를 설정한다.

void sgObject::IMark::SetSpacingX ( double dfX )

심볼 스타일의 X축 간격을 설정한다.

void sgObject::IMark::SetSpacingY ( double dfY )

심볼 스타일의 Y축 간격을 설정한다.

void sgObject::IMark::SetStep ( double dfStep )

심볼 스타일의 스텝을 설정한다.

void sgObject::IMark::SetTextAngle ( BSTR bstrAngleField )

심볼의 회전각 필드명을 설정한다.

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IMark
sgObject::IMark 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IMark (모든 상속된 멤버들도 포함합니다.)

GetAngle() | sgObject::IMark
GetColor() | sgObject::IMark
GetFontName() | sgObject::IMark
GetID() | sgObject::IMark
GetLinePattern() | sgObject::IMark
GetOColor() | sgObject::IMark
GetOffset() | sgObject::IMark
GetPerp() | sgObject::IMark
GetPriority() | sgObject::IMark
GetSize() | sgObject::IMark
GetSpacingX() | sgObject::IMark
GetSpacingY() | sgObject::IMark
GetStep() | sgObject::IMark
GetStyleString() | sgObject::IMark
GetTextAngle() | sgObject::IMark
SetAngle(double dfAngle) | sgObject::IMark
SetColor(BSTR bstrColor) | sgObject::IMark
SetFontName(BSTR bstrFontName) | sgObject::IMark
SetID(BSTR bstrId) | sgObject::IMark
SetLinePattern(BSTR bstrLinePtn) | sgObject::IMark
SetOColor(BSTR bstrColor) | sgObject::IMark
SetOffset(double dfOffset) | sgObject::IMark
SetPerp(double dfPerp) | sgObject::IMark
SetPriority(int nPriority) | sgObject::IMark
SetSize(double dfSize) | sgObject::IMark
SetSpacingX(double dfX) | sgObject::IMark
SetSpacingY(double dfY) | sgObject::IMark
SetStep(double dfStep) | sgObject::IMark
SetTextAngle(BSTR bstrAngleField) | sgObject::IMark
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IMessage 인터페이스 참조

  • IMessage
Public 멤버 함수 | 모든 멤버 목록
sgObject::IMessage 인터페이스 참조

제품의 언어별 메시지 체계에 따라 입력된 메시지 정보 제공 인터페이스를 제공한다. 더 자세히 ...

sgObject::IMessage에 대한 상속 다이어그램 :
sgObject::IMessage에 대한 협력 다이어그램:

Public 멤버 함수

VARIANT_BOOL | SetMessageFile ([in] BSTR strName)
메시지 체계에 따라 입력된 메시지 파일(언어별 설정이 필요시 사용) 더 자세히 ...
BSTR | GetMsgInString ([in] int nID, [in] BSTR strVal)
메세지 번호에 해당하는 문자정보를 반환한다. 더 자세히 ...
BSTR | GetQueryString ([in] BSTR strID, [in] BSTR strVal)
질의문 ID에 해당하는 질의문 정보를 반환한다. [질의파일의 형식은 mybatis xml 형태만 지원] 더 자세히 ...

상세한 설명

제품의 언어별 메시지 체계에 따라 입력된 메시지 정보 제공 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "UT"를 덧붙여서 "OGR_UT_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Message"

멤버 함수 문서화

BSTR sgObject::IMessage::GetMsgInString | ( | [in] int | nID,
 |  | [in] BSTR | strVal
 | ) |  |

메세지 번호에 해당하는 문자정보를 반환한다.

매개변수
nID | - 메시지 번호
strVal | - 메시지 내 입력된 파라미터 [ {} 기호로 변수를 구분 - ex) "{A}{B}" ]
반환값
성공이면 S_OK, 그렇지 않으면 HRESULT 에러코드
BSTR sgObject::IMessage::GetQueryString | ( | [in] BSTR | strID,
 |  | [in] BSTR | strVal
 | ) |  |

질의문 ID에 해당하는 질의문 정보를 반환한다. [질의파일의 형식은 mybatis xml 형태만 지원]

매개변수
strID | - 질의문 ID
strVal | - 질의문 내 입력된 파라미터 [ , 기호로 변수를 구분 - ex) "A, \"B, C"" ]
반환값
성공이면 S_OK, 그렇지 않으면 HRESULT 에러코드
VARIANT_BOOL sgObject::IMessage::SetMessageFile ( [in] BSTR strName )

메시지 체계에 따라 입력된 메시지 파일(언어별 설정이 필요시 사용)

매개변수
strName - 파일의 명칭
반환값
성공이면 S_OK, 그렇지 않으면 HRESULT 에러코드
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IMessage
sgObject::IMessage 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IMessage (모든 상속된 멤버들도 포함합니다.)

GetMsgInString([in] int nID, [in] BSTR strVal) | sgObject::IMessage
GetQueryString([in] BSTR strID, [in] BSTR strVal) | sgObject::IMessage
SetMessageFile([in] BSTR strName) | sgObject::IMessage
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IMotionSensor 인터페이스 참조

  • IMotionSensor
모든 멤버 목록
sgObject::IMotionSensor 인터페이스 참조

자이로스코프 장치와 연결하여 방향각, 기우러짐, 가속도 및 기타 부수 자료를 집계 제공하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::IMotionSensor에 대한 상속 다이어그램 :
sgObject::IMotionSensor에 대한 협력 다이어그램:

추가로 상속된 멤버들

- sgObject::ISensor(으)로부터 상속된 Public 멤버 함수
HRESULT | Start ([in] IParameters *param, [out, retval] VARIANT_BOOL *bSuccess)
위치 센서의 경우 Sensor 장치를 COM 포트를 통해 사용한다. 더 자세히 ...
HRESULT | Stop ()
센서 장치의 사용을 끝낸다. 더 자세히 ...
HRESULT | IsServiceRunning ([out, retval] VARIANT_BOOL *retVal)
Sensor 장치를 사용할 수 있는지 여부 더 자세히 ...
HRESULT | GetLatestValueToXML ([out, retval] BSTR *retVal)
Sensor 장치에서 읽어온 최신 자료를 센서별 XML규격 형태로 반환한다. 더 자세히 ...

상세한 설명

자이로스코프 장치와 연결하여 방향각, 기우러짐, 가속도 및 기타 부수 자료를 집계 제공하는 인터페이스를 제공한다.

자이로스코프 장치로부터 수신되는 정보는 IMotionSensorEvents 인터페이스를 통해 이벤트로 제공된다. C API(linux, iOS, MacOS 등) : 중간이름 "MSN"를 덧붙여서 "OGR_MSN</em>"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.MotionSensor"

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IMotionSensor
sgObject::IMotionSensor 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IMotionSensor (모든 상속된 멤버들도 포함합니다.)

GetLatestValueToXML([out, retval] BSTR *retVal) | sgObject::ISensor
IsServiceRunning([out, retval] VARIANT_BOOL *retVal) | sgObject::ISensor
Start([in] IParameters *param, [out, retval] VARIANT_BOOL *bSuccess) | sgObject::ISensor
Stop() | sgObject::ISensor
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IMultiCurve 인터페이스 참조

  • IMultiCurve
Public 멤버 함수 | 모든 멤버 목록
sgObject::IMultiCurve 인터페이스 참조

기하명세의 MultiCurve에 대한 일반적인 인터페이스를 제공한다. (MultiCurve는 Curve가 여러 개 있는 것) 더 자세히 ...

sgObject::IMultiCurve에 대한 상속 다이어그램 :
sgObject::IMultiCurve에 대한 협력 다이어그램:

Public 멤버 함수

double | GetLength ()
MultiCurve에 속해있는 모든 Curve의 길이의 합을 반환한다. 더 자세히 ...
VARIANT_BOOL | IsClosed ()
속해있는 모든 Curve가 닫혀있는지 여부를 반환한다. (Curve는 시작점과 종료점이 동일하면 닫혀있는 것이다.) 더 자세히 ...
IMultiCurve * GetMultiCurve ()
IGeometryCollection * GetGeometryCollection ()
- sgObject::IGeometryCollection(으)로부터 상속된 Public 멤버 함수
long | GetNumGeometries ()
복잡한 기하 구조를 표현하는데 사용된 부품 기하의 개수를 반환한다. 더 자세히 ...
IGeometry * | Geometry ([in] long index)
해당 인덱스로 추가된 부품 기하를 가져온다. (GeometryColloection 내의 특정 색인에서의 기하를 반환한다.) 더 자세히 ...
VARIANT_BOOL | Add ([in] IGeometry *obj)
기하를 추가한다. 더 자세히 ...
- sgObject::IGeometry(으)로부터 상속된 Public 멤버 함수
long | GetDimension ()
Geometry 객체의 차원 (0, 1, 2차원) 이다. 더 자세히 ...
ISpatialReference * GetSpatialReference ()
Geometry 객체가 참조하는 공간참조체계 (좌표체계) 이다. 더 자세히 ...
void | SetSpatialReference (ISpatialReference *pVal)
VARIANT_BOOL | IsEmpty ()
비어있는 Geometry 객체인지 나타낸다 (일반 프로그래밍 시 변수의 NULL과 유사) 더 자세히 ...
VARIANT_BOOL | IsSimple ()
기하가 심플한지 여부를 나타낸다. 더 자세히 ...
GeometryTypeEnum GetGeometryType ()
Geometry 객체의 구체적인 타입이다. 더 자세히 ...
void | SetEmpty ()
기하를 비어있는 기하로 만든다. 더 자세히 ...
IGeometry * Envelope ()
기하를 감싸는 최소 직사각형을 가져온다. 더 자세히 ...
IGeometry * Clone ()
해당 기하와 동일한 객체를 생성하여 가져온다. 더 자세히 ...
IGeometry * | Project ([in] ISpatialReference *newSystem)
기하를 새로운 공간참조체계로 투영해 만든 새로운 기하를 가져온다. 더 자세히 ...
void | Extent2D ([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY)
기하를 감싸는 최소 직사각형의 x, y 좌표를 Output 변수에 가져온다. 더 자세히 ...
IWks * GetWks ()
ISpatialRelation * GetSpatialRelation ()
ISpatialRelation2 * GetSpatialRelation2 ()
ISpatialOperator * GetSpatialOperator ()

상세한 설명

기하명세의 MultiCurve에 대한 일반적인 인터페이스를 제공한다. (MultiCurve는 Curve가 여러 개 있는 것)

C API(linux, iOS, MacOS 등) : 중간이름 "G"를 덧붙여서 "OGR_G_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Geometry"

멤버 함수 문서화

IGeometryCollection* sgObject::IMultiCurve::GetGeometryCollection ( )
double sgObject::IMultiCurve::GetLength ( )

MultiCurve에 속해있는 모든 Curve의 길이의 합을 반환한다.

IMultiCurve* sgObject::IMultiCurve::GetMultiCurve ( )
VARIANT_BOOL sgObject::IMultiCurve::IsClosed ( )

속해있는 모든 Curve가 닫혀있는지 여부를 반환한다. (Curve는 시작점과 종료점이 동일하면 닫혀있는 것이다.)

반환값
닫혀있으면 VARIANT_TRUE, 닫혀있지 않다면 VARIANT_FALSE
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IMultiCurve
sgObject::IMultiCurve 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IMultiCurve (모든 상속된 멤버들도 포함합니다.)

Add([in] IGeometry *obj) | sgObject::IGeometryCollection
Clone() | sgObject::IGeometry
Envelope() | sgObject::IGeometry
Extent2D([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY) | sgObject::IGeometry
Geometry([in] long index) | sgObject::IGeometryCollection
GetDimension() | sgObject::IGeometry
GetGeometryCollection() | sgObject::IMultiCurve
GetGeometryType() | sgObject::IGeometry
GetLength() | sgObject::IMultiCurve
GetMultiCurve() | sgObject::IMultiCurve
GetNumGeometries() | sgObject::IGeometryCollection
GetSpatialOperator() | sgObject::IGeometry
GetSpatialReference() | sgObject::IGeometry
GetSpatialRelation() | sgObject::IGeometry
GetSpatialRelation2() | sgObject::IGeometry
GetWks() | sgObject::IGeometry
IsClosed() | sgObject::IMultiCurve
IsEmpty() | sgObject::IGeometry
IsSimple() | sgObject::IGeometry
Project([in] ISpatialReference *newSystem) | sgObject::IGeometry
SetEmpty() | sgObject::IGeometry
SetSpatialReference(ISpatialReference *pVal) | sgObject::IGeometry
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IMultiLineString 인터페이스 참조

  • IMultiLineString
모든 멤버 목록
sgObject::IMultiLineString 인터페이스 참조

기하명세에 정의된 MultiLineString에 대한 일반적인 인터페이스를 제공한다. (MultiLineString은 LineString이 여러 개 있는 것) 더 자세히 ...

sgObject::IMultiLineString에 대한 상속 다이어그램 :
sgObject::IMultiLineString에 대한 협력 다이어그램:

추가로 상속된 멤버들

- sgObject::IMultiCurve(으)로부터 상속된 Public 멤버 함수
double | GetLength ()
MultiCurve에 속해있는 모든 Curve의 길이의 합을 반환한다. 더 자세히 ...
VARIANT_BOOL | IsClosed ()
속해있는 모든 Curve가 닫혀있는지 여부를 반환한다. (Curve는 시작점과 종료점이 동일하면 닫혀있는 것이다.) 더 자세히 ...
IMultiCurve * GetMultiCurve ()
IGeometryCollection * GetGeometryCollection ()
- sgObject::IGeometryCollection(으)로부터 상속된 Public 멤버 함수
long | GetNumGeometries ()
복잡한 기하 구조를 표현하는데 사용된 부품 기하의 개수를 반환한다. 더 자세히 ...
IGeometry * | Geometry ([in] long index)
해당 인덱스로 추가된 부품 기하를 가져온다. (GeometryColloection 내의 특정 색인에서의 기하를 반환한다.) 더 자세히 ...
VARIANT_BOOL | Add ([in] IGeometry *obj)
기하를 추가한다. 더 자세히 ...
- sgObject::IGeometry(으)로부터 상속된 Public 멤버 함수
long | GetDimension ()
Geometry 객체의 차원 (0, 1, 2차원) 이다. 더 자세히 ...
ISpatialReference * GetSpatialReference ()
Geometry 객체가 참조하는 공간참조체계 (좌표체계) 이다. 더 자세히 ...
void | SetSpatialReference (ISpatialReference *pVal)
VARIANT_BOOL | IsEmpty ()
비어있는 Geometry 객체인지 나타낸다 (일반 프로그래밍 시 변수의 NULL과 유사) 더 자세히 ...
VARIANT_BOOL | IsSimple ()
기하가 심플한지 여부를 나타낸다. 더 자세히 ...
GeometryTypeEnum GetGeometryType ()
Geometry 객체의 구체적인 타입이다. 더 자세히 ...
void | SetEmpty ()
기하를 비어있는 기하로 만든다. 더 자세히 ...
IGeometry * Envelope ()
기하를 감싸는 최소 직사각형을 가져온다. 더 자세히 ...
IGeometry * Clone ()
해당 기하와 동일한 객체를 생성하여 가져온다. 더 자세히 ...
IGeometry * | Project ([in] ISpatialReference *newSystem)
기하를 새로운 공간참조체계로 투영해 만든 새로운 기하를 가져온다. 더 자세히 ...
void | Extent2D ([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY)
기하를 감싸는 최소 직사각형의 x, y 좌표를 Output 변수에 가져온다. 더 자세히 ...
IWks * GetWks ()
ISpatialRelation * GetSpatialRelation ()
ISpatialRelation2 * GetSpatialRelation2 ()
ISpatialOperator * GetSpatialOperator ()

상세한 설명

기하명세에 정의된 MultiLineString에 대한 일반적인 인터페이스를 제공한다. (MultiLineString은 LineString이 여러 개 있는 것)

(현재는 속성 및 메소드가 없으나 MultiLineString에 대한 속성 및 메소드 추가를 고려해 만들어 놓은 인터페이스이다) MultiLineString에 대한 정의 및 기타 정보는 Knowledge Base의 Geometry를 참고한다. C API(linux, iOS, MacOS 등) : 중간이름 "G"를 덧붙여서 "OGR_G_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Geometry"

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IMultiLineString
sgObject::IMultiLineString 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IMultiLineString (모든 상속된 멤버들도 포함합니다.)

Add([in] IGeometry *obj) | sgObject::IGeometryCollection
Clone() | sgObject::IGeometry
Envelope() | sgObject::IGeometry
Extent2D([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY) | sgObject::IGeometry
Geometry([in] long index) | sgObject::IGeometryCollection
GetDimension() | sgObject::IGeometry
GetGeometryCollection() | sgObject::IMultiCurve
GetGeometryType() | sgObject::IGeometry
GetLength() | sgObject::IMultiCurve
GetMultiCurve() | sgObject::IMultiCurve
GetNumGeometries() | sgObject::IGeometryCollection
GetSpatialOperator() | sgObject::IGeometry
GetSpatialReference() | sgObject::IGeometry
GetSpatialRelation() | sgObject::IGeometry
GetSpatialRelation2() | sgObject::IGeometry
GetWks() | sgObject::IGeometry
IsClosed() | sgObject::IMultiCurve
IsEmpty() | sgObject::IGeometry
IsSimple() | sgObject::IGeometry
Project([in] ISpatialReference *newSystem) | sgObject::IGeometry
SetEmpty() | sgObject::IGeometry
SetSpatialReference(ISpatialReference *pVal) | sgObject::IGeometry
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IMultiPoint 인터페이스 참조

  • IMultiPoint
Public 멤버 함수 | 모든 멤버 목록
sgObject::IMultiPoint 인터페이스 참조

기하 명세에 정의된 MultiPoint에 대한 일반적인 인터페이스를 제공한다. 더 자세히 ...

sgObject::IMultiPoint에 대한 상속 다이어그램 :
sgObject::IMultiPoint에 대한 협력 다이어그램:

Public 멤버 함수

IGeometryCollection * GetGeometryCollection ()
- sgObject::IGeometryCollection(으)로부터 상속된 Public 멤버 함수
long | GetNumGeometries ()
복잡한 기하 구조를 표현하는데 사용된 부품 기하의 개수를 반환한다. 더 자세히 ...
IGeometry * | Geometry ([in] long index)
해당 인덱스로 추가된 부품 기하를 가져온다. (GeometryColloection 내의 특정 색인에서의 기하를 반환한다.) 더 자세히 ...
VARIANT_BOOL | Add ([in] IGeometry *obj)
기하를 추가한다. 더 자세히 ...
- sgObject::IGeometry(으)로부터 상속된 Public 멤버 함수
long | GetDimension ()
Geometry 객체의 차원 (0, 1, 2차원) 이다. 더 자세히 ...
ISpatialReference * GetSpatialReference ()
Geometry 객체가 참조하는 공간참조체계 (좌표체계) 이다. 더 자세히 ...
void | SetSpatialReference (ISpatialReference *pVal)
VARIANT_BOOL | IsEmpty ()
비어있는 Geometry 객체인지 나타낸다 (일반 프로그래밍 시 변수의 NULL과 유사) 더 자세히 ...
VARIANT_BOOL | IsSimple ()
기하가 심플한지 여부를 나타낸다. 더 자세히 ...
GeometryTypeEnum GetGeometryType ()
Geometry 객체의 구체적인 타입이다. 더 자세히 ...
void | SetEmpty ()
기하를 비어있는 기하로 만든다. 더 자세히 ...
IGeometry * Envelope ()
기하를 감싸는 최소 직사각형을 가져온다. 더 자세히 ...
IGeometry * Clone ()
해당 기하와 동일한 객체를 생성하여 가져온다. 더 자세히 ...
IGeometry * | Project ([in] ISpatialReference *newSystem)
기하를 새로운 공간참조체계로 투영해 만든 새로운 기하를 가져온다. 더 자세히 ...
void | Extent2D ([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY)
기하를 감싸는 최소 직사각형의 x, y 좌표를 Output 변수에 가져온다. 더 자세히 ...
IWks * GetWks ()
ISpatialRelation * GetSpatialRelation ()
ISpatialRelation2 * GetSpatialRelation2 ()
ISpatialOperator * GetSpatialOperator ()

상세한 설명

기하 명세에 정의된 MultiPoint에 대한 일반적인 인터페이스를 제공한다.

MultiPoint는 Point가 여러 개 있는 것이다. (현재는 프로퍼티 및 메소드가 없으나 MultiPoint에 대한 프로퍼티 및 메소드 추가를 고려해 만들어 놓은 인터페이스이다) MultiPoint에 대한 정의 및 기타 정보는 Knowledge Base의 Geometry를 참고한다. C API(linux, iOS, MacOS 등) : 중간이름 "G"를 덧붙여서 "OGR_G_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Geometry"

멤버 함수 문서화

IGeometryCollection* sgObject::IMultiPoint::GetGeometryCollection ( )
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IMultiPoint
sgObject::IMultiPoint 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IMultiPoint (모든 상속된 멤버들도 포함합니다.)

Add([in] IGeometry *obj) | sgObject::IGeometryCollection
Clone() | sgObject::IGeometry
Envelope() | sgObject::IGeometry
Extent2D([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY) | sgObject::IGeometry
Geometry([in] long index) | sgObject::IGeometryCollection
GetDimension() | sgObject::IGeometry
GetGeometryCollection() | sgObject::IMultiPoint
GetGeometryType() | sgObject::IGeometry
GetNumGeometries() | sgObject::IGeometryCollection
GetSpatialOperator() | sgObject::IGeometry
GetSpatialReference() | sgObject::IGeometry
GetSpatialRelation() | sgObject::IGeometry
GetSpatialRelation2() | sgObject::IGeometry
GetWks() | sgObject::IGeometry
IsEmpty() | sgObject::IGeometry
IsSimple() | sgObject::IGeometry
Project([in] ISpatialReference *newSystem) | sgObject::IGeometry
SetEmpty() | sgObject::IGeometry
SetSpatialReference(ISpatialReference *pVal) | sgObject::IGeometry
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IMultiPolygon 인터페이스 참조

  • IMultiPolygon
Public 멤버 함수 | 모든 멤버 목록
sgObject::IMultiPolygon 인터페이스 참조

기하 명세에 정의된 MultiPolygon에 대한 일반적인 인터페이스를 제공한다. (MultiPolygon은 Polygon이 여러 개 있는 것) 더 자세히 ...

sgObject::IMultiPolygon에 대한 상속 다이어그램 :
sgObject::IMultiPolygon에 대한 협력 다이어그램:

Public 멤버 함수

IMultiSurface * GetMultiSurface ()
IGeometryCollection * GetGeometryCollection ()
- sgObject::IMultiSurface(으)로부터 상속된 Public 멤버 함수
double | GetArea ()
속해 있는 모든 면의 넓이의 합을 반환한다. 더 자세히 ...
IPoint * Centroid ()
MultiSurface의 수학적 중심점을 가져온다. (중심점은 MultiSurface의 외부에 있을 수도 있다) 더 자세히 ...
IPoint * PointOnSurface ()
MultiSurface 내에 존재하는 것이 보장되는 점 한 개를 가져온다. 더 자세히 ...
- sgObject::IGeometryCollection(으)로부터 상속된 Public 멤버 함수
long | GetNumGeometries ()
복잡한 기하 구조를 표현하는데 사용된 부품 기하의 개수를 반환한다. 더 자세히 ...
IGeometry * | Geometry ([in] long index)
해당 인덱스로 추가된 부품 기하를 가져온다. (GeometryColloection 내의 특정 색인에서의 기하를 반환한다.) 더 자세히 ...
VARIANT_BOOL | Add ([in] IGeometry *obj)
기하를 추가한다. 더 자세히 ...
- sgObject::IGeometry(으)로부터 상속된 Public 멤버 함수
long | GetDimension ()
Geometry 객체의 차원 (0, 1, 2차원) 이다. 더 자세히 ...
ISpatialReference * GetSpatialReference ()
Geometry 객체가 참조하는 공간참조체계 (좌표체계) 이다. 더 자세히 ...
void | SetSpatialReference (ISpatialReference *pVal)
VARIANT_BOOL | IsEmpty ()
비어있는 Geometry 객체인지 나타낸다 (일반 프로그래밍 시 변수의 NULL과 유사) 더 자세히 ...
VARIANT_BOOL | IsSimple ()
기하가 심플한지 여부를 나타낸다. 더 자세히 ...
GeometryTypeEnum GetGeometryType ()
Geometry 객체의 구체적인 타입이다. 더 자세히 ...
void | SetEmpty ()
기하를 비어있는 기하로 만든다. 더 자세히 ...
IGeometry * Envelope ()
기하를 감싸는 최소 직사각형을 가져온다. 더 자세히 ...
IGeometry * Clone ()
해당 기하와 동일한 객체를 생성하여 가져온다. 더 자세히 ...
IGeometry * | Project ([in] ISpatialReference *newSystem)
기하를 새로운 공간참조체계로 투영해 만든 새로운 기하를 가져온다. 더 자세히 ...
void | Extent2D ([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY)
기하를 감싸는 최소 직사각형의 x, y 좌표를 Output 변수에 가져온다. 더 자세히 ...
IWks * GetWks ()
ISpatialRelation * GetSpatialRelation ()
ISpatialRelation2 * GetSpatialRelation2 ()
ISpatialOperator * GetSpatialOperator ()

상세한 설명

기하 명세에 정의된 MultiPolygon에 대한 일반적인 인터페이스를 제공한다. (MultiPolygon은 Polygon이 여러 개 있는 것)

(현재는 프로퍼티 및 메소드가 없으나 MultiPolygon에 대한 프로퍼티 및 메소드 추가를 고려해 만들어 놓은 인터페이스이다) MultiPolygon에 대한 정의 및 기타 정보는 Knowledge Base의 Geometry를 참고한다. C API(linux, iOS, MacOS 등) : 중간이름 "G"를 덧붙여서 "OGR_G_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Geometry"

멤버 함수 문서화

IGeometryCollection* sgObject::IMultiPolygon::GetGeometryCollection ( )
IMultiSurface* sgObject::IMultiPolygon::GetMultiSurface ( )
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IMultiPolygon
sgObject::IMultiPolygon 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IMultiPolygon (모든 상속된 멤버들도 포함합니다.)

Add([in] IGeometry *obj) | sgObject::IGeometryCollection
Centroid() | sgObject::IMultiSurface
Clone() | sgObject::IGeometry
Envelope() | sgObject::IGeometry
Extent2D([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY) | sgObject::IGeometry
Geometry([in] long index) | sgObject::IGeometryCollection
GetArea() | sgObject::IMultiSurface
GetDimension() | sgObject::IGeometry
GetGeometryCollection() | sgObject::IMultiPolygon
GetGeometryType() | sgObject::IGeometry
GetMultiSurface() | sgObject::IMultiPolygon
GetNumGeometries() | sgObject::IGeometryCollection
GetSpatialOperator() | sgObject::IGeometry
GetSpatialReference() | sgObject::IGeometry
GetSpatialRelation() | sgObject::IGeometry
GetSpatialRelation2() | sgObject::IGeometry
GetWks() | sgObject::IGeometry
IsEmpty() | sgObject::IGeometry
IsSimple() | sgObject::IGeometry
PointOnSurface() | sgObject::IMultiSurface
Project([in] ISpatialReference *newSystem) | sgObject::IGeometry
SetEmpty() | sgObject::IGeometry
SetSpatialReference(ISpatialReference *pVal) | sgObject::IGeometry
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IMultiSurface 인터페이스 참조

  • IMultiSurface
Public 멤버 함수 | 모든 멤버 목록
sgObject::IMultiSurface 인터페이스 참조

Surface가 여러 개 있는 것으로, 기하명세의 MultiSurface에 대한 일반적인 인터페이스를 제공한다. 더 자세히 ...

sgObject::IMultiSurface에 대한 상속 다이어그램 :
sgObject::IMultiSurface에 대한 협력 다이어그램:

Public 멤버 함수

double | GetArea ()
속해 있는 모든 면의 넓이의 합을 반환한다. 더 자세히 ...
IPoint * Centroid ()
MultiSurface의 수학적 중심점을 가져온다. (중심점은 MultiSurface의 외부에 있을 수도 있다) 더 자세히 ...
IPoint * PointOnSurface ()
MultiSurface 내에 존재하는 것이 보장되는 점 한 개를 가져온다. 더 자세히 ...
- sgObject::IGeometryCollection(으)로부터 상속된 Public 멤버 함수
long | GetNumGeometries ()
복잡한 기하 구조를 표현하는데 사용된 부품 기하의 개수를 반환한다. 더 자세히 ...
IGeometry * | Geometry ([in] long index)
해당 인덱스로 추가된 부품 기하를 가져온다. (GeometryColloection 내의 특정 색인에서의 기하를 반환한다.) 더 자세히 ...
VARIANT_BOOL | Add ([in] IGeometry *obj)
기하를 추가한다. 더 자세히 ...
- sgObject::IGeometry(으)로부터 상속된 Public 멤버 함수
long | GetDimension ()
Geometry 객체의 차원 (0, 1, 2차원) 이다. 더 자세히 ...
ISpatialReference * GetSpatialReference ()
Geometry 객체가 참조하는 공간참조체계 (좌표체계) 이다. 더 자세히 ...
void | SetSpatialReference (ISpatialReference *pVal)
VARIANT_BOOL | IsEmpty ()
비어있는 Geometry 객체인지 나타낸다 (일반 프로그래밍 시 변수의 NULL과 유사) 더 자세히 ...
VARIANT_BOOL | IsSimple ()
기하가 심플한지 여부를 나타낸다. 더 자세히 ...
GeometryTypeEnum GetGeometryType ()
Geometry 객체의 구체적인 타입이다. 더 자세히 ...
void | SetEmpty ()
기하를 비어있는 기하로 만든다. 더 자세히 ...
IGeometry * Envelope ()
기하를 감싸는 최소 직사각형을 가져온다. 더 자세히 ...
IGeometry * Clone ()
해당 기하와 동일한 객체를 생성하여 가져온다. 더 자세히 ...
IGeometry * | Project ([in] ISpatialReference *newSystem)
기하를 새로운 공간참조체계로 투영해 만든 새로운 기하를 가져온다. 더 자세히 ...
void | Extent2D ([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY)
기하를 감싸는 최소 직사각형의 x, y 좌표를 Output 변수에 가져온다. 더 자세히 ...
IWks * GetWks ()
ISpatialRelation * GetSpatialRelation ()
ISpatialRelation2 * GetSpatialRelation2 ()
ISpatialOperator * GetSpatialOperator ()

상세한 설명

Surface가 여러 개 있는 것으로, 기하명세의 MultiSurface에 대한 일반적인 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "G"를 덧붙여서 "OGR_G_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Geometry"

멤버 함수 문서화

IPoint* sgObject::IMultiSurface::Centroid ( )

MultiSurface의 수학적 중심점을 가져온다. (중심점은 MultiSurface의 외부에 있을 수도 있다)

반환값
중심점의 기하 포인터
double sgObject::IMultiSurface::GetArea ( )

속해 있는 모든 면의 넓이의 합을 반환한다.

IPoint* sgObject::IMultiSurface::PointOnSurface ( )

MultiSurface 내에 존재하는 것이 보장되는 점 한 개를 가져온다.

반환값
점의 기하 포인터
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IMultiSurface
sgObject::IMultiSurface 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IMultiSurface (모든 상속된 멤버들도 포함합니다.)

Add([in] IGeometry *obj) | sgObject::IGeometryCollection
Centroid() | sgObject::IMultiSurface
Clone() | sgObject::IGeometry
Envelope() | sgObject::IGeometry
Extent2D([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY) | sgObject::IGeometry
Geometry([in] long index) | sgObject::IGeometryCollection
GetArea() | sgObject::IMultiSurface
GetDimension() | sgObject::IGeometry
GetGeometryType() | sgObject::IGeometry
GetNumGeometries() | sgObject::IGeometryCollection
GetSpatialOperator() | sgObject::IGeometry
GetSpatialReference() | sgObject::IGeometry
GetSpatialRelation() | sgObject::IGeometry
GetSpatialRelation2() | sgObject::IGeometry
GetWks() | sgObject::IGeometry
IsEmpty() | sgObject::IGeometry
IsSimple() | sgObject::IGeometry
PointOnSurface() | sgObject::IMultiSurface
Project([in] ISpatialReference *newSystem) | sgObject::IGeometry
SetEmpty() | sgObject::IGeometry
SetSpatialReference(ISpatialReference *pVal) | sgObject::IGeometry
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IndexMapWidget 클래스 참조

  • IndexMapWidget
sgObject::IndexMapWidget 클래스 참조
sgObject::IndexMapWidget에 대한 협력 다이어그램:
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::INetworkCoverageAnalysis 인터페이스 참조

  • INetworkCoverageAnalysis
Public 멤버 함수 | 모든 멤버 목록
sgObject::INetworkCoverageAnalysis 인터페이스 참조

INetworkCoverageAnalysis 인터페이스는 네트워크 연산을 위해 사용된다. 더 자세히 ...

sgObject::INetworkCoverageAnalysis에 대한 상속 다이어그램 :
sgObject::INetworkCoverageAnalysis에 대한 협력 다이어그램:

Public 멤버 함수

VARIANT_BOOL | Initialize ([in]IFeatureCollection *dspEdgeFtCol, [in, defaultvalue("")] BSTR dspStNodeFieldInEdgeLayer, [in, defaultvalue("")] BSTR strEdNodeFieldInEdgeLayer, [in, defaultvalue(NULL)] IFeatureCollection *dspNodeFtCol, [in, defaultvalue(0)] double dBuffer, [in, defaultvalue(11)] int nFlag, [in, defaultvalue(NULL)] IParameters *dspPgsFunc)
네트워크를 검색하기 위한 초기 정보를 설정한다. 더 자세히 ...
VARIANT_BOOL | IsUsableSearch ()
네트워크 검색을 위한 그래프 생성 여부를 반환한다 더 자세히 ...
IFeatureCollection * | Search ([in] IPoint *dspStPoint, [in] IPoint *dspEdPoint, [in] BSTR strWeight, [in] ISymbolizer *dspSymbol, [in] VARIANT_BOOL bAppend, [in, defaultvalue(TRUE)] VARIANT_BOOL bLowWeight, [in, defaultvalue(NULL)] IParameters *dspNodeWeightFunc)
초기화된 네트워크로 부터 주어진 가중치에 따라 검색한다. 더 자세히 ...
VARIANT_BOOL | CreateNodeFeatureLayer ([in] BSTR dspStNodeFieldInEdgeLayer, [in] BSTR strEdNodeFieldInEdgeLayer, [in] BSTR strNewNodeFtLayerName)
점 레이어를 생성한다. 더 자세히 ...

상세한 설명

INetworkCoverageAnalysis 인터페이스는 네트워크 연산을 위해 사용된다.

멤버 함수 문서화

VARIANT_BOOL sgObject::INetworkCoverageAnalysis::CreateNodeFeatureLayer | ( | [in] BSTR | dspStNodeFieldInEdgeLayer,
 |  | [in] BSTR | strEdNodeFieldInEdgeLayer,
 |  | [in] BSTR | strNewNodeFtLayerName
 | ) |  |

점 레이어를 생성한다.

매개변수
dspStNodeFieldInEdgeLayer | - 선형정보 레이어의 시작점 노드 필드 정보
strEdNodeFieldInEdgeLayer | - 선형정보 레이어의 끝점 노드 필드 정보
strNewNodeFtLayerName | - 네트워크 점 정보 레이어 이름
반환값
점 세이어 생성 여부
VARIANT_BOOL sgObject::INetworkCoverageAnalysis::Initialize | ( | [in] IFeatureCollection * | dspEdgeFtCol,
 |  | [in, defaultvalue("")] BSTR | dspStNodeFieldInEdgeLayer,
 |  | [in, defaultvalue("")] BSTR | strEdNodeFieldInEdgeLayer,
 |  | [in, defaultvalue(NULL)] IFeatureCollection * | dspNodeFtCol,
 |  | [in, defaultvalue(0)] double | dBuffer,
 |  | [in, defaultvalue(11)] int | nFlag,
 |  | [in, defaultvalue(NULL)] IParameters * | dspPgsFunc
 | ) |  |

네트워크를 검색하기 위한 초기 정보를 설정한다.

매개변수
dspEdgeFtCol | - 네트워크 선형정보 리스트
dspStNodeFieldInEdgeLayer | - 선형정보 레이어의 시작점 노드 필드 정보 [옵션]
strEdNodeFieldInEdgeLayer | - 선형정보 레이어의 끝점 노드 필드 정보 [옵션]
dspNodeFtCol | - 네트워크 점 정보 리스트 [옵션]
dBuffer | - 선정정보 레이어의 시작/끝점 노드 필드가 없을 때 선형간 공간 검색할 거리 [옵션]
nFlag | - 검색대상 플래그 (Node(1), Vertex(2), Nearest(8)) [옵션]
dspPgsFunc | - 초기화 진행 상황 [옵션]
반환값
네트워크 검색을 위한 그래프 생성 여부
VARIANT_BOOL sgObject::INetworkCoverageAnalysis::IsUsableSearch ( )

네트워크 검색을 위한 그래프 생성 여부를 반환한다

IFeatureCollection* sgObject::INetworkCoverageAnalysis::Search | ( | [in] IPoint * | dspStPoint,
 |  | [in] IPoint * | dspEdPoint,
 |  | [in] BSTR | strWeight,
 |  | [in] ISymbolizer * | dspSymbol,
 |  | [in] VARIANT_BOOL | bAppend,
 |  | [in, defaultvalue(TRUE)] VARIANT_BOOL | bLowWeight,
 |  | [in, defaultvalue(NULL)] IParameters * | dspNodeWeightFunc
 | ) |  |

초기화된 네트워크로 부터 주어진 가중치에 따라 검색한다.

매개변수
dspStPoint | - 검색을 위한 시작점 정보
dspEdPoint | - 검색을 위한 종료 정보
strWeight | - 최단거리 검색을 위해 사용되는 가중치 값으로 선형정보 레이어의 속성 표현식
dspSymbol | - 검색된 결과의 저장 FeatureLayer의 스타일 설정
bAppend | - 검색 결과의 기본 저장 레이어(Temp...._search)에 기존 결과를 초기화 또는 추가 여부
bLowWeight | - 검색시 가중치 값의 최소값을 기준으로 검색 여부
dspNodeWeightFunc | - 가중치 산정을 위한 외부 함수 설정
반환값
네트워크 검색 결과가 저장된 임시레이어의 결과 피쳐들
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • INetworkCoverageAnalysis
sgObject::INetworkCoverageAnalysis 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::INetworkCoverageAnalysis (모든 상속된 멤버들도 포함합니다.)

CreateNodeFeatureLayer([in] BSTR dspStNodeFieldInEdgeLayer, [in] BSTR strEdNodeFieldInEdgeLayer, [in] BSTR strNewNodeFtLayerName) | sgObject::INetworkCoverageAnalysis
Initialize([in]IFeatureCollection *dspEdgeFtCol, [in, defaultvalue("")] BSTR dspStNodeFieldInEdgeLayer, [in, defaultvalue("")] BSTR strEdNodeFieldInEdgeLayer, [in, defaultvalue(NULL)] IFeatureCollection *dspNodeFtCol, [in, defaultvalue(0)] double dBuffer, [in, defaultvalue(11)] int nFlag, [in, defaultvalue(NULL)] IParameters *dspPgsFunc) | sgObject::INetworkCoverageAnalysis
IsUsableSearch() | sgObject::INetworkCoverageAnalysis
Search([in] IPoint *dspStPoint, [in] IPoint *dspEdPoint, [in] BSTR strWeight, [in] ISymbolizer *dspSymbol, [in] VARIANT_BOOL bAppend, [in, defaultvalue(TRUE)] VARIANT_BOOL bLowWeight, [in, defaultvalue(NULL)] IParameters *dspNodeWeightFunc) | sgObject::INetworkCoverageAnalysis
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IParameter 인터페이스 참조

  • IParameter
Public 멤버 함수 | 모든 멤버 목록
sgObject::IParameter 인터페이스 참조

IParameter 인터페이스 더 자세히 ...

sgObject::IParameter에 대한 상속 다이어그램 :
sgObject::IParameter에 대한 협력 다이어그램:

Public 멤버 함수

BSTR | GetName ()
파라메터 이름 더 자세히 ...
void | SetName ([in] BSTR name)
VARIANT | GetValue ()
파라메터 값 더 자세히 ...
void | SetValue ([in] VARIANT val)
IParameter * GetParent ()
부모객체 파라메터 더 자세히 ...
void | SetParent ([in] IParameter *pParent)
VariantTypeEnum GetType ()
파라메터 타입 더 자세히 ...
void | SetType ([in] VariantTypeEnum eType)
VARIANT_BOOL | GetBool ()
참/거짓형 변수 더 자세히 ...
void | SetBool ([in] VARIANT_BOOL bVal)
int | GetInt ()
정수형 변수 더 자세히 ...
void | SetInt ([in] int nVal)
short | GetShort ()
Short형 변수 더 자세히 ...
void | SetShort ([in] short iVal)
long | GetLong ()
Long형 변수 더 자세히 ...
void | SetLong ([in] long lVal)
float | GetFloat ()
Float형 변수 더 자세히 ...
void | SetFloat ([in] float fVal)
double | GetDouble ()
Double형 변수 더 자세히 ...
void | SetDouble ([in] double dVal)
BSTR | GetString ()
문자형 변수 더 자세히 ...
void | SetString ([in] BSTR szVal)
IParameter * Clone ()
해당 파라메터와 동일한 파라메터를 생성하여 가져온다. 더 자세히 ...
void | Clear ()
파라메터의 내용을 비우고 초기화한다. 더 자세히 ...

상세한 설명

IParameter 인터페이스

C API(linux, iOS, MacOS 등) : 중간이름 "PT"를 덧붙여서 "OGR_PT_"+메소드명으로 사용할 수 있습니다.
Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Parameter"

멤버 함수 문서화

void sgObject::IParameter::Clear ( )

파라메터의 내용을 비우고 초기화한다.

IParameter* sgObject::IParameter::Clone ( )

해당 파라메터와 동일한 파라메터를 생성하여 가져온다.

VARIANT_BOOL sgObject::IParameter::GetBool ( )

참/거짓형 변수

double sgObject::IParameter::GetDouble ( )

Double형 변수

float sgObject::IParameter::GetFloat ( )

Float형 변수

int sgObject::IParameter::GetInt ( )

정수형 변수

long sgObject::IParameter::GetLong ( )

Long형 변수

BSTR sgObject::IParameter::GetName ( )

파라메터 이름

IParameter* sgObject::IParameter::GetParent ( )

부모객체 파라메터

short sgObject::IParameter::GetShort ( )

Short형 변수

BSTR sgObject::IParameter::GetString ( )

문자형 변수

VariantTypeEnum sgObject::IParameter::GetType ( )

파라메터 타입

VARIANT sgObject::IParameter::GetValue ( )

파라메터 값

void sgObject::IParameter::SetBool ( [in] VARIANT_BOOL bVal )
void sgObject::IParameter::SetDouble ( [in] double dVal )
void sgObject::IParameter::SetFloat ( [in] float fVal )
void sgObject::IParameter::SetInt ( [in] int nVal )
void sgObject::IParameter::SetLong ( [in] long lVal )
void sgObject::IParameter::SetName ( [in] BSTR name )
void sgObject::IParameter::SetParent ( [in] IParameter * pParent )
void sgObject::IParameter::SetShort ( [in] short iVal )
void sgObject::IParameter::SetString ( [in] BSTR szVal )
void sgObject::IParameter::SetType ( [in] VariantTypeEnum eType )
void sgObject::IParameter::SetValue ( [in] VARIANT val )
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IParameter
sgObject::IParameter 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IParameter (모든 상속된 멤버들도 포함합니다.)

Clear() | sgObject::IParameter
Clone() | sgObject::IParameter
GetBool() | sgObject::IParameter
GetDouble() | sgObject::IParameter
GetFloat() | sgObject::IParameter
GetInt() | sgObject::IParameter
GetLong() | sgObject::IParameter
GetName() | sgObject::IParameter
GetParent() | sgObject::IParameter
GetShort() | sgObject::IParameter
GetString() | sgObject::IParameter
GetType() | sgObject::IParameter
GetValue() | sgObject::IParameter
SetBool([in] VARIANT_BOOL bVal) | sgObject::IParameter
SetDouble([in] double dVal) | sgObject::IParameter
SetFloat([in] float fVal) | sgObject::IParameter
SetInt([in] int nVal) | sgObject::IParameter
SetLong([in] long lVal) | sgObject::IParameter
SetName([in] BSTR name) | sgObject::IParameter
SetParent([in] IParameter *pParent) | sgObject::IParameter
SetShort([in] short iVal) | sgObject::IParameter
SetString([in] BSTR szVal) | sgObject::IParameter
SetType([in] VariantTypeEnum eType) | sgObject::IParameter
SetValue([in] VARIANT val) | sgObject::IParameter
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IParameterInfo 인터페이스 참조

  • IParameterInfo
Public 멤버 함수 | 모든 멤버 목록
sgObject::IParameterInfo 인터페이스 참조

IParameterInfo 인터페이스 더 자세히 ...

sgObject::IParameterInfo에 대한 상속 다이어그램 :
sgObject::IParameterInfo에 대한 협력 다이어그램:

Public 멤버 함수

BSTR | GetName ()
파라메터 이름 더 자세히 ...
BSTR | GetDescription ()
파라메터 설명 더 자세히 ...
ParameterType GetType ()
파라메터 타입 더 자세히 ...
VARIANT | GetDefaultValue ()
파라메터 디폴트값 더 자세히 ...
VARIANT | GetMinimumValue ()
파라메터 최소값 더 자세히 ...
VARIANT | GetMaximumValue ()
파라메터 최대값 더 자세히 ...

상세한 설명

IParameterInfo 인터페이스

C API(linux, iOS, MacOS 등) : 중간이름 "PTI"를 덧붙여서 "OGR_PTI_"+메소드명으로 사용할 수 있습니다.
Java(SWT, Android) Package명 : "net.sgsrc.map.jni.ParameterInfo"

멤버 함수 문서화

VARIANT sgObject::IParameterInfo::GetDefaultValue ( )

파라메터 디폴트값

BSTR sgObject::IParameterInfo::GetDescription ( )

파라메터 설명

VARIANT sgObject::IParameterInfo::GetMaximumValue ( )

파라메터 최대값

VARIANT sgObject::IParameterInfo::GetMinimumValue ( )

파라메터 최소값

BSTR sgObject::IParameterInfo::GetName ( )

파라메터 이름

ParameterType sgObject::IParameterInfo::GetType ( )

파라메터 타입

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IParameterInfo
sgObject::IParameterInfo 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IParameterInfo (모든 상속된 멤버들도 포함합니다.)

GetDefaultValue() | sgObject::IParameterInfo
GetDescription() | sgObject::IParameterInfo
GetMaximumValue() | sgObject::IParameterInfo
GetMinimumValue() | sgObject::IParameterInfo
GetName() | sgObject::IParameterInfo
GetType() | sgObject::IParameterInfo
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IParameters 인터페이스 참조

  • IParameters
Public 멤버 함수 | 모든 멤버 목록
sgObject::IParameters 인터페이스 참조

IParameters 인터페이스 더 자세히 ...

sgObject::IParameters에 대한 상속 다이어그램 :
sgObject::IParameters에 대한 협력 다이어그램:

Public 멤버 함수

long | GetSize ()
IParameter * | GetParameter ([in] BSTR name)
IParameter * | AddParameter ([in] IParameter *param)

상세한 설명

IParameters 인터페이스

C API(linux, iOS, MacOS 등) : 중간이름 "PTS"를 덧붙여서 "OGR_PTS_"+메소드명으로 사용할 수 있습니다.
Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Parameters"

멤버 함수 문서화

IParameter* sgObject::IParameters::AddParameter ( [in] IParameter * param )
IParameter* sgObject::IParameters::GetParameter ( [in] BSTR name )
long sgObject::IParameters::GetSize ( )
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IParameters
sgObject::IParameters 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IParameters (모든 상속된 멤버들도 포함합니다.)

AddParameter([in] IParameter *param) | sgObject::IParameters
GetParameter([in] BSTR name) | sgObject::IParameters
GetSize() | sgObject::IParameters
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IPoint 인터페이스 참조

  • IPoint
Public 멤버 함수 | 모든 멤버 목록
sgObject::IPoint 인터페이스 참조

기하 명세에 정의된 점에 대한 일반적인 인터페이스를 제공한다. 더 자세히 ...

sgObject::IPoint에 대한 상속 다이어그램 :
sgObject::IPoint에 대한 협력 다이어그램:

Public 멤버 함수

double | GetX ()
점의 x좌표를 설정한다. 더 자세히 ...
void | SetX (double dX)
double | GetY ()
점의 y좌표를 설정한다. 더 자세히 ...
void | SetY (double dY)
void | Coords ([out] double *x, [out] double *y)
점의 x, y 좌표를 가져온다. 더 자세히 ...
- sgObject::IGeometry(으)로부터 상속된 Public 멤버 함수
long | GetDimension ()
Geometry 객체의 차원 (0, 1, 2차원) 이다. 더 자세히 ...
ISpatialReference * GetSpatialReference ()
Geometry 객체가 참조하는 공간참조체계 (좌표체계) 이다. 더 자세히 ...
void | SetSpatialReference (ISpatialReference *pVal)
VARIANT_BOOL | IsEmpty ()
비어있는 Geometry 객체인지 나타낸다 (일반 프로그래밍 시 변수의 NULL과 유사) 더 자세히 ...
VARIANT_BOOL | IsSimple ()
기하가 심플한지 여부를 나타낸다. 더 자세히 ...
GeometryTypeEnum GetGeometryType ()
Geometry 객체의 구체적인 타입이다. 더 자세히 ...
void | SetEmpty ()
기하를 비어있는 기하로 만든다. 더 자세히 ...
IGeometry * Envelope ()
기하를 감싸는 최소 직사각형을 가져온다. 더 자세히 ...
IGeometry * Clone ()
해당 기하와 동일한 객체를 생성하여 가져온다. 더 자세히 ...
IGeometry * | Project ([in] ISpatialReference *newSystem)
기하를 새로운 공간참조체계로 투영해 만든 새로운 기하를 가져온다. 더 자세히 ...
void | Extent2D ([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY)
기하를 감싸는 최소 직사각형의 x, y 좌표를 Output 변수에 가져온다. 더 자세히 ...
IWks * GetWks ()
ISpatialRelation * GetSpatialRelation ()
ISpatialRelation2 * GetSpatialRelation2 ()
ISpatialOperator * GetSpatialOperator ()

상세한 설명

기하 명세에 정의된 점에 대한 일반적인 인터페이스를 제공한다.

즉, 좌표에 접근하고 점 객체를 측정하기 위한 메소드를 정의한다. Point에 대한 정의 및 기타 정보는 Knowledge Base의 Geometry를 참고한다.
C API(linux, iOS, MacOS 등) : 중간이름 "G"를 덧붙여서 "OGR_G_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Geometry"

멤버 함수 문서화

void sgObject::IPoint::Coords | ( | [out] double * | x,
 |  | [out] double * | y
 | ) |  |

점의 x, y 좌표를 가져온다.

매개변수
x | - x 좌표(x 좌표값을 넣을 출력 변수)
y | - y 좌표(y 좌표값을 넣을 출력 변수)
double sgObject::IPoint::GetX ( )

점의 x좌표를 설정한다.

double sgObject::IPoint::GetY ( )

점의 y좌표를 설정한다.

void sgObject::IPoint::SetX ( double dX )
void sgObject::IPoint::SetY ( double dY )
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IPoint
sgObject::IPoint 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IPoint (모든 상속된 멤버들도 포함합니다.)

Clone() | sgObject::IGeometry
Coords([out] double *x, [out] double *y) | sgObject::IPoint
Envelope() | sgObject::IGeometry
Extent2D([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY) | sgObject::IGeometry
GetDimension() | sgObject::IGeometry
GetGeometryType() | sgObject::IGeometry
GetSpatialOperator() | sgObject::IGeometry
GetSpatialReference() | sgObject::IGeometry
GetSpatialRelation() | sgObject::IGeometry
GetSpatialRelation2() | sgObject::IGeometry
GetWks() | sgObject::IGeometry
GetX() | sgObject::IPoint
GetY() | sgObject::IPoint
IsEmpty() | sgObject::IGeometry
IsSimple() | sgObject::IGeometry
Project([in] ISpatialReference *newSystem) | sgObject::IGeometry
SetEmpty() | sgObject::IGeometry
SetSpatialReference(ISpatialReference *pVal) | sgObject::IGeometry
SetX(double dX) | sgObject::IPoint
SetY(double dY) | sgObject::IPoint
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IPointSymbol 인터페이스 참조

  • IPointSymbol
Public 멤버 함수 | 모든 멤버 목록
sgObject::IPointSymbol 인터페이스 참조

Feature 객체를 화면에 표시하기 위해 심볼이 필요할 수도 있는데 IPointSymbol 인터페이스는 이 중 벡터 타입의 심볼 정보를 관리하는 PointSymbol 객체의 인터페이스를 제공한다. 더 자세히 ...

sgObject::IPointSymbol에 대한 상속 다이어그램 :
sgObject::IPointSymbol에 대한 협력 다이어그램:

Public 멤버 함수

IGeometry * GetGeometry ()
void | SetGeometry ([in] IGeometry *disp)
- sgObject::ISymbol(으)로부터 상속된 Public 멤버 함수
BSTR | GetName ()
심볼의 이름 더 자세히 ...
BSTR | GetTitle ()
심볼의 제목 더 자세히 ...
BSTR | GetAbstract ()
심볼의 추상 개념 더 자세히 ...
SymbolTypeEnum GetSymbolType ()
관리하는 심볼의 타입 (이미지, 벡터) 더 자세히 ...

상세한 설명

Feature 객체를 화면에 표시하기 위해 심볼이 필요할 수도 있는데 IPointSymbol 인터페이스는 이 중 벡터 타입의 심볼 정보를 관리하는 PointSymbol 객체의 인터페이스를 제공한다.

멤버 함수 문서화

IGeometry* sgObject::IPointSymbol::GetGeometry ( )
void sgObject::IPointSymbol::SetGeometry ( [in] IGeometry * disp )
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IPointSymbol
sgObject::IPointSymbol 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IPointSymbol (모든 상속된 멤버들도 포함합니다.)

GetAbstract() | sgObject::ISymbol
GetGeometry() | sgObject::IPointSymbol
GetName() | sgObject::ISymbol
GetSymbolType() | sgObject::ISymbol
GetTitle() | sgObject::ISymbol
SetGeometry([in] IGeometry *disp) | sgObject::IPointSymbol
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IPointSymbolizer 인터페이스 참조

  • IPointSymbolizer
모든 멤버 목록
sgObject::IPointSymbolizer 인터페이스 참조

심볼의 스타일을 표현하는 방법 및 속성을 기술한다. 더 자세히 ...

sgObject::IPointSymbolizer에 대한 상속 다이어그램 :
sgObject::IPointSymbolizer에 대한 협력 다이어그램:

추가로 상속된 멤버들

- sgObject::ISymbolizer(으)로부터 상속된 Public 멤버 함수
BSTR | GetName ()
Symbolizer 이름을 반환한다. (시스템에서 사용할 이름) 더 자세히 ...
void | SetName (BSTR bstrName)
Symbolizer 이름을 설정한다. (시스템에서 사용할 이름) 더 자세히 ...
double | GetMinScaleDenominator ()
화면에 표시할 때 Scale down할 수 있는 최소값을 반환한다. 더 자세히 ...
void | SetMinScaleDenominator (double dScale)
화면에 표시할 때 Scale down할 수 있는 최소값을 설정한다. 더 자세히 ...
double | GetMaxScaleDenominator ()
화면에 표시할 때 Scale up할 수 있는 최대값을 반환한다. 더 자세히 ...
void | SetMaxScaleDenominator (double dScale)
화면에 표시할 때 Scale up할 수 있는 최대값을 설정한다. 더 자세히 ...
void | AddStyleFromString (VARIANT vtIdx, BSTR bstrStyle)
해당 인덱스로 그래픽스타일을 추가한다. 더 자세히 ...
int | RemoveStyle (VARIANT vtIdx)
해당 인덱스의 그래픽스타일을 제거한다. 더 자세히 ...
BSTR | GetStyleToString (VARIANT vtIdx)
해당 인덱스의 그래픽스타일을 가져온다. 더 자세히 ...
ISymbolizer * Clone ()
Symbolizer를 복사하여 새로운 Symbolizer를 생성한다. 더 자세히 ...
SymbolizerTypeEnum GetSymbolizerType ()
Symbolizer의 타입을 반환한다. 더 자세히 ...
void | SetSymbolizerType (SymbolizerTypeEnum eType)
Symbolizer의 타입을 설정한다. 더 자세히 ...
IStroke * | GetStroke (BSTR bstrName)
라인 스타일 객체를 반환한다. 더 자세히 ...
IStroke * | SetStroke (BSTR bstrName, IStroke *poVal)
라인 스타일 객체를 설정한다. 더 자세히 ...
IFill * | GetFill (BSTR bstrName)
면 스타일 객체를 반환한다. 더 자세히 ...
IFill * | SetFill (BSTR bstrName, IFill *poVal)
면 스타일 객체를 설정한다. 더 자세히 ...
IMark * | GetMark (BSTR bstrName)
심볼 스타일 객체를 반환한다. 더 자세히 ...
IMark * | SetMark (BSTR bstrName, IMark *poVal)
심볼 스타일 객체를 설정한다. 더 자세히 ...
IFont * | GetFont (BSTR bstrName)
글꼴 스타일 객체를 반환한다. 더 자세히 ...
IFont * | SetFont (BSTR bstrName, IFont *poVal)
글꼴 스타일 객체를 설정한다. 더 자세히 ...

상세한 설명

심볼의 스타일을 표현하는 방법 및 속성을 기술한다.

C API(linux, iOS, MacOS 등) : 중간이름 "SL"를 덧붙여서 "OGR_SL_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Symbolizer"

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IPointSymbolizer
sgObject::IPointSymbolizer 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IPointSymbolizer (모든 상속된 멤버들도 포함합니다.)

AddStyleFromString(VARIANT vtIdx, BSTR bstrStyle) | sgObject::ISymbolizer
Clone() | sgObject::ISymbolizer
GetFill(BSTR bstrName) | sgObject::ISymbolizer
GetFont(BSTR bstrName) | sgObject::ISymbolizer
GetMark(BSTR bstrName) | sgObject::ISymbolizer
GetMaxScaleDenominator() | sgObject::ISymbolizer
GetMinScaleDenominator() | sgObject::ISymbolizer
GetName() | sgObject::ISymbolizer
GetStroke(BSTR bstrName) | sgObject::ISymbolizer
GetStyleToString(VARIANT vtIdx) | sgObject::ISymbolizer
GetSymbolizerType() | sgObject::ISymbolizer
RemoveStyle(VARIANT vtIdx) | sgObject::ISymbolizer
SetFill(BSTR bstrName, IFill *poVal) | sgObject::ISymbolizer
SetFont(BSTR bstrName, IFont *poVal) | sgObject::ISymbolizer
SetMark(BSTR bstrName, IMark *poVal) | sgObject::ISymbolizer
SetMaxScaleDenominator(double dScale) | sgObject::ISymbolizer
SetMinScaleDenominator(double dScale) | sgObject::ISymbolizer
SetName(BSTR bstrName) | sgObject::ISymbolizer
SetStroke(BSTR bstrName, IStroke *poVal) | sgObject::ISymbolizer
SetSymbolizerType(SymbolizerTypeEnum eType) | sgObject::ISymbolizer
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IPointZ 인터페이스 참조

  • IPointZ
Public 멤버 함수 | 모든 멤버 목록
sgObject::IPointZ 인터페이스 참조

기하 명세에 정의된 Point를 3차원으로 확장하기 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::IPointZ에 대한 상속 다이어그램 :
sgObject::IPointZ에 대한 협력 다이어그램:

Public 멤버 함수

double | GetZ ()
점의 높이(고도)인 z 좌표를 설정한다. 더 자세히 ...
void | SetZ (double dZ)
- sgObject::IPoint(으)로부터 상속된 Public 멤버 함수
double | GetX ()
점의 x좌표를 설정한다. 더 자세히 ...
void | SetX (double dX)
double | GetY ()
점의 y좌표를 설정한다. 더 자세히 ...
void | SetY (double dY)
void | Coords ([out] double *x, [out] double *y)
점의 x, y 좌표를 가져온다. 더 자세히 ...
- sgObject::IGeometry(으)로부터 상속된 Public 멤버 함수
long | GetDimension ()
Geometry 객체의 차원 (0, 1, 2차원) 이다. 더 자세히 ...
ISpatialReference * GetSpatialReference ()
Geometry 객체가 참조하는 공간참조체계 (좌표체계) 이다. 더 자세히 ...
void | SetSpatialReference (ISpatialReference *pVal)
VARIANT_BOOL | IsEmpty ()
비어있는 Geometry 객체인지 나타낸다 (일반 프로그래밍 시 변수의 NULL과 유사) 더 자세히 ...
VARIANT_BOOL | IsSimple ()
기하가 심플한지 여부를 나타낸다. 더 자세히 ...
GeometryTypeEnum GetGeometryType ()
Geometry 객체의 구체적인 타입이다. 더 자세히 ...
void | SetEmpty ()
기하를 비어있는 기하로 만든다. 더 자세히 ...
IGeometry * Envelope ()
기하를 감싸는 최소 직사각형을 가져온다. 더 자세히 ...
IGeometry * Clone ()
해당 기하와 동일한 객체를 생성하여 가져온다. 더 자세히 ...
IGeometry * | Project ([in] ISpatialReference *newSystem)
기하를 새로운 공간참조체계로 투영해 만든 새로운 기하를 가져온다. 더 자세히 ...
void | Extent2D ([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY)
기하를 감싸는 최소 직사각형의 x, y 좌표를 Output 변수에 가져온다. 더 자세히 ...
IWks * GetWks ()
ISpatialRelation * GetSpatialRelation ()
ISpatialRelation2 * GetSpatialRelation2 ()
ISpatialOperator * GetSpatialOperator ()

상세한 설명

기하 명세에 정의된 Point를 3차원으로 확장하기 위한 인터페이스를 제공한다.

3차원 입체 기하에 대한 지원은 향후 버전에서 확장할 예정이다. C API(linux, iOS, MacOS 등) : 중간이름 "G"를 덧붙여서 "OGR_G_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Geometry"

멤버 함수 문서화

double sgObject::IPointZ::GetZ ( )

점의 높이(고도)인 z 좌표를 설정한다.

void sgObject::IPointZ::SetZ ( double dZ )
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IPointZ
sgObject::IPointZ 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IPointZ (모든 상속된 멤버들도 포함합니다.)

Clone() | sgObject::IGeometry
Coords([out] double *x, [out] double *y) | sgObject::IPoint
Envelope() | sgObject::IGeometry
Extent2D([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY) | sgObject::IGeometry
GetDimension() | sgObject::IGeometry
GetGeometryType() | sgObject::IGeometry
GetSpatialOperator() | sgObject::IGeometry
GetSpatialReference() | sgObject::IGeometry
GetSpatialRelation() | sgObject::IGeometry
GetSpatialRelation2() | sgObject::IGeometry
GetWks() | sgObject::IGeometry
GetX() | sgObject::IPoint
GetY() | sgObject::IPoint
GetZ() | sgObject::IPointZ
IsEmpty() | sgObject::IGeometry
IsSimple() | sgObject::IGeometry
Project([in] ISpatialReference *newSystem) | sgObject::IGeometry
SetEmpty() | sgObject::IGeometry
SetSpatialReference(ISpatialReference *pVal) | sgObject::IGeometry
SetX(double dX) | sgObject::IPoint
SetY(double dY) | sgObject::IPoint
SetZ(double dZ) | sgObject::IPointZ
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IPolygon 인터페이스 참조

  • IPolygon
Public 멤버 함수 | 모든 멤버 목록
sgObject::IPolygon 인터페이스 참조

기하 명세에 정의된 Polygon에 대한 일반적인 인터페이스를 제공한다. 더 자세히 ...

sgObject::IPolygon에 대한 상속 다이어그램 :
sgObject::IPolygon에 대한 협력 다이어그램:

Public 멤버 함수

long | GetNumInteriorRings ()
내부 LinearRing의 개수를 반환한다. 더 자세히 ...
ILinearRing * ExteriorRing ()
외부 LinearRing을 가져온다. 더 자세히 ...
ILinearRing * | InteriorRing ([in] long index)
해당 인덱스의 내부 LinearRing을 가져온다. 더 자세히 ...
ISurface * GetSurface ()
Surface 객체로 형 변환한다. 더 자세히 ...
VARIANT_BOOL | IsPointOnSurface ([in] IPoint *dspPt)
해당 점이 내부에 포함되는지 여부를 반환한다. 더 자세히 ...
- sgObject::ISurface(으)로부터 상속된 Public 멤버 함수
double | GetArea ()
면의 넓이를 반환한다. 더 자세히 ...
IPoint * Centroid ()
면의 수학적 중심점을 가져온다. 더 자세히 ...
IPoint * PointOnSurface ()
면 내에 존재하는 것이 보장되는 점 한 개를 가져온다. 더 자세히 ...
- sgObject::IGeometry(으)로부터 상속된 Public 멤버 함수
long | GetDimension ()
Geometry 객체의 차원 (0, 1, 2차원) 이다. 더 자세히 ...
ISpatialReference * GetSpatialReference ()
Geometry 객체가 참조하는 공간참조체계 (좌표체계) 이다. 더 자세히 ...
void | SetSpatialReference (ISpatialReference *pVal)
VARIANT_BOOL | IsEmpty ()
비어있는 Geometry 객체인지 나타낸다 (일반 프로그래밍 시 변수의 NULL과 유사) 더 자세히 ...
VARIANT_BOOL | IsSimple ()
기하가 심플한지 여부를 나타낸다. 더 자세히 ...
GeometryTypeEnum GetGeometryType ()
Geometry 객체의 구체적인 타입이다. 더 자세히 ...
void | SetEmpty ()
기하를 비어있는 기하로 만든다. 더 자세히 ...
IGeometry * Envelope ()
기하를 감싸는 최소 직사각형을 가져온다. 더 자세히 ...
IGeometry * Clone ()
해당 기하와 동일한 객체를 생성하여 가져온다. 더 자세히 ...
IGeometry * | Project ([in] ISpatialReference *newSystem)
기하를 새로운 공간참조체계로 투영해 만든 새로운 기하를 가져온다. 더 자세히 ...
void | Extent2D ([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY)
기하를 감싸는 최소 직사각형의 x, y 좌표를 Output 변수에 가져온다. 더 자세히 ...
IWks * GetWks ()
ISpatialRelation * GetSpatialRelation ()
ISpatialRelation2 * GetSpatialRelation2 ()
ISpatialOperator * GetSpatialOperator ()

상세한 설명

기하 명세에 정의된 Polygon에 대한 일반적인 인터페이스를 제공한다.

클라이언트가 폴리곤 내의 링에 대한 정보를 얻을 수 있도록 한다. Polygon은 한 개의 외부 LinearRing과 0 개 이상의 내부 LinearRing으로 이루어진 면이다. 내부 LinearRing은 면 내부의 구멍을 의미한다. Polygon 내의 모든 점들은 서로 연결되어 있다. (즉, 연결된 점들의 집합이다) Polygon에 대한 정의 및 기타 정보는 Knowledge Base의 Geometry를 참고한다. C API(linux, iOS, MacOS 등) : 중간이름 "G"를 덧붙여서 "OGR_G_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Geometry"

멤버 함수 문서화

ILinearRing* sgObject::IPolygon::ExteriorRing ( )

외부 LinearRing을 가져온다.

반환값
LinearRing의 기하 포인터
long sgObject::IPolygon::GetNumInteriorRings ( )

내부 LinearRing의 개수를 반환한다.

ISurface* sgObject::IPolygon::GetSurface ( )

Surface 객체로 형 변환한다.

반환값
형 변환 객체(자신)
ILinearRing* sgObject::IPolygon::InteriorRing ( [in] long index )

해당 인덱스의 내부 LinearRing을 가져온다.

매개변수
index - 인덱스 번호
반환값
LinearRing의 기하 포인터
VARIANT_BOOL sgObject::IPolygon::IsPointOnSurface ( [in] IPoint * dspPt )

해당 점이 내부에 포함되는지 여부를 반환한다.

매개변수
dspPt - 점 객체
반환값
포함여부
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IPolygon
sgObject::IPolygon 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IPolygon (모든 상속된 멤버들도 포함합니다.)

Centroid() | sgObject::ISurface
Clone() | sgObject::IGeometry
Envelope() | sgObject::IGeometry
Extent2D([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY) | sgObject::IGeometry
ExteriorRing() | sgObject::IPolygon
GetArea() | sgObject::ISurface
GetDimension() | sgObject::IGeometry
GetGeometryType() | sgObject::IGeometry
GetNumInteriorRings() | sgObject::IPolygon
GetSpatialOperator() | sgObject::IGeometry
GetSpatialReference() | sgObject::IGeometry
GetSpatialRelation() | sgObject::IGeometry
GetSpatialRelation2() | sgObject::IGeometry
GetSurface() | sgObject::IPolygon
GetWks() | sgObject::IGeometry
InteriorRing([in] long index) | sgObject::IPolygon
IsEmpty() | sgObject::IGeometry
IsPointOnSurface([in] IPoint *dspPt) | sgObject::IPolygon
IsSimple() | sgObject::IGeometry
PointOnSurface() | sgObject::ISurface
Project([in] ISpatialReference *newSystem) | sgObject::IGeometry
SetEmpty() | sgObject::IGeometry
SetSpatialReference(ISpatialReference *pVal) | sgObject::IGeometry
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IPolygonSymbolizer 인터페이스 참조

  • IPolygonSymbolizer
모든 멤버 목록
sgObject::IPolygonSymbolizer 인터페이스 참조

기하 내부 영역을 채우는 방법 및 속성을 기술한다. 더 자세히 ...

sgObject::IPolygonSymbolizer에 대한 상속 다이어그램 :
sgObject::IPolygonSymbolizer에 대한 협력 다이어그램:

추가로 상속된 멤버들

- sgObject::ISymbolizer(으)로부터 상속된 Public 멤버 함수
BSTR | GetName ()
Symbolizer 이름을 반환한다. (시스템에서 사용할 이름) 더 자세히 ...
void | SetName (BSTR bstrName)
Symbolizer 이름을 설정한다. (시스템에서 사용할 이름) 더 자세히 ...
double | GetMinScaleDenominator ()
화면에 표시할 때 Scale down할 수 있는 최소값을 반환한다. 더 자세히 ...
void | SetMinScaleDenominator (double dScale)
화면에 표시할 때 Scale down할 수 있는 최소값을 설정한다. 더 자세히 ...
double | GetMaxScaleDenominator ()
화면에 표시할 때 Scale up할 수 있는 최대값을 반환한다. 더 자세히 ...
void | SetMaxScaleDenominator (double dScale)
화면에 표시할 때 Scale up할 수 있는 최대값을 설정한다. 더 자세히 ...
void | AddStyleFromString (VARIANT vtIdx, BSTR bstrStyle)
해당 인덱스로 그래픽스타일을 추가한다. 더 자세히 ...
int | RemoveStyle (VARIANT vtIdx)
해당 인덱스의 그래픽스타일을 제거한다. 더 자세히 ...
BSTR | GetStyleToString (VARIANT vtIdx)
해당 인덱스의 그래픽스타일을 가져온다. 더 자세히 ...
ISymbolizer * Clone ()
Symbolizer를 복사하여 새로운 Symbolizer를 생성한다. 더 자세히 ...
SymbolizerTypeEnum GetSymbolizerType ()
Symbolizer의 타입을 반환한다. 더 자세히 ...
void | SetSymbolizerType (SymbolizerTypeEnum eType)
Symbolizer의 타입을 설정한다. 더 자세히 ...
IStroke * | GetStroke (BSTR bstrName)
라인 스타일 객체를 반환한다. 더 자세히 ...
IStroke * | SetStroke (BSTR bstrName, IStroke *poVal)
라인 스타일 객체를 설정한다. 더 자세히 ...
IFill * | GetFill (BSTR bstrName)
면 스타일 객체를 반환한다. 더 자세히 ...
IFill * | SetFill (BSTR bstrName, IFill *poVal)
면 스타일 객체를 설정한다. 더 자세히 ...
IMark * | GetMark (BSTR bstrName)
심볼 스타일 객체를 반환한다. 더 자세히 ...
IMark * | SetMark (BSTR bstrName, IMark *poVal)
심볼 스타일 객체를 설정한다. 더 자세히 ...
IFont * | GetFont (BSTR bstrName)
글꼴 스타일 객체를 반환한다. 더 자세히 ...
IFont * | SetFont (BSTR bstrName, IFont *poVal)
글꼴 스타일 객체를 설정한다. 더 자세히 ...

상세한 설명

기하 내부 영역을 채우는 방법 및 속성을 기술한다.

C API(linux, iOS, MacOS 등) : 중간이름 "SL"를 덧붙여서 "OGR_SL_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Symbolizer"

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IPolygonSymbolizer
sgObject::IPolygonSymbolizer 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IPolygonSymbolizer (모든 상속된 멤버들도 포함합니다.)

AddStyleFromString(VARIANT vtIdx, BSTR bstrStyle) | sgObject::ISymbolizer
Clone() | sgObject::ISymbolizer
GetFill(BSTR bstrName) | sgObject::ISymbolizer
GetFont(BSTR bstrName) | sgObject::ISymbolizer
GetMark(BSTR bstrName) | sgObject::ISymbolizer
GetMaxScaleDenominator() | sgObject::ISymbolizer
GetMinScaleDenominator() | sgObject::ISymbolizer
GetName() | sgObject::ISymbolizer
GetStroke(BSTR bstrName) | sgObject::ISymbolizer
GetStyleToString(VARIANT vtIdx) | sgObject::ISymbolizer
GetSymbolizerType() | sgObject::ISymbolizer
RemoveStyle(VARIANT vtIdx) | sgObject::ISymbolizer
SetFill(BSTR bstrName, IFill *poVal) | sgObject::ISymbolizer
SetFont(BSTR bstrName, IFont *poVal) | sgObject::ISymbolizer
SetMark(BSTR bstrName, IMark *poVal) | sgObject::ISymbolizer
SetMaxScaleDenominator(double dScale) | sgObject::ISymbolizer
SetMinScaleDenominator(double dScale) | sgObject::ISymbolizer
SetName(BSTR bstrName) | sgObject::ISymbolizer
SetStroke(BSTR bstrName, IStroke *poVal) | sgObject::ISymbolizer
SetSymbolizerType(SymbolizerTypeEnum eType) | sgObject::ISymbolizer
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IPrintLayoutItem 인터페이스 참조

  • IPrintLayoutItem
Public 멤버 함수 | 모든 멤버 목록
sgObject::IPrintLayoutItem 인터페이스 참조

출력창의 아이템을 제어하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::IPrintLayoutItem에 대한 상속 다이어그램 :
sgObject::IPrintLayoutItem에 대한 협력 다이어그램:

Public 멤버 함수

void | SetText ([in] BSTR text)
라벨객체의 문자를 설정한다. 더 자세히 ...
void | SetMapCenter ([in] double centerx, [in] double centery, [in] double scale)
지도객체의 중심점 위치 및 스케일을 조정한다. 스케일값이 0이하인 경우 중심점 위치만 설정한다. 더 자세히 ...
void | SetMapScale ([in] double scale)
지도객체의 스케일을 조정한다. 더 자세히 ...
void | SetMapRect ([in] double minx, [in] double miny, [in] double maxx, [in] double maxy)
지도객체의 보기 영역을 조정한다. 더 자세히 ...
void | SetMapRotation ([in] double angle)
지도객체의 회전을 조정한다. 더 자세히 ...
void | SetMapRelativeScale ([in] double scaleDenominator)
지도객체의 스케일을 조정한다. 더 자세히 ...
void | SetMapIndexPrintOption ([in] double scale, [in] double x, [in] double y, [in] VARIANT_BOOL bEnable)
지도객체의 스케일을 조정한다. 더 자세히 ...
void | SetImageFile ([in] BSTR filename)
이미지객체의 파일명을 설정한다. 더 자세히 ...
void | SetPosition ([in] double x, [in] double y, [in] AlignPositionEnum position, int page)
객체의 위치를 설정한다. position은 페이지에서 객체 위치의 기준점이며 page는 페이지번호로 기본 -1을 설정한다. 더 자세히 ...
void | Move ([in] double x, [in] double y, [in] double width, [in] double height, [in] AlignPositionEnum position, int page)
객체의 위치와 크기를 설정한다. position은 페이지에서 객체 위치의 기준점이며 page는 페이지번호로 기본 -1을 설정한다. 더 자세히 ...

상세한 설명

출력창의 아이템을 제어하는 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "PI"를 덧붙여서 "OGR_PI_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.PrintLayoutItem"

멤버 함수 문서화

void sgObject::IPrintLayoutItem::Move | ( | [in] double | x,
 |  | [in] double | y,
 |  | [in] double | width,
 |  | [in] double | height,
 |  | [in] AlignPositionEnum | position,
 |  | int | page
 | ) |  |

객체의 위치와 크기를 설정한다. position은 페이지에서 객체 위치의 기준점이며 page는 페이지번호로 기본 -1을 설정한다.

void sgObject::IPrintLayoutItem::SetImageFile ( [in] BSTR filename )

이미지객체의 파일명을 설정한다.

void sgObject::IPrintLayoutItem::SetMapCenter | ( | [in] double | centerx,
 |  | [in] double | centery,
 |  | [in] double | scale
 | ) |  |

지도객체의 중심점 위치 및 스케일을 조정한다. 스케일값이 0이하인 경우 중심점 위치만 설정한다.

void sgObject::IPrintLayoutItem::SetMapIndexPrintOption | ( | [in] double | scale,
 |  | [in] double | x,
 |  | [in] double | y,
 |  | [in] VARIANT_BOOL | bEnable
 | ) |  |

지도객체의 스케일을 조정한다.

void sgObject::IPrintLayoutItem::SetMapRect | ( | [in] double | minx,
 |  | [in] double | miny,
 |  | [in] double | maxx,
 |  | [in] double | maxy
 | ) |  |

지도객체의 보기 영역을 조정한다.

void sgObject::IPrintLayoutItem::SetMapRelativeScale ( [in] double scaleDenominator )

지도객체의 스케일을 조정한다.

void sgObject::IPrintLayoutItem::SetMapRotation ( [in] double angle )

지도객체의 회전을 조정한다.

void sgObject::IPrintLayoutItem::SetMapScale ( [in] double scale )

지도객체의 스케일을 조정한다.

void sgObject::IPrintLayoutItem::SetPosition | ( | [in] double | x,
 |  | [in] double | y,
 |  | [in] AlignPositionEnum | position,
 |  | int | page
 | ) |  |

객체의 위치를 설정한다. position은 페이지에서 객체 위치의 기준점이며 page는 페이지번호로 기본 -1을 설정한다.

void sgObject::IPrintLayoutItem::SetText ( [in] BSTR text )

라벨객체의 문자를 설정한다.

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IPrintLayoutItem
sgObject::IPrintLayoutItem 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IPrintLayoutItem (모든 상속된 멤버들도 포함합니다.)

Move([in] double x, [in] double y, [in] double width, [in] double height, [in] AlignPositionEnum position, int page) | sgObject::IPrintLayoutItem
SetImageFile([in] BSTR filename) | sgObject::IPrintLayoutItem
SetMapCenter([in] double centerx, [in] double centery, [in] double scale) | sgObject::IPrintLayoutItem
SetMapIndexPrintOption([in] double scale, [in] double x, [in] double y, [in] VARIANT_BOOL bEnable) | sgObject::IPrintLayoutItem
SetMapRect([in] double minx, [in] double miny, [in] double maxx, [in] double maxy) | sgObject::IPrintLayoutItem
SetMapRelativeScale([in] double scaleDenominator) | sgObject::IPrintLayoutItem
SetMapRotation([in] double angle) | sgObject::IPrintLayoutItem
SetMapScale([in] double scale) | sgObject::IPrintLayoutItem
SetPosition([in] double x, [in] double y, [in] AlignPositionEnum position, int page) | sgObject::IPrintLayoutItem
SetText([in] BSTR text) | sgObject::IPrintLayoutItem
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IPrintLayoutWidget 인터페이스 참조

  • IPrintLayoutWidget
Public 멤버 함수 | 모든 멤버 목록
sgObject::IPrintLayoutWidget 인터페이스 참조

출력창을 제어하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::IPrintLayoutWidget에 대한 상속 다이어그램 :
sgObject::IPrintLayoutWidget에 대한 협력 다이어그램:

Public 멤버 함수

VARIANT_BOOL | ReadXML ([in] BSTR filename)
출력폼 파일을 읽어 들인다. 더 자세히 ...
VARIANT_BOOL | WriteXML ([in] BSTR filename)
해당 출력폼 파일로 저장한다. 더 자세히 ...
VARIANT_BOOL | GetDisplayToolBarByType ([in] ToolBarTypeEnum eType)
ToolBarTypeEnum 에 해당하는 툴바 객체의 보이기 여부 더 자세히 ...
void | SetDisplayToolBarByType ([in] ToolBarTypeEnum eType, [in]VARIANT_BOOL bDisplay)
VARIANT_BOOL | GetDisplayMenuBar ()
메뉴바 객체의 보이기 여부 더 자세히 ...
void | SetDisplayMenuBar (VARIANT_BOOL bVal)
void | SetDisplayToolBar (VARIANT_BOOL bVal)
모든 툴바 객체의 보이기 여부 더 자세히 ...
void | DeleteToolBarByType ([in] ToolBarTypeEnum eType)
EditActionTypeEnum에 해당하는 툴바를 삭제한다. 더 자세히 ...
IPrintLayoutItem * | GetItem ([in] BSTR nameid)
ID에 해당하는 객체를 검색하여 반환한다. 더 자세히 ...
void | SetDisplayProperyWidget (VARIANT_BOOL bVal)
모든 속성도킹창 객체의 보이기 여부를 설정한다. 더 자세히 ...
void | SetKeyEnable ([in] SystemKeyEnum eType, [in] VARIANT_BOOL bEnable)
출력폼창 내에서 키보드 버튼의 사용여부를 설정한다. 더 자세히 ...
void | SetMouseButtonEnable ([in] MouseButtonTypeEnum eType, [in] VARIANT_BOOL bEnable)
출력폼창 내에서 마우스 버튼의 사용여부를 설정한다. 더 자세히 ...
void | Invalidate ()
출력폼창의 상태를 재설정한다. 더 자세히 ...
- sgObject::IWidget(으)로부터 상속된 Public 멤버 함수
void | Initialize ([in] ULONG_PTR h)
위젯 초기화 더 자세히 ...
void | ReSize ([in] int x, [in] int y, [in] int cx, [in] int cy)
위젯 객체의 크기를 재설정 한다. 더 자세히 ...
void | AddWidget ([in] IWidget *dspWidget)
현재 위젯에 하부로 위젯을 추가한다. 더 자세히 ...
void | AddWidgetByLayout ([in] IWidget *dspWidget, [in] int row, [in] int col)
현재 위젯에 종, 횡 위치에 위젯을 추가한다. 더 자세히 ...
void | SetQtUiObjectVisible ([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue)
위젯의 해당 오브젝트 객체의 보이기 여부를 설정한다. 더 자세히 ...
long | GetBackColor ()
위젯이 사용하는 배경 색상 정보 더 자세히 ...
void | SetBackColor ([in] long color)
void | SetCanvas (ICanvas *poCanvas)
위젯을 특정(2D, 3D, Earth 등) 지도창으로 설정한다. 더 자세히 ...
IFeatureCanvas * GetFeatureCanvas ()
위젯이 사용하는 FeatureCanvas 정보 더 자세히 ...
void | SetFeatureCanvas (IFeatureCanvas *poFtCvs)
void | SetFeatureLayer (IFeatureLayer *poFtLayer)
위젯이 사용하는 FeatureLayer 정보 더 자세히 ...
void | SetLayer (ILayer *poLayer)
위젯이 사용하는 레이어 정보 더 자세히 ...
BSTR | GetFlag ()
위젯이 사용하는 문자열 파라메터 정보 더 자세히 ...
void | SetFlag (BSTR bstrFlag)
void | SetWidth (int nWidth)
위젯의 가로크기를 설정한다. 더 자세히 ...
int | SetHeight (int nHeight)
위젯의 세로크기를 설정한다. 더 자세히 ...
void | Destroy ()

상세한 설명

출력창을 제어하는 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "PW"를 덧붙여서 "OGR_PW_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.PrintLayoutWidget"

멤버 함수 문서화

void sgObject::IPrintLayoutWidget::DeleteToolBarByType ( [in] ToolBarTypeEnum eType )

EditActionTypeEnum에 해당하는 툴바를 삭제한다.

VARIANT_BOOL sgObject::IPrintLayoutWidget::GetDisplayMenuBar ( )

메뉴바 객체의 보이기 여부

VARIANT_BOOL sgObject::IPrintLayoutWidget::GetDisplayToolBarByType ( [in] ToolBarTypeEnum eType )

ToolBarTypeEnum 에 해당하는 툴바 객체의 보이기 여부

IPrintLayoutItem* sgObject::IPrintLayoutWidget::GetItem ( [in] BSTR nameid )

ID에 해당하는 객체를 검색하여 반환한다.

void sgObject::IPrintLayoutWidget::Invalidate ( )

출력폼창의 상태를 재설정한다.

VARIANT_BOOL sgObject::IPrintLayoutWidget::ReadXML ( [in] BSTR filename )

출력폼 파일을 읽어 들인다.

void sgObject::IPrintLayoutWidget::SetDisplayMenuBar ( VARIANT_BOOL bVal )
void sgObject::IPrintLayoutWidget::SetDisplayProperyWidget ( VARIANT_BOOL bVal )

모든 속성도킹창 객체의 보이기 여부를 설정한다.

void sgObject::IPrintLayoutWidget::SetDisplayToolBar ( VARIANT_BOOL bVal )

모든 툴바 객체의 보이기 여부

void sgObject::IPrintLayoutWidget::SetDisplayToolBarByType | ( | [in] ToolBarTypeEnum | eType,
 |  | [in] VARIANT_BOOL | bDisplay
 | ) |  |
void sgObject::IPrintLayoutWidget::SetKeyEnable | ( | [in] SystemKeyEnum | eType,
 |  | [in] VARIANT_BOOL | bEnable
 | ) |  |

출력폼창 내에서 키보드 버튼의 사용여부를 설정한다.

void sgObject::IPrintLayoutWidget::SetMouseButtonEnable | ( | [in] MouseButtonTypeEnum | eType,
 |  | [in] VARIANT_BOOL | bEnable
 | ) |  |

출력폼창 내에서 마우스 버튼의 사용여부를 설정한다.

VARIANT_BOOL sgObject::IPrintLayoutWidget::WriteXML ( [in] BSTR filename )

해당 출력폼 파일로 저장한다.

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IPrintLayoutWidget
sgObject::IPrintLayoutWidget 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IPrintLayoutWidget (모든 상속된 멤버들도 포함합니다.)

AddWidget([in] IWidget *dspWidget) | sgObject::IWidget
AddWidgetByLayout([in] IWidget *dspWidget, [in] int row, [in] int col) | sgObject::IWidget
DeleteToolBarByType([in] ToolBarTypeEnum eType) | sgObject::IPrintLayoutWidget
Destroy() | sgObject::IWidget
GetBackColor() | sgObject::IWidget
GetDisplayMenuBar() | sgObject::IPrintLayoutWidget
GetDisplayToolBarByType([in] ToolBarTypeEnum eType) | sgObject::IPrintLayoutWidget
GetFeatureCanvas() | sgObject::IWidget
GetFlag() | sgObject::IWidget
GetItem([in] BSTR nameid) | sgObject::IPrintLayoutWidget
Initialize([in] ULONG_PTR h) | sgObject::IWidget
Invalidate() | sgObject::IPrintLayoutWidget
ReadXML([in] BSTR filename) | sgObject::IPrintLayoutWidget
ReSize([in] int x, [in] int y, [in] int cx, [in] int cy) | sgObject::IWidget
SetBackColor([in] long color) | sgObject::IWidget
SetCanvas(ICanvas *poCanvas) | sgObject::IWidget
SetDisplayMenuBar(VARIANT_BOOL bVal) | sgObject::IPrintLayoutWidget
SetDisplayProperyWidget(VARIANT_BOOL bVal) | sgObject::IPrintLayoutWidget
SetDisplayToolBar(VARIANT_BOOL bVal) | sgObject::IPrintLayoutWidget
SetDisplayToolBarByType([in] ToolBarTypeEnum eType, [in]VARIANT_BOOL bDisplay) | sgObject::IPrintLayoutWidget
SetFeatureCanvas(IFeatureCanvas *poFtCvs) | sgObject::IWidget
SetFeatureLayer(IFeatureLayer *poFtLayer) | sgObject::IWidget
SetFlag(BSTR bstrFlag) | sgObject::IWidget
SetHeight(int nHeight) | sgObject::IWidget
SetKeyEnable([in] SystemKeyEnum eType, [in] VARIANT_BOOL bEnable) | sgObject::IPrintLayoutWidget
SetLayer(ILayer *poLayer) | sgObject::IWidget
SetMouseButtonEnable([in] MouseButtonTypeEnum eType, [in] VARIANT_BOOL bEnable) | sgObject::IPrintLayoutWidget
SetQtUiObjectVisible([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue) | sgObject::IWidget
SetWidth(int nWidth) | sgObject::IWidget
WriteXML([in] BSTR filename) | sgObject::IPrintLayoutWidget
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IQueryCommand 인터페이스 참조

  • IQueryCommand
Public 멤버 함수 | 모든 멤버 목록
sgObject::IQueryCommand 인터페이스 참조

전체 비지니스 작업에 포함된 하나의 작업(쿼리)을 의미한다. 더 자세히 ...

sgObject::IQueryCommand에 대한 상속 다이어그램 :
sgObject::IQueryCommand에 대한 협력 다이어그램:

Public 멤버 함수

IFeature * GetRelatedFeature ()
관련된 Feature 객체 더 자세히 ...
void | SetRelatedFeature ([in] IFeature *ft)
long | GetData ()
사용자 데이터 더 자세히 ...
void | SetData ([in] long data)
long | GetID ()
ID. 더 자세히 ...
void | SetID ([in] long val)
BSTR | GetName ()
쿼리 객체의 이름 (시스템에서 사용할 이름) 더 자세히 ...
void | SetName ([in] BSTR name)
BSTR | GetCommandText ()
쿼리 명령 더 자세히 ...
void | SetCommandText ([in] BSTR cmd)
IQueryCommand * Clone ()
해당 QueryCommand 객체와 동일한 객체를 생성하여 반환한다. 더 자세히 ...

상세한 설명

전체 비지니스 작업에 포함된 하나의 작업(쿼리)을 의미한다.

멤버 함수 문서화

IQueryCommand* sgObject::IQueryCommand::Clone ( )

해당 QueryCommand 객체와 동일한 객체를 생성하여 반환한다.

반환값
복사된 QueryCommand 객체의 포인터
BSTR sgObject::IQueryCommand::GetCommandText ( )

쿼리 명령

long sgObject::IQueryCommand::GetData ( )

사용자 데이터

long sgObject::IQueryCommand::GetID ( )

ID.

BSTR sgObject::IQueryCommand::GetName ( )

쿼리 객체의 이름 (시스템에서 사용할 이름)

IFeature* sgObject::IQueryCommand::GetRelatedFeature ( )

관련된 Feature 객체

void sgObject::IQueryCommand::SetCommandText ( [in] BSTR cmd )
void sgObject::IQueryCommand::SetData ( [in] long data )
void sgObject::IQueryCommand::SetID ( [in] long val )
void sgObject::IQueryCommand::SetName ( [in] BSTR name )
void sgObject::IQueryCommand::SetRelatedFeature ( [in] IFeature * ft )
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IQueryCommand
sgObject::IQueryCommand 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IQueryCommand (모든 상속된 멤버들도 포함합니다.)

Clone() | sgObject::IQueryCommand
GetCommandText() | sgObject::IQueryCommand
GetData() | sgObject::IQueryCommand
GetID() | sgObject::IQueryCommand
GetName() | sgObject::IQueryCommand
GetRelatedFeature() | sgObject::IQueryCommand
SetCommandText([in] BSTR cmd) | sgObject::IQueryCommand
SetData([in] long data) | sgObject::IQueryCommand
SetID([in] long val) | sgObject::IQueryCommand
SetName([in] BSTR name) | sgObject::IQueryCommand
SetRelatedFeature([in] IFeature *ft) | sgObject::IQueryCommand
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IQueryCommands 인터페이스 참조

  • IQueryCommands
Public 멤버 함수 | 모든 멤버 목록
sgObject::IQueryCommands 인터페이스 참조

전체 비지니스 작업에 포함된 하나의 작업(쿼리)들을 의미한다. 더 자세히 ...

sgObject::IQueryCommands에 대한 상속 다이어그램 :
sgObject::IQueryCommands에 대한 협력 다이어그램:

Public 멤버 함수

int | GetSize ()
포함된 QueryCommand 객체의 갯수 더 자세히 ...
void | Add ([in] IQueryCommand *cmd)
전체 비지니스 작업에 하나의 작업(쿼리)을 추가한다. 더 자세히 ...
void | Remove ([in] IQueryCommand *cmd)
전체 비지니스 작업에 하나의 작업(쿼리)을 삭제한다. 더 자세히 ...
void | RemoveAll ()
전체 비지니스 작업을 삭제한다. 더 자세히 ...

상세한 설명

전체 비지니스 작업에 포함된 하나의 작업(쿼리)들을 의미한다.

멤버 함수 문서화

void sgObject::IQueryCommands::Add ( [in] IQueryCommand * cmd )

전체 비지니스 작업에 하나의 작업(쿼리)을 추가한다.

매개변수
cmd - 추가할 작업(쿼리)
int sgObject::IQueryCommands::GetSize ( )

포함된 QueryCommand 객체의 갯수

void sgObject::IQueryCommands::Remove ( [in] IQueryCommand * cmd )

전체 비지니스 작업에 하나의 작업(쿼리)을 삭제한다.

매개변수
cmd - 삭제할 작업(쿼리)
void sgObject::IQueryCommands::RemoveAll ( )

전체 비지니스 작업을 삭제한다.

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IQueryCommands
sgObject::IQueryCommands 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IQueryCommands (모든 상속된 멤버들도 포함합니다.)

Add([in] IQueryCommand *cmd) | sgObject::IQueryCommands
GetSize() | sgObject::IQueryCommands
Remove([in] IQueryCommand *cmd) | sgObject::IQueryCommands
RemoveAll() | sgObject::IQueryCommands
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ISampleDimension 인터페이스 참조

  • ISampleDimension
sgObject::ISampleDimension 인터페이스 참조

ISampleDimension 인터페이스는 각각의 커버리지 샘플 차원에 대한 정보를 담고 있다. 더 자세히 ...

sgObject::ISampleDimension에 대한 상속 다이어그램 :
sgObject::ISampleDimension에 대한 협력 다이어그램:

상세한 설명

ISampleDimension 인터페이스는 각각의 커버리지 샘플 차원에 대한 정보를 담고 있다.

이것은 어떠한 커버리지 형식에도 적용가능하다. 그리드 커버리지의 경우 샘플 차원은 각각의 밴드를 가리킨다. C API(linux, iOS, MacOS 등) : 중간이름 "GC"를 덧붙여서 "OGR_SD_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.SampleDimension"

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ISensor 인터페이스 참조

  • ISensor
Public 멤버 함수 | 모든 멤버 목록
sgObject::ISensor 인터페이스 참조

모든 센서(위치, 방향, 속도 외)의 상위 인터페이스로 센서의 공통 인터페이스를 제공한다. 더 자세히 ...

sgObject::ISensor에 대한 상속 다이어그램 :
sgObject::ISensor에 대한 협력 다이어그램:

Public 멤버 함수

HRESULT | Start ([in] IParameters *param, [out, retval] VARIANT_BOOL *bSuccess)
위치 센서의 경우 Sensor 장치를 COM 포트를 통해 사용한다. 더 자세히 ...
HRESULT | Stop ()
센서 장치의 사용을 끝낸다. 더 자세히 ...
HRESULT | IsServiceRunning ([out, retval] VARIANT_BOOL *retVal)
Sensor 장치를 사용할 수 있는지 여부 더 자세히 ...
HRESULT | GetLatestValueToXML ([out, retval] BSTR *retVal)
Sensor 장치에서 읽어온 최신 자료를 센서별 XML규격 형태로 반환한다. 더 자세히 ...

상세한 설명

모든 센서(위치, 방향, 속도 외)의 상위 인터페이스로 센서의 공통 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "SN"를 덧붙여서 "OGR_SN_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Sensor"

멤버 함수 문서화

HRESULT sgObject::ISensor::GetLatestValueToXML ( [out, retval] BSTR * retVal )

Sensor 장치에서 읽어온 최신 자료를 센서별 XML규격 형태로 반환한다.

매개변수
retVal - 센서별 최신값 XML 정보
반환값
성공이면 S_OK, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ISensor::IsServiceRunning ( [out, retval] VARIANT_BOOL * retVal )

Sensor 장치를 사용할 수 있는지 여부

매개변수
retVal - 사용가능 여부
반환값
성공이면 S_OK, 그렇지 않으면 HRESULT 에러코드
HRESULT sgObject::ISensor::Start | ( | [in] IParameters * | param,
 |  | [out, retval] VARIANT_BOOL * | bSuccess
 | ) |  |

위치 센서의 경우 Sensor 장치를 COM 포트를 통해 사용한다.

이 메소드가 성공하면 _ILocationSensorEvents 이벤트를 통해 GPS 정보가 수신된다.

매개변수
param | - GPS 장치와 연결 시도할 COM 포트와 통신 속도를 파라미터 객체를 통해서 받는다. PortNumber - GPS 장치와 연결 시도할 COM 포트 [default = 6] BoundNumber - GPS 장치와 연결 시도할 통신 속도 (Baud Rate) [default = 4800]
bSuccess | - 수신에 성공이면 TRUE, 실패면 FALSE
반환값
성공이면 TRUE, 실패면 FALSE
HRESULT sgObject::ISensor::Stop ( )

센서 장치의 사용을 끝낸다.

이 메소드가 성공하면 Events 이벤트를 통한 센서 정보 수신이 중지된다.

반환값
성공이면 S_OK, 그렇지 않으면 HRESULT 에러코드
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ISensor
sgObject::ISensor 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ISensor (모든 상속된 멤버들도 포함합니다.)

GetLatestValueToXML([out, retval] BSTR *retVal) | sgObject::ISensor
IsServiceRunning([out, retval] VARIANT_BOOL *retVal) | sgObject::ISensor
Start([in] IParameters *param, [out, retval] VARIANT_BOOL *bSuccess) | sgObject::ISensor
Stop() | sgObject::ISensor
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ISpatialOperator 인터페이스 참조

  • ISpatialOperator
Public 멤버 함수 | 모든 멤버 목록
sgObject::ISpatialOperator 인터페이스 참조

기하에 다른 기하와의 공간연산 인터페이스를 제공한다. 더 자세히 ...

sgObject::ISpatialOperator에 대한 상속 다이어그램 :
sgObject::ISpatialOperator에 대한 협력 다이어그램:

Public 멤버 함수

double | Distance ([in] IGeometry *other)
매개변수 기하와의 거리를 측정한다. 즉, 소스 기하와 매개 변수인 기하 사이의 최소 거리를 반환한다. 더 자세히 ...
IGeometry * Boundary ()
기하의 조합 경계 를 가져온다. 더 자세히 ...
IGeometry * | Buffer ([in] double distance)
기하로부터의 거리가 distance 값보다 작거나 같은 점들의 집합을 표현하는 Geoemtry 객체를 가져온다. 더 자세히 ...
IGeometry * ConvexHull ()
기하의 ConvexHull을 표현하는 기하를 가져온다. 더 자세히 ...
IGeometry * | Intersection ([in] IGeometry *other)
기하와 매개변수 기하의 교집합을 표현하는 기하를 가져온다. 더 자세히 ...
IGeometry * | Union ([in] IGeometry *other)
기하와 매개변수 기하의 합집합을 표현하는 기하를 가져온다. 더 자세히 ...
IGeometry * | Difference ([in] IGeometry *other)
기하와 매개변수 기하의 차집합을 표현하는 기하를 가져온다. 더 자세히 ...
IGeometry * | SymmetricDifference ([in] IGeometry *other)
기하와 매개변수 기하의 서로의 차집합의 합집합을 표현하는 기하를 가져온다. 더 자세히 ...
IGeometry * | MoveDistance ([in] double dlLenX, [in] double dlLenY)
주어진 x, y 거리만큼 이동한다. 더 자세히 ...
IGeometry * | MoveAngle ([in] double dlLength, [in] long nAngle)
주어진 각도로 주어진 거리만큼 이동한다. 더 자세히 ...
IGeometry * | Rotate ([in] double dlStandX, [in] double dlStandY, [in] long nAngle)
주어진 기준점으로부터 주어진 각만큼 회전한다. 더 자세히 ...
IGeometry * | Scale ([in] double dlStandX, [in] double dlStandY, [in] double dlSX, [in] double dlSY)
기하의 크기를 조절한다. 더 자세히 ...
double | HausdorffDistance ([in] IGeometry *other)
연속되지 않은 Hausdorff Distance 원거리 값을 반환한다. 더 자세히 ...
double | HausdorffDistanceDensify ([in] IGeometry *other, double densifyFrac)
IGeometry * UnionCascaded ()
Union보다 성능이 개선된 방식으로 결과를 반환한다. 더 자세히 ...
IGeometry * | Simplify ([in] double tolerance)
더글라스-패커(Douglas-Peucker)알고리즘으로 단순화한 결과를 반환한다. 더 자세히 ...
IGeometry * | TopologyPreserveSimplify ([in] double tolerance)
Topology-Preserving 알고리즘으로 단순화한 결과를 반환한다.(Contour단순화에 활용) 더 자세히 ...
IPoint * | Interpolate ([in] double distance)
라인상 시작점으로부터 거리(distance)에 있는 점을 반환한다. 더 자세히 ...
IPoint * | InterpolateNormalized ([in] double dlRate)
라인상 시작점으로부터 길이 배율에 있는 점을 반환한다. (0.5 => 중심점) 더 자세히 ...
IGeometry * | BufferWithStyle ([in] double width, [in] int quadsegs, [in] LineCapEnum endCapStyle, [in] LineJoinEnum joinStyle, [in] double mitreLimit)
기본 버퍼 기능에 약간의 스타일(라인 끝 버퍼의 모양, 라인이 조인되는 부분의 버퍼 모양 등) 조절 기능을 추가로 가미한 메소드이다. 더 자세히 ...
IGeometry * | SingleSidedBuffer ([in] double width, [in] int quadsegs, [in] LineJoinEnum joinStyle, [in] double mitreLimit, [in] VARIANT_BOOL bLeftSide)
한쪽 방향에만 버퍼를 만들어 공간객체를 반환한다. 더 자세히 ...
IPoint * | NearestPoint ([in] IGeometry *other)
주어진 기하로부터 가장 가까운 점 객체를 반환한다. 더 자세히 ...
IGeometry * LineMerge ()
기하의 가장자리가 다른 기하 가장자리와 접점했을 경우, 하나의 라인 기하로 만든다. 더 자세히 ...

상세한 설명

기하에 다른 기하와의 공간연산 인터페이스를 제공한다.

즉, 기하에 대한 근사연산자(Proximity operators), 생성연산자(Constructive operators), 위상연산자(Topological operators) 그리고 집합연산자(Set operators)를 정의한다. 해당 연산에 대해 설명이 불충분한 것은 Knowledge Base의 Geometry 및 수학(집합 및 기하) 서적을 참고한다. C API(linux, iOS, MacOS 등) : 중간이름 "G"를 덧붙여서 "OGR_G_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Geometry"

멤버 함수 문서화

IGeometry* sgObject::ISpatialOperator::Boundary ( )

기하의 조합 경계 를 가져온다.

즉, 소스 기하의 닫혀진 경계를 반환한다.
경계에 대한 정의는 [1]과 2장의 2절을 참조하시오.

반환값
경계를 표현하는 기하의 포인터
IGeometry* sgObject::ISpatialOperator::Buffer ( [in] double distance )

기하로부터의 거리가 distance 값보다 작거나 같은 점들의 집합을 표현하는 Geoemtry 객체를 가져온다.

즉, 소스 기하의 경계에서 일정 거리(distance값) 이내에 존재하는 모든 점를 포함하는 폴리곤을 반환한다.

매개변수
distance - 기하로부터의 거리값 (기하 주변의 버퍼 거리)
반환값
버퍼를 표현하는 기하의 포인터
IGeometry* sgObject::ISpatialOperator::BufferWithStyle | ( | [in] double | width,
 |  | [in] int | quadsegs,
 |  | [in] LineCapEnum | endCapStyle,
 |  | [in] LineJoinEnum | joinStyle,
 |  | [in] double | mitreLimit
 | ) |  |

기본 버퍼 기능에 약간의 스타일(라인 끝 버퍼의 모양, 라인이 조인되는 부분의 버퍼 모양 등) 조절 기능을 추가로 가미한 메소드이다.

매개변수
width | - 버퍼 줄 거리(기본 라인으로부터 얼마의 width 만큼씩 버퍼를 줄 것인가를 결정)
quadsegs | - 라인 끝 버퍼에 몇 개의 점을 주느냐 즉 몇 개의 세그먼트로 나누어 정몇각형을 만들 것이냐를 지정
endCapStyle | - 라인 끝 버퍼 캡의 모양 지정
joinStyle | - 라인이 조인되는 부분의 버퍼 (캡) 모양 지정
mitreLimit | - 조인되는 두 라인의 버퍼라인 거리가 아주 가까울 경우(각도가 거의 일직선에 가까울 경우)에는 라인이 조인되는 부분의 버퍼 캡 모양을 지정할 필요없이 두 점을 이을 수 있도록 하는데, 이때 이 거리의 limit값.
반환값
기하 포인터
IGeometry* sgObject::ISpatialOperator::ConvexHull ( )

기하의 ConvexHull을 표현하는 기하를 가져온다.

ConvexHull에 대해서는 수학 서적을 참고한다.

반환값
ConvexHull을 표현하는 기하의 포인터
IGeometry* sgObject::ISpatialOperator::Difference ( [in] IGeometry * other )

기하와 매개변수 기하의 차집합을 표현하는 기하를 가져온다.

(해당 기하를 A라 하고 매개변수 기하를 B라 할 때 A - B ) 즉, 소스 기하와 입력으로 들어온 기하의 차 집합(source Geometry - other Geometry)을 나타내는 기하를 반환한다.

매개변수
other - 연산할 다른 기하(비교할 기하 컬렉션)
반환값
차집합을 표현하는 기하의 포인터
double sgObject::ISpatialOperator::Distance ( [in] IGeometry * other )

매개변수 기하와의 거리를 측정한다. 즉, 소스 기하와 매개 변수인 기하 사이의 최소 거리를 반환한다.

이 때 최소 거리란 두 기하 위에 존재하는 점들 사이의 거리중 가장 가까운 거리이다. (가장 가까운 경계 간의 거리) 거리의 단위는 소스 기하의 공간 참조체계에 기초를 둔다. 예를 들어, 메소드의 피연산자가 교차하는 두 폴리라인일 경우에는 폴리라인 정점들과의 관계를 고려할 필요 없이 메소드는 영(zero)값을 반환한다.

매개변수
other - 비교 기하 (즉, 해당 기하와 거리를 측정할 대상 기하)
반환값
두 기하 간의 거리
double sgObject::ISpatialOperator::HausdorffDistance ( [in] IGeometry * other )

연속되지 않은 Hausdorff Distance 원거리 값을 반환한다.

(하우스도르프 거리란? : 근방공간이라고도 함. 두 대상에 대한 유사성을 가리기 위해 대표적으로 사용되는 방법 중 유클리디안 거리, 마하라노비스 거리가 있으며, 하우스도르프 거리는 또다른 접근법 중 하나이다.) 두 오브젝트 사이의 가장 가까운 거리를 구하고자 할 경우 한 점을 기준으로 했을 때 한 오브젝트의 점이 다른 오브젝트의 점들로부터 모두 가깝다고 볼 수 없기 때문에 이는 두 오브젝트 사이의 거리(상관성)을 판단하는 데 적합하지 않다. 따라서 두 오브젝트 사이의 최대 거리를 이용하는 것이 효율적. 즉, 다른 오브젝트의 어떤 점과도 거리가 가장 먼 점을 찾는 것. 다시말해, 하우스도르프 거리란 대표성을 갖는 점을 찾는 방법 중의 하나이다. 최단거리는 한 점과 한 점 사이에서는 가능하나, 두 오브젝트의 모든 점들 사이의 거리(모든 조합) 중에서도 최단거리는 아니다. 따라서 어떠한 조합에서도 동일한 결과를 갖는 최대거리를 쓰는 것이 더 낫다는 것이 하우스도르프 거리의 요점)

매개변수
other - 참조할 다른 오브젝트
반환값
측정된 Hausdorff Distance 원거리 값
double sgObject::ISpatialOperator::HausdorffDistanceDensify | ( | [in] IGeometry * | other,
 |  | double | densifyFrac
 | ) |  |
IPoint* sgObject::ISpatialOperator::Interpolate ( [in] double distance )

라인상 시작점으로부터 거리(distance)에 있는 점을 반환한다.

매개변수
distance - 거리값
반환값
Interpolate로 얻은 Point 객체의 포인터
IPoint* sgObject::ISpatialOperator::InterpolateNormalized ( [in] double dlRate )

라인상 시작점으로부터 길이 배율에 있는 점을 반환한다. (0.5 => 중심점)

매개변수
dlRate - 배율
반환값
InterpolateNormalized로 얻은 점 객체의 포인터
IGeometry* sgObject::ISpatialOperator::Intersection ( [in] IGeometry * other )

기하와 매개변수 기하의 교집합을 표현하는 기하를 가져온다.

즉, 입력으로 들어온 기하와 소스 기하의 교집합 기하를 반환한다.

매개변수
other - 연산할 다른 기하
반환값
교집합을 표현하는 기하의 포인터
IGeometry* sgObject::ISpatialOperator::LineMerge ( )

기하의 가장자리가 다른 기하 가장자리와 접점했을 경우, 하나의 라인 기하로 만든다.

반환값
라인 기하의 포인터
IGeometry* sgObject::ISpatialOperator::MoveAngle | ( | [in] double | dlLength,
 |  | [in] long | nAngle
 | ) |  |

주어진 각도로 주어진 거리만큼 이동한다.

매개변수
dlLength | - 이동할 거리
nAngle | - 이동할 방향(각)
반환값
이동한 기하의 포인터
IGeometry* sgObject::ISpatialOperator::MoveDistance | ( | [in] double | dlLenX,
 |  | [in] double | dlLenY
 | ) |  |

주어진 x, y 거리만큼 이동한다.

매개변수
dlLenX | - 이동할 거리를 지정하기 위한 x좌표
dlLenY | - 이동할 거리를 지정하기 위한 y좌표
반환값
이동한 기하의 포인터
IPoint* sgObject::ISpatialOperator::NearestPoint ( [in] IGeometry * other )

주어진 기하로부터 가장 가까운 점 객체를 반환한다.

매개변수
other - 참조할 기하
반환값
NearestPoint로 구한 가장 가까운 점 객체의 포인터
IGeometry* sgObject::ISpatialOperator::Rotate | ( | [in] double | dlStandX,
 |  | [in] double | dlStandY,
 |  | [in] long | nAngle
 | ) |  |

주어진 기준점으로부터 주어진 각만큼 회전한다.

매개변수
dlStandX | - 기준점의 x 좌표
dlStandY | - 기준점의 y 좌표
nAngle | - 회전할 방향(각)
반환값
회전한 기하의 포인터
IGeometry* sgObject::ISpatialOperator::Scale | ( | [in] double | dlStandX,
 |  | [in] double | dlStandY,
 |  | [in] double | dlSX,
 |  | [in] double | dlSY
 | ) |  |

기하의 크기를 조절한다.

매개변수
dlStandX | - 기준점의 x 좌표
dlStandY | - 기준점의 y 좌표
dlSX | - 크기 조절을 위한 x
dlSY | - 크기 조절을 위한 y
반환값
크기 조절한 기하의 포인터
IGeometry* sgObject::ISpatialOperator::Simplify ( [in] double tolerance )

더글라스-패커(Douglas-Peucker)알고리즘으로 단순화한 결과를 반환한다.

더글라스-패커 알고리즘에 대해서는 알고리즘 서적을 참고한다.

매개변수
tolerance - 단순화를 실행하기 위한 허용 오차
반환값
단순화 된 기하의 포인터
IGeometry* sgObject::ISpatialOperator::SingleSidedBuffer | ( | [in] double | width,
 |  | [in] int | quadsegs,
 |  | [in] LineJoinEnum | joinStyle,
 |  | [in] double | mitreLimit,
 |  | [in] VARIANT_BOOL | bLeftSide
 | ) |  |

한쪽 방향에만 버퍼를 만들어 공간객체를 반환한다.

BufferWithStyle과 유사하게 스타일을 지정할 수 있으며, 어느 쪽에 버퍼를 만들지를 추가로 지정할 수 있다.

매개변수
width | - 버퍼 줄 거리(기본 라인으로부터 얼마의 width 만큼씩 버퍼를 줄 것인가를 결정)
quadsegs | - 라인 끝 부분에 버퍼를 줄 때 몇 개의 세그먼트로 된 모양을 만들것인가를 결정
joinStyle | - 라인이 조인되는 부분의 버퍼 (캡) 모양 지정
mitreLimit -
bLeftSide | - 어느 쪽 사이드에 버퍼를 만들 것인지 결정. 왼쪽에 만들 것이면 true, 오른쪽에 만들 것이면 false
반환값
버퍼가 적용된 기하 포인터
IGeometry* sgObject::ISpatialOperator::SymmetricDifference ( [in] IGeometry * other )

기하와 매개변수 기하의 서로의 차집합의 합집합을 표현하는 기하를 가져온다.

(해당 기하를 A라 하고 매개변수 기하를 B라 할 때 (A - B) U (B - A) ) 즉, 소스 기하와 입력으로 들어온 기하 사이의 대칭자(symmetric difference)를 나타내는 기하를 반환한다.

매개변수
other - 연산할 다른 기하(비교할 기하)
반환값
Symmetric Difference를 표현하는 기하의 포인터
IGeometry* sgObject::ISpatialOperator::TopologyPreserveSimplify ( [in] double tolerance )

Topology-Preserving 알고리즘으로 단순화한 결과를 반환한다.(Contour단순화에 활용)

Topology-Preserving 알고리즘에 대해서는 알고리즘 서적을 참고한다.

매개변수
tolerance - 단순화를 실행하기 위한 허용 오차
반환값
단순화 된 기하의 포인터
IGeometry* sgObject::ISpatialOperator::Union ( [in] IGeometry * other )

기하와 매개변수 기하의 합집합을 표현하는 기하를 가져온다.

즉, 입력으로 들어온 기하와 소스 기하의 합집합을 나타내는 기하를 반환한다.

매개변수
other - 연산할 다른 기하(비교할 기하)
반환값
합집합을 표현하는 기하의 포인터
IGeometry* sgObject::ISpatialOperator::UnionCascaded ( )

Union보다 성능이 개선된 방식으로 결과를 반환한다.

생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ISpatialOperator
sgObject::ISpatialOperator 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ISpatialOperator (모든 상속된 멤버들도 포함합니다.)

Boundary() | sgObject::ISpatialOperator
Buffer([in] double distance) | sgObject::ISpatialOperator
BufferWithStyle([in] double width, [in] int quadsegs, [in] LineCapEnum endCapStyle, [in] LineJoinEnum joinStyle, [in] double mitreLimit) | sgObject::ISpatialOperator
ConvexHull() | sgObject::ISpatialOperator
Difference([in] IGeometry *other) | sgObject::ISpatialOperator
Distance([in] IGeometry *other) | sgObject::ISpatialOperator
HausdorffDistance([in] IGeometry *other) | sgObject::ISpatialOperator
HausdorffDistanceDensify([in] IGeometry *other, double densifyFrac) | sgObject::ISpatialOperator
Interpolate([in] double distance) | sgObject::ISpatialOperator
InterpolateNormalized([in] double dlRate) | sgObject::ISpatialOperator
Intersection([in] IGeometry *other) | sgObject::ISpatialOperator
LineMerge() | sgObject::ISpatialOperator
MoveAngle([in] double dlLength, [in] long nAngle) | sgObject::ISpatialOperator
MoveDistance([in] double dlLenX, [in] double dlLenY) | sgObject::ISpatialOperator
NearestPoint([in] IGeometry *other) | sgObject::ISpatialOperator
Rotate([in] double dlStandX, [in] double dlStandY, [in] long nAngle) | sgObject::ISpatialOperator
Scale([in] double dlStandX, [in] double dlStandY, [in] double dlSX, [in] double dlSY) | sgObject::ISpatialOperator
Simplify([in] double tolerance) | sgObject::ISpatialOperator
SingleSidedBuffer([in] double width, [in] int quadsegs, [in] LineJoinEnum joinStyle, [in] double mitreLimit, [in] VARIANT_BOOL bLeftSide) | sgObject::ISpatialOperator
SymmetricDifference([in] IGeometry *other) | sgObject::ISpatialOperator
TopologyPreserveSimplify([in] double tolerance) | sgObject::ISpatialOperator
Union([in] IGeometry *other) | sgObject::ISpatialOperator
UnionCascaded() | sgObject::ISpatialOperator
생성시간 : 화 5월 26 2020 12:14:17, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ISpatialReference 인터페이스 참조

  • ISpatialReference
Public 멤버 함수 | 모든 멤버 목록
sgObject::ISpatialReference 인터페이스 참조

ISpatialReference 인터페이스는 Geometry 객체가 참조하는 공간참조체계를 정의하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::ISpatialReference에 대한 상속 다이어그램 :
sgObject::ISpatialReference에 대한 협력 다이어그램:

Public 멤버 함수

void | Destroy ()
VARIANT_BOOL | ImportFromWkt ([in] BSTR strWkt)
VARIANT_BOOL | ImportFromProj4 ([in] BSTR strProj4)
BSTR | ExportToWkt ()
BSTR | ExportToProj4 ()
VARIANT_BOOL | SetFromUserInput ([in] BSTR strInput)
void | ShowSRSWidget ()
BSTR | GetEPSGName ()
void | SetAuthority ([in] BSTR strTargetKey, [in] BSTR strAuthority, [in] int nCode)
BSTR | GetAuthorityCode ([in] BSTR strTargetKey)
BSTR | GetAuthorityName ([in] BSTR strTargetKey)
VARIANT_BOOL | IsSame ([in] ISpatialReference *otherCRS)
ISpatialReference * Clone ()
- sgObject::ISpatialReferenceInfo(으)로부터 상속된 Public 멤버 함수
BSTR | GetWellKnownText ()

상세한 설명

ISpatialReference 인터페이스는 Geometry 객체가 참조하는 공간참조체계를 정의하는 인터페이스를 제공한다.

SpatialReference의 자세한 내용은 Knowledge Base의 Coordinate System을 참고한다.

멤버 함수 문서화

ISpatialReference* sgObject::ISpatialReference::Clone ( )
void sgObject::ISpatialReference::Destroy ( )
BSTR sgObject::ISpatialReference::ExportToProj4 ( )
BSTR sgObject::ISpatialReference::ExportToWkt ( )
BSTR sgObject::ISpatialReference::GetAuthorityCode ( [in] BSTR strTargetKey )
BSTR sgObject::ISpatialReference::GetAuthorityName ( [in] BSTR strTargetKey )
BSTR sgObject::ISpatialReference::GetEPSGName ( )
VARIANT_BOOL sgObject::ISpatialReference::ImportFromProj4 ( [in] BSTR strProj4 )
VARIANT_BOOL sgObject::ISpatialReference::ImportFromWkt ( [in] BSTR strWkt )
VARIANT_BOOL sgObject::ISpatialReference::IsSame ( [in] ISpatialReference * otherCRS )
void sgObject::ISpatialReference::SetAuthority | ( | [in] BSTR | strTargetKey,
 |  | [in] BSTR | strAuthority,
 |  | [in] int | nCode
 | ) |  |
VARIANT_BOOL sgObject::ISpatialReference::SetFromUserInput ( [in] BSTR strInput )
void sgObject::ISpatialReference::ShowSRSWidget ( )
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ISpatialReference
sgObject::ISpatialReference 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ISpatialReference (모든 상속된 멤버들도 포함합니다.)

Clone() | sgObject::ISpatialReference
Destroy() | sgObject::ISpatialReference
ExportToProj4() | sgObject::ISpatialReference
ExportToWkt() | sgObject::ISpatialReference
GetAuthorityCode([in] BSTR strTargetKey) | sgObject::ISpatialReference
GetAuthorityName([in] BSTR strTargetKey) | sgObject::ISpatialReference
GetEPSGName() | sgObject::ISpatialReference
GetWellKnownText() | sgObject::ISpatialReferenceInfo
ImportFromProj4([in] BSTR strProj4) | sgObject::ISpatialReference
ImportFromWkt([in] BSTR strWkt) | sgObject::ISpatialReference
IsSame([in] ISpatialReference *otherCRS) | sgObject::ISpatialReference
SetAuthority([in] BSTR strTargetKey, [in] BSTR strAuthority, [in] int nCode) | sgObject::ISpatialReference
SetFromUserInput([in] BSTR strInput) | sgObject::ISpatialReference
ShowSRSWidget() | sgObject::ISpatialReference
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ISpatialReferenceFactory 인터페이스 참조

  • ISpatialReferenceFactory
Public 멤버 함수 | 모든 멤버 목록
sgObject::ISpatialReferenceFactory 인터페이스 참조

ISpatialReferenceFactory 인터페이스 더 자세히 ...

sgObject::ISpatialReferenceFactory에 대한 상속 다이어그램 :
sgObject::ISpatialReferenceFactory에 대한 협력 다이어그램:

Public 멤버 함수

ISpatialReference * | CreateFromWKT ([in] BSTR wktSpatialRef)
Well Known Text로 표현된 공간참조체계 정보를 가져와 SpatialReference 객체에 공간참조체계를 정의한다. 더 자세히 ...
ISpatialReference * | CreateFromProj4 ([in] BSTR proj4SpatialRef)
Proj4 스타일 문자열로 표현된 공간참조체계 정보를 가져와 SpatialReference 객체에 공간참조체계를 정의한다. 더 자세히 ...
ISpatialReference * | CreateFromXML ([in] BSTR xmlSpatialRef)
XML 스타일 문자열로 표현된 공간참조체계 정보를 가져와 SpatialReference 객체에 공간참조체계를 정의한다. 더 자세히 ...
ISpatialReference * | CreateFromESRI ([in] BSTR esriSpatialRef)
ESRI 스타일 문자열로 표현된 공간참조체계 정보를 가져와 SpatialReference 객체에 공간참조체계를 정의한다. 더 자세히 ...
BSTR | ExportToWKTAsString ([in] ISpatialReference *sref)
SpatialReference 객체의 공간참조체계를 Proj4 스타일 문자열로 표현한다. 더 자세히 ...
BSTR | ExportToProj4AsString ([in] ISpatialReference *sref)
BSTR | ExportToXMLAsString ([in] ISpatialReference *sref)
IGeographicTransform * | CreateGeographicTransform ([in] ISpatialReference *Source, [in] ISpatialReference *Target)

상세한 설명

ISpatialReferenceFactory 인터페이스

C API(linux, iOS, MacOS 등) : 중간이름 "SF"를 덧붙여서 "OGR_SF_"+메소드명으로 사용할 수 있습니다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.SpatialReferenceFactory"

멤버 함수 문서화

ISpatialReference* sgObject::ISpatialReferenceFactory::CreateFromESRI ( [in] BSTR esriSpatialRef )

ESRI 스타일 문자열로 표현된 공간참조체계 정보를 가져와 SpatialReference 객체에 공간참조체계를 정의한다.

매개변수
esriSpatialRef - ESRI 스타일 문자열로 표현된 공간참조체계 정보
반환값
SpatialReference 객체 포인터
ISpatialReference* sgObject::ISpatialReferenceFactory::CreateFromProj4 ( [in] BSTR proj4SpatialRef )

Proj4 스타일 문자열로 표현된 공간참조체계 정보를 가져와 SpatialReference 객체에 공간참조체계를 정의한다.

Proj4 스타일 문자열에 대한 정보는 Knowledge Base의 "Coordinate System"과 http://trac.osgeo.org/proj/ 를 참조한다.

매개변수
proj4SpatialRef - PROJ.4 스타일 문자열로 표현된 공간참조체계 정보
반환값
SpatialReference 객체 포인터
ISpatialReference* sgObject::ISpatialReferenceFactory::CreateFromWKT ( [in] BSTR wktSpatialRef )

Well Known Text로 표현된 공간참조체계 정보를 가져와 SpatialReference 객체에 공간참조체계를 정의한다.

Well Known Text에 대한 정보는 Knowledge Base의 "Coordinate System"과 http://portal.opengeospatial.org/files/?artifact_id=999를 참조한다.

매개변수
wktSpatialRef - Well Known Text로 표현된 공간참조체계 정보
반환값
SpatialReference 객체 포인터
ISpatialReference* sgObject::ISpatialReferenceFactory::CreateFromXML ( [in] BSTR xmlSpatialRef )

XML 스타일 문자열로 표현된 공간참조체계 정보를 가져와 SpatialReference 객체에 공간참조체계를 정의한다.

매개변수
xmlSpatialRef - XML 스타일 문자열로 표현된 공간참조체계 정보
반환값
SpatialReference 객체 포인터
IGeographicTransform* sgObject::ISpatialReferenceFactory::CreateGeographicTransform | ( | [in] ISpatialReference * | Source,
 |  | [in] ISpatialReference * | Target
 | ) |  |
BSTR sgObject::ISpatialReferenceFactory::ExportToProj4AsString ( [in] ISpatialReference * sref )
BSTR sgObject::ISpatialReferenceFactory::ExportToWKTAsString ( [in] ISpatialReference * sref )

SpatialReference 객체의 공간참조체계를 Proj4 스타일 문자열로 표현한다.

Proj4 스타일 문자열에 대한 정보는 Knowledge Base의 "Coordinate System"과 http://trac.osgeo.org/proj/ 를 참조한다.

매개변수
sref - 해당 공간참조체계를 정의할 SpatialReference 객체 정보
반환값
Proj4 스타일 문자열
BSTR sgObject::ISpatialReferenceFactory::ExportToXMLAsString ( [in] ISpatialReference * sref )
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ISpatialReferenceFactory
sgObject::ISpatialReferenceFactory 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ISpatialReferenceFactory (모든 상속된 멤버들도 포함합니다.)

CreateFromESRI([in] BSTR esriSpatialRef) | sgObject::ISpatialReferenceFactory
CreateFromProj4([in] BSTR proj4SpatialRef) | sgObject::ISpatialReferenceFactory
CreateFromWKT([in] BSTR wktSpatialRef) | sgObject::ISpatialReferenceFactory
CreateFromXML([in] BSTR xmlSpatialRef) | sgObject::ISpatialReferenceFactory
CreateGeographicTransform([in] ISpatialReference *Source, [in] ISpatialReference *Target) | sgObject::ISpatialReferenceFactory
ExportToProj4AsString([in] ISpatialReference *sref) | sgObject::ISpatialReferenceFactory
ExportToWKTAsString([in] ISpatialReference *sref) | sgObject::ISpatialReferenceFactory
ExportToXMLAsString([in] ISpatialReference *sref) | sgObject::ISpatialReferenceFactory
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ISpatialReferenceInfo 인터페이스 참조

  • ISpatialReferenceInfo
Public 멤버 함수 | 모든 멤버 목록
sgObject::ISpatialReferenceInfo 인터페이스 참조

ISpatialReferenceInfo 인터페이스 더 자세히 ...

sgObject::ISpatialReferenceInfo에 대한 상속 다이어그램 :
sgObject::ISpatialReferenceInfo에 대한 협력 다이어그램:

Public 멤버 함수

BSTR GetWellKnownText ()

상세한 설명

ISpatialReferenceInfo 인터페이스

C API(linux, iOS, MacOS 등) : 중간이름 "SR"를 덧붙여서 "OGR_SR_"+메소드명으로 사용할 수 있습니다.
Java(SWT, Android) Package명 : "net.sgsrc.map.jni.SpatialReference"

멤버 함수 문서화

BSTR sgObject::ISpatialReferenceInfo::GetWellKnownText ( )
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ISpatialReferenceInfo
sgObject::ISpatialReferenceInfo 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ISpatialReferenceInfo (모든 상속된 멤버들도 포함합니다.)

GetWellKnownText() sgObject::ISpatialReferenceInfo
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ISpatialRelation 인터페이스 참조

  • ISpatialRelation
Public 멤버 함수 | 모든 멤버 목록
sgObject::ISpatialRelation 인터페이스 참조

기하에 적용되는 공간 관련성 연산자들을 정의한다. 더 자세히 ...

sgObject::ISpatialRelation에 대한 상속 다이어그램 :
sgObject::ISpatialRelation에 대한 협력 다이어그램:

Public 멤버 함수

VARIANT_BOOL | Equals ([in] IGeometry *other)
기하가 매개변수 기하와 공간적으로 동일한지 여부를 테스트한다. 더 자세히 ...
VARIANT_BOOL | Touches ([in] IGeometry *other)
기하가 매개변수 기하와 접촉하는지 여부를 테스트한다. 더 자세히 ...
VARIANT_BOOL | Contains ([in] IGeometry *other)
기하가 매개변수 기하를 포함하는지 여부를 테스트한다. 더 자세히 ...
VARIANT_BOOL | Within ([in] IGeometry *other)
기하가 매개변수 기하에 포함되었는지 여부를 테스트한다. 더 자세히 ...
VARIANT_BOOL | Disjoint ([in] IGeometry *other)
기하가 매개변수 기하와 공간적으로 떨어져 있는지 여부를 테스트한다. 더 자세히 ...
VARIANT_BOOL | Crosses ([in] IGeometry *other)
기하가 매개변수 기하를 횡단하는지 여부를 테스트한다. 더 자세히 ...
VARIANT_BOOL | Overlaps ([in] IGeometry *other)
기하가 매개변수 기하와 공간적으로 일부 겹치는지 여부를 테스트한다. 더 자세히 ...
VARIANT_BOOL | Intersects ([in] IGeometry *other)
기하가 매개변수 기하와 교집합이 있는지 여부를 테스트한다. 더 자세히 ...

상세한 설명

기하에 적용되는 공간 관련성 연산자들을 정의한다.

즉, 기하가 다른 기하와 공간적으로 어떤 관계에 있는지 테스트할 수 있는 인터페이스를 제공한다. 관계에 대한 자세한 내용은 Knowledge Base의 Geometry를 참고한다. C API(linux, iOS, MacOS 등) : 중간이름 "G"를 덧붙여서 "OGR_G_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Geometry"

멤버 함수 문서화

VARIANT_BOOL sgObject::ISpatialRelation::Contains ( [in] IGeometry * other )

기하가 매개변수 기하를 포함하는지 여부를 테스트한다.

매개 변수가 소스 기하(Geometry) 내에 완전히 포함되면 참을 반환한다. 소스기하와 비교할 기하의 순서를 역으로 했을 때의 Within 연산과같다.

매개변수
other - 관계를 나타낼 비교 기하(즉, 관계를 테스트할 다른 기하)
반환값
포함하면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
VARIANT_BOOL sgObject::ISpatialRelation::Crosses ( [in] IGeometry * other )

기하가 매개변수 기하를 횡단하는지 여부를 테스트한다.

두 기하의 교집합에 대한 기하 차원이 교차하는 두개의 소스 기하들의 최대 차원보다 작고 새롭게 생성되는 교차 부분의 기하가 소스기하 또는 매개 변수인 기하와 같지 않을 경우 참을 반환한다.

매개변수
other - 관계를 나타낼 비교 형태(즉, 관계를 테스트할 다른 기하)
반환값
횡단하면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
VARIANT_BOOL sgObject::ISpatialRelation::Disjoint ( [in] IGeometry * other )

기하가 매개변수 기하와 공간적으로 떨어져 있는지 여부를 테스트한다.

매개변수로 온 기하와 소스 기하가 서로 떨어져 있을 경우 참을 반환한다.

매개변수
other - 관계를 나타낼 비교 기하(즉, 관계를 테스트할 다른 기하)
반환값
떨어져 있으면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
VARIANT_BOOL sgObject::ISpatialRelation::Equals ( [in] IGeometry * other )

기하가 매개변수 기하와 공간적으로 동일한지 여부를 테스트한다.

매개변수
other - 관계를 테스트할 다른 기하
반환값
동일하면(소스 기하(Geometry)와 같은 점 집합을 정의한다면) VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
VARIANT_BOOL sgObject::ISpatialRelation::Intersects ( [in] IGeometry * other )

기하가 매개변수 기하와 교집합이 있는지 여부를 테스트한다.

이는 Not Disjoint와 같다. 두개의 기하 사이에 교집합이 존재할 경우 참을 반환한다.

매개변수
other - 관계를 나타낼 비교 기하(관계를 테스트할 다른 기하)
반환값
교집합이 있으면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
VARIANT_BOOL sgObject::ISpatialRelation::Overlaps ( [in] IGeometry * other )

기하가 매개변수 기하와 공간적으로 일부 겹치는지 여부를 테스트한다.

두 기하의 교집합을 나타내는 기하의 차원 입력으로 들어온 기하들의 차원과 같고 새롭게 생성된 교차부분의 기하가 소스 기하 또는 매개 변수인 기하와 같지 않을 경우 참을 반환한다.

매개변수
other - 관계를 나타낼 비교 기하(관계를 테스트할 다른 기하)
반환값
겹치면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
VARIANT_BOOL sgObject::ISpatialRelation::Touches ( [in] IGeometry * other )

기하가 매개변수 기하와 접촉하는지 여부를 테스트한다.

매개변수
other - 관계를 나타낼 비교 기하(즉, 관계를 테스트할 다른 기하)
반환값
접촉하면(두 객체의 교집합이 두 객체의 경계 내에만 존재하는 경우) VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
VARIANT_BOOL sgObject::ISpatialRelation::Within ( [in] IGeometry * other )

기하가 매개변수 기하에 포함되었는지 여부를 테스트한다.

소스 기하가 비교할 기하 내에 완전히 포함된다면 참을 반환한다.

매개변수
other - 관계를 나타낼 비교 기하(즉, 관계를 테스트할 다른 기하)
반환값
포함되었으면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ISpatialRelation2 인터페이스 참조

  • ISpatialRelation2
Public 멤버 함수 | 모든 멤버 목록
sgObject::ISpatialRelation2 인터페이스 참조

기하가 다른 기하와 공간적으로 어떤 관계에 있는지 테스트할 수 있는 인터페이스를 제공한다. 더 자세히 ...

sgObject::ISpatialRelation2에 대한 상속 다이어그램 :
sgObject::ISpatialRelation2에 대한 협력 다이어그램:

Public 멤버 함수

VARIANT_BOOL Relate ([in] IGeometry *other, [in] BSTR patternMatrix)
기하가 매개변수 기하와 patternMatrix 매개변수에 지정된 관계를 만족하는지 여부를 테스트한다. 더 자세히 ...

상세한 설명

기하가 다른 기하와 공간적으로 어떤 관계에 있는지 테스트할 수 있는 인터페이스를 제공한다.

SpatialRelation 인터페이스와 다른 점은 테스트하는 관계의 종류를 patternMatrix 매개변수에 지정한다는 것이다. patternMatrix 매개변수를 지정하기 위한 자세한 내용은 Knowledge Base의 Geometry를 참고한다. 또한 기하 객체에서 사용하는 공간 연산자들에 대하여 정의한다. 공간 관련성 연산자들은 기하 모델 명세를 참조하면 된다. 매개변수인 기하와 공간 관련성은 "차원 확장 9-교집합 모델" 행렬에서 정의한 테스트패턴행렬 형태로 비교하여 결과를 반환한다. C API(linux, iOS, MacOS 등) : 중간이름 "G"를 덧붙여서 "OGR_G_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Geometry"

멤버 함수 문서화

VARIANT_BOOL sgObject::ISpatialRelation2::Relate | ( | [in] IGeometry * | other,
 |  | [in] BSTR | patternMatrix
 | ) |  |

기하가 매개변수 기하와 patternMatrix 매개변수에 지정된 관계를 만족하는지 여부를 테스트한다.

patternMatrix 매개변수에는 "차원 확장 9-교집합 모델"에 근거한 문자열을 지정한다. 이에 대한 자세한 내용은 Knowledge Base의 Geometry를 참고한다.

매개변수
other | - 테스트 패턴 기하(관계를 테스트할 다른 기하)
patternMatrix | - 테스트 패턴 행렬(테스트할 관계를 지정하는 문자열)
반환값
관계를 만족하면 VARIANT_TRUE, 그렇지 않으면 VARIANT_FALSE
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ISpatialRelation2
sgObject::ISpatialRelation2 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ISpatialRelation2 (모든 상속된 멤버들도 포함합니다.)

Relate([in] IGeometry *other, [in] BSTR patternMatrix) sgObject::ISpatialRelation2
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IStroke 인터페이스 참조

  • IStroke
Public 멤버 함수 | 모든 멤버 목록
sgObject::IStroke 인터페이스 참조

펜의 스타일을 표현하기 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::IStroke에 대한 상속 다이어그램 :
sgObject::IStroke에 대한 협력 다이어그램:

Public 멤버 함수

BSTR | GetStyleString ()
펜 스타일을 문자열 형태로 반환한다. 더 자세히 ...
BSTR | GetColor ()
펜의 색상을 문자열 형태로 반환한다. 더 자세히 ...
void | SetColor (BSTR bstrColor)
펜의 색상을 문자열 형태로 설정한다. 더 자세히 ...
double | GetWidth ()
펜의 두께를 반환한다. 더 자세히 ...
void | SetWidth (double dfWidth)
펜의 두께를 설정한다. 더 자세히 ...
BSTR | GetID ()
펜의 ID를 반환한다. 더 자세히 ...
void | SetID (BSTR bstrId)
펜의 ID를 설정한다. 더 자세히 ...
BSTR | GetCap ()
라인의 양끝부분의 스타일를 반환한다. 더 자세히 ...
void | SetCap (BSTR bstrCap)
라인의 양끝점의 스타일를 설정한다. 더 자세히 ...
int | GetSCap ()
라인의 시작점의 스타일를 반환한다. 더 자세히 ...
void | SetSCap (int nSCap)
라인의 시작점의 스타일를 설정한다. 더 자세히 ...
int | GetECap ()
라인의 끝점의 스타일를 반환한다. 더 자세히 ...
void | SetECap (int nECap)
라인의 끝점의 스타일를 설정한다. 더 자세히 ...
BSTR | GetJoin ()
라인의 접합 부분의 스타일를 반환한다. 더 자세히 ...
void | SetJoin (BSTR bstrJoin)
라인의 접합 부분의 스타일를 설정한다. 더 자세히 ...
int | GetPriority ()
그려야하는 순서를 정의하는 값을 반환한다. 더 자세히 ...
void | SetPriority (int nPriority)
그려야하는 순서를 정의하는 값을 설정한다. 더 자세히 ...
BSTR | GetOutlineColor ()
윤곽선의 색상을 문자열 형태로 반환한다. 더 자세히 ...
void | SetOutlineColor (BSTR bstrOutlineColor)
윤곽선의 색상을 문자열 형태로 설정한다. 더 자세히 ...
int | GetOutlineWidth ()
윤곽선의 두께를 반환한다. 더 자세히 ...
void | SetOutlineWidth (int nInterval)
윤곽선의 두께를 설정한다. 더 자세히 ...
BSTR | GetPattern ()
라인의 패턴을 반환한다. 더 자세히 ...
void | SetPattern (BSTR bstrPattern)
라인의 패턴을 설정한다. 더 자세히 ...

상세한 설명

펜의 스타일을 표현하기 위한 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "SK"를 덧붙여서 "OGR_SK_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Stroke"

멤버 함수 문서화

BSTR sgObject::IStroke::GetCap ( )

라인의 양끝부분의 스타일를 반환한다.

BSTR sgObject::IStroke::GetColor ( )

펜의 색상을 문자열 형태로 반환한다.

int sgObject::IStroke::GetECap ( )

라인의 끝점의 스타일를 반환한다.

BSTR sgObject::IStroke::GetID ( )

펜의 ID를 반환한다.

BSTR sgObject::IStroke::GetJoin ( )

라인의 접합 부분의 스타일를 반환한다.

BSTR sgObject::IStroke::GetOutlineColor ( )

윤곽선의 색상을 문자열 형태로 반환한다.

int sgObject::IStroke::GetOutlineWidth ( )

윤곽선의 두께를 반환한다.

BSTR sgObject::IStroke::GetPattern ( )

라인의 패턴을 반환한다.

int sgObject::IStroke::GetPriority ( )

그려야하는 순서를 정의하는 값을 반환한다.

int sgObject::IStroke::GetSCap ( )

라인의 시작점의 스타일를 반환한다.

BSTR sgObject::IStroke::GetStyleString ( )

펜 스타일을 문자열 형태로 반환한다.

double sgObject::IStroke::GetWidth ( )

펜의 두께를 반환한다.

void sgObject::IStroke::SetCap ( BSTR bstrCap )

라인의 양끝점의 스타일를 설정한다.

void sgObject::IStroke::SetColor ( BSTR bstrColor )

펜의 색상을 문자열 형태로 설정한다.

void sgObject::IStroke::SetECap ( int nECap )

라인의 끝점의 스타일를 설정한다.

void sgObject::IStroke::SetID ( BSTR bstrId )

펜의 ID를 설정한다.

void sgObject::IStroke::SetJoin ( BSTR bstrJoin )

라인의 접합 부분의 스타일를 설정한다.

void sgObject::IStroke::SetOutlineColor ( BSTR bstrOutlineColor )

윤곽선의 색상을 문자열 형태로 설정한다.

void sgObject::IStroke::SetOutlineWidth ( int nInterval )

윤곽선의 두께를 설정한다.

void sgObject::IStroke::SetPattern ( BSTR bstrPattern )

라인의 패턴을 설정한다.

void sgObject::IStroke::SetPriority ( int nPriority )

그려야하는 순서를 정의하는 값을 설정한다.

void sgObject::IStroke::SetSCap ( int nSCap )

라인의 시작점의 스타일를 설정한다.

void sgObject::IStroke::SetWidth ( double dfWidth )

펜의 두께를 설정한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IStroke
sgObject::IStroke 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IStroke (모든 상속된 멤버들도 포함합니다.)

GetCap() | sgObject::IStroke
GetColor() | sgObject::IStroke
GetECap() | sgObject::IStroke
GetID() | sgObject::IStroke
GetJoin() | sgObject::IStroke
GetOutlineColor() | sgObject::IStroke
GetOutlineWidth() | sgObject::IStroke
GetPattern() | sgObject::IStroke
GetPriority() | sgObject::IStroke
GetSCap() | sgObject::IStroke
GetStyleString() | sgObject::IStroke
GetWidth() | sgObject::IStroke
SetCap(BSTR bstrCap) | sgObject::IStroke
SetColor(BSTR bstrColor) | sgObject::IStroke
SetECap(int nECap) | sgObject::IStroke
SetID(BSTR bstrId) | sgObject::IStroke
SetJoin(BSTR bstrJoin) | sgObject::IStroke
SetOutlineColor(BSTR bstrOutlineColor) | sgObject::IStroke
SetOutlineWidth(int nInterval) | sgObject::IStroke
SetPattern(BSTR bstrPattern) | sgObject::IStroke
SetPriority(int nPriority) | sgObject::IStroke
SetSCap(int nSCap) | sgObject::IStroke
SetWidth(double dfWidth) | sgObject::IStroke
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ISurface 인터페이스 참조

  • ISurface
Public 멤버 함수 | 모든 멤버 목록
sgObject::ISurface 인터페이스 참조

기하 명세에 정의된 Surface에 대한 일반적인 인터페이스를 제공한다. 더 자세히 ...

sgObject::ISurface에 대한 상속 다이어그램 :
sgObject::ISurface에 대한 협력 다이어그램:

Public 멤버 함수

double | GetArea ()
면의 넓이를 반환한다. 더 자세히 ...
IPoint * Centroid ()
면의 수학적 중심점을 가져온다. 더 자세히 ...
IPoint * PointOnSurface ()
면 내에 존재하는 것이 보장되는 점 한 개를 가져온다. 더 자세히 ...
- sgObject::IGeometry(으)로부터 상속된 Public 멤버 함수
long | GetDimension ()
Geometry 객체의 차원 (0, 1, 2차원) 이다. 더 자세히 ...
ISpatialReference * GetSpatialReference ()
Geometry 객체가 참조하는 공간참조체계 (좌표체계) 이다. 더 자세히 ...
void | SetSpatialReference (ISpatialReference *pVal)
VARIANT_BOOL | IsEmpty ()
비어있는 Geometry 객체인지 나타낸다 (일반 프로그래밍 시 변수의 NULL과 유사) 더 자세히 ...
VARIANT_BOOL | IsSimple ()
기하가 심플한지 여부를 나타낸다. 더 자세히 ...
GeometryTypeEnum GetGeometryType ()
Geometry 객체의 구체적인 타입이다. 더 자세히 ...
void | SetEmpty ()
기하를 비어있는 기하로 만든다. 더 자세히 ...
IGeometry * Envelope ()
기하를 감싸는 최소 직사각형을 가져온다. 더 자세히 ...
IGeometry * Clone ()
해당 기하와 동일한 객체를 생성하여 가져온다. 더 자세히 ...
IGeometry * | Project ([in] ISpatialReference *newSystem)
기하를 새로운 공간참조체계로 투영해 만든 새로운 기하를 가져온다. 더 자세히 ...
void | Extent2D ([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY)
기하를 감싸는 최소 직사각형의 x, y 좌표를 Output 변수에 가져온다. 더 자세히 ...
IWks * GetWks ()
ISpatialRelation * GetSpatialRelation ()
ISpatialRelation2 * GetSpatialRelation2 ()
ISpatialOperator * GetSpatialOperator ()

상세한 설명

기하 명세에 정의된 Surface에 대한 일반적인 인터페이스를 제공한다.

(이 인터페이스는 모든 Surface에서 사용 가능한 연산을 기술한다.)
Surface에 대한 정의 및 기타 정보는 Knowledge Base의 Geometry를 참고한다. C API(linux, iOS, MacOS 등) : 중간이름 "G"를 덧붙여서 "OGR_G_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Geometry"

멤버 함수 문서화

IPoint* sgObject::ISurface::Centroid ( )

면의 수학적 중심점을 가져온다.

(중심점은 면의 외부에 있을 수도 있다)

반환값
중심점의 기하 포인터
double sgObject::ISurface::GetArea ( )

면의 넓이를 반환한다.

IPoint* sgObject::ISurface::PointOnSurface ( )

면 내에 존재하는 것이 보장되는 점 한 개를 가져온다.

반환값
점의 기하 포인터
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ISurface
sgObject::ISurface 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ISurface (모든 상속된 멤버들도 포함합니다.)

Centroid() | sgObject::ISurface
Clone() | sgObject::IGeometry
Envelope() | sgObject::IGeometry
Extent2D([in] double *minX, [in] double *minY, [in] double *maxX, [in] double *maxY) | sgObject::IGeometry
GetArea() | sgObject::ISurface
GetDimension() | sgObject::IGeometry
GetGeometryType() | sgObject::IGeometry
GetSpatialOperator() | sgObject::IGeometry
GetSpatialReference() | sgObject::IGeometry
GetSpatialRelation() | sgObject::IGeometry
GetSpatialRelation2() | sgObject::IGeometry
GetWks() | sgObject::IGeometry
IsEmpty() | sgObject::IGeometry
IsSimple() | sgObject::IGeometry
PointOnSurface() | sgObject::ISurface
Project([in] ISpatialReference *newSystem) | sgObject::IGeometry
SetEmpty() | sgObject::IGeometry
SetSpatialReference(ISpatialReference *pVal) | sgObject::IGeometry
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ISymbol 인터페이스 참조

  • ISymbol
Public 멤버 함수 | 모든 멤버 목록
sgObject::ISymbol 인터페이스 참조

Feature 객체를 화면에 표시하기 위해 심볼이 필요할 수도 있는데 ISymbol 인터페이스는 심볼 정보를 관리하는 Symbol 객체의 인터페이스를 제공한다. 더 자세히 ...

sgObject::ISymbol에 대한 상속 다이어그램 :
sgObject::ISymbol에 대한 협력 다이어그램:

Public 멤버 함수

BSTR | GetName ()
심볼의 이름 더 자세히 ...
BSTR | GetTitle ()
심볼의 제목 더 자세히 ...
BSTR | GetAbstract ()
심볼의 추상 개념 더 자세히 ...
SymbolTypeEnum GetSymbolType ()
관리하는 심볼의 타입 (이미지, 벡터) 더 자세히 ...

상세한 설명

Feature 객체를 화면에 표시하기 위해 심볼이 필요할 수도 있는데 ISymbol 인터페이스는 심볼 정보를 관리하는 Symbol 객체의 인터페이스를 제공한다.

Symbol 객체는 FeatureStyle 객체에 포함되어 관리된다.

멤버 함수 문서화

BSTR sgObject::ISymbol::GetAbstract ( )

심볼의 추상 개념

BSTR sgObject::ISymbol::GetName ( )

심볼의 이름

SymbolTypeEnum sgObject::ISymbol::GetSymbolType ( )

관리하는 심볼의 타입 (이미지, 벡터)

BSTR sgObject::ISymbol::GetTitle ( )

심볼의 제목

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ISymbol
sgObject::ISymbol 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ISymbol (모든 상속된 멤버들도 포함합니다.)

GetAbstract() | sgObject::ISymbol
GetName() | sgObject::ISymbol
GetSymbolType() | sgObject::ISymbol
GetTitle() | sgObject::ISymbol
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ISymbolizer 인터페이스 참조

  • ISymbolizer
Public 멤버 함수 | 모든 멤버 목록
sgObject::ISymbolizer 인터페이스 참조

Feature 객체를 화면에 표시하기 위해 필요한 그래픽 속성 (선굵기, 색 등)을 관리하는 FeatureStyle 객체의 인터페이스를 제공한다. 더 자세히 ...

sgObject::ISymbolizer에 대한 상속 다이어그램 :
sgObject::ISymbolizer에 대한 협력 다이어그램:

Public 멤버 함수

BSTR | GetName ()
Symbolizer 이름을 반환한다. (시스템에서 사용할 이름) 더 자세히 ...
void | SetName (BSTR bstrName)
Symbolizer 이름을 설정한다. (시스템에서 사용할 이름) 더 자세히 ...
double | GetMinScaleDenominator ()
화면에 표시할 때 Scale down할 수 있는 최소값을 반환한다. 더 자세히 ...
void | SetMinScaleDenominator (double dScale)
화면에 표시할 때 Scale down할 수 있는 최소값을 설정한다. 더 자세히 ...
double | GetMaxScaleDenominator ()
화면에 표시할 때 Scale up할 수 있는 최대값을 반환한다. 더 자세히 ...
void | SetMaxScaleDenominator (double dScale)
화면에 표시할 때 Scale up할 수 있는 최대값을 설정한다. 더 자세히 ...
void | AddStyleFromString (VARIANT vtIdx, BSTR bstrStyle)
해당 인덱스로 그래픽스타일을 추가한다. 더 자세히 ...
int | RemoveStyle (VARIANT vtIdx)
해당 인덱스의 그래픽스타일을 제거한다. 더 자세히 ...
BSTR | GetStyleToString (VARIANT vtIdx)
해당 인덱스의 그래픽스타일을 가져온다. 더 자세히 ...
ISymbolizer * Clone ()
Symbolizer를 복사하여 새로운 Symbolizer를 생성한다. 더 자세히 ...
SymbolizerTypeEnum GetSymbolizerType ()
Symbolizer의 타입을 반환한다. 더 자세히 ...
void | SetSymbolizerType (SymbolizerTypeEnum eType)
Symbolizer의 타입을 설정한다. 더 자세히 ...
IStroke * | GetStroke (BSTR bstrName)
라인 스타일 객체를 반환한다. 더 자세히 ...
IStroke * | SetStroke (BSTR bstrName, IStroke *poVal)
라인 스타일 객체를 설정한다. 더 자세히 ...
IFill * | GetFill (BSTR bstrName)
면 스타일 객체를 반환한다. 더 자세히 ...
IFill * | SetFill (BSTR bstrName, IFill *poVal)
면 스타일 객체를 설정한다. 더 자세히 ...
IMark * | GetMark (BSTR bstrName)
심볼 스타일 객체를 반환한다. 더 자세히 ...
IMark * | SetMark (BSTR bstrName, IMark *poVal)
심볼 스타일 객체를 설정한다. 더 자세히 ...
IFont * | GetFont (BSTR bstrName)
글꼴 스타일 객체를 반환한다. 더 자세히 ...
IFont * | SetFont (BSTR bstrName, IFont *poVal)
글꼴 스타일 객체를 설정한다. 더 자세히 ...

상세한 설명

Feature 객체를 화면에 표시하기 위해 필요한 그래픽 속성 (선굵기, 색 등)을 관리하는 FeatureStyle 객체의 인터페이스를 제공한다.

Feature 객체를 화면에 표시하기 위해 심볼이 필요할 수도 있는데 이런 경우 Symbol 객체가 심볼 정보를 관리한다. 이 Symbol 객체는 FeatureStyle 객체에 포함되어 관리된다. C API(linux, iOS, MacOS 등) : 중간이름 "SL"를 덧붙여서 "OGR_SL_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Symbolizer"

멤버 함수 문서화

void sgObject::ISymbolizer::AddStyleFromString | ( | VARIANT | vtIdx,
 |  | BSTR | bstrStyle
 | ) |  |

해당 인덱스로 그래픽스타일을 추가한다.

매개변수
vtIdx | - 인덱스 번호
bstrStyle | - 그래픽스타일을 나타내는 문자열
ISymbolizer* sgObject::ISymbolizer::Clone ( )

Symbolizer를 복사하여 새로운 Symbolizer를 생성한다.

IFill* sgObject::ISymbolizer::GetFill ( BSTR bstrName )

면 스타일 객체를 반환한다.

IFont* sgObject::ISymbolizer::GetFont ( BSTR bstrName )

글꼴 스타일 객체를 반환한다.

IMark* sgObject::ISymbolizer::GetMark ( BSTR bstrName )

심볼 스타일 객체를 반환한다.

double sgObject::ISymbolizer::GetMaxScaleDenominator ( )

화면에 표시할 때 Scale up할 수 있는 최대값을 반환한다.

반환값
화면에 표시할 때 Scale down할 수 있는 최대값
double sgObject::ISymbolizer::GetMinScaleDenominator ( )

화면에 표시할 때 Scale down할 수 있는 최소값을 반환한다.

반환값
화면에 표시할 때 Scale down할 수 있는 최소값
BSTR sgObject::ISymbolizer::GetName ( )

Symbolizer 이름을 반환한다. (시스템에서 사용할 이름)

반환값
Symbolizer 이름
IStroke* sgObject::ISymbolizer::GetStroke ( BSTR bstrName )

라인 스타일 객체를 반환한다.

BSTR sgObject::ISymbolizer::GetStyleToString ( VARIANT vtIdx )

해당 인덱스의 그래픽스타일을 가져온다.

매개변수
vtIdx - 인덱스 번호
반환값
그래픽스타일을 나타내는 문자열
SymbolizerTypeEnum sgObject::ISymbolizer::GetSymbolizerType ( )

Symbolizer의 타입을 반환한다.

int sgObject::ISymbolizer::RemoveStyle ( VARIANT vtIdx )

해당 인덱스의 그래픽스타일을 제거한다.

매개변수
vtIdx - 인덱스 번호
IFill* sgObject::ISymbolizer::SetFill | ( | BSTR | bstrName,
 |  | IFill * | poVal
 | ) |  |

면 스타일 객체를 설정한다.

IFont* sgObject::ISymbolizer::SetFont | ( | BSTR | bstrName,
 |  | IFont * | poVal
 | ) |  |

글꼴 스타일 객체를 설정한다.

IMark* sgObject::ISymbolizer::SetMark | ( | BSTR | bstrName,
 |  | IMark * | poVal
 | ) |  |

심볼 스타일 객체를 설정한다.

void sgObject::ISymbolizer::SetMaxScaleDenominator ( double dScale )

화면에 표시할 때 Scale up할 수 있는 최대값을 설정한다.

반환값
화면에 표시할 때 Scale down할 수 있는 최대값
void sgObject::ISymbolizer::SetMinScaleDenominator ( double dScale )

화면에 표시할 때 Scale down할 수 있는 최소값을 설정한다.

반환값
화면에 표시할 때 Scale down할 수 있는 최소값
void sgObject::ISymbolizer::SetName ( BSTR bstrName )

Symbolizer 이름을 설정한다. (시스템에서 사용할 이름)

매개변수
bstrName - Symbolizer 이름
IStroke* sgObject::ISymbolizer::SetStroke | ( | BSTR | bstrName,
 |  | IStroke * | poVal
 | ) |  |

라인 스타일 객체를 설정한다.

void sgObject::ISymbolizer::SetSymbolizerType ( SymbolizerTypeEnum eType )

Symbolizer의 타입을 설정한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ISymbolizer
sgObject::ISymbolizer 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ISymbolizer (모든 상속된 멤버들도 포함합니다.)

AddStyleFromString(VARIANT vtIdx, BSTR bstrStyle) | sgObject::ISymbolizer
Clone() | sgObject::ISymbolizer
GetFill(BSTR bstrName) | sgObject::ISymbolizer
GetFont(BSTR bstrName) | sgObject::ISymbolizer
GetMark(BSTR bstrName) | sgObject::ISymbolizer
GetMaxScaleDenominator() | sgObject::ISymbolizer
GetMinScaleDenominator() | sgObject::ISymbolizer
GetName() | sgObject::ISymbolizer
GetStroke(BSTR bstrName) | sgObject::ISymbolizer
GetStyleToString(VARIANT vtIdx) | sgObject::ISymbolizer
GetSymbolizerType() | sgObject::ISymbolizer
RemoveStyle(VARIANT vtIdx) | sgObject::ISymbolizer
SetFill(BSTR bstrName, IFill *poVal) | sgObject::ISymbolizer
SetFont(BSTR bstrName, IFont *poVal) | sgObject::ISymbolizer
SetMark(BSTR bstrName, IMark *poVal) | sgObject::ISymbolizer
SetMaxScaleDenominator(double dScale) | sgObject::ISymbolizer
SetMinScaleDenominator(double dScale) | sgObject::ISymbolizer
SetName(BSTR bstrName) | sgObject::ISymbolizer
SetStroke(BSTR bstrName, IStroke *poVal) | sgObject::ISymbolizer
SetSymbolizerType(SymbolizerTypeEnum eType) | sgObject::ISymbolizer
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ITabWidget 인터페이스 참조

  • ITabWidget
Public 멤버 함수 | 모든 멤버 목록
sgObject::ITabWidget 인터페이스 참조

탭위젯 객체를 제어하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::ITabWidget에 대한 상속 다이어그램 :
sgObject::ITabWidget에 대한 협력 다이어그램:

Public 멤버 함수

void | AddTab ([in] BSTR Title, [in] IWidget *dspWidget)
새로운 탭을 추가하고 해당 탭에 위젯을 추가한다. 더 자세히 ...
ICanvas * | AddCanvas ([in] BSTR Title, [in] BSTR strCanvasType)
새로운 탭을 추가하여 지도 객체를 생성하여 추가한다. 더 자세히 ...
void | SetTabPosition ([in] TapPositionEnum ePos)
탭의 위치를 설정한다. 더 자세히 ...
void | SetTabRoundedShape ([in] VARIANT_BOOL bVal)
탭의 모양을 둥근 모서리형태로 지정 여부 더 자세히 ...
- sgObject::IWidget(으)로부터 상속된 Public 멤버 함수
void | Initialize ([in] ULONG_PTR h)
위젯 초기화 더 자세히 ...
void | ReSize ([in] int x, [in] int y, [in] int cx, [in] int cy)
위젯 객체의 크기를 재설정 한다. 더 자세히 ...
void | AddWidget ([in] IWidget *dspWidget)
현재 위젯에 하부로 위젯을 추가한다. 더 자세히 ...
void | AddWidgetByLayout ([in] IWidget *dspWidget, [in] int row, [in] int col)
현재 위젯에 종, 횡 위치에 위젯을 추가한다. 더 자세히 ...
void | SetQtUiObjectVisible ([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue)
위젯의 해당 오브젝트 객체의 보이기 여부를 설정한다. 더 자세히 ...
long | GetBackColor ()
위젯이 사용하는 배경 색상 정보 더 자세히 ...
void | SetBackColor ([in] long color)
void | SetCanvas (ICanvas *poCanvas)
위젯을 특정(2D, 3D, Earth 등) 지도창으로 설정한다. 더 자세히 ...
IFeatureCanvas * GetFeatureCanvas ()
위젯이 사용하는 FeatureCanvas 정보 더 자세히 ...
void | SetFeatureCanvas (IFeatureCanvas *poFtCvs)
void | SetFeatureLayer (IFeatureLayer *poFtLayer)
위젯이 사용하는 FeatureLayer 정보 더 자세히 ...
void | SetLayer (ILayer *poLayer)
위젯이 사용하는 레이어 정보 더 자세히 ...
BSTR | GetFlag ()
위젯이 사용하는 문자열 파라메터 정보 더 자세히 ...
void | SetFlag (BSTR bstrFlag)
void | SetWidth (int nWidth)
위젯의 가로크기를 설정한다. 더 자세히 ...
int | SetHeight (int nHeight)
위젯의 세로크기를 설정한다. 더 자세히 ...
void | Destroy ()

상세한 설명

탭위젯 객체를 제어하는 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "TAW"를 덧붙여서 "OGR_TAW_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.TabWidget"

멤버 함수 문서화

ICanvas* sgObject::ITabWidget::AddCanvas | ( | [in] BSTR | Title,
 |  | [in] BSTR | strCanvasType
 | ) |  |

새로운 탭을 추가하여 지도 객체를 생성하여 추가한다.

매개변수
Title | - 탭 제목
strCanvasType | - 추가된 탭에 위치하는 지도 객체의 문자열 예) "map2d"
void sgObject::ITabWidget::AddTab | ( | [in] BSTR | Title,
 |  | [in] IWidget * | dspWidget
 | ) |  |

새로운 탭을 추가하고 해당 탭에 위젯을 추가한다.

매개변수
Title | - 탭 제목
dspWidget | - 추가된 탭에 위치하는 위젯
void sgObject::ITabWidget::SetTabPosition ( [in] TapPositionEnum ePos )

탭의 위치를 설정한다.

매개변수
ePos - 탭 위치
void sgObject::ITabWidget::SetTabRoundedShape ( [in] VARIANT_BOOL bVal )

탭의 모양을 둥근 모서리형태로 지정 여부

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ITabWidget
sgObject::ITabWidget 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ITabWidget (모든 상속된 멤버들도 포함합니다.)

AddCanvas([in] BSTR Title, [in] BSTR strCanvasType) | sgObject::ITabWidget
AddTab([in] BSTR Title, [in] IWidget *dspWidget) | sgObject::ITabWidget
AddWidget([in] IWidget *dspWidget) | sgObject::IWidget
AddWidgetByLayout([in] IWidget *dspWidget, [in] int row, [in] int col) | sgObject::IWidget
Destroy() | sgObject::IWidget
GetBackColor() | sgObject::IWidget
GetFeatureCanvas() | sgObject::IWidget
GetFlag() | sgObject::IWidget
Initialize([in] ULONG_PTR h) | sgObject::IWidget
ReSize([in] int x, [in] int y, [in] int cx, [in] int cy) | sgObject::IWidget
SetBackColor([in] long color) | sgObject::IWidget
SetCanvas(ICanvas *poCanvas) | sgObject::IWidget
SetFeatureCanvas(IFeatureCanvas *poFtCvs) | sgObject::IWidget
SetFeatureLayer(IFeatureLayer *poFtLayer) | sgObject::IWidget
SetFlag(BSTR bstrFlag) | sgObject::IWidget
SetHeight(int nHeight) | sgObject::IWidget
SetLayer(ILayer *poLayer) | sgObject::IWidget
SetQtUiObjectVisible([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue) | sgObject::IWidget
SetTabPosition([in] TapPositionEnum ePos) | sgObject::ITabWidget
SetTabRoundedShape([in] VARIANT_BOOL bVal) | sgObject::ITabWidget
SetWidth(int nWidth) | sgObject::IWidget
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ITextSymbolizer 인터페이스 참조

  • ITextSymbolizer
모든 멤버 목록
sgObject::ITextSymbolizer 인터페이스 참조

라벨의 텍스트 스타일을 표현하기 위해 사용한다. 더 자세히 ...

sgObject::ITextSymbolizer에 대한 상속 다이어그램 :
sgObject::ITextSymbolizer에 대한 협력 다이어그램:

추가로 상속된 멤버들

- sgObject::ISymbolizer(으)로부터 상속된 Public 멤버 함수
BSTR | GetName ()
Symbolizer 이름을 반환한다. (시스템에서 사용할 이름) 더 자세히 ...
void | SetName (BSTR bstrName)
Symbolizer 이름을 설정한다. (시스템에서 사용할 이름) 더 자세히 ...
double | GetMinScaleDenominator ()
화면에 표시할 때 Scale down할 수 있는 최소값을 반환한다. 더 자세히 ...
void | SetMinScaleDenominator (double dScale)
화면에 표시할 때 Scale down할 수 있는 최소값을 설정한다. 더 자세히 ...
double | GetMaxScaleDenominator ()
화면에 표시할 때 Scale up할 수 있는 최대값을 반환한다. 더 자세히 ...
void | SetMaxScaleDenominator (double dScale)
화면에 표시할 때 Scale up할 수 있는 최대값을 설정한다. 더 자세히 ...
void | AddStyleFromString (VARIANT vtIdx, BSTR bstrStyle)
해당 인덱스로 그래픽스타일을 추가한다. 더 자세히 ...
int | RemoveStyle (VARIANT vtIdx)
해당 인덱스의 그래픽스타일을 제거한다. 더 자세히 ...
BSTR | GetStyleToString (VARIANT vtIdx)
해당 인덱스의 그래픽스타일을 가져온다. 더 자세히 ...
ISymbolizer * Clone ()
Symbolizer를 복사하여 새로운 Symbolizer를 생성한다. 더 자세히 ...
SymbolizerTypeEnum GetSymbolizerType ()
Symbolizer의 타입을 반환한다. 더 자세히 ...
void | SetSymbolizerType (SymbolizerTypeEnum eType)
Symbolizer의 타입을 설정한다. 더 자세히 ...
IStroke * | GetStroke (BSTR bstrName)
라인 스타일 객체를 반환한다. 더 자세히 ...
IStroke * | SetStroke (BSTR bstrName, IStroke *poVal)
라인 스타일 객체를 설정한다. 더 자세히 ...
IFill * | GetFill (BSTR bstrName)
면 스타일 객체를 반환한다. 더 자세히 ...
IFill * | SetFill (BSTR bstrName, IFill *poVal)
면 스타일 객체를 설정한다. 더 자세히 ...
IMark * | GetMark (BSTR bstrName)
심볼 스타일 객체를 반환한다. 더 자세히 ...
IMark * | SetMark (BSTR bstrName, IMark *poVal)
심볼 스타일 객체를 설정한다. 더 자세히 ...
IFont * | GetFont (BSTR bstrName)
글꼴 스타일 객체를 반환한다. 더 자세히 ...
IFont * | SetFont (BSTR bstrName, IFont *poVal)
글꼴 스타일 객체를 설정한다. 더 자세히 ...

상세한 설명

라벨의 텍스트 스타일을 표현하기 위해 사용한다.

C API(linux, iOS, MacOS 등) : 중간이름 "SL"를 덧붙여서 "OGR_SL_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Symbolizer"

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ITextSymbolizer
sgObject::ITextSymbolizer 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ITextSymbolizer (모든 상속된 멤버들도 포함합니다.)

AddStyleFromString(VARIANT vtIdx, BSTR bstrStyle) | sgObject::ISymbolizer
Clone() | sgObject::ISymbolizer
GetFill(BSTR bstrName) | sgObject::ISymbolizer
GetFont(BSTR bstrName) | sgObject::ISymbolizer
GetMark(BSTR bstrName) | sgObject::ISymbolizer
GetMaxScaleDenominator() | sgObject::ISymbolizer
GetMinScaleDenominator() | sgObject::ISymbolizer
GetName() | sgObject::ISymbolizer
GetStroke(BSTR bstrName) | sgObject::ISymbolizer
GetStyleToString(VARIANT vtIdx) | sgObject::ISymbolizer
GetSymbolizerType() | sgObject::ISymbolizer
RemoveStyle(VARIANT vtIdx) | sgObject::ISymbolizer
SetFill(BSTR bstrName, IFill *poVal) | sgObject::ISymbolizer
SetFont(BSTR bstrName, IFont *poVal) | sgObject::ISymbolizer
SetMark(BSTR bstrName, IMark *poVal) | sgObject::ISymbolizer
SetMaxScaleDenominator(double dScale) | sgObject::ISymbolizer
SetMinScaleDenominator(double dScale) | sgObject::ISymbolizer
SetName(BSTR bstrName) | sgObject::ISymbolizer
SetStroke(BSTR bstrName, IStroke *poVal) | sgObject::ISymbolizer
SetSymbolizerType(SymbolizerTypeEnum eType) | sgObject::ISymbolizer
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IUserDefinedWidget 인터페이스 참조

  • IUserDefinedWidget
Public 멤버 함수 | 모든 멤버 목록
sgObject::IUserDefinedWidget 인터페이스 참조

사용자 정의 UI 객체를 정의/표현하기 위한 공통 인터페이스를 제공한다. 더 자세히 ...

sgObject::IUserDefinedWidget에 대한 상속 다이어그램 :
sgObject::IUserDefinedWidget에 대한 협력 다이어그램:

Public 멤버 함수

AlignPositionEnum GetPosition ()
Feature를 기준으로한 객체의 기준점 상대 위치 더 자세히 ...
void | SetPosition ([in] AlignPositionEnum pos)
int | GetRelateX ()
기준점으로부터 X 이격거리 더 자세히 ...
void | SetRelateX ([in] int x)
int | GetRelateY ()
기준점으로부터 Y 이격거리 더 자세히 ...
void | SetRelateY ([in] int y)
VARIANT_BOOL | IsExteriorHandle ()
외부 핸들인지의 여부 더 자세히 ...
void | SetExteriorHandle ([in] VARIANT_BOOL val)
VARIANT_BOOL | ExportImage (FileFormatEnum nFileType, BSTR bstrVal)
차트를 지정된 파일형태로 내보낸다. 더 자세히 ...
- sgObject::IWidget(으)로부터 상속된 Public 멤버 함수
void | Initialize ([in] ULONG_PTR h)
위젯 초기화 더 자세히 ...
void | ReSize ([in] int x, [in] int y, [in] int cx, [in] int cy)
위젯 객체의 크기를 재설정 한다. 더 자세히 ...
void | AddWidget ([in] IWidget *dspWidget)
현재 위젯에 하부로 위젯을 추가한다. 더 자세히 ...
void | AddWidgetByLayout ([in] IWidget *dspWidget, [in] int row, [in] int col)
현재 위젯에 종, 횡 위치에 위젯을 추가한다. 더 자세히 ...
void | SetQtUiObjectVisible ([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue)
위젯의 해당 오브젝트 객체의 보이기 여부를 설정한다. 더 자세히 ...
long | GetBackColor ()
위젯이 사용하는 배경 색상 정보 더 자세히 ...
void | SetBackColor ([in] long color)
void | SetCanvas (ICanvas *poCanvas)
위젯을 특정(2D, 3D, Earth 등) 지도창으로 설정한다. 더 자세히 ...
IFeatureCanvas * GetFeatureCanvas ()
위젯이 사용하는 FeatureCanvas 정보 더 자세히 ...
void | SetFeatureCanvas (IFeatureCanvas *poFtCvs)
void | SetFeatureLayer (IFeatureLayer *poFtLayer)
위젯이 사용하는 FeatureLayer 정보 더 자세히 ...
void | SetLayer (ILayer *poLayer)
위젯이 사용하는 레이어 정보 더 자세히 ...
BSTR | GetFlag ()
위젯이 사용하는 문자열 파라메터 정보 더 자세히 ...
void | SetFlag (BSTR bstrFlag)
void | SetWidth (int nWidth)
위젯의 가로크기를 설정한다. 더 자세히 ...
int | SetHeight (int nHeight)
위젯의 세로크기를 설정한다. 더 자세히 ...
void | Destroy ()

상세한 설명

사용자 정의 UI 객체를 정의/표현하기 위한 공통 인터페이스를 제공한다.

예를 들어 객체를 클릭한 경우 그 위치에 객체의 세부정보를 보여줄때 사용되기도 한다. Feature단위로 외부의 핸들을 UserDefinedWidget핸들로 셋팅하여 사용할 수 있다. C API(linux, iOS, MacOS 등) : 중간이름 "UD"를 덧붙여서 "OGR_UD_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.UserDefinedWidget"

멤버 함수 문서화

VARIANT_BOOL sgObject::IUserDefinedWidget::ExportImage | ( | FileFormatEnum | nFileType,
 |  | BSTR | bstrVal
 | ) |  |

차트를 지정된 파일형태로 내보낸다.

AlignPositionEnum sgObject::IUserDefinedWidget::GetPosition ( )

Feature를 기준으로한 객체의 기준점 상대 위치

int sgObject::IUserDefinedWidget::GetRelateX ( )

기준점으로부터 X 이격거리

int sgObject::IUserDefinedWidget::GetRelateY ( )

기준점으로부터 Y 이격거리

VARIANT_BOOL sgObject::IUserDefinedWidget::IsExteriorHandle ( )

외부 핸들인지의 여부

VARIANT_FALSE일 경우 외부 핸들의 소거권한은 UserDefinedWidget에도 있으며 UserDefinedWidget 소멸시 내부에서 같이 소멸시도를 한다.

void sgObject::IUserDefinedWidget::SetExteriorHandle ( [in] VARIANT_BOOL val )
void sgObject::IUserDefinedWidget::SetPosition ( [in] AlignPositionEnum pos )
void sgObject::IUserDefinedWidget::SetRelateX ( [in] int x )
void sgObject::IUserDefinedWidget::SetRelateY ( [in] int y )
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IUserDefinedWidget
sgObject::IUserDefinedWidget 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IUserDefinedWidget (모든 상속된 멤버들도 포함합니다.)

AddWidget([in] IWidget *dspWidget) | sgObject::IWidget
AddWidgetByLayout([in] IWidget *dspWidget, [in] int row, [in] int col) | sgObject::IWidget
Destroy() | sgObject::IWidget
ExportImage(FileFormatEnum nFileType, BSTR bstrVal) | sgObject::IUserDefinedWidget
GetBackColor() | sgObject::IWidget
GetFeatureCanvas() | sgObject::IWidget
GetFlag() | sgObject::IWidget
GetPosition() | sgObject::IUserDefinedWidget
GetRelateX() | sgObject::IUserDefinedWidget
GetRelateY() | sgObject::IUserDefinedWidget
Initialize([in] ULONG_PTR h) | sgObject::IWidget
IsExteriorHandle() | sgObject::IUserDefinedWidget
ReSize([in] int x, [in] int y, [in] int cx, [in] int cy) | sgObject::IWidget
SetBackColor([in] long color) | sgObject::IWidget
SetCanvas(ICanvas *poCanvas) | sgObject::IWidget
SetExteriorHandle([in] VARIANT_BOOL val) | sgObject::IUserDefinedWidget
SetFeatureCanvas(IFeatureCanvas *poFtCvs) | sgObject::IWidget
SetFeatureLayer(IFeatureLayer *poFtLayer) | sgObject::IWidget
SetFlag(BSTR bstrFlag) | sgObject::IWidget
SetHeight(int nHeight) | sgObject::IWidget
SetLayer(ILayer *poLayer) | sgObject::IWidget
SetPosition([in] AlignPositionEnum pos) | sgObject::IUserDefinedWidget
SetQtUiObjectVisible([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue) | sgObject::IWidget
SetRelateX([in] int x) | sgObject::IUserDefinedWidget
SetRelateY([in] int y) | sgObject::IUserDefinedWidget
SetWidth(int nWidth) | sgObject::IWidget
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IUtility 인터페이스 참조

  • IUtility
Public 멤버 함수 | 모든 멤버 목록
sgObject::IUtility 인터페이스 참조

일반적이지 않은 다양한 부수적인 기능 인터페이스를 제공한다. 더 자세히 ...

sgObject::IUtility에 대한 상속 다이어그램 :
sgObject::IUtility에 대한 협력 다이어그램:

Public 멤버 함수

void | Encryption ([in] BSTR Key, [in, out] VARIANT *Value)
AES 암호화 알고리즘을 사용하여 데이터를 암호화한다. 더 자세히 ...
VARIANT | Encryption1 ([in] BSTR Key, [in] VARIANT Value)
AES 암호화 알고리즘을 사용하여 데이터를 암호화한다. 더 자세히 ...
void | Decryption ([in] BSTR Key, [in, out] VARIANT *Value)
AES 암호화 알고리즘을 사용하여 암호화된 데이터를 복호화한다. 더 자세히 ...
BSTR | ProjectToMGRS ([in] IPoint *pVal, [in, defaultvalue(NULL)] ISpatialReference *poSrcRef)
일반 숫자 좌표를 MGRS좌표로 변환한다. 더 자세히 ...
IPoint * | ProjectMGRS ([in] BSTR strCoord, [in, defaultvalue(NULL)] ISpatialReference *poTgtRef)
MGRS좌표를 일반 숫자 좌표계로 변환한다. 더 자세히 ...
BSTR | ProjectWorldMapPoint ([in] ISpatialReference *poSrcRef, [in] double x, [in] double y, [in] int nLevel, [out] int *xPix, [out] int *yPix)
위치값에 해당하는 세계도면인덱스명을 반환한다. 더 자세히 ...
IPolygon * | WorldMapBoundingBox ([in] ISpatialReference *poTgtRef, [in] int nLevel, [in] BSTR strMapName)
세계도면인덱스명에 해당하는 도곽을 폴리곤으로 반환한다. 더 자세히 ...
BSTR | GetModuleFilePath ()
제품의 설치된 위치를 반환한다. 더 자세히 ...
VARIANT_BOOL | Compression ([in] BSTR strSrcFile, [in] BSTR strZipFile)
입력된 명칭에 해당하는 파일을 해당 압축파일로 압축한다. 더 자세히 ...
VARIANT_BOOL | Decompression ([in] BSTR strZipFile, [in] BSTR strOutPath)
입력된 명칭에 해당하는 압축파일을 해당 경로에 압축해제한다. 더 자세히 ...
VARIANT_BOOL | IsConfigured ()
제품이 올바로 설치 되었는지 여부를 반환한다. 더 자세히 ...
void | SetConfigured ([in] VARIANT_BOOL bConf)
제품의 설정구성 여부를 설정한다. 더 자세히 ...
void | ShowUpdater ()
업데이트 프로그램을 구동한다. 더 자세히 ...
BSTR | GetVersion ()
제품의 버전정보를 반환한다. 더 자세히 ...
BSTR | GetMyMacAddress ()
구동중인 장비의 네트워크 MAC주소 리스트를 반환한다. 더 자세히 ...
BSTR | GetMyIPAddress ()
구동중인 장비의 네트워크 IP주소 리스트를 반환한다. 더 자세히 ...
double | CalculateDistanceFromLL ([in] double x1, [in] double y1, [in] double x2, [in] double y2)
경위도 좌표간의 거리를 미터로 환산하여 반환한다. 더 자세히 ...
BSTR | GetLastErrorMsg ()
가장 최근에 발생된 오류 정보를 반환한다. 더 자세히 ...
BSTR | StringToUnicode ([in] BSTR strVal)
유니코드형식의 문자열로 변환하여 반환한다. 더 자세히 ...
BSTR | StringToUTF8 ([in] BSTR strVal)
UTF-8형식의 문자열로 변환하여 반환한다. 더 자세히 ...
BSTR | GetEncoding ()
문자 인코딩 타입을 반환한다. 더 자세히 ...
void | SetEncoding ([in] BSTR strVal)
문자 인코딩 타입을 설정한다. 더 자세히 ...
void | SetDebug ([in] VARIANT_BOOL bVal)
디버깅 로그 기록 여부를 설정한다. 더 자세히 ...
double | CalculateMeterUnitFromLL ([in] double x, [in] double y, [in] VARIANT_BOOL bHoriz)
경위도 좌표상에서 1미터에 해당하는 거리를 도단위로 환산하여 반환한다. 더 자세히 ...
double | GetSurfaceVolumeFromGridCoverage ([in] IGridCoverage *dspRaster, [in] IPolygon *dspRangeGeom, [in] VolumeTypeEnum eType, [in] double base_z, [in] double z_factor, [in] int pyramid_level_resolution)
DEM 그리드로부터 주어진 영역내 부피값을 계산한다. 더 자세히 ...
BSTR | GetConfigOption ([in] BSTR strKey)
시스템내 키에 해당하는 환경변수값을 반환한다. 더 자세히 ...
void | SetConfigOption ([in] BSTR strKey, [in] BSTR strValue)
시스템내 키에 해당하는 환경변수값을 설정 한다. 더 자세히 ...
long | ColorToNumber ([in] int red, [in] int green, [in] int blue, [in, defaultvalue(0)] int alpha)
RGBA 색상을 변환하여 반환한다. 더 자세히 ...
void | ColorStringToNumber ([in] BSTR strValue)
색상 문자열을 변환하여 반환한다. 더 자세히 ...
int | GetMap3DKeyFromQtKey ([in] int nQtKey)
QT 키보드의 키값을 Map3D의 키값으로 변환한다. 더 자세히 ...
int | GetMap2DKeyFromWinKey ([in] int nChar)
Windows 키보드의 키값을 Map2D의 키값으로 변환한다. 더 자세히 ...
BSTR | GetHttpResult ([in] BSTR strAddress, [in] BSTR strOption)
웹 Rest 서비스 호출을 통해 획득된 문자를 반환한다. 더 자세히 ...
VARIANT_BOOL | ProjectFromCRS ([out] double *x, [out] double *y, [in] ISpatialReference *poSRSRS, [in] ISpatialReference *poTgtSRS)
x, y 좌표를 좌표계 변환한다. 더 자세히 ...
VARIANT_BOOL | ProjectFromText ([out] double *x, [out] double *y, [in] BSTR strSrcSRS, [in] BSTR strTgtSRS)
x, y 좌표를 좌표계 변환한다. 더 자세히 ...

상세한 설명

일반적이지 않은 다양한 부수적인 기능 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "UT"를 덧붙여서 "OGR_UT_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Utility"

멤버 함수 문서화

double sgObject::IUtility::CalculateDistanceFromLL | ( | [in] double | x1,
 |  | [in] double | y1,
 |  | [in] double | x2,
 |  | [in] double | y2
 | ) |  |

경위도 좌표간의 거리를 미터로 환산하여 반환한다.

double sgObject::IUtility::CalculateMeterUnitFromLL | ( | [in] double | x,
 |  | [in] double | y,
 |  | [in] VARIANT_BOOL | bHoriz
 | ) |  |

경위도 좌표상에서 1미터에 해당하는 거리를 도단위로 환산하여 반환한다.

매개변수
x | - 기준 경도
y | - 기준 위도
bHoriz | - 위도(가로) 기준 여부
반환값
1미터에 해당하는 경위도 환산
void sgObject::IUtility::ColorStringToNumber ( [in] BSTR strValue )

색상 문자열을 변환하여 반환한다.

매개변수
strValue - 색상 문자열(ex: #ffffff)
long sgObject::IUtility::ColorToNumber | ( | [in] int | red,
 |  | [in] int | green,
 |  | [in] int | blue,
 |  | [in, defaultvalue(0)] int | alpha
 | ) |  |

RGBA 색상을 변환하여 반환한다.

매개변수
red | - Red 색상 값
green | - Green 색상 값
blue | - Blue 색상 값
alpha | - 투명도 값
VARIANT_BOOL sgObject::IUtility::Compression | ( | [in] BSTR | strSrcFile,
 |  | [in] BSTR | strZipFile
 | ) |  |

입력된 명칭에 해당하는 파일을 해당 압축파일로 압축한다.

매개변수
strSrcFile | - 압축할 파일의 명칭
strZipFile | - 압축된 파일의 출력위치 및 명칭
반환값
압축 성공 여부
VARIANT_BOOL sgObject::IUtility::Decompression | ( | [in] BSTR | strZipFile,
 |  | [in] BSTR | strOutPath
 | ) |  |

입력된 명칭에 해당하는 압축파일을 해당 경로에 압축해제한다.

매개변수
strZipFile | - 압축해제할 파일의 명칭
strOutPath | - 압축해제할 출력위치
반환값
압축해제 성공 여부
void sgObject::IUtility::Decryption | ( | [in] BSTR | Key,
 |  | [in, out] VARIANT * | Value
 | ) |  |

AES 암호화 알고리즘을 사용하여 암호화된 데이터를 복호화한다.

매개변수
Key | - 복호화 시 사용할 128비트 Key (암호화 시 사용한 값이 사용된다)
Value | - 메소드 호출 시 복호화할 데이터를 넣는다. (Value->vt에는 VT_ARRAY와 VT_BSTR가 들어갈 수 있다). 메소드가 실행되면 복호화된 데이터가 들어간다. (Value->vt는 VT_ARRAY | VT_UI1이다)
반환값
없음
void sgObject::IUtility::Encryption | ( | [in] BSTR | Key,
 |  | [in, out] VARIANT * | Value
 | ) |  |

AES 암호화 알고리즘을 사용하여 데이터를 암호화한다.

매개변수
Key | - 암호화 시 사용할 128비트 Key (복호화 시에도 같은 값이 사용된다)
Value | - 메소드 호출 시 암호화할 데이터를 넣는다. (Value->vt에는 VT_ARRAY와 VT_BSTR가 들어갈 수 있다). 메소드가 실행되면 암호화된 데이터가 들어간다. (Value->vt는 VT_ARRAY | VT_UI1이다)
반환값
없음
VARIANT sgObject::IUtility::Encryption1 | ( | [in] BSTR | Key,
 |  | [in] VARIANT | Value
 | ) |  |

AES 암호화 알고리즘을 사용하여 데이터를 암호화한다.

매개변수
Key | - 암호화 시 사용할 128비트 Key (복호화 시에도 같은 값이 사용된다)
Value | - 암호화할 데이터 (Value.vt에는 VT_ARRAY와 VT_BSTR가 들어갈 수 있다)
반환값
암호화된 데이터 (Value.vt는 VT_ARRAY | VT_UI1이다)
BSTR sgObject::IUtility::GetConfigOption ( [in] BSTR strKey )

시스템내 키에 해당하는 환경변수값을 반환한다.

매개변수
strKey - 환경변수 키값
반환값
변수값
BSTR sgObject::IUtility::GetEncoding ( )

문자 인코딩 타입을 반환한다.

BSTR sgObject::IUtility::GetHttpResult | ( | [in] BSTR | strAddress,
 |  | [in] BSTR | strOption
 | ) |  |

웹 Rest 서비스 호출을 통해 획득된 문자를 반환한다.

매개변수
strAddress | - 웹 Rest 주소
strOption | - 옵션(ex:HEADERS=Accept:application/sgmap-object;TIMEOUT=120)
BSTR sgObject::IUtility::GetLastErrorMsg ( )

가장 최근에 발생된 오류 정보를 반환한다.

int sgObject::IUtility::GetMap2DKeyFromWinKey ( [in] int nChar )

Windows 키보드의 키값을 Map2D의 키값으로 변환한다.

매개변수
nChar - Windows 키값
int sgObject::IUtility::GetMap3DKeyFromQtKey ( [in] int nQtKey )

QT 키보드의 키값을 Map3D의 키값으로 변환한다.

매개변수
nQtKey - Qt 키값(ex: Qt::Key_Escape)
BSTR sgObject::IUtility::GetModuleFilePath ( )

제품의 설치된 위치를 반환한다.

BSTR sgObject::IUtility::GetMyIPAddress ( )

구동중인 장비의 네트워크 IP주소 리스트를 반환한다.

BSTR sgObject::IUtility::GetMyMacAddress ( )

구동중인 장비의 네트워크 MAC주소 리스트를 반환한다.

double sgObject::IUtility::GetSurfaceVolumeFromGridCoverage | ( | [in] IGridCoverage * | dspRaster,
 |  | [in] IPolygon * | dspRangeGeom,
 |  | [in] VolumeTypeEnum | eType,
 |  | [in] double | base_z,
 |  | [in] double | z_factor,
 |  | [in] int | pyramid_level_resolution
 | ) |  |

DEM 그리드로부터 주어진 영역내 부피값을 계산한다.

매개변수
dspRaster | - DEM 그리드 객체
dspRangeGeom | - 연산 영역 폴리곤 객체
eType | - 기준 고도로 부터 위 또는 아래 선택(기본값 위)
base_z | - 기준 고도(기본값 0)
z_factor | - 고도 가중치(기본값 1)
pyramid_level_resolution | - 해상도 레벨(0 이하는 전체 픽셀계산)
반환값
부피
BSTR sgObject::IUtility::GetVersion ( )

제품의 버전정보를 반환한다.

VARIANT_BOOL sgObject::IUtility::IsConfigured ( )

제품이 올바로 설치 되었는지 여부를 반환한다.

VARIANT_BOOL sgObject::IUtility::ProjectFromCRS | ( | [out] double * | x,
 |  | [out] double * | y,
 |  | [in] ISpatialReference * | poSRSRS,
 |  | [in] ISpatialReference * | poTgtSRS
 | ) |  |

x, y 좌표를 좌표계 변환한다.

매개변수
x | - x 좌표
y | - y 좌표
poSRSRS | - 원본 좌표계 포인터
poTgtSRS | - 목표 좌표계 포인터
반환값
변환 성공 여부
VARIANT_BOOL sgObject::IUtility::ProjectFromText | ( | [out] double * | x,
 |  | [out] double * | y,
 |  | [in] BSTR | strSrcSRS,
 |  | [in] BSTR | strTgtSRS
 | ) |  |

x, y 좌표를 좌표계 변환한다.

매개변수
x | - x 좌표
y | - y 좌표
poSRSRS | - 원본 좌표계 문자열
poTgtSRS | - 목표 좌표계 문자열
반환값
변환 성공 여부
IPoint* sgObject::IUtility::ProjectMGRS | ( | [in] BSTR | strCoord,
 |  | [in, defaultvalue(NULL)] ISpatialReference * | poTgtRef
 | ) |  |

MGRS좌표를 일반 숫자 좌표계로 변환한다.

매개변수
strCoord | - MGRS 좌표 문자열
poTgtRef | - 변환 후 실세계 좌표의 공간참조계
반환값
실세계 숫자 좌표
BSTR sgObject::IUtility::ProjectToMGRS | ( | [in] IPoint * | pVal,
 |  | [in, defaultvalue(NULL)] ISpatialReference * | poSrcRef
 | ) |  |

일반 숫자 좌표를 MGRS좌표로 변환한다.

매개변수
pVal | - 실세계 좌표점
poSrcRef | - 실세계 좌표의 공간참조계
반환값
MGRS 좌표 문자열
BSTR sgObject::IUtility::ProjectWorldMapPoint | ( | [in] ISpatialReference * | poSrcRef,
 |  | [in] double | x,
 |  | [in] double | y,
 |  | [in] int | nLevel,
 |  | [out] int * | xPix,
 |  | [out] int * | yPix
 | ) |  |

위치값에 해당하는 세계도면인덱스명을 반환한다.

매개변수
poSrcRef | - 뒤 x, y 좌표값의 기준 좌표계
x | - X 좌표값
y | - Y 좌표값
nLevel | - 경위도를 기준으로 2의 승수로 표현되는 레벨값
xPix | - X좌표값을 도면인덱스로 변환 후 해당 도면에서 좌상단 위치 픽셀값 반환
yPix | - Y좌표값을 도면인덱스로 변환 후 해당 도면에서 좌상단 위치 픽셀값 반환
반환값
메소드가 실행되면 세계도면인덱스명이 문자로 반환된다.
void sgObject::IUtility::SetConfigOption | ( | [in] BSTR | strKey,
 |  | [in] BSTR | strValue
 | ) |  |

시스템내 키에 해당하는 환경변수값을 설정 한다.

매개변수
strKey | - 환경변수 키값
strValue | - 환경변수 값
void sgObject::IUtility::SetConfigured ( [in] VARIANT_BOOL bConf )

제품의 설정구성 여부를 설정한다.

void sgObject::IUtility::SetDebug ( [in] VARIANT_BOOL bVal )

디버깅 로그 기록 여부를 설정한다.

void sgObject::IUtility::SetEncoding ( [in] BSTR strVal )

문자 인코딩 타입을 설정한다.

void sgObject::IUtility::ShowUpdater ( )

업데이트 프로그램을 구동한다.

BSTR sgObject::IUtility::StringToUnicode ( [in] BSTR strVal )

유니코드형식의 문자열로 변환하여 반환한다.

BSTR sgObject::IUtility::StringToUTF8 ( [in] BSTR strVal )

UTF-8형식의 문자열로 변환하여 반환한다.

IPolygon* sgObject::IUtility::WorldMapBoundingBox | ( | [in] ISpatialReference * | poTgtRef,
 |  | [in] int | nLevel,
 |  | [in] BSTR | strMapName
 | ) |  |

세계도면인덱스명에 해당하는 도곽을 폴리곤으로 반환한다.

매개변수
poTgtRef | - 반환 도곽 폴리곤의 좌표계
nLevel | - 경위도를 기준으로 2의 승수로 표현되는 레벨값
strMapName | - 세계도면인덱스명
반환값
메소드가 실행되면 세계도면인덱스명에 해당하는 도곽 폴리곤이 반환된다.
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IUtility
sgObject::IUtility 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IUtility (모든 상속된 멤버들도 포함합니다.)

CalculateDistanceFromLL([in] double x1, [in] double y1, [in] double x2, [in] double y2) | sgObject::IUtility
CalculateMeterUnitFromLL([in] double x, [in] double y, [in] VARIANT_BOOL bHoriz) | sgObject::IUtility
ColorStringToNumber([in] BSTR strValue) | sgObject::IUtility
ColorToNumber([in] int red, [in] int green, [in] int blue, [in, defaultvalue(0)] int alpha) | sgObject::IUtility
Compression([in] BSTR strSrcFile, [in] BSTR strZipFile) | sgObject::IUtility
Decompression([in] BSTR strZipFile, [in] BSTR strOutPath) | sgObject::IUtility
Decryption([in] BSTR Key, [in, out] VARIANT *Value) | sgObject::IUtility
Encryption([in] BSTR Key, [in, out] VARIANT *Value) | sgObject::IUtility
Encryption1([in] BSTR Key, [in] VARIANT Value) | sgObject::IUtility
GetConfigOption([in] BSTR strKey) | sgObject::IUtility
GetEncoding() | sgObject::IUtility
GetHttpResult([in] BSTR strAddress, [in] BSTR strOption) | sgObject::IUtility
GetLastErrorMsg() | sgObject::IUtility
GetMap2DKeyFromWinKey([in] int nChar) | sgObject::IUtility
GetMap3DKeyFromQtKey([in] int nQtKey) | sgObject::IUtility
GetModuleFilePath() | sgObject::IUtility
GetMyIPAddress() | sgObject::IUtility
GetMyMacAddress() | sgObject::IUtility
GetSurfaceVolumeFromGridCoverage([in] IGridCoverage *dspRaster, [in] IPolygon *dspRangeGeom, [in] VolumeTypeEnum eType, [in] double base_z, [in] double z_factor, [in] int pyramid_level_resolution) | sgObject::IUtility
GetVersion() | sgObject::IUtility
IsConfigured() | sgObject::IUtility
ProjectFromCRS([out] double *x, [out] double *y, [in] ISpatialReference *poSRSRS, [in] ISpatialReference *poTgtSRS) | sgObject::IUtility
ProjectFromText([out] double *x, [out] double *y, [in] BSTR strSrcSRS, [in] BSTR strTgtSRS) | sgObject::IUtility
ProjectMGRS([in] BSTR strCoord, [in, defaultvalue(NULL)] ISpatialReference *poTgtRef) | sgObject::IUtility
ProjectToMGRS([in] IPoint *pVal, [in, defaultvalue(NULL)] ISpatialReference *poSrcRef) | sgObject::IUtility
ProjectWorldMapPoint([in] ISpatialReference *poSrcRef, [in] double x, [in] double y, [in] int nLevel, [out] int *xPix, [out] int *yPix) | sgObject::IUtility
SetConfigOption([in] BSTR strKey, [in] BSTR strValue) | sgObject::IUtility
SetConfigured([in] VARIANT_BOOL bConf) | sgObject::IUtility
SetDebug([in] VARIANT_BOOL bVal) | sgObject::IUtility
SetEncoding([in] BSTR strVal) | sgObject::IUtility
ShowUpdater() | sgObject::IUtility
StringToUnicode([in] BSTR strVal) | sgObject::IUtility
StringToUTF8([in] BSTR strVal) | sgObject::IUtility
WorldMapBoundingBox([in] ISpatialReference *poTgtRef, [in] int nLevel, [in] BSTR strMapName) | sgObject::IUtility
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IVectorAnalysis 인터페이스 참조

  • IVectorAnalysis
Public 멤버 함수 | 모든 멤버 목록
sgObject::IVectorAnalysis 인터페이스 참조

벡터 레이어에 있는 feature들을 이용해서 다양한 연산을 할 수 있도록 인터페이스를 제공합니다. 더 자세히 ...

sgObject::IVectorAnalysis에 대한 상속 다이어그램 :
sgObject::IVectorAnalysis에 대한 협력 다이어그램:

Public 멤버 함수

void | SetParameters ([in] IParameters *dspParams)
주어진 FeatureCollection 객체에 공간 연산에서 사용하는 세부 파라메터를 추가로 지정한다. 더 자세히 ...
IFeatureCollection * | ClipGeometry ([in] IFeatureCollection *dspFtCol, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
주어진 FeatureCollection 객체에 공간 연산을 하여 교집합, 차집합 객체로 이루어진 FeatureCollection 객체를 반환한다. 더 자세히 ...
IFeatureCollection * | IntersectGeometry ([in] IFeatureCollection *dspFtCol, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
주어진 FeatureCollection에 공간 연산을 하여 교집합 연산된 FeatureCollection을 반환한다. 더 자세히 ...
IFeatureCollection * | BoundaryGeometry ([in] VARIANT_BOOL bResultUnion, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
FeatureCollection에 있는 feature의 경계선을 FeatureCollection으로 반환한다. 더 자세히 ...
IFeatureCollection * | BufferGeometry ([in] double distance, [in] int quadsegs, [in] VARIANT_BOOL bResultUnion, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
기하마다 거리 버퍼를 적용해서 폴리곤 feature를 담고있는 FeatureCollection 객체를 반환 더 자세히 ...
IFeatureCollection * | BufferGeometryWithStyle ([in] double width, [in] int quadsegs, [in] LineCapEnum endCapStyle, [in] LineJoinEnum joinStyle, [in] double mitreLimit, [in] VARIANT_BOOL bResultUnion, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
기본 Buffer 기능에 스타일(라인 끝 버퍼의 모양, 라인이 꺽이는 부분의 버퍼 모양 등) 조절 기능을 추가 더 자세히 ...
IFeatureCollection * | BufferGeometryWithSingleSide ([in] double width, [in] int quadsegs, [in] LineJoinEnum joinStyle, [in] double mitreLimit, [in] VARIANT_BOOL bLeftSide, [in] VARIANT_BOOL bResultUnion, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
기본 Buffer 기능에 한쪽 방향에만 버퍼를 만들어주는 기능을 추가 더 자세히 ...
IFeatureCollection * | UnionGeometry ([in] IFeatureCollection *dspFtCol, [in] VARIANT_BOOL bResultUnion, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
두 FeatureCollection간의 Union Feature를 생성하여 FeatureCollection으로 반환한다. 즉, 두 FeatureCollection간에 합집합을 한다. 더 자세히 ...
IFeatureCollection * | DifferenceGeometry ([in] IFeatureCollection *dspFtCol, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
주어진 FeatureCollection 간의 공간 연산을 통해 차집합 연산된 FeatureCollection을 반환한다. 더 자세히 ...
IFeatureCollection * | SymmetricDifferenceGeometry ([in] IFeatureCollection *dspFtCol, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
두 FeatureCollection간의 차집합의 합집합 연산이 된 FeatureCollection을 반환한다. 즉, 교집합 부분을 제거한다. 더 자세히 ...
IFeatureCollection * | Merge ([in] IFeatureCollection *dspFtCol, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
FeatureCollection 간의 합친 결과를 반환한다. 더 자세히 ...
IFeatureCollection * | Split ([in] ILineString *dspSplitLine, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
주어진 라인객체를 이용하여 잘라진 결과 FeatureCollection을 반환한다. 더 자세히 ...
IFeatureCollection * | Dissolve ([in] BSTR bstrAttrDescList, [in] BSTR bstrStatisticsFields, [in, defaultvalue(FALSE)] VARIANT_BOOL bUseMultiPart, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
주어진 속성필드 값이 같은 것끼리 공간 연산을 통해 합집합된 Feature의 셋을 반환한다. 더 자세히 ...
IFeatureCollection * | Generalize ([in] double dDistanceTolerance, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
레이어의 feature(Point,Line,Curve,Circle,Rectangle,Polygon)에서 인접한 vertex간의 거리가 지정한 dDistanceTolerance 값 이내라면 더 자세히 ...
IFeatureCollection * | Densify ([in] double dDistanceTolerance, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
레이어의 feature(Point,Line,Curve,Circle,Rectangle,Polygon)에서 인접한 vertex간의 거리가 지정한 dDistanceTolerance 값 이내라면 더 자세히 ...
IFeatureCollection * | RepairGeometry ([in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
Geometry에 존재하는 문제점(오류)를 해결하여 정상적인 Geometry를 반환합니다. 더 자세히 ...
IFeatureCollection * | Fishnet ([in] double dlExtMinX, [in] double dlExtMinY, [in] double dlExtMaxX, [in] double dlExtMaxY, [in] double dlUnitWidth, [in] double dlUnitHeight, [in, defaultvalue(FALSE)] VARIANT_BOOL bLineString, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
사각형 셀 객체 폴리곤을 생성한다. (파라메터의 생성 범위 값이 모두 0이면 현재 FeatureCollection의 범위 값을 사용함) 더 자세히 ...
IFeatureCollection * | DelaunayTriangulation ([in, defaultvalue(0)] double dlTolerence, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
델로네 삼각분할(TIN)은 평면에 여러 점을 잡은 뒤 외접원의 내부에 다른 점이 없는 삼각형의 세변을 이은 것으로 티센폴리곤(보로노이 다이어그램)과는 상대 관계이다. 더 자세히 ...
IFeatureCollection * | ThiessenPolygon ([in, defaultvalue(0)] double dlTolerence, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
티센폴리곤(보로노이 다이어그램)은 공간에 여러개의 점을 잡을때 공간을 가장 가까운 점에 따라 나눈 폴리곤으로 한 점에 가장 가까운 구역 영역으로 델로네 삼각분할과는 상대 관계이다. 더 자세히 ...
IFeatureCollection * | FeaturesToPoint ([in] BSTR bstrInside, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
Polygon FeatureCollection을 Point FeatureCollection으로 변환 후 FeatureCollection을 반환한다. 더 자세히 ...
IFeatureCollection * | FeatureVerticesToPoints ([in] PointLocationEnum ePointLocation, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
Feature내의 모든 Vertex를 Point로 변환 후 FeatureCollection을 반환한다. 더 자세히 ...
IFeatureCollection * | MultipartToSinglepart ([in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
Multi Geometry를 Single Geometry로 변환 후 FeatureCollection을 반환한다. 더 자세히 ...
IFeatureCollection * | RemoveHoles ([in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
Geometry내의 구멍처럼 뚫린 부분을 없앤 후 FeatureCollection을 반환한다. 더 자세히 ...
IFeatureCollection * | Project ([in] ISpatialReference *dspSrcSRS, [in] ISpatialReference *dspDecSRS, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
원본좌표계에서 목표좌표계로 변환 후 FeatureCollection을 반환한다. 더 자세히 ...
IFeatureCollection * | MoveDistance ([in] double dlLenX, [in] double dlLenY, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
주어진 x, y 거리만큼 이동한다. 더 자세히 ...
IFeatureCollection * | MoveAngle ([in] double dlLength, [in] long nAngle, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
주어진 각도로 주어진 거리만큼 이동한다. 더 자세히 ...
IFeatureCollection * | Rotate ([in] double dlStandX, [in] double dlStandY, [in] long nAngle, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
주어진 기준점으로부터 주어진 각만큼 회전한다. 더 자세히 ...
IFeatureCollection * | Scale ([in] double dlStandX, [in] double dlStandY, [in] double dlSX, [in] double dlSY, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
Scale(크기) 조절 기능 더 자세히 ...
IFeatureCollection * | PolygonGeneralize ([in] double dDistanceTolerance, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
Generalize와 유사하지만 폴리곤간의 인접을 유지하면서 단순화를 진행합니다. 더 자세히 ...
IFeatureCollection * | UnionLineMerge ([in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
객체들을 라인으로 변경하고 union 공간연산을 하고 중복을 삭제한다.(네트워크 edge를 생성한다) 더 자세히 ...
IFeatureCollection * | LineToPolygon ([in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
Line FeatureCollection을 Polygon FeatureCollection으로 변환 후 FeatureCollection을 반환한다. 더 자세히 ...
IFeatureCollection * | PolygonToLine ([in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal)
Line FeatureCollection을 Polygon FeatureCollection으로 변환 후 FeatureCollection을 반환한다. 더 자세히 ...
void | Group ()
선택한 Polygon FeatureCollection을 그룹화하여 하나의 MultiPolygon FeatureCollection으로 변환한다. 더 자세히 ...
void | Ungroup ()
하나의 MultiPolygon FeatureCollection을 개별 Polygon FeatureCollection으로 나눈다. 더 자세히 ...

상세한 설명

벡터 레이어에 있는 feature들을 이용해서 다양한 연산을 할 수 있도록 인터페이스를 제공합니다.

C API(linux, iOS, MacOS 등) : 중간이름 "FC"를 덧붙여서 "OGR_FC_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.FeatureCollection"

멤버 함수 문서화

IFeatureCollection* sgObject::IVectorAnalysis::BoundaryGeometry | ( | [in] VARIANT_BOOL | bResultUnion,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

FeatureCollection에 있는 feature의 경계선을 FeatureCollection으로 반환한다.

매개변수
bResultUnion | - 선택한 레이어에 있는 기존 FeatureCollection 객체를 처리 결과와 합집합할지, 아니면 삭제할지를 결정합니다. VARIANT_TRUE면 합집합을 하고, VARIANT_FALSE면 삭제를 한다.(defaultvalue는 FALSE)
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::BufferGeometry | ( | [in] double | distance,
 |  | [in] int | quadsegs,
 |  | [in] VARIANT_BOOL | bResultUnion,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

기하마다 거리 버퍼를 적용해서 폴리곤 feature를 담고있는 FeatureCollection 객체를 반환

매개변수
distance | - 버퍼 줄 거리(기본 라인으로부터 얼마의 width 만큼씩 버퍼를 줄 것인가를 결정)
quadsegs | - 버퍼 줄 객체의 끝 부분 즉, 라인 끝 버퍼에 몇 개의 점을 주느냐 즉 몇 개의 세그먼트로 나누어 정몇각형을 만들 것이냐를 지정
bResultUnion | - 선택한 레이어에 있는 기존 FeatureCollection 객체를 처리 결과와 합집합할지, 아니면 삭제할지를 결정합니다. VARIANT_TRUE면 합집합을 하고, VARIANT_FALSE면 삭제를 한다.(defaultvalue는 FALSE)
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::BufferGeometryWithSingleSide | ( | [in] double | width,
 |  | [in] int | quadsegs,
 |  | [in] LineJoinEnum | joinStyle,
 |  | [in] double | mitreLimit,
 |  | [in] VARIANT_BOOL | bLeftSide,
 |  | [in] VARIANT_BOOL | bResultUnion,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

기본 Buffer 기능에 한쪽 방향에만 버퍼를 만들어주는 기능을 추가

매개변수
width | - 버퍼 줄 거리(기본 라인으로부터 얼마의 width 만큼씩 버퍼를 줄 것인가를 결정)
quadsegs | - 버퍼 줄 객체의 끝 부분 즉, 라인 끝 버퍼에 몇 개의 점을 주느냐 즉 몇 개의 세그먼트로 나누어 정몇각형을 만들 것이냐를 지정
joinStyle | - 라인이 꺽이는 부분의 버퍼 모양을 설정한다. sgLJ_Round = 선과 선 사이에 부드러운 원형 호로 표현 sgLJ_Mitre = 선과 선 사이에 날카로운 모퉁이나 클리핑된 모퉁이로 표현 sgLJ_Bevel = 선과 선 사이에 대각선 모퉁이로 표현
mitreLimit | - 꺽이는 각의 한도를 설정한다. (defaultvalue는 0)
bLeftSide | - 어느 쪽 방향에 버퍼를 만들지 설정한다.
bResultUnion | - 선택한 레이어에 있는 기존 FeatureCollection 객체를 처리 결과와 합집합할지, 아니면 삭제할지를 결정합니다. VARIANT_TRUE면 합집합을 하고, VARIANT_FALSE면 삭제를 한다.(defaultvalue는 FALSE)
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::BufferGeometryWithStyle | ( | [in] double | width,
 |  | [in] int | quadsegs,
 |  | [in] LineCapEnum | endCapStyle,
 |  | [in] LineJoinEnum | joinStyle,
 |  | [in] double | mitreLimit,
 |  | [in] VARIANT_BOOL | bResultUnion,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

기본 Buffer 기능에 스타일(라인 끝 버퍼의 모양, 라인이 꺽이는 부분의 버퍼 모양 등) 조절 기능을 추가

매개변수
width | - 버퍼 줄 거리(기본 라인으로부터 얼마의 width 만큼씩 버퍼를 줄 것인가를 결정)
quadsegs | - 버퍼 줄 객체의 끝 부분 즉, 라인 끝 버퍼에 몇 개의 점을 주느냐 즉 몇 개의 세그먼트로 나누어 정몇각형을 만들 것이냐를 지정
endCapStyle | - 라인 끝 버퍼의 모양을 설정한다. sgLC_Flat = 일직선 형태의 끝 모양을 지정 sgLC_Square = 정사각형 형태의 선 끝 모양을 지정 sgLC_Round = 둥근 선 끝 모양을 지정
joinStyle | - 라인이 꺽이는 부분의 버퍼 모양을 설정한다. sgLJ_Round = 선과 선 사이에 부드러운 원형 호로 표현 sgLJ_Mitre = 선과 선 사이에 날카로운 모퉁이나 클리핑된 모퉁이로 표현 sgLJ_Bevel = 선과 선 사이에 대각선 모퉁이로 표현
mitreLimit | - 꺽이는 각의 한도를 설정한다. (defaultvalue는 0)
bResultUnion | - 선택한 레이어에 있는 기존 FeatureCollection 객체를 처리 결과와 합집합할지, 아니면 삭제할지를 결정합니다. VARIANT_TRUE면 합집합을 하고, VARIANT_FALSE면 삭제를 한다.(defaultvalue는 FALSE)
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::ClipGeometry | ( | [in] IFeatureCollection * | dspFtCol,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

주어진 FeatureCollection 객체에 공간 연산을 하여 교집합, 차집합 객체로 이루어진 FeatureCollection 객체를 반환한다.

매개변수
dspFtCol | - 공간 연산을 하려는 FeatureCollection 객체
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::DelaunayTriangulation | ( | [in, defaultvalue(0)] double | dlTolerence,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

델로네 삼각분할(TIN)은 평면에 여러 점을 잡은 뒤 외접원의 내부에 다른 점이 없는 삼각형의 세변을 이은 것으로 티센폴리곤(보로노이 다이어그램)과는 상대 관계이다.

매개변수
dlTolerence -
bNewVal -
반환값
IFeatureCollection* sgObject::IVectorAnalysis::Densify | ( | [in] double | dDistanceTolerance,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

레이어의 feature(Point,Line,Curve,Circle,Rectangle,Polygon)에서 인접한 vertex간의 거리가 지정한 dDistanceTolerance 값 이내라면

치밀화되어 선택한 bVal에 따라 해당 레이어에 생성합니다.

매개변수
dDistanceTolerance | - Generalize의 허용오차를 설정한다.
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::DifferenceGeometry | ( | [in] IFeatureCollection * | dspFtCol,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

주어진 FeatureCollection 간의 공간 연산을 통해 차집합 연산된 FeatureCollection을 반환한다.

매개변수
dspFtCol | - 차집합 공간 연산을 위해 주어지는 FeatureCollection
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::Dissolve | ( | [in] BSTR | bstrAttrDescList,
 |  | [in] BSTR | bstrStatisticsFields,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bUseMultiPart,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

주어진 속성필드 값이 같은 것끼리 공간 연산을 통해 합집합된 Feature의 셋을 반환한다.

매개변수
bstrAttrDescList | - Feature 객체에 저장된 콤마로 구분되는 일반 (속성) 정보 필드명 리스트
bstrStatisticsFields | - 속성필드의 값을 합칠 필드 리스트(구분자는 ,)
bUseMultiPart | - 합집합된 객체의 Multi Part 허용 여부 (허용하지 않는 경우 여러개의 객체로 나뉨)
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::FeaturesToPoint | ( | [in] BSTR | bstrInside,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

Polygon FeatureCollection을 Point FeatureCollection으로 변환 후 FeatureCollection을 반환한다.

매개변수
bstrInside | - 다양한 옵션을 설정. 현재는 Centroid(중심점)만을 지원함
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::FeatureVerticesToPoints | ( | [in] PointLocationEnum | ePointLocation,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

Feature내의 모든 Vertex를 Point로 변환 후 FeatureCollection을 반환한다.

매개변수
ePointLocation | - 변환할 Vertex를 지정한다. (sgPL_All, sgPL_Start, sgPL_Mid, sgPL_End, sgPL_Both_Ends)
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::Fishnet | ( | [in] double | dlExtMinX,
 |  | [in] double | dlExtMinY,
 |  | [in] double | dlExtMaxX,
 |  | [in] double | dlExtMaxY,
 |  | [in] double | dlUnitWidth,
 |  | [in] double | dlUnitHeight,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bLineString,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

사각형 셀 객체 폴리곤을 생성한다. (파라메터의 생성 범위 값이 모두 0이면 현재 FeatureCollection의 범위 값을 사용함)

매개변수
dlExtMinX | - 생성 범위 최소 X값
dlExtMinY | - 생성 범위 최소 Y값
dlExtMaxX | - 생성 범위 최대 X값
dlExtMaxY | - 생성 범위 최대 Y값
dlUnitWidth | - 셀 객체의 가로 크기값
dlUnitHeight | - 셀 객체의 세로 크기값
bLineString | - 라인형태로 생성 여부
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::Generalize | ( | [in] double | dDistanceTolerance,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

레이어의 feature(Point,Line,Curve,Circle,Rectangle,Polygon)에서 인접한 vertex간의 거리가 지정한 dDistanceTolerance 값 이내라면

단순화되어 선택한 bVal에 따라 해당 레이어에 생성합니다.

매개변수
dDistanceTolerance | - Generalize의 허용오차를 설정한다.
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
void sgObject::IVectorAnalysis::Group ( )

선택한 Polygon FeatureCollection을 그룹화하여 하나의 MultiPolygon FeatureCollection으로 변환한다.

IFeatureCollection* sgObject::IVectorAnalysis::IntersectGeometry | ( | [in] IFeatureCollection * | dspFtCol,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

주어진 FeatureCollection에 공간 연산을 하여 교집합 연산된 FeatureCollection을 반환한다.

매개변수
dspFtCol | - 교집합 공간 연산을 위해 주어지는 FeatureCollection
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::LineToPolygon ( [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal )

Line FeatureCollection을 Polygon FeatureCollection으로 변환 후 FeatureCollection을 반환한다.

매개변수
bNewVal - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::Merge | ( | [in] IFeatureCollection * | dspFtCol,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

FeatureCollection 간의 합친 결과를 반환한다.

매개변수
dspFtCol | - 연산을 위해 주어지는 FeatureCollection
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::MoveAngle | ( | [in] double | dlLength,
 |  | [in] long | nAngle,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

주어진 각도로 주어진 거리만큼 이동한다.

매개변수
dlLength | - 이동할 거리
nAngle | - 이동할 각도
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::MoveDistance | ( | [in] double | dlLenX,
 |  | [in] double | dlLenY,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

주어진 x, y 거리만큼 이동한다.

매개변수
dlLenX | - x 좌표
dlLenY | - y 좌표
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::MultipartToSinglepart ( [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal )

Multi Geometry를 Single Geometry로 변환 후 FeatureCollection을 반환한다.

매개변수
bNewVal - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::PolygonGeneralize | ( | [in] double | dDistanceTolerance,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

Generalize와 유사하지만 폴리곤간의 인접을 유지하면서 단순화를 진행합니다.

매개변수
dDistanceTolerance | - 허용오차를 설정한다.
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::PolygonToLine ( [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal )

Line FeatureCollection을 Polygon FeatureCollection으로 변환 후 FeatureCollection을 반환한다.

매개변수
bNewVal - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::Project | ( | [in] ISpatialReference * | dspSrcSRS,
 |  | [in] ISpatialReference * | dspDecSRS,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

원본좌표계에서 목표좌표계로 변환 후 FeatureCollection을 반환한다.

매개변수
dspSrcSRS | - 원본좌표계
dspDecSRS | - 목표좌표계
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::RemoveHoles ( [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal )

Geometry내의 구멍처럼 뚫린 부분을 없앤 후 FeatureCollection을 반환한다.

매개변수
bNewVal - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::RepairGeometry ( [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal )

Geometry에 존재하는 문제점(오류)를 해결하여 정상적인 Geometry를 반환합니다.

매개변수
bNewVal - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::Rotate | ( | [in] double | dlStandX,
 |  | [in] double | dlStandY,
 |  | [in] long | nAngle,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

주어진 기준점으로부터 주어진 각만큼 회전한다.

매개변수
dlStandX | - 기준점 x 좌표
dlStandY | - 기준점 y 좌표
nAngle | - 회전할 각도
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::Scale | ( | [in] double | dlStandX,
 |  | [in] double | dlStandY,
 |  | [in] double | dlSX,
 |  | [in] double | dlSY,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

Scale(크기) 조절 기능

매개변수
dlStandX | - 기준점 x 좌표
dlStandY | - 기준점 y 좌표
dlSX | - x 배율
dlSY | - y 배율
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
void sgObject::IVectorAnalysis::SetParameters ( [in] IParameters * dspParams )

주어진 FeatureCollection 객체에 공간 연산에서 사용하는 세부 파라메터를 추가로 지정한다.

매개변수
dspParams - 공간 연산을 하려는 FeatureCollection 객체의 세부 파라메터들
IFeatureCollection* sgObject::IVectorAnalysis::Split | ( | [in] ILineString * | dspSplitLine,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

주어진 라인객체를 이용하여 잘라진 결과 FeatureCollection을 반환한다.

매개변수
dspSplitLine | - 객체를 자르기 위한 기준 라인 객체
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::SymmetricDifferenceGeometry | ( | [in] IFeatureCollection * | dspFtCol,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

두 FeatureCollection간의 차집합의 합집합 연산이 된 FeatureCollection을 반환한다. 즉, 교집합 부분을 제거한다.

매개변수
dspFtCol | - 공간 연산을 위해 주어지는 FeatureCollection
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::ThiessenPolygon | ( | [in, defaultvalue(0)] double | dlTolerence,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

티센폴리곤(보로노이 다이어그램)은 공간에 여러개의 점을 잡을때 공간을 가장 가까운 점에 따라 나눈 폴리곤으로 한 점에 가장 가까운 구역 영역으로 델로네 삼각분할과는 상대 관계이다.

매개변수
dlTolerence -
bNewVal -
반환값
void sgObject::IVectorAnalysis::Ungroup ( )

하나의 MultiPolygon FeatureCollection을 개별 Polygon FeatureCollection으로 나눈다.

IFeatureCollection* sgObject::IVectorAnalysis::UnionGeometry | ( | [in] IFeatureCollection * | dspFtCol,
 |  | [in] VARIANT_BOOL | bResultUnion,
 |  | [in, defaultvalue(FALSE)] VARIANT_BOOL | bNewVal
 | ) |  |

두 FeatureCollection간의 Union Feature를 생성하여 FeatureCollection으로 반환한다. 즉, 두 FeatureCollection간에 합집합을 한다.

매개변수
dspFtCol | - 합집합 공간 연산을 위해 주어지는 FeatureCollection
bResultUnion | - 선택한 레이어에 있는 기존 FeatureCollection 객체를 처리 결과와 합집합할지, 아니면 삭제할지를 결정합니다.
bNewVal | - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
IFeatureCollection* sgObject::IVectorAnalysis::UnionLineMerge ( [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal )

객체들을 라인으로 변경하고 union 공간연산을 하고 중복을 삭제한다.(네트워크 edge를 생성한다)

매개변수
bNewVal - 새로운 레이어에 처리 결과 넣을지 여부를 결정한다. (FALSE시 현재 FeatureCollection에 입력) VARIANT_TRUE면 새 레이어에, VARIANT_FALSE면 원본 레이어에 넣는다.(defaultvalue는 FALSE)
반환값
처리를 통해 얻어진 FeatureCollection 객체의 포인터
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IVectorAnalysis
sgObject::IVectorAnalysis 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IVectorAnalysis (모든 상속된 멤버들도 포함합니다.)

BoundaryGeometry([in] VARIANT_BOOL bResultUnion, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
BufferGeometry([in] double distance, [in] int quadsegs, [in] VARIANT_BOOL bResultUnion, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
BufferGeometryWithSingleSide([in] double width, [in] int quadsegs, [in] LineJoinEnum joinStyle, [in] double mitreLimit, [in] VARIANT_BOOL bLeftSide, [in] VARIANT_BOOL bResultUnion, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
BufferGeometryWithStyle([in] double width, [in] int quadsegs, [in] LineCapEnum endCapStyle, [in] LineJoinEnum joinStyle, [in] double mitreLimit, [in] VARIANT_BOOL bResultUnion, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
ClipGeometry([in] IFeatureCollection *dspFtCol, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
DelaunayTriangulation([in, defaultvalue(0)] double dlTolerence, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
Densify([in] double dDistanceTolerance, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
DifferenceGeometry([in] IFeatureCollection *dspFtCol, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
Dissolve([in] BSTR bstrAttrDescList, [in] BSTR bstrStatisticsFields, [in, defaultvalue(FALSE)] VARIANT_BOOL bUseMultiPart, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
FeaturesToPoint([in] BSTR bstrInside, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
FeatureVerticesToPoints([in] PointLocationEnum ePointLocation, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
Fishnet([in] double dlExtMinX, [in] double dlExtMinY, [in] double dlExtMaxX, [in] double dlExtMaxY, [in] double dlUnitWidth, [in] double dlUnitHeight, [in, defaultvalue(FALSE)] VARIANT_BOOL bLineString, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
Generalize([in] double dDistanceTolerance, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
Group() | sgObject::IVectorAnalysis
IntersectGeometry([in] IFeatureCollection *dspFtCol, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
LineToPolygon([in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
Merge([in] IFeatureCollection *dspFtCol, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
MoveAngle([in] double dlLength, [in] long nAngle, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
MoveDistance([in] double dlLenX, [in] double dlLenY, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
MultipartToSinglepart([in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
PolygonGeneralize([in] double dDistanceTolerance, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
PolygonToLine([in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
Project([in] ISpatialReference *dspSrcSRS, [in] ISpatialReference *dspDecSRS, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
RemoveHoles([in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
RepairGeometry([in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
Rotate([in] double dlStandX, [in] double dlStandY, [in] long nAngle, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
Scale([in] double dlStandX, [in] double dlStandY, [in] double dlSX, [in] double dlSY, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
SetParameters([in] IParameters *dspParams) | sgObject::IVectorAnalysis
Split([in] ILineString *dspSplitLine, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
SymmetricDifferenceGeometry([in] IFeatureCollection *dspFtCol, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
ThiessenPolygon([in, defaultvalue(0)] double dlTolerence, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
Ungroup() | sgObject::IVectorAnalysis
UnionGeometry([in] IFeatureCollection *dspFtCol, [in] VARIANT_BOOL bResultUnion, [in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
UnionLineMerge([in, defaultvalue(FALSE)] VARIANT_BOOL bNewVal) | sgObject::IVectorAnalysis
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IVideo 인터페이스 참조

  • IVideo
모든 멤버 목록
sgObject::IVideo 인터페이스 참조

비디오의 세부 속성을 설정하기 위한 인터페이스를 제공한다. 더 자세히 ...

sgObject::IVideo에 대한 상속 다이어그램 :
sgObject::IVideo에 대한 협력 다이어그램:

추가로 상속된 멤버들

- sgObject::IUserDefinedWidget(으)로부터 상속된 Public 멤버 함수
AlignPositionEnum GetPosition ()
Feature를 기준으로한 객체의 기준점 상대 위치 더 자세히 ...
void | SetPosition ([in] AlignPositionEnum pos)
int | GetRelateX ()
기준점으로부터 X 이격거리 더 자세히 ...
void | SetRelateX ([in] int x)
int | GetRelateY ()
기준점으로부터 Y 이격거리 더 자세히 ...
void | SetRelateY ([in] int y)
VARIANT_BOOL | IsExteriorHandle ()
외부 핸들인지의 여부 더 자세히 ...
void | SetExteriorHandle ([in] VARIANT_BOOL val)
VARIANT_BOOL | ExportImage (FileFormatEnum nFileType, BSTR bstrVal)
차트를 지정된 파일형태로 내보낸다. 더 자세히 ...
- sgObject::IWidget(으)로부터 상속된 Public 멤버 함수
void | Initialize ([in] ULONG_PTR h)
위젯 초기화 더 자세히 ...
void | ReSize ([in] int x, [in] int y, [in] int cx, [in] int cy)
위젯 객체의 크기를 재설정 한다. 더 자세히 ...
void | AddWidget ([in] IWidget *dspWidget)
현재 위젯에 하부로 위젯을 추가한다. 더 자세히 ...
void | AddWidgetByLayout ([in] IWidget *dspWidget, [in] int row, [in] int col)
현재 위젯에 종, 횡 위치에 위젯을 추가한다. 더 자세히 ...
void | SetQtUiObjectVisible ([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue)
위젯의 해당 오브젝트 객체의 보이기 여부를 설정한다. 더 자세히 ...
long | GetBackColor ()
위젯이 사용하는 배경 색상 정보 더 자세히 ...
void | SetBackColor ([in] long color)
void | SetCanvas (ICanvas *poCanvas)
위젯을 특정(2D, 3D, Earth 등) 지도창으로 설정한다. 더 자세히 ...
IFeatureCanvas * GetFeatureCanvas ()
위젯이 사용하는 FeatureCanvas 정보 더 자세히 ...
void | SetFeatureCanvas (IFeatureCanvas *poFtCvs)
void | SetFeatureLayer (IFeatureLayer *poFtLayer)
위젯이 사용하는 FeatureLayer 정보 더 자세히 ...
void | SetLayer (ILayer *poLayer)
위젯이 사용하는 레이어 정보 더 자세히 ...
BSTR | GetFlag ()
위젯이 사용하는 문자열 파라메터 정보 더 자세히 ...
void | SetFlag (BSTR bstrFlag)
void | SetWidth (int nWidth)
위젯의 가로크기를 설정한다. 더 자세히 ...
int | SetHeight (int nHeight)
위젯의 세로크기를 설정한다. 더 자세히 ...
void | Destroy ()

상세한 설명

비디오의 세부 속성을 설정하기 위한 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "VD"를 덧붙여서 "OGR_VD_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Video"

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IVideo
sgObject::IVideo 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IVideo (모든 상속된 멤버들도 포함합니다.)

AddWidget([in] IWidget *dspWidget) | sgObject::IWidget
AddWidgetByLayout([in] IWidget *dspWidget, [in] int row, [in] int col) | sgObject::IWidget
Destroy() | sgObject::IWidget
ExportImage(FileFormatEnum nFileType, BSTR bstrVal) | sgObject::IUserDefinedWidget
GetBackColor() | sgObject::IWidget
GetFeatureCanvas() | sgObject::IWidget
GetFlag() | sgObject::IWidget
GetPosition() | sgObject::IUserDefinedWidget
GetRelateX() | sgObject::IUserDefinedWidget
GetRelateY() | sgObject::IUserDefinedWidget
Initialize([in] ULONG_PTR h) | sgObject::IWidget
IsExteriorHandle() | sgObject::IUserDefinedWidget
ReSize([in] int x, [in] int y, [in] int cx, [in] int cy) | sgObject::IWidget
SetBackColor([in] long color) | sgObject::IWidget
SetCanvas(ICanvas *poCanvas) | sgObject::IWidget
SetExteriorHandle([in] VARIANT_BOOL val) | sgObject::IUserDefinedWidget
SetFeatureCanvas(IFeatureCanvas *poFtCvs) | sgObject::IWidget
SetFeatureLayer(IFeatureLayer *poFtLayer) | sgObject::IWidget
SetFlag(BSTR bstrFlag) | sgObject::IWidget
SetHeight(int nHeight) | sgObject::IWidget
SetLayer(ILayer *poLayer) | sgObject::IWidget
SetPosition([in] AlignPositionEnum pos) | sgObject::IUserDefinedWidget
SetQtUiObjectVisible([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue) | sgObject::IWidget
SetRelateX([in] int x) | sgObject::IUserDefinedWidget
SetRelateY([in] int y) | sgObject::IUserDefinedWidget
SetWidth(int nWidth) | sgObject::IWidget
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IVideoSensor 인터페이스 참조

  • IVideoSensor
모든 멤버 목록
sgObject::IVideoSensor 인터페이스 참조

카메라 센서 및 동영상 서비스로 부터 영상 정보를 획득하고 표현하는 인터페이스를 제공한다. 더 자세히 ...

sgObject::IVideoSensor에 대한 상속 다이어그램 :
sgObject::IVideoSensor에 대한 협력 다이어그램:

추가로 상속된 멤버들

- sgObject::ISensor(으)로부터 상속된 Public 멤버 함수
HRESULT | Start ([in] IParameters *param, [out, retval] VARIANT_BOOL *bSuccess)
위치 센서의 경우 Sensor 장치를 COM 포트를 통해 사용한다. 더 자세히 ...
HRESULT | Stop ()
센서 장치의 사용을 끝낸다. 더 자세히 ...
HRESULT | IsServiceRunning ([out, retval] VARIANT_BOOL *retVal)
Sensor 장치를 사용할 수 있는지 여부 더 자세히 ...
HRESULT | GetLatestValueToXML ([out, retval] BSTR *retVal)
Sensor 장치에서 읽어온 최신 자료를 센서별 XML규격 형태로 반환한다. 더 자세히 ...

상세한 설명

카메라 센서 및 동영상 서비스로 부터 영상 정보를 획득하고 표현하는 인터페이스를 제공한다.

카메라 센서 및 동영상 서비스로부터 수신되는 정보는 IVideoSensorEvents 인터페이스를 통해 이벤트로 제공된다. C API(linux, iOS, MacOS 등) : 중간이름 "VSN"를 덧붙여서 "OGR_VSN</em>"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.VideoSensor"

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IVideoSensor
sgObject::IVideoSensor 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IVideoSensor (모든 상속된 멤버들도 포함합니다.)

GetLatestValueToXML([out, retval] BSTR *retVal) | sgObject::ISensor
IsServiceRunning([out, retval] VARIANT_BOOL *retVal) | sgObject::ISensor
Start([in] IParameters *param, [out, retval] VARIANT_BOOL *bSuccess) | sgObject::ISensor
Stop() | sgObject::ISensor
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IWidget 인터페이스 참조

  • IWidget
Public 멤버 함수 | 모든 멤버 목록
sgObject::IWidget 인터페이스 참조

위젯 객체를 관리하기 위한 최상의 인터페이스를 제공한다. 더 자세히 ...

sgObject::IWidget에 대한 상속 다이어그램 :
sgObject::IWidget에 대한 협력 다이어그램:

Public 멤버 함수

void | Initialize ([in] ULONG_PTR h)
위젯 초기화 더 자세히 ...
void | ReSize ([in] int x, [in] int y, [in] int cx, [in] int cy)
위젯 객체의 크기를 재설정 한다. 더 자세히 ...
void | AddWidget ([in] IWidget *dspWidget)
현재 위젯에 하부로 위젯을 추가한다. 더 자세히 ...
void | AddWidgetByLayout ([in] IWidget *dspWidget, [in] int row, [in] int col)
현재 위젯에 종, 횡 위치에 위젯을 추가한다. 더 자세히 ...
void | SetQtUiObjectVisible ([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue)
위젯의 해당 오브젝트 객체의 보이기 여부를 설정한다. 더 자세히 ...
long | GetBackColor ()
위젯이 사용하는 배경 색상 정보 더 자세히 ...
void | SetBackColor ([in] long color)
void | SetCanvas (ICanvas *poCanvas)
위젯을 특정(2D, 3D, Earth 등) 지도창으로 설정한다. 더 자세히 ...
IFeatureCanvas * GetFeatureCanvas ()
위젯이 사용하는 FeatureCanvas 정보 더 자세히 ...
void | SetFeatureCanvas (IFeatureCanvas *poFtCvs)
void | SetFeatureLayer (IFeatureLayer *poFtLayer)
위젯이 사용하는 FeatureLayer 정보 더 자세히 ...
void | SetLayer (ILayer *poLayer)
위젯이 사용하는 레이어 정보 더 자세히 ...
BSTR | GetFlag ()
위젯이 사용하는 문자열 파라메터 정보 더 자세히 ...
void | SetFlag (BSTR bstrFlag)
void | SetWidth (int nWidth)
위젯의 가로크기를 설정한다. 더 자세히 ...
int | SetHeight (int nHeight)
위젯의 세로크기를 설정한다. 더 자세히 ...
void | Destroy ()

상세한 설명

위젯 객체를 관리하기 위한 최상의 인터페이스를 제공한다.

C API(linux, iOS, MacOS 등) : 중간이름 "WG"를 덧붙여서 "OGR_WG_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Widget"

멤버 함수 문서화

void sgObject::IWidget::AddWidget ( [in] IWidget * dspWidget )

현재 위젯에 하부로 위젯을 추가한다.

현재 위젯의 layout 설정에 따라 추가된 위젯의 위치와 크기가 변경되어 추가된다.

매개변수
dspWidget - 추가된 하위 위젯
void sgObject::IWidget::AddWidgetByLayout | ( | [in] IWidget * | dspWidget,
 |  | [in] int | row,
 |  | [in] int | col
 | ) |  |

현재 위젯에 종, 횡 위치에 위젯을 추가한다.

현재 위젯의 layout 설정에 따라 추가된 위젯의 위치와 크기가 변경되어 추가된다.

매개변수
dspWidget | - 추가된 하위 위젯
row | - 위치될 종 인덱스
col | - 위치될 횡 인덱스
void sgObject::IWidget::Destroy ( )
long sgObject::IWidget::GetBackColor ( )

위젯이 사용하는 배경 색상 정보

IFeatureCanvas* sgObject::IWidget::GetFeatureCanvas ( )

위젯이 사용하는 FeatureCanvas 정보

BSTR sgObject::IWidget::GetFlag ( )

위젯이 사용하는 문자열 파라메터 정보

void sgObject::IWidget::Initialize ( [in] ULONG_PTR h )

위젯 초기화

매개변수
h - 위젯 객체를 초기화하기 위한 외부 핸들
void sgObject::IWidget::ReSize | ( | [in] int | x,
 |  | [in] int | y,
 |  | [in] int | cx,
 |  | [in] int | cy
 | ) |  |

위젯 객체의 크기를 재설정 한다.

Canvas가 그리는 윈도우에서 WM_SIZE 메시지 발생 시 이 메소드를 호출하고 메시지에 첨부된 정보를 매개변수로 주면 Canvas가 적당한 동작을 한다.

매개변수
x | - 시작 x위치
y | - 시작 y위치
cx | - OnSize()의 파라미터 cx
cy | - OnSize()의 파라미터 cy
반환값
S_OK이면 성공, 그렇지 않으면 HRESULT 에러코드
void sgObject::IWidget::SetBackColor ( [in] long color )
void sgObject::IWidget::SetCanvas ( ICanvas * poCanvas )

위젯을 특정(2D, 3D, Earth 등) 지도창으로 설정한다.

void sgObject::IWidget::SetFeatureCanvas ( IFeatureCanvas * poFtCvs )
void sgObject::IWidget::SetFeatureLayer ( IFeatureLayer * poFtLayer )

위젯이 사용하는 FeatureLayer 정보

void sgObject::IWidget::SetFlag ( BSTR bstrFlag )
int sgObject::IWidget::SetHeight ( int nHeight )

위젯의 세로크기를 설정한다.

반환값
세로크기
void sgObject::IWidget::SetLayer ( ILayer * poLayer )

위젯이 사용하는 레이어 정보

void sgObject::IWidget::SetQtUiObjectVisible | ( | [in] BSTR | bstrObjectName,
 |  | [in] VARIANT_BOOL | bValue
 | ) |  |

위젯의 해당 오브젝트 객체의 보이기 여부를 설정한다.

void sgObject::IWidget::SetWidth ( int nWidth )

위젯의 가로크기를 설정한다.

반환값
가로크기
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IWidget
sgObject::IWidget 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IWidget (모든 상속된 멤버들도 포함합니다.)

AddWidget([in] IWidget *dspWidget) | sgObject::IWidget
AddWidgetByLayout([in] IWidget *dspWidget, [in] int row, [in] int col) | sgObject::IWidget
Destroy() | sgObject::IWidget
GetBackColor() | sgObject::IWidget
GetFeatureCanvas() | sgObject::IWidget
GetFlag() | sgObject::IWidget
Initialize([in] ULONG_PTR h) | sgObject::IWidget
ReSize([in] int x, [in] int y, [in] int cx, [in] int cy) | sgObject::IWidget
SetBackColor([in] long color) | sgObject::IWidget
SetCanvas(ICanvas *poCanvas) | sgObject::IWidget
SetFeatureCanvas(IFeatureCanvas *poFtCvs) | sgObject::IWidget
SetFeatureLayer(IFeatureLayer *poFtLayer) | sgObject::IWidget
SetFlag(BSTR bstrFlag) | sgObject::IWidget
SetHeight(int nHeight) | sgObject::IWidget
SetLayer(ILayer *poLayer) | sgObject::IWidget
SetQtUiObjectVisible([in] BSTR bstrObjectName, [in] VARIANT_BOOL bValue) | sgObject::IWidget
SetWidth(int nWidth) | sgObject::IWidget
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IWks 인터페이스 참조

  • IWks
Public 멤버 함수 | 모든 멤버 목록
sgObject::IWks 인터페이스 참조

기하에 Well Known Binary 표현과 Well Known Text 표현을 다루는 인터페이스를 제공한다. 더 자세히 ...

sgObject::IWks에 대한 상속 다이어그램 :
sgObject::IWks에 대한 협력 다이어그램:

Public 멤버 함수

void | ExportToWKB ([in] VARIANT *wkb)
해당 기하를 표현하는 Well Known Binary 데이터를 만들어준다. 더 자세히 ...
BSTR | ExportToWKT ()
해당 기하를 표현하는 Well Known Text 데이터를 만들어준다. 더 자세히 ...
void | ImportFromWKB (VARIANT wkb, [in, defaultvalue(NULL)] ISpatialReference *spatialRef)
입력으로 들어온 Well Known Binary 데이터(이진표현)를 기하 내로 Import한다. (껍데기 기하의 내용을 채운다) 더 자세히 ...
void | ImportFromWKT ([in] BSTR wkt, [in, defaultvalue(NULL)] ISpatialReference *spatialRef)
입력된 Well Known Text 데이터를 이용하여 기하 내로 Import한다. (껍데기 기하의 내용을 채운다) 더 자세히 ...

상세한 설명

기하에 Well Known Binary 표현과 Well Known Text 표현을 다루는 인터페이스를 제공한다.

Well Known Binary 및 Well Known Text에 대한 내용은 Knowledge Base를 참고한다. Geometry의 잘 알려진 외부 표현을 다루는 메소드에 대해서 정의되어 있다. Geometry(WKBGeometry)에 대한 외부 표현들은 이진 표현이다. C API(linux, iOS, MacOS 등) : 중간이름 "G"를 덧붙여서 "OGR_G_"+메소드명으로 사용한다. Java(SWT, Android) Package명 : "net.sgsrc.map.jni.Geometry"

멤버 함수 문서화

void sgObject::IWks::ExportToWKB ( [in] VARIANT * wkb )

해당 기하를 표현하는 Well Known Binary 데이터를 만들어준다.

기하의 이진 표현(WKB)을 복사한다. 여기서 변수의 타입은 unsigned bytes(VT_ARRAY|VT_UI1)의 배열이다.

매개변수
wkb - Well Known Binary 데이터를 넣을 Output 변수. 기하의 이진 표현을 저장. VARIANT 변수의 parray->pvData에 Well Known Binary 데이터 넣는다. VARIANT 변수의 vt에는 VT_ARRAY | VT_UI1를 넣는다.
반환값
없음
BSTR sgObject::IWks::ExportToWKT ( )

해당 기하를 표현하는 Well Known Text 데이터를 만들어준다.

기하에 대해 잘 알려진 텍스트 표현(WKT)을 반환한다.

반환값
Well Known Text 데이터
void sgObject::IWks::ImportFromWKB | ( | VARIANT | wkb,
 |  | [in, defaultvalue(NULL)] ISpatialReference * | spatialRef
 | ) |  |

입력으로 들어온 Well Known Binary 데이터(이진표현)를 기하 내로 Import한다. (껍데기 기하의 내용을 채운다)

이 메소드는 Geometry CoClass에 대한 일반적인 COM Instantiation(COM ClassFactory)을 이용해 객체를 생성한 후 해당 기하를 초기화 하는데 사용할 수 있다.
이때 입력된 WKBGeometry를 저장하는 객체 타입은 소스 객체의 클래스와 일치해야 한다. (즉, 해당 기하 타입에 합당한 Well Known Binary 데이터를 Input Data로 주어야 한다.)

매개변수
wkb | - Well Known Binary 데이터. VARIANT 변수에 wkb이진 표현을 저장하는 버퍼 VARIANT 변수의 parray->pvData에 Well Known Binary 데이터를 넣는다. VARIANT 변수의 vt에는 VT_ARRAY | VT_UI1를 넣는다.
spatialRef | - 기하가 참조하는 WKB에 대한 공간참조체계. 참조하는 공간참조체계가 정의되어 있지 않다면 NULL
반환값
없음
void sgObject::IWks::ImportFromWKT | ( | [in] BSTR | wkt,
 |  | [in, defaultvalue(NULL)] ISpatialReference * | spatialRef
 | ) |  |

입력된 Well Known Text 데이터를 이용하여 기하 내로 Import한다. (껍데기 기하의 내용을 채운다)

이 메소드는 Geometry CoClass에 대한 일반적인 COM Instantiation(COM ClassFactory)을 이용해 객체를 생성한 후 기하를 초기화 하는 데 사용할 수 있다. 이때 입력된 WKBGeometry를 저장하는 객체 타입은 소스 객체의 클래스와 일치해야 한다. (즉, 해당 기하 타입에 합당한 Well Known Text(WKT) 데이터를 Input Data로 주어야 한다.)

매개변수
wkt | - Well Known Text 데이터, 즉, 기하(WKBGeometry) 텍스트 표현을 저장하는 버퍼
spatialRef | - 기하가 참조하는 공간참조체계 참조하는 공간참조체계가 정의되어 있지 않다면 NULL [default = NULL]
반환값
없음
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IWks
sgObject::IWks 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IWks (모든 상속된 멤버들도 포함합니다.)

ExportToWKB([in] VARIANT *wkb) | sgObject::IWks
ExportToWKT() | sgObject::IWks
ImportFromWKB(VARIANT wkb, [in, defaultvalue(NULL)] ISpatialReference *spatialRef) | sgObject::IWks
ImportFromWKT([in] BSTR wkt, [in, defaultvalue(NULL)] ISpatialReference *spatialRef) | sgObject::IWks
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IXMLDoc 인터페이스 참조

  • IXMLDoc
Public 멤버 함수 | 모든 멤버 목록
sgObject::IXMLDoc 인터페이스 참조

XML파일을 관리, 분석 인터페이스를 제공한다. 더 자세히 ...

sgObject::IXMLDoc에 대한 상속 다이어그램 :
sgObject::IXMLDoc에 대한 협력 다이어그램:

Public 멤버 함수

VARIANT_BOOL | Open ([in] VARIANT xmlSource)
XML 파일을 연다. 더 자세히 ...
VARIANT_BOOL | OpenXML ([in] BSTR bstrXML)
XML 정보를 직접 해석한다. 더 자세히 ...
VARIANT_BOOL | Save ()
편집된 XML정보를 저장한다. 더 자세히 ...
void | Clear ()
해석된 XML정보를 초기화 한다. 더 자세히 ...
IXMLElements * | CreateElement ([in] BSTR bstrName)
열린 XML 파일에 새로운 단위 객체를 생성한다. 더 자세히 ...
IXMLElements * GetElements ()
현재 열린 문서의 최상위 단위 객체를 반환 더 자세히 ...
void | SetElements ([in] IXMLElements *disp)
BSTR | GetFileName ()
현재 열려 있는 XML문서 파일명을 반환 더 자세히 ...
void | SetFileName ([in] BSTR name)

상세한 설명

XML파일을 관리, 분석 인터페이스를 제공한다.

멤버 함수 문서화

void sgObject::IXMLDoc::Clear ( )

해석된 XML정보를 초기화 한다.

IXMLElements* sgObject::IXMLDoc::CreateElement ( [in] BSTR bstrName )

열린 XML 파일에 새로운 단위 객체를 생성한다.

IXMLElements* sgObject::IXMLDoc::GetElements ( )

현재 열린 문서의 최상위 단위 객체를 반환

BSTR sgObject::IXMLDoc::GetFileName ( )

현재 열려 있는 XML문서 파일명을 반환

VARIANT_BOOL sgObject::IXMLDoc::Open ( [in] VARIANT xmlSource )

XML 파일을 연다.

매개변수
xmlSource - XML 파일 이름
VARIANT_BOOL sgObject::IXMLDoc::OpenXML ( [in] BSTR bstrXML )

XML 정보를 직접 해석한다.

매개변수
bstrXML - XML 정보
VARIANT_BOOL sgObject::IXMLDoc::Save ( )

편집된 XML정보를 저장한다.

void sgObject::IXMLDoc::SetElements ( [in] IXMLElements * disp )
void sgObject::IXMLDoc::SetFileName ( [in] BSTR name )
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IXMLDoc
sgObject::IXMLDoc 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IXMLDoc (모든 상속된 멤버들도 포함합니다.)

Clear() | sgObject::IXMLDoc
CreateElement([in] BSTR bstrName) | sgObject::IXMLDoc
GetElements() | sgObject::IXMLDoc
GetFileName() | sgObject::IXMLDoc
Open([in] VARIANT xmlSource) | sgObject::IXMLDoc
OpenXML([in] BSTR bstrXML) | sgObject::IXMLDoc
Save() | sgObject::IXMLDoc
SetElements([in] IXMLElements *disp) | sgObject::IXMLDoc
SetFileName([in] BSTR name) | sgObject::IXMLDoc
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::IXMLElements 인터페이스 참조

  • IXMLElements
Public 멤버 함수 | 모든 멤버 목록
sgObject::IXMLElements 인터페이스 참조

XMLDoc객체로부터 해석된 객체에 존재하는 다양한 정보 관리 인터페이스를 제공한다. 더 자세히 ...

sgObject::IXMLElements에 대한 상속 다이어그램 :
sgObject::IXMLElements에 대한 협력 다이어그램:

Public 멤버 함수

void | MoveFirst ()
단위 객체 리스트의 첫 번째 위치로 커서 이동 더 자세히 ...
void | MoveNext ()
단위 객체 리스트의 다음 위치로 커서 이동 더 자세히 ...
IXMLElements * GetElement ()
현재 커서의 단위 객체 반환 더 자세히 ...
void | SetElement ([in] IXMLElements *inputElement)
현재 커서 위치에 단위 객체 설정 더 자세히 ...
IXMLElements * | GetChildElement ([in] int index)
해당 인덱스 번호에 해당하는 자식 단위 객체 반환 더 자세히 ...
void | AddChildElement ([in] IXMLElements *inputElement)
자식 단위 객체 추가 더 자세히 ...
VARIANT_BOOL | RemoveElement ()
현재 단위 객체 삭제 더 자세히 ...
IXMLElements * | GetParentElement ([in] IXMLElements *inputElement)
주어진 단위 객체의 부모 단위 객체 반환 더 자세히 ...
BSTR | GetName ()
단위 객체의 이름 더 자세히 ...
BSTR | GetValue ()
단위 객체의 값 더 자세히 ...
void | SetValue ([in] BSTR val)
VARIANT_BOOL | IsChild ()
단위 객체의 자식 객체의 존재 여부 더 자세히 ...
int | GetChildLength ()
단위 객체의 자식 객체의 개수 더 자세히 ...

상세한 설명

XMLDoc객체로부터 해석된 객체에 존재하는 다양한 정보 관리 인터페이스를 제공한다.

멤버 함수 문서화

void sgObject::IXMLElements::AddChildElement ( [in] IXMLElements * inputElement )

자식 단위 객체 추가

IXMLElements* sgObject::IXMLElements::GetChildElement ( [in] int index )

해당 인덱스 번호에 해당하는 자식 단위 객체 반환

int sgObject::IXMLElements::GetChildLength ( )

단위 객체의 자식 객체의 개수

IXMLElements* sgObject::IXMLElements::GetElement ( )

현재 커서의 단위 객체 반환

BSTR sgObject::IXMLElements::GetName ( )

단위 객체의 이름

IXMLElements* sgObject::IXMLElements::GetParentElement ( [in] IXMLElements * inputElement )

주어진 단위 객체의 부모 단위 객체 반환

BSTR sgObject::IXMLElements::GetValue ( )

단위 객체의 값

VARIANT_BOOL sgObject::IXMLElements::IsChild ( )

단위 객체의 자식 객체의 존재 여부

void sgObject::IXMLElements::MoveFirst ( )

단위 객체 리스트의 첫 번째 위치로 커서 이동

void sgObject::IXMLElements::MoveNext ( )

단위 객체 리스트의 다음 위치로 커서 이동

VARIANT_BOOL sgObject::IXMLElements::RemoveElement ( )

현재 단위 객체 삭제

void sgObject::IXMLElements::SetElement ( [in] IXMLElements * inputElement )

현재 커서 위치에 단위 객체 설정

void sgObject::IXMLElements::SetValue ( [in] BSTR val )
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • IXMLElements
sgObject::IXMLElements 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::IXMLElements (모든 상속된 멤버들도 포함합니다.)

AddChildElement([in] IXMLElements *inputElement) | sgObject::IXMLElements
GetChildElement([in] int index) | sgObject::IXMLElements
GetChildLength() | sgObject::IXMLElements
GetElement() | sgObject::IXMLElements
GetName() | sgObject::IXMLElements
GetParentElement([in] IXMLElements *inputElement) | sgObject::IXMLElements
GetValue() | sgObject::IXMLElements
IsChild() | sgObject::IXMLElements
MoveFirst() | sgObject::IXMLElements
MoveNext() | sgObject::IXMLElements
RemoveElement() | sgObject::IXMLElements
SetElement([in] IXMLElements *inputElement) | sgObject::IXMLElements
SetValue([in] BSTR val) | sgObject::IXMLElements
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Layer 클래스 참조

  • Layer
sgObject::Layer 클래스 참조

GIS에서는 데이터를 화면에 표현하기위해 관리할 때 보통 Layer의 개념을 도입해 객체 종류별 관리를 한다. 더 자세히 ...

sgObject::Layer에 대한 협력 다이어그램:

상세한 설명

GIS에서는 데이터를 화면에 표현하기위해 관리할 때 보통 Layer의 개념을 도입해 객체 종류별 관리를 한다.

Layer 객체는 이렇게 Layer 단위로 데이터를 관리하기 위한 객체이다. Layer 객체는 Layer에 속한 Feature들을 관리하는 FeatureLayer 객체를 갖고 있다. 자세한 설명은 ILayer 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::LayerSource 클래스 참조

  • LayerSource
sgObject::LayerSource 클래스 참조

GIS에서는 데이터를 화면에 표현하기 위해 관리할 때 보통 Layer의 개념을 도입해 객체 종류별 관리를 한다. 더 자세히 ...

sgObject::LayerSource에 대한 협력 다이어그램:

상세한 설명

GIS에서는 데이터를 화면에 표현하기 위해 관리할 때 보통 Layer의 개념을 도입해 객체 종류별 관리를 한다.

LayerSourceFactory가 생성하는 LayerSource는 이렇게 Layer 단위로 관리되는 데이터의 전체 구조 (Layer의 모음) 이다. 자세한 설명은 ILayerSource 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::LayerSourceFactory 클래스 참조

  • LayerSourceFactory
sgObject::LayerSourceFactory 클래스 참조

LayerSourceFactory는 GIS 데이터를 갖고 있는 데이터소스로부터 데이터를 가져와 LayerSource를 생성하는 객체이다. 더 자세히 ...

sgObject::LayerSourceFactory에 대한 협력 다이어그램:

상세한 설명

LayerSourceFactory는 GIS 데이터를 갖고 있는 데이터소스로부터 데이터를 가져와 LayerSource를 생성하는 객체이다.

자세한 설명은 ILayerSourceFactory 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::LayerTreeWidget 클래스 참조

  • LayerTreeWidget
sgObject::LayerTreeWidget 클래스 참조
sgObject::LayerTreeWidget에 대한 협력 다이어그램:
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::LinearRing 클래스 참조

  • LinearRing
sgObject::LinearRing 클래스 참조

LinearRing은 기하 객체 모델의 LinearRing을 나타내는 객체이다. 더 자세히 ...

sgObject::LinearRing에 대한 협력 다이어그램:

상세한 설명

LinearRing은 기하 객체 모델의 LinearRing을 나타내는 객체이다.

자세한 설명은 ILinearRing 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::LineString 클래스 참조

  • LineString
sgObject::LineString 클래스 참조

LineString은 기하 객체 모델의 LineString을 나타내는 객체이다. 더 자세히 ...

sgObject::LineString에 대한 협력 다이어그램:

상세한 설명

LineString은 기하 객체 모델의 LineString을 나타내는 객체이다.

LineString은 점들 사이를 선형 보간법으로 나타낼 수 있는 커브이다. 각각의 연속된 점들의 쌍은 라인 세그먼트로 정의된다. 자세한 설명은 ILineString 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::LocationSensor 클래스 참조

  • LocationSensor
sgObject::LocationSensor 클래스 참조

LocationSensor은 GPS 장치와 연결하여 GPS 수신 기능을 행하는 객체이다. 자세한 내용은 ILocationSensor 에 대한 설명을 참고한다. 더 자세히 ...

sgObject::LocationSensor에 대한 협력 다이어그램:

상세한 설명

LocationSensor은 GPS 장치와 연결하여 GPS 수신 기능을 행하는 객체이다. 자세한 내용은 ILocationSensor 에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::LocationService 클래스 참조

  • LocationService
sgObject::LocationService 클래스 참조

주소정보를 기반으로 해당위치의 Feature 객체를 검색하고, 관리하는 기능과 POI 기능을 제공하는 객체이다. 자세한 내용은 ILocationService 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::LocationService에 대한 협력 다이어그램:

상세한 설명

주소정보를 기반으로 해당위치의 Feature 객체를 검색하고, 관리하는 기능과 POI 기능을 제공하는 객체이다. 자세한 내용은 ILocationService 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Map2D 클래스 참조

  • Map2D
sgObject::Map2D 클래스 참조

Map2D 클래스는 FeatureCanvas 객체와 연동하여 Feature들의 Geometry 및 주석 정보를 화면에 그리고 화면으로부터 사용자 입력을 받는 등 실제 화면 제어를 담당하는 객체이다. 더 자세히 ...

sgObject::Map2D에 대한 협력 다이어그램:

상세한 설명

Map2D 클래스는 FeatureCanvas 객체와 연동하여 Feature들의 Geometry 및 주석 정보를 화면에 그리고 화면으로부터 사용자 입력을 받는 등 실제 화면 제어를 담당하는 객체이다.

자세한 내용은 IMap2D 에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Map2DControl 클래스 참조

  • Map2DControl
sgObject::Map2DControl 클래스 참조
sgObject::Map2DControl에 대한 협력 다이어그램:
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Map3D 클래스 참조

  • Map3D
sgObject::Map3D 클래스 참조

Map3D 클래스는 FeatureCanvas 객체와 연동하여 Feature들의 Geometry 및 주석 정보를 화면에 그리고 화면으로부터 사용자 입력을 받는 등 실제 화면 제어를 담당하는 객체이다. 자세한 내용은 IMap3D 에 대한 설명을 참고한다. 더 자세히 ...

sgObject::Map3D에 대한 협력 다이어그램:

상세한 설명

Map3D 클래스는 FeatureCanvas 객체와 연동하여 Feature들의 Geometry 및 주석 정보를 화면에 그리고 화면으로부터 사용자 입력을 받는 등 실제 화면 제어를 담당하는 객체이다. 자세한 내용은 IMap3D 에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Map3DControl 클래스 참조

  • Map3DControl
sgObject::Map3DControl 클래스 참조
sgObject::Map3DControl에 대한 협력 다이어그램:
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::MapAR 클래스 참조

  • MapAR
sgObject::MapAR 클래스 참조

MapAR 클래스는 FeatureCanvas 객체와 연동하여 Feature들의 Geometry 및 주석 정보를 화면에 그리고 화면으로부터 사용자 입력을 받는 등 실제 화면 제어를 담당하는 객체이다. 자세한 내용은 IMapAR 에 대한 설명을 참고한다. 더 자세히 ...

sgObject::MapAR에 대한 협력 다이어그램:

상세한 설명

MapAR 클래스는 FeatureCanvas 객체와 연동하여 Feature들의 Geometry 및 주석 정보를 화면에 그리고 화면으로부터 사용자 입력을 받는 등 실제 화면 제어를 담당하는 객체이다. 자세한 내용은 IMapAR 에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::MapARControl 클래스 참조

  • MapARControl
sgObject::MapARControl 클래스 참조
sgObject::MapARControl에 대한 협력 다이어그램:
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::MapEarth 클래스 참조

  • MapEarth
sgObject::MapEarth 클래스 참조

MapEarth 클래스는 FeatureCanvas 객체와 연동하여 Feature들의 Geometry 및 주석 정보를 화면에 그리고 화면으로부터 사용자 입력을 받는 등 실제 화면 제어를 담당하는 객체이다. 자세한 내용은 IMapEarth 에 대한 설명을 참고한다. 더 자세히 ...

sgObject::MapEarth에 대한 협력 다이어그램:

상세한 설명

MapEarth 클래스는 FeatureCanvas 객체와 연동하여 Feature들의 Geometry 및 주석 정보를 화면에 그리고 화면으로부터 사용자 입력을 받는 등 실제 화면 제어를 담당하는 객체이다. 자세한 내용은 IMapEarth 에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::MapEarthControl 클래스 참조

  • MapEarthControl
sgObject::MapEarthControl 클래스 참조
sgObject::MapEarthControl에 대한 협력 다이어그램:
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Mark 클래스 참조

  • Mark
sgObject::Mark 클래스 참조

자세한 설명은 IMark 설명을 참고한다. 더 자세히 ...

sgObject::Mark에 대한 협력 다이어그램:

상세한 설명

자세한 설명은 IMark 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Message 클래스 참조

  • Message
sgObject::Message 클래스 참조

Message는 메시지파일에 따른 메시지를 출력하는 객체이다. 자세한 내용은 IMessage 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::Message에 대한 협력 다이어그램:

상세한 설명

Message는 메시지파일에 따른 메시지를 출력하는 객체이다. 자세한 내용은 IMessage 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::MotionSensor 클래스 참조

  • MotionSensor
sgObject::MotionSensor 클래스 참조

MotionSensor은 Gyroscope 장치와 연결하여 Motion 수신 기능을 행하는 객체이다. 자세한 내용은 IMotionSensor 에 대한 설명을 참고한다. 더 자세히 ...

sgObject::MotionSensor에 대한 협력 다이어그램:

상세한 설명

MotionSensor은 Gyroscope 장치와 연결하여 Motion 수신 기능을 행하는 객체이다. 자세한 내용은 IMotionSensor 에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::MultiLineString 클래스 참조

  • MultiLineString
sgObject::MultiLineString 클래스 참조

MultiLineString은 기하 객체 모델의 MultiLineString을 나타내는 객체이다. 더 자세히 ...

sgObject::MultiLineString에 대한 협력 다이어그램:

상세한 설명

MultiLineString은 기하 객체 모델의 MultiLineString을 나타내는 객체이다.

자세한 설명은 IMultiLineString 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::MultiPoint 클래스 참조

  • MultiPoint
sgObject::MultiPoint 클래스 참조

MultiPoint는 기하 객체 모델의 MultiPoint를 나타내는 객체이다. 더 자세히 ...

sgObject::MultiPoint에 대한 협력 다이어그램:

상세한 설명

MultiPoint는 기하 객체 모델의 MultiPoint를 나타내는 객체이다.

자세한 설명은 IGeometryCollection 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::MultiPolygon 클래스 참조

  • MultiPolygon
sgObject::MultiPolygon 클래스 참조

MultiPolygon은 기하 객체 모델의 MultiPolygon을 나타내는 객체이다. 더 자세히 ...

sgObject::MultiPolygon에 대한 협력 다이어그램:

상세한 설명

MultiPolygon은 기하 객체 모델의 MultiPolygon을 나타내는 객체이다.

자세한 설명은 IMultiPolygon 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::NetworkCoverageAnalysis 클래스 참조

  • NetworkCoverageAnalysis
sgObject::NetworkCoverageAnalysis 클래스 참조

NetworkCoverageAnalysis 클래스. 자세한 내용은 INetworkCoverageAnalysis 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::NetworkCoverageAnalysis에 대한 협력 다이어그램:

상세한 설명

NetworkCoverageAnalysis 클래스. 자세한 내용은 INetworkCoverageAnalysis 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Parameter 클래스 참조

  • Parameter
sgObject::Parameter 클래스 참조

Parameter. 더 자세히 ...

sgObject::Parameter에 대한 협력 다이어그램:

상세한 설명

Parameter.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::ParameterInfo 클래스 참조

  • ParameterInfo
sgObject::ParameterInfo 클래스 참조

ParameterInfo. 더 자세히 ...

sgObject::ParameterInfo에 대한 협력 다이어그램:

상세한 설명

ParameterInfo.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Parameters 클래스 참조

  • Parameters
sgObject::Parameters 클래스 참조

Parameters. 더 자세히 ...

sgObject::Parameters에 대한 협력 다이어그램:

상세한 설명

Parameters.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Point 클래스 참조

  • Point
sgObject::Point 클래스 참조

Point는 기하 객체 모델의 Point를 나타내는 객체이다. 더 자세히 ...

sgObject::Point에 대한 협력 다이어그램:

상세한 설명

Point는 기하 객체 모델의 Point를 나타내는 객체이다.

자세한 설명은 IPoint 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::PointSymbol 클래스 참조

  • PointSymbol
sgObject::PointSymbol 클래스 참조

PointSymbol은 Vector로 그려진 심볼을 관리하는 객체이다. 더 자세히 ...

sgObject::PointSymbol에 대한 협력 다이어그램:

상세한 설명

PointSymbol은 Vector로 그려진 심볼을 관리하는 객체이다.

심볼은 Geometry를 가진 객체이지만 이를 표현하는 것보다 이를 대표하는 그림을 사용하는 것이 좋을 때 사용한다 또한 주석 등에도 심볼을 사용할 수 있다. 자세한 설명은 IPointSymbol 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Polygon 클래스 참조

  • Polygon
sgObject::Polygon 클래스 참조

Polygon은 기하 객체 모델의 Polygon을 나타내는 객체이다. 더 자세히 ...

sgObject::Polygon에 대한 협력 다이어그램:

상세한 설명

Polygon은 기하 객체 모델의 Polygon을 나타내는 객체이다.

경계에서 두 linear Rings은 서로 교차할 수 없으며, 폴리곤의 경계에 있는 Linear Ring은 최소 한 점에서만 교차 접촉 한다. 자세한 설명은 IPolygon 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::QueryCommand 클래스 참조

  • QueryCommand
sgObject::QueryCommand 클래스 참조

자세한 설명은 IQueryCommand 설명을 참고한다. 더 자세히 ...

sgObject::QueryCommand에 대한 협력 다이어그램:

상세한 설명

자세한 설명은 IQueryCommand 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::QueryCommands 클래스 참조

  • QueryCommands
sgObject::QueryCommands 클래스 참조

자세한 설명은 IQueryCommands 설명을 참고한다. 더 자세히 ...

sgObject::QueryCommands에 대한 협력 다이어그램:

상세한 설명

자세한 설명은 IQueryCommands 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::SpatialReference 클래스 참조

  • SpatialReference
sgObject::SpatialReference 클래스 참조

SpatialReference는 Geometry 객체가 참조하는 공간참조체계를 정의하는 객체이다. 더 자세히 ...

sgObject::SpatialReference에 대한 협력 다이어그램:

상세한 설명

SpatialReference는 Geometry 객체가 참조하는 공간참조체계를 정의하는 객체이다.

자세한 설명은 SpatialReference 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::SpatialReferenceFactory 클래스 참조

  • SpatialReferenceFactory
sgObject::SpatialReferenceFactory 클래스 참조

SpatialReferenceFactory. 더 자세히 ...

sgObject::SpatialReferenceFactory에 대한 협력 다이어그램:

상세한 설명

SpatialReferenceFactory.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Stroke 클래스 참조

  • Stroke
sgObject::Stroke 클래스 참조

자세한 설명은 IStroke 설명을 참고한다. 더 자세히 ...

sgObject::Stroke에 대한 협력 다이어그램:

상세한 설명

자세한 설명은 IStroke 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Symbolizer 클래스 참조

  • Symbolizer
sgObject::Symbolizer 클래스 참조

자세한 설명은 ISymbolizer 설명을 참고한다. 더 자세히 ...

sgObject::Symbolizer에 대한 협력 다이어그램:

상세한 설명

자세한 설명은 ISymbolizer 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::TabWidget 클래스 참조

  • TabWidget
sgObject::TabWidget 클래스 참조
sgObject::TabWidget에 대한 협력 다이어그램:
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::UserDefinedWidget 클래스 참조

  • UserDefinedWidget
sgObject::UserDefinedWidget 클래스 참조

UserDefinedWidget 클래스. 자세한 내용은 IUserDefinedWidget 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::UserDefinedWidget에 대한 협력 다이어그램:

상세한 설명

UserDefinedWidget 클래스. 자세한 내용은 IUserDefinedWidget 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Utility 클래스 참조

  • Utility
sgObject::Utility 클래스 참조

Utility는 여러가지 부수적인 기능을 제공하는 객체이다. 자세한 내용은 IUtility 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::Utility에 대한 협력 다이어그램:

상세한 설명

Utility는 여러가지 부수적인 기능을 제공하는 객체이다. 자세한 내용은 IUtility 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::Video 클래스 참조

  • Video
sgObject::Video 클래스 참조

Video 클래스. 자세한 내용은 IVideo 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::Video에 대한 협력 다이어그램:

상세한 설명

Video 클래스. 자세한 내용은 IVideo 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::VideoSensor 클래스 참조

  • VideoSensor
sgObject::VideoSensor 클래스 참조

VideoSensor은 Camera 장치와 연결하여 Video 수신 기능을 행하는 객체이다. 자세한 내용은 IVideoSensor 에 대한 설명을 참고한다. 더 자세히 ...

sgObject::VideoSensor에 대한 협력 다이어그램:

상세한 설명

VideoSensor은 Camera 장치와 연결하여 Video 수신 기능을 행하는 객체이다. 자세한 내용은 IVideoSensor 에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::XMLDoc 클래스 참조

  • XMLDoc
sgObject::XMLDoc 클래스 참조

XMLDoc 클래스. 자세한 내용은 IXMLDoc 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::XMLDoc에 대한 협력 다이어그램:

상세한 설명

XMLDoc 클래스. 자세한 내용은 IXMLDoc 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: sgObject::XMLElements 클래스 참조

  • XMLElements
sgObject::XMLElements 클래스 참조

XMLElements 클래스. 자세한 내용은 IXMLElements 인터페이스에 대한 설명을 참고한다. 더 자세히 ...

sgObject::XMLElements에 대한 협력 다이어그램:

상세한 설명

XMLElements 클래스. 자세한 내용은 IXMLElements 인터페이스에 대한 설명을 참고한다.

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: IDispatch 클래스 참조

IDispatch 클래스 참조

sgObject::_IApplicationControlEvents, sgObject::_IFeatureLayerEvents, sgObject::_IGraphicCanvasEvents, sgObject::_ILocationSensorEvents, sgObject::_IMap2DControlEvents, sgObject::_IMap2DEvents, sgObject::_IMap3DControlEvents, sgObject::_IMap3DEvents, sgObject::_IMapARControlEvents, sgObject::_IMapAREvents, sgObject::_IMapEarthControlEvents, sgObject::_IMapEarthEvents, sgObject::_IMotionSensorEvents, sgObject::_IVideoSensorEvents, sgObject::IAnimator, sgObject::IAnnotation, sgObject::IApplicationControl, sgObject::IAttributeIndex, sgObject::ICanvas, sgObject::IColorModel, sgObject::IColorRampList, sgObject::ICommonFactory, sgObject::ICoverage, sgObject::ICoverageFactory, sgObject::IDefaultTransaction, sgObject::IDisplayFactory, sgObject::IFeature, sgObject::IFeatureAttributeDescriptor, sgObject::IFeatureAttributeValidValue, sgObject::IFeatureCanvas, sgObject::IFeatureLayer, sgObject::IFeatureQuery, sgObject::IFeatureStyleCollection, sgObject::IFeatureType, sgObject::IFeatureTypeStyle, sgObject::IFeatureTypeStyleFactory, sgObject::IFeatureTypeStyleRule, sgObject::IFill, sgObject::IFont, sgObject::IGenerator3D, sgObject::IGeometry, sgObject::IGeometryFactory, sgObject::IGraphic, sgObject::IGridAnalysis, sgObject::IGridCoverageProcessor, sgObject::IGridOperation, sgObject::IHalo, sgObject::IHistogram, sgObject::ILayer, sgObject::ILayerSource, sgObject::ILayerSourceFactory, sgObject::ILocationService, sgObject::IMap2DControl, sgObject::IMap3DCamera, sgObject::IMap3DControl, sgObject::IMap3DLight, sgObject::IMapARControl, sgObject::IMapEarthControl, sgObject::IMark, sgObject::IMessage, sgObject::INetworkCoverageAnalysis, sgObject::IParameter, sgObject::IParameterInfo, sgObject::IParameters, sgObject::IPrintLayoutItem, sgObject::IQueryCommand, sgObject::IQueryCommands, sgObject::ISampleDimension, sgObject::ISensor, sgObject::ISpatialOperator, sgObject::ISpatialReferenceFactory, sgObject::ISpatialReferenceInfo, sgObject::ISpatialRelation, sgObject::ISpatialRelation2, sgObject::IStroke, sgObject::ISymbol, sgObject::ISymbolizer, sgObject::IUtility, sgObject::IVectorAnalysis, sgObject::IWidget, sgObject::IWks, sgObject::IXMLDoc, sgObject::IXMLElements에 의해 상속되었습니다.

IDispatch에 대한 협력 다이어그램:
생성시간 : 화 5월 26 2020 12:14:16, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 색인

클래스 색인
A | C | D | F | G | I | L | M | N | P | Q | S | T | U | V | X | _
A
GridMathOp (sgObject) IGraphicPolygon (sgObject) IPoint (sgObject) MultiLineString (sgObject)
GridMorphometryOp (sgObject) IGraphicRectangle (sgObject) IPointSymbol (sgObject) MultiPoint (sgObject)
AggregateGraphic (sgObject) GridPreprocessOp (sgObject) IGraphicScaledImage (sgObject) IPointSymbolizer (sgObject) MultiPolygon (sgObject)
Animator (sgObject) GridSurfaceOp (sgObject) IGridAnalysis (sgObject) IPointZ (sgObject)
N
Annotation (sgObject) GridVisibilityOp (sgObject) IGridColorRampItem (sgObject) IPolygon (sgObject)
AnnotationLabel (sgObject)
I
IGridColorRampStyle (sgObject) IPolygonSymbolizer (sgObject) NetworkCoverageAnalysis (sgObject)
Application (sgObject) IGridCoverage (sgObject) IPrintLayoutItem (sgObject)
P
ApplicationControl (sgObject) IAggregateGraphic (sgObject) IGridCoverageProcessor (sgObject) IPrintLayoutWidget (sgObject)
AttributeIndex (sgObject) IAnimator (sgObject) IGridGeneralizeOp (sgObject) IQueryCommand (sgObject) Parameter (sgObject)
C
IAnnotation (sgObject) IGridHydrologyOp (sgObject) IQueryCommands (sgObject) ParameterInfo (sgObject)
IAnnotationLabel (sgObject) IGridInterpolationOp (sgObject) ISampleDimension (sgObject) Parameters (sgObject)
Chart (sgObject) IApplication (sgObject) IGridMathOp (sgObject) ISensor (sgObject) Point (sgObject)
CommonFactory (sgObject) IApplicationControl (sgObject) IGridMorphometryOp (sgObject) ISpatialOperator (sgObject) PointSymbol (sgObject)
CoverageFactory (sgObject) IAttributeIndex (sgObject) IGridOperation (sgObject) ISpatialReference (sgObject) Polygon (sgObject)
D
ICanvas (sgObject) IGridPreprocessOp (sgObject) ISpatialReferenceFactory (sgObject)
Q
IChart (sgObject) IGridSampleDimension (sgObject) ISpatialReferenceInfo (sgObject)
DefaultTransaction (sgObject) IColorModel (sgObject) IGridSurfaceOp (sgObject) ISpatialRelation (sgObject) QueryCommand (sgObject)
DisplayFactory (sgObject) IColorRampList (sgObject) IGridTypeStyle (sgObject) ISpatialRelation2 (sgObject) QueryCommands (sgObject)
DockWidget (sgObject) ICommonFactory (sgObject) IGridVisibilityOp (sgObject) IStroke (sgObject)
S
F
ICoverage (sgObject) IHalo (sgObject) ISurface (sgObject)
ICoverageFactory (sgObject) IHistogram (sgObject) ISymbol (sgObject) SpatialReference (sgObject)
Feature (sgObject) ICurve (sgObject) IImageSymbol (sgObject) ISymbolizer (sgObject) SpatialReferenceFactory (sgObject)
FeatureAttributeDescriptor (sgObject) IDefaultTransaction (sgObject) IIndexMapWidget (sgObject) ITabWidget (sgObject) Stroke (sgObject)
FeatureAttributeTreeWidget (sgObject) IDispatch ILayer (sgObject) ITextSymbolizer (sgObject) Symbolizer (sgObject)
FeatureCanvas (sgObject) IDisplayFactory (sgObject) ILayerSource (sgObject) IUserDefinedWidget (sgObject)
T
FeatureCollection (sgObject) IDockWidget (sgObject) ILayerSourceFactory (sgObject) IUtility (sgObject)
FeatureLayer (sgObject) IFeature (sgObject) ILayerTreeWidget (sgObject) IVectorAnalysis (sgObject) TabWidget (sgObject)
FeatureQuery (sgObject) IFeatureAttributeDescriptor (sgObject) ILinearRing (sgObject) IVideo (sgObject)
U
FeatureType (sgObject) IFeatureAttributeTreeWidget (sgObject) ILineString (sgObject) IVideoSensor (sgObject)
FeatureTypeStyle (sgObject) IFeatureAttributeValidValue (sgObject) ILineSymbolizer (sgObject) IWidget (sgObject) UserDefinedWidget (sgObject)
FeatureTypeStyleFactory (sgObject) IFeatureCanvas (sgObject) ILocationSensor (sgObject) IWks (sgObject) Utility (sgObject)
FeatureTypeStyleRule (sgObject) IFeatureCollection (sgObject) ILocationService (sgObject) IXMLDoc (sgObject)
V
Fill (sgObject) IFeatureLayer (sgObject) ImageSymbol (sgObject) IXMLElements (sgObject)
Font (sgObject) IFeatureQuery (sgObject) IMap2D (sgObject)
L
Video (sgObject)
G
IFeatureStyleCollection (sgObject) IMap2DControl (sgObject) VideoSensor (sgObject)
IFeatureType (sgObject) IMap3D (sgObject) Layer (sgObject)
X
Generator3D (sgObject) IFeatureTypeStyle (sgObject) IMap3DCamera (sgObject) LayerSource (sgObject)
GeographicTransform (sgObject) IFeatureTypeStyleFactory (sgObject) IMap3DControl (sgObject) LayerSourceFactory (sgObject) XMLDoc (sgObject)
GeometryCollection (sgObject) IFeatureTypeStyleRule (sgObject) IMap3DLight (sgObject) LayerTreeWidget (sgObject) XMLElements (sgObject)
GeometryFactory (sgObject) IFill (sgObject) IMapAR (sgObject) LinearRing (sgObject)
_
GPDLayerSource (sgObject) IFont (sgObject) IMapARControl (sgObject) LineString (sgObject)
Graph (sgObject) IGenerator3D (sgObject) IMapEarth (sgObject) LocationSensor (sgObject) _IApplicationControlEvents (sgObject)
GraphicArc (sgObject) IGeodeticSpatialReference (sgObject) IMapEarthControl (sgObject) LocationService (sgObject) _IFeatureCanvasEvents (sgObject)
GraphicCanvas (sgObject) IGeographicCoordinateSystem (sgObject) IMark (sgObject)
M
_IFeatureLayerEvents (sgObject)
GraphicIcon (sgObject) IGeographicTransform (sgObject) IMessage (sgObject) _IGraphicCanvasEvents (sgObject)
GraphicLabel (sgObject) IGeometry (sgObject) IMotionSensor (sgObject) Map2D (sgObject) _ILocationSensorEvents (sgObject)
GraphicLineString (sgObject) IGeometryCollection (sgObject) IMultiCurve (sgObject) Map2DControl (sgObject) _IMap2DControlEvents (sgObject)
GraphicPolygon (sgObject) IGeometryFactory (sgObject) IMultiLineString (sgObject) Map3D (sgObject) _IMap2DEvents (sgObject)
GraphicRectangle (sgObject) IGPDLayerSource (sgObject) IMultiPoint (sgObject) Map3DControl (sgObject) _IMap3DControlEvents (sgObject)
GraphicScaledImage (sgObject) IGraph (sgObject) IMultiPolygon (sgObject) MapAR (sgObject) _IMap3DEvents (sgObject)
GridColorRampStyle (sgObject) IGraphic (sgObject) IMultiSurface (sgObject) MapARControl (sgObject) _IMapARControlEvents (sgObject)
GridCoverage (sgObject) IGraphicArc (sgObject) IndexMapWidget (sgObject) MapEarth (sgObject) _IMapAREvents (sgObject)
GridCoverageProcessor (sgObject) IGraphicCanvas (sgObject) INetworkCoverageAnalysis (sgObject) MapEarthControl (sgObject) _IMapEarthControlEvents (sgObject)
GridGeneralizeOp (sgObject) IGraphicIcon (sgObject) IParameter (sgObject) Mark (sgObject) _IMapEarthEvents (sgObject)
GridHydrologyOp (sgObject) IGraphicLabel (sgObject) IParameterInfo (sgObject) Message (sgObject) _IMotionSensorEvents (sgObject)
GridInterpolationOp (sgObject) IGraphicLineString (sgObject) IParameters (sgObject) MotionSensor (sgObject) _IVideoSensorEvents (sgObject)
A | C | D | F | G | I | L | M | N | P | Q | S | T | U | V | X | _
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 계통도

클래스 계통도

그래픽컬한 클래스 계통도 페이지로 가기

이 상속 목록은 완전하진 않지만 알파벳순으로 대략적으로 정렬되어있습니다.:
[상세 단계 12345]
C sgObject::_IFeatureCanvasEvents | FeatureCanvas에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다
C sgObject::AggregateGraphic |
C sgObject::Animator | Animator는 Graphic객체를 Animation하는 객체이다. 자세한 내용은 IAnimator 인터페이스에 대한 설명을 참고한다
C sgObject::Annotation | Feature 객체의 주석 정보 (간단한 텍스트 정보)를 관리한다
C sgObject::AnnotationLabel | AnnotationLabel는 Feature 객체의 주석 텍스트를 관리하는 객체이다
C sgObject::Application |
C sgObject::ApplicationControl |
C sgObject::AttributeIndex | AttributeIndex 객체는 FeatureCollection 객체에 Spatial Indexing 기능을 제공하고, 이를 사용하여 빠른 공간 검색 (공간 연산을 통한 부분집합 검색) 기능을 FeatureCollection 객체에 제공한다
C sgObject::Chart | Chart 클래스. 자세한 내용은 IChart 인터페이스에 대한 설명을 참고한다
C sgObject::CommonFactory | CommonFactory 클래스. 자세한 내용은 ICommonFactory 인터페이스에 대한 설명을 참고한다
C sgObject::CoverageFactory | CoverageFactory 클래스. 자세한 내용은 ICoverageFactory 인터페이스에 대한 설명을 참고한다
C sgObject::DefaultTransaction | DefaultTransaction 객체는 작업의 전체 세트가 동시에 롤백 또는 커밋 할 수있는 작업을 제공합니다
C sgObject::DisplayFactory | DisplayFactory 클래스. 자세한 내용은 IDisplayFactory 인터페이스에 대한 설명을 참고한다
C sgObject::DockWidget |
C sgObject::Feature | Feature 객체는 Object를 활용한 GIS 애플리케이션에서 실세계의 객체를 표현하는 기본 단위로 Feature 객체를 데이터베이스와 대응시키면 레코드 한 개와 대응된다
C sgObject::FeatureAttributeDescriptor | FeatureAttributeDescriptor 객체는 Feature 객체에 저장된 일반 (속성) 정보 필드 한 개의 구조를 설명하는 객체이다. (데이터 타입 등)
C sgObject::FeatureAttributeTreeWidget |
C sgObject::FeatureCanvas | FeatureCanvas는 화면에 표현할 수 있는 여러 개의 FeatureLayer가 저장된 객체로 Map2D 객체를 통해 FeatureCanvas에 있는 Feature들을 실제 모니터 화면에 표현한다
C sgObject::FeatureCollection | FeatureCollection은 같은 종류의 Feature 객체들의 집합을 관리하는 객체이다
C sgObject::FeatureLayer | GIS에서는 데이터를 화면에 표현하기 위해 관리할 때 보통 Layer의 개념을 도입해 객체 종류별 관리를 한다
C sgObject::FeatureQuery | FeatureQuery는 주어진 Query 조건에 맞는 Feature 객체를 선별하기 위한 기능을 FeatureCollection에 제공하는 객체이다
C sgObject::FeatureType | FeatureType은 Feature 객체가 어떤 타입인지를 나타내는 객체이다
C sgObject::FeatureTypeStyle | FeatureTypeStyle 클래스. 자세한 내용은 IFeatureTypeStyle 인터페이스에 대한 설명을 참고한다
C sgObject::FeatureTypeStyleFactory | FeatureTypeStyleFactory는 FeatureStyle 객체 및 Symbolizer객체를 생성하는 객체이다
C sgObject::FeatureTypeStyleRule | FeatureTypeStyleRule 클래스. 자세한 내용은 IFeatureTypeStyleRule 인터페이스에 대한 설명을 참고한다
C sgObject::Fill | 자세한 설명은 IFill 설명을 참고한다
C sgObject::Font | 자세한 설명은 IText 설명을 참고한다
C sgObject::Generator3D | Generator3D 인터페이스는 2D를 3D로 변환하기 위한 객체이다
C sgObject::GeographicTransform | GeographicTransform
C sgObject::GeometryCollection | GeometryCollection은 기하 객체 모델의 GeometryCollection을 나타내는 객체이다
C sgObject::GeometryFactory | GeometryFactory는 기하를 생성하는 기능을 제공하는 객체이다
C sgObject::GPDLayerSource | [업데이트 예정]
C sgObject::Graph | Graph 클래스. 자세한 내용은 IGraph 인터페이스에 대한 설명을 참고한다
C sgObject::GraphicArc |
C sgObject::GraphicCanvas |
C sgObject::GraphicIcon |
C sgObject::GraphicLabel |
C sgObject::GraphicLineString |
C sgObject::GraphicPolygon |
C sgObject::GraphicRectangle |
C sgObject::GraphicScaledImage |
C sgObject::GridColorRampStyle | GridColorRampStyle 클래스. 자세한 내용은 IGridColorRampStyle 인터페이스에 대한 설명을 참고한다
C sgObject::GridCoverage | GridCoverage 클래스. 자세한 내용은 IGridCoverage 인터페이스에 대한 설명을 참고한다
C sgObject::GridCoverageProcessor | GridCoverageProcessor 클래스. 자세한 내용은 IGridCoverageProcessor 인터페이스에 대한 설명을 참고한다
C sgObject::GridGeneralizeOp |
C sgObject::GridHydrologyOp | GridHydrologyOp 클래스. 자세한 내용은 IGridHydrologyOp 인터페이스에 대한 설명을 참고한다
C sgObject::GridInterpolationOp | GridInterpolationOp 클래스. 자세한 내용은 IGridInterpolationOp 인터페이스에 대한 설명을 참고한다
C sgObject::GridMathOp | GridMathOp 클래스. 자세한 내용은 IGridMathOp 인터페이스에 대한 설명을 참고한다
C sgObject::GridMorphometryOp | GridMorphometryOp 클래스. 자세한 내용은 IGridMorphometryOp 인터페이스에 대한 설명을 참고한다
C sgObject::GridPreprocessOp | GridPreprocessOp 클래스. 자세한 내용은 IGridPreprocessOp 인터페이스에 대한 설명을 참고한다
C sgObject::GridSurfaceOp | GridSurfaceOp 클래스. 자세한 내용은 IGridSurfaceOp 인터페이스에 대한 설명을 참고한다
C sgObject::GridVisibilityOp | GridVisibilityOp 클래스. 자세한 내용은 IGridVisibilityOp 인터페이스에 대한 설명을 참고한다
►C IDispatch |
C sgObject::_IApplicationControlEvents | 어플리케이션 ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다
C sgObject::_IFeatureLayerEvents | FeatureLayer 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다
C sgObject::_IGraphicCanvasEvents | GraphicCanvas 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다
C sgObject::_ILocationSensorEvents | LocationSensor 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다
C sgObject::_IMap2DControlEvents | Map2D ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다
C sgObject::_IMap2DEvents | Map2D 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다
C sgObject::_IMap3DControlEvents | Map3D ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다
C sgObject::_IMap3DEvents | Map3D 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다
C sgObject::_IMapARControlEvents | MapAR ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다
C sgObject::_IMapAREvents | MapAR 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다
C sgObject::_IMapEarthControlEvents | MapEarth ActiveX 컨트롤에서 발생하는 이벤트 인터페이스를 제공한다
C sgObject::_IMapEarthEvents | MapEarth 객체에서 발생하는 이벤트 처리를 위한 인터페이스를 제공한다
C sgObject::_IMotionSensorEvents | MotionSensor 객체에 발생하는 이벤트 처리를 위한 인터페이스를 제공한다
C sgObject::_IVideoSensorEvents | Camera 장치와 연결하여 Video 수신 기능을 행하는 VideoSensor 객체에 이벤트 처리를 위한 인터페이스를 제공한다
C sgObject::IAnimator | 그래픽 객체의 애니메이션 효과를 제공하는 인터페이스를 제공한다
C sgObject::IAnnotation | Feature 객체의 주석 정보 (간단한 텍스트 정보)를 관리하는 주석 객체에 인터페이스를 제공한다
C sgObject::IApplicationControl | 어플리케이션 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다
C sgObject::IAttributeIndex | FeatureCollection 객체에 인덱싱 기능을 제공하는 AttributeIndex 객체의 인터페이스를 제공한다
►C sgObject::ICanvas | 지도 객체의 최상위 인터페이스로 2D/3D/AR 등 하위 상속 객체가 존재하며 모든 지도 객체의 공통 인터페이스를 제공한다
C sgObject::IGraphicCanvas | 실세계좌표를 기반으로 표현되는 지도객체와 달라 비축척 그래픽 객체에 기반한 객체로 단면도, 설계도와 같이 지리적 특성을
C sgObject::IMap2D | 2D 지도를 관리하는 객체로 Canvas 객체로 부터 상속되었으며 사용자에게 지도를 표출하고 마우스 등 사용자 UI 인터페이스를 제공한다
C sgObject::IMap3D | Canvas객체로부터 상속된 Map3D 객체에 대한 인터페이스를 제공한다
C sgObject::IMapAR | Canvas객체로부터 상속받은 MapAR 객체에 대한 인터페이스를 제공한다
C sgObject::IMapEarth | Canvas객체로부터 상속받은 MapEarth 객체에 대한 인터페이스를 제공한다
C sgObject::IColorModel | C API(linux, iOS, MacOS 등) : 중간이름 "GCM"를 덧붙여서 "OGR_GCM_"+메소드명으로 사용한다
C sgObject::IColorRampList | 시스템에 유일하게 존재하는 GridColorRampStyle 형태의 래스터 일괄 표현 규정 리스트를 정의한 인터페이스를 제공한다
C sgObject::ICommonFactory | 다양한 Factory객체 인터페이스를 생성할 수 있는 최상위 인터페이스를 제공한다
►C sgObject::ICoverage | 커버리지에 접근할 수 있도록 해주는 인터페이스이다
C sgObject::IGridCoverage | IGridCoverage 인터페이스는 데이터 공급 업체와 그리드를 (래스터) 분석 및 처리 기능을 제공하는 소프트웨어 공급 업체에 의해 소프트웨어 구현 간의 상호 운용성을 허용 방법을 정의합니다
C sgObject::ICoverageFactory | ICoverageFactory 인터페이스는 커버리지 관련된 객체를 생성하기 위하여 사용된다
C sgObject::IDefaultTransaction | 작업의 전체 세트가 동시에 롤백 또는 커밋 할 수있는 작업을 제공합니다
C sgObject::IDisplayFactory | 화면에 표현되는 지도와 관련된 객체를 생성하기 위한 인터페이스를 제공한다
►C sgObject::IFeature | 실세계의 객체를 표현하는 기본 단위인 Feature 객체의 인터페이스를 제공한다
C sgObject::IAnnotationLabel | Feature 객체의 주석 텍스트를 관리하는 라벨 객체에 인터페이스를 제공한다
C sgObject::IFeatureCollection | 같은 종류의 Feature 객체들의 집합을 관리하는 FeatureCollection 객체의 인터페이스를 제공한다
C sgObject::IFeatureAttributeDescriptor | Feature 객체의 필드(속성) 객체로 FeatureType 객체는 FeatureAttributeDescriptor 객체의 집합이다
C sgObject::IFeatureAttributeValidValue | C API(linux, iOS, MacOS 등) : 중간이름 "FAV"를 덧붙여서 "OGR_FAV_"+메소드명으로 사용한다
C sgObject::IFeatureCanvas | 화면에 표현할 수 있는 여러 개의 FeatureLayer가 저장된 객체로 Map2D 객체를 통해 FeatureCanvas에 있는 Feature들을 실제 모니터 화면에 표현한다. (Document/View 구조에서 FeatureCanvas는 Document, Canvas2D는 View에 해당한다)
C sgObject::IFeatureLayer | FeatureLayer 객체의 인터페이스를 제공한다
C sgObject::IFeatureQuery | 주어진 쿼리 조건에 맞는 Feature 객체를 선별하기 위한 기능을 제공하는 인터페이스를 제공한다
C sgObject::IFeatureStyleCollection | 자주 사용하는 FeatureStyle 객체의 집합을 관리하기 위한 인터페이스를 제공한다
C sgObject::IFeatureType | Feature 객체가 어떤 타입인지를 나타내는 FeatureType 객체의 인터페이스를 제공한다
►C sgObject::IFeatureTypeStyle | FeatureCollection내의 Feature에 대한 속성 및 공간 정보에 따른 표현 방법을 기술하기 위해 사용된다. 예) 주제도
►C sgObject::IGridTypeStyle | FeatureTypeStyle로 부터 상속된 래스터를 위한 래스터 표현 규정을 정의한 인터페이스를 제공한다
C sgObject::IGridColorRampStyle | GridTypeStyle로 부터 상속된 래스터를 위한 래스터 표현 규정을 일괄 정의한 인터페이스를 제공한다
C sgObject::IFeatureTypeStyleFactory | FeatureStyle의 생성 및 Symbolizer등 스타일 관련 객체를 생성하는 인터페이스를 제공한다
►C sgObject::IFeatureTypeStyleRule | FeatureTypeStyle의 규정을 정의하며 속성 및 스케일에 따른 표현 인터페이스를 제공한다
C sgObject::IGridColorRampItem | FeatureTypeStyleRule에서 상속된 객체로 GridTypeStyle의 Rule에 의해 정의되는 표현 색상에 대한 정보 및
C sgObject::IFill | Brush의 스타일을 표현하기 위한 인터페이스를 제공한다
C sgObject::IFont | 글꼴의 스타일을 표현하기 위한 인터페이스를 제공한다
C sgObject::IGenerator3D | 2D를 3D로 변환하기 위한 인터페이스를 제공한다
►C sgObject::IGeometry | 기하 및 위치 정보(공간 좌표)를 갖는 기하의 기하 및 위치 정보 관리를 위한 인터페이스를 제공한다
►C sgObject::ICurve | 기하 명세에 정의된 커브의 일반 속성과 그러한 속성에 접근하기 위한 인터페이스를 제공한다
►C sgObject::ILineString | 기하 명세에 정의된 LineString의 속성과 그 속성에 접근하는 인터페이스를 제공한다
C sgObject::ILinearRing | 기하 명세에 정의된 LinearRing에 대한 일반적인 인터페이스를 제공한다. (현재는 프로퍼티 및 메소드가 없으나 LinearRing에 대한 프로퍼티 및 메소드 추가를 고려해 만들어 놓은 인터페이스이다)
►C sgObject::IGeometryCollection | 기하 및 위치 정보(공간 좌표)를 갖는 기하가 기본 기하(Point, LineString, Polygon 등)로 표현할 수 없는 복잡한 기하 구조를 갖는 경우 이를 표현할 수 있도록 해주는 인터페이스를 제공한다
►C sgObject::IMultiCurve | 기하명세의 MultiCurve에 대한 일반적인 인터페이스를 제공한다. (MultiCurve는 Curve가 여러 개 있는 것)
C sgObject::IMultiLineString | 기하명세에 정의된 MultiLineString에 대한 일반적인 인터페이스를 제공한다. (MultiLineString은 LineString이 여러 개 있는 것)
C sgObject::IMultiPoint | 기하 명세에 정의된 MultiPoint에 대한 일반적인 인터페이스를 제공한다
►C sgObject::IMultiSurface | Surface가 여러 개 있는 것으로, 기하명세의 MultiSurface에 대한 일반적인 인터페이스를 제공한다
C sgObject::IMultiPolygon | 기하 명세에 정의된 MultiPolygon에 대한 일반적인 인터페이스를 제공한다. (MultiPolygon은 Polygon이 여러 개 있는 것)
►C sgObject::IPoint | 기하 명세에 정의된 점에 대한 일반적인 인터페이스를 제공한다
C sgObject::IPointZ | 기하 명세에 정의된 Point를 3차원으로 확장하기 위한 인터페이스를 제공한다
►C sgObject::ISurface | 기하 명세에 정의된 Surface에 대한 일반적인 인터페이스를 제공한다
C sgObject::IPolygon | 기하 명세에 정의된 Polygon에 대한 일반적인 인터페이스를 제공한다
C sgObject::IGeometryFactory | Well Known Binary 및 Well Known Text 데이터를 통해 IGeometry 인터페이스를 갖는 객체를 생성하기 위한 인터페이스를 제공한다
►C sgObject::IGraphic | 그래픽 객체의 인터페이스를 제공한다
C sgObject::IAggregateGraphic | 다수의 그래픽 객체의 집합 형태를 그래픽화 하여 표현하는 인터페이스를 제공한다
C sgObject::IGraphicArc | 호의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다
C sgObject::IGraphicIcon | 아이콘의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다
C sgObject::IGraphicLabel | 텍스트의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다
C sgObject::IGraphicLineString | 라인의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다
C sgObject::IGraphicPolygon | 폴리곤 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다
C sgObject::IGraphicRectangle | 사각형의 형태로 그래픽 객체를 표현하는 인터페이스를 제공한다
C sgObject::IGraphicScaledImage | 입력된 스케일과 이미지로 그래픽 객체를 표현하는 인터페이스를 제공한다
C sgObject::IGridAnalysis |
C sgObject::IGridCoverageProcessor | IGridCoverageProcessor 인터페이스는 그리드 커버리지 값에 접근할 수 있도록 해준다
►C sgObject::IGridOperation | IGridOperation 인터페이스는 그리드 커버리지 처리 기능에 대한 정보를 제공한다
C sgObject::IGridGeneralizeOp | IGridGeneralizeOp 인터페이스
C sgObject::IGridHydrologyOp | IGridHydrologyOp 인터페이스는 수문학(수로, 수문, 하천, 지하수 등) 등의 처리를 위한 그리드 커버리지 알고리즘 제어 인터페이스
C sgObject::IGridInterpolationOp | IGridInterpolationOp 인터페이스는 그리드 보간 처리를 위한 그리드 커버리지 알고리즘 제어 인터페이스
C sgObject::IGridMathOp | IGridMathOp 인터페이스는 산술연산 등의 처리를 위한 그리드 커버리지 알고리즘 제어 인터페이스
C sgObject::IGridMorphometryOp | IGridMorphometryOp 인터페이스는 영상의 형태를 활용한 분석 알고리즘 제어 인터페이스
C sgObject::IGridPreprocessOp | IGridPreprocessOp 인터페이스는 영상전처리를 위한 그리드 커버리지 알고리즘 제어 인터페이스
C sgObject::IGridSurfaceOp | IGridSurfaceOp 인터페이스
C sgObject::IGridVisibilityOp | IGridVisibilityOp 인터페이스
C sgObject::IHalo | 글꼴의 배경 스타일을 표현하기 위한 인터페이스를 제공한다
C sgObject::IHistogram | IHistogram 인터페이스는 하나의 샘플차원의 그리드 값에 대한 히스토그램을 계산한다
C sgObject::ILayer | 레이어 객체 인테페이스를 제공한다
►C sgObject::ILayerSource | LayerSource 객체의 인터페이스를 제공한다
C sgObject::IGPDLayerSource | [업데이트 예정]
C sgObject::ILayerSourceFactory | GIS 데이터를 갖고 있는 데이터소스로부터 데이터를 가져와 LayerSource를 생성하는 LayerSourceFactory 객체에 인터페이스를 제공한다
C sgObject::ILocationService | LBS의 주요 기능을 제공하는 인터페이스로 주소정보를 기반으로 해당위치의 Feature 객체를 검색하고,
C sgObject::IMap2DControl | Map2D 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다
C sgObject::IMap3DCamera | 3D 지도의 카메라를 제어하기 위한 인터페이스를 제공한다
C sgObject::IMap3DControl | Map3D 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다
C sgObject::IMap3DLight | 3D 지도의 채광을 제어하기 위한 인터페이스를 제공한다
C sgObject::IMapARControl | MapAR 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다
C sgObject::IMapEarthControl | MapEarth 객체를 포함하는 ActiveX 컨트롤 인터페이스를 제공한다
C sgObject::IMark | 심볼의 스타일을 표현하기 위한 인터페이스를 제공한다
C sgObject::IMessage | 제품의 언어별 메시지 체계에 따라 입력된 메시지 정보 제공 인터페이스를 제공한다
C sgObject::INetworkCoverageAnalysis | INetworkCoverageAnalysis 인터페이스는 네트워크 연산을 위해 사용된다
C sgObject::IParameter | IParameter 인터페이스
C sgObject::IParameterInfo | IParameterInfo 인터페이스
C sgObject::IParameters | IParameters 인터페이스
C sgObject::IPrintLayoutItem | 출력창의 아이템을 제어하는 인터페이스를 제공한다
C sgObject::IQueryCommand | 전체 비지니스 작업에 포함된 하나의 작업(쿼리)을 의미한다
C sgObject::IQueryCommands | 전체 비지니스 작업에 포함된 하나의 작업(쿼리)들을 의미한다
►C sgObject::ISampleDimension | ISampleDimension 인터페이스는 각각의 커버리지 샘플 차원에 대한 정보를 담고 있다
C sgObject::IGridSampleDimension | IGridSampleDimension 인터페이스는 각각의 커버리지 샘플 차원에 대한 정보를 담고 있다
►C sgObject::ISensor | 모든 센서(위치, 방향, 속도 외)의 상위 인터페이스로 센서의 공통 인터페이스를 제공한다
C sgObject::ILocationSensor | 위치 센서 장치와 연결하여 위치 정보 수신 및 기타 부수 자료의 집계하고 제공 인터페이스를 제공한다
C sgObject::IMotionSensor | 자이로스코프 장치와 연결하여 방향각, 기우러짐, 가속도 및 기타 부수 자료를 집계 제공하는 인터페이스를 제공한다
C sgObject::IVideoSensor | 카메라 센서 및 동영상 서비스로 부터 영상 정보를 획득하고 표현하는 인터페이스를 제공한다
C sgObject::ISpatialOperator | 기하에 다른 기하와의 공간연산 인터페이스를 제공한다
C sgObject::ISpatialReferenceFactory | ISpatialReferenceFactory 인터페이스
►C sgObject::ISpatialReferenceInfo | ISpatialReferenceInfo 인터페이스
C sgObject::IGeographicTransform | IGeographicTransform 인터페이스
►C sgObject::ISpatialReference | ISpatialReference 인터페이스는 Geometry 객체가 참조하는 공간참조체계를 정의하는 인터페이스를 제공한다
►C sgObject::IGeodeticSpatialReference | IGeodeticSpatialReference 인터페이스
C sgObject::IGeographicCoordinateSystem | IGeographicCoordinateSystem 인터페이스
C sgObject::ISpatialRelation | 기하에 적용되는 공간 관련성 연산자들을 정의한다
C sgObject::ISpatialRelation2 | 기하가 다른 기하와 공간적으로 어떤 관계에 있는지 테스트할 수 있는 인터페이스를 제공한다
C sgObject::IStroke | 펜의 스타일을 표현하기 위한 인터페이스를 제공한다
►C sgObject::ISymbol | Feature 객체를 화면에 표시하기 위해 심볼이 필요할 수도 있는데 ISymbol 인터페이스는 심볼 정보를 관리하는 Symbol 객체의 인터페이스를 제공한다
C sgObject::IImageSymbol | Feature 객체를 화면에 표시하기 위해 심볼이 필요할 수도 있는데 IImageSymbol 인터페이스는 이 중 이미지 타입의 심볼 정보를 관리하는 ImageSymbol 객체의 인터페이스를 제공한다
C sgObject::IPointSymbol | Feature 객체를 화면에 표시하기 위해 심볼이 필요할 수도 있는데 IPointSymbol 인터페이스는 이 중 벡터 타입의 심볼 정보를 관리하는 PointSymbol 객체의 인터페이스를 제공한다
►C sgObject::ISymbolizer | Feature 객체를 화면에 표시하기 위해 필요한 그래픽 속성 (선굵기, 색 등)을 관리하는 FeatureStyle 객체의 인터페이스를 제공한다
C sgObject::ILineSymbolizer | 선 스타일의 표현하는 방법 및 속성을 기술한다
C sgObject::IPointSymbolizer | 심볼의 스타일을 표현하는 방법 및 속성을 기술한다
C sgObject::IPolygonSymbolizer | 기하 내부 영역을 채우는 방법 및 속성을 기술한다
C sgObject::ITextSymbolizer | 라벨의 텍스트 스타일을 표현하기 위해 사용한다
C sgObject::IUtility | 일반적이지 않은 다양한 부수적인 기능 인터페이스를 제공한다
C sgObject::IVectorAnalysis | 벡터 레이어에 있는 feature들을 이용해서 다양한 연산을 할 수 있도록 인터페이스를 제공합니다
►C sgObject::IWidget | 위젯 객체를 관리하기 위한 최상의 인터페이스를 제공한다
C sgObject::IApplication | 어플리케이션 위젯(최상의 위젯)을 제어하는 인터페이스를 제공한다
C sgObject::IDockWidget | 도킹위젯을 제어하는 인터페이스를 제공한다
C sgObject::IFeatureAttributeTreeWidget | 속성관리창을 제어하는 인터페이스를 제공한다
C sgObject::IIndexMapWidget | 인덱스지도창 위젯을 관리하는 인터페이스를 제공한다
C sgObject::ILayerTreeWidget | 레이어제어 관리창을 제어하는 인터페이스를 제공한다
C sgObject::IPrintLayoutWidget | 출력창을 제어하는 인터페이스를 제공한다
C sgObject::ITabWidget | 탭위젯 객체를 제어하는 인터페이스를 제공한다
►C sgObject::IUserDefinedWidget | 사용자 정의 UI 객체를 정의/표현하기 위한 공통 인터페이스를 제공한다
C sgObject::IChart | 차트의 세부 속성을 설정하기 위한 인터페이스를 제공한다
C sgObject::IGraph | 그래프의 세부 속성을 설정하기 위한 인터페이스를 제공한다
C sgObject::IVideo | 비디오의 세부 속성을 설정하기 위한 인터페이스를 제공한다
C sgObject::IWks | 기하에 Well Known Binary 표현과 Well Known Text 표현을 다루는 인터페이스를 제공한다
C sgObject::IXMLDoc | XML파일을 관리, 분석 인터페이스를 제공한다
C sgObject::IXMLElements | XMLDoc객체로부터 해석된 객체에 존재하는 다양한 정보 관리 인터페이스를 제공한다
C sgObject::ImageSymbol | ImageSymbol은 Raster Image 심볼을 관리하는 객체이다
C sgObject::IndexMapWidget |
C sgObject::Layer | GIS에서는 데이터를 화면에 표현하기위해 관리할 때 보통 Layer의 개념을 도입해 객체 종류별 관리를 한다
C sgObject::LayerSource | GIS에서는 데이터를 화면에 표현하기 위해 관리할 때 보통 Layer의 개념을 도입해 객체 종류별 관리를 한다
C sgObject::LayerSourceFactory | LayerSourceFactory는 GIS 데이터를 갖고 있는 데이터소스로부터 데이터를 가져와 LayerSource를 생성하는 객체이다
C sgObject::LayerTreeWidget |
C sgObject::LinearRing | LinearRing은 기하 객체 모델의 LinearRing을 나타내는 객체이다
C sgObject::LineString | LineString은 기하 객체 모델의 LineString을 나타내는 객체이다
C sgObject::LocationSensor | LocationSensor은 GPS 장치와 연결하여 GPS 수신 기능을 행하는 객체이다. 자세한 내용은 ILocationSensor 에 대한 설명을 참고한다
C sgObject::LocationService | 주소정보를 기반으로 해당위치의 Feature 객체를 검색하고, 관리하는 기능과 POI 기능을 제공하는 객체이다. 자세한 내용은 ILocationService 인터페이스에 대한 설명을 참고한다
C sgObject::Map2D | Map2D 클래스는 FeatureCanvas 객체와 연동하여 Feature들의 Geometry 및 주석 정보를 화면에 그리고 화면으로부터 사용자 입력을 받는 등 실제 화면 제어를 담당하는 객체이다
C sgObject::Map2DControl |
C sgObject::Map3D | Map3D 클래스는 FeatureCanvas 객체와 연동하여 Feature들의 Geometry 및 주석 정보를 화면에 그리고 화면으로부터 사용자 입력을 받는 등 실제 화면 제어를 담당하는 객체이다. 자세한 내용은 IMap3D 에 대한 설명을 참고한다
C sgObject::Map3DControl |
C sgObject::MapAR | MapAR 클래스는 FeatureCanvas 객체와 연동하여 Feature들의 Geometry 및 주석 정보를 화면에 그리고 화면으로부터 사용자 입력을 받는 등 실제 화면 제어를 담당하는 객체이다. 자세한 내용은 IMapAR 에 대한 설명을 참고한다
C sgObject::MapARControl |
C sgObject::MapEarth | MapEarth 클래스는 FeatureCanvas 객체와 연동하여 Feature들의 Geometry 및 주석 정보를 화면에 그리고 화면으로부터 사용자 입력을 받는 등 실제 화면 제어를 담당하는 객체이다. 자세한 내용은 IMapEarth 에 대한 설명을 참고한다
C sgObject::MapEarthControl |
C sgObject::Mark | 자세한 설명은 IMark 설명을 참고한다
C sgObject::Message | Message는 메시지파일에 따른 메시지를 출력하는 객체이다. 자세한 내용은 IMessage 인터페이스에 대한 설명을 참고한다
C sgObject::MotionSensor | MotionSensor은 Gyroscope 장치와 연결하여 Motion 수신 기능을 행하는 객체이다. 자세한 내용은 IMotionSensor 에 대한 설명을 참고한다
C sgObject::MultiLineString | MultiLineString은 기하 객체 모델의 MultiLineString을 나타내는 객체이다
C sgObject::MultiPoint | MultiPoint는 기하 객체 모델의 MultiPoint를 나타내는 객체이다
C sgObject::MultiPolygon | MultiPolygon은 기하 객체 모델의 MultiPolygon을 나타내는 객체이다
C sgObject::NetworkCoverageAnalysis | NetworkCoverageAnalysis 클래스. 자세한 내용은 INetworkCoverageAnalysis 인터페이스에 대한 설명을 참고한다
C sgObject::Parameter | Parameter
C sgObject::ParameterInfo | ParameterInfo
C sgObject::Parameters | Parameters
C sgObject::Point | Point는 기하 객체 모델의 Point를 나타내는 객체이다
C sgObject::PointSymbol | PointSymbol은 Vector로 그려진 심볼을 관리하는 객체이다
C sgObject::Polygon | Polygon은 기하 객체 모델의 Polygon을 나타내는 객체이다
C sgObject::QueryCommand | 자세한 설명은 IQueryCommand 설명을 참고한다
C sgObject::QueryCommands | 자세한 설명은 IQueryCommands 설명을 참고한다
C sgObject::SpatialReference | SpatialReference는 Geometry 객체가 참조하는 공간참조체계를 정의하는 객체이다
C sgObject::SpatialReferenceFactory | SpatialReferenceFactory
C sgObject::Stroke | 자세한 설명은 IStroke 설명을 참고한다
C sgObject::Symbolizer | 자세한 설명은 ISymbolizer 설명을 참고한다
C sgObject::TabWidget |
C sgObject::UserDefinedWidget | UserDefinedWidget 클래스. 자세한 내용은 IUserDefinedWidget 인터페이스에 대한 설명을 참고한다
C sgObject::Utility | Utility는 여러가지 부수적인 기능을 제공하는 객체이다. 자세한 내용은 IUtility 인터페이스에 대한 설명을 참고한다
C sgObject::Video | Video 클래스. 자세한 내용은 IVideo 인터페이스에 대한 설명을 참고한다
C sgObject::VideoSensor | VideoSensor은 Camera 장치와 연결하여 Video 수신 기능을 행하는 객체이다. 자세한 내용은 IVideoSensor 에 대한 설명을 참고한다
C sgObject::XMLDoc | XMLDoc 클래스. 자세한 내용은 IXMLDoc 인터페이스에 대한 설명을 참고한다
C sgObject::XMLElements | XMLElements 클래스. 자세한 내용은 IXMLElements 인터페이스에 대한 설명을 참고한다
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
다음은 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버가 속해 있는 클래스에 대한 링크를 가지고 있습니다. :

- a -

  • Add()
: sgObject::IAnnotation
, sgObject::IFeatureCollection
, sgObject::IFeatureStyleCollection
, sgObject::IFeatureType
, sgObject::IGeometryCollection
, sgObject::IGraphicCanvas
, sgObject::IQueryCommands
  • AddAction() : sgObject::IApplication
  • AddAll() : sgObject::IFeatureCollection
  • AddAttribute() : sgObject::IFeatureLayer
  • AddCanvas() : sgObject::ITabWidget
  • AddChild() : sgObject::IAggregateGraphic
  • AddChildElement() : sgObject::IXMLElements
  • AddChildren() : sgObject::IAggregateGraphic
  • AddColorRamp() : sgObject::IColorRampList
  • AddControl() : sgObject::ICanvas
  • AddDockWidget() : sgObject::IApplication
  • AddExteriorPoint() : sgObject::IGraphicPolygon
  • AddFeatureLayer()
: sgObject::IFeatureCanvas
, sgObject::IIndexMapWidget
  • AddGridSampleDimension() : sgObject::IGridCoverage
  • AddInteriorPoint() : sgObject::IGraphicPolygon
  • AddLayerSource() : sgObject::IFeatureCanvas
  • AddMenu() : sgObject::IApplication
  • AddParameter() : sgObject::IParameters
  • AddPoint()
: sgObject::IGraphicLineString
, sgObject::ILineString
  • AddRule() : sgObject::IFeatureTypeStyle
  • AddStyleFromString() : sgObject::ISymbolizer
  • AddTab() : sgObject::ITabWidget
  • AddToFeatureLayer() : sgObject::ILayer
  • AddToIndex() : sgObject::IAttributeIndex
  • AddUser() : sgObject::IGPDLayerSource
  • AddWidget() : sgObject::IWidget
  • AddWidgetByLayout() : sgObject::IWidget
  • AfterQueryCommands() : sgObject::IDefaultTransaction
  • AnimateSelectedFeatureCollection() : sgObject::IMap2D
  • AttributeDescriptor() : sgObject::IFeatureType
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
다음은 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버가 속해 있는 클래스에 대한 링크를 가지고 있습니다. :

- b -

  • BeforeQueryCommands() : sgObject::IDefaultTransaction
  • Boundary() : sgObject::ISpatialOperator
  • BoundaryGeometry() : sgObject::IVectorAnalysis
  • BoundingBox() : sgObject::IMap2D
  • Buffer() : sgObject::ISpatialOperator
  • BufferGeometry() : sgObject::IVectorAnalysis
  • BufferGeometryWithSingleSide() : sgObject::IVectorAnalysis
  • BufferGeometryWithStyle() : sgObject::IVectorAnalysis
  • BufferWithStyle() : sgObject::ISpatialOperator
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
다음은 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버가 속해 있는 클래스에 대한 링크를 가지고 있습니다. :

- c -

  • CalculateDistanceFromLL() : sgObject::IUtility
  • CalculateMeterUnitFromLL() : sgObject::IUtility
  • CanProcess() : sgObject::ILayerSourceFactory
  • Centroid()
: sgObject::IMultiSurface
, sgObject::ISurface
  • Clear()
: sgObject::IAttributeIndex
, sgObject::IFeatureCollection
, sgObject::IGraphicCanvas
, sgObject::IParameter
, sgObject::IXMLDoc
  • ClearEffectFilter() : sgObject::IGridTypeStyle
  • ClearViewshed() : sgObject::IMapEarth
  • Click()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • ClipGeometry() : sgObject::IVectorAnalysis
  • Clone()
: sgObject::IFeature
, sgObject::IFeatureAttributeDescriptor
, sgObject::IFeatureType
, sgObject::IFeatureTypeStyleRule
, sgObject::IGeometry
, sgObject::IParameter
, sgObject::IQueryCommand
, sgObject::ISpatialReference
, sgObject::ISymbolizer
  • Close()
: sgObject::IFeatureCollection
, sgObject::IFeatureStyleCollection
  • ColorStringToNumber() : sgObject::IUtility
  • ColorToNumber() : sgObject::IUtility
  • Commit()
: sgObject::IDefaultTransaction
, sgObject::IFeatureCanvas
  • Committed() : sgObject::_IFeatureCanvasEvents
  • Compile() : sgObject::IFeatureQuery
  • Compression() : sgObject::IUtility
  • Contains()
: sgObject::IFeatureCanvas
, sgObject::IFeatureCollection
, sgObject::ISpatialRelation
  • ContainsAll() : sgObject::IFeatureCollection
  • ConvexHull() : sgObject::ISpatialOperator
  • Coordinates() : sgObject::_ILocationSensorEvents
  • Coords() : sgObject::IPoint
  • Copy() : sgObject::IFeatureCanvas
  • CopyTo() : sgObject::IFeature
  • CountPerBucket() : sgObject::IHistogram
  • Create() : sgObject::IAttributeIndex
  • CreateAnimator() : sgObject::ICommonFactory
  • CreateApplication() : sgObject::IDisplayFactory
  • CreateAttributeIndex() : sgObject::ICommonFactory
  • CreateCanvas() : sgObject::IDisplayFactory
  • CreateCoverageFactory() : sgObject::ICommonFactory
  • CreateCRSFactory() : sgObject::ICommonFactory
  • CreateElement() : sgObject::IXMLDoc
  • CreateFeature() : sgObject::IFeatureCollection
  • CreateFeatureAttributeDescriptor() : sgObject::ICommonFactory
  • CreateFeatureCanvas() : sgObject::IDisplayFactory
  • CreateFeatureLayer() : sgObject::ILayer
  • CreateFeatureQuery() : sgObject::ICommonFactory
  • CreateFeatureType() : sgObject::ICommonFactory
  • CreateFeatureTypeStyle() : sgObject::IFeatureTypeStyleFactory
  • CreateFeatureTypeStyleFactory() : sgObject::ICommonFactory
  • CreateFeatureTypeStyleFromXML() : sgObject::IFeatureTypeStyleFactory
  • CreateFeatureTypeStyleRule() : sgObject::IFeatureTypeStyleFactory
  • CreateFillStyle() : sgObject::IFeatureTypeStyleFactory
  • CreateFontStyle() : sgObject::IFeatureTypeStyleFactory
  • CreateFromESRI() : sgObject::ISpatialReferenceFactory
  • CreateFromProj4() : sgObject::ISpatialReferenceFactory
  • CreateFromWKB() : sgObject::IGeometryFactory
  • CreateFromWKT()
: sgObject::IGeometryFactory
, sgObject::ISpatialReferenceFactory
  • CreateFromXML() : sgObject::ISpatialReferenceFactory
  • CreateGeographicTransform() : sgObject::ISpatialReferenceFactory
  • CreateGeometryFactory() : sgObject::ICommonFactory
  • CreateGraphic() : sgObject::IDisplayFactory
  • CreateGraphicFromFeature() : sgObject::IDisplayFactory
  • CreateGraphicFromGeometry() : sgObject::IDisplayFactory
  • CreateGridCoverageProcessor() : sgObject::ICoverageFactory
  • CreateLayer() : sgObject::ILayerSource
  • CreateLayerSource() : sgObject::ILayerSourceFactory
  • CreateLocationService() : sgObject::ICommonFactory
  • CreateMarkStyle() : sgObject::IFeatureTypeStyleFactory
  • CreateMessage() : sgObject::ICommonFactory
  • CreateNetworkCoverageAnalysis() : sgObject::ICoverageFactory
  • CreateNewLayerSource() : sgObject::ILayerSourceFactory
  • CreateNodeFeatureLayer() : sgObject::INetworkCoverageAnalysis
  • CreateParameter() : sgObject::ICommonFactory
  • CreateParameters() : sgObject::ICommonFactory
  • CreateStrokeStyle() : sgObject::IFeatureTypeStyleFactory
  • CreateSymbolizer() : sgObject::IFeatureTypeStyleFactory
  • CreateTemporaryLayer() : sgObject::IFeatureCanvas
  • CreateUtility() : sgObject::ICommonFactory
  • CreateViewshed() : sgObject::IMapEarth
  • CreateWidget() : sgObject::IDisplayFactory
  • CreateWidgetToFeatureAttributeTree() : sgObject::IDisplayFactory
  • CreateWidgetToIndexMap() : sgObject::IDisplayFactory
  • CreateWidgetToLayerTree() : sgObject::IDisplayFactory
  • Crosses() : sgObject::ISpatialRelation
  • Cut() : sgObject::IFeatureCanvas
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
다음은 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버가 속해 있는 클래스에 대한 링크를 가지고 있습니다. :

- d -

  • DblClick() : sgObject::ICanvas
  • Decompression() : sgObject::IUtility
  • Decryption() : sgObject::IUtility
  • DefaultShapeAttribute() : sgObject::IFeatureType
  • DelaunayTriangulation() : sgObject::IVectorAnalysis
  • DeleteFeatureCollection() : sgObject::IFeatureCanvas
  • DeleteFeatureLayer() : sgObject::IFeatureCanvas
  • DeleteFeatureLayerAll() : sgObject::IFeatureCanvas
  • DeleteLayer() : sgObject::ILayerSource
  • DeletePoint() : sgObject::IGraphicLineString
  • DeleteToolBarByType()
: sgObject::IApplication
, sgObject::IPrintLayoutWidget
  • Densify() : sgObject::IVectorAnalysis
  • Destroy()
: sgObject::ISpatialReference
, sgObject::IWidget
  • DeviceToWorld() : sgObject::IMap2D
  • DeviceToWorldZ() : sgObject::IMap2D
  • Difference() : sgObject::ISpatialOperator
  • DifferenceGeometry() : sgObject::IVectorAnalysis
  • Disjoint() : sgObject::ISpatialRelation
  • Dissolve() : sgObject::IVectorAnalysis
  • Distance() : sgObject::ISpatialOperator
  • DoOperation() : sgObject::IGridCoverageProcessor
  • DoubleClick()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • Draw() : sgObject::_IMap2DEvents
  • Drawed() : sgObject::_IMap2DEvents
  • DrawingGeometryAddGPSPoint() : sgObject::IMap2D
  • DrawingGeometryAddPoint() : sgObject::IMap2D
  • DrawingGeometryComplete() : sgObject::IMap2D
  • DrawingGeometryGetPoint() : sgObject::IMap2D
  • DrawingGeometryRemovePoint() : sgObject::IMap2D
  • DrawingGeometrySetPoint() : sgObject::IMap2D
  • DrawingGeometrySize() : sgObject::IMap2D
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
다음은 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버가 속해 있는 클래스에 대한 링크를 가지고 있습니다. :

- e -

  • Encryption() : sgObject::IUtility
  • Encryption1() : sgObject::IUtility
  • EndPoint() : sgObject::ICurve
  • Envelope() : sgObject::IGeometry
  • Equal() : sgObject::IFeature
  • Equals() : sgObject::ISpatialRelation
  • Evaluate() : sgObject::IFeatureQuery
  • Execute() : sgObject::IGridOperation
  • ExecuteSQL() : sgObject::ILayerSource
  • ExecuteSQLToString() : sgObject::ILayerSource
  • Export()
: sgObject::IFeatureLayer
, sgObject::ILayer
  • Exported() : sgObject::_IMap2DEvents
  • ExportImage()
: sgObject::ICanvas
, sgObject::IUserDefinedWidget
  • ExportImageToWorld() : sgObject::IMap2D
  • ExportLTM() : sgObject::IFeatureCollection
  • ExportScreenImage() : sgObject::IMap2D
  • ExportToClipboard() : sgObject::IMap2D
  • ExportToProj4() : sgObject::ISpatialReference
  • ExportToProj4AsString() : sgObject::ISpatialReferenceFactory
  • ExportToWKB() : sgObject::IWks
  • ExportToWkt() : sgObject::ISpatialReference
  • ExportToWKT() : sgObject::IWks
  • ExportToWKTAsString() : sgObject::ISpatialReferenceFactory
  • ExportToXMLAsString() : sgObject::ISpatialReferenceFactory
  • Extent2D()
: sgObject::ICoverage
, sgObject::IFeature
, sgObject::IGeometry
  • ExteriorRing() : sgObject::IPolygon
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
다음은 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버가 속해 있는 클래스에 대한 링크를 가지고 있습니다. :

- f -

  • Feature3DDeSelected()
: sgObject::_IMap3DEvents
, sgObject::_IMapAREvents
, sgObject::_IMapEarthEvents
  • Feature3DSelected()
: sgObject::_IMap3DEvents
, sgObject::_IMapAREvents
, sgObject::_IMapEarthEvents
  • FeatureDelete() : sgObject::_IFeatureCanvasEvents
  • FeatureDeleted() : sgObject::_IFeatureCanvasEvents
  • FeatureDeSelected() : sgObject::_IFeatureCanvasEvents
  • FeatureInsert() : sgObject::_IFeatureCanvasEvents
  • FeatureInserted() : sgObject::_IFeatureCanvasEvents
  • FeatureOut() : sgObject::_IMap2DEvents
  • FeatureOver() : sgObject::_IMap2DEvents
  • FeaturePreUpdate() : sgObject::_IFeatureCanvasEvents
  • FeatureSelected() : sgObject::_IFeatureCanvasEvents
  • FeaturesToPoint() : sgObject::IVectorAnalysis
  • FeatureStyle() : sgObject::IFeatureStyleCollection
  • FeatureUpdate() : sgObject::_IFeatureCanvasEvents
  • FeatureUpdated() : sgObject::_IFeatureCanvasEvents
  • FeatureVerticesToPoints() : sgObject::IVectorAnalysis
  • FillNodata() : sgObject::IGridGeneralizeOp
  • Fishnet() : sgObject::IVectorAnalysis
  • ForceStopRender()
: sgObject::ICanvas
, sgObject::IFeatureCanvas
  • Forward() : sgObject::IGeographicTransform
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
다음은 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버가 속해 있는 클래스에 대한 링크를 가지고 있습니다. :

- g -

  • Generalize() : sgObject::IVectorAnalysis
  • GeoCode() : sgObject::ILocationService
  • Geometry() : sgObject::IGeometryCollection
  • GetAbsolutePage() : sgObject::ILayer
  • GetAbstract()
: sgObject::ILayer
, sgObject::ISymbol
  • GetActive() : sgObject::IFeatureCanvas
  • GetAdjustmentHor() : sgObject::IFont
  • GetAdjustmentVert() : sgObject::IFont
  • GetAffectedCount() : sgObject::ILayerSource
  • GetAnchor() : sgObject::IFont
  • GetAngle()
: sgObject::IFill
, sgObject::IFont
, sgObject::IMark
  • GetAnnoLineAttribute() : sgObject::ILayer
  • GetAnnoLineVisibleAttribute() : sgObject::ILayer
  • GetAnnotation() : sgObject::IFeature
  • GetAnnotationLine() : sgObject::IFeature
  • GetAnnoVisibleAttribute() : sgObject::ILayer
  • GetAnnoXMLAttribute() : sgObject::ILayer
  • GetAntiAlias() : sgObject::IMap2D
  • GetApplication() : sgObject::IApplicationControl
  • GetArea()
: sgObject::IMultiSurface
, sgObject::ISurface
  • GetAttribute() : sgObject::IFeature
  • GetAttributeAsString()
: sgObject::IFeature
, sgObject::IFeatureQuery
  • GetAttributeAsStringByName() : sgObject::IFeature
  • GetAttributeToString() : sgObject::IFeature
  • GetAuthorityCode() : sgObject::ISpatialReference
  • GetAuthorityName() : sgObject::ISpatialReference
  • GetAutoScale() : sgObject::IMap2D
  • GetBackColor()
: sgObject::ICanvas
, sgObject::IFill
, sgObject::IFont
, sgObject::IWidget
  • GetBackgroundColor() : sgObject::IChart
  • GetBaudRate() : sgObject::ILocationSensor
  • GetBold() : sgObject::IFont
  • GetBool() : sgObject::IParameter
  • GetBoundingBox() : sgObject::ILayer
  • GetBounds() : sgObject::IFeature
  • GetBoxPaddingX() : sgObject::IFont
  • GetBoxPaddingY() : sgObject::IFont
  • GetCanMoveIndexMap() : sgObject::IIndexMapWidget
  • GetCanvas() : sgObject::IIndexMapWidget
  • GetCanvasType() : sgObject::ICanvas
  • GetCap() : sgObject::IStroke
  • GetCategory() : sgObject::ILayer
  • GetCategoryNames() : sgObject::IGridSampleDimension
  • GetCenter()
: sgObject::IGraphicArc
, sgObject::IGraphicRectangle
  • GetChartType() : sgObject::IChart
  • GetChildCount() : sgObject::IAggregateGraphic
  • GetChildElement() : sgObject::IXMLElements
  • GetChildLength() : sgObject::IXMLElements
  • GetColor()
: sgObject::IColorModel
, sgObject::IGridColorRampItem
, sgObject::IMark
, sgObject::IStroke
  • GetColorAsRGB() : sgObject::IColorModel
  • GetColorInterpretation() : sgObject::IGridSampleDimension
  • GetColorRamp() : sgObject::IColorRampList
  • GetColorRampByName() : sgObject::IColorRampList
  • GetColorRampList() : sgObject::ICommonFactory
  • GetColorTable() : sgObject::IGridSampleDimension
  • GetCommandText() : sgObject::IQueryCommand
  • GetCommonFactory()
: sgObject::IApplication
, sgObject::ICanvas
  • GetConfigOption() : sgObject::IUtility
  • GetConnectStringFromFileName() : sgObject::IFeatureCanvas
  • GetCoordinateSystem() : sgObject::ICoverage
  • GetCoverage() : sgObject::IGridCoverage
  • GetCRS() : sgObject::IGraphicScaledImage
  • GetCurve() : sgObject::ILineString
  • GetData()
: sgObject::IFeature
, sgObject::IQueryCommand
  • GetDataType() : sgObject::IFeatureAttributeDescriptor
  • GetDefaultValue() : sgObject::IParameterInfo
  • GetDefaultValueHeight() : sgObject::IGenerator3D
  • GetDefaultValueRadius() : sgObject::IGenerator3D
  • GetDefaultValueType() : sgObject::IGenerator3D
  • GetDefaultValueZ() : sgObject::IGenerator3D
  • GetDefaultViewpoint() : sgObject::IMap3DCamera
  • GetDescription()
: sgObject::IGridCoverage
, sgObject::IGridOperation
, sgObject::ILayerSource
, sgObject::ILayerSourceFactory
, sgObject::IParameterInfo
  • GetDiagram() : sgObject::ILayer
  • GetDimension() : sgObject::IGeometry
  • GetDisplayEditActionByType() : sgObject::IApplication
  • GetDisplayFactory() : sgObject::ICommonFactory
  • GetDisplayMenuBar()
: sgObject::IApplication
, sgObject::IPrintLayoutWidget
  • GetDisplayName()
: sgObject::ILayerSource
, sgObject::ILayerSourceFactory
  • GetDisplaySpatialReference() : sgObject::IFeatureCanvas
  • GetDisplayStatusBar() : sgObject::IApplication
  • GetDisplayToolBar()
: sgObject::IFeatureAttributeTreeWidget
, sgObject::ILayerTreeWidget
  • GetDisplayToolBarByType()
: sgObject::IApplication
, sgObject::IPrintLayoutWidget
  • GetDocURL() : sgObject::IGridOperation
  • GetDouble() : sgObject::IParameter
  • GetDriverType()
: sgObject::IFeatureLayer
, sgObject::ILayerSource
  • GetECap() : sgObject::IStroke
  • GetEditableAuth()
: sgObject::IFeatureAttributeDescriptor
, sgObject::ILayer
  • GetEffectFilter() : sgObject::IGridTypeStyle
  • GetElement() : sgObject::IXMLElements
  • GetElements() : sgObject::IXMLDoc
  • GetElseFilterFeatureStyle() : sgObject::IFeatureTypeStyle
  • GetElseFilterVisible() : sgObject::IFeatureTypeStyle
  • GetEncoding() : sgObject::IUtility
  • GetEnd() : sgObject::IGraphicArc
  • GetEnvelope() : sgObject::ICoverage
  • GetEPSGName() : sgObject::ISpatialReference
  • GetExteriorPoint() : sgObject::IGraphicPolygon
  • GetFeature()
: sgObject::IAnnotation
, sgObject::IAnnotationLabel
, sgObject::IFeatureCollection
  • GetFeatureAtPoint() : sgObject::IFeatureCanvas
  • GetFeatureCanvas()
: sgObject::ICanvas
, sgObject::IFeatureLayer
, sgObject::IMap2DControl
, sgObject::IMap3DControl
, sgObject::IMapARControl
, sgObject::IMapEarthControl
, sgObject::IWidget
  • GetFeatureCollection()
: sgObject::IAttributeIndex
, sgObject::IFeature
, sgObject::IFeatureLayer
  • GetFeatureColors() : sgObject::IChart
  • GetFeatureFields() : sgObject::IChart
  • GetFeatureFromFID() : sgObject::IFeatureCollection
  • GetFeatureInterface() : sgObject::IFeatureCollection
  • GetFeatureLables() : sgObject::IChart
  • GetFeatureLayer()
: sgObject::IFeatureCanvas
, sgObject::IFeatureCollection
, sgObject::ILayer
  • GetFeatureLayerByID() : sgObject::IFeatureCanvas
  • GetFeatureLayerByLayer() : sgObject::IFeatureCanvas
  • GetFeatureLayerByName() : sgObject::IFeatureCanvas
  • GetFeatures() : sgObject::IDockWidget
  • GetFeaturesAtPoint() : sgObject::IFeatureCanvas
  • GetFeatureStyle() : sgObject::IFeatureStyleCollection
  • GetFeatureType()
: sgObject::IFeature
, sgObject::ILayer
  • GetFeatureTypeStyle()
: sgObject::IFeatureTypeStyleRule
, sgObject::ILayer
  • GetFIDColumn() : sgObject::ILayer
  • GetFileName() : sgObject::IXMLDoc
  • GetFill() : sgObject::ISymbolizer
  • GetFillBrush() : sgObject::IMap2D
  • GetFilter() : sgObject::IFeatureTypeStyleRule
  • GetFlag() : sgObject::IWidget
  • GetFlashset() : sgObject::IFeatureCanvas
  • GetFlickerSelected() : sgObject::IMap2D
  • GetFloat() : sgObject::IParameter
  • GetFont() : sgObject::ISymbolizer
  • GetFontName()
: sgObject::IFont
, sgObject::IMark
  • GetForeColor()
: sgObject::IFill
, sgObject::IFont
  • GetGeometry()
: sgObject::IFeature
, sgObject::IPointSymbol
  • GetGeometryCollection()
: sgObject::IMultiCurve
, sgObject::IMultiPoint
, sgObject::IMultiPolygon
  • GetGeometryColumn() : sgObject::ILayer
  • GetGeometryType()
: sgObject::IFeatureType
, sgObject::IGeometry
  • GetGraphicsAt() : sgObject::IGraphicCanvas
  • GetGridAnalysis() : sgObject::IGridCoverage
  • GetGridColorType() : sgObject::IGridTypeStyle
  • GetGridCoverage()
: sgObject::IFeature
, sgObject::IGridSampleDimension
  • GetHasArbitraryOverviews() : sgObject::IGridSampleDimension
  • GetHeight()
: sgObject::IGraphicArc
, sgObject::IGraphicRectangle
  • GetHeightAttribute() : sgObject::IGenerator3D
  • GetHistogram() : sgObject::IGridAnalysis
  • GetHittestSize() : sgObject::ICanvas
  • GetHttpResult() : sgObject::IUtility
  • GetIcon()
: sgObject::ILayerSource
, sgObject::ILayerSourceFactory
  • GetID()
: sgObject::IFeature
, sgObject::IFill
, sgObject::IMark
, sgObject::IQueryCommand
, sgObject::IStroke
  • GetImage() : sgObject::IImageSymbol
  • GetIndex() : sgObject::IFeatureType
  • GetIndexMapAutoMove() : sgObject::IIndexMapWidget
  • GetIndexOfFeatureLayer() : sgObject::IFeatureCanvas
  • GetInt() : sgObject::IParameter
  • GetIntensity() : sgObject::IGraphicScaledImage
  • GetInteriorPoint() : sgObject::IGraphicPolygon
  • GetInterpretation() : sgObject::IColorModel
  • GetIsSeqKey() : sgObject::IFeatureAttributeDescriptor
  • GetItalic() : sgObject::IFont
  • GetItem() : sgObject::IPrintLayoutWidget
  • GetJoin() : sgObject::IStroke
  • GetLabel() : sgObject::IAnnotation
  • GetLabelExpression() : sgObject::ILayer
  • GetLabelMaxScaleDenominator() : sgObject::ILayer
  • GetLabelMinScaleDenominator() : sgObject::ILayer
  • GetLabelPosition() : sgObject::ILayer
  • GetLabelSize() : sgObject::IFeatureCollection
  • GetLabelText() : sgObject::ILayer
  • GetLastErrorMsg() : sgObject::IUtility
  • GetLatestValueToXML() : sgObject::ISensor
  • GetLayer()
: sgObject::IAnnotationLabel
, sgObject::IFeatureLayer
, sgObject::ILayerSource
  • GetLayerCount() : sgObject::ILayerSource
  • GetLayerID() : sgObject::ILayer
  • GetLayerSource() : sgObject::IFeatureLayer
  • GetLayerSourceFactory() : sgObject::ICommonFactory
  • GetLayerSourceFromFileName() : sgObject::IFeatureCanvas
  • GetLength()
: sgObject::ICurve
, sgObject::IMultiCurve
  • GetLineColor() : sgObject::IChart
  • GetLinePattern() : sgObject::IMark
  • GetLineString() : sgObject::ILinearRing
  • GetLocationSensor() : sgObject::ICommonFactory
  • GetLocationSensorType() : sgObject::ILocationSensor
  • GetLong() : sgObject::IParameter
  • GetLowerRight() : sgObject::IGraphicScaledImage
  • GetMagnifierPixelSize() : sgObject::IMap2D
  • GetMagnifierScale() : sgObject::IMap2D
  • GetMap2D() : sgObject::IMap2DControl
  • GetMap2DKeyFromWinKey() : sgObject::IUtility
  • GetMap3D() : sgObject::IMap3DControl
  • GetMap3DCamera()
: sgObject::IMap3D
, sgObject::IMapAR
, sgObject::IMapEarth
  • GetMap3DKeyFromQtKey() : sgObject::IUtility
  • GetMap3DLight()
: sgObject::IMap3D
, sgObject::IMapAR
, sgObject::IMapEarth
  • GetMapAR() : sgObject::IMapARControl
  • GetMapControl() : sgObject::ICanvas
  • GetMapControlRelativePos() : sgObject::IMap2D
  • GetMapControlShowType() : sgObject::IMap2D
  • GetMapEarth() : sgObject::IMapEarthControl
  • GetMapIdxColumn() : sgObject::ILayer
  • GetMapIdxLevel() : sgObject::ILayer
  • GetMapMoveMode() : sgObject::ICanvas
  • GetMapRotateMode() : sgObject::ICanvas
  • GetMark() : sgObject::ISymbolizer
  • GetMaximumOccurrences() : sgObject::IFeatureAttributeDescriptor
  • GetMaximumValue()
: sgObject::IGridSampleDimension
, sgObject::IGridTypeStyle
, sgObject::IParameterInfo
  • GetMaxScaleDenominator()
: sgObject::IFeatureTypeStyleRule
, sgObject::ILayer
, sgObject::ISymbolizer
  • GetMaxValue()
: sgObject::IGridAnalysis
, sgObject::IHistogram
  • GetMaxXBoundingBox() : sgObject::IMap2D
  • GetMaxXExtent2D() : sgObject::IFeature
  • GetMaxYBoundingBox() : sgObject::IMap2D
  • GetMaxYExtent2D() : sgObject::IFeature
  • GetMaxZoomScaleDenominator() : sgObject::IMap2D
  • GetMeanValue() : sgObject::IGridAnalysis
  • GetMeasureLineShowType() : sgObject::IMap2D
  • GetMeasureLineStd() : sgObject::IMap2D
  • GetMeasureLineStdLength() : sgObject::IMap2D
  • GetMeasureLineSubUnitNum() : sgObject::IMap2D
  • GetMeasureValue() : sgObject::IMap2D
  • GetMedianValue() : sgObject::IGridAnalysis
  • GetMetadataItemValue() : sgObject::IGridCoverage
  • GetMetadataValue() : sgObject::IGridCoverage
  • GetMinimumOccurrences() : sgObject::IFeatureAttributeDescriptor
  • GetMinimumValue()
: sgObject::IGridSampleDimension
, sgObject::IGridTypeStyle
, sgObject::IParameterInfo
  • GetMinMaxPitch() : sgObject::IMap3DCamera
  • GetMinScaleDenominator()
: sgObject::IFeatureTypeStyleRule
, sgObject::ILayer
, sgObject::ISymbolizer
  • GetMinValue()
: sgObject::IGridAnalysis
, sgObject::IHistogram
  • GetMinXBoundingBox() : sgObject::IMap2D
  • GetMinXExtent2D() : sgObject::IFeature
  • GetMinYBoundingBox() : sgObject::IMap2D
  • GetMinYExtent2D() : sgObject::IFeature
  • GetMinZoomScaleDenominator() : sgObject::IMap2D
  • GetModeValue() : sgObject::IGridAnalysis
  • GetModuleFilePath() : sgObject::IUtility
  • GetMotionSensor() : sgObject::ICommonFactory
  • GetMsgInString() : sgObject::IMessage
  • GetMultiCurve() : sgObject::IMultiCurve
  • GetMultiSurface() : sgObject::IMultiPolygon
  • GetMyIPAddress() : sgObject::IUtility
  • GetMyMacAddress() : sgObject::IUtility
  • GetName()
: sgObject::IColorRampList
, sgObject::IFeatureAttributeDescriptor
, sgObject::IFeatureType
, sgObject::IGridOperation
, sgObject::ILayer
, sgObject::IParameter
, sgObject::IParameterInfo
, sgObject::IQueryCommand
, sgObject::ISymbol
, sgObject::ISymbolizer
, sgObject::IXMLElements
  • GetNodataValue() : sgObject::IGridSampleDimension
  • GetNodeLayerEndIDColumn() : sgObject::ILayer
  • GetNodeLayerName() : sgObject::ILayer
  • GetNodeLayerStartIDColumn() : sgObject::ILayer
  • GetNumBucket() : sgObject::IHistogram
  • GetNumColor() : sgObject::IColorModel
  • GetNumColumn()
: sgObject::IGridCoverage
, sgObject::IGridSampleDimension
  • GetNumDataSeries() : sgObject::IChart
  • GetNumExteriorPoints() : sgObject::IGraphicPolygon
  • GetNumGeometries() : sgObject::IGeometryCollection
  • GetNumInteriorPoints() : sgObject::IGraphicPolygon
  • GetNumInteriorRings()
: sgObject::IGraphicPolygon
, sgObject::IPolygon
  • GetNumOperations() : sgObject::IGridCoverageProcessor
  • GetNumOverviews() : sgObject::IGridSampleDimension
  • GetNumParameters() : sgObject::IGridOperation
  • GetNumPoints() : sgObject::ILineString
  • GetNumRow()
: sgObject::IGridCoverage
, sgObject::IGridSampleDimension
  • GetNumSampleDimensions() : sgObject::ICoverage
  • GetNumSources() : sgObject::IGridOperation
  • GetObjectiveSpatialReference() : sgObject::ICanvas
  • GetOceanEnable() : sgObject::IMapEarth
  • GetOColor() : sgObject::IMark
  • GetOffset()
: sgObject::IGraphicIcon
, sgObject::IGridSampleDimension
, sgObject::IMark
  • GetOperation() : sgObject::IGridCoverageProcessor
  • GetOperationByName() : sgObject::IGridCoverageProcessor
  • GetOrder()
: sgObject::IAnnotationLabel
, sgObject::ILayer
  • GetOutlineColor()
: sgObject::IFont
, sgObject::IStroke
  • GetOutlineWidth()
: sgObject::IFont
, sgObject::IStroke
  • GetOverlapLabel() : sgObject::IMap2D
  • GetOverview() : sgObject::IGridSampleDimension
  • GetPageSize() : sgObject::ILayer
  • GetParameter() : sgObject::IParameters
  • GetParameterInfo() : sgObject::IGridOperation
  • GetParameters() : sgObject::ILayer
  • GetParent() : sgObject::IParameter
  • GetParentElement() : sgObject::IXMLElements
  • GetPathType() : sgObject::IGraphicPolygon
  • GetPattern() : sgObject::IStroke
  • GetPerp()
: sgObject::IFont
, sgObject::IMark
  • GetPixelUnit() : sgObject::IGridCoverage
  • GetPlacement() : sgObject::IFont
  • GetPoint() : sgObject::ILineString
  • GetPointOnSurface() : sgObject::IMap2D
  • GetPortNumber() : sgObject::ILocationSensor
  • GetPosition()
: sgObject::IGraphicIcon
, sgObject::IGraphicLabel
, sgObject::IUserDefinedWidget
  • GetPrecision() : sgObject::IFeatureAttributeDescriptor
  • GetPreferredPrefix() : sgObject::IFeatureType
  • GetPriority()
: sgObject::IFill
, sgObject::IFont
, sgObject::IMark
, sgObject::IStroke
  • GetQueryString() : sgObject::IMessage
  • GetRadiusAttribute() : sgObject::IGenerator3D
  • GetRatioZoomScale() : sgObject::IMap2D
  • GetReferField() : sgObject::IFeatureAttributeDescriptor
  • GetReferFieldName() : sgObject::IFeatureAttributeDescriptor
  • GetReferGeometryLayerName() : sgObject::ILayer
  • GetReferLayer() : sgObject::IFeatureAttributeDescriptor
  • GetReferLayerName() : sgObject::IFeatureAttributeDescriptor
  • GetRelatedFeature() : sgObject::IQueryCommand
  • GetRelateX() : sgObject::IUserDefinedWidget
  • GetRelateY() : sgObject::IUserDefinedWidget
  • GetRotate() : sgObject::IMap2D
  • GetRoundX() : sgObject::IGraphicRectangle
  • GetRoundY() : sgObject::IGraphicRectangle
  • GetRule() : sgObject::IFeatureTypeStyle
  • GetSampleDimension() : sgObject::ICoverage
  • GetSampleDimensionType() : sgObject::IGridSampleDimension
  • GetScale()
: sgObject::IGridSampleDimension
, sgObject::IMap2D
  • GetScaleBarRelativePos() : sgObject::IMap2D
  • GetScaleBarShowType() : sgObject::IMap2D
  • GetScalePrecision() : sgObject::IMap2D
  • GetScaleRatio() : sgObject::IIndexMapWidget
  • GetSCap() : sgObject::IStroke
  • GetScreenMode()
: sgObject::IMap2D
, sgObject::IMapEarth
  • GetSelectable() : sgObject::ILayer
  • GetSelected() : sgObject::IFeature
  • GetSelection() : sgObject::IFeatureCanvas
  • GetSelectMode() : sgObject::IMap2D
  • GetShadeColor() : sgObject::IGridTypeStyle
  • GetShadeColorInterpretation() : sgObject::IGridTypeStyle
  • GetShadeColorInterpretationByOrder() : sgObject::IGridTypeStyle
  • GetShadeColorInterpretationSize() : sgObject::IGridTypeStyle
  • GetShadeIndexByColorInterpretation() : sgObject::IGridTypeStyle
  • GetShadeIndexByOrder() : sgObject::IGridTypeStyle
  • GetShadePaletteInterpretation() : sgObject::IGridTypeStyle
  • GetShadowColor() : sgObject::IFont
  • GetShadowEnable() : sgObject::IMapEarth
  • GetShadowSpacingX() : sgObject::IFont
  • GetShadowSpacingY() : sgObject::IFont
  • GetShadowWidth() : sgObject::IFont
  • GetShort() : sgObject::IParameter
  • GetShortLabelExpression() : sgObject::ILayer
  • GetSightMode() : sgObject::IMapEarth
  • GetSize()
: sgObject::IAnnotation
, sgObject::IColorRampList
, sgObject::IFeatureAttributeDescriptor
, sgObject::IFeatureCanvas
, sgObject::IFeatureCollection
, sgObject::IFeatureStyleCollection
, sgObject::IFeatureType
, sgObject::IFeatureTypeStyle
, sgObject::IFill
, sgObject::IFont
, sgObject::ILayerSource
, sgObject::IMark
, sgObject::IParameters
, sgObject::IQueryCommands
  • GetSkyDateTime() : sgObject::IMapEarth
  • GetSmallPixelSize() : sgObject::IMap2D
  • GetSnapGrid() : sgObject::IMap2D
  • GetSnapMode() : sgObject::IMap2D
  • GetSourceCS() : sgObject::IGeographicTransform
  • GetSpacingX()
: sgObject::IFill
, sgObject::IFont
, sgObject::IMark
  • GetSpacingY()
: sgObject::IFill
, sgObject::IFont
, sgObject::IMark
  • GetSpatialOperator() : sgObject::IGeometry
  • GetSpatialReference()
: sgObject::IGeometry
, sgObject::ILayer
, sgObject::ILocationService
  • GetSpatialRelation() : sgObject::IGeometry
  • GetSpatialRelation2() : sgObject::IGeometry
  • GetStandardDeviation()
: sgObject::IGridAnalysis
, sgObject::IGridTypeStyle
  • GetStart() : sgObject::IGraphicArc
  • GetState() : sgObject::ICanvas
  • GetStatistics() : sgObject::IGridSampleDimension
  • GetStep() : sgObject::IMark
  • GetStretch() : sgObject::IFont
  • GetStrikeout() : sgObject::IFont
  • GetString() : sgObject::IParameter
  • GetStroke() : sgObject::ISymbolizer
  • GetStyleAttribute() : sgObject::ILayer
  • GetStyleString()
: sgObject::IFill
, sgObject::IFont
, sgObject::IMark
, sgObject::IStroke
  • GetStyleToString() : sgObject::ISymbolizer
  • GetStyleType() : sgObject::IFeatureTypeStyle
  • GetSurface() : sgObject::IPolygon
  • GetSurfaceVolumeFromGridCoverage() : sgObject::IUtility
  • GetSymbolizer()
: sgObject::IFeature
, sgObject::IFeatureTypeStyleRule
, sgObject::ILayer
  • GetSymbolizer3D() : sgObject::ILayer
  • GetSymbolizerType() : sgObject::ISymbolizer
  • GetSymbolType() : sgObject::ISymbol
  • GetSyncMoveMode() : sgObject::IMap2D
  • GetSystemLayerSource() : sgObject::ICommonFactory
  • GetTargetCS() : sgObject::IGeographicTransform
  • GetText()
: sgObject::IAnnotationLabel
, sgObject::IGraphicLabel
  • GetTextAngle()
: sgObject::IFont
, sgObject::IMark
  • GetTextSize() : sgObject::IGraphicLabel
  • GetTextString() : sgObject::IFont
  • GetTitle()
: sgObject::IApplication
, sgObject::ICanvas
, sgObject::IFeatureAttributeDescriptor
, sgObject::IFeatureTypeStyleRule
, sgObject::ILayer
, sgObject::ISymbol
  • GetToolTipExpression() : sgObject::ILayer
  • GetTopGraphicAt() : sgObject::IGraphicCanvas
  • GetTransaction()
: sgObject::IFeatureCanvas
, sgObject::IFeatureCollection
  • GetTransparency() : sgObject::IGraphicScaledImage
  • GetTransparent()
: sgObject::IChart
, sgObject::IImageSymbol
  • GetTransparentBackColor() : sgObject::IMap2D
  • GetType()
: sgObject::IParameter
, sgObject::IParameterInfo
  • GetTypeAttribute() : sgObject::IGenerator3D
  • GetUnderline() : sgObject::IFont
  • GetUnits() : sgObject::IGridSampleDimension
  • GetUpperLeft() : sgObject::IGraphicScaledImage
  • GetUseDrawThread() : sgObject::IMap2D
  • GetUser() : sgObject::IGPDLayerSource
  • GetUserDefinedWidget() : sgObject::IFeature
  • GetUserSize() : sgObject::IGPDLayerSource
  • GetValidValue() : sgObject::IFeatureAttributeDescriptor
  • GetValidValueSize() : sgObject::IFeatureAttributeDescriptor
  • GetValue()
: sgObject::IGridColorRampItem
, sgObject::IGridSampleDimension
, sgObject::IParameter
, sgObject::IXMLElements
  • GetValueAlias() : sgObject::IFeatureAttributeValidValue
  • GetValueExpression() : sgObject::IFeatureAttributeValidValue
  • GetValueFromCoordinate() : sgObject::IGridSampleDimension
  • GetValueKeyValue() : sgObject::IFeatureAttributeValidValue
  • GetVectorAnalysis() : sgObject::IFeatureCollection
  • GetVendor() : sgObject::IGridOperation
  • GetVersion()
: sgObject::IGridOperation
, sgObject::IUtility
  • GetVideoSensor() : sgObject::ICommonFactory
  • GetViewpoint() : sgObject::IMap3DCamera
  • GetVisible()
: sgObject::IFeature
, sgObject::IFeatureTypeStyleRule
, sgObject::ILayer
  • GetVisibleAnnotation() : sgObject::IFeature
  • GetVisibleAnnotationLine() : sgObject::IFeature
  • GetVisibleAuth()
: sgObject::IFeatureAttributeDescriptor
, sgObject::ILayer
  • GetVisibleMagnifier() : sgObject::IMap2D
  • GetVisibleSmallGeometry() : sgObject::IMap2D
  • GetVisibleUserDefinedWidget() : sgObject::IFeature
  • GetWellKnownText() : sgObject::ISpatialReferenceInfo
  • GetWidth()
: sgObject::IGraphicArc
, sgObject::IGraphicRectangle
, sgObject::IStroke
  • GetWks() : sgObject::IGeometry
  • GetWorkspace() : sgObject::IFeatureCanvas
  • GetX()
: sgObject::ILineString
, sgObject::IPoint
  • GetXAnchor() : sgObject::IGraphicLabel
  • GetXDeviceToWorld() : sgObject::IMap2D
  • GetXWorldToDevice() : sgObject::IMap2D
  • GetY()
: sgObject::ILineString
, sgObject::IPoint
  • GetYAnchor() : sgObject::IGraphicLabel
  • GetYDeviceToWorld() : sgObject::IMap2D
  • GetYWorldToDevice() : sgObject::IMap2D
  • GetZ() : sgObject::IPointZ
  • GetZAttribute() : sgObject::IGenerator3D
  • Group() : sgObject::IVectorAnalysis
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
다음은 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버가 속해 있는 클래스에 대한 링크를 가지고 있습니다. :

- h -

  • HausdorffDistance() : sgObject::ISpatialOperator
  • HausdorffDistanceDensify() : sgObject::ISpatialOperator
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
다음은 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버가 속해 있는 클래스에 대한 링크를 가지고 있습니다. :

- i -

  • ImportFromProj4() : sgObject::ISpatialReference
  • ImportFromWKB() : sgObject::IWks
  • ImportFromWkt() : sgObject::ISpatialReference
  • ImportFromWKT() : sgObject::IWks
  • IndexOfSelectedItem()
: sgObject::IFeatureAttributeTreeWidget
, sgObject::ILayerTreeWidget
  • InitDataset() : sgObject::IChart
  • Initialize()
: sgObject::ICanvas
, sgObject::INetworkCoverageAnalysis
, sgObject::IWidget
  • InsertExteriorPoint() : sgObject::IGraphicPolygon
  • InsertInteriorPoint() : sgObject::IGraphicPolygon
  • InsertPoint() : sgObject::IGraphicLineString
  • InteriorRing() : sgObject::IPolygon
  • Interpolate() : sgObject::ISpatialOperator
  • InterpolateNormalized() : sgObject::ISpatialOperator
  • IntersectGeometry() : sgObject::IVectorAnalysis
  • Intersection() : sgObject::ISpatialOperator
  • Intersects() : sgObject::ISpatialRelation
  • Invalidate()
: sgObject::ICanvas
, sgObject::IFeatureCanvas
, sgObject::IPrintLayoutWidget
  • Inverse() : sgObject::IGeographicTransform
  • IsAllowingExtentsChang()
: sgObject::IGraphicArc
, sgObject::IGraphicRectangle
  • IsAllowingNewVertices() : sgObject::IGraphicPolygon
  • IsAllowingRotation() : sgObject::IGraphicRectangle
  • IsAvailable() : sgObject::ILayerSourceFactory
  • IsChild() : sgObject::IXMLElements
  • IsCircle() : sgObject::IGraphicArc
  • IsClosed()
: sgObject::ICurve
, sgObject::IGraphicLineString
, sgObject::IMultiCurve
  • IsClosedEllipse() : sgObject::IGraphicArc
  • IsConfigured() : sgObject::IUtility
  • IsEmpty()
: sgObject::IFeatureCollection
, sgObject::IGeometry
  • IsEqual() : sgObject::IChart
  • IsExteriorHandle() : sgObject::IUserDefinedWidget
  • IsNullable() : sgObject::IFeatureAttributeDescriptor
  • IsPointInRing() : sgObject::ILinearRing
  • IsPointOnRingBoundary() : sgObject::ILinearRing
  • IsPointOnSurface() : sgObject::IPolygon
  • IsRefer() : sgObject::IFeatureCollection
  • IsSame() : sgObject::ISpatialReference
  • IsServiceRunning() : sgObject::ISensor
  • IsSimple() : sgObject::IGeometry
  • IsSystemField() : sgObject::ILayer
  • IsUsableSearch() : sgObject::INetworkCoverageAnalysis
  • IsValid() : sgObject::IFeatureAttributeValidValue
  • IsValidFilter() : sgObject::IFeatureTypeStyleRule
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
다음은 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버가 속해 있는 클래스에 대한 링크를 가지고 있습니다. :

- k -

  • KeyDown()
: sgObject::IApplication
, sgObject::ICanvas
  • KeyUp() : sgObject::ICanvas
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
다음은 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버가 속해 있는 클래스에 대한 링크를 가지고 있습니다. :

- l -

  • LayerActivated() : sgObject::_IFeatureCanvasEvents
  • LayerAdded() : sgObject::_IFeatureCanvasEvents
  • LayerAnnotationChanged() : sgObject::_IFeatureCanvasEvents
  • LayerAttributeChange() : sgObject::_IFeatureCanvasEvents
  • LayerAttributeChanged() : sgObject::_IFeatureCanvasEvents
  • LayerDelete() : sgObject::_IFeatureCanvasEvents
  • LayerDeleted() : sgObject::_IFeatureCanvasEvents
  • LayerDisplayNameChanged() : sgObject::_IFeatureCanvasEvents
  • LayerEditableChanged() : sgObject::_IFeatureCanvasEvents
  • LayerExported() : sgObject::_IFeatureCanvasEvents
  • LayerOrderChanged() : sgObject::_IFeatureCanvasEvents
  • LayerSelectableChanged() : sgObject::_IFeatureCanvasEvents
  • LayerStyleChanged() : sgObject::_IFeatureCanvasEvents
  • LayerTypeStyleChanged() : sgObject::_IFeatureCanvasEvents
  • LayerVisibleChanged() : sgObject::_IFeatureCanvasEvents
  • LButtonDown() : sgObject::ICanvas
  • LButtonUp() : sgObject::ICanvas
  • LineMerge() : sgObject::ISpatialOperator
  • LineToPolygon() : sgObject::IVectorAnalysis
  • LongClick()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
다음은 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버가 속해 있는 클래스에 대한 링크를 가지고 있습니다. :

- m -

  • MakeTiles() : sgObject::IGridGeneralizeOp
  • MapControlChanged() : sgObject::_IMap2DEvents
  • MapExtendChange()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • MapExtendChanged()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • MapMove()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • MapMoved()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • MapReSized()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • MapTiles() : sgObject::IGridGeneralizeOp
  • MButtonDown() : sgObject::ICanvas
  • MButtonUp() : sgObject::ICanvas
  • Merge()
: sgObject::IGridGeneralizeOp
, sgObject::IVectorAnalysis
  • MouseMove() : sgObject::ICanvas
  • Move() : sgObject::IPrintLayoutItem
  • MoveAngle()
: sgObject::ISpatialOperator
, sgObject::IVectorAnalysis
  • MoveDistance()
: sgObject::ISpatialOperator
, sgObject::IVectorAnalysis
  • MoveFirst()
: sgObject::IFeatureCollection
, sgObject::IFeatureStyleCollection
, sgObject::IXMLElements
  • MoveLast() : sgObject::IFeatureCollection
  • MoveNext()
: sgObject::IFeatureCollection
, sgObject::IFeatureStyleCollection
, sgObject::IXMLElements
  • MovePrevious()
: sgObject::IFeatureCollection
, sgObject::IFeatureStyleCollection
  • MoveTo() : sgObject::IFeatureCanvas
  • MultipartToSinglepart() : sgObject::IVectorAnalysis
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
다음은 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버가 속해 있는 클래스에 대한 링크를 가지고 있습니다. :

- n -

  • NearBlack() : sgObject::IGridGeneralizeOp
  • NearestName() : sgObject::ILocationService
  • NearestPoint()
: sgObject::ILocationService
, sgObject::ISpatialOperator
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
다음은 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버가 속해 있는 클래스에 대한 링크를 가지고 있습니다. :

- o -

  • Open() : sgObject::IXMLDoc
  • OpenXML() : sgObject::IXMLDoc
  • Overlaps() : sgObject::ISpatialRelation
  • Overview() : sgObject::IGridGeneralizeOp
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
다음은 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버가 속해 있는 클래스에 대한 링크를 가지고 있습니다. :

- p -

  • Paint() : sgObject::_IMap2DEvents
  • Paste() : sgObject::IFeatureCanvas
  • PointOnSurface()
: sgObject::IMultiSurface
, sgObject::ISurface
  • PolygonGeneralize() : sgObject::IVectorAnalysis
  • Polygonize() : sgObject::IGridGeneralizeOp
  • PolygonToLine() : sgObject::IVectorAnalysis
  • PreCommit() : sgObject::_IFeatureCanvasEvents
  • PreUndo() : sgObject::_IFeatureCanvasEvents
  • Printed()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • Project()
: sgObject::IGeometry
, sgObject::IVectorAnalysis
  • ProjectFromCRS() : sgObject::IUtility
  • ProjectFromText() : sgObject::IUtility
  • ProjectMGRS() : sgObject::IUtility
  • ProjectToMGRS() : sgObject::IUtility
  • ProjectWorldMapPoint() : sgObject::IUtility
  • ProviderDisabled() : sgObject::_ILocationSensorEvents
  • ProviderEnabled() : sgObject::_ILocationSensorEvents
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
다음은 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버가 속해 있는 클래스에 대한 링크를 가지고 있습니다. :

- r -

  • Rasterize() : sgObject::IGridGeneralizeOp
  • RasterPixelToWorld() : sgObject::IMap2D
  • RButtonDown() : sgObject::ICanvas
  • RButtonUp() : sgObject::ICanvas
  • ReadWorkspace() : sgObject::IFeatureCanvas
  • ReadXML() : sgObject::IPrintLayoutWidget
  • ReCalculateExtent()
: sgObject::IFeature
, sgObject::IFeatureCanvas
, sgObject::IFeatureCollection
  • Refresh() : sgObject::IFeatureLayer
  • Relate() : sgObject::ISpatialRelation2
  • Remove()
: sgObject::IAnnotation
, sgObject::IAttributeIndex
, sgObject::IFeatureCollection
, sgObject::IFeatureStyleCollection
, sgObject::IFeatureType
, sgObject::IGraphicCanvas
, sgObject::IQueryCommands
  • RemoveAll()
: sgObject::IAnnotation
, sgObject::IFeatureCollection
, sgObject::IFeatureTypeStyle
, sgObject::IQueryCommands
  • RemoveAllControl() : sgObject::ICanvas
  • RemoveAttribute() : sgObject::IFeatureLayer
  • RemoveChild() : sgObject::IAggregateGraphic
  • RemoveChildren() : sgObject::IAggregateGraphic
  • RemoveColorRamp() : sgObject::IColorRampList
  • RemoveControl() : sgObject::ICanvas
  • RemoveEffectFilter() : sgObject::IGridTypeStyle
  • RemoveElement() : sgObject::IXMLElements
  • RemoveExteriorPoint() : sgObject::IGraphicPolygon
  • RemoveFromIndex() : sgObject::IAttributeIndex
  • RemoveFromKey() : sgObject::IGraphicCanvas
  • RemoveHoles() : sgObject::IVectorAnalysis
  • RemoveInteriorPoint() : sgObject::IGraphicPolygon
  • RemoveInteriorRing() : sgObject::IGraphicPolygon
  • RemovePoint() : sgObject::ILineString
  • RemoveRule() : sgObject::IFeatureTypeStyle
  • RemoveSensor() : sgObject::ICanvas
  • RemoveStyle() : sgObject::ISymbolizer
  • RemoveSymbol() : sgObject::IFeatureCanvas
  • RemoveUser() : sgObject::IGPDLayerSource
  • RenameLayer() : sgObject::ILayerSource
  • RepairGeometry() : sgObject::IVectorAnalysis
  • ReplaceChild() : sgObject::IAggregateGraphic
  • Resample() : sgObject::IGridGeneralizeOp
  • ReSize()
: sgObject::ICanvas
, sgObject::IWidget
  • RetainAll() : sgObject::IFeatureCollection
  • RevGeoCode() : sgObject::ILocationService
  • RightClick()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • Rollback() : sgObject::IDefaultTransaction
  • Rotate()
: sgObject::ISpatialOperator
, sgObject::IVectorAnalysis
  • RouteDetermine() : sgObject::ILocationService
  • RunScript() : sgObject::IApplication
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
다음은 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버가 속해 있는 클래스에 대한 링크를 가지고 있습니다. :

- s -

  • Satellite() : sgObject::_ILocationSensorEvents
  • Save() : sgObject::IXMLDoc
  • Scale()
: sgObject::ISpatialOperator
, sgObject::IVectorAnalysis
  • ScreenModeChanged()
: sgObject::_IMap2DEvents
, sgObject::_IMap3DEvents
, sgObject::_IMapEarthEvents
  • Search() : sgObject::INetworkCoverageAnalysis
  • SelectCompile() : sgObject::IFeatureQuery
  • SelectModeChanged() : sgObject::_IMap2DEvents
  • SendActionEvent() : sgObject::IApplication
  • SensingValueChanged() : sgObject::_ILocationSensorEvents
  • SensorAdded()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • SensorRemoved()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • SetAbstract() : sgObject::ILayer
  • SetActive() : sgObject::IFeatureCanvas
  • SetAdjustmentHor() : sgObject::IFont
  • SetAdjustmentVert() : sgObject::IFont
  • SetAllowedAreas() : sgObject::IDockWidget
  • SetAllowingExtentsChang()
: sgObject::IGraphicArc
, sgObject::IGraphicRectangle
  • SetAllowingNewVertices() : sgObject::IGraphicPolygon
  • SetAllowingRotation() : sgObject::IGraphicRectangle
  • SetAnchor() : sgObject::IFont
  • SetAngle()
: sgObject::IFill
, sgObject::IFont
, sgObject::IMark
  • SetAnnoLineAttribute() : sgObject::ILayer
  • SetAnnoLineVisibleAttribute() : sgObject::ILayer
  • SetAnnotation() : sgObject::IFeature
  • SetAnnotationLine() : sgObject::IFeature
  • SetAnnoVisibleAttribute() : sgObject::ILayer
  • SetAnnoXMLAttribute() : sgObject::ILayer
  • SetAntiAlias() : sgObject::IMap2D
  • SetAttribute()
: sgObject::IFeature
, sgObject::IFeatureLayer
, sgObject::IFeatureType
  • SetAttributeFilter() : sgObject::ILayer
  • SetAuthority() : sgObject::ISpatialReference
  • SetAutoScale() : sgObject::IMap2D
  • SetBackColor()
: sgObject::ICanvas
, sgObject::IFill
, sgObject::IFont
, sgObject::IWidget
  • SetBackgroundColor() : sgObject::IChart
  • SetBold() : sgObject::IFont
  • SetBool() : sgObject::IParameter
  • SetBoxPaddingX() : sgObject::IFont
  • SetBoxPaddingY() : sgObject::IFont
  • SetCanMoveIndexMap() : sgObject::IIndexMapWidget
  • SetCanvas()
: sgObject::IDockWidget
, sgObject::IWidget
  • SetCap() : sgObject::IStroke
  • SetCategory() : sgObject::ILayer
  • SetCategoryNames() : sgObject::IGridSampleDimension
  • SetCenter()
: sgObject::IGraphicArc
, sgObject::IGraphicRectangle
  • SetChartType() : sgObject::IChart
  • SetColor()
: sgObject::IColorModel
, sgObject::IGridColorRampItem
, sgObject::IMark
, sgObject::IStroke
  • SetColorInterpretation() : sgObject::IGridSampleDimension
  • SetColorTable() : sgObject::IGridSampleDimension
  • SetCommandText() : sgObject::IQueryCommand
  • SetConfigOption() : sgObject::IUtility
  • SetConfigured() : sgObject::IUtility
  • SetCRS() : sgObject::IGraphicScaledImage
  • SetData()
: sgObject::IFeature
, sgObject::IQueryCommand
  • SetDataSeries() : sgObject::IChart
  • SetDataSeriesFromString() : sgObject::IChart
  • SetDataType() : sgObject::IFeatureAttributeDescriptor
  • SetDebug() : sgObject::IUtility
  • SetDefaultValueHeight() : sgObject::IGenerator3D
  • SetDefaultValueRadius() : sgObject::IGenerator3D
  • SetDefaultValueType() : sgObject::IGenerator3D
  • SetDefaultValueZ() : sgObject::IGenerator3D
  • SetDefaultViewpoint() : sgObject::IMap3DCamera
  • SetDescription()
: sgObject::IGridCoverage
, sgObject::ILayerSource
, sgObject::ILayerSourceFactory
  • SetDiagram() : sgObject::ILayer
  • SetDisplayContextMenu()
: sgObject::IFeatureAttributeTreeWidget
, sgObject::ILayerTreeWidget
  • SetDisplayEditActionByType() : sgObject::IApplication
  • SetDisplayMenuBar()
: sgObject::IApplication
, sgObject::IPrintLayoutWidget
  • SetDisplayName()
: sgObject::ILayerSource
, sgObject::ILayerSourceFactory
  • SetDisplayProperyWidget() : sgObject::IPrintLayoutWidget
  • SetDisplaySpatialReference() : sgObject::IFeatureCanvas
  • SetDisplayStatusBar() : sgObject::IApplication
  • SetDisplayToolBar()
: sgObject::IApplication
, sgObject::IFeatureAttributeTreeWidget
, sgObject::ILayerTreeWidget
, sgObject::IPrintLayoutWidget
  • SetDisplayToolBarByType()
: sgObject::IApplication
, sgObject::IPrintLayoutWidget
  • SetDouble() : sgObject::IParameter
  • SetDrawProgressEnable() : sgObject::IMap2D
  • SetECap() : sgObject::IStroke
  • SetEditableAuth()
: sgObject::IFeatureAttributeDescriptor
, sgObject::ILayer
  • SetEffectFilter() : sgObject::IGridTypeStyle
  • SetElement() : sgObject::IXMLElements
  • SetElements() : sgObject::IXMLDoc
  • SetElseFilterFeatureStyle() : sgObject::IFeatureTypeStyle
  • SetElseFilterVisible() : sgObject::IFeatureTypeStyle
  • SetEmpty() : sgObject::IGeometry
  • SetEncoding() : sgObject::IUtility
  • SetEnd() : sgObject::IGraphicArc
  • SetExteriorHandle() : sgObject::IUserDefinedWidget
  • SetExteriorPoint() : sgObject::IGraphicPolygon
  • SetFeature()
: sgObject::IAnnotation
, sgObject::IFeatureCollection
  • SetFeatureCanvas()
: sgObject::ICanvas
, sgObject::IWidget
  • SetFeatureCollection()
: sgObject::IAttributeIndex
, sgObject::IFeatureLayer
  • SetFeatureColors() : sgObject::IChart
  • SetFeatureFields() : sgObject::IChart
  • SetFeatureLables() : sgObject::IChart
  • SetFeatureLayer() : sgObject::IWidget
  • SetFeatures() : sgObject::IDockWidget
  • SetFeatureStyleColor() : sgObject::IFeatureTypeStyleRule
  • SetFeatureType() : sgObject::ILayer
  • SetFeatureTypeStyle() : sgObject::ILayer
  • SetFileName() : sgObject::IXMLDoc
  • SetFill() : sgObject::ISymbolizer
  • SetFillBrush() : sgObject::IMap2D
  • SetFilter() : sgObject::IFeatureTypeStyleRule
  • SetFlag() : sgObject::IWidget
  • SetFlickerSelected() : sgObject::IMap2D
  • SetFloat() : sgObject::IParameter
  • SetFont() : sgObject::ISymbolizer
  • SetFontName()
: sgObject::IFont
, sgObject::IMark
  • SetForeColor()
: sgObject::IFill
, sgObject::IFont
  • SetFromUserInput() : sgObject::ISpatialReference
  • SetGeometry()
: sgObject::IFeature
, sgObject::IPointSymbol
  • SetGeometryType() : sgObject::IFeatureType
  • SetGridColorType() : sgObject::IGridTypeStyle
  • SetHeight()
: sgObject::IGraphicArc
, sgObject::IGraphicRectangle
, sgObject::IWidget
  • SetHeightAttribute() : sgObject::IGenerator3D
  • SetHittestSize() : sgObject::ICanvas
  • SetIcon()
: sgObject::ILayerSource
, sgObject::ILayerSourceFactory
  • SetIconFromString() : sgObject::IGraphicIcon
  • SetID()
: sgObject::IFeature
, sgObject::IFill
, sgObject::IMark
, sgObject::IQueryCommand
, sgObject::IStroke
  • SetImage() : sgObject::IImageSymbol
  • SetImageFile() : sgObject::IPrintLayoutItem
  • SetIndexMapAutoMove() : sgObject::IIndexMapWidget
  • SetInt() : sgObject::IParameter
  • SetIntensity() : sgObject::IGraphicScaledImage
  • SetInteriorPoint() : sgObject::IGraphicPolygon
  • SetIsSeqKey() : sgObject::IFeatureAttributeDescriptor
  • SetItalic() : sgObject::IFont
  • SetJoin() : sgObject::IStroke
  • SetKeyEnable()
: sgObject::IMap2D
, sgObject::IPrintLayoutWidget
  • SetLabelExpression() : sgObject::ILayer
  • SetLabelMaxScaleDenominator() : sgObject::ILayer
  • SetLabelMinScaleDenominator() : sgObject::ILayer
  • SetLabelPosition() : sgObject::ILayer
  • SetLayer()
: sgObject::IAnnotationLabel
, sgObject::IWidget
  • SetLayerOrder() : sgObject::ILayer
  • SetLineColor() : sgObject::IChart
  • SetLinePattern() : sgObject::IMark
  • SetLocationSensor() : sgObject::ICanvas
  • SetLocationSensorType() : sgObject::ILocationSensor
  • SetLong() : sgObject::IParameter
  • SetLowerRight() : sgObject::IGraphicScaledImage
  • SetMagnifierPixelSize() : sgObject::IMap2D
  • SetMagnifierScale() : sgObject::IMap2D
  • SetMapCenter() : sgObject::IPrintLayoutItem
  • SetMapControl() : sgObject::ICanvas
  • SetMapControlImageFromFileName() : sgObject::IMap2D
  • SetMapControlRelativePos() : sgObject::IMap2D
  • SetMapControlShowType() : sgObject::IMap2D
  • SetMapIdxColumn() : sgObject::ILayer
  • SetMapIdxLevel() : sgObject::ILayer
  • SetMapIndexPrintOption() : sgObject::IPrintLayoutItem
  • SetMapMoveMode() : sgObject::ICanvas
  • SetMapRect() : sgObject::IPrintLayoutItem
  • SetMapRelativeScale() : sgObject::IPrintLayoutItem
  • SetMapRotateMode() : sgObject::ICanvas
  • SetMapRotation() : sgObject::IPrintLayoutItem
  • SetMapScale() : sgObject::IPrintLayoutItem
  • SetMark() : sgObject::ISymbolizer
  • SetMaximumOccurrences() : sgObject::IFeatureAttributeDescriptor
  • SetMaximumValue() : sgObject::IGridTypeStyle
  • SetMaxScaleDenominator()
: sgObject::IFeatureTypeStyleRule
, sgObject::ILayer
, sgObject::ISymbolizer
  • SetMaxZoomScaleDenominator() : sgObject::IMap2D
  • SetMeasureLineShowType() : sgObject::IMap2D
  • SetMeasureLineStd() : sgObject::IMap2D
  • SetMeasureLineStdLength() : sgObject::IMap2D
  • SetMeasureLineSubUnitNum() : sgObject::IMap2D
  • SetMessageFile() : sgObject::IMessage
  • SetMetadataItemValue() : sgObject::IGridCoverage
  • SetMetadataValue() : sgObject::IGridCoverage
  • SetMinimumOccurrences() : sgObject::IFeatureAttributeDescriptor
  • SetMinimumValue() : sgObject::IGridTypeStyle
  • SetMinMaxPitch() : sgObject::IMap3DCamera
  • SetMinScaleDenominator()
: sgObject::IFeatureTypeStyleRule
, sgObject::ILayer
, sgObject::ISymbolizer
  • SetMinZoomScaleDenominator() : sgObject::IMap2D
  • SetMotionSensor() : sgObject::ICanvas
  • SetMouseButtonEnable()
: sgObject::IMap2D
, sgObject::IPrintLayoutWidget
  • SetMouseCursor() : sgObject::IMap2D
  • SetName()
: sgObject::IFeatureAttributeDescriptor
, sgObject::IFeatureType
, sgObject::ILayer
, sgObject::IParameter
, sgObject::IQueryCommand
, sgObject::ISymbolizer
  • SetNodataValue() : sgObject::IGridSampleDimension
  • SetNodeLayerEndIDColumn() : sgObject::ILayer
  • SetNodeLayerName() : sgObject::ILayer
  • SetNodeLayerStartIDColumn() : sgObject::ILayer
  • SetNullable() : sgObject::IFeatureAttributeDescriptor
  • SetObjectiveSpatialReference() : sgObject::ICanvas
  • SetOceanEnable() : sgObject::IMapEarth
  • SetOColor() : sgObject::IMark
  • SetOffset()
: sgObject::IGraphicIcon
, sgObject::IGridSampleDimension
, sgObject::IMark
  • SetOrder() : sgObject::IAnnotationLabel
  • SetOutlineColor()
: sgObject::IFont
, sgObject::IStroke
  • SetOutlineWidth()
: sgObject::IFont
, sgObject::IStroke
  • SetOverlapLabel() : sgObject::IMap2D
  • SetPageSize() : sgObject::ILayer
  • SetParameter() : sgObject::IChart
  • SetParameters() : sgObject::IVectorAnalysis
  • SetParent() : sgObject::IParameter
  • SetPathType() : sgObject::IGraphicPolygon
  • SetPattern() : sgObject::IStroke
  • SetPerp()
: sgObject::IFont
, sgObject::IMark
  • SetPlacement() : sgObject::IFont
  • SetPoint() : sgObject::IGraphicLineString
  • SetPointOnSurface() : sgObject::IMap2D
  • SetPosition()
: sgObject::IGraphicIcon
, sgObject::IGraphicLabel
, sgObject::IPrintLayoutItem
, sgObject::IUserDefinedWidget
  • SetPrecision() : sgObject::IFeatureAttributeDescriptor
  • SetPreferredPrefix() : sgObject::IFeatureType
  • SetPriority()
: sgObject::IFill
, sgObject::IFont
, sgObject::IMark
, sgObject::IStroke
  • SetQtUiObjectVisible() : sgObject::IWidget
  • SetRadiusAttribute() : sgObject::IGenerator3D
  • SetRatioZoomScale() : sgObject::IMap2D
  • SetRefer() : sgObject::IFeatureCollection
  • SetReferField() : sgObject::IFeatureAttributeDescriptor
  • SetReferFieldName() : sgObject::IFeatureAttributeDescriptor
  • SetReferLayer() : sgObject::IFeatureAttributeDescriptor
  • SetReferLayerName() : sgObject::IFeatureAttributeDescriptor
  • SetRefreshTime() : sgObject::IFeatureLayer
  • SetRelatedFeature() : sgObject::IQueryCommand
  • SetRelateX() : sgObject::IUserDefinedWidget
  • SetRelateY() : sgObject::IUserDefinedWidget
  • SetRotate() : sgObject::IMap2D
  • SetRoundX() : sgObject::IGraphicRectangle
  • SetRoundY() : sgObject::IGraphicRectangle
  • SetScale()
: sgObject::IGridSampleDimension
, sgObject::IMap2D
  • SetScaleBarRelativePos() : sgObject::IMap2D
  • SetScaleBarShowType() : sgObject::IMap2D
  • SetScaleBarSymbolizer() : sgObject::IMap2D
  • SetScaleBarSymbolizerFromString() : sgObject::IMap2D
  • SetScaledImageFromString() : sgObject::IGraphicScaledImage
  • SetScalePrecision() : sgObject::IMap2D
  • SetScaleRatio() : sgObject::IIndexMapWidget
  • SetSCap() : sgObject::IStroke
  • SetScreenMode()
: sgObject::IMap2D
, sgObject::IMapEarth
  • SetSelectable() : sgObject::ILayer
  • SetSelected() : sgObject::IFeature
  • SetSelectedFeature() : sgObject::IFeatureCanvas
  • SetSelectedSymbolizer() : sgObject::IMap2D
  • SetSelectedSymbolizerFromString() : sgObject::IMap2D
  • SetSelectedVertexSymbolizer() : sgObject::IMap2D
  • SetSelectedVertexSymbolizerFromString() : sgObject::IMap2D
  • SetSelectMode() : sgObject::IMap2D
  • SetShadePaletteInterpretation() : sgObject::IGridTypeStyle
  • SetShadowColor() : sgObject::IFont
  • SetShadowEnable() : sgObject::IMapEarth
  • SetShadowSpacingX() : sgObject::IFont
  • SetShadowSpacingY() : sgObject::IFont
  • SetShadowWidth() : sgObject::IFont
  • SetShort() : sgObject::IParameter
  • SetShortLabelExpression() : sgObject::ILayer
  • SetSightMode() : sgObject::IMapEarth
  • SetSize()
: sgObject::IFeatureAttributeDescriptor
, sgObject::IFill
, sgObject::IFont
, sgObject::IMark
  • SetSkyDateTime() : sgObject::IMapEarth
  • SetSmallPixelSize() : sgObject::IMap2D
  • SetSnapGrid() : sgObject::IMap2D
  • SetSnapMode() : sgObject::IMap2D
  • SetSourceCS() : sgObject::IGeographicTransform
  • SetSpacingX()
: sgObject::IFill
, sgObject::IFont
, sgObject::IMark
  • SetSpacingY()
: sgObject::IFill
, sgObject::IFont
, sgObject::IMark
  • SetSpatialReference()
: sgObject::IGeometry
, sgObject::ILayer
, sgObject::ILocationService
  • SetStandardDeviation() : sgObject::IGridTypeStyle
  • SetStart() : sgObject::IGraphicArc
  • SetState() : sgObject::ICanvas
  • SetStatistics() : sgObject::IGridSampleDimension
  • SetStep() : sgObject::IMark
  • SetStretch() : sgObject::IFont
  • SetStrikeout() : sgObject::IFont
  • SetString() : sgObject::IParameter
  • SetStroke() : sgObject::ISymbolizer
  • SetStyleAttribute() : sgObject::ILayer
  • SetStyleType() : sgObject::IFeatureTypeStyle
  • SetSymbolizer()
: sgObject::IFeature
, sgObject::IFeatureTypeStyleRule
, sgObject::ILayer
  • SetSymbolizerType() : sgObject::ISymbolizer
  • SetSyncMoveMode() : sgObject::IMap2D
  • SetSystemSymbolizerFromString() : sgObject::IMap2D
  • SetTabPosition() : sgObject::ITabWidget
  • SetTabRoundedShape() : sgObject::ITabWidget
  • SetTargetCS() : sgObject::IGeographicTransform
  • SetTerrainOptions() : sgObject::IFeatureCanvas
  • SetText()
: sgObject::IAnnotationLabel
, sgObject::IGraphicLabel
, sgObject::IPrintLayoutItem
  • SetTextAngle()
: sgObject::IFont
, sgObject::IMark
  • SetTextSize() : sgObject::IGraphicLabel
  • SetTextString() : sgObject::IFont
  • SetTitle()
: sgObject::ICanvas
, sgObject::IFeatureAttributeDescriptor
, sgObject::IFeatureTypeStyleRule
, sgObject::ILayer
  • SetToolTipExpression() : sgObject::ILayer
  • SetTransaction() : sgObject::IFeatureCollection
  • SetTransparency() : sgObject::IGraphicScaledImage
  • SetTransparent()
: sgObject::IChart
, sgObject::IImageSymbol
  • SetTransparentBackColor() : sgObject::IMap2D
  • SetType() : sgObject::IParameter
  • SetTypeAttribute() : sgObject::IGenerator3D
  • SetUnderline() : sgObject::IFont
  • SetUnits() : sgObject::IGridSampleDimension
  • SetUnknownSensor() : sgObject::ILocationSensor
  • SetUpperLeft() : sgObject::IGraphicScaledImage
  • SetUseDrawThread() : sgObject::IMap2D
  • SetUser() : sgObject::IGPDLayerSource
  • SetUserDefinedWidget() : sgObject::IFeature
  • SetValue()
: sgObject::IGridColorRampItem
, sgObject::IGridSampleDimension
, sgObject::IParameter
, sgObject::IXMLElements
  • SetValueInBoundary() : sgObject::IGridCoverage
  • SetVideoSensor() : sgObject::ICanvas
  • SetViewpoint() : sgObject::IMap3DCamera
  • SetViewshedColor() : sgObject::IMapEarth
  • SetViewshedParam() : sgObject::IMapEarth
  • SetVisible()
: sgObject::IFeature
, sgObject::IFeatureTypeStyleRule
, sgObject::ILayer
  • SetVisibleAnnotation() : sgObject::IFeature
  • SetVisibleAnnotationLine() : sgObject::IFeature
  • SetVisibleAuth()
: sgObject::IFeatureAttributeDescriptor
, sgObject::ILayer
  • SetVisibleMagnifier() : sgObject::IMap2D
  • SetVisibleSmallGeometry() : sgObject::IMap2D
  • SetVisibleUserDefinedWidget() : sgObject::IFeature
  • SetWidget() : sgObject::IDockWidget
  • SetWidth()
: sgObject::IGraphicArc
, sgObject::IGraphicRectangle
, sgObject::IStroke
, sgObject::IWidget
  • SetX()
: sgObject::ILineString
, sgObject::IPoint
  • SetXAnchor() : sgObject::IGraphicLabel
  • SetY()
: sgObject::ILineString
, sgObject::IPoint
  • SetYAnchor() : sgObject::IGraphicLabel
  • SetZ() : sgObject::IPointZ
  • SetZAttribute() : sgObject::IGenerator3D
  • ShadeColorInterpretationAdd() : sgObject::IGridTypeStyle
  • ShadeColorInterpretationRemoveAll() : sgObject::IGridTypeStyle
  • ShowCRSWidget() : sgObject::IFeatureLayer
  • ShowExportLayerWidget() : sgObject::IFeatureLayer
  • ShowFeatureTableWidget() : sgObject::IFeatureLayer
  • ShowFeatureTypeEditWidget() : sgObject::IFeatureLayer
  • ShowFieldCalculatorWidget() : sgObject::IFeatureLayer
  • ShowLabelWidget() : sgObject::IFeatureLayer
  • ShowLayerPropertyWidget() : sgObject::IFeatureLayer
  • ShowNewVectorLayerWidget() : sgObject::IFeatureCanvas
  • ShowOpenRasterLayerWidget() : sgObject::IFeatureCanvas
  • ShowOpenVectorLayerWidget() : sgObject::IFeatureCanvas
  • ShowOpenWebLayerWidget() : sgObject::IFeatureCanvas
  • ShowPrintLayoutWidget()
: sgObject::IApplication
, sgObject::IMap2D
  • ShowSRSWidget() : sgObject::ISpatialReference
  • ShowStyleWidget() : sgObject::IFeatureLayer
  • ShowTypeStyleWidget() : sgObject::IFeatureLayer
  • ShowUpdater() : sgObject::IUtility
  • Sieve() : sgObject::IGridGeneralizeOp
  • Simplify() : sgObject::ISpatialOperator
  • SingleSidedBuffer() : sgObject::ISpatialOperator
  • Snap() : sgObject::_IMap2DEvents
  • Snaped() : sgObject::_IMap2DEvents
  • SnapModeChanged() : sgObject::_IMap2DEvents
  • SnapOut() : sgObject::_IMap2DEvents
  • Sort() : sgObject::IAnnotation
  • Speed() : sgObject::_ILocationSensorEvents
  • Split() : sgObject::IVectorAnalysis
  • Start() : sgObject::ISensor
  • StartPoint() : sgObject::ICurve
  • Stop() : sgObject::ISensor
  • StringToUnicode() : sgObject::IUtility
  • StringToUTF8() : sgObject::IUtility
  • SubCollection()
: sgObject::IAttributeIndex
, sgObject::IFeatureCollection
  • SubLineString() : sgObject::ILineString
  • SymmetricDifference() : sgObject::ISpatialOperator
  • SymmetricDifferenceGeometry() : sgObject::IVectorAnalysis
  • SyncMoveModeChanged() : sgObject::_IMap2DEvents
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
다음은 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버가 속해 있는 클래스에 대한 링크를 가지고 있습니다. :

- t -

  • TabifyDockWidget() : sgObject::IApplication
  • ThiessenPolygon() : sgObject::IVectorAnalysis
  • TileIndex() : sgObject::IGridGeneralizeOp
  • Time() : sgObject::_ILocationSensorEvents
  • TopologyPreserveSimplify() : sgObject::ISpatialOperator
  • TouchDown()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • Touches() : sgObject::ISpatialRelation
  • TouchMove()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • TouchUp()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
다음은 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버가 속해 있는 클래스에 대한 링크를 가지고 있습니다. :

- u -

  • Undid() : sgObject::_IFeatureCanvasEvents
  • Undo() : sgObject::IFeatureCanvas
  • Ungroup() : sgObject::IVectorAnalysis
  • Union() : sgObject::ISpatialOperator
  • UnionCascaded() : sgObject::ISpatialOperator
  • UnionGeometry() : sgObject::IVectorAnalysis
  • UnionLineMerge() : sgObject::IVectorAnalysis
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
다음은 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버가 속해 있는 클래스에 대한 링크를 가지고 있습니다. :

- v -

  • Value() : sgObject::ICurve
  • Vectorize() : sgObject::IGridGeneralizeOp
  • VisibleMapControl() : sgObject::ICanvas
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
다음은 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버가 속해 있는 클래스에 대한 링크를 가지고 있습니다. :

- w -

  • Warp() : sgObject::IGridPreprocessOp
  • Within() : sgObject::ISpatialRelation
  • WithinDistance() : sgObject::ILocationService
  • WithinFeature() : sgObject::ILocationService
  • WorkspaceChanged() : sgObject::_IFeatureCanvasEvents
  • WorldMapBoundingBox() : sgObject::IUtility
  • WorldToDevice() : sgObject::IMap2D
  • WorldToRasterPixel() : sgObject::IMap2D
  • WriteWorkspace() : sgObject::IFeatureCanvas
  • WriteXML() : sgObject::IPrintLayoutWidget
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
다음은 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버가 속해 있는 클래스에 대한 링크를 가지고 있습니다. :

- z -

  • ZoomAll()
: sgObject::IMap2D
, sgObject::IMap3DCamera
  • ZoomCenter() : sgObject::IMap2D
  • ZoomFeature() : sgObject::IMap2D
  • ZoomGPS() : sgObject::IMap2D
  • ZoomIn()
: sgObject::IMap2D
, sgObject::IMap3DCamera
  • ZoomNext() : sgObject::IMap2D
  • ZoomOut()
: sgObject::IMap2D
, sgObject::IMap3DCamera
  • ZoomPrevious() : sgObject::IMap2D
  • ZoomRect() : sgObject::IMap2D
  • ZoomToFeatureCollection()
: sgObject::IMap2D
, sgObject::IMapEarth
  • ZoomToSelectedFeatures() : sgObject::IMap2D
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버 - 함수

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- a -

  • Add()
: sgObject::IAnnotation
, sgObject::IFeatureCollection
, sgObject::IFeatureStyleCollection
, sgObject::IFeatureType
, sgObject::IGeometryCollection
, sgObject::IGraphicCanvas
, sgObject::IQueryCommands
  • AddAction() : sgObject::IApplication
  • AddAll() : sgObject::IFeatureCollection
  • AddAttribute() : sgObject::IFeatureLayer
  • AddCanvas() : sgObject::ITabWidget
  • AddChild() : sgObject::IAggregateGraphic
  • AddChildElement() : sgObject::IXMLElements
  • AddChildren() : sgObject::IAggregateGraphic
  • AddColorRamp() : sgObject::IColorRampList
  • AddControl() : sgObject::ICanvas
  • AddDockWidget() : sgObject::IApplication
  • AddExteriorPoint() : sgObject::IGraphicPolygon
  • AddFeatureLayer()
: sgObject::IFeatureCanvas
, sgObject::IIndexMapWidget
  • AddGridSampleDimension() : sgObject::IGridCoverage
  • AddInteriorPoint() : sgObject::IGraphicPolygon
  • AddLayerSource() : sgObject::IFeatureCanvas
  • AddMenu() : sgObject::IApplication
  • AddParameter() : sgObject::IParameters
  • AddPoint()
: sgObject::IGraphicLineString
, sgObject::ILineString
  • AddRule() : sgObject::IFeatureTypeStyle
  • AddStyleFromString() : sgObject::ISymbolizer
  • AddTab() : sgObject::ITabWidget
  • AddToFeatureLayer() : sgObject::ILayer
  • AddToIndex() : sgObject::IAttributeIndex
  • AddUser() : sgObject::IGPDLayerSource
  • AddWidget() : sgObject::IWidget
  • AddWidgetByLayout() : sgObject::IWidget
  • AfterQueryCommands() : sgObject::IDefaultTransaction
  • AnimateSelectedFeatureCollection() : sgObject::IMap2D
  • AttributeDescriptor() : sgObject::IFeatureType
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버 - 함수

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- b -

  • BeforeQueryCommands() : sgObject::IDefaultTransaction
  • Boundary() : sgObject::ISpatialOperator
  • BoundaryGeometry() : sgObject::IVectorAnalysis
  • BoundingBox() : sgObject::IMap2D
  • Buffer() : sgObject::ISpatialOperator
  • BufferGeometry() : sgObject::IVectorAnalysis
  • BufferGeometryWithSingleSide() : sgObject::IVectorAnalysis
  • BufferGeometryWithStyle() : sgObject::IVectorAnalysis
  • BufferWithStyle() : sgObject::ISpatialOperator
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버 - 함수

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- c -

  • CalculateDistanceFromLL() : sgObject::IUtility
  • CalculateMeterUnitFromLL() : sgObject::IUtility
  • CanProcess() : sgObject::ILayerSourceFactory
  • Centroid()
: sgObject::IMultiSurface
, sgObject::ISurface
  • Clear()
: sgObject::IAttributeIndex
, sgObject::IFeatureCollection
, sgObject::IGraphicCanvas
, sgObject::IParameter
, sgObject::IXMLDoc
  • ClearEffectFilter() : sgObject::IGridTypeStyle
  • ClearViewshed() : sgObject::IMapEarth
  • Click()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • ClipGeometry() : sgObject::IVectorAnalysis
  • Clone()
: sgObject::IFeature
, sgObject::IFeatureAttributeDescriptor
, sgObject::IFeatureType
, sgObject::IFeatureTypeStyleRule
, sgObject::IGeometry
, sgObject::IParameter
, sgObject::IQueryCommand
, sgObject::ISpatialReference
, sgObject::ISymbolizer
  • Close()
: sgObject::IFeatureCollection
, sgObject::IFeatureStyleCollection
  • ColorStringToNumber() : sgObject::IUtility
  • ColorToNumber() : sgObject::IUtility
  • Commit()
: sgObject::IDefaultTransaction
, sgObject::IFeatureCanvas
  • Committed() : sgObject::_IFeatureCanvasEvents
  • Compile() : sgObject::IFeatureQuery
  • Compression() : sgObject::IUtility
  • Contains()
: sgObject::IFeatureCanvas
, sgObject::IFeatureCollection
, sgObject::ISpatialRelation
  • ContainsAll() : sgObject::IFeatureCollection
  • ConvexHull() : sgObject::ISpatialOperator
  • Coordinates() : sgObject::_ILocationSensorEvents
  • Coords() : sgObject::IPoint
  • Copy() : sgObject::IFeatureCanvas
  • CopyTo() : sgObject::IFeature
  • CountPerBucket() : sgObject::IHistogram
  • Create() : sgObject::IAttributeIndex
  • CreateAnimator() : sgObject::ICommonFactory
  • CreateApplication() : sgObject::IDisplayFactory
  • CreateAttributeIndex() : sgObject::ICommonFactory
  • CreateCanvas() : sgObject::IDisplayFactory
  • CreateCoverageFactory() : sgObject::ICommonFactory
  • CreateCRSFactory() : sgObject::ICommonFactory
  • CreateElement() : sgObject::IXMLDoc
  • CreateFeature() : sgObject::IFeatureCollection
  • CreateFeatureAttributeDescriptor() : sgObject::ICommonFactory
  • CreateFeatureCanvas() : sgObject::IDisplayFactory
  • CreateFeatureLayer() : sgObject::ILayer
  • CreateFeatureQuery() : sgObject::ICommonFactory
  • CreateFeatureType() : sgObject::ICommonFactory
  • CreateFeatureTypeStyle() : sgObject::IFeatureTypeStyleFactory
  • CreateFeatureTypeStyleFactory() : sgObject::ICommonFactory
  • CreateFeatureTypeStyleFromXML() : sgObject::IFeatureTypeStyleFactory
  • CreateFeatureTypeStyleRule() : sgObject::IFeatureTypeStyleFactory
  • CreateFillStyle() : sgObject::IFeatureTypeStyleFactory
  • CreateFontStyle() : sgObject::IFeatureTypeStyleFactory
  • CreateFromESRI() : sgObject::ISpatialReferenceFactory
  • CreateFromProj4() : sgObject::ISpatialReferenceFactory
  • CreateFromWKB() : sgObject::IGeometryFactory
  • CreateFromWKT()
: sgObject::IGeometryFactory
, sgObject::ISpatialReferenceFactory
  • CreateFromXML() : sgObject::ISpatialReferenceFactory
  • CreateGeographicTransform() : sgObject::ISpatialReferenceFactory
  • CreateGeometryFactory() : sgObject::ICommonFactory
  • CreateGraphic() : sgObject::IDisplayFactory
  • CreateGraphicFromFeature() : sgObject::IDisplayFactory
  • CreateGraphicFromGeometry() : sgObject::IDisplayFactory
  • CreateGridCoverageProcessor() : sgObject::ICoverageFactory
  • CreateLayer() : sgObject::ILayerSource
  • CreateLayerSource() : sgObject::ILayerSourceFactory
  • CreateLocationService() : sgObject::ICommonFactory
  • CreateMarkStyle() : sgObject::IFeatureTypeStyleFactory
  • CreateMessage() : sgObject::ICommonFactory
  • CreateNetworkCoverageAnalysis() : sgObject::ICoverageFactory
  • CreateNewLayerSource() : sgObject::ILayerSourceFactory
  • CreateNodeFeatureLayer() : sgObject::INetworkCoverageAnalysis
  • CreateParameter() : sgObject::ICommonFactory
  • CreateParameters() : sgObject::ICommonFactory
  • CreateStrokeStyle() : sgObject::IFeatureTypeStyleFactory
  • CreateSymbolizer() : sgObject::IFeatureTypeStyleFactory
  • CreateTemporaryLayer() : sgObject::IFeatureCanvas
  • CreateUtility() : sgObject::ICommonFactory
  • CreateViewshed() : sgObject::IMapEarth
  • CreateWidget() : sgObject::IDisplayFactory
  • CreateWidgetToFeatureAttributeTree() : sgObject::IDisplayFactory
  • CreateWidgetToIndexMap() : sgObject::IDisplayFactory
  • CreateWidgetToLayerTree() : sgObject::IDisplayFactory
  • Crosses() : sgObject::ISpatialRelation
  • Cut() : sgObject::IFeatureCanvas
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버 - 함수

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- d -

  • DblClick() : sgObject::ICanvas
  • Decompression() : sgObject::IUtility
  • Decryption() : sgObject::IUtility
  • DefaultShapeAttribute() : sgObject::IFeatureType
  • DelaunayTriangulation() : sgObject::IVectorAnalysis
  • DeleteFeatureCollection() : sgObject::IFeatureCanvas
  • DeleteFeatureLayer() : sgObject::IFeatureCanvas
  • DeleteFeatureLayerAll() : sgObject::IFeatureCanvas
  • DeleteLayer() : sgObject::ILayerSource
  • DeletePoint() : sgObject::IGraphicLineString
  • DeleteToolBarByType()
: sgObject::IApplication
, sgObject::IPrintLayoutWidget
  • Densify() : sgObject::IVectorAnalysis
  • Destroy()
: sgObject::ISpatialReference
, sgObject::IWidget
  • DeviceToWorld() : sgObject::IMap2D
  • DeviceToWorldZ() : sgObject::IMap2D
  • Difference() : sgObject::ISpatialOperator
  • DifferenceGeometry() : sgObject::IVectorAnalysis
  • Disjoint() : sgObject::ISpatialRelation
  • Dissolve() : sgObject::IVectorAnalysis
  • Distance() : sgObject::ISpatialOperator
  • DoOperation() : sgObject::IGridCoverageProcessor
  • DoubleClick()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • Draw() : sgObject::_IMap2DEvents
  • Drawed() : sgObject::_IMap2DEvents
  • DrawingGeometryAddGPSPoint() : sgObject::IMap2D
  • DrawingGeometryAddPoint() : sgObject::IMap2D
  • DrawingGeometryComplete() : sgObject::IMap2D
  • DrawingGeometryGetPoint() : sgObject::IMap2D
  • DrawingGeometryRemovePoint() : sgObject::IMap2D
  • DrawingGeometrySetPoint() : sgObject::IMap2D
  • DrawingGeometrySize() : sgObject::IMap2D
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버 - 함수

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- e -

  • Encryption() : sgObject::IUtility
  • Encryption1() : sgObject::IUtility
  • EndPoint() : sgObject::ICurve
  • Envelope() : sgObject::IGeometry
  • Equal() : sgObject::IFeature
  • Equals() : sgObject::ISpatialRelation
  • Evaluate() : sgObject::IFeatureQuery
  • Execute() : sgObject::IGridOperation
  • ExecuteSQL() : sgObject::ILayerSource
  • ExecuteSQLToString() : sgObject::ILayerSource
  • Export()
: sgObject::IFeatureLayer
, sgObject::ILayer
  • Exported() : sgObject::_IMap2DEvents
  • ExportImage()
: sgObject::ICanvas
, sgObject::IUserDefinedWidget
  • ExportImageToWorld() : sgObject::IMap2D
  • ExportLTM() : sgObject::IFeatureCollection
  • ExportScreenImage() : sgObject::IMap2D
  • ExportToClipboard() : sgObject::IMap2D
  • ExportToProj4() : sgObject::ISpatialReference
  • ExportToProj4AsString() : sgObject::ISpatialReferenceFactory
  • ExportToWKB() : sgObject::IWks
  • ExportToWkt() : sgObject::ISpatialReference
  • ExportToWKT() : sgObject::IWks
  • ExportToWKTAsString() : sgObject::ISpatialReferenceFactory
  • ExportToXMLAsString() : sgObject::ISpatialReferenceFactory
  • Extent2D()
: sgObject::ICoverage
, sgObject::IFeature
, sgObject::IGeometry
  • ExteriorRing() : sgObject::IPolygon
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버 - 함수

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- f -

  • Feature3DDeSelected()
: sgObject::_IMap3DEvents
, sgObject::_IMapAREvents
, sgObject::_IMapEarthEvents
  • Feature3DSelected()
: sgObject::_IMap3DEvents
, sgObject::_IMapAREvents
, sgObject::_IMapEarthEvents
  • FeatureDelete() : sgObject::_IFeatureCanvasEvents
  • FeatureDeleted() : sgObject::_IFeatureCanvasEvents
  • FeatureDeSelected() : sgObject::_IFeatureCanvasEvents
  • FeatureInsert() : sgObject::_IFeatureCanvasEvents
  • FeatureInserted() : sgObject::_IFeatureCanvasEvents
  • FeatureOut() : sgObject::_IMap2DEvents
  • FeatureOver() : sgObject::_IMap2DEvents
  • FeaturePreUpdate() : sgObject::_IFeatureCanvasEvents
  • FeatureSelected() : sgObject::_IFeatureCanvasEvents
  • FeaturesToPoint() : sgObject::IVectorAnalysis
  • FeatureStyle() : sgObject::IFeatureStyleCollection
  • FeatureUpdate() : sgObject::_IFeatureCanvasEvents
  • FeatureUpdated() : sgObject::_IFeatureCanvasEvents
  • FeatureVerticesToPoints() : sgObject::IVectorAnalysis
  • FillNodata() : sgObject::IGridGeneralizeOp
  • Fishnet() : sgObject::IVectorAnalysis
  • ForceStopRender()
: sgObject::ICanvas
, sgObject::IFeatureCanvas
  • Forward() : sgObject::IGeographicTransform
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버 - 함수

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- g -

  • Generalize() : sgObject::IVectorAnalysis
  • GeoCode() : sgObject::ILocationService
  • Geometry() : sgObject::IGeometryCollection
  • GetAbsolutePage() : sgObject::ILayer
  • GetAbstract()
: sgObject::ILayer
, sgObject::ISymbol
  • GetActive() : sgObject::IFeatureCanvas
  • GetAdjustmentHor() : sgObject::IFont
  • GetAdjustmentVert() : sgObject::IFont
  • GetAffectedCount() : sgObject::ILayerSource
  • GetAnchor() : sgObject::IFont
  • GetAngle()
: sgObject::IFill
, sgObject::IFont
, sgObject::IMark
  • GetAnnoLineAttribute() : sgObject::ILayer
  • GetAnnoLineVisibleAttribute() : sgObject::ILayer
  • GetAnnotation() : sgObject::IFeature
  • GetAnnotationLine() : sgObject::IFeature
  • GetAnnoVisibleAttribute() : sgObject::ILayer
  • GetAnnoXMLAttribute() : sgObject::ILayer
  • GetAntiAlias() : sgObject::IMap2D
  • GetApplication() : sgObject::IApplicationControl
  • GetArea()
: sgObject::IMultiSurface
, sgObject::ISurface
  • GetAttribute() : sgObject::IFeature
  • GetAttributeAsString()
: sgObject::IFeature
, sgObject::IFeatureQuery
  • GetAttributeAsStringByName() : sgObject::IFeature
  • GetAttributeToString() : sgObject::IFeature
  • GetAuthorityCode() : sgObject::ISpatialReference
  • GetAuthorityName() : sgObject::ISpatialReference
  • GetAutoScale() : sgObject::IMap2D
  • GetBackColor()
: sgObject::ICanvas
, sgObject::IFill
, sgObject::IFont
, sgObject::IWidget
  • GetBackgroundColor() : sgObject::IChart
  • GetBaudRate() : sgObject::ILocationSensor
  • GetBold() : sgObject::IFont
  • GetBool() : sgObject::IParameter
  • GetBoundingBox() : sgObject::ILayer
  • GetBounds() : sgObject::IFeature
  • GetBoxPaddingX() : sgObject::IFont
  • GetBoxPaddingY() : sgObject::IFont
  • GetCanMoveIndexMap() : sgObject::IIndexMapWidget
  • GetCanvas() : sgObject::IIndexMapWidget
  • GetCanvasType() : sgObject::ICanvas
  • GetCap() : sgObject::IStroke
  • GetCategory() : sgObject::ILayer
  • GetCategoryNames() : sgObject::IGridSampleDimension
  • GetCenter()
: sgObject::IGraphicArc
, sgObject::IGraphicRectangle
  • GetChartType() : sgObject::IChart
  • GetChildCount() : sgObject::IAggregateGraphic
  • GetChildElement() : sgObject::IXMLElements
  • GetChildLength() : sgObject::IXMLElements
  • GetColor()
: sgObject::IColorModel
, sgObject::IGridColorRampItem
, sgObject::IMark
, sgObject::IStroke
  • GetColorAsRGB() : sgObject::IColorModel
  • GetColorInterpretation() : sgObject::IGridSampleDimension
  • GetColorRamp() : sgObject::IColorRampList
  • GetColorRampByName() : sgObject::IColorRampList
  • GetColorRampList() : sgObject::ICommonFactory
  • GetColorTable() : sgObject::IGridSampleDimension
  • GetCommandText() : sgObject::IQueryCommand
  • GetCommonFactory()
: sgObject::IApplication
, sgObject::ICanvas
  • GetConfigOption() : sgObject::IUtility
  • GetConnectStringFromFileName() : sgObject::IFeatureCanvas
  • GetCoordinateSystem() : sgObject::ICoverage
  • GetCoverage() : sgObject::IGridCoverage
  • GetCRS() : sgObject::IGraphicScaledImage
  • GetCurve() : sgObject::ILineString
  • GetData()
: sgObject::IFeature
, sgObject::IQueryCommand
  • GetDataType() : sgObject::IFeatureAttributeDescriptor
  • GetDefaultValue() : sgObject::IParameterInfo
  • GetDefaultValueHeight() : sgObject::IGenerator3D
  • GetDefaultValueRadius() : sgObject::IGenerator3D
  • GetDefaultValueType() : sgObject::IGenerator3D
  • GetDefaultValueZ() : sgObject::IGenerator3D
  • GetDefaultViewpoint() : sgObject::IMap3DCamera
  • GetDescription()
: sgObject::IGridCoverage
, sgObject::IGridOperation
, sgObject::ILayerSource
, sgObject::ILayerSourceFactory
, sgObject::IParameterInfo
  • GetDiagram() : sgObject::ILayer
  • GetDimension() : sgObject::IGeometry
  • GetDisplayEditActionByType() : sgObject::IApplication
  • GetDisplayFactory() : sgObject::ICommonFactory
  • GetDisplayMenuBar()
: sgObject::IApplication
, sgObject::IPrintLayoutWidget
  • GetDisplayName()
: sgObject::ILayerSource
, sgObject::ILayerSourceFactory
  • GetDisplaySpatialReference() : sgObject::IFeatureCanvas
  • GetDisplayStatusBar() : sgObject::IApplication
  • GetDisplayToolBar()
: sgObject::IFeatureAttributeTreeWidget
, sgObject::ILayerTreeWidget
  • GetDisplayToolBarByType()
: sgObject::IApplication
, sgObject::IPrintLayoutWidget
  • GetDocURL() : sgObject::IGridOperation
  • GetDouble() : sgObject::IParameter
  • GetDriverType()
: sgObject::IFeatureLayer
, sgObject::ILayerSource
  • GetECap() : sgObject::IStroke
  • GetEditableAuth()
: sgObject::IFeatureAttributeDescriptor
, sgObject::ILayer
  • GetEffectFilter() : sgObject::IGridTypeStyle
  • GetElement() : sgObject::IXMLElements
  • GetElements() : sgObject::IXMLDoc
  • GetElseFilterFeatureStyle() : sgObject::IFeatureTypeStyle
  • GetElseFilterVisible() : sgObject::IFeatureTypeStyle
  • GetEncoding() : sgObject::IUtility
  • GetEnd() : sgObject::IGraphicArc
  • GetEnvelope() : sgObject::ICoverage
  • GetEPSGName() : sgObject::ISpatialReference
  • GetExteriorPoint() : sgObject::IGraphicPolygon
  • GetFeature()
: sgObject::IAnnotation
, sgObject::IAnnotationLabel
, sgObject::IFeatureCollection
  • GetFeatureAtPoint() : sgObject::IFeatureCanvas
  • GetFeatureCanvas()
: sgObject::ICanvas
, sgObject::IFeatureLayer
, sgObject::IMap2DControl
, sgObject::IMap3DControl
, sgObject::IMapARControl
, sgObject::IMapEarthControl
, sgObject::IWidget
  • GetFeatureCollection()
: sgObject::IAttributeIndex
, sgObject::IFeature
, sgObject::IFeatureLayer
  • GetFeatureColors() : sgObject::IChart
  • GetFeatureFields() : sgObject::IChart
  • GetFeatureFromFID() : sgObject::IFeatureCollection
  • GetFeatureInterface() : sgObject::IFeatureCollection
  • GetFeatureLables() : sgObject::IChart
  • GetFeatureLayer()
: sgObject::IFeatureCanvas
, sgObject::IFeatureCollection
, sgObject::ILayer
  • GetFeatureLayerByID() : sgObject::IFeatureCanvas
  • GetFeatureLayerByLayer() : sgObject::IFeatureCanvas
  • GetFeatureLayerByName() : sgObject::IFeatureCanvas
  • GetFeatures() : sgObject::IDockWidget
  • GetFeaturesAtPoint() : sgObject::IFeatureCanvas
  • GetFeatureStyle() : sgObject::IFeatureStyleCollection
  • GetFeatureType()
: sgObject::IFeature
, sgObject::ILayer
  • GetFeatureTypeStyle()
: sgObject::IFeatureTypeStyleRule
, sgObject::ILayer
  • GetFIDColumn() : sgObject::ILayer
  • GetFileName() : sgObject::IXMLDoc
  • GetFill() : sgObject::ISymbolizer
  • GetFillBrush() : sgObject::IMap2D
  • GetFilter() : sgObject::IFeatureTypeStyleRule
  • GetFlag() : sgObject::IWidget
  • GetFlashset() : sgObject::IFeatureCanvas
  • GetFlickerSelected() : sgObject::IMap2D
  • GetFloat() : sgObject::IParameter
  • GetFont() : sgObject::ISymbolizer
  • GetFontName()
: sgObject::IFont
, sgObject::IMark
  • GetForeColor()
: sgObject::IFill
, sgObject::IFont
  • GetGeometry()
: sgObject::IFeature
, sgObject::IPointSymbol
  • GetGeometryCollection()
: sgObject::IMultiCurve
, sgObject::IMultiPoint
, sgObject::IMultiPolygon
  • GetGeometryColumn() : sgObject::ILayer
  • GetGeometryType()
: sgObject::IFeatureType
, sgObject::IGeometry
  • GetGraphicsAt() : sgObject::IGraphicCanvas
  • GetGridAnalysis() : sgObject::IGridCoverage
  • GetGridColorType() : sgObject::IGridTypeStyle
  • GetGridCoverage()
: sgObject::IFeature
, sgObject::IGridSampleDimension
  • GetHasArbitraryOverviews() : sgObject::IGridSampleDimension
  • GetHeight()
: sgObject::IGraphicArc
, sgObject::IGraphicRectangle
  • GetHeightAttribute() : sgObject::IGenerator3D
  • GetHistogram() : sgObject::IGridAnalysis
  • GetHittestSize() : sgObject::ICanvas
  • GetHttpResult() : sgObject::IUtility
  • GetIcon()
: sgObject::ILayerSource
, sgObject::ILayerSourceFactory
  • GetID()
: sgObject::IFeature
, sgObject::IFill
, sgObject::IMark
, sgObject::IQueryCommand
, sgObject::IStroke
  • GetImage() : sgObject::IImageSymbol
  • GetIndex() : sgObject::IFeatureType
  • GetIndexMapAutoMove() : sgObject::IIndexMapWidget
  • GetIndexOfFeatureLayer() : sgObject::IFeatureCanvas
  • GetInt() : sgObject::IParameter
  • GetIntensity() : sgObject::IGraphicScaledImage
  • GetInteriorPoint() : sgObject::IGraphicPolygon
  • GetInterpretation() : sgObject::IColorModel
  • GetIsSeqKey() : sgObject::IFeatureAttributeDescriptor
  • GetItalic() : sgObject::IFont
  • GetItem() : sgObject::IPrintLayoutWidget
  • GetJoin() : sgObject::IStroke
  • GetLabel() : sgObject::IAnnotation
  • GetLabelExpression() : sgObject::ILayer
  • GetLabelMaxScaleDenominator() : sgObject::ILayer
  • GetLabelMinScaleDenominator() : sgObject::ILayer
  • GetLabelPosition() : sgObject::ILayer
  • GetLabelSize() : sgObject::IFeatureCollection
  • GetLabelText() : sgObject::ILayer
  • GetLastErrorMsg() : sgObject::IUtility
  • GetLatestValueToXML() : sgObject::ISensor
  • GetLayer()
: sgObject::IAnnotationLabel
, sgObject::IFeatureLayer
, sgObject::ILayerSource
  • GetLayerCount() : sgObject::ILayerSource
  • GetLayerID() : sgObject::ILayer
  • GetLayerSource() : sgObject::IFeatureLayer
  • GetLayerSourceFactory() : sgObject::ICommonFactory
  • GetLayerSourceFromFileName() : sgObject::IFeatureCanvas
  • GetLength()
: sgObject::ICurve
, sgObject::IMultiCurve
  • GetLineColor() : sgObject::IChart
  • GetLinePattern() : sgObject::IMark
  • GetLineString() : sgObject::ILinearRing
  • GetLocationSensor() : sgObject::ICommonFactory
  • GetLocationSensorType() : sgObject::ILocationSensor
  • GetLong() : sgObject::IParameter
  • GetLowerRight() : sgObject::IGraphicScaledImage
  • GetMagnifierPixelSize() : sgObject::IMap2D
  • GetMagnifierScale() : sgObject::IMap2D
  • GetMap2D() : sgObject::IMap2DControl
  • GetMap2DKeyFromWinKey() : sgObject::IUtility
  • GetMap3D() : sgObject::IMap3DControl
  • GetMap3DCamera()
: sgObject::IMap3D
, sgObject::IMapAR
, sgObject::IMapEarth
  • GetMap3DKeyFromQtKey() : sgObject::IUtility
  • GetMap3DLight()
: sgObject::IMap3D
, sgObject::IMapAR
, sgObject::IMapEarth
  • GetMapAR() : sgObject::IMapARControl
  • GetMapControl() : sgObject::ICanvas
  • GetMapControlRelativePos() : sgObject::IMap2D
  • GetMapControlShowType() : sgObject::IMap2D
  • GetMapEarth() : sgObject::IMapEarthControl
  • GetMapIdxColumn() : sgObject::ILayer
  • GetMapIdxLevel() : sgObject::ILayer
  • GetMapMoveMode() : sgObject::ICanvas
  • GetMapRotateMode() : sgObject::ICanvas
  • GetMark() : sgObject::ISymbolizer
  • GetMaximumOccurrences() : sgObject::IFeatureAttributeDescriptor
  • GetMaximumValue()
: sgObject::IGridSampleDimension
, sgObject::IGridTypeStyle
, sgObject::IParameterInfo
  • GetMaxScaleDenominator()
: sgObject::IFeatureTypeStyleRule
, sgObject::ILayer
, sgObject::ISymbolizer
  • GetMaxValue()
: sgObject::IGridAnalysis
, sgObject::IHistogram
  • GetMaxXBoundingBox() : sgObject::IMap2D
  • GetMaxXExtent2D() : sgObject::IFeature
  • GetMaxYBoundingBox() : sgObject::IMap2D
  • GetMaxYExtent2D() : sgObject::IFeature
  • GetMaxZoomScaleDenominator() : sgObject::IMap2D
  • GetMeanValue() : sgObject::IGridAnalysis
  • GetMeasureLineShowType() : sgObject::IMap2D
  • GetMeasureLineStd() : sgObject::IMap2D
  • GetMeasureLineStdLength() : sgObject::IMap2D
  • GetMeasureLineSubUnitNum() : sgObject::IMap2D
  • GetMeasureValue() : sgObject::IMap2D
  • GetMedianValue() : sgObject::IGridAnalysis
  • GetMetadataItemValue() : sgObject::IGridCoverage
  • GetMetadataValue() : sgObject::IGridCoverage
  • GetMinimumOccurrences() : sgObject::IFeatureAttributeDescriptor
  • GetMinimumValue()
: sgObject::IGridSampleDimension
, sgObject::IGridTypeStyle
, sgObject::IParameterInfo
  • GetMinMaxPitch() : sgObject::IMap3DCamera
  • GetMinScaleDenominator()
: sgObject::IFeatureTypeStyleRule
, sgObject::ILayer
, sgObject::ISymbolizer
  • GetMinValue()
: sgObject::IGridAnalysis
, sgObject::IHistogram
  • GetMinXBoundingBox() : sgObject::IMap2D
  • GetMinXExtent2D() : sgObject::IFeature
  • GetMinYBoundingBox() : sgObject::IMap2D
  • GetMinYExtent2D() : sgObject::IFeature
  • GetMinZoomScaleDenominator() : sgObject::IMap2D
  • GetModeValue() : sgObject::IGridAnalysis
  • GetModuleFilePath() : sgObject::IUtility
  • GetMotionSensor() : sgObject::ICommonFactory
  • GetMsgInString() : sgObject::IMessage
  • GetMultiCurve() : sgObject::IMultiCurve
  • GetMultiSurface() : sgObject::IMultiPolygon
  • GetMyIPAddress() : sgObject::IUtility
  • GetMyMacAddress() : sgObject::IUtility
  • GetName()
: sgObject::IColorRampList
, sgObject::IFeatureAttributeDescriptor
, sgObject::IFeatureType
, sgObject::IGridOperation
, sgObject::ILayer
, sgObject::IParameter
, sgObject::IParameterInfo
, sgObject::IQueryCommand
, sgObject::ISymbol
, sgObject::ISymbolizer
, sgObject::IXMLElements
  • GetNodataValue() : sgObject::IGridSampleDimension
  • GetNodeLayerEndIDColumn() : sgObject::ILayer
  • GetNodeLayerName() : sgObject::ILayer
  • GetNodeLayerStartIDColumn() : sgObject::ILayer
  • GetNumBucket() : sgObject::IHistogram
  • GetNumColor() : sgObject::IColorModel
  • GetNumColumn()
: sgObject::IGridCoverage
, sgObject::IGridSampleDimension
  • GetNumDataSeries() : sgObject::IChart
  • GetNumExteriorPoints() : sgObject::IGraphicPolygon
  • GetNumGeometries() : sgObject::IGeometryCollection
  • GetNumInteriorPoints() : sgObject::IGraphicPolygon
  • GetNumInteriorRings()
: sgObject::IGraphicPolygon
, sgObject::IPolygon
  • GetNumOperations() : sgObject::IGridCoverageProcessor
  • GetNumOverviews() : sgObject::IGridSampleDimension
  • GetNumParameters() : sgObject::IGridOperation
  • GetNumPoints() : sgObject::ILineString
  • GetNumRow()
: sgObject::IGridCoverage
, sgObject::IGridSampleDimension
  • GetNumSampleDimensions() : sgObject::ICoverage
  • GetNumSources() : sgObject::IGridOperation
  • GetObjectiveSpatialReference() : sgObject::ICanvas
  • GetOceanEnable() : sgObject::IMapEarth
  • GetOColor() : sgObject::IMark
  • GetOffset()
: sgObject::IGraphicIcon
, sgObject::IGridSampleDimension
, sgObject::IMark
  • GetOperation() : sgObject::IGridCoverageProcessor
  • GetOperationByName() : sgObject::IGridCoverageProcessor
  • GetOrder()
: sgObject::IAnnotationLabel
, sgObject::ILayer
  • GetOutlineColor()
: sgObject::IFont
, sgObject::IStroke
  • GetOutlineWidth()
: sgObject::IFont
, sgObject::IStroke
  • GetOverlapLabel() : sgObject::IMap2D
  • GetOverview() : sgObject::IGridSampleDimension
  • GetPageSize() : sgObject::ILayer
  • GetParameter() : sgObject::IParameters
  • GetParameterInfo() : sgObject::IGridOperation
  • GetParameters() : sgObject::ILayer
  • GetParent() : sgObject::IParameter
  • GetParentElement() : sgObject::IXMLElements
  • GetPathType() : sgObject::IGraphicPolygon
  • GetPattern() : sgObject::IStroke
  • GetPerp()
: sgObject::IFont
, sgObject::IMark
  • GetPixelUnit() : sgObject::IGridCoverage
  • GetPlacement() : sgObject::IFont
  • GetPoint() : sgObject::ILineString
  • GetPointOnSurface() : sgObject::IMap2D
  • GetPortNumber() : sgObject::ILocationSensor
  • GetPosition()
: sgObject::IGraphicIcon
, sgObject::IGraphicLabel
, sgObject::IUserDefinedWidget
  • GetPrecision() : sgObject::IFeatureAttributeDescriptor
  • GetPreferredPrefix() : sgObject::IFeatureType
  • GetPriority()
: sgObject::IFill
, sgObject::IFont
, sgObject::IMark
, sgObject::IStroke
  • GetQueryString() : sgObject::IMessage
  • GetRadiusAttribute() : sgObject::IGenerator3D
  • GetRatioZoomScale() : sgObject::IMap2D
  • GetReferField() : sgObject::IFeatureAttributeDescriptor
  • GetReferFieldName() : sgObject::IFeatureAttributeDescriptor
  • GetReferGeometryLayerName() : sgObject::ILayer
  • GetReferLayer() : sgObject::IFeatureAttributeDescriptor
  • GetReferLayerName() : sgObject::IFeatureAttributeDescriptor
  • GetRelatedFeature() : sgObject::IQueryCommand
  • GetRelateX() : sgObject::IUserDefinedWidget
  • GetRelateY() : sgObject::IUserDefinedWidget
  • GetRotate() : sgObject::IMap2D
  • GetRoundX() : sgObject::IGraphicRectangle
  • GetRoundY() : sgObject::IGraphicRectangle
  • GetRule() : sgObject::IFeatureTypeStyle
  • GetSampleDimension() : sgObject::ICoverage
  • GetSampleDimensionType() : sgObject::IGridSampleDimension
  • GetScale()
: sgObject::IGridSampleDimension
, sgObject::IMap2D
  • GetScaleBarRelativePos() : sgObject::IMap2D
  • GetScaleBarShowType() : sgObject::IMap2D
  • GetScalePrecision() : sgObject::IMap2D
  • GetScaleRatio() : sgObject::IIndexMapWidget
  • GetSCap() : sgObject::IStroke
  • GetScreenMode()
: sgObject::IMap2D
, sgObject::IMapEarth
  • GetSelectable() : sgObject::ILayer
  • GetSelected() : sgObject::IFeature
  • GetSelection() : sgObject::IFeatureCanvas
  • GetSelectMode() : sgObject::IMap2D
  • GetShadeColor() : sgObject::IGridTypeStyle
  • GetShadeColorInterpretation() : sgObject::IGridTypeStyle
  • GetShadeColorInterpretationByOrder() : sgObject::IGridTypeStyle
  • GetShadeColorInterpretationSize() : sgObject::IGridTypeStyle
  • GetShadeIndexByColorInterpretation() : sgObject::IGridTypeStyle
  • GetShadeIndexByOrder() : sgObject::IGridTypeStyle
  • GetShadePaletteInterpretation() : sgObject::IGridTypeStyle
  • GetShadowColor() : sgObject::IFont
  • GetShadowEnable() : sgObject::IMapEarth
  • GetShadowSpacingX() : sgObject::IFont
  • GetShadowSpacingY() : sgObject::IFont
  • GetShadowWidth() : sgObject::IFont
  • GetShort() : sgObject::IParameter
  • GetShortLabelExpression() : sgObject::ILayer
  • GetSightMode() : sgObject::IMapEarth
  • GetSize()
: sgObject::IAnnotation
, sgObject::IColorRampList
, sgObject::IFeatureAttributeDescriptor
, sgObject::IFeatureCanvas
, sgObject::IFeatureCollection
, sgObject::IFeatureStyleCollection
, sgObject::IFeatureType
, sgObject::IFeatureTypeStyle
, sgObject::IFill
, sgObject::IFont
, sgObject::ILayerSource
, sgObject::IMark
, sgObject::IParameters
, sgObject::IQueryCommands
  • GetSkyDateTime() : sgObject::IMapEarth
  • GetSmallPixelSize() : sgObject::IMap2D
  • GetSnapGrid() : sgObject::IMap2D
  • GetSnapMode() : sgObject::IMap2D
  • GetSourceCS() : sgObject::IGeographicTransform
  • GetSpacingX()
: sgObject::IFill
, sgObject::IFont
, sgObject::IMark
  • GetSpacingY()
: sgObject::IFill
, sgObject::IFont
, sgObject::IMark
  • GetSpatialOperator() : sgObject::IGeometry
  • GetSpatialReference()
: sgObject::IGeometry
, sgObject::ILayer
, sgObject::ILocationService
  • GetSpatialRelation() : sgObject::IGeometry
  • GetSpatialRelation2() : sgObject::IGeometry
  • GetStandardDeviation()
: sgObject::IGridAnalysis
, sgObject::IGridTypeStyle
  • GetStart() : sgObject::IGraphicArc
  • GetState() : sgObject::ICanvas
  • GetStatistics() : sgObject::IGridSampleDimension
  • GetStep() : sgObject::IMark
  • GetStretch() : sgObject::IFont
  • GetStrikeout() : sgObject::IFont
  • GetString() : sgObject::IParameter
  • GetStroke() : sgObject::ISymbolizer
  • GetStyleAttribute() : sgObject::ILayer
  • GetStyleString()
: sgObject::IFill
, sgObject::IFont
, sgObject::IMark
, sgObject::IStroke
  • GetStyleToString() : sgObject::ISymbolizer
  • GetStyleType() : sgObject::IFeatureTypeStyle
  • GetSurface() : sgObject::IPolygon
  • GetSurfaceVolumeFromGridCoverage() : sgObject::IUtility
  • GetSymbolizer()
: sgObject::IFeature
, sgObject::IFeatureTypeStyleRule
, sgObject::ILayer
  • GetSymbolizer3D() : sgObject::ILayer
  • GetSymbolizerType() : sgObject::ISymbolizer
  • GetSymbolType() : sgObject::ISymbol
  • GetSyncMoveMode() : sgObject::IMap2D
  • GetSystemLayerSource() : sgObject::ICommonFactory
  • GetTargetCS() : sgObject::IGeographicTransform
  • GetText()
: sgObject::IAnnotationLabel
, sgObject::IGraphicLabel
  • GetTextAngle()
: sgObject::IFont
, sgObject::IMark
  • GetTextSize() : sgObject::IGraphicLabel
  • GetTextString() : sgObject::IFont
  • GetTitle()
: sgObject::IApplication
, sgObject::ICanvas
, sgObject::IFeatureAttributeDescriptor
, sgObject::IFeatureTypeStyleRule
, sgObject::ILayer
, sgObject::ISymbol
  • GetToolTipExpression() : sgObject::ILayer
  • GetTopGraphicAt() : sgObject::IGraphicCanvas
  • GetTransaction()
: sgObject::IFeatureCanvas
, sgObject::IFeatureCollection
  • GetTransparency() : sgObject::IGraphicScaledImage
  • GetTransparent()
: sgObject::IChart
, sgObject::IImageSymbol
  • GetTransparentBackColor() : sgObject::IMap2D
  • GetType()
: sgObject::IParameter
, sgObject::IParameterInfo
  • GetTypeAttribute() : sgObject::IGenerator3D
  • GetUnderline() : sgObject::IFont
  • GetUnits() : sgObject::IGridSampleDimension
  • GetUpperLeft() : sgObject::IGraphicScaledImage
  • GetUseDrawThread() : sgObject::IMap2D
  • GetUser() : sgObject::IGPDLayerSource
  • GetUserDefinedWidget() : sgObject::IFeature
  • GetUserSize() : sgObject::IGPDLayerSource
  • GetValidValue() : sgObject::IFeatureAttributeDescriptor
  • GetValidValueSize() : sgObject::IFeatureAttributeDescriptor
  • GetValue()
: sgObject::IGridColorRampItem
, sgObject::IGridSampleDimension
, sgObject::IParameter
, sgObject::IXMLElements
  • GetValueAlias() : sgObject::IFeatureAttributeValidValue
  • GetValueExpression() : sgObject::IFeatureAttributeValidValue
  • GetValueFromCoordinate() : sgObject::IGridSampleDimension
  • GetValueKeyValue() : sgObject::IFeatureAttributeValidValue
  • GetVectorAnalysis() : sgObject::IFeatureCollection
  • GetVendor() : sgObject::IGridOperation
  • GetVersion()
: sgObject::IGridOperation
, sgObject::IUtility
  • GetVideoSensor() : sgObject::ICommonFactory
  • GetViewpoint() : sgObject::IMap3DCamera
  • GetVisible()
: sgObject::IFeature
, sgObject::IFeatureTypeStyleRule
, sgObject::ILayer
  • GetVisibleAnnotation() : sgObject::IFeature
  • GetVisibleAnnotationLine() : sgObject::IFeature
  • GetVisibleAuth()
: sgObject::IFeatureAttributeDescriptor
, sgObject::ILayer
  • GetVisibleMagnifier() : sgObject::IMap2D
  • GetVisibleSmallGeometry() : sgObject::IMap2D
  • GetVisibleUserDefinedWidget() : sgObject::IFeature
  • GetWellKnownText() : sgObject::ISpatialReferenceInfo
  • GetWidth()
: sgObject::IGraphicArc
, sgObject::IGraphicRectangle
, sgObject::IStroke
  • GetWks() : sgObject::IGeometry
  • GetWorkspace() : sgObject::IFeatureCanvas
  • GetX()
: sgObject::ILineString
, sgObject::IPoint
  • GetXAnchor() : sgObject::IGraphicLabel
  • GetXDeviceToWorld() : sgObject::IMap2D
  • GetXWorldToDevice() : sgObject::IMap2D
  • GetY()
: sgObject::ILineString
, sgObject::IPoint
  • GetYAnchor() : sgObject::IGraphicLabel
  • GetYDeviceToWorld() : sgObject::IMap2D
  • GetYWorldToDevice() : sgObject::IMap2D
  • GetZ() : sgObject::IPointZ
  • GetZAttribute() : sgObject::IGenerator3D
  • Group() : sgObject::IVectorAnalysis
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버 - 함수

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- h -

  • HausdorffDistance() : sgObject::ISpatialOperator
  • HausdorffDistanceDensify() : sgObject::ISpatialOperator
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버 - 함수

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- i -

  • ImportFromProj4() : sgObject::ISpatialReference
  • ImportFromWKB() : sgObject::IWks
  • ImportFromWkt() : sgObject::ISpatialReference
  • ImportFromWKT() : sgObject::IWks
  • IndexOfSelectedItem()
: sgObject::IFeatureAttributeTreeWidget
, sgObject::ILayerTreeWidget
  • InitDataset() : sgObject::IChart
  • Initialize()
: sgObject::ICanvas
, sgObject::INetworkCoverageAnalysis
, sgObject::IWidget
  • InsertExteriorPoint() : sgObject::IGraphicPolygon
  • InsertInteriorPoint() : sgObject::IGraphicPolygon
  • InsertPoint() : sgObject::IGraphicLineString
  • InteriorRing() : sgObject::IPolygon
  • Interpolate() : sgObject::ISpatialOperator
  • InterpolateNormalized() : sgObject::ISpatialOperator
  • IntersectGeometry() : sgObject::IVectorAnalysis
  • Intersection() : sgObject::ISpatialOperator
  • Intersects() : sgObject::ISpatialRelation
  • Invalidate()
: sgObject::ICanvas
, sgObject::IFeatureCanvas
, sgObject::IPrintLayoutWidget
  • Inverse() : sgObject::IGeographicTransform
  • IsAllowingExtentsChang()
: sgObject::IGraphicArc
, sgObject::IGraphicRectangle
  • IsAllowingNewVertices() : sgObject::IGraphicPolygon
  • IsAllowingRotation() : sgObject::IGraphicRectangle
  • IsAvailable() : sgObject::ILayerSourceFactory
  • IsChild() : sgObject::IXMLElements
  • IsCircle() : sgObject::IGraphicArc
  • IsClosed()
: sgObject::ICurve
, sgObject::IGraphicLineString
, sgObject::IMultiCurve
  • IsClosedEllipse() : sgObject::IGraphicArc
  • IsConfigured() : sgObject::IUtility
  • IsEmpty()
: sgObject::IFeatureCollection
, sgObject::IGeometry
  • IsEqual() : sgObject::IChart
  • IsExteriorHandle() : sgObject::IUserDefinedWidget
  • IsNullable() : sgObject::IFeatureAttributeDescriptor
  • IsPointInRing() : sgObject::ILinearRing
  • IsPointOnRingBoundary() : sgObject::ILinearRing
  • IsPointOnSurface() : sgObject::IPolygon
  • IsRefer() : sgObject::IFeatureCollection
  • IsSame() : sgObject::ISpatialReference
  • IsServiceRunning() : sgObject::ISensor
  • IsSimple() : sgObject::IGeometry
  • IsSystemField() : sgObject::ILayer
  • IsUsableSearch() : sgObject::INetworkCoverageAnalysis
  • IsValid() : sgObject::IFeatureAttributeValidValue
  • IsValidFilter() : sgObject::IFeatureTypeStyleRule
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버 - 함수

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- k -

  • KeyDown()
: sgObject::IApplication
, sgObject::ICanvas
  • KeyUp() : sgObject::ICanvas
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버 - 함수

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- l -

  • LayerActivated() : sgObject::_IFeatureCanvasEvents
  • LayerAdded() : sgObject::_IFeatureCanvasEvents
  • LayerAnnotationChanged() : sgObject::_IFeatureCanvasEvents
  • LayerAttributeChange() : sgObject::_IFeatureCanvasEvents
  • LayerAttributeChanged() : sgObject::_IFeatureCanvasEvents
  • LayerDelete() : sgObject::_IFeatureCanvasEvents
  • LayerDeleted() : sgObject::_IFeatureCanvasEvents
  • LayerDisplayNameChanged() : sgObject::_IFeatureCanvasEvents
  • LayerEditableChanged() : sgObject::_IFeatureCanvasEvents
  • LayerExported() : sgObject::_IFeatureCanvasEvents
  • LayerOrderChanged() : sgObject::_IFeatureCanvasEvents
  • LayerSelectableChanged() : sgObject::_IFeatureCanvasEvents
  • LayerStyleChanged() : sgObject::_IFeatureCanvasEvents
  • LayerTypeStyleChanged() : sgObject::_IFeatureCanvasEvents
  • LayerVisibleChanged() : sgObject::_IFeatureCanvasEvents
  • LButtonDown() : sgObject::ICanvas
  • LButtonUp() : sgObject::ICanvas
  • LineMerge() : sgObject::ISpatialOperator
  • LineToPolygon() : sgObject::IVectorAnalysis
  • LongClick()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버 - 함수

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- m -

  • MakeTiles() : sgObject::IGridGeneralizeOp
  • MapControlChanged() : sgObject::_IMap2DEvents
  • MapExtendChange()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • MapExtendChanged()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • MapMove()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • MapMoved()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • MapReSized()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • MapTiles() : sgObject::IGridGeneralizeOp
  • MButtonDown() : sgObject::ICanvas
  • MButtonUp() : sgObject::ICanvas
  • Merge()
: sgObject::IGridGeneralizeOp
, sgObject::IVectorAnalysis
  • MouseMove() : sgObject::ICanvas
  • Move() : sgObject::IPrintLayoutItem
  • MoveAngle()
: sgObject::ISpatialOperator
, sgObject::IVectorAnalysis
  • MoveDistance()
: sgObject::ISpatialOperator
, sgObject::IVectorAnalysis
  • MoveFirst()
: sgObject::IFeatureCollection
, sgObject::IFeatureStyleCollection
, sgObject::IXMLElements
  • MoveLast() : sgObject::IFeatureCollection
  • MoveNext()
: sgObject::IFeatureCollection
, sgObject::IFeatureStyleCollection
, sgObject::IXMLElements
  • MovePrevious()
: sgObject::IFeatureCollection
, sgObject::IFeatureStyleCollection
  • MoveTo() : sgObject::IFeatureCanvas
  • MultipartToSinglepart() : sgObject::IVectorAnalysis
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버 - 함수

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- n -

  • NearBlack() : sgObject::IGridGeneralizeOp
  • NearestName() : sgObject::ILocationService
  • NearestPoint()
: sgObject::ILocationService
, sgObject::ISpatialOperator
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버 - 함수

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- o -

  • Open() : sgObject::IXMLDoc
  • OpenXML() : sgObject::IXMLDoc
  • Overlaps() : sgObject::ISpatialRelation
  • Overview() : sgObject::IGridGeneralizeOp
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버 - 함수

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- p -

  • Paint() : sgObject::_IMap2DEvents
  • Paste() : sgObject::IFeatureCanvas
  • PointOnSurface()
: sgObject::IMultiSurface
, sgObject::ISurface
  • PolygonGeneralize() : sgObject::IVectorAnalysis
  • Polygonize() : sgObject::IGridGeneralizeOp
  • PolygonToLine() : sgObject::IVectorAnalysis
  • PreCommit() : sgObject::_IFeatureCanvasEvents
  • PreUndo() : sgObject::_IFeatureCanvasEvents
  • Printed()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • Project()
: sgObject::IGeometry
, sgObject::IVectorAnalysis
  • ProjectFromCRS() : sgObject::IUtility
  • ProjectFromText() : sgObject::IUtility
  • ProjectMGRS() : sgObject::IUtility
  • ProjectToMGRS() : sgObject::IUtility
  • ProjectWorldMapPoint() : sgObject::IUtility
  • ProviderDisabled() : sgObject::_ILocationSensorEvents
  • ProviderEnabled() : sgObject::_ILocationSensorEvents
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버 - 함수

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- r -

  • Rasterize() : sgObject::IGridGeneralizeOp
  • RasterPixelToWorld() : sgObject::IMap2D
  • RButtonDown() : sgObject::ICanvas
  • RButtonUp() : sgObject::ICanvas
  • ReadWorkspace() : sgObject::IFeatureCanvas
  • ReadXML() : sgObject::IPrintLayoutWidget
  • ReCalculateExtent()
: sgObject::IFeature
, sgObject::IFeatureCanvas
, sgObject::IFeatureCollection
  • Refresh() : sgObject::IFeatureLayer
  • Relate() : sgObject::ISpatialRelation2
  • Remove()
: sgObject::IAnnotation
, sgObject::IAttributeIndex
, sgObject::IFeatureCollection
, sgObject::IFeatureStyleCollection
, sgObject::IFeatureType
, sgObject::IGraphicCanvas
, sgObject::IQueryCommands
  • RemoveAll()
: sgObject::IAnnotation
, sgObject::IFeatureCollection
, sgObject::IFeatureTypeStyle
, sgObject::IQueryCommands
  • RemoveAllControl() : sgObject::ICanvas
  • RemoveAttribute() : sgObject::IFeatureLayer
  • RemoveChild() : sgObject::IAggregateGraphic
  • RemoveChildren() : sgObject::IAggregateGraphic
  • RemoveColorRamp() : sgObject::IColorRampList
  • RemoveControl() : sgObject::ICanvas
  • RemoveEffectFilter() : sgObject::IGridTypeStyle
  • RemoveElement() : sgObject::IXMLElements
  • RemoveExteriorPoint() : sgObject::IGraphicPolygon
  • RemoveFromIndex() : sgObject::IAttributeIndex
  • RemoveFromKey() : sgObject::IGraphicCanvas
  • RemoveHoles() : sgObject::IVectorAnalysis
  • RemoveInteriorPoint() : sgObject::IGraphicPolygon
  • RemoveInteriorRing() : sgObject::IGraphicPolygon
  • RemovePoint() : sgObject::ILineString
  • RemoveRule() : sgObject::IFeatureTypeStyle
  • RemoveSensor() : sgObject::ICanvas
  • RemoveStyle() : sgObject::ISymbolizer
  • RemoveSymbol() : sgObject::IFeatureCanvas
  • RemoveUser() : sgObject::IGPDLayerSource
  • RenameLayer() : sgObject::ILayerSource
  • RepairGeometry() : sgObject::IVectorAnalysis
  • ReplaceChild() : sgObject::IAggregateGraphic
  • Resample() : sgObject::IGridGeneralizeOp
  • ReSize()
: sgObject::ICanvas
, sgObject::IWidget
  • RetainAll() : sgObject::IFeatureCollection
  • RevGeoCode() : sgObject::ILocationService
  • RightClick()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • Rollback() : sgObject::IDefaultTransaction
  • Rotate()
: sgObject::ISpatialOperator
, sgObject::IVectorAnalysis
  • RouteDetermine() : sgObject::ILocationService
  • RunScript() : sgObject::IApplication
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버 - 함수

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- s -

  • Satellite() : sgObject::_ILocationSensorEvents
  • Save() : sgObject::IXMLDoc
  • Scale()
: sgObject::ISpatialOperator
, sgObject::IVectorAnalysis
  • ScreenModeChanged()
: sgObject::_IMap2DEvents
, sgObject::_IMap3DEvents
, sgObject::_IMapEarthEvents
  • Search() : sgObject::INetworkCoverageAnalysis
  • SelectCompile() : sgObject::IFeatureQuery
  • SelectModeChanged() : sgObject::_IMap2DEvents
  • SendActionEvent() : sgObject::IApplication
  • SensingValueChanged() : sgObject::_ILocationSensorEvents
  • SensorAdded()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • SensorRemoved()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • SetAbstract() : sgObject::ILayer
  • SetActive() : sgObject::IFeatureCanvas
  • SetAdjustmentHor() : sgObject::IFont
  • SetAdjustmentVert() : sgObject::IFont
  • SetAllowedAreas() : sgObject::IDockWidget
  • SetAllowingExtentsChang()
: sgObject::IGraphicArc
, sgObject::IGraphicRectangle
  • SetAllowingNewVertices() : sgObject::IGraphicPolygon
  • SetAllowingRotation() : sgObject::IGraphicRectangle
  • SetAnchor() : sgObject::IFont
  • SetAngle()
: sgObject::IFill
, sgObject::IFont
, sgObject::IMark
  • SetAnnoLineAttribute() : sgObject::ILayer
  • SetAnnoLineVisibleAttribute() : sgObject::ILayer
  • SetAnnotation() : sgObject::IFeature
  • SetAnnotationLine() : sgObject::IFeature
  • SetAnnoVisibleAttribute() : sgObject::ILayer
  • SetAnnoXMLAttribute() : sgObject::ILayer
  • SetAntiAlias() : sgObject::IMap2D
  • SetAttribute()
: sgObject::IFeature
, sgObject::IFeatureLayer
, sgObject::IFeatureType
  • SetAttributeFilter() : sgObject::ILayer
  • SetAuthority() : sgObject::ISpatialReference
  • SetAutoScale() : sgObject::IMap2D
  • SetBackColor()
: sgObject::ICanvas
, sgObject::IFill
, sgObject::IFont
, sgObject::IWidget
  • SetBackgroundColor() : sgObject::IChart
  • SetBold() : sgObject::IFont
  • SetBool() : sgObject::IParameter
  • SetBoxPaddingX() : sgObject::IFont
  • SetBoxPaddingY() : sgObject::IFont
  • SetCanMoveIndexMap() : sgObject::IIndexMapWidget
  • SetCanvas()
: sgObject::IDockWidget
, sgObject::IWidget
  • SetCap() : sgObject::IStroke
  • SetCategory() : sgObject::ILayer
  • SetCategoryNames() : sgObject::IGridSampleDimension
  • SetCenter()
: sgObject::IGraphicArc
, sgObject::IGraphicRectangle
  • SetChartType() : sgObject::IChart
  • SetColor()
: sgObject::IColorModel
, sgObject::IGridColorRampItem
, sgObject::IMark
, sgObject::IStroke
  • SetColorInterpretation() : sgObject::IGridSampleDimension
  • SetColorTable() : sgObject::IGridSampleDimension
  • SetCommandText() : sgObject::IQueryCommand
  • SetConfigOption() : sgObject::IUtility
  • SetConfigured() : sgObject::IUtility
  • SetCRS() : sgObject::IGraphicScaledImage
  • SetData()
: sgObject::IFeature
, sgObject::IQueryCommand
  • SetDataSeries() : sgObject::IChart
  • SetDataSeriesFromString() : sgObject::IChart
  • SetDataType() : sgObject::IFeatureAttributeDescriptor
  • SetDebug() : sgObject::IUtility
  • SetDefaultValueHeight() : sgObject::IGenerator3D
  • SetDefaultValueRadius() : sgObject::IGenerator3D
  • SetDefaultValueType() : sgObject::IGenerator3D
  • SetDefaultValueZ() : sgObject::IGenerator3D
  • SetDefaultViewpoint() : sgObject::IMap3DCamera
  • SetDescription()
: sgObject::IGridCoverage
, sgObject::ILayerSource
, sgObject::ILayerSourceFactory
  • SetDiagram() : sgObject::ILayer
  • SetDisplayContextMenu()
: sgObject::IFeatureAttributeTreeWidget
, sgObject::ILayerTreeWidget
  • SetDisplayEditActionByType() : sgObject::IApplication
  • SetDisplayMenuBar()
: sgObject::IApplication
, sgObject::IPrintLayoutWidget
  • SetDisplayName()
: sgObject::ILayerSource
, sgObject::ILayerSourceFactory
  • SetDisplayProperyWidget() : sgObject::IPrintLayoutWidget
  • SetDisplaySpatialReference() : sgObject::IFeatureCanvas
  • SetDisplayStatusBar() : sgObject::IApplication
  • SetDisplayToolBar()
: sgObject::IApplication
, sgObject::IFeatureAttributeTreeWidget
, sgObject::ILayerTreeWidget
, sgObject::IPrintLayoutWidget
  • SetDisplayToolBarByType()
: sgObject::IApplication
, sgObject::IPrintLayoutWidget
  • SetDouble() : sgObject::IParameter
  • SetDrawProgressEnable() : sgObject::IMap2D
  • SetECap() : sgObject::IStroke
  • SetEditableAuth()
: sgObject::IFeatureAttributeDescriptor
, sgObject::ILayer
  • SetEffectFilter() : sgObject::IGridTypeStyle
  • SetElement() : sgObject::IXMLElements
  • SetElements() : sgObject::IXMLDoc
  • SetElseFilterFeatureStyle() : sgObject::IFeatureTypeStyle
  • SetElseFilterVisible() : sgObject::IFeatureTypeStyle
  • SetEmpty() : sgObject::IGeometry
  • SetEncoding() : sgObject::IUtility
  • SetEnd() : sgObject::IGraphicArc
  • SetExteriorHandle() : sgObject::IUserDefinedWidget
  • SetExteriorPoint() : sgObject::IGraphicPolygon
  • SetFeature()
: sgObject::IAnnotation
, sgObject::IFeatureCollection
  • SetFeatureCanvas()
: sgObject::ICanvas
, sgObject::IWidget
  • SetFeatureCollection()
: sgObject::IAttributeIndex
, sgObject::IFeatureLayer
  • SetFeatureColors() : sgObject::IChart
  • SetFeatureFields() : sgObject::IChart
  • SetFeatureLables() : sgObject::IChart
  • SetFeatureLayer() : sgObject::IWidget
  • SetFeatures() : sgObject::IDockWidget
  • SetFeatureStyleColor() : sgObject::IFeatureTypeStyleRule
  • SetFeatureType() : sgObject::ILayer
  • SetFeatureTypeStyle() : sgObject::ILayer
  • SetFileName() : sgObject::IXMLDoc
  • SetFill() : sgObject::ISymbolizer
  • SetFillBrush() : sgObject::IMap2D
  • SetFilter() : sgObject::IFeatureTypeStyleRule
  • SetFlag() : sgObject::IWidget
  • SetFlickerSelected() : sgObject::IMap2D
  • SetFloat() : sgObject::IParameter
  • SetFont() : sgObject::ISymbolizer
  • SetFontName()
: sgObject::IFont
, sgObject::IMark
  • SetForeColor()
: sgObject::IFill
, sgObject::IFont
  • SetFromUserInput() : sgObject::ISpatialReference
  • SetGeometry()
: sgObject::IFeature
, sgObject::IPointSymbol
  • SetGeometryType() : sgObject::IFeatureType
  • SetGridColorType() : sgObject::IGridTypeStyle
  • SetHeight()
: sgObject::IGraphicArc
, sgObject::IGraphicRectangle
, sgObject::IWidget
  • SetHeightAttribute() : sgObject::IGenerator3D
  • SetHittestSize() : sgObject::ICanvas
  • SetIcon()
: sgObject::ILayerSource
, sgObject::ILayerSourceFactory
  • SetIconFromString() : sgObject::IGraphicIcon
  • SetID()
: sgObject::IFeature
, sgObject::IFill
, sgObject::IMark
, sgObject::IQueryCommand
, sgObject::IStroke
  • SetImage() : sgObject::IImageSymbol
  • SetImageFile() : sgObject::IPrintLayoutItem
  • SetIndexMapAutoMove() : sgObject::IIndexMapWidget
  • SetInt() : sgObject::IParameter
  • SetIntensity() : sgObject::IGraphicScaledImage
  • SetInteriorPoint() : sgObject::IGraphicPolygon
  • SetIsSeqKey() : sgObject::IFeatureAttributeDescriptor
  • SetItalic() : sgObject::IFont
  • SetJoin() : sgObject::IStroke
  • SetKeyEnable()
: sgObject::IMap2D
, sgObject::IPrintLayoutWidget
  • SetLabelExpression() : sgObject::ILayer
  • SetLabelMaxScaleDenominator() : sgObject::ILayer
  • SetLabelMinScaleDenominator() : sgObject::ILayer
  • SetLabelPosition() : sgObject::ILayer
  • SetLayer()
: sgObject::IAnnotationLabel
, sgObject::IWidget
  • SetLayerOrder() : sgObject::ILayer
  • SetLineColor() : sgObject::IChart
  • SetLinePattern() : sgObject::IMark
  • SetLocationSensor() : sgObject::ICanvas
  • SetLocationSensorType() : sgObject::ILocationSensor
  • SetLong() : sgObject::IParameter
  • SetLowerRight() : sgObject::IGraphicScaledImage
  • SetMagnifierPixelSize() : sgObject::IMap2D
  • SetMagnifierScale() : sgObject::IMap2D
  • SetMapCenter() : sgObject::IPrintLayoutItem
  • SetMapControl() : sgObject::ICanvas
  • SetMapControlImageFromFileName() : sgObject::IMap2D
  • SetMapControlRelativePos() : sgObject::IMap2D
  • SetMapControlShowType() : sgObject::IMap2D
  • SetMapIdxColumn() : sgObject::ILayer
  • SetMapIdxLevel() : sgObject::ILayer
  • SetMapIndexPrintOption() : sgObject::IPrintLayoutItem
  • SetMapMoveMode() : sgObject::ICanvas
  • SetMapRect() : sgObject::IPrintLayoutItem
  • SetMapRelativeScale() : sgObject::IPrintLayoutItem
  • SetMapRotateMode() : sgObject::ICanvas
  • SetMapRotation() : sgObject::IPrintLayoutItem
  • SetMapScale() : sgObject::IPrintLayoutItem
  • SetMark() : sgObject::ISymbolizer
  • SetMaximumOccurrences() : sgObject::IFeatureAttributeDescriptor
  • SetMaximumValue() : sgObject::IGridTypeStyle
  • SetMaxScaleDenominator()
: sgObject::IFeatureTypeStyleRule
, sgObject::ILayer
, sgObject::ISymbolizer
  • SetMaxZoomScaleDenominator() : sgObject::IMap2D
  • SetMeasureLineShowType() : sgObject::IMap2D
  • SetMeasureLineStd() : sgObject::IMap2D
  • SetMeasureLineStdLength() : sgObject::IMap2D
  • SetMeasureLineSubUnitNum() : sgObject::IMap2D
  • SetMessageFile() : sgObject::IMessage
  • SetMetadataItemValue() : sgObject::IGridCoverage
  • SetMetadataValue() : sgObject::IGridCoverage
  • SetMinimumOccurrences() : sgObject::IFeatureAttributeDescriptor
  • SetMinimumValue() : sgObject::IGridTypeStyle
  • SetMinMaxPitch() : sgObject::IMap3DCamera
  • SetMinScaleDenominator()
: sgObject::IFeatureTypeStyleRule
, sgObject::ILayer
, sgObject::ISymbolizer
  • SetMinZoomScaleDenominator() : sgObject::IMap2D
  • SetMotionSensor() : sgObject::ICanvas
  • SetMouseButtonEnable()
: sgObject::IMap2D
, sgObject::IPrintLayoutWidget
  • SetMouseCursor() : sgObject::IMap2D
  • SetName()
: sgObject::IFeatureAttributeDescriptor
, sgObject::IFeatureType
, sgObject::ILayer
, sgObject::IParameter
, sgObject::IQueryCommand
, sgObject::ISymbolizer
  • SetNodataValue() : sgObject::IGridSampleDimension
  • SetNodeLayerEndIDColumn() : sgObject::ILayer
  • SetNodeLayerName() : sgObject::ILayer
  • SetNodeLayerStartIDColumn() : sgObject::ILayer
  • SetNullable() : sgObject::IFeatureAttributeDescriptor
  • SetObjectiveSpatialReference() : sgObject::ICanvas
  • SetOceanEnable() : sgObject::IMapEarth
  • SetOColor() : sgObject::IMark
  • SetOffset()
: sgObject::IGraphicIcon
, sgObject::IGridSampleDimension
, sgObject::IMark
  • SetOrder() : sgObject::IAnnotationLabel
  • SetOutlineColor()
: sgObject::IFont
, sgObject::IStroke
  • SetOutlineWidth()
: sgObject::IFont
, sgObject::IStroke
  • SetOverlapLabel() : sgObject::IMap2D
  • SetPageSize() : sgObject::ILayer
  • SetParameter() : sgObject::IChart
  • SetParameters() : sgObject::IVectorAnalysis
  • SetParent() : sgObject::IParameter
  • SetPathType() : sgObject::IGraphicPolygon
  • SetPattern() : sgObject::IStroke
  • SetPerp()
: sgObject::IFont
, sgObject::IMark
  • SetPlacement() : sgObject::IFont
  • SetPoint() : sgObject::IGraphicLineString
  • SetPointOnSurface() : sgObject::IMap2D
  • SetPosition()
: sgObject::IGraphicIcon
, sgObject::IGraphicLabel
, sgObject::IPrintLayoutItem
, sgObject::IUserDefinedWidget
  • SetPrecision() : sgObject::IFeatureAttributeDescriptor
  • SetPreferredPrefix() : sgObject::IFeatureType
  • SetPriority()
: sgObject::IFill
, sgObject::IFont
, sgObject::IMark
, sgObject::IStroke
  • SetQtUiObjectVisible() : sgObject::IWidget
  • SetRadiusAttribute() : sgObject::IGenerator3D
  • SetRatioZoomScale() : sgObject::IMap2D
  • SetRefer() : sgObject::IFeatureCollection
  • SetReferField() : sgObject::IFeatureAttributeDescriptor
  • SetReferFieldName() : sgObject::IFeatureAttributeDescriptor
  • SetReferLayer() : sgObject::IFeatureAttributeDescriptor
  • SetReferLayerName() : sgObject::IFeatureAttributeDescriptor
  • SetRefreshTime() : sgObject::IFeatureLayer
  • SetRelatedFeature() : sgObject::IQueryCommand
  • SetRelateX() : sgObject::IUserDefinedWidget
  • SetRelateY() : sgObject::IUserDefinedWidget
  • SetRotate() : sgObject::IMap2D
  • SetRoundX() : sgObject::IGraphicRectangle
  • SetRoundY() : sgObject::IGraphicRectangle
  • SetScale()
: sgObject::IGridSampleDimension
, sgObject::IMap2D
  • SetScaleBarRelativePos() : sgObject::IMap2D
  • SetScaleBarShowType() : sgObject::IMap2D
  • SetScaleBarSymbolizer() : sgObject::IMap2D
  • SetScaleBarSymbolizerFromString() : sgObject::IMap2D
  • SetScaledImageFromString() : sgObject::IGraphicScaledImage
  • SetScalePrecision() : sgObject::IMap2D
  • SetScaleRatio() : sgObject::IIndexMapWidget
  • SetSCap() : sgObject::IStroke
  • SetScreenMode()
: sgObject::IMap2D
, sgObject::IMapEarth
  • SetSelectable() : sgObject::ILayer
  • SetSelected() : sgObject::IFeature
  • SetSelectedFeature() : sgObject::IFeatureCanvas
  • SetSelectedSymbolizer() : sgObject::IMap2D
  • SetSelectedSymbolizerFromString() : sgObject::IMap2D
  • SetSelectedVertexSymbolizer() : sgObject::IMap2D
  • SetSelectedVertexSymbolizerFromString() : sgObject::IMap2D
  • SetSelectMode() : sgObject::IMap2D
  • SetShadePaletteInterpretation() : sgObject::IGridTypeStyle
  • SetShadowColor() : sgObject::IFont
  • SetShadowEnable() : sgObject::IMapEarth
  • SetShadowSpacingX() : sgObject::IFont
  • SetShadowSpacingY() : sgObject::IFont
  • SetShadowWidth() : sgObject::IFont
  • SetShort() : sgObject::IParameter
  • SetShortLabelExpression() : sgObject::ILayer
  • SetSightMode() : sgObject::IMapEarth
  • SetSize()
: sgObject::IFeatureAttributeDescriptor
, sgObject::IFill
, sgObject::IFont
, sgObject::IMark
  • SetSkyDateTime() : sgObject::IMapEarth
  • SetSmallPixelSize() : sgObject::IMap2D
  • SetSnapGrid() : sgObject::IMap2D
  • SetSnapMode() : sgObject::IMap2D
  • SetSourceCS() : sgObject::IGeographicTransform
  • SetSpacingX()
: sgObject::IFill
, sgObject::IFont
, sgObject::IMark
  • SetSpacingY()
: sgObject::IFill
, sgObject::IFont
, sgObject::IMark
  • SetSpatialReference()
: sgObject::IGeometry
, sgObject::ILayer
, sgObject::ILocationService
  • SetStandardDeviation() : sgObject::IGridTypeStyle
  • SetStart() : sgObject::IGraphicArc
  • SetState() : sgObject::ICanvas
  • SetStatistics() : sgObject::IGridSampleDimension
  • SetStep() : sgObject::IMark
  • SetStretch() : sgObject::IFont
  • SetStrikeout() : sgObject::IFont
  • SetString() : sgObject::IParameter
  • SetStroke() : sgObject::ISymbolizer
  • SetStyleAttribute() : sgObject::ILayer
  • SetStyleType() : sgObject::IFeatureTypeStyle
  • SetSymbolizer()
: sgObject::IFeature
, sgObject::IFeatureTypeStyleRule
, sgObject::ILayer
  • SetSymbolizerType() : sgObject::ISymbolizer
  • SetSyncMoveMode() : sgObject::IMap2D
  • SetSystemSymbolizerFromString() : sgObject::IMap2D
  • SetTabPosition() : sgObject::ITabWidget
  • SetTabRoundedShape() : sgObject::ITabWidget
  • SetTargetCS() : sgObject::IGeographicTransform
  • SetTerrainOptions() : sgObject::IFeatureCanvas
  • SetText()
: sgObject::IAnnotationLabel
, sgObject::IGraphicLabel
, sgObject::IPrintLayoutItem
  • SetTextAngle()
: sgObject::IFont
, sgObject::IMark
  • SetTextSize() : sgObject::IGraphicLabel
  • SetTextString() : sgObject::IFont
  • SetTitle()
: sgObject::ICanvas
, sgObject::IFeatureAttributeDescriptor
, sgObject::IFeatureTypeStyleRule
, sgObject::ILayer
  • SetToolTipExpression() : sgObject::ILayer
  • SetTransaction() : sgObject::IFeatureCollection
  • SetTransparency() : sgObject::IGraphicScaledImage
  • SetTransparent()
: sgObject::IChart
, sgObject::IImageSymbol
  • SetTransparentBackColor() : sgObject::IMap2D
  • SetType() : sgObject::IParameter
  • SetTypeAttribute() : sgObject::IGenerator3D
  • SetUnderline() : sgObject::IFont
  • SetUnits() : sgObject::IGridSampleDimension
  • SetUnknownSensor() : sgObject::ILocationSensor
  • SetUpperLeft() : sgObject::IGraphicScaledImage
  • SetUseDrawThread() : sgObject::IMap2D
  • SetUser() : sgObject::IGPDLayerSource
  • SetUserDefinedWidget() : sgObject::IFeature
  • SetValue()
: sgObject::IGridColorRampItem
, sgObject::IGridSampleDimension
, sgObject::IParameter
, sgObject::IXMLElements
  • SetValueInBoundary() : sgObject::IGridCoverage
  • SetVideoSensor() : sgObject::ICanvas
  • SetViewpoint() : sgObject::IMap3DCamera
  • SetViewshedColor() : sgObject::IMapEarth
  • SetViewshedParam() : sgObject::IMapEarth
  • SetVisible()
: sgObject::IFeature
, sgObject::IFeatureTypeStyleRule
, sgObject::ILayer
  • SetVisibleAnnotation() : sgObject::IFeature
  • SetVisibleAnnotationLine() : sgObject::IFeature
  • SetVisibleAuth()
: sgObject::IFeatureAttributeDescriptor
, sgObject::ILayer
  • SetVisibleMagnifier() : sgObject::IMap2D
  • SetVisibleSmallGeometry() : sgObject::IMap2D
  • SetVisibleUserDefinedWidget() : sgObject::IFeature
  • SetWidget() : sgObject::IDockWidget
  • SetWidth()
: sgObject::IGraphicArc
, sgObject::IGraphicRectangle
, sgObject::IStroke
, sgObject::IWidget
  • SetX()
: sgObject::ILineString
, sgObject::IPoint
  • SetXAnchor() : sgObject::IGraphicLabel
  • SetY()
: sgObject::ILineString
, sgObject::IPoint
  • SetYAnchor() : sgObject::IGraphicLabel
  • SetZ() : sgObject::IPointZ
  • SetZAttribute() : sgObject::IGenerator3D
  • ShadeColorInterpretationAdd() : sgObject::IGridTypeStyle
  • ShadeColorInterpretationRemoveAll() : sgObject::IGridTypeStyle
  • ShowCRSWidget() : sgObject::IFeatureLayer
  • ShowExportLayerWidget() : sgObject::IFeatureLayer
  • ShowFeatureTableWidget() : sgObject::IFeatureLayer
  • ShowFeatureTypeEditWidget() : sgObject::IFeatureLayer
  • ShowFieldCalculatorWidget() : sgObject::IFeatureLayer
  • ShowLabelWidget() : sgObject::IFeatureLayer
  • ShowLayerPropertyWidget() : sgObject::IFeatureLayer
  • ShowNewVectorLayerWidget() : sgObject::IFeatureCanvas
  • ShowOpenRasterLayerWidget() : sgObject::IFeatureCanvas
  • ShowOpenVectorLayerWidget() : sgObject::IFeatureCanvas
  • ShowOpenWebLayerWidget() : sgObject::IFeatureCanvas
  • ShowPrintLayoutWidget()
: sgObject::IApplication
, sgObject::IMap2D
  • ShowSRSWidget() : sgObject::ISpatialReference
  • ShowStyleWidget() : sgObject::IFeatureLayer
  • ShowTypeStyleWidget() : sgObject::IFeatureLayer
  • ShowUpdater() : sgObject::IUtility
  • Sieve() : sgObject::IGridGeneralizeOp
  • Simplify() : sgObject::ISpatialOperator
  • SingleSidedBuffer() : sgObject::ISpatialOperator
  • Snap() : sgObject::_IMap2DEvents
  • Snaped() : sgObject::_IMap2DEvents
  • SnapModeChanged() : sgObject::_IMap2DEvents
  • SnapOut() : sgObject::_IMap2DEvents
  • Sort() : sgObject::IAnnotation
  • Speed() : sgObject::_ILocationSensorEvents
  • Split() : sgObject::IVectorAnalysis
  • Start() : sgObject::ISensor
  • StartPoint() : sgObject::ICurve
  • Stop() : sgObject::ISensor
  • StringToUnicode() : sgObject::IUtility
  • StringToUTF8() : sgObject::IUtility
  • SubCollection()
: sgObject::IAttributeIndex
, sgObject::IFeatureCollection
  • SubLineString() : sgObject::ILineString
  • SymmetricDifference() : sgObject::ISpatialOperator
  • SymmetricDifferenceGeometry() : sgObject::IVectorAnalysis
  • SyncMoveModeChanged() : sgObject::_IMap2DEvents
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버 - 함수

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- t -

  • TabifyDockWidget() : sgObject::IApplication
  • ThiessenPolygon() : sgObject::IVectorAnalysis
  • TileIndex() : sgObject::IGridGeneralizeOp
  • Time() : sgObject::_ILocationSensorEvents
  • TopologyPreserveSimplify() : sgObject::ISpatialOperator
  • TouchDown()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • Touches() : sgObject::ISpatialRelation
  • TouchMove()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
  • TouchUp()
: sgObject::_IMap2DEvents
, sgObject::_IMapEarthEvents
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버 - 함수

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- u -

  • Undid() : sgObject::_IFeatureCanvasEvents
  • Undo() : sgObject::IFeatureCanvas
  • Ungroup() : sgObject::IVectorAnalysis
  • Union() : sgObject::ISpatialOperator
  • UnionCascaded() : sgObject::ISpatialOperator
  • UnionGeometry() : sgObject::IVectorAnalysis
  • UnionLineMerge() : sgObject::IVectorAnalysis
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버 - 함수

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- v -

  • Value() : sgObject::ICurve
  • Vectorize() : sgObject::IGridGeneralizeOp
  • VisibleMapControl() : sgObject::ICanvas
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버 - 함수

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- w -

  • Warp() : sgObject::IGridPreprocessOp
  • Within() : sgObject::ISpatialRelation
  • WithinDistance() : sgObject::ILocationService
  • WithinFeature() : sgObject::ILocationService
  • WorkspaceChanged() : sgObject::_IFeatureCanvasEvents
  • WorldMapBoundingBox() : sgObject::IUtility
  • WorldToDevice() : sgObject::IMap2D
  • WorldToRasterPixel() : sgObject::IMap2D
  • WriteWorkspace() : sgObject::IFeatureCanvas
  • WriteXML() : sgObject::IPrintLayoutWidget
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 멤버 - 함수

  • 모두
  • 함수
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- z -

  • ZoomAll()
: sgObject::IMap2D
, sgObject::IMap3DCamera
  • ZoomCenter() : sgObject::IMap2D
  • ZoomFeature() : sgObject::IMap2D
  • ZoomGPS() : sgObject::IMap2D
  • ZoomIn()
: sgObject::IMap2D
, sgObject::IMap3DCamera
  • ZoomNext() : sgObject::IMap2D
  • ZoomOut()
: sgObject::IMap2D
, sgObject::IMap3DCamera
  • ZoomPrevious() : sgObject::IMap2D
  • ZoomRect() : sgObject::IMap2D
  • ZoomToFeatureCollection()
: sgObject::IMap2D
, sgObject::IMapEarth
  • ZoomToSelectedFeatures() : sgObject::IMap2D
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: include 디렉토리 참조

  • libs
  • include
include 디렉토리 참조
include에 대한 디렉토리 의존성 그래프:

파일들

파일 sg_object.idl
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: libs 디렉토리 참조

  • libs
libs 디렉토리 참조
libs에 대한 디렉토리 의존성 그래프:

디렉토리들

디렉토리 include
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 그래프 범례

그래프 범례

이 페이지는 doxygen에 의해 생성된 그래프들을 이해하는 방법을 설명합니다.

다음의 예제를 참고하십시오.:

1 /*! 생략되었기 때문에 보이지 않는 클래스 */
2 class Invisible { };
3
4 /*! Truncated 클래스, 상속관계가 숨겨짐 */
5 class Truncated : public Invisible { };
6
7 /* doxygen 주석에 의해서 문서화되지 않는 클래스 */
8 class Undocumented { };
9
10 /*! public 상속을 통해서 상속된 클래스 */
11 class PublicBase : public Truncated { };
12
13 /*! 템플릿 클래스 */
14 template<class T> class Templ { };
15
16 /*! protected 상속을 통해서 상속된 클래스 */
17 class ProtectedBase { };
18
19 /*! private 상속을 통해서 상속된 클래스 */
20 class PrivateBase { };
21
22 /*! 상속되어진 클래스에 의해 (멤버로) 사용되어지는 클래스 */
23 class Used { };
24
25 /*! 다른 클래스들을 상속하는 슈퍼 클래스 */
26 class Inherited : public PublicBase,
27 protected ProtectedBase,
28 private PrivateBase,
29 public Undocumented,
30 public Templ<int>
31 {
32 private:
33 Used *m_usedClass;
34 };

다음과 같은 그래프가 출력될 것입니다. :

위 그래프의 박스들은 다음과 같은 의미를 가집니다. :

  • A 회색으로 채워진 박스는 이 그래프를 생성해 낸 구조체나 클래스를 의미합니다.
  • A 검은색 테두리의 박스는 문서화된 구조체나 클래스를 의미합니다.
  • A 회색 테두리의 박스는 문서화되지 않은 구조체나 클래스를 의미합니다.
  • A 빨간색 테두리의 박스는 모든 상속이나 포함관계가 보여지지 않는 구조체나 클래스를 의미합니다.A 만약 그래프가 지정된 경계내에 맞지 않으면, 그래프가 잘려집니다.

화살표들은 다음과 같은 의미를 가집니다. :

  • A 어두운 파랑색 화살표는 두 클래스들 간에 public 상속이 있음을 의미합니다.
  • A 어두운 연두색 화살표는 protected 상속이 있음을 의미합니다.
  • A 어두운 빨간색 화살표는 private 상속이 있음을 의미합니다.
  • A 보라색 점선 화살표는 다른 클래스에 의해 포함되거나 사용되어짐을 의미합니다. 화살표의 라벨은 화살표가 가리키는 클래스나 구조체로 접근하는 변수명(들)으로 붙습니다.
  • A 노란색 점선 화살표는 템플릿 인스턴스와 템프릿 클래스에 대한 관계를 의미합니다. 화살표의 라벨은 인스턴스의 템플릿 파라메터로 붙습니다.
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 클래스 계통도

클래스 계통도

텍스트 형식의 클래스 계통도 페이지로 가기

생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10


sgMap Object: 멤버 목록

  • ISpatialRelation
sgObject::ISpatialRelation 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : sgObject::ISpatialRelation (모든 상속된 멤버들도 포함합니다.)

Contains([in] IGeometry *other) | sgObject::ISpatialRelation
Crosses([in] IGeometry *other) | sgObject::ISpatialRelation
Disjoint([in] IGeometry *other) | sgObject::ISpatialRelation
Equals([in] IGeometry *other) | sgObject::ISpatialRelation
Intersects([in] IGeometry *other) | sgObject::ISpatialRelation
Overlaps([in] IGeometry *other) | sgObject::ISpatialRelation
Touches([in] IGeometry *other) | sgObject::ISpatialRelation
Within([in] IGeometry *other) | sgObject::ISpatialRelation
생성시간 : 화 5월 26 2020 12:14:18, 프로젝트명 : sgMap Object, 생성자 : doxygen 1.8.10